Subject: [perpass] A bit more detail on QUANTUM advanced targeting...

From: Nicholas Weaver <[email-masked]>
Date: Thu, 12 Dec 2013 09:59:28 -0800

I've written up a more detailed take on how active cookie discovery could be used for exploitation targeting...

https://medium.com/p/bb8816e88d86

The real fun bit, however, is:

> Yet foreign intelligence agencies can do even better. Want to target every Senator, every DC staffer, and every lobbyist by name? Do you have their Gmail addresses, LinkedIn profile, and/or Warcraft player names? Have a couple of “diplomats” you can afford to get kicked out of the country on the very remote chance your caught? If so, this one is for you. So the DGSE (the French version of the NSA) should listen up.

Using packet injection on the WiFi at the local starbucks...

Enjoy this brave new world.  Fun times all, fun times.

--
Nicholas Weaver                  it is a tale, told by an idiot,
[email-masked]                full of sound and fury,
510-666-2903                                 .signifying nothing
PGP: http://www1.icsi.berkeley.edu/~nweaver/data/nweaver_pub.asc

---

From: Richard Barnes <[email-masked]>
Date: Thu, 12 Dec 2013 13:20:33 -0500

On Thu, Dec 12, 2013 at 12:59 PM, Nicholas Weaver <[email-masked]
> wrote:

> > Yet foreign intelligence agencies can do even better. Want to target
> every Senator, every DC staffer, and every lobbyist by name? Do you have
> their Gmail addresses, LinkedIn profile, and/or Warcraft player names? Have
> a couple of “diplomats” you can afford to get kicked out of the country on
> the very remote chance your caught? If so, this one is for you. So the DGSE
> (the French version of the NSA) should listen up.
>

I would note that attack at this level does not really qualify as
"pervasive".  And that there are sizeable technical differences between
doing injection on a WiFi link and doing injection in, say, an OC-192.  So
we should not regard passive and active attack as equivalent.

--Richard

> _______________________________________________
> perpass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perpass
>
>

---

From: Nicholas Weaver <[email-masked]>
Date: Thu, 12 Dec 2013 10:24:52 -0800

On Dec 12, 2013, at 10:20 AM, Richard Barnes <[email-masked]> wrote:
> I would note that attack at this level does not really qualify as "pervasive".  And that there are sizeable technical differences between doing injection on a WiFi link and doing injection in, say, an OC-192.  So we should not regard passive and active attack as equivalent.
> 
> --Richard

There is no difference between the two scenarios, just the cost of the hardware: a $35 Raspberry Pi vs a $5000 multicore box running Bro.  The technology, techniques, and attacker abilities are the same.

And dollars to doughnuts says France can use this within their boarders on OC-192 links.

---

From: Richard Barnes <[email-masked]>
Date: Thu, 12 Dec 2013 13:29:10 -0500

Maybe it's just me, but I consider a 100x cost increase significant.  And I
don't buy your assertion that you can do real-time, line-rate scanning and
filtering with a $5k box.  Otherwise routers wouldn't need ASICs.

On Thu, Dec 12, 2013 at 1:24 PM, Nicholas Weaver
<[email-masked]>wrote:

> There is no difference between the two scenarios, just the cost of the
> hardware: a $35 Raspberry Pi vs a $5000 multicore box running Bro.  The
> technology, techniques, and attacker abilities are the same.
>

---

From: Scott Brim <[email-masked]>
Date: Thu, 12 Dec 2013 13:32:58 -0500

Yes, so maybe it's the wrong time and place, but I for one hope the IETF
will give new emphasis to personal privacy as well.

Scott

---

From: Nicholas Weaver <[email-masked]>
Date: Thu, 12 Dec 2013 10:54:10 -0800

On Dec 12, 2013, at 10:29 AM, Richard Barnes <[email-masked]> wrote:

> Maybe it's just me, but I consider a 100x cost increase significant.  And I don't buy your assertion that you can do real-time, line-rate scanning and filtering with a $5k box.  Otherwise routers wouldn't need ASICs.  

$5K can easily handle 10 Gbps links on a single computer, with just a bit of hacking.  You don't even need to do TCP stream reassembly, and there are trivial parallelizations.

And if thats not fast enough, then add in a hardware load balancer in front to do tuple-distribution (those exist for the IDS application area, and are pretty simple, just a hash of the SRC/DST 2-tuple to rewrite the MAC address and toss at a switch), and use a $50K cluster.  

Its an insanely scalable problem, and there are off the shelf designs.  Not to mention you can handle packet loss a lot easier on an on-path device rather than in-path device, which is one of 

And packet injection on backbone links is reality, with at least two major users:

Packet injection on backbone links is USED by the NSA.  The NSA calls it QUANTUM.  

Packet injection on backbone links is USED by China.  We call it the "great firewall of China".  They've only been using it for censorship to-date that we know of, but it is downright trivia to turn it into an exploitation tool.

This is not rocket science, and it is not magic.  Rather, the limitation of packet injection is the ability to place suitable hardware at suitable vantage points.

The NSA has the ability to place their hardware throughout the world.  Most other countries are limited to their national borders OR techniques they can install near the edge surreptitiously.  

And all it takes is a SINGLE request which identifies the potential victim as a VALID target passing a SINGLE adversarial wiretap for this type of attack to be launched.

And, finally, don't underestimate the power of software running on commodity hardware:  RouteBricks showed you can do 35 Gbps in software using Click on a single, 2 CPU, 4 cores/cpu server, back in 2009!

---

From: Sam Hartman <[email-masked]>
Date: Thu, 12 Dec 2013 16:07:55 -0500

>>>>> "Richard" == Richard Barnes <[email-masked]> writes:

    Richard>    I would note that attack at this level does not really
    Richard> qualify as "pervasive".  And that there are sizeable
    Richard> technical differences between doing injection on a WiFi
    Richard> link and doing injection in, say, an OC-192.  So we should
    Richard> not regard passive and active attack as equivalent.

I do buy the arguments about being able to handle 10 gbps on commodity
hardware.
However, let's assume I didn't buy that.

Why would I choose to inject on the oc-192?
To get a packet in, I just need to inject somewhere where it will not
get filtered out.
There are a lot of exploits I can run if I can see your traffic (my
permasive monitoring) and if I can insert packets, even if I cannot
suppress or modify packets.
Yeah, perhaps you'll get some images that fail to download correctly, or
some strange TCP resets observed at one end but not the other.

I suspect I'm not the only one on this list who fails to inventigate all
the events of that class that affect me.

So, I think understanding how permasive monitoring enables these other
attacks is very much in scope for the high-level picture and is
definitely something the March workshop should consider.
It's also the sort of analysis I'd expect people to look into when doing
security considerations sections after the passive threat BCP is
approved.

---

From: "Christian Huitema" <[email-masked]>
Date: Thu, 12 Dec 2013 13:57:20 -0800

> security considerations sections after the passive threat BCP is

The basic point is that it is fairly easy for agencies with wide monitoring
capabilities to observe third party cookies, and to associate them with user
identities. Once you have that, you can identify the IP address of the
target, and start prepping for the injection.

To mount an active attack, you only need to observe the SYN packet, and
immediately send a SYN-ACK, a DATA packet containing the HTTP Redirect, and
a FIN. You don't need to actually receive the ACK from the remote site. If
you beat the race against the actual web site, you win. And you can
certainly do that "from the side," you just need to find a router that will
let you inject packets without checking the origin address. 

After that, up to your imagination. Targets are unlikely to find out that
one of dozen or so trackers on the web page was redirected. Or thFor exat it
downloaded some exploit...

I don't think we will be able to eradicate clear text HTTP, but we can
certainly limit the damage and create momentum. For example, we could assume
that any clear text HTTP connection is untrusted, and ask browsers to treat
them as such. No cookies, no scripts, definitely no download. That would be
a nice way to push sites towards HTTPS. The various trackers will probably
be the first to move...

-- Christian Huitema