Subject: [perpass] Updated info for perpass lunch mtg

From: Avri Doria <[email-masked]>
Date: Mon, 17 Feb 2014 16:25:51 +0100

perpass lunch meeting agenda and reading list

1. Tentative Draft Agenda

* Assorted things required by an IETF mtg
   (If any for an informal meeting)

* - Discuss goals and scope
    * of meeting
    * of reviews
       *  Privacy including PM
       * Just PM

* A look at possible criteria for Privacy or PM reviews
*   with examples taken from the readings
*   with examples taken from the perpass list

   (some of this can be scoped out before the meeting)

* How to organize the draft review process for maximum benefit. Eg.
    *   Keeping records,
    *   establishing a way for a WG to request a Privacy or PM review,
    *   making the reviews timely,
    *   other issues?

* is there a need to do reviews of past RFCs.
    * What would that involve?

* where to go from here.
    * Volunteers for organization and reviews?
    * List, wiki etc?
    * Case studies? Volunteers?

2.  Reading and Research list

*   RFC 6973
*   draft-farrell-perpass-attack
*   draft-trammell-perpass-ppa
*   http://www.ietf.org/proceedings/88/perpass.html
*   others ...

3. Possible drafts for Interest

* http://tools.ietf.org/html/draft-hzhwm-start-tls-for-dns-00
* https://datatracker.ietf.org/doc/draft-farinacci-lisp-crypto/
* https://datatracker.ietf.org/doc/draft-seitz-ace-design-considerations/

4. Sample Reviews

* http://huitema.net/papers/draft-huitema-perpass-dhcp-identifiers-00.txt
* http://www.iab.org/activities/programs/privacy-program/privacy-reviews/
*

This is avaialbe as google drive document that is open for comment. I 
will process comments from either the list of drive.  dont' wnat to 
force anyone to use a tool they are not cmfortable with, but since I can 
export text to send to this list, I figure it is not all that bad.

https://docs.google.com/document/d/1dZnpifcto4M70MAeLkfWPWPHvujmkEl9ac_VrsrciTQ/edit?usp=sharing

---

From: "Christian Huitema" <[email-masked]>
Date: Mon, 17 Feb 2014 11:01:39 -0800

> * http://huitema.net/papers/draft-huitema-perpass-dhcp-identifiers-00.txt

Just a quick note about this draft. During previous perpass discussions, I
mentioned the need to go back to old standards and review them. Typical
reason for the review is that post-Snowden, our estimate of proper tradeoff
between ease of management and privacy changes. The review of DHCP here is
typical. 

Of course, I missed the submission window by a whole week, so I don't really
expect the draft to be reviewed during the next IETF. Besides, I cannot join
you in London. But regardless of the actual content, you may use it as an
example of what "reviewing old RFC" could mean.

-- Christian Huitema

---

From: Stephen Farrell <[email-masked]>
Date: Mon, 17 Feb 2014 19:35:30 +0000

FWIW, I think its a fine example, showing as it does that
not all changes are protocol changes and that some changes
to sensible defaults for implementations might depend on
how privacy-friendly one wants to be. Analyses like this
that make those kinds of thing explicit are very welcome.

And we don't need to worry about the draft cutoff here,
we're at the early stages of figuring this stuff out.

Cheers,
S.

On 02/17/2014 07:01 PM, Christian Huitema wrote:
> _______________________________________________
> perpass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perpass
> 
>

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 17 Feb 2014 11:58:15 -0800

This is the first some of us have heard of the lunch meeting. Can you say
what day it is being held?

--Paul Hoffman

---

From: Paul Hoffman <[email-masked]>
Date: Mon, 17 Feb 2014 12:03:51 -0800

Gaaah, never mind. I searched for "lunch".

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 17 Feb 2014 21:36:05 +0100

On Mon, Feb 17, 2014 at 04:25:51PM +0100,
 Avri Doria <[email-masked]> wrote 

> *   RFC 6973

Specially the section 8 which sets a good example to follow by other
privacy/PM reviews.

> 4. Sample Reviews

May be draft-bortzmeyer-dnsop-dns-privacy, a privacy review of the DNS protocol?

---

From: Pranesh Prakash <[email-masked]>
Date: Tue, 18 Feb 2014 23:07:52 -0500

> https://docs.google.com/document/d/1dZnpifcto4M70MAeLkfWPWPHvujmkEl9ac_VrsrciTQ/edit?usp=sharing

Avri, would https://pad.riseup.net/ be an acceptable alternative?  It
also has the ep_markdown plugin for etherpad-lite, which allows for some
basic markdown to be included.

See:

https://pad.riseup.net/p/perpass-meeting-notes

Etherpad-lite also allows for comments to be left via the "chat"
facility (on the frame on the right-hand side) that comes built-in.

-- Pranesh Prakash Policy Director, Centre for Internet and Society T:
+91 80 40926283 | W: http://cis-india.org ------------------- Access to
Knowledge Fellow, Information Society Project, Yale Law School M: +1 520
314 7147 | W: http://yaleisp.org PGP ID: 0x1D5C5F07 | Twitter:
https://twitter.com/pranesh_prakash