Subject: [perpass] Crypto Won’t Save You Either

From: Brian E Carpenter <[email-masked]>
Date: Sat, 17 May 2014 08:30:01 +1200

I've been waiting for Peter Gutmann's slides to appear on line
since I first saw them some months ago. Well worth studying:

http://regmedia.co.uk/2014/05/16/0955_peter_gutmann.pdf

Favourite quotes: "It's probably at least some sort of sign
of the end times when your conference badge has a rootkit."

"There were so many other ways to render DKIM ineffective
that no-one bothered attacking the crypto."

News story:
http://www.theregister.co.uk/2014/05/16/kiwi_prof_calls_bunk_on_nsaproof_tech_says_crypto_is_enough/

Regards
   Brian

---

From: Ted Lemon <[email-masked]>
Date: Fri, 16 May 2014 16:33:44 -0400

> http://www.theregister.co.uk/2014/05/16/kiwi_prof_calls_bunk_on_nsaproof_tech_says_crypto_is_enough/

I particularly like the fact that one of the examples he uses of weak implementations is that lovely ransomware that encrypts your hard drive and then demands payment: apparently it's quite easy to hack to de-encrypt your hard drive because it's so poorly done.   Poetic justice.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 16 May 2014 12:41:32 -0800

> that no-one bothered attacking the crypto."

I wish I could remember the source for this - I'm pretty
sure I heard it at the IETF (EKR?): strong crypto in too
many cases is like using an armored car to transport something
between two guys living in cardboard boxes.

Melinda

---

From: Eliot Lear <[email-masked]>
Date: Fri, 16 May 2014 22:52:28 +0200

Hi,

> that no-one bothered attacking the crypto."

Except for [1], of course.  I am also not one for these sorts of laundry
list presentations, as it comes across as the sky is falling, and leads
one to not take responsibility for one's own faults.  The public
statements from our leadership on this have been quite clear: we will
fix what we can fix... and perhaps exhort others to fix what they can fix.

Anyone who thinks this is a sprint is in the wrong race.  It's a STRINT ;-)

Eliot
[1] http://www.theregister.co.uk/2012/10/24/uscert_dkim_spoofing_flaw/

---

From: "Carl S. Gutekunst" <[email-masked]>
Date: Fri, 16 May 2014 13:52:43 -0700

> between two guys living in cardboard boxes.

Old one, usually attributed to Gene Spafford --

   Using encryption on the Internet is the equivalent of arranging
   an armored car to deliver credit-card information from someone
   living in a cardboard box to someone living on a park bench.

<csg>

---

From: Ted Lemon <[email-masked]>
Date: Fri, 16 May 2014 17:41:36 -0400

>  living in a cardboard box to someone living on a park bench.

The thing I really hate about these metaphors is that they lead one to the conclusion that it's pointless to use strong crypto, when really the conclusion one should draw is that one should try to avoid living in cardboard boxes, where possible.

---

From: Melinda Shore <[email-masked]>
Date: Fri, 16 May 2014 13:47:03 -0800

On 5/16/14 1:41 PM, Ted Lemon wrote:
> The thing I really hate about these metaphors is that they lead one
> to the conclusion that it's pointless to use strong crypto, when
> really the conclusion one should draw is that one should try to avoid
> living in cardboard boxes, where possible.

I don't see that, myself.  Seems to me to be arguing for a systems
view.

Melinda

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 16 May 2014 23:02:28 +0100

Yeah, the NSA-proof thing was overstated, at least as it was
taken-up by press. Doesn't mean we don't have work to do
though. We do, and its better to focus on that than on any
particular term, hyperbolic or not.

And things can be done by us, and others, e.g. I was happy
to see FB's figures [1] showing 58% of their outbound mail now
being encrypted via STARTTLS, which is afaik a significant
increase on what'd have been the case a couple of years ago.
There's also a significant increase in deployment of PFS
ciphersuites in such cases as well when compared to a year
or two ago so I'm told.

I for one do not believe that that makes no difference to
the spooks. Esp if we can get many more deployments doing
much more of that and similar. (Hint: if you're an active
participant in httpbis - go implement/argue-for/test that
opportunistic security alt-svcs thing and try to help do
for the web what FB have shown works for MTA-MTA SMTP:-)

Which brings it back to our bit of the work - to make it
easier for many more deployments to deploy reasonable security
(which is not all crypto) where there are protocol barriers
getting in their way. It doesn't matter so much how those
barriers got there, but its really clear what we need to
be doing about any such.

Cheers,
S.

[1] https://www.facebook.com/notes/1453015901605223/

On 16/05/14 21:30, Brian E Carpenter wrote:
> _______________________________________________
> perpass mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/perpass
>

---

From: "Carl S. Gutekunst" <[email-masked]>
Date: Fri, 16 May 2014 15:13:53 -0700

> The thing I really hate about these metaphors is that they lead one to the conclusion that it's pointless to use strong crypto, when really the conclusion one should draw is that one should try to…

Spafford's is also a 25-year-old metaphor, which is why someone updated 
it to "using strong crypto...." Old metaphors, like urban legends, adapt 
to the times.

In the same vein: people complaining that I "locked the front door and 
left the window open." This is one I confess to using quite a bit. But 
it does not mean I should unlock the front door.

<csg>

---

From: Brian E Carpenter <[email-masked]>
Date: Sat, 17 May 2014 11:14:04 +1200

> I don't see that, myself.  Seems to me to be arguing for a systems

I think that is Peter's point, from hearing his talk live a few months
ago. You need crypto, but you also need a very strong cardboard box
with no buffer overflows, and without the password being scrawled
on the outside. And do not trust passing strangers who offer
unexpected gifts.

Of course, there is only so much we can do in IETF protocol
specifications.

    Brian

---

From: Ted Lemon <[email-masked]>
Date: Fri, 16 May 2014 21:00:11 -0400

> on the outside. And do not trust passing strangers who offer

The problem is that the quote is quite memorable, and is repeated out of context quite frequently.   And a person who is not, like us, familiar with the technology, will hear "there is no real hope, so don't bother" when what is meant is "make sure you secure the end nodes."

---

From: Scott Brim <[email-masked]>
Date: Fri, 16 May 2014 21:56:44 -0400

> ago. You need crypto, but you also need a very strong cardboard box

That was my gut reaction. At least we can do really good design, that might
make the crypto count for something.

---

From: Tim Bray <[email-masked]>
Date: Fri, 16 May 2014 18:58:28 -0700

Relevant to this: https://encryptallthethings.net//

-- 
- Tim Bray (If you’d like to send me a private message, see
https://keybase.io/timbray)

---

From: Harry Halpin <[email-masked]>
Date: Sat, 17 May 2014 13:44:24 +0200

> Of course, there is only so much we can do in IETF protocol

Actually, from a systems perspective this is quite a bit one can do in
an IETF or W3C specification. For example, data minimization by not
leaking identifiers except when necessary. See "hiding metadata" in the
STRINT workshop report [1]. The methods of system-thinking in security
is still very young, but I'd say the arms race with the NSA is on :)

[1] https://tools.ietf.org/html/draft-iab-strint-report-00#page-6

   cheers,
       harry

---

From: David Singer <[email-masked]>
Date: Tue, 20 May 2014 16:14:59 +0200

On May 17, 2014, at 3:00 , Ted Lemon <[email-masked]> wrote:

> The problem is that the quote is quite memorable, and is repeated out of context quite frequently.   And a person who is not, like us, familiar with the technology, will hear "there is no real hope, so don't bother" when what is meant is "make sure you secure the end nodes.”

Even were the quote simply true, it may be a non-sequitur.  Front door locks get broken sometimes, safes get cracked, padlocks get sawn off, and so on.  Even if a technique is not 100% effective, that doesn’t make it useless. 

Dave Singer

[email-masked]

David Singer
Manager, Software Standards, Apple Inc.

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 21 May 2014 17:07:42 -0400

> Relevant to this: https://encryptallthethings.net//

+1

You'll see us (CDT) and many others have signed on to this campaign
from Access and will attempt to do all the things here by the end of
the year (PFS, HSTS, etc.).

Part of the impetus here is that legal reform is slow and wildly
unpredictable, beefing up standards is a bit faster (not much!) and
often has other competing interests... so, how can we get folks that
make apps, run servers, etc. to turn on and properly configure
technical bits that provide a higher degree of security and privacy.

There is also:

https://www.resetthenet.org/

Which is a broader effort -- centered around the anniversary of the
first Snowden revelation -- to get everyone (even the general public!)
to commit to using a new security and/or privacy technology.

best, Joe

- -- 
Joseph Lorenzo Hall
Chief Technologist
Center for Democracy & Technology
1634 I ST NW STE 1100
Washington DC 20006-4011
(p) 202-407-8825
(f) 202-637-0968
[email-masked]
PGP: https://josephhall.org/gpg-key
fingerprint: 3CA2 8D7B 9F6D DBD3 4B10  1607 5F86 6987 40A9 A871