
From nobody Wed Dec  6 07:30:31 2017
Return-Path: <housley@vigilsec.com>
X-Original-To: pkix@ietfa.amsl.com
Delivered-To: pkix@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E91E1126DD9 for <pkix@ietfa.amsl.com>; Wed,  6 Dec 2017 07:30:28 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id d7Hu9EszZG6w for <pkix@ietfa.amsl.com>; Wed,  6 Dec 2017 07:30:26 -0800 (PST)
Received: from mail.smeinc.net (mail.smeinc.net [209.135.209.11]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 3DC16120725 for <pkix@ietf.org>; Wed,  6 Dec 2017 07:30:26 -0800 (PST)
Received: from localhost (localhost [127.0.0.1]) by mail.smeinc.net (Postfix) with ESMTP id 76669300670 for <pkix@ietf.org>; Wed,  6 Dec 2017 10:30:25 -0500 (EST)
X-Virus-Scanned: amavisd-new at mail.smeinc.net
Received: from mail.smeinc.net ([127.0.0.1]) by localhost (mail.smeinc.net [127.0.0.1]) (amavisd-new, port 10026) with ESMTP id A3MNLPKjjyBS for <pkix@ietf.org>; Wed,  6 Dec 2017 10:30:20 -0500 (EST)
Received: from a860b60074bd.home (pool-108-45-101-150.washdc.fios.verizon.net [108.45.101.150]) by mail.smeinc.net (Postfix) with ESMTPSA id 054553002C6; Wed,  6 Dec 2017 10:30:19 -0500 (EST)
From: Russ Housley <housley@vigilsec.com>
Message-Id: <7FC51BDF-D5E5-4473-9658-BE0F34C1021C@vigilsec.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_DBC78D87-69FE-4898-9CC5-D17A1EB25326"
Mime-Version: 1.0 (Mac OS X Mail 10.3 \(3273\))
Date: Wed, 6 Dec 2017 10:30:19 -0500
In-Reply-To: <20171205213236.83CB1B81B9E@rfc-editor.org>
Cc: Jim Schaad <ietf@augustcellars.com>, Burt Kaliski <bkaliski@verisign.com>,  Stefan Santesson <stefan@aaa-sec.com>, bernd-2017@eckenfels.net, IETF PKIX <pkix@ietf.org>
To: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>, Eric Rescorla <ekr@rtfm.com>
References: <20171205213236.83CB1B81B9E@rfc-editor.org>
X-Mailer: Apple Mail (2.3273)
Archived-At: <https://mailarchive.ietf.org/arch/msg/pkix/ksSxa4b7-Evlf-Md_GwQy9i-c7M>
Subject: Re: [pkix] [Technical Errata Reported] RFC4055 (5199)
X-BeenThere: pkix@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: PKIX Working Group <pkix.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/pkix>, <mailto:pkix-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pkix/>
List-Post: <mailto:pkix@ietf.org>
List-Help: <mailto:pkix-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/pkix>, <mailto:pkix-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 06 Dec 2017 15:30:29 -0000

--Apple-Mail=_DBC78D87-69FE-4898-9CC5-D17A1EB25326
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=utf-8

Burt Kaliski observes:

"""
The text in Sec. 4.1 of RFC4055 including the syntax of =
RSAES-OAEP-params largely follows Sec. 11.2.1 of RFC2437 (PKCS #1 v2.0), =
which uses the term =E2=80=9Cencoding parameters P=E2=80=9D, rather than =
the Sec. A.2.1 of RFC3447 (PKCS #1 v2.1), which uses the term =E2=80=9Clab=
el L=E2=80=9D.  (RFC3560, the CMS profile for these algorithms, =
similarly follows RFC2437.)
=20
RFC3447 acknowledges that =E2=80=9CIn previous versions of this =
specification, the term =E2=80=98encoding parameters=E2=80=99 was =
used=E2=80=9D.  Given that RFC4055 inserts =E2=80=9Ccommonly called=E2=80=9D=
 before RFC2437=E2=80=99s =E2=80=9CP=E2=80=9D, it appears that RFC4055 =
is attempting to bridge between RFC3447 and RFC2437.
"""

I observe that RFC 2437, RFC 3447, and RFC 4055 all use the same ASN.1 =
structure for RSAES-OAEP-params.  While the description of RSAES-OAEP in =
[P1v2.1] uses "L" instead of "P", this change in terminology did not =
carry through to the ASN.1 structure.

I think that this should not be classified as a technical errata.  =
Perhaps a better text would be:

   The pSourceFunc field identifies the source (and possibly the value)
   of the encoding parameters, commonly called P. (Note: it is referred
   to as label L in Section 7.1.1 of [P1v2.1], and it is referred to as =
P
   throughout [P1v2.0] and Section A.2.1 of [P1v2.1].)

   [P1v2.0] =3D RFC 2437

I don=E2=80=99t see an error here, so I think the corrected errata =
should be approved as editorial.

Russ



> On Dec 5, 2017, at 4:32 PM, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC4055,
> "Additional Algorithms and Identifiers for RSA Cryptography for use in =
the Internet X.509 Public Key Infrastructure Certificate and Certificate =
Revocation List (CRL) Profile".
>=20
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5199
>=20
> --------------------------------------
> Type: Technical
> Reported by: Bernd Eckenfels <bernd-2017@eckenfels.net>
>=20
> Section: 4.1
>=20
> Original Text
> -------------
> The pSourceFunc field identifies the source (and possibly the value)
> of the encoding parameters, commonly called P.
>=20
> Corrected Text
> --------------
> The pSourceFunc field identifies the source (and possibly the value)
> of the encoding parameters, commonly called P. In the EME-OAEP =
encoding
> method [P1v2.1] defines this parameter as label L.
>=20
> Notes
> -----
> There is no place where P is linked to the parameter name L as used in
> referenced [P1v2.1]
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party =20
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC4055 (draft-ietf-pkix-rsa-pkalgs-03)
> --------------------------------------
> Title               : Additional Algorithms and Identifiers for RSA =
Cryptography for use in the Internet X.509 Public Key Infrastructure =
Certificate and Certificate Revocation List (CRL) Profile
> Publication Date    : June 2005
> Author(s)           : J. Schaad, B. Kaliski, R. Housley
> Category            : PROPOSED STANDARD
> Source              : Public-Key Infrastructure (X.509)
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG


--Apple-Mail=_DBC78D87-69FE-4898-9CC5-D17A1EB25326
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=utf-8

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html =
charset=3Dutf-8"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" =
class=3D""><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D"">Burt Kaliski =
observes:</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">"""</div><div style=3D"margin: 0in 0in =
0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif;" =
class=3D"">The text in Sec. 4.1 of RFC4055 including the syntax of =
RSAES-OAEP-params largely follows Sec. 11.2.1 of RFC2437 (PKCS #1 v2.0), =
which uses the term =E2=80=9Cencoding parameters P=E2=80=9D, rather than =
the Sec. A.2.1 of RFC3447 (PKCS #1 v2.1), which uses the term =E2=80=9Clab=
el L=E2=80=9D. &nbsp;(RFC3560, the CMS profile for these algorithms, =
similarly follows RFC2437.)<o:p class=3D""></o:p></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D""><o:p class=3D"">&nbsp;</o:p></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">RFC3447 acknowledges that =E2=80=9CIn =
previous versions of this specification, the term =E2=80=98encoding =
parameters=E2=80=99 was used=E2=80=9D.&nbsp; Given that RFC4055 inserts =
=E2=80=9Ccommonly called=E2=80=9D before RFC2437=E2=80=99s =E2=80=9CP=E2=80=
=9D, it appears that RFC4055 is attempting to bridge between RFC3447 and =
RFC2437.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D"">"""</div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">I observe that RFC 2437, RFC 3447, and =
RFC 4055 all use the same ASN.1 structure for&nbsp;RSAES-OAEP-params. =
&nbsp;While the description of RSAES-OAEP in [P1v2.1] uses "L" instead =
of "P", this change in terminology did not carry through to the ASN.1 =
structure.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">I think that this should not be =
classified as a technical errata. &nbsp;Perhaps a better text would =
be:</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt;" class=3D""><div style=3D"margin: 0in =
0in 0.0001pt;" class=3D""><font face=3D"Calibri, sans-serif" =
class=3D""><span style=3D"font-size: 14.666666984558105px;" =
class=3D"">&nbsp; &nbsp;The pSourceFunc field identifies the source (and =
possibly the value)</span></font></div><div style=3D"margin: 0in 0in =
0.0001pt;" class=3D""><font face=3D"Calibri, sans-serif" class=3D""><span =
style=3D"font-size: 14.666666984558105px;" class=3D"">&nbsp; &nbsp;of =
the encoding parameters, commonly called P. (Note: it is =
referred</span></font></div><div style=3D"margin: 0in 0in 0.0001pt;" =
class=3D""><span style=3D"font-size: 14.666666984558105px; font-family: =
Calibri, sans-serif;" class=3D"">&nbsp; &nbsp;to&nbsp;</span><span =
style=3D"font-size: 14.666666984558105px; font-family: Calibri, =
sans-serif;" class=3D"">as label L in Section 7.1.1 of [P1v2.1], and it =
is referred to as P</span></div><div style=3D"margin: 0in 0in 0.0001pt;" =
class=3D""><span style=3D"font-size: 14.666666984558105px; font-family: =
Calibri, sans-serif;" class=3D"">&nbsp; &nbsp;throughout</span><span =
style=3D"font-size: 14.666666984558105px; font-family: Calibri, =
sans-serif;" class=3D"">&nbsp;[P1v2.0] and</span><span =
style=3D"font-family: Calibri, sans-serif; font-size: =
14.666666984558105px;" class=3D"">&nbsp;Section A.2.1 of =
[P1v2.1].)</span></div></div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D"">&nbsp; =
&nbsp;[P1v2.0] =3D RFC 2437</div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D"">I don=E2=80=99t see =
an error here, so I think the corrected errata should be approved as =
editorial.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">Russ</div><div style=3D"margin: 0in 0in =
0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif;" =
class=3D""><br class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div><blockquote type=3D"cite" class=3D""><div =
class=3D"">On Dec 5, 2017, at 4:32 PM, RFC Errata System &lt;<a =
href=3D"mailto:rfc-editor@rfc-editor.org" =
class=3D"">rfc-editor@rfc-editor.org</a>&gt; wrote:</div><br =
class=3D"Apple-interchange-newline"><div class=3D""><div class=3D"">The =
following errata report has been submitted for RFC4055,<br =
class=3D"">"Additional Algorithms and Identifiers for RSA Cryptography =
for use in the Internet X.509 Public Key Infrastructure Certificate and =
Certificate Revocation List (CRL) Profile".<br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">You may =
review the report below and at:<br class=3D""><a =
href=3D"http://www.rfc-editor.org/errata/eid5199" =
class=3D"">http://www.rfc-editor.org/errata/eid5199</a><br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">Type: =
Technical<br class=3D"">Reported by: Bernd Eckenfels =
&lt;bernd-2017@eckenfels.net&gt;<br class=3D""><br class=3D"">Section: =
4.1<br class=3D""><br class=3D"">Original Text<br =
class=3D"">-------------<br class=3D"">The pSourceFunc field identifies =
the source (and possibly the value)<br class=3D"">of the encoding =
parameters, commonly called P.<br class=3D""><br class=3D"">Corrected =
Text<br class=3D"">--------------<br class=3D"">The pSourceFunc field =
identifies the source (and possibly the value)<br class=3D"">of the =
encoding parameters, commonly called P. In the EME-OAEP encoding<br =
class=3D"">method [P1v2.1] defines this parameter as label L.<br =
class=3D""><br class=3D"">Notes<br class=3D"">-----<br class=3D"">There =
is no place where P is linked to the parameter name L as used in<br =
class=3D"">referenced [P1v2.1]<br class=3D""><br =
class=3D"">Instructions:<br class=3D"">-------------<br class=3D"">This =
erratum is currently posted as "Reported". If necessary, please<br =
class=3D"">use "Reply All" to discuss whether it should be verified =
or<br class=3D"">rejected. When a decision is reached, the verifying =
party &nbsp;<br class=3D"">can log in to change the status and edit the =
report, if necessary. <br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">RFC4055 =
(draft-ietf-pkix-rsa-pkalgs-03)<br =
class=3D"">--------------------------------------<br class=3D"">Title =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;: Additional Algorithms and Identifiers for RSA Cryptography =
for use in the Internet X.509 Public Key Infrastructure Certificate and =
Certificate Revocation List (CRL) Profile<br class=3D"">Publication Date =
&nbsp;&nbsp;&nbsp;: June 2005<br class=3D"">Author(s) =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: J. Schaad, =
B. Kaliski, R. Housley<br class=3D"">Category =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: =
PROPOSED STANDARD<br class=3D"">Source =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;: Public-Key Infrastructure (X.509)<br class=3D"">Area =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;&nbsp;: Security<br class=3D"">Stream =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;: IETF<br class=3D"">Verifying Party &nbsp;&nbsp;&nbsp;&nbsp;: =
IESG<br class=3D""></div></div></blockquote></div><br =
class=3D""></body></html>=

--Apple-Mail=_DBC78D87-69FE-4898-9CC5-D17A1EB25326--


From nobody Wed Dec  6 13:58:19 2017
Return-Path: <housley@vigilsec.com>
X-Original-To: pkix@ietfa.amsl.com
Delivered-To: pkix@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B1CDE127977 for <pkix@ietfa.amsl.com>; Wed,  6 Dec 2017 13:58:17 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, HTML_MESSAGE=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id knp5wB9_Da_T for <pkix@ietfa.amsl.com>; Wed,  6 Dec 2017 13:58:15 -0800 (PST)
Received: from mail.smeinc.net (mail.smeinc.net [209.135.209.11]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 92F01126B72 for <pkix@ietf.org>; Wed,  6 Dec 2017 13:58:15 -0800 (PST)
Received: from localhost (localhost [127.0.0.1]) by mail.smeinc.net (Postfix) with ESMTP id BAEC8300670 for <pkix@ietf.org>; Wed,  6 Dec 2017 16:58:14 -0500 (EST)
X-Virus-Scanned: amavisd-new at mail.smeinc.net
Received: from mail.smeinc.net ([127.0.0.1]) by localhost (mail.smeinc.net [127.0.0.1]) (amavisd-new, port 10026) with ESMTP id jd6fJEJi929B for <pkix@ietf.org>; Wed,  6 Dec 2017 16:58:10 -0500 (EST)
Received: from a860b60074bd.home (pool-108-45-101-150.washdc.fios.verizon.net [108.45.101.150]) by mail.smeinc.net (Postfix) with ESMTPSA id 0BCAF300266; Wed,  6 Dec 2017 16:58:09 -0500 (EST)
From: Russ Housley <housley@vigilsec.com>
Message-Id: <3EE9D837-BBBD-4BF0-8D52-F75E94C54878@vigilsec.com>
Content-Type: multipart/alternative; boundary="Apple-Mail=_92A48CAE-9787-44BB-9DB0-9A3C0D5BEA3A"
Mime-Version: 1.0 (Mac OS X Mail 10.3 \(3273\))
Date: Wed, 6 Dec 2017 16:58:10 -0500
In-Reply-To: <7FC51BDF-D5E5-4473-9658-BE0F34C1021C@vigilsec.com>
Cc: Jim Schaad <ietf@augustcellars.com>, Burt Kaliski <bkaliski@verisign.com>,  Stefan Santesson <stefan@aaa-sec.com>, bernd-2017@eckenfels.net, IETF PKIX <pkix@ietf.org>
To: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>, Eric Rescorla <ekr@rtfm.com>
References: <20171205213236.83CB1B81B9E@rfc-editor.org> <7FC51BDF-D5E5-4473-9658-BE0F34C1021C@vigilsec.com>
X-Mailer: Apple Mail (2.3273)
Archived-At: <https://mailarchive.ietf.org/arch/msg/pkix/T_78veMWIY8cPSREh91ri7KEhgM>
Subject: Re: [pkix] [Technical Errata Reported] RFC4055 (5199)
X-BeenThere: pkix@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: PKIX Working Group <pkix.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/pkix>, <mailto:pkix-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pkix/>
List-Post: <mailto:pkix@ietf.org>
List-Help: <mailto:pkix-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/pkix>, <mailto:pkix-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 06 Dec 2017 21:58:18 -0000

--Apple-Mail=_92A48CAE-9787-44BB-9DB0-9A3C0D5BEA3A
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
	charset=utf-8

A minor clarification:

   The pSourceFunc field identifies the source (and possibly the value)
   of the encoding parameters, commonly called P. (Note: it is referred
   to as label L in [P1v2.1], and it is referred to as P throughout =
[P1v2.0],
   although the ASN.1 structures in both document use the letter =
=E2=80=9Cp=E2=80=9D.)

Russ


> On Dec 6, 2017, at 10:30 AM, Russ Housley <housley@vigilsec.com> =
wrote:
>=20
> Burt Kaliski observes:
>=20
> """
> The text in Sec. 4.1 of RFC4055 including the syntax of =
RSAES-OAEP-params largely follows Sec. 11.2.1 of RFC2437 (PKCS #1 v2.0), =
which uses the term =E2=80=9Cencoding parameters P=E2=80=9D, rather than =
the Sec. A.2.1 of RFC3447 (PKCS #1 v2.1), which uses the term =E2=80=9Clab=
el L=E2=80=9D.  (RFC3560, the CMS profile for these algorithms, =
similarly follows RFC2437.)
> =20
> RFC3447 acknowledges that =E2=80=9CIn previous versions of this =
specification, the term =E2=80=98encoding parameters=E2=80=99 was =
used=E2=80=9D.  Given that RFC4055 inserts =E2=80=9Ccommonly called=E2=80=9D=
 before RFC2437=E2=80=99s =E2=80=9CP=E2=80=9D, it appears that RFC4055 =
is attempting to bridge between RFC3447 and RFC2437.
> """
>=20
> I observe that RFC 2437, RFC 3447, and RFC 4055 all use the same ASN.1 =
structure for RSAES-OAEP-params.  While the description of RSAES-OAEP in =
[P1v2.1] uses "L" instead of "P", this change in terminology did not =
carry through to the ASN.1 structure.
>=20
> I think that this should not be classified as a technical errata.  =
Perhaps a better text would be:
>=20
>    The pSourceFunc field identifies the source (and possibly the =
value)
>    of the encoding parameters, commonly called P. (Note: it is =
referred
>    to as label L in Section 7.1.1 of [P1v2.1], and it is referred to =
as P
>    throughout [P1v2.0] and Section A.2.1 of [P1v2.1].)
>=20
>    [P1v2.0] =3D RFC 2437
>=20
> I don=E2=80=99t see an error here, so I think the corrected errata =
should be approved as editorial.
>=20
> Russ
>=20
>=20
>=20
>> On Dec 5, 2017, at 4:32 PM, RFC Errata System =
<rfc-editor@rfc-editor.org <mailto:rfc-editor@rfc-editor.org>> wrote:
>>=20
>> The following errata report has been submitted for RFC4055,
>> "Additional Algorithms and Identifiers for RSA Cryptography for use =
in the Internet X.509 Public Key Infrastructure Certificate and =
Certificate Revocation List (CRL) Profile".
>>=20
>> --------------------------------------
>> You may review the report below and at:
>> http://www.rfc-editor.org/errata/eid5199 =
<http://www.rfc-editor.org/errata/eid5199>
>>=20
>> --------------------------------------
>> Type: Technical
>> Reported by: Bernd Eckenfels <bernd-2017@eckenfels.net>
>>=20
>> Section: 4.1
>>=20
>> Original Text
>> -------------
>> The pSourceFunc field identifies the source (and possibly the value)
>> of the encoding parameters, commonly called P.
>>=20
>> Corrected Text
>> --------------
>> The pSourceFunc field identifies the source (and possibly the value)
>> of the encoding parameters, commonly called P. In the EME-OAEP =
encoding
>> method [P1v2.1] defines this parameter as label L.
>>=20
>> Notes
>> -----
>> There is no place where P is linked to the parameter name L as used =
in
>> referenced [P1v2.1]
>>=20
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party =20
>> can log in to change the status and edit the report, if necessary.=20
>>=20
>> --------------------------------------
>> RFC4055 (draft-ietf-pkix-rsa-pkalgs-03)
>> --------------------------------------
>> Title               : Additional Algorithms and Identifiers for RSA =
Cryptography for use in the Internet X.509 Public Key Infrastructure =
Certificate and Certificate Revocation List (CRL) Profile
>> Publication Date    : June 2005
>> Author(s)           : J. Schaad, B. Kaliski, R. Housley
>> Category            : PROPOSED STANDARD
>> Source              : Public-Key Infrastructure (X.509)
>> Area                : Security
>> Stream              : IETF
>> Verifying Party     : IESG
>=20


--Apple-Mail=_92A48CAE-9787-44BB-9DB0-9A3C0D5BEA3A
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
	charset=utf-8

<html><head><meta http-equiv=3D"Content-Type" content=3D"text/html =
charset=3Dutf-8"></head><body style=3D"word-wrap: break-word; =
-webkit-nbsp-mode: space; -webkit-line-break: after-white-space;" =
class=3D"">A minor clarification:<div class=3D""><br class=3D""></div><div=
 class=3D""><div class=3D"">&nbsp; &nbsp;The pSourceFunc field =
identifies the source (and possibly the value)</div><div class=3D"">&nbsp;=
 &nbsp;of the encoding parameters, commonly called P. (Note: it is =
referred</div><div class=3D"">&nbsp; &nbsp;to as label L in [P1v2.1], =
and it is referred to as P throughout [P1v2.0],</div><div =
class=3D"">&nbsp; &nbsp;although the ASN.1 structures in both document =
use the letter =E2=80=9Cp=E2=80=9D.)</div><div class=3D""><br =
class=3D""></div><div class=3D"">Russ</div><div class=3D""><br =
class=3D""></div><div class=3D""><br class=3D""><div><blockquote =
type=3D"cite" class=3D""><div class=3D"">On Dec 6, 2017, at 10:30 AM, =
Russ Housley &lt;<a href=3D"mailto:housley@vigilsec.com" =
class=3D"">housley@vigilsec.com</a>&gt; wrote:</div><br =
class=3D"Apple-interchange-newline"><div class=3D""><meta =
http-equiv=3D"Content-Type" content=3D"text/html charset=3Dutf-8" =
class=3D""><div style=3D"word-wrap: break-word; -webkit-nbsp-mode: =
space; -webkit-line-break: after-white-space;" class=3D""><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">Burt Kaliski observes:</div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">"""</div><div style=3D"margin: 0in 0in =
0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif;" =
class=3D"">The text in Sec. 4.1 of RFC4055 including the syntax of =
RSAES-OAEP-params largely follows Sec. 11.2.1 of RFC2437 (PKCS #1 v2.0), =
which uses the term =E2=80=9Cencoding parameters P=E2=80=9D, rather than =
the Sec. A.2.1 of RFC3447 (PKCS #1 v2.1), which uses the term =E2=80=9Clab=
el L=E2=80=9D. &nbsp;(RFC3560, the CMS profile for these algorithms, =
similarly follows RFC2437.)<o:p class=3D""></o:p></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D""><o:p class=3D"">&nbsp;</o:p></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">RFC3447 acknowledges that =E2=80=9CIn =
previous versions of this specification, the term =E2=80=98encoding =
parameters=E2=80=99 was used=E2=80=9D.&nbsp; Given that RFC4055 inserts =
=E2=80=9Ccommonly called=E2=80=9D before RFC2437=E2=80=99s =E2=80=9CP=E2=80=
=9D, it appears that RFC4055 is attempting to bridge between RFC3447 and =
RFC2437.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D"">"""</div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">I observe that RFC 2437, RFC 3447, and =
RFC 4055 all use the same ASN.1 structure for&nbsp;RSAES-OAEP-params. =
&nbsp;While the description of RSAES-OAEP in [P1v2.1] uses "L" instead =
of "P", this change in terminology did not carry through to the ASN.1 =
structure.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">I think that this should not be =
classified as a technical errata. &nbsp;Perhaps a better text would =
be:</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt;" class=3D""><div style=3D"margin: 0in =
0in 0.0001pt;" class=3D""><font face=3D"Calibri, sans-serif" =
class=3D""><span style=3D"font-size: 14.666666984558105px;" =
class=3D"">&nbsp; &nbsp;The pSourceFunc field identifies the source (and =
possibly the value)</span></font></div><div style=3D"margin: 0in 0in =
0.0001pt;" class=3D""><font face=3D"Calibri, sans-serif" class=3D""><span =
style=3D"font-size: 14.666666984558105px;" class=3D"">&nbsp; &nbsp;of =
the encoding parameters, commonly called P. (Note: it is =
referred</span></font></div><div style=3D"margin: 0in 0in 0.0001pt;" =
class=3D""><span style=3D"font-size: 14.666666984558105px; font-family: =
Calibri, sans-serif;" class=3D"">&nbsp; &nbsp;to&nbsp;</span><span =
style=3D"font-size: 14.666666984558105px; font-family: Calibri, =
sans-serif;" class=3D"">as label L in Section 7.1.1 of [P1v2.1], and it =
is referred to as P</span></div><div style=3D"margin: 0in 0in 0.0001pt;" =
class=3D""><span style=3D"font-size: 14.666666984558105px; font-family: =
Calibri, sans-serif;" class=3D"">&nbsp; &nbsp;throughout</span><span =
style=3D"font-size: 14.666666984558105px; font-family: Calibri, =
sans-serif;" class=3D"">&nbsp;[P1v2.0] and</span><span =
style=3D"font-family: Calibri, sans-serif; font-size: =
14.666666984558105px;" class=3D"">&nbsp;Section A.2.1 of =
[P1v2.1].)</span></div></div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D"">&nbsp; =
&nbsp;[P1v2.0] =3D RFC 2437</div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D"">I don=E2=80=99t see =
an error here, so I think the corrected errata should be approved as =
editorial.</div><div style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; =
font-family: Calibri, sans-serif;" class=3D""><br class=3D""></div><div =
style=3D"margin: 0in 0in 0.0001pt; font-size: 11pt; font-family: =
Calibri, sans-serif;" class=3D"">Russ</div><div style=3D"margin: 0in 0in =
0.0001pt; font-size: 11pt; font-family: Calibri, sans-serif;" =
class=3D""><br class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; =
font-size: 11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div style=3D"margin: 0in 0in 0.0001pt; font-size: =
11pt; font-family: Calibri, sans-serif;" class=3D""><br =
class=3D""></div><div class=3D""><blockquote type=3D"cite" class=3D""><div=
 class=3D"">On Dec 5, 2017, at 4:32 PM, RFC Errata System &lt;<a =
href=3D"mailto:rfc-editor@rfc-editor.org" =
class=3D"">rfc-editor@rfc-editor.org</a>&gt; wrote:</div><br =
class=3D"Apple-interchange-newline"><div class=3D""><div class=3D"">The =
following errata report has been submitted for RFC4055,<br =
class=3D"">"Additional Algorithms and Identifiers for RSA Cryptography =
for use in the Internet X.509 Public Key Infrastructure Certificate and =
Certificate Revocation List (CRL) Profile".<br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">You may =
review the report below and at:<br class=3D""><a =
href=3D"http://www.rfc-editor.org/errata/eid5199" =
class=3D"">http://www.rfc-editor.org/errata/eid5199</a><br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">Type: =
Technical<br class=3D"">Reported by: Bernd Eckenfels &lt;<a =
href=3D"mailto:bernd-2017@eckenfels.net" =
class=3D"">bernd-2017@eckenfels.net</a>&gt;<br class=3D""><br =
class=3D"">Section: 4.1<br class=3D""><br class=3D"">Original Text<br =
class=3D"">-------------<br class=3D"">The pSourceFunc field identifies =
the source (and possibly the value)<br class=3D"">of the encoding =
parameters, commonly called P.<br class=3D""><br class=3D"">Corrected =
Text<br class=3D"">--------------<br class=3D"">The pSourceFunc field =
identifies the source (and possibly the value)<br class=3D"">of the =
encoding parameters, commonly called P. In the EME-OAEP encoding<br =
class=3D"">method [P1v2.1] defines this parameter as label L.<br =
class=3D""><br class=3D"">Notes<br class=3D"">-----<br class=3D"">There =
is no place where P is linked to the parameter name L as used in<br =
class=3D"">referenced [P1v2.1]<br class=3D""><br =
class=3D"">Instructions:<br class=3D"">-------------<br class=3D"">This =
erratum is currently posted as "Reported". If necessary, please<br =
class=3D"">use "Reply All" to discuss whether it should be verified =
or<br class=3D"">rejected. When a decision is reached, the verifying =
party &nbsp;<br class=3D"">can log in to change the status and edit the =
report, if necessary. <br class=3D""><br =
class=3D"">--------------------------------------<br class=3D"">RFC4055 =
(draft-ietf-pkix-rsa-pkalgs-03)<br =
class=3D"">--------------------------------------<br class=3D"">Title =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;: Additional Algorithms and Identifiers for RSA Cryptography =
for use in the Internet X.509 Public Key Infrastructure Certificate and =
Certificate Revocation List (CRL) Profile<br class=3D"">Publication Date =
&nbsp;&nbsp;&nbsp;: June 2005<br class=3D"">Author(s) =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: J. Schaad, =
B. Kaliski, R. Housley<br class=3D"">Category =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;: =
PROPOSED STANDARD<br class=3D"">Source =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;: Public-Key Infrastructure (X.509)<br class=3D"">Area =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;&nbsp;&nbsp;: Security<br class=3D"">Stream =
&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&n=
bsp;: IETF<br class=3D"">Verifying Party &nbsp;&nbsp;&nbsp;&nbsp;: =
IESG<br class=3D""></div></div></blockquote></div><br =
class=3D""></div></div></blockquote></div><br =
class=3D""></div></div></body></html>=

--Apple-Mail=_92A48CAE-9787-44BB-9DB0-9A3C0D5BEA3A--


From nobody Fri Dec  8 10:01:20 2017
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: pkix@ietfa.amsl.com
Delivered-To: pkix@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id DDBFF126E3A for <pkix@ietfa.amsl.com>; Fri,  8 Dec 2017 10:01:18 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.201
X-Spam-Level: 
X-Spam-Status: No, score=-4.201 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 8AW4xR1nZLxM for <pkix@ietfa.amsl.com>; Fri,  8 Dec 2017 10:01:17 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 466EB126DFB for <pkix@ietf.org>; Fri,  8 Dec 2017 10:01:17 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id ACB1EB81ACE; Fri,  8 Dec 2017 10:00:55 -0800 (PST)
To: philliph@comodo.com, rob.stradling@comodo.com, Kathleen.Moriarty.ietf@gmail.com, ekr@rtfm.com, kent@bbn.com, stefan@aaa-sec.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: richard.j.gibson@oracle.com, pkix@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20171208180055.ACB1EB81ACE@rfc-editor.org>
Date: Fri,  8 Dec 2017 10:00:55 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/pkix/Bzjxbtkh9_1e5oV3ewlIGo8JazA>
Subject: [pkix] [Technical Errata Reported] RFC6844 (5200)
X-BeenThere: pkix@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: PKIX Working Group <pkix.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/pkix>, <mailto:pkix-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/pkix/>
List-Post: <mailto:pkix@ietf.org>
List-Help: <mailto:pkix-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/pkix>, <mailto:pkix-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 08 Dec 2017 18:01:19 -0000

The following errata report has been submitted for RFC6844,
"DNS Certification Authority Authorization (CAA) Resource Record".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5200

--------------------------------------
Type: Technical
Reported by: Richard Gibson <richard.j.gibson@oracle.com>

Section: 3

Original Text
-------------
<Issuer Domain Name> [; <name>=<value> ]*

Corrected Text
--------------
<Issuer Domain Name> [; [ <name>=<value> ]* ]

Notes
-----
For values of the "issue" and "issuewild" property tags, section 3 specifies [; <name>=<value> ]* (which seems to indicate that every parameter is preceded by a semicolon) but the grammar in section 5.2 specifies [";" *(space parameter) space] (in which parameters are separated by whitespace and the entire list is preceded by a single semicolon). Presumably, the formal grammar is definitive and the preceding shorthand should be updated to better express it.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6844 (draft-ietf-pkix-caa-15)
--------------------------------------
Title               : DNS Certification Authority Authorization (CAA) Resource Record
Publication Date    : January 2013
Author(s)           : P. Hallam-Baker, R. Stradling
Category            : PROPOSED STANDARD
Source              : Public-Key Infrastructure (X.509)
Area                : Security
Stream              : IETF
Verifying Party     : IESG

