Subject: [plasma] GetRoleToken or GetRoleTokens?

From: Alan Borland <[email-masked]>
Date: Thu, 8 Nov 2012 11:45:38 +0000

In draft-schaad-plasma-service-03:

- Section 7.1 uses 'GetRoleToken'

- Appendix B uses 'GetRoleTokens'

For our prototyping exercise we have been using 'GetRoleToken'

Alan.

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 8 Nov 2012 10:13:58 -0500

One should always use the schema as the authoritative space for names.  I
don't always manage to schema check the examples before publishing the
document as I don't have a command line schema checker like I do for ASN.1

Let me know when text and schema disagree on the names

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alan Borland
Sent: Thursday, November 08, 2012 6:46 AM
To: [email-masked]
Subject: [plasma] GetRoleToken or GetRoleTokens?

Alan.

---

From: Ed Simon <[email-masked]>
Date: Sat, 10 Nov 2012 14:50:24 +0000

OK, but the schema does not cover many of the naming issues such as when the PLASMA schema references external schemas (such as SAML, XACML, etc.) and the specification, but not the schema, requires certain values to be used in those external structures.

For Alan's question, the question is what should be the value of the XACML action-id attribute; that is not specified in the schema (unless I missed it, though I agree the PLASMA-specific <GetCMSToken> element is).

For my question about the XACML <Attributes> category for PLASMA data, that also is not defined in the PLASMA schema, correct?

Ed
________________________________________
From: [email-masked] [[email-masked]] on behalf of Jim Schaad [[email-masked]]
Sent: Thursday, November 08, 2012 10:13
To: 'Alan Borland'; [email-masked]
Subject: Re: [plasma] GetRoleToken or GetRoleTokens?

One should always use the schema as the authoritative space for names.  I don’t always manage to schema check the examples before publishing the document as I don’t have a command line schema checker like I do for ASN.1

Jim

From: [email-masked] [mailto:[email-masked]] On Behalf Of Alan Borland
Sent: Thursday, November 08, 2012 6:46 AM
To: [email-masked]
Subject: [plasma] GetRoleToken or GetRoleTokens?

Alan.