Subject: [pm-dir] Fwd: Performance metrics doctors generated email

From: Benoit Claise <[email-masked]>
Date: Tue, 11 Dec 2012 01:07:00 +0100

Dear all,

 From the last IETF meeting minutes:
     ACTION Benoit: script to generate a weekly email with drafts 
containing "performance metric", "6390", etc..

Thanks to Alan Dekok, who runs a similar script for the AAA doctors, I 
have setup a similar script for the performance metrics directorate.
Currently, the scripts checks for IETF internet-drafts that reference 
the PMOL RFC 6390, as a normative reference.

If the script returns nothing, an email with "Performance metrics 
doctors generated email: nothing this week" will be generated.
Otherwise, something such as the attached email will be sent.

The part of the script that searches for "performance" and "metric" is 
not there yet.

Regards, Benoit

-------- Original Message --------
Subject: 	Performance metrics doctors generated email
Date: 	Tue, 11 Dec 2012 00:55:33 +0100
From: 	Benoit Claise <[email-masked]>
To: 	[email-masked]

Dear all,

This is an automatically generated email.  It lists the IETF internet-drafts
that reference the PMOL RFC 6390, as a normative reference.

Regards, Benoit

===========================================================

draft-ietf-xrblock-rtcp-xr-discard-rle-metrics-04 Active

---

From: Al Morton <[email-masked]>
Date: Mon, 10 Dec 2012 21:32:42 -0500

Thanks, this should help when you configure as planned.

Al

At 07:07 PM 12/10/2012, Benoit Claise wrote:

Dear all,

ACTION Benoit: script to generate a weekly email with
drafts containing "performance metric", "6390",
etc..

---

From: Benoit Claise <[email-masked]>
Date: Tue, 11 Dec 2012 09:20:59 +0100

Alan DeKok will improve his script.
Two new feature requests will be implemented:
- the informative references addition
- keyword-based addition

This will be done in January. Thanks Alan.

Regards, Benoit

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Dec 2012 10:05:20 +0000

Hi,

I believe that adding informative references is very mandatory, otherwise relevant documents risk to be left out. 

Regards,

Dan

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Benoit Claise
> Sent: Tuesday, December 11, 2012 10:21 AM
> To: Al Morton
> Cc: Ron Bonica; [email-masked]; Alan DeKok
> Subject: Re: [pm-dir] Fwd: Performance metrics doctors generated email
> 
> _______________________________________________
> pm-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pm-dir

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Tue, 11 Dec 2012 10:16:39 +0000

I meant 'very desirable' - of course :-)

> Of Romascanu, Dan (Dan)
> Sent: Tuesday, December 11, 2012 12:05 PM
> To: Benoit Claise; Al Morton
> I believe that adding informative references is very mandatory,
> otherwise relevant documents risk to be left out.
> 
> Regards,
> 
> Dan
> 
> 
> 
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of Benoit Claise

---

From: Alan DeKok <[email-masked]>
Date: Tue, 11 Dec 2012 10:05:56 -0500

> I believe that adding informative references is very mandatory, otherwise relevant documents risk to be left out. 

  Added:

$ ./ietf-tech-report  -h
ietf-tech-report [-h] [-i] [-n] [-r LIST] [-W EXCLUDE]
   -h         print this message
   -i         include informative references, too
   -n         include normatice references (default)
   -r LIST    comma-separated list of key RFCs
   -W EXCLUDE comma-separated list of working groups to exclude

              See the file 'tech.txt' for more configuration

  The updated code is on github:

https://github.com/alandekok/ietf-tech-report

  Alan DeKok.