Subject: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 13 Sep 2017 12:31:15 -0500

Dear PM-Dir,

As the responsible AD for this draft, I'd like to request an RFC 6390
review for https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/.

The draft is in Last Call Requested state, with Last Call ending around
9-27-2017.

Please let me know if you need anything else, and thanks,

Spencer

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Sep 2017 17:49:17 +0000

Thank you for your request, Spencer.

Are there any volunteers to review this draft?

Al
pm-dir admin

From: pm-dir [mailto:[email-masked]] On Behalf Of Spencer Dawkins at IETF
Sent: Wednesday, September 13, 2017 1:31 PM
To: [email-masked]
Cc: Benoit Claise
Subject: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

Dear PM-Dir,

As the responsible AD for this draft, I'd like to request an RFC 6390 review for https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=kqJFJ9C8Msh8I6rl992a4ePZ8bFiEr0zXa4uhSm5bjw&s=FSox9TzwP1sgsegolaQeO-zCZlGONCwregid1rBRLFY&e=>.

The draft is in Last Call Requested state, with Last Call ending around 9-27-2017.

Spencer

---

From: Vinayak Hegde <[email-masked]>
Date: Thu, 14 Sep 2017 02:50:55 +0530

I am okay with doing it over the weekend.

Regards
Vinayak

On 13 Sep 2017 23:19, "MORTON, ALFRED C (AL)" <[email-masked]> wrote:

> *From:* pm-dir [mailto:[email-masked]] *On Behalf Of *Spencer
> Dawkins at IETF
> *Sent:* Wednesday, September 13, 2017 1:31 PM
> *To:* [email-masked]
> *Cc:* Benoit Claise
> *Subject:* [pm-dir] Request for RFC 6390 review of
> https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/
>
>
>
> Dear PM-Dir,
>
>
>
> review for https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=kqJFJ9C8Msh8I6rl992a4ePZ8bFiEr0zXa4uhSm5bjw&s=FSox9TzwP1sgsegolaQeO-zCZlGONCwregid1rBRLFY&e=>
> .
>
>
>
> _______________________________________________
> pm-dir mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pm-dir
>
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 13 Sep 2017 22:14:18 +0000

Thanks Vin! you have about two weeks till the
deadline in Spencer’s mail below.

@Spencer: Reviewer Assigned.
Al

From: Vinayak Hegde [mailto:[email-masked]]
Sent: Wednesday, September 13, 2017 5:21 PM
To: MORTON, ALFRED C (AL)
Cc: Spencer Dawkins at IETF; Benoit Claise; [email-masked]
Subject: Re: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

Regards
Vinayak

On 13 Sep 2017 23:19, "MORTON, ALFRED C (AL)" <[email-masked]<mailto:[email-masked]>> wrote:
Thank you for your request, Spencer.

Al
pm-dir admin

From: pm-dir [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Spencer Dawkins at IETF
Sent: Wednesday, September 13, 2017 1:31 PM
To: [email-masked]<mailto:[email-masked]>
Cc: Benoit Claise
Subject: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=C_01Pb4oiAlY20iYvBctcRrOSzBsM6NOlBXzTkP4-_M&s=61OThBXZMgAUpXHlmUHKOa0ahjYyrnak1PvyEitpjw0&e=>

Dear PM-Dir,

Spencer

_______________________________________________
pm-dir mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pm-dir<https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pm-2Ddir&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=C_01Pb4oiAlY20iYvBctcRrOSzBsM6NOlBXzTkP4-_M&s=-ssGmpIfbNAjupsk6L06-kQUp0L1Cv36LeLf-l4Ase4&e=>

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Wed, 13 Sep 2017 21:58:41 -0500

Hi, Al,

> deadline in Spencer’s mail below.

Thanks to the both of you!

Spencer

> *From:* Vinayak Hegde [mailto:[email-masked]]
> *Sent:* Wednesday, September 13, 2017 5:21 PM
> *To:* MORTON, ALFRED C (AL)
> *Cc:* Spencer Dawkins at IETF; Benoit Claise; [email-masked]
> *Subject:* Re: [pm-dir] Request for RFC 6390 review of
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=C_01Pb4oiAlY20iYvBctcRrOSzBsM6NOlBXzTkP4-_M&s=61OThBXZMgAUpXHlmUHKOa0ahjYyrnak1PvyEitpjw0&e=>
>
>
>
> Dear PM-Dir,
>
>
>
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pm-2Ddir&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=C_01Pb4oiAlY20iYvBctcRrOSzBsM6NOlBXzTkP4-_M&s=-ssGmpIfbNAjupsk6L06-kQUp0L1Cv36LeLf-l4Ase4&e=>
>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Sun, 24 Sep 2017 08:32:40 +0000

Hi Vin,
reminder for this review,
Al

From: Spencer Dawkins at IETF [mailto:[email-masked]]
Sent: Wednesday, September 13, 2017 10:59 PM
To: MORTON, ALFRED C (AL)
Cc: Vinayak Hegde; Benoit Claise; [email-masked]
Subject: Re: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/

Hi, Al,

On Wed, Sep 13, 2017 at 5:14 PM, MORTON, ALFRED C (AL) <[email-masked]<mailto:[email-masked]>> wrote:
Thanks Vin! you have about two weeks till the
deadline in Spencer’s mail below.

Spencer

From: Vinayak Hegde [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Wednesday, September 13, 2017 5:21 PM
To: MORTON, ALFRED C (AL)
Cc: Spencer Dawkins at IETF; Benoit Claise; [email-masked]<mailto:[email-masked]>
Subject: Re: [pm-dir] Request for RFC 6390 review of https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/<https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=lqCVNTxJzxSv6fDPhJ_7XO9WVkJedn6m08RcGsYjBfE&s=-usdGp4vmzmJO1h45IIrbPYNClyxhrJ3ioEe_gS9CvY&e=>

Regards
Vinayak

Al
pm-dir admin

Dear PM-Dir,

Spencer

---

From: Vinayak Hegde <[email-masked]>
Date: Sun, 24 Sep 2017 14:19:45 +0530

I will send this across in a few hours. On it

Regards
Vinayak

On 24 Sep 2017 14:03, "MORTON, ALFRED C (AL)" <[email-masked]> wrote:

> *From:* Spencer Dawkins at IETF [mailto:[email-masked]]
> *Sent:* Wednesday, September 13, 2017 10:59 PM
> *Cc:* Vinayak Hegde; Benoit Claise; [email-masked]
> <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_doc_draft-2Dietf-2Dippm-2Dalt-2Dmark_&d=DwMFaQ&c=LFYZ-o9_HUMeMTSQicvjIg&r=OfsSu8kTIltVyD1oL72cBw&m=lqCVNTxJzxSv6fDPhJ_7XO9WVkJedn6m08RcGsYjBfE&s=-usdGp4vmzmJO1h45IIrbPYNClyxhrJ3ioEe_gS9CvY&e=>
>
>
>

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 25 Sep 2017 03:02:43 +0530

I have done the review of the draft below as per RFC 6390

The RFC mostly conforms to the RFC 6390 recommended format (separately
noted in a section "8.  Compliance with RFC6390 guidelines"). There
are some small changes that might make the document more clear and
readable.

1. Define steady state explicitly - there is an attempt made though
noting that when the alternate color is being marked in the flow but
calling it out would make it clearer.

2. It might be useful to also explicitly state what the timeout should
be for marking the packet as marked. Currently it seems that it is
left as an exercise to the implementer of the draft. One way could be
to not consider the packets when the same colour is marked again on
the flow. The old packets of the same colour "expire" or are lost. For
example the draft recomends 5 min fr switching the colour. A similar
recommendation might be made for marking packets as lost after a
certain timeout (either as a percentage of the measurement period or a
flat time).

3. There are two sections - Normative and Informative. The draft
addresses the normative and informative parts except the verification
section of the informative part. If it is not applicable (may not be
possible to reproduce results for verification), then it should be
explicitly noted in the draft.

Regards
Vinayak

On Sun, Sep 24, 2017 at 2:02 PM, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> Subject: Re: [pm-dir] Request for RFC 6390 review of
> Subject: Re: [pm-dir] Request for RFC 6390 review of
> Subject: [pm-dir] Request for RFC 6390 review of
> As the responsible AD for this draft, I'd like to request an RFC 6390 review
> for https://datatracker.ietf.org/doc/draft-ietf-ippm-alt-mark/.
>
>
>