Subject: Re: [PMOL] Thoughts on how we operate as a Directorate

From: Carlos Pignataro <[email-masked]>
Date: Mon, 2 Apr 2012 14:15:05 +0200

No additional documents to review, but please find one comment inline.

On Mar 27, 2012, at 4:57 PM, Yaakov Stein wrote:

> Other than draft-tempia-opsawg-p3m, which we have discussed before, 
> I would suggest looking into the work proposed in MPLS on performance-based path selection 
> (e.g., draft-atlas-mpls-te-express-path).
> 
> Had we been ready earlier, we would have taken a look at what became
> RFC 6374 and 6375, but that is now water under the bridge.
> 
> I checked the OAM proposal in trill (draft-ietf-trill-rbridge-oam) 
> and it is pure FM OAM, with no PM features. At least for now.

Even though it is not in the documents, there were some discussions about passive performance metrics in OAM discussions (traceflow, IIRC even trill). So I think this is an area to snoop for how things progress.

Thanks,

-- Carlos.

> 
> Y(J)S
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Al Morton
> Sent: Tuesday, March 27, 2012 15:41
> To: Romascanu, Dan (Dan); [email-masked]
> Subject: Re: [PMOL] Thoughts on how we operate as a Directorate
> 
> At 11:49 AM 1/23/2012, Romascanu, Dan (Dan) wrote:
>> Probably going beyond the name of the document is desirable - looking
>> into the content for strings like 'performance metrics', 'performance
>> monitoring', etc. could reveal things that are missed by just scanning
>> the titles.
> 
> So, now that we've all had a chance to wade through docs in our
> normal working areas:
> 
> Has anyone seen a draft we should be reviewing/considering?
> 
> Let us all know, and we'll take the next steps,
> Al
> 
> 
> 
> _______________________________________________
> PMOL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pmol
> _______________________________________________
> PMOL mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pmol
>

---

From: Al Morton <[email-masked]>
Date: Mon, 02 Apr 2012 08:50:46 -0400

At 08:15 AM 4/2/2012, Carlos Pignataro wrote:
>...Even though it is not in the documents, there were some 
>discussions about passive performance metrics in OAM discussions 
>(traceflow, IIRC even trill). So I think this is an area to snoop 
>for how things progress.

I agree, is anyone following trill on a regular basis?

Nice work published on April 1st, Carlos!
Al

---

From: Yaakov Stein <[email-masked]>
Date: Mon, 2 Apr 2012 14:10:29 +0000

Carlos

Yes, I was afraid of that (which I why I said "At least for now").

We definitely have to follow this work.

Y(J)S

-----Original Message-----
From: Carlos Pignataro [mailto:[email-masked]] 
Sent: Monday, April 02, 2012 15:15
To: Yaakov Stein
Cc: Al Morton; Romascanu, Dan (Dan); [email-masked]
Subject: Re: [PMOL] Thoughts on how we operate as a Directorate

On Mar 27, 2012, at 4:57 PM, Yaakov Stein wrote:

> Other than draft-tempia-opsawg-p3m, which we have discussed before, I 
> would suggest looking into the work proposed in MPLS on 
> performance-based path selection (e.g., draft-atlas-mpls-te-express-path).
> 
> I checked the OAM proposal in trill (draft-ietf-trill-rbridge-oam) and 
> it is pure FM OAM, with no PM features. At least for now.

Thanks,

-- Carlos.

>> monitoring', etc. could reveal things that are missed by just 
>> scanning the titles.
> 
> So, now that we've all had a chance to wade through docs in our normal 
> working areas:
> 
> Let us all know, and we'll take the next steps, Al
> 
> 
>

---

From: Vinayak Hegde <[email-masked]>
Date: Mon, 9 Apr 2012 01:00:54 +0530

Comments on draft-tempia-opsawg-p3m
(http://datatracker.ietf.org/doc/draft-tempia-opsawg-p3m/)

These comments are for the -01 version on this draft.

1. Doesn't reference prior work in IPPM by RFC number (in the
References section). This is important as the approaches for passive
measurement seem to borrow heavily from the concepts of the IPPM
drafts (active measurements)

IPPM Delay http://tools.ietf.org/html/rfc2679
IPPM Loss http://tools.ietf.org/html/rfc2680

2. The draft does not take into out-of-order packet arrivals which is
possible in a real world scenario. Would the counters be updated or
how will they be switched off. Are there any conditions for timeouts.
If so, they are not explicitly mentioned.

3. Adding more implementation details of how colouring is done will be
done will help as it one of the main proposals of the draft. It has
not be covered in sufficient detail - only a few sentences mention
that certain DSCP bits be set but elsewhere the draft mentions that
several "colours" can be used in traffic flows.

4. In sections 6.3 monitoring nodes when there is periodic reading of
counters, it seems that the implicit upper bound on timeout of 5
minutes as counters are read every 5 minutes. Also there are time
synchnoisation issues when multiple intermediate elements are involved
in measurement.

5. The authors should elaborate on the data collection methods from
various routers since such measurements may be near real-time to
enable reactions from people monitoring the network. Scalability
concerns apply here when multiple monitoring nodes are needed.

Skipping the other draft as I do not know the nuances of underlying
protocols and it references other drafts which are also in transition.

Regards
Vinayak

On Tue, Mar 27, 2012 at 9:42 PM, Vinayak Hegde <[email-masked]> wrote:
> I can review both drafts by this weekend.
>
> Regards
> Vinayak
>
> On Tue, Mar 27, 2012 at 9:11 PM, Al Morton <[email-masked]> wrote:
>>
>> Any volunteers to review?
>>
>>
>>
>> At 10:57 AM 3/27/2012, Yaakov Stein wrote:
>>>

---

From: Al Morton <[email-masked]>
Date: Mon, 09 Apr 2012 10:03:38 -0400

Thanks, Vin!

I will forward your review to opsawg, and CC your address.

Al