Subject: [PMOL] Fwd: RMCAT

From: Al Morton <[email-masked]>
Date: Tue, 06 Nov 2012 11:16:32 -0500

PM Dir members,

FYI - Carlos Pignataro has volunteered to be our
Liaison/Advisor to the Network Complexity Research Group.
They will be working on metrics of network/configuration complexity
which should be a challenging topic.

In the message appended below, Lars Eggert has identified
work and a draft of potential interest to the PM Dir,
on evaluation metrics for congestion control of real-time media.

1- Do we have someone at IETF-85 who can attend rmcat this Thursday,
    and feedback info to the rest of the Directorate on metric development
   there?

2- Do we have a volunteer to review this work on an on-going basis?

I will look in on this myself too, but I plan to return home
to the "more-Sandy-than-usual" Jersey Shore on Thursday morning
to deal with additional issues there, so I'll miss rmcat this time.

thanks and regards,
Al
PM Dir admin

>X-Originating-IP: [135.31.41.113]
>X-IronPort-AV: E=Sophos;i="4.80,715,1344236400";
>    d="p7s'?scan'208";a="707204331"
>From: "Eggert, Lars" <[email-masked]>
>To: Al Morton <[email-masked]>
>CC: Mirja Kühlewind <[email-masked]>
>Subject: RMCAT
>Thread-Topic: RMCAT
>Thread-Index: AQHNu4BxAaAyiEzhrE2seqoTWOO2tQ==
>Date: Mon, 5 Nov 2012 18:06:51 +0000
>Accept-Language: en-US
>X-MS-Has-Attach: yes
>X-MS-TNEF-Correlator:
>x-originating-ip: [10.104.60.114]
>X-Spam: [F=0.0967741935; B=0.500(0); spf=0.500; 
>STSI=0.500(-49); STSM=0.300(-49); CM=0.500; 
>MH=0.500(2012110508); S=0.200(2010122901); SC=none]
>X-MAIL-FROM: <[email-masked]>
>X-SOURCE-IP: [216.240.18.37]
>X-AnalysisOut: [v=2.0 cv=PMy4D4WC c=1 sm=0 a=DIr8ZNXyXqu9Ub98gekLxA==:17 a]
>X-AnalysisOut: [=M9a1YIcYKwYA:10 a=2MUsH4NA2g4A:10 a=BLceEmwcHowA:10 a=JDj]
>X-AnalysisOut: [sHSkAAAAA:8 a=TA9xfephONY9FTyEowIA:9 a=CjuIK1q_8ugA:10 a=z]
>X-AnalysisOut: [CHD0xgTAAAA:8 a=aw9yd_vvCxrm4Rc-QgwA:9 a=ZVk8-NSrHBgA:10 a]
>X-AnalysisOut: [=dALb8cO8VnmdAbJO:21 a=qtuVMX0CIW0jGHo1:21]
>
>Hi Al,
>
>since you mentioned the metrics directorate 
>earlier today: RMCAT will likely work on 
>evaluation metrics for congestion control 
>mechanisms for realtime media. 
>draft-singh-rmcat-cc-eval is one draft in this 
>space. Not sure if this is of interest to the 
>directorate; just wanted to make sure its on your radar.
>
>Lars

---

From: Vinayak Hegde <[email-masked]>
Date: Thu, 8 Nov 2012 13:09:50 +0530

> to deal with additional issues there, so I'll miss rmcat this time.

I am not attending this meeting and the next one in person but I can
help review the drafts if they forward it to this list.

Regards
Vinayak

---

From: Al Morton <[email-masked]>
Date: Thu, 08 Nov 2012 09:39:48 -0500

Thanks Vin, there is at least one proposal
identified in my first message.

Al

---

From: Vinayak Hegde <[email-masked]>
Date: Sun, 11 Nov 2012 20:03:09 +0530

Draft comments for draft-singh-rmcat-cc-eval follow:

Draft Section 3 - Metrics

1. Can you please explain why each metric is relevant for congestion ?
For example

Delay can be caused due to buffer bloat or due to the underlying
(suboptimal) path that is taken. Both have different remedies.
Possibly add ways of finding out root cause for this.

2. Also how do you account for burstiness. Lots of packets arriving at
once with some having expired (arrived late) by the time of arrival.
How does this interplay with the User's experience of quality
(blockiness and jitter depending on how the codec works).

3. Also some of the metrics are interdependent. Packet loss and
discard rate can be made to approximate User's experience if we know
how the codec works (such as amount of robustness under packet loss)
and delay characteristics of the underlying streams (Such as busty
arrival of packets).

4. In the statistical measures - Standard deviation and variance might
also be useful in the context of interactive streams possibly to
measure possibility of interruptions in play (Directly correlates to
User's quality of experience).

4. Guidelines
Section 4.4 Diverse Environments
1. A minimum list of environment or simulations in which the algorithm
is recommended to be tested could be useful. Even more useful could be
setting min/max range limits for tests (such as delay/bandwidth). This
could closely model real network characteristics.

Section 4.8 Impact on Cross Traffic
How will you measure the impact of the RTP flows on competing TCP
flows. A list of metrics and/or examples would be useful.

General comments:
1. If any simulation/real world tests are carried out by network
equipment what are the standards that they should adhere to in terms
of delay (sensitivity) in counting / measuring.

Regards
Vinayak

---

From: "Eggert, Lars" <[email-masked]>
Date: Sun, 11 Nov 2012 14:39:51 +0000

Thanks for the detailed comments!

Lars