Subject: [ppsp] P2P-Next contribution to IETF PPSP WG discussion

From: Johan Pouwelse <[email-masked]>
Date: Fri, 8 Jul 2011 20:49:36 +0200

Dear PPSP people,

Hereby we would like to formally request a time slot at the upcoming
IETF meeting
to discuss our contribution of ideas plus running code to PPSP.

Our prior contribution to PPSP, focussed on the peer protocol:
https://datatracker.ietf.org/doc/draft-grishchenko-ppsp-swift/  (updated soon)
Software: https://github.com/gritzko/swift

In the role of scientific director I'm representing a large EU
research project. This project called P2P-Next has
considerable resources and involves 45 scientists/engineers at 19
organisations (BBC, STMicroelectronics, Pioneer, etc).
We are planning to attend the upcoming meeting in Canada with two people.
Over the past years we have:
 - created a team of experts combining: theory (SIGCOMM '11 publication)
   and implementation (LEDBAT in Linux kernel prototype)
 - running Open Source code of both live streaming and on-demand streaming
   http://spectrum.ieee.org/apr08/6119
 - tested in the wild using various field trials incuding 1080p video
   http://www.nytimes.com/external/gigaom/2009/12/05/05gigaom-bbc-and-p2p-next-test-hd-bittorrent-streaming-49840.html
 - Integrates with websites, deployed and operational at Wikipedia.org
   http://arstechnica.com/tech-policy/news/2010/09/wikipedia-now-distributes-its-videos-using-p2p.ars
 - Our proposal is specifically crafted for low-power and mobile environment.
   Operational on PCs, integrated in browsers (Windows,Mac,Linux),
settop boxes, smartphones and tablets.
   We have what we believe is currently the smallest footprint P2P
engine running on both Android and iPad (<100KByte).
   http://torrentfreak.com/pioneers-live-bittorrent-streaming-device-080911/
 - conducted our initial streaming trial two years ago; startup
streaming delay was measured to be 8.5 seconds.
   http://trial.p2p-next.org/stats/swarminfo.html
 - deployed our streaming technology to the living room of 100+
LivingLab volunteers
   http://livinglab.eu
 - ongoing work of Linux kernel module implementation of PPSP proposed
Libswift code
   https://p2p-next.cs.pub.ro/redmine/issues/22
 - LEDBAT-compliant implementation inside PPSP core
   http://doi.ieeecomputersociety.org/10.1109/AQTR.2010.5520827
 - Designed and prototype of extensions for Layered Video Coding,
   "An architecture for distributing scalable content over
peer-to-peer networks"
   www-itec.uni-klu.ac.at/publications/mmc/MMEDIA2010_p2p-next.pdf
 - Requirements doc states: "PPSP.PP.REQ-4: Streaming content availability
   update message among the peers MUST be supported by peer protocol."
   http://trac.tools.ietf.org/html/draft-ietf-ppsp-reqs-03#section-4.3
   Binmap are specificaly designed to be a superior datastructure when
   compared to traditional bitmaps, used for signalling chunk availability:
   http://bouillon.math.usu.ru/articles/binmaps-alenex.pdf
   We have efficient code for this datastructure:
https://github.com/the-zett/swift
-  We expanded our code with NAT traversal capability, based on an
extensive NAT box measurement:
   Measurement report http://pds.twi.tudelft.nl/reports/2010/PDS-2010-007.pdf
   Integrated NAT puncturing code: https://github.com/gphalkes/swift
-  "PPSP.SEC.REQ-1: PPSP MUST support closed swarms, where the peers
are authenticated."
   Design, Implementation and deployment of closed swarms with
restricted access for only authenticated peers:
   http://www.livinglab.eu/test.html
 - published all our software using LGPL license and authored numerous
scientific papers
   http://doi.ieeecomputersociety.org/10.1109/ISM.2009.16
   http://dx.doi.org/10.1109/P2P.2010.5569984
   https://publications.st.ewi.tudelft.nl/index.php?selectedPageId=list&topic=10&layout=brief

We are looking forward to any feedback you might have on the above and
hope to be discussing PPSP matters with you in Quebec.

Greetings from Holland,
 Dr. J.A. Pouwelse

---

From: "zhangyunfei" <[email-masked]>
Date: Sun, 10 Jul 2011 22:05:29 +0800

Hi Johan and P2P-Next guys,
   Firist of all welcome to join us together for making PPSP come true. I am very impressed by the fruits P2P-Next community brings out,esp. the running code and system in heterogenous environment including mobile networks and setbox terminals. 
    I see no reason not involving this presentation into PPSP session:)Would like to discuss more in the PPSP session based on the updated swift protocol, which is envisioned to be one proposal of PPSP peer protocol. 
    
BR
Yunfei

zhangyunfei
2011-07-10

发件人： Johan Pouwelse
发送时间： 2011-07-09 02:49:41
收件人： [email-masked]
抄送： 
主题： [ppsp] P2P-Next contribution to IETF PPSP WG discussion

Dear  PPSP  people,

In  the  role  of  scientific  director  I'm  representing  a  large  EU
research  project.  This  project  called  P2P-Next  has
considerable  resources  and  involves  45  scientists/engineers  at  19
organisations  (BBC,  STMicroelectronics,  Pioneer,  etc).
We  are  planning  to  attend  the  upcoming  meeting  in  Canada  with  two  people.
Over  the  past  years  we  have:
?  created  a  team  of  experts  combining:  theory  (SIGCOMM  '11  publication)
     and  implementation  (LEDBAT  in  Linux  kernel  prototype)
?  running  Open  Source  code  of  both  live  streaming  and  on-demand  streaming
?爃ttp://spectrum.ieee.org/apr08/6119
?  tested  in  the  wild  using  various  field  trials  incuding  1080p  video
?爃ttp://www.nytimes.com/external/gigaom/2009/12/05/05gigaom-bbc-and-p2p-next-test-hd-bittorrent-streaming-49840.html
?  Integrates  with  websites,  deployed  and  operational  at  Wikipedia.org
?爃ttp://arstechnica.com/tech-policy/news/2010/09/wikipedia-now-distributes-its-videos-using-p2p.ars
?  Our  proposal  is  specifically  crafted  for  low-power  and  mobile  environment.
     Operational  on  PCs,  integrated  in  browsers  (Windows,Mac,Linux),
settop  boxes,  smartphones  and  tablets.
     We  have  what  we  believe  is  currently  the  smallest  footprint  P2P
engine  running  on  both  Android  and  iPad  ( <100KByte).
?爃ttp://torrentfreak.com/pioneers-live-bittorrent-streaming-device-080911/
 -  conducted  our  initial  streaming  trial  two  years  ago;  startup
streaming  delay  was  measured  to  be  8.5  seconds.
     http://trial.p2p-next.org/stats/swarminfo.html
?  deployed  our  streaming  technology  to  the  living  room  of  100+
LivingLab  volunteers
?爃ttp://livinglab.eu
 -  ongoing  work  of  Linux  kernel  module  implementation  of  PPSP  proposed
Libswift  code
     https://p2p-next.cs.pub.ro/redmine/issues/22
?  LEDBAT-compliant  implementation  inside  PPSP  core
?爃ttp://doi.ieeecomputersociety.org/10.1109/AQTR.2010.5520827
 -  Designed  and  prototype  of  extensions  for  Layered  Video  Coding,
     "An  architecture  for  distributing  scalable  content  over
peer-to-peer  networks"
     www-itec.uni-klu.ac.at/publications/mmc/MMEDIA2010_p2p-next.pdf
 -  Requirements  doc  states:  "PPSP.PP.REQ-4:  Streaming  content  availability
     update  message  among  the  peers  MUST  be  supported  by  peer  protocol."
     http://trac.tools.ietf.org/html/draft-ietf-ppsp-reqs-03#section-4.3
     Binmap  are  specificaly  designed  to  be  a  superior  datastructure  when
     compared  to  traditional  bitmaps,  used  for  signalling  chunk  availability:
     http://bouillon.math.usu.ru/articles/binmaps-alenex.pdf
     We  have  efficient  code  for  this  datastructure:
https://github.com/the-zett/swift
-    We  expanded  our  code  with  NAT  traversal  capability,  based  on  an
extensive  NAT  box  measurement:
     Measurement  report  http://pds.twi.tudelft.nl/reports/2010/PDS-2010-007.pdf
     Integrated  NAT  puncturing  code:  https://github.com/gphalkes/swift
-    "PPSP.SEC.REQ-1:  PPSP  MUST  support  closed  swarms,  where  the  peers
are  authenticated."
     Design,  Implementation  and  deployment  of  closed  swarms  with
restricted  access  for  only  authenticated  peers:
     http://www.livinglab.eu/test.html
?  published  all  our  software  using  LGPL  license  and  authored  numerous
scientific  papers
?爃ttp://doi.ieeecomputersociety.org/10.1109/ISM.2009.16
?爃ttp://dx.doi.org/10.1109/P2P.2010.5569984
?爃ttps://publications.st.ewi.tudelft.nl/index.php?selectedPageId=list&topic=10&layout=brief

Greetings  from  Holland,
燚r.  J.A.  Pouwelse
_______________________________________________
ppsp  mailing  list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp