Subject: [ppsp] re-charter issue discussion(cont'):transport mechanism

From: zhangyunfei <[email-masked]>
Date: Fri, 30 Mar 2012 16:53:02 +0800

Hi all,
     To continue the re-charter discussion in PPSP WG meeting, I would like to discuss more on the transport mechanism issue.
     I happen to know in RTCWeb, the transport protocol between two peer browsers seems to been decided: For media part, srtp/rtp over UDP(I am not quite sure of if it is accurate).  For data transmit, Datagrams over SCTP over DTLS over UDP.
       My question is: If this related to PPSP transport mechanism? Or totally two different things?Any different requirements? Just to provide such info to incur discussion.

BR
Yunfei

zhangyunfei

---

From: ZongNing <[email-masked]>
Date: Fri, 30 Mar 2012 09:50:24 +0000

Hi, Yunfei,

I think it is related if RTCWeb includes the scenario of one browser streaming video to others by using P2P way.

Also start discussing P2P use case in RTCWeb (or discussing web-brower usage in PPSP) might be interesting.

-Ning

________________________________
From: [email-masked] [[email-masked]] on behalf of zhangyunfei [[email-masked]]
Sent: Friday, March 30, 2012 4:53 PM
To: ppsp
Subject: [ppsp] re-charter issue discussion(cont'):transport mechanism

Hi all,

BR
Yunfei

________________________________
zhangyunfei

---

From: zhangyunfei <[email-masked]>
Date: Fri, 30 Mar 2012 18:06:12 +0800

I think in RTCWeb they are indeed discussing the peer browser scenarios. But I guess this is not a large scale P2P usage, aka, some tens is already a very large amount in RTCweb(like conferencening).

BR
Yunfei

zhangyunfei

From: ZongNing
Date: 2012-03-30 17:50
To: zhangyunfei; ppsp
Subject: RE: [ppsp] re-charter issue discussion(cont'):transport mechanism
Hi, Yunfei,

-Ning

Hi all,

BR
Yunfei

zhangyunfei

---

From: "Y. Richard Yang" <[email-masked]>
Date: Fri, 30 Mar 2012 14:52:21 -0400

Hi all,

I consider browsers as one major platform for the deployment of P2P 
streaming clients. We have a browser (Flash based though) P2P streaming 
system, and recent large trial experiences are quite positive. So I 
support that if PPSP can use RTCWeb transport, it is a good plus.

Richard

On 3/30/12 6:06 AM, zhangyunfei wrote:
> I think in RTCWeb they are indeed discussing the peer browser 
> scenarios. But I guess this is not a large scale P2P usage, aka, some 
> tens is already a very large amount in RTCweb(like conferencening).
> BR
> Yunfei
> ------------------------------------------------------------------------
> zhangyunfei
> *From:* ZongNing <mailto:[email-masked]>
> *Date:* 2012-03-30 17:50
> *To:* zhangyunfei <mailto:[email-masked]>; ppsp 
> <mailto:[email-masked]>
> *Subject:* RE: [ppsp] re-charter issue discussion(cont'):transport 
> mechanism
>
> Hi, Yunfei,
>
> I think it is related if RTCWeb includes the scenario of one 
> browser streaming video to others by using P2P way.
>
> ------------------------------------------------------------------------
> *From:* [email-masked] [[email-masked]] on behalf of 
> zhangyunfei [[email-masked]]
> *Sent:* Friday, March 30, 2012 4:53 PM
> *To:* ppsp
> *Subject:* [ppsp] re-charter issue discussion(cont'):transport mechanism
>
> Hi all,
>      To continue the re-charter discussion in PPSP WG meeting, I would 
> like to discuss more on the transport mechanism issue.
>      I happen to know in RTCWeb, the transport protocol between two 
> peer browsers seems to been decided: For media part, srtp/rtp over 
> UDP(I am not quite sure of if it is accurate).  For data transmit, 
> Datagrams over SCTP over DTLS over UDP.
> My question is: If this related to PPSP transport mechanism? Or 
> totally two different things?Any different requirements? Just to 
> provide such info to incur discussion.
> BR
> Yunfei
> ------------------------------------------------------------------------
> zhangyunfei
>
>
> _______________________________________________
> ppsp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ppsp