Subject: [ppsp] I-D Action: draft-ietf-ppsp-peer-protocol-02.txt

From: [email-masked]
Date: Tue, 19 Jun 2012 23:04:16 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Peer to Peer Streaming Protocol Working Group of the IETF.

	Title           : Peer-to-Peer Streaming Peer Protocol (PPSPP)
	Author(s)       : Arno Bakker
                          Riccardo Petrocco
	Filename        : draft-ietf-ppsp-peer-protocol-02.txt
	Pages           : 56
	Date            : 2012-06-19

Abstract:
   The Peer-to-Peer Streaming Peer Protocol (PPSPP) is a peer-to-peer
   based transport protocol for content dissemination.  It can be used
   for streaming on-demand and live video content, as well as
   conventional downloading.  In PPSPP, the clients consuming the
   content participate in the dissemination by forwarding the content to
   other clients via a mesh-like structure.  It is a generic protocol
   which can run directly on top of UDP, TCP, or as a RTP profile.
   Features of PPSPP are short time-till-playback and extensibility.
   Hence, it can use different mechanisms to prevent freeriding, and
   work with different peer discovery schemes (centralized trackers or
   Distributed Hash Tables).  Depending on the underlying transport
   protocol, PPSPP can also use different congestion control algorithms,
   such as LEDBAT, and offer transparent NAT traversal.  Finally, PPSPP
   maintains only a small amount of state per peer and detects malicious
   modification of content.  This documents describes PPSPP and how it
   satisfies the requirements for the IETF Peer-to-Peer Streaming
   Protocol (PPSP) Working Group's peer protocol.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-ppsp-peer-protocol

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-ppsp-peer-protocol-02

A diff from previous version is available at:
http://tools.ietf.org/rfcdiff?url2=draft-ietf-ppsp-peer-protocol-02

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: zhangyunfei <[email-masked]>
Date: Wed, 20 Jun 2012 15:09:25 +0800

Hi Arno and Riccardo (Speaking individually),
    Due to a following holiday started from tomorrow, I have a quick read on the draft. The following is my comments. I'll reply the emails until next week.

1) In general, this version is much better than last version in the sense of an IETF draft, instead of a paper or a technical report for the implementation. I mean the generality is better.
2)  bin numbers in 1st paragraph: Since there are at least two schemes introduced in section 4, the range scheme should be stated here as well.
3)Merkle hash tree in section 2.2：Occur for the first time without explaining before.It's better to add the term in section 1.3.
4)INTEGRITY in section 2.2: It should be stated that this message is not used all the time.
5)Section3.3： The sentence "it MUST send a ACK message containing a chunk specification for C". MUST or SHOULD.
6)Section 3.9, since TCP is abandoned by PPSPP, do we need to explain the related case?
7)  Section 4.3 PEX_ADD, no explanation before.
8)Section 6: I suggest to exclude this section  because it involves a over-strong limitation:fixed chunk size.Furthermore I am not clear of the necessity of this scheme.Just as the background of section 7?
9) Section 7:for the similar reason, remove the section 7.1.1
10)Section 9.3.2, why placed here? I suggest to remove this section. 

BR
Yunfei

zhangyunfei

From: internet-drafts
Date: 2012-06-20 14:04
To: i-d-announce
CC: ppsp
Subject: [ppsp] I-D Action: draft-ietf-ppsp-peer-protocol-02.txt

Abstract:

_______________________________________________
ppsp mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ppsp