Subject: Re: [ppsp] Feedback on Errata for RFC 7574, "Peer-to-Peer Streaming Peer Protocol (PPSPP)"

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 9 Mar 2017 09:33:45 -0600

Hi, Riccardo,

On Wed, Feb 8, 2017 at 9:11 AM, Spencer Dawkins at IETF <
[email-masked]> wrote:

> Hi, Riccardo,
>
> On Wed, Feb 8, 2017 at 9:10 AM, Riccardo Petrocco <[email-masked]>
> wrote:
>
>> Dear Spencer,
>>
>> Thank you for for keeping us updated on the progress.
>> I'll try to go over the feedback, and come back with my thoughts.
>>
>
Have you had an opportunity to look at these errata yet?

Thanks,

Spencer

>
> Thanks!
>
> Spencer
>
>
>> Have a nice day,
>> Riccardo Petrocco
>>
>> 2017-02-08 16:01 GMT+01:00 Spencer Dawkins at IETF <
>> [email-masked]>:
>>
>>> Dear PPSPers,
>>>
>>> We've had implementers for your RFC, which is good, and some feedback
>>> from them, filed in the IETF Errata system.
>>>
>>> We'd like your thoughts on these three errata, so we'll know what to do
>>> with them. If the resolutions are approved, other implementers will have an
>>> easier time in their work.
>>>
>>> The errata are available at https://www.rfc-editor.org/
>>> errata_search.php?rfc=7574.
>>>
>>> We thank you for your help.
>>>
>>> Spencer Dawkins, TSV Area Director
>>>
>>> _______________________________________________
>>> ppsp mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/ppsp
>>>
>>>
>>
>

---

From: Victor Grishchenko <[email-masked]>
Date: Fri, 24 Mar 2017 16:15:29 +0100

I generally support Mr Kim and Mr Lee. That no-protection option is
not well defined and better be removed. We need integrity protection
just to store data locally. That way, we protect it from disk
corruptions/failures.

I believe that no-protection is an unnecessary optimization. After
all, an optimistic receiver may not check those hashes to speed things
up.

By the way, the DAT project made some use of the RFC.
https://datproject.org

On 9 March 2017 at 16:33, Spencer Dawkins at IETF
<[email-masked]> wrote:
> Hi, Riccardo,
>
> On Wed, Feb 8, 2017 at 9:11 AM, Spencer Dawkins at IETF
> <[email-masked]> wrote:
>>
>> Hi, Riccardo,
>>
>>> 2017-02-08 16:01 GMT+01:00 Spencer Dawkins at IETF
>>> <[email-masked]>:
>>>>
>>>> Dear PPSPers,
>>>>
>>>> The errata are available at
>>>> https://www.rfc-editor.org/errata_search.php?rfc=7574.
>>>>

-- 
Victor