Subject: [quicwg/base-drafts] TLS interface overview (#30)

From: Martin Thomson <[email-masked]>
Date: Sun, 27 Nov 2016 19:58:16 -0800

This PR attempts to do a few things:

1. Remove the QUIC structural diagram.  That belongs in the main spec, if anywhere.

2. Add some basic material on TLS.

3. Expand on the interface between QUIC (the transport pieces) and TLS.  In the process, hopefully make it clear that this document is talking about the QUIC and interface-y pieces.  I'll likely need more on this later, but it's a start.

I haven't touched later sections of the document; this concentrates on introductory material only.  As a result, there is an inconsistency where this talks about the solution to #27 as though it were fixed.  I plan to add that fix in the next PR, but it was pointless doing the text twice: once as though that fix wasn't coming and again with a fix.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/30

-- Commit Summary --

  * Work in progress: Improving the quality of the TLS overview
  * Adding details of the interaction between QUIC and TLS
  * Refinement of delivery requirements

-- File Changes --

    M draft-ietf-quic-tls.md (346)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/30.patch
https://github.com/quicwg/base-drafts/pull/30.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30

---

From: Martin Thomson <[email-masked]>
Date: Sun, 27 Nov 2016 20:43:17 -0800

@martinthomson pushed 2 commits.

17ab6f8  Fix ignore
474b579  Fix client's second phase

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/9155bd97c3018e34c42839213cfe66b71f36c72a..474b579e76beaf1d2c8c05429e220d0526617a45

---

From: Martin Thomson <[email-masked]>
Date: Sun, 27 Nov 2016 21:15:10 -0800

@martinthomson pushed 1 commit.

577d8df  Expand on retransmission of handshake messages

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/474b579e76beaf1d2c8c05429e220d0526617a45..577d8df8f5216a18b94497cd449056b8cb688397

---

From: Martin Thomson <[email-masked]>
Date: Sun, 27 Nov 2016 22:02:57 -0800

31eaab6  Make it clearer what keys are used for which in packet protection
ef666a9  Pre-handshake clarifications

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/577d8df8f5216a18b94497cd449056b8cb688397..ef666a931b8e39e96f574ba1ef242e0c125b9c67