Subject: [quicwg/base-drafts] How big can a server's first flight be (#38)

From: Martin Thomson <[email-masked]>
Date: Sun, 27 Nov 2016 22:17:32 -0800

... relative to the client's ClientHello.

We don't want to design a packet amplifier, but it's highly likely that the server's Certificate will cause the server's messages to be at least a little bigger than the initial messages from the client.  We do need servers to send HelloRetryRequest and do source address validation, but how often?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/38

---

From: ianswett <[email-masked]>
Date: Tue, 29 Nov 2016 13:14:06 -0800

I'm not sure how we could come up with a good one-size fits all limit.  Different deployment environments may be more or less capable of generating amplification attacks.  There are things we can do with the design of QUIC, such as add the ability to pair a connection id to a resumption token, to make these less practical.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/38#issuecomment-263700714