Subject: [quicwg/base-drafts] Updating transport parameters (#50)

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Nov 2016 18:21:34 -0800

In h2, we were able to update transport-y parameters like flow control window and number of streams.  If we adopt a TLS extension for negotiating/advertising these, that means we can't update them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50

---

From: ianswett <[email-masked]>
Date: Wed, 30 Nov 2016 05:45:57 -0800

For flow control, it makes sense to have an initial value in the handshake and then use the flow control frames to manage the window.

For max number of streams and similar things, I expected we'd support the SETTINGS frame, but that would be specified in the HTTP doc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/50#issuecomment-263876754