Subject: [quicwg/base-drafts] Move ALPN information to HTTP mapping (#13)

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Nov 2016 18:08:38 -0800

The TLS document doesn't really need to include this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/13

---

From: MikeBishop <[email-masked]>
Date: Tue, 29 Nov 2016 13:32:53 -0800

Touches on #44 and #45.  Does the HTTP mapping need to require that the crypto protocol be TLS?  If not, how does it know that ALPN in particular will be used?  It would just specify that the negotiated protocol should be "http/q" or whatever we wind up calling it.

I think where this leads me is that one of the requirements of the crypto handshake protocol is application-layer protocol negotiation, which the TLS mapping will satisfy by using the ALPN extension.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/13#issuecomment-263705732