Subject: [quicwg/base-drafts] Eliminating double-muxing (#71)

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Dec 2016 13:09:09 -0800

This pull request changes the current document substantially, with the following major points of change:

- The HTTP/2 outer frame containing the stream number is replaced with a (otherwise similar) frame format that doesn't contain a stream number.  All stream management is delegated to QUIC.
- HTTP exchanges take up two streams per request/response -- one for data, one for everything else (but mostly headers).  This permits retaining the current behavior (also from HTTP/2) of not flow-controlling non-DATA traffic, and avoids double-framing bodies.
- HPACK frames acquire sequence numbers to enable ordering at the decoder.  This is decidedly suboptimal, but no worse than current and allows us to keep moving and leave the potential redesign of HPACK for the future.

It may be more useful to look at the [final content](https://quicwg.github.io/base-drafts/http-unstraddled/draft-ietf-quic-http.html) rather than the diff -- in places, GitHub isn't finding enough of the retained text to make the diff sensible.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/71

-- Commit Summary --

  * HTTP over QUIC, not HTTP/2 over QUIC
  * Moving to a two-stream mapping with HPACK sequence numbers.
  * Fixing references.

-- File Changes --

    M draft-ietf-quic-http.md (583)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/71.patch
https://github.com/quicwg/base-drafts/pull/71.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/71

---

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Dec 2016 13:33:25 -0800

@MikeBishop pushed 1 commit.

49edae3  Minor tpyos

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/71/files/e1a8753a8a1ca6643eb806e1048245fb8fe74d2b..49edae3afedf63c33e900646511296b2bd7ff3ff

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Dec 2016 12:56:36 -0800

@MikeBishop pushed 2 commits.

dddbdb8  PRIORITY has to be on control stream.
c2823e8  Exempt from connection-level flow control isn't exempt from *all* flow control.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/71/files/49edae3afedf63c33e900646511296b2bd7ff3ff..c2823e8bb20aa0d3ee03ad4adf4c1ce053796b9c

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Dec 2016 13:41:14 -0800

77b11b3  Fixing priority reference again.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/71/files/03c8ac6899596229cfe067a597361105d46d0f95..77b11b313106371a6da89234576df61189ef22ec

---

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Dec 2016 16:09:34 -0800

0fcaaeb  CONTINUATION, IANA

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/71/files/77b11b313106371a6da89234576df61189ef22ec..0fcaaeb224c68a66e21bd7791601e7979b5a4cea

---

From: Mike Bishop <[email-masked]>
Date: Thu, 08 Dec 2016 09:50:58 -0800

Merged #71.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/71#event-887229735