Subject: [quicwg/base-drafts] Add ECN to the recovery and transport drafts (#68)

From: ianswett <[email-masked]>
Date: Sat, 03 Dec 2016 07:38:48 -0800

ECN is not currently mentioned in the recovery draft, but it should be included.

More importantly, the transport draft has no ability for the peer to communicate ECN marks back to the sender.  I suspect, like ECN, the use of this in the transport would be negotiable in the QUIC handshake.

In practice, there most userspace network stacks also cannot see if those marks are set when packets are read.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/68

---

From: IngJohEricsson <[email-masked]>
Date: Mon, 05 Dec 2016 01:14:19 -0800

The specific items that are needed are (perhaps more ?)
+ ECN echo in protocol, preferrably as a mandatory to implement part, RFC7560 can provide with valuable input in the design
+ ECN negotiation, the work on updated ECN semanticts in TSVWG should be addressed (L4S support)
+ Fallback for in various failure cases, and RFC6679 and draft-kuehlewind-tcpm-ecn-fallback-01 may provide input
+ Address user space limitation, collect best current practice to read/write ECN bits for different OS.
+ Align meaning of ECN-CE marking of ECT(0) and ECT(1) traffic with TSVWG

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/68#issuecomment-264802339