Subject: Re: [quicwg/base-drafts] TLS interface overview (#30)

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Dec 2016 16:24:54 -0800

MikeBishop commented on this pull request.

 The words "MUST", "MUST NOT", "SHOULD", and "MAY" are used in this document.
 It's not shouting; when they are capitalized, they have the special meaning
 defined in {{!RFC2119}}.
 
+This document uses the terminology established in {{QUIC-TRANSPORT}}.
+
+For brevity, the acronym TLS is used to refer to TLS 1.3.
+
+This document uses TLS terminology is used when referring to parts of TLS.

I think two possible phrasings are combined here.  "This document uses TLS terminology" / "TLS terminology is used" -- but not both.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30#pullrequestreview-11927378

---

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Dec 2016 16:29:14 -0800

> @@ -226,24 +259,29 @@ document:
 
 # TLS in Stream 1
 
-QUIC completes its cryptographic handshake on stream 1, which means that the
-negotiation of keying material happens after the QUIC protocol has started.
-This simplifies the use of TLS since QUIC is able to ensure that the TLS
-handshake packets are delivered reliably and in order.
+QUIC reserves stream 1 for a TLS connection.  Stream contains a complete TLS

"Stream 1" or "This stream", not "Stream"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30#pullrequestreview-11927858

---

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Dec 2016 16:37:46 -0800

> +Additional functions might be needed to configure TLS.
+
+
+### Handshake Interface
+
+In order to drive the handshake, TLS depends on being able to send and receive
+handshake messages on stream 1.  There are two basic functions on this
+interface: one where QUIC requests handshake messages and one where QUIC
+provides handshake packets.
+
+A QUIC client starts TLS by requesting TLS handshake octets from
+TLS.  The client acquires handshake octets before sending its first packet.
+
+A QUIC server starts the process by providing TLS with any stream 1 octets that
+might have arrived.  Only in-sequence packets are delivered; packets that arrive
+out of order are buffered by QUIC until all preceding packets are available.

Should this be "frames"?  Packets might be lost and retransmitted, so you wouldn't necessarily have preceding packets becoming available.  (Not including in the purely-editorial commit I'm preparing, because I'm not certain if that's the correct wording.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30#pullrequestreview-11928784

---

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Dec 2016 16:48:13 -0800

@MikeBishop pushed 1 commit.

035b6b5  Contributing editorial fixes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/ef666a931b8e39e96f574ba1ef242e0c125b9c67..035b6b515bc29466370329acd04288c592c2e591

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Dec 2016 18:44:53 -0800

martinthomson commented on this pull request.

+
+
+### Handshake Interface
+

I think that it's even more granular: the data that is in the frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Dec 2016 18:45:10 -0800

@martinthomson pushed 1 commit.

d2956b8  QUIC delivers data to TLS

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/035b6b515bc29466370329acd04288c592c2e591..d2956b87358a0363c5673cf4802940e72bc3f5f9

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Dec 2016 18:50:46 -0800

4188b83  More precise talk about TLS data exchange

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/30/files/d2956b87358a0363c5673cf4802940e72bc3f5f9..4188b83053fe6ac21b314a06c9cbcf7fd6d840b0

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Dec 2016 15:58:49 -0800

Merged #30.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/30#event-889097746