Subject: [quicwg/base-drafts] Consider moving ACK/STOP_WAITING into the packet header (#70)

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Dec 2016 11:02:38 -0800

Mirja Kühlewind points out that multiple ACK frames per packet don't really make sense, and they aren't retransmittable.  Instead, Mirja suggests replacing the ACK frame with an optional region in the packet header and a bit indicating its presence.  STOP_WAITING, already a candidate for removal (#66), could be consolidated here as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/70

---

From: ianswett <[email-masked]>
Date: Mon, 05 Dec 2016 11:06:54 -0800

Could you clarify what you mean by packet header?  There is currently no encrypted packet header, so we'd have to create one in order to place the ack frame there.  I'll point out two connection close frames in a packet make even less sense.  Or PING frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/70#issuecomment-264945336

---

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Dec 2016 11:12:38 -0800

And I think that's the distinction.  If we had an encrypted header region, it could logically hold a lot of the connection-level information.  Of course, if we allow that set of stuff to be extensible, it could wind up looking a lot like frames.  ;-)  Updating the title to better reflect the suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/70#issuecomment-264946933