Subject: Re: [quicwg/base-drafts] Alt-Svc text -- starts to address #87 (f324fd9)

From: Lucas Pardue <[email-masked]>
Date: Mon, 19 Dec 2016 06:43:13 -0800

{{?RFC7301}} is a typo for {{!RFC7301}}?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/f324fd9b15408e3c6e74fba44448e6089aecde9a#commitcomment-20233435

---

From: Mike Bishop <[email-masked]>
Date: Tue, 20 Dec 2016 09:19:19 -0800

No, intentional, though I'm borderline.  QUIC doesn't actually *require* the use of ALPN.  QUIC requires that the crypto handshake, whatever it might be, provide application-level protocol negotiation capabilities.  When using TLS 1.3 as the crypto protocol, ALPN is used to satisfy this requirement.

So while HTTP/QUIC specifies a token to be used, and registers it *in case* you're using it with ALPN, a different crypto handshake could use a different negotiation protocol with a different registry and still work with HTTP/QUIC.  ALPN itself isn't a hard requirement to implement HTTP/QUIC, which to me says non-normative.

But practically, we have no other crypto protocol currently defined and we're strongly assuming the use ALPN, so it's... *nearly* normative.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/f324fd9b15408e3c6e74fba44448e6089aecde9a#commitcomment-20249710