Subject: [quicwg/base-drafts] Specify the minimum packet size required for QUIC (#69)

From: ianswett <[email-masked]>
Date: Sat, 03 Dec 2016 13:57:27 -0800

Issue #64 brought up PTUMD, which brought up the issue of minimum packet size.

Stateless rejects require the CHLO to fit into one packet, so the minimum should be specified with that in mind.

#64 also brought up the issue of downgrade attacks, and given the vast majority of paths permit 1200 bytes, we should be able to agree on a reasonable(ie: >1k) minimum size.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/69

---

From: martinduke <[email-masked]>
Date: Tue, 13 Dec 2016 14:43:01 -0800

I fully support a relatively large minimum packet size for QUIC. It massively mitigates the downside of some MTU-based attacks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/69#issuecomment-266885816

---

From: martinduke <[email-masked]>
Date: Wed, 28 Dec 2016 12:42:55 -0800

The other question here is, "what do we do if the reported path MTU is less than the minimum?" I think the answer is to simply ignore the lower MTU and keep sending big packets, even if that causes fragmentation. The alternative is to have an ICMP packet that can force TCP failover.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/69#issuecomment-269537900