Subject: [quicwg/base-drafts] Cancellation of requests with (partial) responses (#756)

From: Martin Thomson <[email-masked]>
Date: Sun, 03 Sep 2017 19:03:44 -0700

We should be a lot clearer about what it means to receive HTTP_REQUEST_CANCELLED for a stream where part of the response was received.  What if you receive (in the same packet even) a STREAM frame containing the headers block and a 200 status code, followed by a cancellation of that stream?

This also applies to GOAWAY, which implicitly sends HTTP_REQUEST_CANCELLED for all requests with stream ID > N.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/756

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Sep 2017 12:23:43 -0700

#770 appears to cover this as well, though the part about CANCELLED should perhaps move elsewhere in the doc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/756#issuecomment-328632477