Subject: [quicwg/base-drafts] Explain reason for having connection limits (#796)

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 25 Sep 2017 20:01:29 -0700

The lifetime of a connection and the amount of data that can be transferred thereon are limited because the packet numbers, connection byte offsets, and stream byte offsets all have maximum values.  The draft should address the reason(s) why there are maximum values at all.

I raised this issue on the mailing list twice, but received no answers:

https://www.ietf.org/mail-archive/web/quic/current/msg02144.html
https://www.ietf.org/mail-archive/web/quic/current/msg02251.html

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Sep 2017 05:07:45 +0000 (UTC)

To be fair, you received answers, but you didn't like those answers.  I'm not defending those answers, they are somewhat arbitrary, but I think that the onus is on you not to question that they have limits, but to motivate a change.  Do you have a specific change in mind?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332087684

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 26 Sep 2017 11:56:36 +0000 (UTC)

That is incorrect: the question _Why is connection lifetime limited?_ has not been answered.

I do have a specific change in mind: take the answer to the question above and put it into the draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332175364

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Sep 2017 00:45:47 +0000 (UTC)

The answer was: because those various numbers have maximums.  That is in the draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332376003

---

From: MikkelFJ <[email-masked]>
Date: Tue, 26 Sep 2017 23:17:49 -0700

It would also be possible to wrap 128-bit bumbers, which are practically unbounded, similar to how packet numbers are truncated on wire. So it must be an implementation complexity tradeoff or a technical difficulty in resolving representational conflicts, or a yagni.

________________________________
From: Martin Thomson <[email-masked]>
Sent: Wednesday, September 27, 2017 2:45:44 AM
To: quicwg/base-drafts
Cc: Subscribed
Subject: Re: [quicwg/base-drafts] Explain reason for having connection limits (#796)

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/796#issuecomment-332376003>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AALzN2cu8Mpg3lsyKXemX3Wks9ZD2F85ks5smZq4gaJpZM4PjnCs>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332420319

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 Sep 2017 10:00:03 +0000 (UTC)

> The answer was: because those various numbers have maximums. That is in the draft.

@martinthomson, the fact that a number representation has a maximum not cause TCP to abort a connection after 2^32 bytes have been sent.  I think the reason must be something else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332472595

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 Sep 2017 03:02:31 -0700

@mikkelfj, I agree with your analysis.  (For my money, a 64-bit number is practically unbounded as well.)  What I am proposing is that this verbiage or something to that effect -- _practical considerations... blah-blah-blah_ -- be put into the draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332473219

---

From: Ryan Hamilton <[email-masked]>
Date: Wed, 27 Sep 2017 13:55:34 +0000 (UTC)

How 'bout sending out a PR.

On Wed, Sep 27, 2017 at 3:02 AM, Dmitri Tikhonov <[email-masked]>
wrote:

> @mikkelfj <https://github.com/mikkelfj>, I agree with your analysis. (For
> my money, a 64-bit number is practically unbounded as well.) What I am
> proposing is that this verbiage or something to that effect -- *practical
> considerations... blah-blah-blah* -- be put into the draft.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/796#issuecomment-332473219>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ASp6yrXZk9XMyhYGQ1L2MmEYTjQ3rRl5ks5smh03gaJpZM4PjnCs>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/796#issuecomment-332528840