Subject: [quicwg/base-drafts] Streams start as "idle" (#778)

From: ekr <[email-masked]>
Date: Mon, 18 Sep 2017 12:58:36 -0700

There are two ways of thinking about streams:

1. All 2^32 streams exist but are in the IDLE state and transition to other states when messages are received/sent on them.
2. Streams are created when the aforementioned messages are received/sent.

The document is kind of agnostic on this, talking about them as being in IDLE (the state machine) but also talking about streams being created:

```
   A QUIC endpoint cannot reuse a Stream ID.  Streams MUST be created in
   sequential order.  Open streams can be used in any order.  Streams
```

I tend to think that it would be better to talk about streams being created and remove the IDLE state, but in any case it would be good if the draft were consistent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/778

---

From: ianswett <[email-masked]>
Date: Mon, 18 Sep 2017 13:11:12 -0700

Streams being created better matches the way they're managed in data structures, so I would tend to favor that as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/778#issuecomment-330341778