Subject: [quicwg/base-drafts] ECN echo in ACK frame or as separate frame (#804)

From: IngJohEricsson <[email-masked]>
Date: Thu, 28 Sep 2017 12:16:49 +0000 (UTC)

There has been discussion wether the ECN indication (or echo) should be included in the ACK frame or in a separate dedicated frame. 
Proponents of a dedicated ECN frame argue that adding extra ECN info in the ACK frame can increase the complexity of the ACK frame encoding and parsing. Ian Swett however as a very strong point in his remark that ECN in a separate frame can give additional issues in the congestion control functionality, in other words, what we save (in complexity) in one part of the chain can cause extra cost and in the worst case incomprehensible code in another part of the chain. 
My personal opinion is that it is best to have ECN in the ACK frame

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/804

---

From: Brian Trammell <[email-masked]>
Date: Thu, 28 Sep 2017 14:54:30 +0000 (UTC)

+1 to ECN in ACK for Ian's reasons.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/804#issuecomment-332862482