Subject: Re: [quicwg/base-drafts] IP Anycast with server IP+Port renegotiation (#560)

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 11:51:38 -0700

This is definitely valuable.

In the short term, I'd expect most users to migrate at the end of the handshake.  In the long term, there are other use cases, such as migrating from one server to another within a cluster for load balancing/etc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-330635807

---

From: janaiyengar <[email-masked]>
Date: Tue, 19 Sep 2017 19:12:12 +0000 (UTC)

I seem to have missed this thread entirely -- this is very valuable indeed. This is also useful for connection migration later on in the connection, since a migrating client may hit a different server if the servers are behind anycast IPs.

I'm also in favor of making this part of the server transport params instead of a new frame. It's sent exactly once, at the beginning of the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-330641301

---

From: Igor Lubashev <[email-masked]>
Date: Tue, 19 Sep 2017 22:36:31 +0000 (UTC)

I actually like this proposal a lot. Moving connections off anycast address to a unicast address belonging to the same server quickly (at the end of a handshake) is a major use-case.

@ianswett's migration to a different server is a different use case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-330693410

---

From: MikkelFJ <[email-masked]>
Date: Wed, 20 Sep 2017 06:50:48 +0000 (UTC)

wrt. migration to different server, should there be protection against loops, or is this an application configuration issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-330761242

---

From: Igor Lubashev <[email-masked]>
Date: Wed, 20 Sep 2017 12:31:00 +0000 (UTC)

Loops sound like an app concern. (And it is probably among the simplest of app concerns in case of a mid-connection server migration. The app would also need to migrate app state and quic state out-of-band. It would also need to forward to the new sever quic packets arriving at the old sever after that state migration.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-330836614