Subject: [quicwg/base-drafts] Why is the crypto stream not subject to connection flow control (#800)

From: Subodh Iyengar <[email-masked]>
Date: Wed, 27 Sep 2017 22:45:10 +0000 (UTC)

IIRC previously this was not done because flow control messages for the connection were sent on the stream 0. However with MAX_DATA frames they are not sent over stream id 0 any more. Having only crypto streams not be subject to connection level flow control creates a bunch of workaround code to check for  if (stream == cryptoStream) before you increment the cumulativewritedataoffset for the connection which is used to track conn flow control.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/800

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Sep 2017 23:00:32 +0000 (UTC)

The problem is early data and the handshake.  It is possible that early data will exhaust the connection flow control window.  I fact, that's a feature: we use the connection flow control window to limit the amount of early data, just as there is an early data limit in TLS.  If that happens, there is no room to send the client Finished (and Certificate[Verify]).  That would block handshake completion, which is bad.  Also, the server doesn't really have a good way to send authenticated MAX_DATA frames to the client at this point, so it doesn't easily resolve itself.

Yeah, it's a real pain.  Stream 0 is too special for my liking also.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/800#issuecomment-332679382

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Sep 2017 23:00:32 +0000 (UTC)

Closed #800.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/800#event-1268781075

---

From: Subodh Iyengar <[email-masked]>
Date: Wed, 27 Sep 2017 16:14:24 -0700

ya that sounds reasonable, I realized that this might be a reason just after posting :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/800#issuecomment-332681798

---

From: janaiyengar <[email-masked]>
Date: Wed, 27 Sep 2017 23:31:32 +0000 (UTC)

Necessary evil. Control channels are as old as the hills -- nothing new here :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/800#issuecomment-332684512