Subject: [quicwg/base-drafts] CANCELLED streams outside of GOAWAY (#782)

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Sep 2017 22:27:57 +0000 (UTC)

In #757, the CANCELLED state is discussed in the context of GOAWAY, because HTTP/2 used cancellation only for closure and for exceeding the stream limit (which is moot in HTTP/QUIC).  But there's no text that actually *prohibits* sending it at other times.  Should there be?

If not, the logic in #770 for not blowing up when the server cancels (declaring it hasn't processed any of the request) after starting to respond (proving that it has started processing the request) is somewhat broken.  As @janaiyengar points out, if the client doesn't hard-require it, it's not a MUST [NOT].

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/782

---

From: Martin Thomson <[email-masked]>
Date: Sun, 24 Sep 2017 22:07:10 -0700

1XX  might influence the outcome.  I think that it is valid for a server to cancel a stream after sending 100 Continue, for example.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/782#issuecomment-331778218