Subject: [quicwg/base-drafts] GOAWAY review (#757)

From: Martin Thomson <[email-masked]>
Date: Sun, 03 Sep 2017 19:04:59 -0700

In reviewing GOAWAY I noticed a few things.  I don't think that these are controversial, but they probably need clarification.

* The QUIC stream ID MUST be a client-initiated frame.

* The QUIC stream ID can be lower than the ID of streams that carried requests, even completed requests.  If the stream carried a request that was successfully completed, then the fact that the stream was "cancelled" by the GOAWAY doesn't retroactively cancel that request.  Critically, completed streams can't be safely retried. See also #756.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/757

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Sep 2017 19:22:50 +0000 (UTC)

It does say that the frame "contains the stream identifier of **the last client-initiated request**", or "MAY be zero."  This seems sufficient, but you're welcome to convince me otherwise or suggest how to make it clearer.

The second one feels like a server error -- the GOAWAY frame declares that the requests weren't processed, yet you're positing that a response has already been generated.  I've added some text about this in #770, but it fundamentally feels like the server oughtn't be doing that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/757#issuecomment-328632245

---

From: Mike Bishop <[email-masked]>
Date: Thu, 21 Sep 2017 15:40:28 -0700

Closed #757 via #770.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/757#event-1260324436