Subject: Re: [quicwg/base-drafts] Guidance for port number use (#495)

From: Igor Lubashev <[email-masked]>
Date: Fri, 15 Sep 2017 21:33:59 +0000 (UTC)

@bemasc 
> Multihosting QUIC on IPv4 without SNI.

I believe TLS 1.3 requires SNI, and QUIC requires TLS 1.3, so SNI is required for QUIC.  Is that incorrect?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-329909475

---

From: janaiyengar <[email-masked]>
Date: Fri, 15 Sep 2017 17:35:35 -0700

@igorlord Yes, QUIC requires TLS1.3 (and therefore SNI).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-329932587

---

From: Igor Lubashev <[email-masked]>
Date: Sat, 16 Sep 2017 00:43:41 +0000 (UTC)

Thank you, @janaiyengar !

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-329933144

---

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Sep 2017 04:50:58 +0000 (UTC)

TLS 1.3 does not require that SNI be used.  HTTP/2 does.  We won't be picking up the TLS usage requirements from h2, mainly because TLS 1.3 invalidates virtually all of them.  Mandatory SNI is one that we won't get.

@igorlord, can you open an issue to track this.  I don't think that there was ever any intent to differ from HTTP/2 on this point, but we need to make sure that we don't lose it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-331776572

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 25 Sep 2017 10:25:23 -0700

On Sun, Sep 24, 2017 at 9:50 PM, Martin Thomson <[email-masked]>
wrote:

> TLS 1.3 does not require that SNI be used. HTTP/2 does. We won't be
> picking up the TLS usage requirements from h2, mainly because TLS 1.3
> invalidates virtually all of them. Mandatory SNI is one that we won't get.
>
I think I hear you saying that QUIC doesn't currently require SNI. But
could QUIC require SNI?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-331952506

---

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Sep 2017 14:57:35 -0700

The only reason it doesn't is because we haven't written it down.  I believe that the intent is to require SNI.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-332025746

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 25 Sep 2017 22:15:51 +0000 (UTC)

Carry on, then!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/495#issuecomment-332029700