Subject: Re: [quicwg/base-drafts] Handshake errors (#608)

From: janaiyengar <[email-masked]>
Date: Tue, 19 Sep 2017 21:52:49 +0000 (UTC)

Revisiting this question, I think we have a small bit of a pickle. From #645, we agreed in Prague that "Off-path attacks would be protected against by using return routeability/proof of receipt." Server Cleartext carries a brand new packet number and carries a server-chosen connection ID, which means there's no proof of receipt in this packet. We should address this.

We could simply require that a Server Cleartext packet that closes a connection MUST echo the client's connection ID. This ought to be ok, since this connection is getting torn down, so there won't be a need to use a new connection ID anyways.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-330684602

---

From: ekr <[email-masked]>
Date: Tue, 19 Sep 2017 22:01:06 +0000 (UTC)

The plan was that Server Cleartext is going to be integrity protected with
a key derived from the client connection ID. I'll try to get to the PR this
week.

On Tue, Sep 19, 2017 at 2:52 PM, janaiyengar <[email-masked]>
wrote:

> Revisiting this question, I think we have a small bit of a pickle. From
> #645 <https://github.com/quicwg/base-drafts/issues/645>, we agreed in
> Prague that "Off-path attacks would be protected against by using return
> routeability/proof of receipt." Server Cleartext carries a brand new packet
> number and carries a server-chosen connection ID, which means there's no
> proof of receipt in this packet. We should address this.
>
> We could simply require that a Server Cleartext packet that closes a
> connection MUST echo the client's connection ID. This ought to be ok, since
> this connection is getting torn down, so there won't be a need to use a new
> connection ID anyways.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/608#issuecomment-330684602>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oVQj_68E-jWMA1-xNO4SCsr28bsEks5skDetgaJpZM4NytAA>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-330686471

---

From: Ryan Hamilton <[email-masked]>
Date: Tue, 19 Sep 2017 15:25:43 -0700

Presumably this means the client's connection ID, not the server's right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-330691396

---

From: janaiyengar <[email-masked]>
Date: Thu, 21 Sep 2017 18:42:00 +0000 (UTC)

Good point -- it should be the client's connection ID, otherwise there's no proof of receipt. The Server Cleartext however carries a server-chosen Connection ID, which makes this all just a bit confusing unfortunately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/608#issuecomment-331245750