Subject: [quicwg/base-drafts] Can Server Require Connection ID to be Included in Packets Sent by Clients? (#789)

From: Nick Banks <[email-masked]>
Date: Fri, 22 Sep 2017 07:15:02 -0700

This is slightly related to #659.

Is it reasonable/acceptable for a server implementation to require that a client always include the connection ID? If so, what exactly should it do if it receives a new connection where the client specified `omit_connection_id` in its transport parameters? Should it drop the connection? Send an error back (if so, what error)?

It seems to me that if we want to allow servers to restrict the usage of `omit_connection_id` by the client, we should probably have some mechanism to indicate the client the connection must include the connection ID. One possibility is a new transport parameters that is server specific that indicates connection id is required.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/789

---

From: Ryan Hamilton <[email-masked]>
Date: Fri, 22 Sep 2017 14:24:47 +0000 (UTC)

" The Connection ID field can only be omitted if the omit_connection_id
transport parameter is specified by the intended recipient of the packet."

So if a server does not send this parameter, the client must send
connection IDs. I think that gives you what you want?

On Fri, Sep 22, 2017 at 7:15 AM, Nick Banks <[email-masked]>
wrote:

> This is slightly related to #659
> <https://github.com/quicwg/base-drafts/issues/659>.
>
> Is it reasonable/acceptable for a server implementation to require that a
> client always include the connection ID? If so, what exactly should it do
> if it receives a new connection where the client specified
> omit_connection_id in its transport parameters? Should it drop the
> connection? Send an error back (if so, what error)?
>
> It seems to me that if we want to allow servers to restrict the usage of
> omit_connection_id by the client, we should probably have some mechanism
> to indicate the client the connection must include the connection ID. One
> possibility is a new transport parameters that is server specific that
> indicates connection id is required.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/789>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ASp6yhsIaC7pDEAFMOZTLZ0DGVk83n7qks5sk8DlgaJpZM4PgxIT>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/789#issuecomment-331461802

---

From: Nick Banks <[email-masked]>
Date: Fri, 22 Sep 2017 07:30:50 -0700

Closed #789.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/789#event-1261354777

---

From: Nick Banks <[email-masked]>
Date: Fri, 22 Sep 2017 14:30:52 +0000 (UTC)

So the `omit_connection_id` indicates to the remote whether or not they should include connection ID. I thought it was indicating the sender was going to omit them. That makes a bit more sense. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/789#issuecomment-331463431