Subject: [quicwg/base-drafts] Fix references to companion QUIC drafts (#809)

From: janaiyengar <[email-masked]>
Date: Sat, 30 Sep 2017 15:35:08 -0700

Closes #808 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/809

-- Commit Summary --

  * Fix references to drafts.
  * fix tls draft as well

-- File Changes --

    M draft-ietf-quic-http.md (33)
    M draft-ietf-quic-recovery.md (21)
    M draft-ietf-quic-tls.md (54)
    M draft-ietf-quic-transport.md (84)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/809.patch
https://github.com/quicwg/base-drafts/pull/809.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/809

---

From: Martin Thomson <[email-masked]>
Date: Sun, 01 Oct 2017 00:09:46 +0000 (UTC)

This won't work.  It will cause quic-http-05 to reference quic-transport-04.

The template has the ability to generate the right anchors as necessary for submission, but I haven't checked that it works properly.  I'll double-check when I get the chance.

BTW, I have a new submission process, which should remove some of the human error factors.  The code that generates the right tags has been recently updated (since the -06 drafts were submitted).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/809#issuecomment-333344445

---

From: Martin Thomson <[email-masked]>
Date: Sat, 30 Sep 2017 22:00:50 -0700

Closed #809.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/809#event-1272960766

---

From: Martin Thomson <[email-masked]>
Date: Sun, 01 Oct 2017 05:00:51 +0000 (UTC)

I am fairly confident now that my new code correctly changes any instances of `draft-foo-latest` when building for submission.

I didn't include a link before, but [here are the new instructions](https://github.com/martinthomson/i-d-template/blob/master/doc/SUBMITTING.md). Be careful to note the use of `git tag -a`, which creates an annotated tag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/809#issuecomment-333353774