Subject: [quicwg/base-drafts] Add OnPacketSentCC (#780)

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 15:58:55 +0000 (UTC)

Also improve pacing text and remove pacing pseudocode.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/780

-- Commit Summary --

  * Add OnPacketSentCC

-- File Changes --

    M draft-ietf-quic-recovery.md (76)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/780.patch
https://github.com/quicwg/base-drafts/pull/780.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/780

---

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 17:49:54 +0000 (UTC)

@ianswett pushed 1 commit.

f17d3dc  Fix formatting and minor clarifications

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/780/files/548342b2f03ec1be60108aeab947d646b0550d0e..f17d3dcc51b67ff93f789a5a86fe98fdba6a2dfa

---

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 11:16:01 -0700

a249176  Add more text on Recovery Period

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/780/files/f17d3dcc51b67ff93f789a5a86fe98fdba6a2dfa..a249176de04903225ede4a3e09893d789c40fa45

---

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 18:27:22 +0000 (UTC)

463d2ff  Martin's comments from Aug 24th

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/780/files/a249176de04903225ede4a3e09893d789c40fa45..463d2ffa0112fbfc0eb5d1b34a0c9c5f63616cbc

---

From: janaiyengar <[email-masked]>
Date: Tue, 19 Sep 2017 11:58:21 -0700

janaiyengar approved this pull request.

> @@ -636,7 +640,9 @@ The pacing rate is a function of the mode, the congestion window, and
 the smoothed rtt.  Specifically, the pacing rate is 2 times the
 congestion window divided by the smoothed RTT during slow start
 and 1.25 times the congestion window divided by the smoothed RTT during
-slow start.
+slow start.  In order to fairly compete with flows that are not pacing,
+it is recommended to not pace the first 10 sent packets when exiting
+quiescence.

I wonder if this entire section should be removed and left to implementers. But this is fine for now, let's discuss that separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/780#pullrequestreview-63765988

---

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 12:00:53 -0700

Merged #780.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/780#event-1256085298

---

From: Nick Banks <[email-masked]>
Date: Tue, 19 Sep 2017 19:03:19 +0000 (UTC)

nibanks commented on this pull request.

> @@ -693,22 +702,35 @@ follows:
    ssthresh = infinite
 ~~~
 
+### On Packet Sent
+
+Whenever a packet is sent, and is contains non-ACK frames,

Instead of `and is contains non-ACK frames,` I assume you mean `and it contains non-ACK frames,`?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/780#pullrequestreview-63768195

---

From: ianswett <[email-masked]>
Date: Tue, 19 Sep 2017 19:06:25 +0000 (UTC)

Thanks for the comments Nick, I'll try to make sure those end up in my next PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/780#issuecomment-330639843