Subject: [quicwg/base-drafts] Use address validation tokens, not STK (#1045)

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jan 2018 06:47:59 +0000 (UTC)

Closes #1035.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1045

-- Commit Summary --

  * Use address validation tokens, not STK

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1045.patch
https://github.com/quicwg/base-drafts/pull/1045.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1045

---

From: Mike Bishop <[email-masked]>
Date: Tue, 09 Jan 2018 12:59:48 -0800

MikeBishop approved this pull request.

> @@ -3649,12 +3649,13 @@ transport to cancel a stream in response to receipt of a STOP_SENDING frame.
 
 ## Spoofed ACK Attack
 
-An attacker receives an STK from the server and then releases the IP address on
-which it received the STK.  The attacker may, in the future, spoof this same
+An attacker might be able to receive an address validation token
+({{address-validation}}) from the server and then releases the IP address it

"be able to receive... and then release" or "receives... and then releases".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1045#pullrequestreview-87648406

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jan 2018 02:54:38 +0000 (UTC)

@martinthomson pushed 1 commit.

632add9  Grammo

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1045/files/33343b9b61210e8352d54ea3cc4c5c9b81cd4fa5..632add9880269f54acf66282f505b54f21b7f55e

---

From: janaiyengar <[email-masked]>
Date: Fri, 12 Jan 2018 22:41:40 +0000 (UTC)

janaiyengar approved this pull request.

LGTM - merging.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1045#pullrequestreview-88624292

---

From: janaiyengar <[email-masked]>
Date: Fri, 12 Jan 2018 14:41:44 -0800

Merged #1045.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1045#event-1422653086