Subject: [quicwg/base-drafts] Invariant: the first packet on a connection uses the long header (#1040)

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jan 2018 02:58:49 +0000 (UTC)

We need this for version negotiation to work.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040

---

From: Mike Bishop <[email-masked]>
Date: Tue, 09 Jan 2018 20:28:47 +0000 (UTC)

Agreed -- this is generally assumed, but not actually written down.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#issuecomment-356404560

---

From: ianswett <[email-masked]>
Date: Tue, 09 Jan 2018 20:50:18 +0000 (UTC)

In order for this not to be true, that implies you have done out of band version negotiation and key negotiation?  At that point, I would call it migration rather than a new connection.

One use case is to migrate a connection from a TLS 1.3 TCP connection to a QUIC connection.  A similar use might be WebRTC using QUIC?

It seems like we could do these no matter what we decide here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#issuecomment-356409850

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jan 2018 18:53:11 -0800

Yes.  There's always this little annoying insect that reminds me that people start QUIC from not-QUIC with keys and context already established.  Those people are welcome to do so, but they aren't really using the same protocol and so wouldn't be bound by the same constraints.  In this case, they would have to understand that they don't get to use version negotiation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#issuecomment-356484498

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jan 2018 22:30:35 -0800

Closed #1040.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#event-1417061628

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jan 2018 06:30:36 +0000 (UTC)

Closed in e6ac5c1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#issuecomment-356512394

---

From: Mike Bishop <[email-masked]>
Date: Wed, 10 Jan 2018 13:50:58 -0800

And if they need it, all they have to do is define a version that has the long-header 1-RTT packet types put back.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1040#issuecomment-356748538