Subject: Re: [quicwg/base-drafts] responses to comments (9cc0cab)

From: Martin Thomson <[email-masked]>
Date: Thu, 01 Feb 2018 01:40:03 +0000 (UTC)

I think that we've established that this isn't the case.  If the response follows any path, and the usual ACK delays are factored in, then you only get this value if you also have an ACK with timing information for the packet containing the PATH_CHALLENGE.

I think that the real benefit is that it doesn't constrain implementations in any way.  They can put whatever they want in the frame as long as it is hard to guess for an off-path attacker.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9cc0cabb6ad9f36c72ed605a6318f9e177efa2a2#commitcomment-27250995

---

From: janaiyengar <[email-masked]>
Date: Thu, 01 Feb 2018 01:51:49 +0000 (UTC)

I don't believe that's true. It is more accurate than without new random, since you don't have to deal with retransmission ambiguity. It's the same argument for using new packet numbers for retransmissions. That allows more accurate RTT measurements, even without ack delay information. That said, I don't care much what we say here, so I've changed this text to say "measure the time taken to respond to a challenge."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9cc0cabb6ad9f36c72ed605a6318f9e177efa2a2#commitcomment-27251200

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jan 2018 18:03:13 -0800

Fair enough - I'm just noting that you don't always get to know how long the peer say on your challenge before putting it into a packet (that's ACK delay, but we don't always get an ACK delay that correlates well with the packet that the challenge was in).  And then the response doesn't need to follow the same path, so you get the whole path asymmetry problem playing into things.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9cc0cabb6ad9f36c72ed605a6318f9e177efa2a2#commitcomment-27251318