Subject: Re: [quicwg/base-drafts] HTTP header compression: static table fit for QUIC (#904)

From: Lucas Pardue <[email-masked]>
Date: Fri, 26 Jan 2018 05:57:53 -0800

@MikeBishop, post-Melbourne and the decision to adopt QCRAM, is this something to look into now? Or would it be better to keep it parked?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904#issuecomment-360791217

---

From: Mike Bishop <[email-masked]>
Date: Sat, 27 Jan 2018 20:23:48 -0800

Assuming the draft is formally adopted (which requires the mailing list), I suspect this falls into the "bring data and demonstrate it's better" bucket.

If someone can come up with a draft static table and demonstrate appreciable improvements in compression performance or reductions in HOLB to justify the departure from shared code with HPACK, I don't see why we wouldn't consider it.  (Assuming that either the gains were dramatic enough to justify time investment or the time requirements to agree and merge it were minimal.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/904#issuecomment-361037347