Subject: Re: [quicwg/base-drafts] Multiple connections on the same port (#714)

From: martinduke <[email-masked]>
Date: Wed, 24 Jan 2018 00:56:59 +0000 (UTC)

An additional benefit of addressing this issue is to allow handshakes to succeed during a NAT rebinding. This is not a requirement but would be a nice feature.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-359984222

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Jan 2018 17:59:37 -0800

Closed #714.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#event-1438626826

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Jan 2018 02:33:07 +0000 (UTC)

When we discussed this in the context of other things at Melbourne we decided not to address this use case in this version of the protocol.  Many of the solutions proposed do not require changes to protocol invariants, so we could fix this in a future version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-359995274

---

From: MikkelFJ <[email-masked]>
Date: Tue, 23 Jan 2018 23:52:07 -0800

Even if the protocol does not consider this in v1, it would be highly useful to ensure that there is linkage between CID SID in all packages, so an implementation can do define its own semantics to resolve connection conflicts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/714#issuecomment-360048706