Subject: [quicwg/base-drafts] Text proposal on user land warning about lower layer overhead to addr… (#1036)

From: Magnus Westerlund <[email-masked]>
Date: Thu, 04 Jan 2018 02:59:40 -0800

…ess issue #614 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1036

-- Commit Summary --

  * Text proposal on user land warning about lower layer overhead to address issue #614

-- File Changes --

    M draft-ietf-quic-transport.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1036.patch
https://github.com/quicwg/base-drafts/pull/1036.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036

---

From: Mike Bishop <[email-masked]>
Date: Thu, 04 Jan 2018 13:48:20 -0800

"operating system user land" is confusing and seems somewhat colloquial.  Also, it doesn't build because you exceed the line length.  You should rewrap to 80 characters per line.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#issuecomment-355408357

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 Jan 2018 22:39:12 +0000 (UTC)

I don't think that this is specific to user space implementations.  There are two general classes of concern for user space implementations: timing and MTU.  Neither of these are special enough to warrant text (in my opinion).  In all cases, there are things that lowers layers of the stack might do to degrade service, either by adding delays or encapsulation.  Something like TURN is particularly annoying because the overheads can change over time, but it isn't all that different to a routing change causing packets to be sent on a path with a different MTU (on the contrary, it's actually more predictable).

If the intent is to say that you get better performance if you know more about lower layers of the stack, that is a truism.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#issuecomment-355419540

---

From: martinduke <[email-masked]>
Date: Thu, 04 Jan 2018 23:32:58 +0000 (UTC)

martinduke requested changes on this pull request.

I don't care much one way or the other whether we include this, but if so I would suggest the following rephrasing, inserted not in its own section but after the  phrase "...1252 octets for IPv4".

"Some QUIC implementations MAY wish to be more conservative in computing allowed QUIC packet size given unknown tunneling overheads or IP header options."

I think that's sufficient, if people would like to see explicit language on this subject.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#pullrequestreview-86790343

---

From: Martin Thomson <[email-masked]>
Date: Thu, 04 Jan 2018 23:33:38 +0000 (UTC)

That might be a better approach.  I'd be OK with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#issuecomment-355429850

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 05 Jan 2018 08:45:12 +0000 (UTC)

@gloinul pushed 1 commit.

420fd1f  Changing to Martin Duke's proposal for how to resolve this issue.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036/files/4ed1e9fafa49d166b675588c118468b9ef0efd3b..420fd1f2f8fa2be37511bf74f5d8c500de5e8b54

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 05 Jan 2018 00:47:35 -0800

a09976c  Fixing trailing spaces issue.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036/files/420fd1f2f8fa2be37511bf74f5d8c500de5e8b54..a09976c6aaef18da023a2cf8f4e95e20971abc71

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 05 Jan 2018 00:49:03 -0800

@martinduke Okay, lets go with your suggestion. I have updated the pull request to only do that change. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#issuecomment-355502406

---

From: martinduke <[email-masked]>
Date: Fri, 05 Jan 2018 21:52:41 +0000 (UTC)

martinduke approved this pull request.

Ship it!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#pullrequestreview-87033471

---

From: Martin Thomson <[email-masked]>
Date: Mon, 08 Jan 2018 01:02:47 +0000 (UTC)

Merged #1036.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#event-1412948840

---

From: Martin Thomson <[email-masked]>
Date: Mon, 08 Jan 2018 01:02:55 +0000 (UTC)

Thanks Magus and Martin!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1036#issuecomment-355868042