Subject: Re: [quicwg/base-drafts] Handling un-ackable packets (#751)

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 01:40:37 +0000 (UTC)

Right now we don't have any way to signal this with an ACK frame (the encoding demands a minimum acknowledgment set of size 1).  We could amend that frame type, but that affects far more than this one usage.  Given the unique circumstances an empty packet of a new type seems awful, but not that much more than the alternatives.  We could also just use Handshake with no content, but that sort of overloading might be unwise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/751#issuecomment-357829033

---

From: MikkelFJ <[email-masked]>
Date: Tue, 16 Jan 2018 09:14:07 +0000 (UTC)

How about CONNECTION_CLOSE 0RTT_LOST. A 0-RTT retransmission could make use of buffered packets at receiver by noting the 0-RTT handshake is a retransmission, if that is worthwhile?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/751#issuecomment-357898130

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 23:29:25 +0000 (UTC)

CONNECTION_CLOSE isn't appropriate here.  It implies dropping state, where the server might save the 0-RTT until it gets the missing handshake message.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/751#issuecomment-358142704

---

From: janaiyengar <[email-masked]>
Date: Wed, 17 Jan 2018 02:35:38 +0000 (UTC)

Since this information is advisory, I would argue that the receiver should be allowed the freedom to drop this data that's being buffered, waiting for the Initial packet. Given that, it makes sense to not use the ACK frame since we would have to overload the reliability semantics of an ACK frame. I agree that a new packet type seems like the best of the available options here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/751#issuecomment-358176091