Subject: [quicwg/base-drafts] Definition of Recovery End (#1059)

From: Nick Banks <[email-masked]>
Date: Tue, 16 Jan 2018 15:17:34 -0800

According to the spec, recovery starts with detection of a lost packet and ends with the acknowledgement of a single, newly sent packet. Why isn’t recovery ending only after all the information in the frames that were lost prior to the recovery period have been acknowledged?

For instance, if 4 packets worth of STREAM frames and a MAX_DATA frame were lost, why shouldn’t recovery last until all that data had been resent and acknowledged?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1059

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 23:58:37 +0000 (UTC)

This is probably a question better taken to the list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1059#issuecomment-358148272

---

From: janaiyengar <[email-masked]>
Date: Wed, 17 Jan 2018 00:19:52 +0000 (UTC)

Traditionally, "recovery period" is used for isolating loss epochs, for congestion control purposes. This definition is meant for that purpose. (Agreed with Martin, please take further discussion to the list.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1059#issuecomment-358152392

---

From: janaiyengar <[email-masked]>
Date: Tue, 16 Jan 2018 16:19:53 -0800

Closed #1059.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1059#event-1427316547