Subject: [quicwg/base-drafts] Limit peers MTU (#1080)

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Jan 2018 10:33:18 +0000 (UTC)

The current transport draft only discusses minimum MTU. However, a large MTU drains resources on the receiving end and could lead DoS attacks on validation of invalid very large packets. IPv6 has a limit of 64K, but apparently there can also be gigabyte sized jumbograms. Futher, this adds an implicit dependency on IPv6 that might be overlooked when adapting QUIC to other transports.

A receiver can always drop large data grams and thus force a MTU limit, but perhaps some text is needed to make this explicit?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1080

---

From: Marten Seemann <[email-masked]>
Date: Mon, 29 Jan 2018 10:35:30 +0000 (UTC)

We already have the `max_packet_size` parameter in the transport parameters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1080#issuecomment-361204781

---

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Jan 2018 10:35:55 +0000 (UTC)

Of course I overlooked `max_packet_size` in transport parameters.

But I still think some mention is needed in section 9.2 https://quicwg.github.io/base-drafts/draft-ietf-quic-transport.html#rfc.section.9.2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1080#issuecomment-361204883

---

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Jan 2018 10:36:25 +0000 (UTC)

> We already have the max_packet_size parameter in the transport parameters.
yes I just realized

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1080#issuecomment-361204992

---

From: Martin Thomson <[email-masked]>
Date: Mon, 29 Jan 2018 14:55:03 -0800

PR welcome.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1080#issuecomment-361415506