Subject: [quicwg/base-drafts] Exclusion from congestion control for ACK (#1055)

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 03:51:01 +0000 (UTC)

There is no evidence in the current draft of the exemption that ACK-only packets get to ignore the limit set by `congestion_window`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1055

---

From: Roni Even <[email-masked]>
Date: Tue, 16 Jan 2018 01:14:30 -0800

Implied in  4.7.2 "Packets only containing ACK frames do not
      count towards byte_in_flight to ensure congestion control does not
      impede congestion feedback."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1055#issuecomment-357898257

---

From: ianswett <[email-masked]>
Date: Tue, 16 Jan 2018 13:59:07 +0000 (UTC)

Thanks Roni, exactly.

Did you have a suggestion for somewhere else it should be mentioned?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1055#issuecomment-357968442

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 23:31:56 +0000 (UTC)

I think that providing an explicit can-send description would help (as I request with #1056).  And the computation of bytes_in_flight in Section 4.7.4 doesn't include this tweak.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1055#issuecomment-358143203