Subject: [quicwg/base-drafts] "CanSendPacket" function or equivalent function (#1056)

From: Martin Thomson <[email-masked]>
Date: Mon, 15 Jan 2018 19:51:35 -0800

The congestion control section doesn't provide a function that describes how a sender might decide whether to send a packet (or, similarly, but more complicated, a function that describes what can be sent in a packet at the current moment).

Ideally this would include pacing and congestion limits.  And it would include the exclusion for ACK-only packets (#1055).  

Anyone addressing this might consider #837 at the same time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1056

---

From: ianswett <[email-masked]>
Date: Tue, 16 Jan 2018 14:04:04 +0000 (UTC)

Getting into the mechanics of pacing is potentially complex and implementation dependent, so currently the editor's draft just recommends using pacing.

#837 is not editorial, whereas I am fairly sure this suggestion is, so I don't see a need to resolve them at once.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1056#issuecomment-357969843

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 23:34:43 +0000 (UTC)

It's only really an editorial issue if you consider an omission like this to be editorial.  That is, you consider the design to be implied.  I don't think that it's that trivial.

Pacing inclusion might only be exemplary in the sense that choosing the value might still be left to implementations, but it seems feasible to describe one potential integration into the algorithm.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1056#issuecomment-358143784

---

From: janaiyengar <[email-masked]>
Date: Wed, 17 Jan 2018 02:06:24 +0000 (UTC)

Without pacing, the design is implied IMO -- the congestion controller allows a packet to be sent if inflight is below the congestion window.

I don't think we should specify pacing here, since there's no current equivalent spec for TCP that we can simply "re-map". There are multiple implementations of pacers for TCP out there (for different OSes), and we'd either end up describing one of them, or litigate the right way to pace. I'm not convinced either of these options is useful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1056#issuecomment-358171340