Subject: [quicwg/base-drafts] Recommend simulating migration after quiescence (#1087)

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jan 2018 20:00:56 -0800

A connection that is unused for a while might trigger NAT rebinding when the NAT times out.  We can recommend that a client use the next available connection ID at that point.  Nothing much is lost by doing so, and it increases the use of NEW_CONNECTION_ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1087

---

From: janaiyengar <[email-masked]>
Date: Wed, 31 Jan 2018 23:25:44 +0000 (UTC)

Seems reasonable, and I like the common-casing of NEW_CONNECTION_ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1087#issuecomment-362105440

---

From: Christian Huitema <[email-masked]>
Date: Wed, 31 Jan 2018 18:03:52 -0800

OK. Now define "a while". How long is that? Obviously less than the idle timeout. Then what? The 2 minutes specified in RFC 4787? The 30 seconds often adopted as a conservative NAT refresh rate?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1087#issuecomment-362134347

---

From: janaiyengar <[email-masked]>
Date: Thu, 01 Feb 2018 02:19:11 +0000 (UTC)

We'll have to define "unused" too. The send time of any packet, or just those that are acked?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1087#issuecomment-362136924

---

From: Martin Thomson <[email-masked]>
Date: Thu, 01 Feb 2018 03:23:44 +0000 (UTC)

Those don't really need definition here.  If you think that a new connection ID is worth using, then switch over to a new one.

Unlike the idle timeout, this has the advantage of being discretionary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1087#issuecomment-362146790