Subject: Re: [quicwg/base-drafts] Connection ID is not a number (#834)

From: Mike Bishop <[email-masked]>
Date: Mon, 29 Jan 2018 14:33:09 -0800

So three months later, we've been limping along without either this text or #881.  Can we pick one and close these out?  Particularly if we're considering variable-length now, I think we should weigh on the side of it simply being an opaque identifier without integer semantics.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/834#issuecomment-361410089

---

From: ianswett <[email-masked]>
Date: Mon, 29 Jan 2018 18:30:49 -0800

Varlen seems to imply opaque ID, at least to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/834#issuecomment-361456886

---

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Jan 2018 22:52:33 -0800

A number isn't meaningful if the CID carries routing paths. It's just a byte sequence.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/834#issuecomment-361494007

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 30 Jan 2018 23:17:16 +0000 (UTC)

+1 for byte sequence. Defining it as a number leads to ambiguity like if we can omit leading zeroes, which would be especially troublesome if we decide to support variable length.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/834#issuecomment-361767825

---

From: janaiyengar <[email-masked]>
Date: Tue, 30 Jan 2018 16:31:42 -0800

Based on recent discussions, I'm fine with this not being a number.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/834#issuecomment-361782527