Subject: [quicwg/base-drafts] Tweak send stream figure (#1054)

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 01:58:00 +0000 (UTC)

The use of "Application Open" was confusing.  The text is clearer on this point, so simplify the diagram.

Closes #1008.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1054

-- Commit Summary --

  * Tweak send stream figure

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1054.patch
https://github.com/quicwg/base-drafts/pull/1054.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054

---

From: MikkelFJ <[email-masked]>
Date: Tue, 16 Jan 2018 09:02:35 +0000 (UTC)

mikkelfj commented on this pull request.

> @@ -2960,7 +2960,7 @@ data to a peer.
 
 ~~~
        o
-       | Application Open
+       | Open Stream
        | Open Paired Stream (bidirectional)
        v

The term "Paired Stream" only appears in the figures. Shouldn't this be Open Unidirectional Stream, Open Bidirectional Stream?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#pullrequestreview-89021775

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 15:28:36 -0800

@martinthomson pushed 1 commit.

45e7350  No more paired streams

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054/files/3736b081ffcb21a713137042aa74899451a16429..45e7350cb269eafaf1469f01a746ec8cded3dcef

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jan 2018 23:28:43 +0000 (UTC)

martinthomson commented on this pull request.

 ~~~
        o
-       | Application Open
+       | Open Stream

Good point.  Does the latest change work for you?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#discussion_r161918118

---

From: MikkelFJ <[email-masked]>
Date: Tue, 16 Jan 2018 16:02:23 -0800

~~~
        o
-       | Application Open
+       | Open Stream

yeah - sort of - Receive in Send diagram is a bit confusing - but I suppose it means also get ready to receive data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#discussion_r161923630

---

From: janaiyengar <[email-masked]>
Date: Wed, 17 Jan 2018 01:41:23 +0000 (UTC)

janaiyengar commented on this pull request.

> @@ -2960,8 +2960,8 @@ data to a peer.
 
 ~~~
        o
-       | Application Open
-       | Open Paired Stream (bidirectional)
+       | Open Stream
+       | Open Bidirectional Receive Stream

You have the directions flipped (should be Send here and Receive below). Admittedly pedantic, but how about "Open Bidirectional Stream (Sending part)"? Calling it a "Bidirectional Send Stream" sounds silly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#pullrequestreview-89306911

---

From: Martin Thomson <[email-masked]>
Date: Sat, 20 Jan 2018 09:25:22 +0000 (UTC)

~~~
        o
-       | Application Open

No, this is entirely intentional.  Opening the receive half of a bidirectional stream causes the send side to open.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#discussion_r161955780

---

From: Martin Thomson <[email-masked]>
Date: Mon, 29 Jan 2018 05:38:12 +0000 (UTC)

~~~
        o
-       | Application Open

@janaiyengar do you have any suggestions for clarifying this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#discussion_r164339571

---

From: ianswett <[email-masked]>
Date: Mon, 29 Jan 2018 12:22:45 -0800

ianswett commented on this pull request.

 ~~~
        o
-       | Application Open

Agreed the current text is confusing.  Open Bidirectional Stream might be clearer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1054#discussion_r164553025