Subject: [quicwg/base-drafts] Retry packet and PADDING (#1067)

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Jan 2018 21:13:00 -0800

-08 in Section 5.4.2. says:

>   The payload of the Retry packet contains a single STREAM frame on
>   stream 0 with offset 0 containing the server's cryptographic
>   stateless retry material.  It MUST NOT contain any other frames.  The
>   next STREAM frame sent by the server will also start at stream offset
>   0.

Any reason why PADDING is not allowed? (Insert usual stuff about zero-copy and fixed offsets.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1067

---

From: Marten Seemann <[email-masked]>
Date: Wed, 24 Jan 2018 05:17:13 +0000 (UTC)

There’s a related PR for this: https://github.com/quicwg/base-drafts/pull/882

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1067#issuecomment-360023583

---

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Jan 2018 21:23:06 -0800

#882 says "It SHOULD also contain an ACK frame" and removes the limit on any other frames. That looks a bit too broad? 

Why not say "MAY contain PADDING (and ACK?) and MUST NOT..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1067#issuecomment-360024378