Subject: [quicwg/base-drafts] Version Negotiation doesn't have a packet number (#1078)

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Jan 2018 19:39:45 -0800

And all that follows from that...
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1078

-- Commit Summary --

  * Version Negotiation doesn't have a packet number

-- File Changes --

    M draft-ietf-quic-transport.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1078.patch
https://github.com/quicwg/base-drafts/pull/1078.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078

---

From: Mike Bishop <[email-masked]>
Date: Mon, 29 Jan 2018 19:16:14 +0000 (UTC)

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078#pullrequestreview-92322250

---

From: ianswett <[email-masked]>
Date: Mon, 29 Jan 2018 11:29:08 -0800

ianswett commented on this pull request.

One small suggestion.

> @@ -2375,8 +2376,11 @@ Unlike TCP SACKs, QUIC acknowledgements are irrevocable.  Once a packet has
 been acknowledged, even if it does not appear in a future ACK frame,
 it remains acknowledged.
 
-A client MUST NOT acknowledge Version Negotiation or Retry packets.  These
-packet types contain packet numbers selected by the client, not the server.
+A client MUST NOT acknowledge Version Negotiation or Retry packets.  Version

nit: technically they CAN NOT acknowledge VN packets, since there's no packet number.

How about "A client MUST NOT acknowledge Retry packets.  Version Negotiation packets cannot be acknowledged because they do not contain a packet number."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078#pullrequestreview-92323938

---

From: Martin Thomson <[email-masked]>
Date: Mon, 29 Jan 2018 23:26:20 +0000 (UTC)

@martinthomson pushed 1 commit.

55d19ef  Ian's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078/files/2ddb0a7bc45c8143659018b754ce7ae5a0eec432..55d19eff3bf1ce9e77fc3d947aee1efe88f19478

---

From: ianswett <[email-masked]>
Date: Mon, 29 Jan 2018 18:29:09 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078#pullrequestreview-92426279

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jan 2018 03:10:09 +0000 (UTC)

Merged #1078.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1078#event-1447709064