Subject: [quicwg/base-drafts] QCRAM opcodes with non-byte (#1144)

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 00:24:28 +0000 (UTC)

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1144

-- Commit Summary --

  * Opcodes without sentinel values
  * Non-byte-aligned string literals
  * Actually use prefix terminology

-- File Changes --

    M draft-ietf-quic-qcram.md (64)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1144.patch
https://github.com/quicwg/base-drafts/pull/1144.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Feb 2018 16:32:34 -0800

martinthomson approved this pull request.

> @@ -175,17 +197,21 @@ always non-zero; a zero index is reserved for literal names.
 ~~~~~~~~~~
 {: title="Insert Header Field -- Indexed Name"}
 
-Otherwise, the header field name is represented as a string literal (see Section
-5.2 of [RFC7541]). A value 0 is used in place of the table reference, followed
-by the header field name.
+
+### Insert Without Reference

Without Name Reference

 ~~~~~~~~~~ drawing
      0   1   2   3   4   5   6   7
    +---+---+---+---+---+---+---+---+
-   | 1 | 0 |           0           |
-   +---+---+-----------------------+
-   | H |     Name Length (7+)      |
-   +---+---------------------------+
+   | 0 | 0 | H | Name Length (5+)  |

Almost a bike shed: invert the second bit here.  Then you can reasonably say that you are describing 11 (insert with static name reference), 10 (insert with dynamic name reference), 01 (insert with new name), 00 (duplication).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144#pullrequestreview-99908287

---

From: Mike Bishop <[email-masked]>
Date: Tue, 27 Feb 2018 17:01:42 -0800

@MikeBishop pushed 1 commit.

d4065fd  Martin's feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144/files/a0c1a31819d420158e6a66ab5ff07dc4a4d4580b..d4065fde6ebf18a242cbe766999ee9d11934776f

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 01:02:33 +0000 (UTC)

MikeBishop commented on this pull request.

 ~~~~~~~~~~ drawing
      0   1   2   3   4   5   6   7

I'm not wholly sure that makes a difference, but I suppose there's an argument to be made that '00' is the "unique" one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144#discussion_r171117135

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 16:44:59 +0000 (UTC)

Having separately discussed bringing back table size change, there are now five instructions, so "00" represents "uncommon things" with a third bit to differentiate duplicate versus size change.  Purely by coincidence, that means size change is now identical to the HPACK instruction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144#issuecomment-369299573

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 16:49:29 +0000 (UTC)

Merged #1144.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144#event-1497141351

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 08:35:10 -0800

7f495bb  Table size change

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1144/files/d4065fde6ebf18a242cbe766999ee9d11934776f..7f495bb0659828fd0cbcee84f71f6210a353527c