Subject: [quicwg/base-drafts] Invariants (#1109)

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Feb 2018 15:34:03 -0800

This adds the invariants draft to the repo and does a minimal integration with the transport doc.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1109

-- Commit Summary --

  * Add invariants doc
  * Cut text from intro
  * Don't use payload too often
  * Tweak description of long and short packet headers
  * Rework connection ID purpose text
  * Connection ID isn't stable
  * lowercase packet
  * The long header as defined here
  * Authentication of VN is part of the version-specific part
  * Remove extra text that might be too much
  * Add security consideration about integrity protection for version negotiation
  * Not the editor this time
  * Fix draft name
  * Use the full date, because ticket 2422
  * Close #1040
  * Tweak use of ellipsis
  * Packets aren't short or long, only the headers are
  * Move invariants to an -ietf- name
  * Integrate invariants into transport

-- File Changes --

    M Makefile (2)
    A draft-ietf-quic-invariants.md (346)
    M draft-ietf-quic-transport.md (41)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1109.patch
https://github.com/quicwg/base-drafts/pull/1109.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1109

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 18 Feb 2018 20:38:43 -0800

Merge and publish at your pleasure...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1109#issuecomment-366587149

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Feb 2018 23:58:21 +0000 (UTC)

Merged #1109.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1109#event-1481472934

---

From: janaiyengar <[email-masked]>
Date: Tue, 20 Feb 2018 13:34:28 -0800

janaiyengar commented on this pull request.

(thanks for merging!)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1109#pullrequestreview-97997686