Subject: [quicwg/base-drafts] Simplify QCRAM abstract (#1114)

From: Lucas Pardue <[email-masked]>
Date: Thu, 15 Feb 2018 12:07:36 +0000 (UTC)

A terse strawman proposal.

State what not why, make it more similar to HPACK abstract.

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1114

-- Commit Summary --

  * Simplify abstract

-- File Changes --

    M draft-ietf-quic-qcram.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1114.patch
https://github.com/quicwg/base-drafts/pull/1114.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 15 Feb 2018 15:20:21 +0000 (UTC)

build failed due to trailing whitespace >.<

Please judge on content.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#issuecomment-365958914

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Feb 2018 23:18:10 +0000 (UTC)

@martinthomson pushed 1 commit.

1722945  Trim trailing whitespace

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114/files/a0e0fbd4dae7bd8746d99fc8ac7b446ac3b15548..1722945ddfd162b4d39fdc4a979cead7e3d277de

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Feb 2018 23:18:18 +0000 (UTC)

I like the content and have fixed the whitespace.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#issuecomment-366094791

---

From: Mike Bishop <[email-masked]>
Date: Sat, 17 Feb 2018 08:27:57 -0800

MikeBishop approved this pull request.

LGTM. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#pullrequestreview-97378537

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 19 Feb 2018 13:18:30 +0000 (UTC)

dtikhonov commented on this pull request.

> @@ -32,15 +32,9 @@ author:
 
 --- abstract
 
-The design of the core QUIC transport subsumes many HTTP/2 features, prominent
-among them stream multiplexing.  A key advantage of the QUIC transport is stream
-multiplexing free of head-of-line (HoL) blocking between streams. In HTTP/2,
-multiplexed streams can suffer HoL blocking due to TCP.
-
-If HTTP/2's HPACK is used for header compression, HTTP/QUIC is still vulnerable
-to HoL blocking, because of HPACK's assumption of in-order delivery.  This draft
-defines QCRAM, a variation of HPACK and mechanisms in the HTTP/QUIC mapping that
-allow the flexibility to avoid header-compression-induced HoL blocking.
+This specification defines QCRAM, a compression format for efficiently
+representing HTTP header fields, to be used in HTTP over QUIC. This is a
+variation of HPACK header compression that avoids head-of-line blocking.

"Avoids" is an incorrect term to use: we differentiate avoidance and minimization.  In the default mode, QCRAM minimizes head-of-line blocking.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#pullrequestreview-97539224

---

From: afrind <[email-masked]>
Date: Tue, 20 Feb 2018 09:27:16 -0800

afrind commented on this pull request.

 --- abstract

Agreed.  @dtikhonov, would you prefer 'minimizes' here, or do you think we should elaborate? 

'...that minimizes or avoids...'
'...that seeks to reduce...'

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#discussion_r169396443

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 20 Feb 2018 10:42:44 -0800

--- abstract

As far as abstracts go, the current QCRAM abstract is short.  To keep it that way, "seeks to reduce" is probably the best way to go.  Discussion about minimization vs. avoidance does not have to be surfaced to the level of the abstract.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#discussion_r169418649

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 20 Feb 2018 18:44:53 +0000 (UTC)

SGTM, I'll incorporate that text into PR when at the computer next.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#issuecomment-367077570

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 20 Feb 2018 21:55:55 +0000 (UTC)

@LPardue pushed 1 commit.

43ec4a5  dmitri's feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114/files/1722945ddfd162b4d39fdc4a979cead7e3d277de..43ec4a530c17dd769ebf13a1c540610d3dea7618

---

From: afrind <[email-masked]>
Date: Tue, 20 Feb 2018 15:15:39 -0800

Merged #1114.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1114#event-1483584697