Subject: [quicwg/base-drafts] text on retry and connection id (#1118)

From: Patrick McManus <[email-masked]>
Date: Sat, 17 Feb 2018 13:20:59 -0800

5.4.2 retry

> The server includes a connection ID of its choice in the connection   ID field.  The client MUST use this connection ID for any subsequent   packets that it sends.

I don't think "any subsequent packets" is right.. this applies to subsequent initials, not forever and forever right? (the server, being stateless on the retry, might choose a new cid again in the HANDSHAKE reply)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1118

---

From: Martin Thomson <[email-masked]>
Date: Sun, 18 Feb 2018 19:24:09 -0800

I think that is fine.  That the server might later provide a different connection ID and that clients can use that is OK.

Is the imprecision here made worse by the choice of 2119 "MUST"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1118#issuecomment-366580368

---

From: Patrick McManus <[email-masked]>
Date: Mon, 19 Feb 2018 08:19:53 -0800

I read "MUST - any subsequent" as "MUST all subsequent" which would rule
out the server later providing a different connection ID (which we both
agree we want to allow)

can't we just say "for subsequent INITIAL packets it sends" ?

On Sun, Feb 18, 2018 at 10:24 PM, Martin Thomson <[email-masked]>
wrote:

> I think that is fine. That the server might later provide a different
> connection ID and that clients can use that is OK.
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1118#issuecomment-366580368>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5sxIZIH4Af--Ujxvaux00nfUjIDODks5tWOlXgaJpZM4SJd6E>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1118#issuecomment-366740386

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Feb 2018 16:00:04 -0800

Would dropping the "any" help.  I just don't want to avoid the over-rotation that specifically identifying Initial here would have: "so just the Initial, but not Handshake or packets with short headers..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1118#issuecomment-366830278