Subject: [quicwg/base-drafts] add an error code for rejecting new connections (#1137)

From: Marten Seemann <[email-masked]>
Date: Fri, 23 Feb 2018 01:12:21 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1137

-- Commit Summary --

  * add a SERVER_BUSY error code

-- File Changes --

    M draft-ietf-quic-transport.md (10)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1137.patch
https://github.com/quicwg/base-drafts/pull/1137.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137

---

From: Mike Bishop <[email-masked]>
Date: Sun, 25 Feb 2018 14:16:53 +0000 (UTC)

MikeBishop requested changes on this pull request.

Some consistency issues, but I don't have a problem with the approach.

> @@ -926,8 +926,11 @@ server continues below.
 
 If the packet is an Initial packet fully conforming with the
 specification, the server proceeds with the handshake ({{handshake}}).
-This commits the server to the version that the client
-selected.
+This commits the server to the version that the client selected.
+
+If the server currently doesn't accept any new connections, it SHOULD send a
+SERVER_BUSY error code. A client that receives this error code SHOULD NOT
+immediately try to reconnect to this server.

"send an error code" isn't the same terminology we've used elsewhere.  I'd use something like "If a server isn't currently accepting any new connections, it SHOULD send a Handshake packet containing a CONNECTION_CLOSE frame with error code SERVER_BUSY."

> @@ -3676,6 +3679,9 @@ INTERNAL_ERROR (0x1):
 : The endpoint encountered an internal error and cannot continue with the
   connection.
 
+SERVER_BUSY (0x2):
+: The server is currently busy and does not accept any new connections.

Others have a line between entry and definition.  I don't particularly care for that style, but let's be consistent anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137#pullrequestreview-99144280