Subject: [quicwg/base-drafts] Alt-Svc quic= a list (#1097)

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Feb 2018 08:56:23 -0800

Fixes #1093.

Replaces the multiple occurrences of the quic= parameter with a quoted string containing a comma-delimited list.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1097

-- Commit Summary --

  * Alt-Svc quic= a list

-- File Changes --

    M draft-ietf-quic-http.md (15)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1097.patch
https://github.com/quicwg/base-drafts/pull/1097.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097

---

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Feb 2018 21:23:19 +0000 (UTC)

martinthomson approved this pull request.

 ~~~ example
-Alt-Svc: hq=":49288";quic=1;quic=51303334
+Alt-Svc: hq=":49288";quic="1,51303334"

Unrelated to this, but can you add one of the greasing versions to this list?  We don't have any use of those yet, and it would be good to include something in the a-f range (which that does).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#pullrequestreview-94146981

---

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Feb 2018 13:37:26 -0800

@MikeBishop pushed 1 commit.

593bba4  Exercise (and mention) reserved version numbers

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097/files/ad96edab948d30d7a443cafb353817340b12d9db..593bba4093cceaba17c3c8517b571f778818b303

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 05 Feb 2018 23:57:50 +0000 (UTC)

LPardue commented on this pull request.

> @@ -138,14 +141,16 @@ For example, if a server supported both version 0x00000001 and the version
 rendered in ASCII as "Q034", it could specify the following header:
 
 ~~~ example
-Alt-Svc: hq=":49288";quic="1,51303334"
+Alt-Svc: hq=":49288";quic="1,dadababa,51303334"

0xdadababa values is not explained in preceding paragraph.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#pullrequestreview-94186094

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 06 Feb 2018 00:01:11 +0000 (UTC)

Just sanity check, the reserved value 0x00000000 would result in something like quic="" or quic="1,", is that a good thing? Perhaps better to prohibit advertising this value?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363263005

---

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Feb 2018 00:06:15 +0000 (UTC)

@LPardue, that sounds like a feature to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363264022

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 00:08:28 +0000 (UTC)

Should I include a double comma in the list, just to demonstrate?  (Facetious -- I actually think having empty-string as a possible value is unfortunate.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363264445

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 00:12:51 +0000 (UTC)

Actually, never mind, this is fine.  `version-number` is at least one digit long, so version zero would be rendered as `0`, and who cares?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363265262

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 05 Feb 2018 16:16:07 -0800

Good point. In that case ignore me on 0.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363265828

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 06 Feb 2018 00:20:01 +0000 (UTC)

Now that we've gone back to this list format, is it invalid to repeat the the quic parameter in a single Alt-Svc?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#issuecomment-363266555

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 00:25:15 +0000 (UTC)

419eb0f  @LPardue's feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097/files/593bba4093cceaba17c3c8517b571f778818b303..419eb0ff3bb18e907967fbf619e5e42879054a05

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 06 Feb 2018 00:50:31 +0000 (UTC)

LPardue approved this pull request.

Lgtm

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#pullrequestreview-94195225

---

From: janaiyengar <[email-masked]>
Date: Mon, 05 Feb 2018 16:59:36 -0800

janaiyengar commented on this pull request.

Minor suggestion

>  ~~~
 
-Where multiple versions are listed, the order of the values reflects the
-server's preference (with the first value being the most preferred version).
-Origins SHOULD list only versions which are supported by the alternative, but
-MAY omit supported versions for any reason.
-
+A client acting on this header would drop the reserved versions (because it does

For clarity, can you add a note first about 1abadaba and 0 being reserved versions, with a ref to Section 4 of the transport draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#pullrequestreview-94196328

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 10:15:03 -0800

8f9fa1f  Reference to QUIC-TRANSPORT

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097/files/419eb0ff3bb18e907967fbf619e5e42879054a05..8f9fa1f47c6f960c982cf05fa096f6d3a2606252

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 10:19:41 -0800

Merged #1097.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1097#event-1460742347