Subject: Re: [quicwg/base-drafts] Priority grouping node ambiguity (#441)

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 19:28:48 +0000 (UTC)

I floated a proposal as an HTTP/2 extension, in the form of https://tools.ietf.org/html/draft-bishop-httpbis-priority-placeholder (expired draft).  That didn't get much traction on the HTTP/2 side, though there was at least one comment that we should just do this in HTTP/QUIC directly.

Are we interested in adopting that approach in HTTP/QUIC separately from HTTP/2?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363537250

---

From: ianswett <[email-masked]>
Date: Tue, 06 Feb 2018 19:55:49 +0000 (UTC)

I think this is worth discussion.  Given this wouldn't need to be an extension for QUIC, if we did this, I'd like to see strict rules on when one can depend upon a stream.  ie: streams can only depend upon placeholders or leaf node streams.  

Or we should do something entirely different.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363545385

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 22:21:13 +0000 (UTC)

I think I'd prefer strict rules about pruning the tree.  I don't so much want to constrain the tree's structure as make sure both sides have a consistent view of it, which is one of the biggest drawbacks of the strategy in h2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363584875

---

From: ianswett <[email-masked]>
Date: Tue, 06 Feb 2018 22:27:28 +0000 (UTC)

I strongly support not taking the existing H2 priority scheme with no modifications.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363586602

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 06 Feb 2018 16:20:29 -0800

My preference goes to making minimal changes to the H2 prioritization tree.

If there is a benefit in switching to an approach other than the one we use in H2, it is likely that the HTTPx over TCP would would benefit from the switch as well. So why not do that in HTTPWG?

Going back to the topic of what the minimal change could be, I think the only thing that we need to do is find a code point for grouping node.

Fortunately, we have that space: the number space for client->server unidirectional streams. By definition, H2 priority is a scheme for controlling server's emission. Therefore, there is a guarantee that client -> server unidirectional streams will never be covered by prioritization.

I admit that this might sound like a hack. But proposing it anyways since IMO it demonstrates what a minimal change could look like.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363612116

---

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Feb 2018 00:23:31 +0000 (UTC)

There is also the possibility of defining explicit request identifiers rather than use stream IDs for identifying requests.  That has some benefits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/441#issuecomment-363612673