Subject: [quicwg/base-drafts] 0-based indexing (#1145)

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Feb 2018 03:16:25 +0000 (UTC)

QPACK (?) uses the same 1-based indexing that HPACK does.  But if we contemplate #1144, then all that 1-based indexing does is create an unused value.  That's annoying.  0-based indexes are more common and are natural.  We tolerated 1-based indexing in HPACK because it make name indexes somewhat easier to manage.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1145

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Feb 2018 08:46:31 -0800

We tolerated it because losing one value to a sentinel was deemed better than losing an entire bit.  However, with the reworked instruction space, we wouldn't be able to reclaim a bit by using a sentinel, so I'd be fine with reclaiming the value.  (Of course, as with each step in this direction, that means we're departing further and further from HPACK equivalence.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1145#issuecomment-369302376