Subject: [quicwg/base-drafts] hq Alt-Svc quic parameter and structured headers (#1093)

From: Lucas Pardue <[email-masked]>
Date: Fri, 02 Feb 2018 14:30:18 +0000 (UTC)

I think the current syntax of the "quic" parameter for hq Alt-Svc is, after recent changes, incompatible with structured headers. For reference, https://github.com/httpwg/http-extensions/issues/281 provides history of the issue. This ticket highlights that HTTP/QUIC is now incompatible. 

Please close this out if a non-issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093

---

From: Mike Bishop <[email-masked]>
Date: Fri, 02 Feb 2018 18:32:20 +0000 (UTC)

Technically, it's a non-issue, since Alt-Svc isn't defined to be a structured header.  However, the goal is to track that draft as closely as reasonable, since it also represents a best practice.  I'll take a look and see if there's a simple change that would bring us closer, but I also don't want change for change's sake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362662352

---

From: Mike Bishop <[email-masked]>
Date: Fri, 02 Feb 2018 18:33:45 +0000 (UTC)

Seems like the simplest choice would be a comma-delimited quoted string, i.e.

```
quic = DQUOTE version-number [ "," version-number ] * DQUOTE
version-number = 1*8HEXDIG; hex-encoded QUIC version
```

That certainly makes it shorter and matches the guidance, at the price of updating everyone's parser again.  What do folks think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362665000

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 02 Feb 2018 18:51:42 +0000 (UTC)

I have no strong stake.

Good point about structured header / best common practice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362671545

---

From: ianswett <[email-masked]>
Date: Fri, 02 Feb 2018 14:08:07 -0800

So, oddly enough GQUIC has already started supporting the newly proposed IETF Alt-Svc, but if we're going to change it, sooner would be better.  And if you change it again after this time, we'll probably start getting grumpy :)

But shorter and following best practices seems like general goodness.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362721928

---

From: Subodh Iyengar <[email-masked]>
Date: Fri, 02 Feb 2018 23:35:25 +0000 (UTC)

+1 on sooner the better. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362741030

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Feb 2018 00:07:54 +0000 (UTC)

+1 -- Let's do this, and ASAP.

On Fri, Feb 2, 2018 at 3:35 PM, Subodh Iyengar <[email-masked]>
wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362741030>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1GBKYo_NbQhEGSC4sTsQUW7smFM6ks5tQ5u8gaJpZM4R3PmO>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#issuecomment-362747272

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 18:19:42 +0000 (UTC)

Closed #1093 via #1097.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1093#event-1460742350