Subject: Re: [quicwg/base-drafts] Define "httpq" (#348)

From: Lucas Pardue <[email-masked]>
Date: Fri, 02 Feb 2018 15:07:53 -0800

FWIW

The ["Is HTTP being used?" section](https://github.com/httpwg/http-extensions/blob/master/draft-ietf-httpbis-bcp56bis.md#is-http-being-used-used) in bcp56bis defines clauses that are used to determine if the protocol _uses_ HTTP or is _based_ on HTTP. 

It could be argued that HTTP/QUIC satisfies only one of those clauses, that a "http" or "https" scheme is used. Defining and using "httpq" could mean that we lose the tie and violate BCP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/348#issuecomment-362735428

---

From: Mike Bishop <[email-masked]>
Date: Fri, 02 Feb 2018 23:12:07 +0000 (UTC)

Given that we're porting HTTP to a new transport, I would expect the definition in that draft to expand to include the "hq" ALPN token if this draft completes first.  Also, if we take this draft, the transport port in use would be :443.  And lastly, since Alt-Svc is the common case, the scheme will be http:// or https:// most of the time -- this simply provides another option.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/348#issuecomment-362736324

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 02 Feb 2018 23:26:18 +0000 (UTC)

All fair points, I was being a bit surreptitious.

Although I was under the impression that use of port 443 was no longer explicitly specified in HTTP/QUIC. It falls under the "any UDP port" statement.

It would be horrible if, formally speaking, the combination of clauses means sometimes HTTP/QUIC is using HTTP and sometimes its not. That might mean that bcp56bis needs some tightening up.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/348#issuecomment-362739245

---

From: Mike Bishop <[email-masked]>
Date: Fri, 02 Feb 2018 23:35:44 +0000 (UTC)

It's not, in the current document, since it's only used with Alt-Svc and Alt-Svc always gives you an explicit port.  This PR defines UDP port 443 as the default for the httpq:// scheme, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/348#issuecomment-362741103

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 02 Feb 2018 15:37:43 -0800

> This PR defines UDP port 443 as the default for the httpq:// scheme, though.

Quite right, forgot/missed that sorry!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/348#issuecomment-362741538

---

From: Mike Bishop <[email-masked]>
Date: Tue, 06 Feb 2018 11:17:09 -0800

@MikeBishop pushed 1 commit.

871d547  Section anchor

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/348/files/e6cc9d5464c6103da62a066b485cbad4e8930fdd..871d54738fe7312ffde2a3f99be965d3a57a1849