Subject: [quicwg/base-drafts] Base in header table updates (#1124)

From: Martin Thomson <[email-masked]>
Date: Wed, 21 Feb 2018 03:05:26 +0000 (UTC)

The inclusion of a base in header table updates makes updating unnecessarily harder.  Because only a single stream updates the table, the state of the table is well defined ahead of each instruction.  References relative to a base increase the likelihood of programming errors.  It is also awkward to use a name-reference that was recently introduced.  For instance, if 'custom: b' follows 'custom: a', then the current design requires that the header block be closed after sending 'custom: a' so that 'custom: b' can reference the name.

Using the HPACK reference scheme for updates avoids all sorts of problems.  It makes it possible to write an update that refers to the most recent update without closing the last transaction and opening a new one.  Also, it makes it possible to write header table changes in a contiguous stream as suggested by #1121.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1124

---

From: afrind <[email-masked]>
Date: Wed, 21 Feb 2018 17:39:33 +0000 (UTC)

The current draft language is:

" For request and push promise streams, in HEADERS and PUSH_PROMISE frames, HPACK Header data is prefixed by an integer: "Base Index"."

So I don't think base is currently intended to be included in header table updates.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1124#issuecomment-367408202

---

From: Mike Bishop <[email-masked]>
Date: Mon, 26 Feb 2018 19:03:28 +0000 (UTC)

@martinthomson, is this based on a misreading per Alan's quoted text, or is this an actual issue that we need to work on?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1124#issuecomment-368611003

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Feb 2018 14:38:02 -0800

I think that as long as both use the same format and as long as that format includes a picture that shows Base, we have an issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1124#issuecomment-368676286