Subject: [quicwg/base-drafts] Move opportunistic ACK defense to security considerations (#1185)

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 13:45:04 +0000 (UTC)

Closes #305.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1185

-- Commit Summary --

  * Move opportunistic ACK defense to security considerations

-- File Changes --

    M draft-ietf-quic-transport.md (15)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1185.patch
https://github.com/quicwg/base-drafts/pull/1185.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185

---

From: Marten Seemann <[email-masked]>
Date: Tue, 13 Mar 2018 13:46:43 +0000 (UTC)

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#pullrequestreview-103434524

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 06:51:04 -0700

@martinthomson pushed 1 commit.

c8e1421  Not received

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185/files/b6319a22aa5a787d1f089d7599c579505962f2e5..c8e1421a892c0f55ab85caebf5222d9cb4af4df0

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 07:00:37 -0700

@martinthomson pushed 2 commits.

ef1a352  Be more precise about actions
7db18c7  Grammar

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185/files/c8e1421a892c0f55ab85caebf5222d9cb4af4df0..7db18c70a065f6cb927f2d5950c92b48bf20f5f7

---

From: Marten Seemann <[email-masked]>
Date: Tue, 13 Mar 2018 14:02:54 +0000 (UTC)

marten-seemann commented on this pull request.

> @@ -3896,6 +3890,15 @@ secure key, the attacker will not be able to generate forward-secure protected
 packets with ACK frames.

+## Opportunistic ACK Attack
+
+An endpoint that acknowledges packets it has not received might cause a
+congestion controller to permit sending at rates beyond what the network
+supports.  An endpoint MAY skip packet numbers when sending packets to detect
+this.  An endpoint can then drop connection state and stop sending packets
+toward the misbehaving peer.

That just means closing the connection, doesn't it? Why don't we say it explicitly?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#pullrequestreview-103441821

---

From: Mike Bishop <[email-masked]>
Date: Tue, 13 Mar 2018 14:05:01 +0000 (UTC)

MikeBishop commented on this pull request.

 packets with ACK frames.

Because "closing" generally means generating an error code, etc. to inform a peer that it made a mistake.  This is malicious behavior.  Also, by not making it normative, we leave room for any implementation-specific responses.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#discussion_r174142108

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Mar 2018 07:05:04 -0700

janaiyengar commented on this pull request.

 packets with ACK frames.

this -> this behavior

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#pullrequestreview-103442926

---

From: Sean Turner <[email-masked]>
Date: Tue, 13 Mar 2018 14:06:19 +0000 (UTC)

seanturner approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#pullrequestreview-103443422

---

From: ianswett <[email-masked]>
Date: Tue, 13 Mar 2018 07:11:48 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#pullrequestreview-103445698

---

From: ianswett <[email-masked]>
Date: Tue, 13 Mar 2018 14:12:01 +0000 (UTC)

Merged #1185.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1185#event-1518669424