Subject: Re: [quicwg/base-drafts] Version Negotiation Routing Problem (#1146)

From: MikkelFJ <[email-masked]>
Date: Fri, 02 Mar 2018 10:03:55 +0000 (UTC)

https://github.com/quicwg/base-drafts/pull/1151 will resolve this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-369878535

---

From: Martin Thomson <[email-masked]>
Date: Sun, 04 Mar 2018 19:26:17 -0800

I don't see how #1151 fails to fix this.  The client puts its preferred value in the packet it sends and the server has to use that value.  These values are available to all middleboxes on the path.  No exception is needed for Version Negotiation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370299789

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Mar 2018 02:03:42 -0800

@martinthomson I really like the changes in #1151 and it does solve most concerns. You argue my remaining issue is a matter of expections and that it is not specific to vneg:

The concern is that the server and the TLS handshake places some restrictions on the initial client source CID because it is required to be random. If the client exists in a complex p2p server network it might want detailed control of routing bits in CID. A middelbox could do NAT style routing setup and remember the CID for reverse routing, but that is an assumption on infrastructure. In particular the reverse route might take an entirely different path so NAT won't work at all. Encrypting the CID is an option even if less than 16 bytes, but not all infrastructure might want to do that.

At the same time there are (or ought to be) requirements on CIDs to be unique per tuple and for linkability concerns etc. so there is a broader discussion on what a CID must fulfill. Since a CID is allowed to be zero length, it cannot be very hard requirements in general.

So, removing randomness restrictions on CIDs and in place provide recommendations or requirements for specific usecases (linkability) would remove the concerns I still have.

Note that randomness is less important now that the server can always choose it's own CID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370369138

---

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Mar 2018 14:16:15 -0800

Only the destination connection ID needs to be random in that proposal.  The client sets the source connection ID in the Initial packet to whatever it likes.  The idea there being that the server will use this value in its destination connection ID on the return path.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370586906

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Mar 2018 14:25:52 -0800

Oh, maybe I'm not thinking clearly here. In vneg dest is random, fine. On normal handshake destination is replaced by servers chosen source. And then both CID's are free. Yes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370589548

---

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Mar 2018 14:32:18 -0800

Close this then?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370591298

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Mar 2018 22:38:19 +0000 (UTC)

I'd say its pending on the PR, but close it if you like.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#issuecomment-370592894

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 06:00:53 -0700

Closed #1146 via b6db6fae2815b363b6b7f46b8f001eb88f21b56e.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1146#event-1518511107