Subject: [quicwg/base-drafts] Fix up Packet Number explaination (#1182)

From: Sean Turner <[email-masked]>
Date: Tue, 13 Mar 2018 11:13:39 +0000 (UTC)

s5.7 contains the following:

A packet number is decoded by finding the packet number value that is closest to the next expected packet. The next expected packet is the highest received packet number plus one. For example, if the highest successfully authenticated packet had a packet number of 0xaa82f30e, then a packet containing a 16-bit value of 0x1f94 will be decoded as 0xaa831f94.

I read this a couple of times and the first time I got:
highest packed number = 0xaa82f30e + 1 = 0xaa82f30f +0x1f94 = aa8312A3
But, if I drop the bytes that are the same length as what's sent 4 for 0x1f94 form  0xaa82f30e you get  0xaa82 then add 1 and 0x194 I get 0xaa831f94.  Maybe there's a better way to say this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1182

---

From: Sean Turner <[email-masked]>
Date: Wed, 14 Mar 2018 04:25:22 -0700

Closed #1182.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1182#event-1520698399

---

From: Sean Turner <[email-masked]>
Date: Wed, 14 Mar 2018 11:25:23 +0000 (UTC)

closed via #674 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1182#issuecomment-372988630