Subject: Re: [quicwg/base-drafts] Prime client with connection ID for 0-RTT (#584)

From: ianswett <[email-masked]>
Date: Tue, 13 Mar 2018 17:44:43 +0000 (UTC)

The editors discussed this and especially with the new varlen connection IDs, we don't believe a new packet type is necessary.

We can imagine this being useful to limit the scope of resumption for the purpose of preventing replay.

After discussing the mechanisms, bundling the ID in the transport params is one approach, since implementations are expected to be able to store transport params for future 0RTTs.

The supplied connection ID(s) in the transport params could be used with any session ticket.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/584#issuecomment-372755763

---

From: hardie <[email-masked]>
Date: Mon, 19 Mar 2018 13:47:31 +0000 (UTC)

It seems like supplying the connection ID with the session ticket allows you to both use the same one for all session tickets supplied (the same as this proposal) or to vary them with session ticket supplied which might be useful in some routing contexts.  Could we consider that approach as well?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/584#issuecomment-374217104

---

From: ekr <[email-masked]>
Date: Mon, 19 Mar 2018 13:48:38 +0000 (UTC)

I think it's a reasonable idea in concept, but I'm not super-enthusiastic about the proposed newSessionTicket frame. As a practical matter, you're going to need your TLS stack to process the NST, so I'd rather just send it in stream/cream 0 and then have the TLS stack eat it. At that point you have two options:

1. Internal session cache, in which you interrogate the TLS stack after it has emitted CH (but before you send the packet) for its properties (whether 0-RTT is available, ALPN, etc.)
2. External session cache, in which the TLS stack tells you when a new ticket is available and its properties and you store it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/584#issuecomment-374217442