Subject: [quicwg/base-drafts] Ban trial decryption in TLS stream after rejected early data? (#1172)

From: Kyle Nekritz <[email-masked]>
Date: Wed, 07 Mar 2018 00:14:18 +0000 (UTC)

TLS 1.3 early data requires trial decryption after rejecting early data to skip over the records encrypted with 0-RTT keys that cannot be decrypted before you get to the client finished. In QUIC there will be no app data 0-RTT records, and the EndOfEarlyData is required by TLS to only be sent if early data is accepted, so there will be no records to skip but a TLS implementation will still likely set its record layer to skip TLS records that fail decryption.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1172

---

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Mar 2018 03:46:29 -0800

Seems reasonable to allow the stack to disable trial decryption.  I wouldn't require this though, because that might be more intrusive than stacks might like (for instance, I doubt that we would provide a knob for this in NSS).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1172#issuecomment-371113636

---

From: Sean Turner <[email-masked]>
Date: Thu, 15 Mar 2018 05:23:20 -0700

Closed #1172 via 6ea7707fad350f00d0ed12aea8a3ff58d8b524f1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1172#event-1523141516