Subject: Re: [quicwg/base-drafts] Referencing strategy (#1129)

From: krasic <[email-masked]>
Date: Fri, 09 Mar 2018 18:43:06 +0000 (UTC)

Complementary to preventing blocked evictions, another tactic might be to duplicate whenever a reference is generated for an index that requires or is close to the point that requires more than one byte to represent.     e.g. if indicies < 128 require one byte, and all others require tow or more.   Then whenever a reference to entry >= (128 - epsilon), duplicate.     This could save quite a few bytes if there would otherwise be a time window when an entry that requires more than one byte is popular.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1129#issuecomment-371908172

---

From: afrind <[email-masked]>
Date: Fri, 09 Mar 2018 20:02:57 +0000 (UTC)

I'm not sure there's any design work that needs to come of this issue, but editorial work in a section describing different possible approaches to reference strategy.

I think it makes sense to describe the 'draining index' algorithm, and also Buck's proposed optimization.  I'm somewhat skeptical many implementations are going to go to the length Martin described in choosing how much free space to keep in the table.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1129#issuecomment-371930092