Subject: [quicwg/base-drafts] Simplify ACKing rules by prohibit sending or processing ACK frames in 0RTT packets (#1187)

From: ianswett <[email-masked]>
Date: Wed, 14 Mar 2018 03:36:45 -0700

The rules about sending acknowledgements have been commented as too complex.  This issue is an effort to simplify them slightly.

A client may have 0RTT keys when sending ACK frames, but using them to send ACK frames may be ineffective and is unnecessary.

When 0RTT is successful, these ACK frames can be processed, but the only time 0RTT keys are available and 1RTT keys are not available is when HANDSHAKE packet types are being received, so there is no need to send these ACK frames with 0RTT protection, since HANDSHAKE packets are not encrypted.

When 0RTT is unsuccessful, these ACK frames cannot be processed and are a waste of bytes.  Even worse, if the client mistakenly believes the ACK frames can be processed, the handshake ends up relying solely on timeouts to succeed, which can increase tail latency substantially.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1187

---

From: ianswett <[email-masked]>
Date: Thu, 22 Mar 2018 07:59:25 -0700

This isn't a terrible idea, but it's likely to be super-ceded by the design team's work.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1187#issuecomment-375337138

---

From: ianswett <[email-masked]>
Date: Thu, 22 Mar 2018 14:59:26 +0000 (UTC)

Closed #1187.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1187#event-1535792381