Subject: [quicwg/base-drafts] Retransmit data, not frames (#1213)

From: ianswett <[email-masked]>
Date: Thu, 15 Mar 2018 16:56:27 +0000 (UTC)

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1213

-- Commit Summary --

  * Retransmit data, not frames

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1213.patch
https://github.com/quicwg/base-drafts/pull/1213.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1213

---

From: Nick Banks <[email-masked]>
Date: Thu, 15 Mar 2018 16:57:15 +0000 (UTC)

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1213#pullrequestreview-104290745

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Mar 2018 16:57:44 +0000 (UTC)

Merged #1213.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1213#event-1523798354

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Mar 2018 17:27:18 +0000 (UTC)

MikeBishop commented on this pull request.

> @@ -3419,7 +3419,7 @@ cryptographic handshake.  This includes the retransmission of the second flight
 of client handshake messages, that is, the TLS Finished and any client
 authentication messages.
 
-STREAM frames that are determined to be lost SHOULD be retransmitted before
+STREAM data in frames determined to be lost SHOULD be retransmitted before

Data in STREAM frames.  We wouldn't all-caps it if it's talking about "stream data".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1213#pullrequestreview-104302740

---

From: MikkelFJ <[email-masked]>
Date: Thu, 15 Mar 2018 10:29:10 -0700

mikkelfj commented on this pull request.

Could it be stated more explicitly that retransmitted data may have different framing and overlap, just to avoid the odd interop problem?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1213#discussion_r174866426