Subject: Re: [quicwg/base-drafts] add an error code for rejecting new connections (#1137)

From: Marten Seemann <[email-masked]>
Date: Fri, 02 Mar 2018 03:38:32 +0000 (UTC)

marten-seemann commented on this pull request.

> @@ -926,8 +926,11 @@ server continues below.
 
 If the packet is an Initial packet fully conforming with the
 specification, the server proceeds with the handshake ({{handshake}}).
-This commits the server to the version that the client
-selected.
+This commits the server to the version that the client selected.
+
+If the server currently doesn't accept any new connections, it SHOULD send a
+SERVER_BUSY error code. A client that receives this error code SHOULD NOT
+immediately try to reconnect to this server.

Thanks for the suggestion. That sounds better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137#discussion_r171758776

---

From: Marten Seemann <[email-masked]>
Date: Fri, 02 Mar 2018 03:39:05 +0000 (UTC)

@marten-seemann pushed 1 commit.

a8f0331  Mike's review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137/files/ff9ae904eafa4195044ea04b7cd0d3864e5935d9..a8f0331e79e45364b20714b8c9200b5320f29731

---

From: Martin Thomson <[email-masked]>
Date: Fri, 02 Mar 2018 04:02:01 +0000 (UTC)

@martinthomson pushed 1 commit.

eab5b3e  Add SERVER_BUSY to IANA table

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137/files/a8f0331e79e45364b20714b8c9200b5320f29731..eab5b3e30b102bdaeffb3cdee3f141b8abd3ccb9

---

From: Martin Thomson <[email-masked]>
Date: Fri, 02 Mar 2018 04:03:16 +0000 (UTC)

Merged #1137.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1137#event-1500452384