Subject: [quicwg/base-drafts] loss recovery timers are based on time of last retransmittable packet (#1219)

From: Marten Seemann <[email-masked]>
Date: Fri, 16 Mar 2018 15:15:17 -0700

If I understand the loss recovery correctly, we should base the loss recovery timers (TLP and RTO) on the send time of the last retransmittable packet, not the last packet sent.

@janaiyengar, @ianswett: Is that correct?
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1219

-- Commit Summary --

  * loss recovery timers are based on time of last retransmittable packet

-- File Changes --

    M draft-ietf-quic-recovery.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1219.patch
https://github.com/quicwg/base-drafts/pull/1219.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219

---

From: ianswett <[email-masked]>
Date: Fri, 16 Mar 2018 15:41:49 -0700

ianswett commented on this pull request.

> @@ -506,8 +506,8 @@ largest_sent_before_rto:
 : The last packet number sent prior to the first retransmission
   timeout.
 
-time_of_last_sent_packet:
-: The time the most recent packet was sent.
+time_of_last_sent_retransmittable_packet:

I'm trying to remove the use of retransmittable from this document in a different PR, so I'd prefer not to add it here.  Can you change the text below to be "The time the most recent congestion-controlled packet was sent."?  For the variable rename, is there something shorter we could come up with that doesn't use the word retransmittable?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#pullrequestreview-104736907

---

From: Marten Seemann <[email-masked]>
Date: Fri, 16 Mar 2018 16:09:38 -0700

marten-seemann commented on this pull request.

I used retransmitted here since your PR isn't merged yet.

Maybe we can call these packets ackable instead of congestion controlled? I'm not sure if I really like this term, since ACK-only packets can also be acked (later, as soon as a retransmittable packet is received), but I can't think of anything better right now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#discussion_r175234070

---

From: MikkelFJ <[email-masked]>
Date: Fri, 16 Mar 2018 16:12:43 -0700

mikkelfj commented on this pull request.

time_of_last_ack_eliciting_packet?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#discussion_r175234369

---

From: Patrick McManus <[email-masked]>
Date: Sat, 17 Mar 2018 08:44:35 +0000 (UTC)

"reliable information" ?

On Sat, Mar 17, 2018 at 12:12 AM, MikkelFJ <[email-masked]> wrote:

> *@mikkelfj* commented on this pull request.
> ------------------------------
>
> In draft-ietf-quic-recovery.md
> <https://github.com/quicwg/base-drafts/pull/1219#discussion_r175234369>:
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/1219#discussion_r175234369>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s8EP3gKo7-NOi_-GH4Ou-4xVI17uks5tfEbpgaJpZM4Sugcf>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373904434

---

From: Marten Seemann <[email-masked]>
Date: Sat, 17 Mar 2018 02:27:21 -0700

I think the discussion about the right term belongs in #1211. Ian chose "congestion controlled" there, and I'm fine with this term, although it makes variable names pretty long.

If we merge this PR here first, #1211 should be rebased and change the variable name. If we merge #1211 first, I'll rebase this PR to reflect whatever term we came up with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373906726

---

From: MikkelFJ <[email-masked]>
Date: Sat, 17 Mar 2018 10:43:27 +0000 (UTC)

We could define two terms more explicitly elsewhere - for example Signal packet and Reliable packet where signal packets must elicit an ACK and Carrier packets SHOULD elicit an ack.
It still sort of suggests that the packet is retransmitted, but then, the logic as at packet level.

The name would then be, as @mcmanus suggests:

time_of_last_sent_reliable_packet 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373910743

---

From: ianswett <[email-masked]>
Date: Sat, 17 Mar 2018 10:51:59 +0000 (UTC)

I'd rather not introduce the word reliable here, since this term is really
about whether it counts towards bytes_in_flight and therefore whether it
invokes an ack.

Even in a use case where nothing is ever retransmitted, congestion control
and acknowledgement behavior are still relevant.

On Sat, Mar 17, 2018 at 6:43 AM MikkelFJ <[email-masked]> wrote:

> We could define two terms more explicitly elsewhere - for example Signal
> packet and Reliable packet where signal packets must elicit an ACK and
> Carrier packets SHOULD elicit an ack.
> The name would then be, as @mcmanus <https://github.com/mcmanus> suggests:
>
> You are receiving this because you were mentioned.
> <https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373910743>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ATJJcWEnAcggepFIuVWdGwhYEIwWyKAdks5tfOjOgaJpZM4Sugcf>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373911201

---

From: Subodh Iyengar <[email-masked]>
Date: Sat, 17 Mar 2018 08:30:32 -0700

looks good to me. I'm also fine with the use of the word ``retransmittable``

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#issuecomment-373928797

---

From: ianswett <[email-masked]>
Date: Sat, 17 Mar 2018 23:24:29 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#pullrequestreview-104781020

---

From: ianswett <[email-masked]>
Date: Sat, 17 Mar 2018 23:24:36 +0000 (UTC)

Merged #1219.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1219#event-1527038013