Subject: Re: [quicwg/base-drafts] Stateless Reset from clients (#466)

From: MikkelFJ <[email-masked]>
Date: Fri, 09 Mar 2018 08:56:45 +0000 (UTC)

Added a more general issue to discuss relevance/importance of reset in #1177

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/466#issuecomment-371752562

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 09:05:56 -0700

Based on #1151 being merged, the idea here is to change the client/server text on stateless reset to be endpoint/peer and allow clients to send one.  Then add a small paragraph noting that the client cannot send the token in its transport parameters because they aren't encrypted, therefore only the second client connection ID, as provided with NEW_CONNECTION_ID, is the first that can be used with stateless reset.

That's not a perfect solution.  Client's can't guarantee that servers will move to a new connection ID, for instance.  But it's a step in that direction that we can iterate on.  We aren't sure that we'll get around to a more complete fix before quicv2 though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/466#issuecomment-372720237