Subject: [quicwg/base-drafts] Moving version before connection ID in the long header (#1166)

From: ianswett <[email-masked]>
Date: Mon, 05 Mar 2018 19:52:52 -0800

As I mentioned on PR##1151, if we change to asymmetric connection IDs with variable length, it would be ideal to have the version come before the connection IDs in the long header, because then it would be at a fixed offset and the destination connection ID would also still be at a fixed(but 4 byte later) offset.

Due to the importance of Connection ID, there is no intent to remove Connection ID from the invariants, though this change may enable some extra flexibility far down the road.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1166

---

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 07:18:25 -0700

Closed #1166 via c0f9f0ff19e946f2821b5a1cb0220b8066405187.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1166#event-1518685946

---

From: helpingothers4u <[email-masked]>
Date: Tue, 13 Mar 2018 15:34:30 +0000 (UTC)

I cannot remember my password and I am on my phone now that is my kindel
I'm trying get on in

Angela Risner

On Mar 13, 2018 9:18 AM, "Martin Thomson" <[email-masked]> wrote:

> Closed #1166 <https://github.com/quicwg/base-drafts/issues/1166> via
> c0f9f0f
> <https://github.com/quicwg/base-drafts/commit/c0f9f0ff19e946f2821b5a1cb0220b8066405187>
> .
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1166#event-1518685946>, or mute
> the thread
> <https://github.com/notifications/unsubscribe-auth/AjCympbshZA7sQdqHyG_wTQPi5EsKQr3ks5td9UxgaJpZM4SeENL>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1166#issuecomment-372708281