Subject: [quicwg/base-drafts] Define time_of_last_sent_handshake_packet (#1171)

From: ianswett <[email-masked]>
Date: Tue, 06 Mar 2018 21:11:44 +0000 (UTC)

Fixes Issue #962
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1171

-- Commit Summary --

  * Define time_of_last_sent_handshake_packet

-- File Changes --

    M draft-ietf-quic-recovery.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1171.patch
https://github.com/quicwg/base-drafts/pull/1171.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171

---

From: ianswett <[email-masked]>
Date: Tue, 06 Mar 2018 21:13:26 +0000 (UTC)

@ianswett pushed 1 commit.

23b00c9  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171/files/37c1aac6f302de721b27f1090e6dcde9d42cfa5e..23b00c9b640f198011b5828d75a3a7b0a4cf882f

---

From: ianswett <[email-masked]>
Date: Tue, 06 Mar 2018 21:13:34 +0000 (UTC)

a4e0dd9  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171/files/23b00c9b640f198011b5828d75a3a7b0a4cf882f..a4e0dd98d421de05d9a75052de7f7a4add60765e

---

From: Marten Seemann <[email-masked]>
Date: Fri, 09 Mar 2018 12:10:27 +0000 (UTC)

marten-seemann commented on this pull request.

> @@ -619,18 +623,24 @@ are as follows:
   ACK frame.  If true, it is still expected an ack will be received for
   this packet, but it is not congestion controlled.
 
+* is_handshake_packet: A boolean that indicates whether a packet is part of

How does this apply to ack-only packets sent during the handshake?

It we're regarding them as handshake packets here, we probably need to change `OnPacketSend`, such that `time_of_last_sent_handshake_packet` is only updated for retransmittable handshake packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171#pullrequestreview-102626030

---

From: ianswett <[email-masked]>
Date: Fri, 09 Mar 2018 13:47:05 +0000 (UTC)

ianswett commented on this pull request.

Ah, I was thinking a handshake packet was a packet with handshake data in it, not based on packet type, but I'll restructure to make it clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171#discussion_r173453233

---

From: ianswett <[email-masked]>
Date: Fri, 09 Mar 2018 13:52:12 +0000 (UTC)

d8d6480  Marten's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171/files/a4e0dd98d421de05d9a75052de7f7a4add60765e..d8d6480de10bb5688046e2d85e0db723b903e0ed

---

From: Marten Seemann <[email-masked]>
Date: Mon, 12 Mar 2018 06:49:50 +0000 (UTC)

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171#pullrequestreview-102935185

---

From: ianswett <[email-masked]>
Date: Mon, 12 Mar 2018 06:54:39 -0700

Merged #1171.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1171#event-1516272988