Subject: [quicwg/base-drafts] Closing or draining state after idle timeout? (#1178)

From: Lars Eggert <[email-masked]>
Date: Fri, 09 Mar 2018 00:54:20 -0800

Section 7.9.1 says:
> An endpoint enters a **closing period** after initiating an immediate close (Section 7.9.3) and optionally after an idle timeout (Section 7.9.2). 

But Section 7.9.2 says:
> A connection enters the **draining state** when the idle timeout expires.

Which is it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 09:16:20 +0000 (UTC)

Hmm, I think that it has to be draining.  Without a CONNECTION_CLOSE to signal an end, both endpoints could enter closing and that would be bad.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371757223

---

From: Lars Eggert <[email-masked]>
Date: Fri, 09 Mar 2018 09:18:50 +0000 (UTC)

Shouldn't a *_CLOSE frame be sent prior to that? Otherwise the other side needs to wait for an idle timeout, too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371757835

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 09:19:36 +0000 (UTC)

Yes, but the expectation is that both peers hit this at about the same time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371758044

---

From: Lars Eggert <[email-masked]>
Date: Fri, 09 Mar 2018 09:20:07 +0000 (UTC)

Why would that be? Both can use different idle timeouts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371758143

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 02:59:39 -0800

The minimum of the two applies.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371781776

---

From: Marten Seemann <[email-masked]>
Date: Fri, 09 Mar 2018 11:28:24 +0000 (UTC)

Why would that be? A server might want choose a much shorter idle timeout than a client.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371787800

---

From: Lars Eggert <[email-masked]>
Date: Fri, 09 Mar 2018 11:37:47 +0000 (UTC)

The minimum applies? Where does it say that?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371789651

---

From: janaiyengar <[email-masked]>
Date: Fri, 09 Mar 2018 13:21:35 -0800

A server might choose a smaller value, but both sides should close when the earliest end times out.  The draft doesn't say anything about this, which is an oversight. I'll fix it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#issuecomment-371948477

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 14:33:11 -0800

Closed #1178 via #1179.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1178#event-1514265647