Subject: [quicwg/base-drafts] min_rtt could stay 0 (#1169)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 06 Mar 2018 07:23:09 -0800

https://tools.ietf.org/html/draft-ietf-quic-recovery-10#section-3.4.3 says that min_rtt is initialized to 0.

And it is updated using the following formula: 

      // min_rtt ignores ack delay.
       min_rtt = min(min_rtt, latest_rtt)

This means that unless latest_rtt is negative (not possible), min_rtt stays 0.
I think there is missing something which treats 0 min_rtt as special, but not sure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1169

---

From: ianswett <[email-masked]>
Date: Wed, 14 Mar 2018 12:53:43 -0700

Closed #1169 via 929274c286e56d144b1741862fbb72ba414dfded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1169#event-1521832319