Subject: [quicwg/base-drafts] Clients ignore packets of unknown versions (#1192)

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Mar 2018 14:19:11 +0000 (UTC)

Closes #827.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1192

-- Commit Summary --

  * Clients ignore packets of unknown versions

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1192.patch
https://github.com/quicwg/base-drafts/pull/1192.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1192

---

From: Nick Banks <[email-masked]>
Date: Wed, 14 Mar 2018 14:31:01 +0000 (UTC)

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1192#pullrequestreview-103841864

---

From: janaiyengar <[email-masked]>
Date: Wed, 14 Mar 2018 07:45:36 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1192#pullrequestreview-103848536

---

From: janaiyengar <[email-masked]>
Date: Wed, 14 Mar 2018 07:45:47 -0700

Merged #1192.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1192#event-1521119526

---

From: MikkelFJ <[email-masked]>
Date: Wed, 14 Mar 2018 09:55:49 -0700

mikkelfj commented on this pull request.

> @@ -888,6 +888,9 @@ that are encrypted with a key it has not yet computed. Clients MAY drop these
 packets, or MAY buffer them in anticipation of later packets that allow it to
 compute the key.
 
+If a client receives a packet that has an unsupported version, it MUST discard
+that packet.
+

Isn't that an invariant? Otherwise the next version could require the client to do a best effort on unknown versions, and a client would not know what guides the world.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1192#pullrequestreview-103907237