Subject: [quicwg/base-drafts] Defaults for SETTINGS and 0-RTT (#1157)

From: Martin Thomson <[email-masked]>
Date: Sun, 04 Mar 2018 23:44:59 -0800

The transport doc is pretty clear about how transport parameters are managed.  They have defaults, or are mandatory.

The HTTP mapping is less clear.  Right now, prior to receiving SETTINGS, it's not obvious what values you might assume for the header table size.  We should nail that down.  I suggest 0 until SETTINGS is received.  That allows for some sending, but implies no commitment of memory from the recipient.

For 0-RTT, the situation is worse.  We should just insist on the values being remembered, just like we do for transport parameters.  Right now we only have a SHOULD cache.  That would be OK if the assumed values were safe (0 table size is always safe to assume), but they aren't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1157

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Mar 2018 12:29:37 +0000 (UTC)

Closed #1157 via #1207.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1157#event-1523152412