Subject: [quicwg/base-drafts] Running out of NEW_CONNECTION_ID (#1163)

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Mar 2018 22:27:47 +0000 (UTC)

@mirjak asked what happens if you need to send using a different connection ID, but you ran out the supply from your peer?

I think that it is possible to adopt two policies: either favour continuity at the expense of linkability, or favour unlinkability at the expense of continuing the session.  We should explain this trade-off somewhere.  We should also encourage the provision of an ample supply of connection IDs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1163

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Mar 2018 22:44:37 +0000 (UTC)

There is also the DoS concern, forcing routing state both at endpoint and middleware.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1163#issuecomment-370594672

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 11:40:23 +0000 (UTC)

Discussed at editors' meeting. An endpoint can receive and process packets ok even if it doesn't have a new connection ID to use in response to a new one received. When it is about to send however, it needs to have a new connection ID (as per Section 6.7.1). If the endpoint doesn't have a new connection ID to use, we think the endpoint should immediately drop all connection state and respond to the packet with a stateless reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1163#issuecomment-373347872