Subject: [quicwg/base-drafts] inconsistent definition of the TLP duration (#1220)

From: Marten Seemann <[email-masked]>
Date: Fri, 16 Mar 2018 22:43:29 +0000 (UTC)

The text says

> The alarm duration, or Probe Timeout (PTO), is set based on the following conditions:
> * PTO SHOULD be scheduled for max(1.5*SRTT+MaxAckDelay, 10ms)
> * If RTO (Section 3.3.2) is earlier, schedule a TLP alarm in its place. That is, PTO SHOULD be scheduled for min(RTO, PTO).

The second point is missing in the pseudo code:
```
else if (tlp_count < kMaxTLPs):
      // Tail Loss Probe
      alarm_duration = max(1.5 * smoothed_rtt + max_ack_delay, kMinTLPTimeout)
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1220

---

From: Praveen Balasubramanian <[email-masked]>
Date: Sun, 18 Mar 2018 07:03:19 +0000 (UTC)

Yes this is needed otherwise the alarm duration could be too conservative in some cases.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1220#issuecomment-373977252

---

From: ianswett <[email-masked]>
Date: Sun, 18 Mar 2018 09:49:31 +0000 (UTC)

Agreed, the psuedocode should be updated to include this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1220#issuecomment-373985210

---

From: ianswett <[email-masked]>
Date: Sun, 18 Mar 2018 12:25:59 +0000 (UTC)

Closed #1220 via #1225.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1220#event-1527210875