Subject: [quicwg/base-drafts] Change Index-Duplicate instruction code point (#1235)

From: afrind <[email-masked]>
Date: Mon, 19 Mar 2018 13:20:16 +0000 (UTC)

Changed the instruction for duplicate from 001/5+ to 1/7+.  This is because Table Size Update is otherwise a valid QPACK instruction

Fixes #1142
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1235

-- Commit Summary --

  * Change Index-Duplicate instruction code point

-- File Changes --

    M draft-ietf-quic-qpack.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1235.patch
https://github.com/quicwg/base-drafts/pull/1235.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1235

---

From: Mike Bishop <[email-masked]>
Date: Tue, 20 Mar 2018 04:33:44 -0700

MikeBishop commented on this pull request.

> @@ -253,7 +253,7 @@ Indexed-Duplicate representation instead (see {{indexed-duplicate}}).
 ~~~~~~~~~~  drawing
     0 1 2 3 4 5 6 7
    +-+-+-+-+-+-+-+-+
-   |0|0|1|Index(5+)|
+   |1|Index(7+)    |

Center, and probably a space before the parenthesis since there's room.

> @@ -262,8 +262,8 @@ Indexed-Duplicate representation instead (see {{indexed-duplicate}}).
 an existing entry. {{RFC7541}} allows duplicate HPACK table entries, that is
 entries that have the same name and value.
 
-This replaces the HPACK instruction for Dynamic Table Size Update (see Section
-6.3 of {{RFC7541}}, which is not supported by HTTP over QUIC.
+This repurposes the HPACK instruction for Indexed Header Field (see Section
+6.1 of {{RFC7541}}.

This wording might be confusing to some readers.  It might be more accurate to say that you're defining the behavior of this instruction on the control stream, while it retains its usual meaning on the request streams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1235#pullrequestreview-105308786

---

From: Mike Bishop <[email-masked]>
Date: Tue, 20 Mar 2018 04:34:05 -0700

I like that this makes the instructions sets have fewer invalid values.  I dislike that it gives a short prefix code to one of the least-common instructions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1235#issuecomment-374565497

---

From: afrind <[email-masked]>
Date: Tue, 20 Mar 2018 08:15:29 -0700

@afrind pushed 1 commit.

7e9cdd4  Mike's feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1235/files/97608d8f418b1daa4fec0f1db45c85a39e6ff80b..7e9cdd481935ae105392cd5bb1640b2360780986