Subject: [quicwg/base-drafts] hq: Can we have payload diagrams for all frames? (#1158)

From: Lucas Pardue <[email-masked]>
Date: Mon, 05 Mar 2018 04:14:47 -0800

Hi,

I've been caught out again by HTTP/QUIC doc's "inconsistent" approach to diagramming the payload of frames. Specifically the `GOAWAY` frame in this case but it affects other frames too.

I appreciate a diagram for a single field is a bit of overkill, however I think it is of value and I would be happy to prepare a PR to do so. Comparing HTTP to Transport, there are diagrams for MAX_STREAM_ID, BLOCKED, PATH_CHALLENGE etc

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1158

---

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Mar 2018 19:41:54 +0000 (UTC)

I thought @martinthomson had filed an issue requesting this as well, but I don't see it.  By popular demand, I'm willing to add them, but would gladly accept a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1158#issuecomment-370538785

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 05 Mar 2018 19:49:56 +0000 (UTC)

Ok let me see what I can come up with...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1158#issuecomment-370540434

---

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Mar 2018 20:20:49 +0000 (UTC)

Closed #1158 via #1162.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1158#event-1505020073