Subject: [quicwg/base-drafts] PING guidance (#1240)

From: MikkelFJ <[email-masked]>
Date: Mon, 19 Mar 2018 15:00:37 +0000 (UTC)

It is unclear how fast an endpoint should respond to PING so some clarification would be useful.

It could be no later than when the delayed ACK timer expires because this is the latest an ACK can be deferred. But it could also be expected to be ASAP and used for timing data, or it could be application dependent.

There is also a potential for abuse - as others have pointed out recently, just adding PING to ACK frames can force the hand of the peer. But, if PING is responded to particularly fast, this could be worse than with normal delayed ACKs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1240

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Mar 2018 10:10:22 -0700

Closed #1240.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1240#event-1529034616

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Mar 2018 17:10:23 +0000 (UTC)

With PATH_CHALLENGE, the current text is fine.  PING is acknowledged, as normal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1240#issuecomment-374291053