Subject: Re: [quicwg/base-drafts] Initial packet is special (#627)

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Mar 2018 10:35:22 +0000 (UTC)

Editors discussed this, and for both Handshake and Retry from the server, we will mandate the inclusion of ACK.  This allows clients to drive loss detection based purely on ACK logic.  However, we will encourage clients not to send more Initial packets if they get packets from the server.  This might be happen if they receive packets out of order or the packet with ACK is lost.  The client can then ACK rather than retransmitting the Initial.

Note that this creates a situation that makes no sense.  If the client receives an out-of-order packet from the server, it will assume that the Initial was lost and might reasonable send a Handshake containing an ACK and the ClientHello.  We need to separately disable sending Initial if packets are received (and only re-enable it if the packet was VN/Retry - both of those cause a new Initial packet to be created).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/627#issuecomment-372975861

---

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Mar 2018 10:41:50 +0000 (UTC)

Note that the issue OP makes a proposal.  I think that we're in the process of discussing that particular issue, but we need a little more clarity on that problem.  When that discussion matures some more, we can open an issue for stream 0 usage and offsets, etc...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/627#issuecomment-372977535