Subject: [quicwg/base-drafts] UDP-like, not exclusively UDP (#1250)

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Mar 2018 03:22:03 +0000 (UTC)

@enygren suggests:

Would it make sense to say that "endpoints exchange QUIC packets via a datagram protocol such as UDP"?  While we are currently only defining on UDP, there is nothing in invariants that would force this perpetually.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250

---

From: Lars Eggert <[email-masked]>
Date: Tue, 27 Mar 2018 06:57:22 +0000 (UTC)

Let's get an IP protocol number :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-376417811

---

From: ianswett <[email-masked]>
Date: Tue, 27 Mar 2018 05:53:00 -0700

>From the first sentence of the charter: "The QUIC working group will provide a standards-track specification for a UDP-based, stream-multiplexing..."

So I'm biased towards saying this is QUICv2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-376513526

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Mar 2018 18:15:47 -0700

I think that it is reasonable to say that we are developing invariants that are based on UDP.  In doing so we make no claims about the use of QUIC over other substrates (such as IP directly).  That seems perfectly OK.

This is invariants, so it can't be v2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-376727237

---

From: ianswett <[email-masked]>
Date: Wed, 28 Mar 2018 07:13:12 -0700

The invariants don't say anything about non-UDP substrates, as you note, so I think it can be v2, because non-UDP substrates are out of scope.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-376901629

---

From: Christian Huitema <[email-masked]>
Date: Thu, 29 Mar 2018 20:55:06 +0000 (UTC)

V2, please!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-377369350

---

From: Praveen Balasubramanian <[email-masked]>
Date: Sun, 01 Apr 2018 01:10:32 +0000 (UTC)

agreed, v2 or later.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-377735042