Subject: [quicwg/base-drafts] Reboot after 0-RTT reject (or version negotiation) (#1206)

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Mar 2018 04:11:41 -0700

When 0-RTT is rejected, you can't just pretend that your 0-RTT packets were dropped, you have to start over completely.

For example, if the client thought it could send 10 concurrent streams, and do so in 0-RTT, then when 0-RTT is rejected, it might be because the server wants to limit this to 5 streams.

For example, if the client thought it could use hq-10, but the server rejects 0-RTT because it chose hq-14, then the things it put on streams might not be understood by the server.

We need to document this VERY clearly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1206

---

From: Sean Turner <[email-masked]>
Date: Thu, 15 Mar 2018 05:23:19 -0700

Closed #1206 via 910a81f331ea7a9577c00325bf9c7d87c46ab705.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1206#event-1523141518