Subject: Re: [quicwg/base-drafts] Specify Version Negotiation after Crypto Failure (#1069)

From: Martin Thomson <[email-masked]>
Date: Sun, 04 Mar 2018 19:32:42 -0800

@huitema, do you think that the new text in [Section 7.1](https://quicwg.github.io/base-drafts/draft-ietf-quic-transport.html#rfc.section.7.1) helps here?  If not, perhaps you could recommend some text to add (and the appropriate location for that text).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1069#issuecomment-370300559

---

From: Christian Huitema <[email-masked]>
Date: Mon, 05 Mar 2018 06:17:49 +0000 (UTC)

Section 7.1.2 says: If a server receives a packet that has an unsupported version and sufficient length to be an Initial packet for some version supported by the server, it SHOULD send a Version Negotiation packet as described in Section 7.2.1. Servers MAY rate control these packets to avoid storms of Version Negotiation packets.

That's good, but I would add a specific caveat. "Packets from different versions may use different parameters when computing clear text packet protection per [some appropriate ref to the TLS draft]. Servers who do not support a particular version will not be able to decrypt the content of the packet. They still SHOULD send a Version Negotiation packet, as long as the message has a sufficient length."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1069#issuecomment-370320644

---

From: Martin Thomson <[email-masked]>
Date: Mon, 05 Mar 2018 22:25:25 +0000 (UTC)

Closed #1069 via #1156.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1069#event-1505254723