Subject: Re: [quicwg/base-drafts] IP Anycast with server IP+Port renegotiation (#560)

From: Martin Thomson <[email-masked]>
Date: Tue, 13 Mar 2018 09:40:47 -0700

This depends on a resolution to #880.  Editors discussed the inclusion of a preferred IP transport parameter and how that might be used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-372733017

---

From: Mike Bishop <[email-masked]>
Date: Tue, 13 Mar 2018 16:54:03 +0000 (UTC)

Proposal to be written up:

- New transport param with server's "preferred IP"
- Client MUST probe the server's preferred address following the Handshake
- Same constraints about how much data can be sent to an unvalidated IP address apply
- Need to talk about what happens if the client migrates before the probe completes (client SHOULD probe the preferred IP only; MAY probe the old IP if they fail)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-372737801

---

From: hardie <[email-masked]>
Date: Tue, 13 Mar 2018 20:00:27 +0000 (UTC)

On Tue, Mar 13, 2018 at 9:54 AM, Mike Bishop <[email-masked]>
wrote:

> When writing the proposal, can I ask that we be really clear about whether
we expect this to be used across address families?  If someone reaches
server X on an anycast IPv4 address, for example, will this transport param
be allowed to redirect them to an IPv6 address?  Or vice versa?

While I can see very valid reasons for doing so, that would be a change to
how happy eyeballs work, and I'd like to get review if it will be permitted.

thanks,

Ted

>    - Need to talk about what happens if the client migrates before the
>    probe completes (client SHOULD probe the preferred IP only; MAY probe the
>    old IP if they fail)
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/560#issuecomment-372737801>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABVb5FSCYEHuGMKhKFcYLZxhHuYfzZU-ks5td_mpgaJpZM4No0gk>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/560#issuecomment-372798883