Subject: Re: [quicwg/base-drafts] Endpoint symmetry (#462)

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 03:52:50 +0000 (UTC)

Right now we are moving on the connection ID issues: #1151

The connection migration issue is defining endpoint-agnostic mechanisms, but limiting applicability (the text needs work in my view, but it's basically right): #1012

Stateless reset is workable after #1151, but we'll need to change the wording somewhat, probably along the lines of what I requested in #1012.

The handshake is inherently asymmetric.  I think that we'll have to just live with that.

And I think that is the entire list of asymmetries.  Is there something else you think needs attention?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#issuecomment-371705742

---

From: MikkelFJ <[email-masked]>
Date: Fri, 09 Mar 2018 08:43:17 +0000 (UTC)

My opinion on reset is all over the place in these issues - #1177 - but that aside:

The symmetri in server p2p with fixed IP/port at both ends, i.e. static tuple. This in parts handle ephemeral port exhaustion, notably from reverse proxy to app server, and in part allows for simpler raw socket / netmap implementations, and non-IP/UDP transports in special cases.

This was almost supported at one point, but apparently it was reverted in Melbourne though I'm not sure why, or if this still apply, or if it applies for the duration of the connection or only during handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#issuecomment-371749524

---

From: Martin Thomson <[email-masked]>
Date: Fri, 09 Mar 2018 01:15:00 -0800

The idea here would be, after #1151, to allow stateless reset from clients.  A stateless reset wouldn't be usable until the server moved to a connection ID that was provided with NEW_CONNECTION_ID though.

The reason symmetric stateless reset was dropped was that the token couldn't be carried with confidentiality protection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#issuecomment-371756907

---

From: Mike Bishop <[email-masked]>
Date: Fri, 09 Mar 2018 22:47:48 +0000 (UTC)

(And note that the client can, after the in-flight PRs, force a change of CID by changing its own CID.  However, a client that doesn't require a CID also can't issue the server a new one, and hence can't issue the server a PR token.  This is reasonably similar to the current strawman algorithm's requirement of CIDs as an input to the token creation, but goes a step further in making it part of the protocol.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#issuecomment-371967370

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Mar 2018 15:55:51 +0000 (UTC)

Closed #462.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#event-1518953253

---

From: janaiyengar <[email-masked]>
Date: Tue, 13 Mar 2018 15:55:52 +0000 (UTC)

Closing this issue since we have issues tracking the various individual mechanisms listed, and symmetry is not driving design for QUICv1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/462#issuecomment-372716365