Subject: [quicwg/base-drafts] Add unknown packet handling to invariants (#1197)

From: MikkelFJ <[email-masked]>
Date: Wed, 14 Mar 2018 09:58:18 -0700

#827 mentions that packets of unknown versions must be dropped.
But it is hard to make a version related requirement for a specific QUIC version, when clients can implement multiple versions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Mar 2018 09:25:08 +0000 (UTC)

The type of a packet is not an invariant, so what do you imagine we might do to distinguish "unknown" here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197#issuecomment-373312393

---

From: MikkelFJ <[email-masked]>
Date: Thu, 15 Mar 2018 12:53:02 +0000 (UTC)

Sorry for being unclear - I meant to express the same as #827 does and the commit that resolves it:

"If a client receives a packet that has an unsupported version, it MUST discard that packet."

I'd say this ought to be an invariant because otherwise versions could disgree on this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197#issuecomment-373365511

---

From: MikkelFJ <[email-masked]>
Date: Thu, 15 Mar 2018 06:54:05 -0700

Closed #1197.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197#event-1523333899

---

From: MikkelFJ <[email-masked]>
Date: Thu, 15 Mar 2018 06:54:05 -0700

I'm not sure this really needs to be addressed the invariants already says:

"A QUIC endpoint that receives a packet with a long header and a version it either does not understand or does not support sends a Version Negotiation packet in response. Packets with a short header do not trigger version negotiation and are always associated with an existing connection."

It just doesn't say what to do after a connection is established, but that might be splitting hairs, so closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197#issuecomment-373383156

---

From: Martin Thomson <[email-masked]>
Date: Fri, 16 Mar 2018 02:36:35 -0700

I see.  Yes, we have that text (though it suggests that a client sends VN, which is probably wrong).  I'll fix that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1197#issuecomment-373655808