Subject: Re: [quicwg/base-drafts] allow ACKs in the Server Stateless Retry packet (#882)

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Mar 2018 10:05:49 +0000 (UTC)

This PR needs to be re-targeted to cover the new scope of #627, but it's otherwise good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#issuecomment-373323920

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 10:23:53 +0000 (UTC)

@janaiyengar pushed 1 commit.

2d0ba7d  Mandate ACK and allow PADDING in Revert

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/882/files/9a4266ab0782d619923fb63bd5c42c3832cdcbbf..2d0ba7dca103762b28191c1a5085c6debbaa7886

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 03:27:24 -0700

Ugh, sorry @marten-seemann -- I meant to send a patch to your commit, but ended up committing to your branch instead. Take a look, and respond if you think it's fine. I'm happy to merge if you agree.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#issuecomment-373329817

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 03:30:02 -0700

d9096de  f*** whitespace

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/882/files/2d0ba7dca103762b28191c1a5085c6debbaa7886..d9096de3024c4fe53c909a32ade410e64afb8120

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 10:36:18 +0000 (UTC)

00e9298  ACK for Initial packet

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/882/files/d9096de3024c4fe53c909a32ade410e64afb8120..00e9298c293c0d252882a9c32b4d5a383deb9173

---

From: Marten Seemann <[email-masked]>
Date: Thu, 15 Mar 2018 10:38:18 +0000 (UTC)

marten-seemann commented on this pull request.

> @@ -627,10 +627,11 @@ any version negotiation that occurred (see {{version-negotiation}}).  The client
 MAY also retain any observed RTT or congestion state that it has accumulated for
 the flow, but other transport state MUST be discarded.
 
-The payload of the Retry packet contains a single STREAM frame
-on stream 0 with offset 0 containing the server's cryptographic stateless retry
-material. It MUST NOT contain any other frames. The next STREAM frame sent by
-the server will also start at stream offset 0.
+The payload of the Retry packet contains at least two frames. It MUST include a
+STREAM frame on stream 0 with offset 0 containing the server's cryptographic
+stateless retry material. It MUST also include an ACK frame to acknowledge the
+client's Initial packet. It MAY additionally include one ore more PADDING

s/ore/or

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#pullrequestreview-104148360

---

From: Marten Seemann <[email-masked]>
Date: Thu, 15 Mar 2018 10:38:41 +0000 (UTC)

LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#issuecomment-373332682

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 03:39:22 -0700

6b8ce22  reflow because f*** web editor

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/882/files/00e9298c293c0d252882a9c32b4d5a383deb9173..6b8ce22285703f9c93b8ff85918abb51aad3ef3f

---

From: janaiyengar <[email-masked]>
Date: Thu, 15 Mar 2018 03:39:43 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#pullrequestreview-104148818

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Mar 2018 10:39:52 +0000 (UTC)

Merged #882.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/882#event-1522953864