Subject: Re: [quicwg/base-drafts] Server responses to multiple Initial packets (#1115)

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Mar 2018 10:58:47 +0000 (UTC)

Closed #1115.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1115#event-1522989495

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Mar 2018 10:58:48 +0000 (UTC)

Discussed at editors' meeting:  Proposal is to assume this is broken server infrastructure.  Different client source CIDs would fix this, but doesn't solve anything in the common zero-length case.  In that case, we'll accept the handshake failure here.  If there's a good suggestion on how to close these holes, we can reopen and consider.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1115#issuecomment-373337792

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Mar 2018 03:59:16 -0700

Creating multiple connections from the client (with different randomized Destination Connection ID and new Source Connection ID fields) might work, but complicates the client.  It also doesn't work if the client uses a zero-length connection ID because the server packets don't properly identify which of the cryptographic contexts the client used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1115#issuecomment-373337888