Subject: Re: [quicwg/base-drafts] How to recover from loss of 3 Handshake packets without receiving PATH_RESPONSE (#1257)

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Apr 2018 11:03:54 +0000 (UTC)

The intent, as I understand it, was 3 packets out for every 1 in.  Is that the understanding?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-377907782

---

From: ianswett <[email-masked]>
Date: Mon, 02 Apr 2018 11:13:15 +0000 (UTC)

Martin's correct, that was the intent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-377909043

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 02 Apr 2018 06:36:55 -0700

I think it would be nice to clarify this by explicitly saying that it is per received packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-377930567

---

From: martinduke <[email-masked]>
Date: Tue, 17 Apr 2018 21:15:08 +0000 (UTC)

Please do so, and make it clear that it's a *decryptable* packet with a unique packet number (assuming that's correct)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-382148945

---

From: ianswett <[email-masked]>
Date: Tue, 17 Apr 2018 21:21:23 +0000 (UTC)

To be maximally correct, I believe it should be per new packet that's received and processed, not just decrypted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-382151011