Subject: Re: [quicwg/base-drafts] UDP-like, not exclusively UDP (#1250)

From: Mike Bishop <[email-masked]>
Date: Mon, 02 Apr 2018 15:03:55 -0700

I think the/another problem with this is that, unlike TCP, QUIC doesn't have port numbers -- it leaves that concern to UDP.  If we want to work atop something other than UDP, then we need to replace that multi-recipient functionality (or build atop something with equivalent recipient-demuxing capability).

Or say that QUIC is a per-device service in a non-UDP environment and use connection IDs to demux.  ;-)

Regardless, this is outside our charter as noted on the list.  We're explicitly chartered to define QUIC over UDP.  I'm inclined to close this with no action on that basis.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-378060718

---

From: MikkelFJ <[email-masked]>
Date: Mon, 02 Apr 2018 22:25:41 +0000 (UTC)

Charter or not, it would be considerate to at least contemplate non-UDP designs, especially if this can be done with minimal impact. With dual connection ID's I don't see a strong need for port numbers - there might be some corner cases in handshake, and there might be some text that isn't sufficiently clear in this regard, but fundamentally this ought to be workable.

For example sensor networks using a minimal size connection ID dropping all data at IP/DUP layer and leaving any external routing to a gateway that  understands 8-bit CID's through an out of band configuration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-378065800

---

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Apr 2018 17:47:06 -0700

Based on the feedback thus far and [Section 3](https://quicwg.github.io/base-drafts/draft-ietf-quic-invariants.html#an-extremely-abstract-description-of-quic), I'm going to close with no action.  That doesn't mean that we're not going to ignore other substrates, only that our invariants are UDP-specific.

For all those who said v2: ![](http://3.bp.blogspot.com/-yiLSMXBJbVo/UrT9aN9hwRI/AAAAAAAAHJk/U_KfssGpG6U/s1600/picard-facepalm.jpg)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#issuecomment-378092577

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Apr 2018 00:47:07 +0000 (UTC)

Closed #1250.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1250#event-1553021550