Subject: [quicwg/base-drafts] remove incorrect statement about the connection ID in server packet (#1316)

From: Marten Seemann <[email-masked]>
Date: Sun, 22 Apr 2018 18:27:53 -0700

The randomized Destination Connection ID is contained in Retry as well as in Handshake packets sent by the server. Or am I missing something obvious here?
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1316

-- Commit Summary --

  * remove incorrect statement about the connection ID in server packet

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1316.patch
https://github.com/quicwg/base-drafts/pull/1316.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316

---

From: ianswett <[email-masked]>
Date: Mon, 23 Apr 2018 07:02:17 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#pullrequestreview-114396478

---

From: Mike Bishop <[email-masked]>
Date: Mon, 23 Apr 2018 16:39:58 +0000 (UTC)

Those packets from the server contain the CID that the server wants the client to start using.  See the next couple paragraphs of that section and 4.7.  The server can always choose the client's randomly selected one if it just needs to disambiguate, but the server never blindly echos the client's randomly-selected ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#issuecomment-383641534

---

From: ianswett <[email-masked]>
Date: Mon, 23 Apr 2018 16:45:28 +0000 (UTC)

Good point Mike.  That being said, I find the way it's currently stated a bit confusing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#issuecomment-383643342

---

From: Mike Bishop <[email-masked]>
Date: Mon, 23 Apr 2018 12:52:33 -0700

Perhaps the next paragraph needs a lead-in explaining why the SCID in the server's packet might be different than the DCID the client used.  It currently describes the mechanics -- when the client should pick up a new value to use in future packets.  It doesn't link that to a server's desire to select the CID to provide the context.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#issuecomment-383701154

---

From: janaiyengar <[email-masked]>
Date: Tue, 24 Apr 2018 22:40:49 +0000 (UTC)

janaiyengar approved this pull request.

This seems fine -- that phrase is not incorrect, but is unnecessary and confusing where it is right now. I'm fine with removing it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#pullrequestreview-114990223

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Apr 2018 15:41:06 -0700

MikeBishop approved this pull request.

@janaiyengar has convinced me this is okay -- this section is talking about the Initial packet only, and the clause being removed is not relevant *to the Initial packet*.  The discussion of CID changes is elsewhere.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#pullrequestreview-114990264

---

From: janaiyengar <[email-masked]>
Date: Tue, 24 Apr 2018 22:41:47 +0000 (UTC)

Merged #1316.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1316#event-1592789513