Subject: Re: [quicwg/base-drafts] Duplication can use different indexing (#1128)

From: Mike Bishop <[email-masked]>
Date: Wed, 25 Apr 2018 16:40:38 -0700

Discussed with Alan; absolute indices grow without bound, so they're not a good option.  Most tables have less than 1k entries, which can be represented in at most three bytes.  You could index from the end of the dynamic table and make it always one byte, but that introduces a fourth (!!!) way to reference entries in QPACK, which seems less than ideal.

Inclination is to leave this alone unless we have data that says Duplicate instructions are getting intractably large.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1128#issuecomment-384467155

---

From: Mike Bishop <[email-masked]>
Date: Wed, 25 Apr 2018 16:40:39 -0700

Closed #1128.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1128#event-1595327663