Subject: Re: [quicwg/base-drafts] Gratuitous change of QHKDF-Expand in draft 10 (#1255)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 02 Apr 2018 02:30:18 -0700

OpenSSL is not affected by this.  It is just a label.  Is this TLS implementation specific?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-377894009

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 03 Apr 2018 06:34:46 +0000 (UTC)

@tatsuhiro-t I'd assume that it is because you are not reusing the AEAD function of OpenSSL.

Some TLS libraries provide AEAD construction functions so that application developers do not need to figure out how to use HKDF.

In case of picotls, the library provides a function named [`ptls_aead_new`](https://github.com/h2o/picotls/blob/master/lib/picotls.c#L3683-L3709) that _internally_ calls the HKDF with two different parameters; i.e. "key" and "iv", at the same time allowing the application to specify BaseLabel.

Reading https://github.com/quicwg/base-drafts/issues/1255#issuecomment-377276565, I'd assume that the case is similar with NSS, except for the fact that NSS does not provide a way to specify BaseLabel other than "tls13 ".

The voice behind this issue is that we want to continue using those functions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-378143414

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Tue, 03 Apr 2018 07:53:00 +0000 (UTC)

@kazuho Thank you for clarifying the issue.  And no, I don't reuse AEAD function in OpenSSL because I think there are no such functions in OpenSSL.  It has only HKDF function.
I have no preference between the two; keeping as is or getting hashLength back in label because it is not a big change for me in either way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-378160844

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Apr 2018 13:44:20 -0700

The future is bigger than the past.  And I've already been asked why this string is null-terminated once.  This is pure cruft.  

See also https://github.com/quicwg/base-drafts/pull/1256#pullrequestreview-109208113

> Reading #1255 (comment), I'd assume that the case is similar with NSS, except for the fact that NSS does not provide a way to specify BaseLabel other than "tls13 ".

NSS doesn't export an HKDF wrapper, so anyone who wants to do this rolls their own, as Patrick has done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-380589529

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Apr 2018 22:56:43 +0000 (UTC)

> NSS doesn't export an HKDF wrapper, so anyone who wants to do this rolls their own, as Patrick has done.

Sorry for the confusion. Reading https://github.com/quicwg/base-drafts/issues/1255#issuecomment-377276565, I assumed that it was NSS. It was minq, actually (https://github.com/quicwg/base-drafts/pull/1256#issuecomment-378590889).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-380621352

---

From: Patrick McManus <[email-masked]>
Date: Wed, 11 Apr 2018 16:56:28 -0700

I did it for mozquic/nss too.. except i actually did it from day 1 so the
recent changes were easy.

On Wed, Apr 11, 2018 at 6:56 PM, Kazuho Oku <[email-masked]>
wrote:

> Reading #1255 <https://github.com/quicwg/base-drafts/issues/1255>
> (comment), I'd assume that the case is similar with NSS, except for the
> fact that NSS does not provide a way to specify BaseLabel other than "tls13
> ".
>
> Sorry for the confusion. Reading #1255 (comment)
> <https://github.com/quicwg/base-drafts/issues/1255#issuecomment-377276565>,
> I assumed that it was NSS. It was minq, actually (#1256 (comment)
> <https://github.com/quicwg/base-drafts/pull/1256#issuecomment-378590889>).
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1255#issuecomment-380621352>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AAP5s7AH8kSYwjew7jdlqYHJriYKb79Dks5tnoongaJpZM4S_ISL>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1255#issuecomment-380631557