Subject: [quicwg/base-drafts] Exhausting a supply of connection IDs (#1276)

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Apr 2018 03:01:37 -0700

What - if anything - do we want to say about connection migration in the face of a server that provides too few (including 0) connection IDs?  It's a fairly simple trade-off that we can explain.  I suspect that different clients will adopt different policies though.

And, should we provide a means to request more?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1276

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 09 Apr 2018 10:21:04 +0000 (UTC)

I do not have an opinion on if the client behavior needs to be documented.

OTOH, I would prefer having a way to request more, considering the fact that the client could run out of spare connection IDs without the server noticing it, when a path probe fails to reach the server.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1276#issuecomment-379705365

---

From: ianswett <[email-masked]>
Date: Mon, 09 Apr 2018 13:03:33 +0000 (UTC)

I'd prefer to stick to the "if you run out of connection IDs and you want to use a new one, 0RTT a new connection" answer unless we think there's a really compelling case for the extra complexity.

A server that cares about giving a client enough IDs should be able to do that without too much work, and it can see which ones have been used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1276#issuecomment-379744264

---

From: Mike Bishop <[email-masked]>
Date: Mon, 09 Apr 2018 11:07:20 -0700

I thought we'd discussed and resolved that in St. Pancras', but I don't see it in the spec.  There are two versions of this:
- Client wants to migrate, but is out of CIDs:  0-RTT is probably the right answer here.
- Client has migrated, but server is out of CIDs:  Clients should be allowed / encouraged to include NCID in probing frames to avoid this.  Should servers be prohibited from sending until they get a new CID?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1276#issuecomment-379842268