Subject: Re: [quicwg/base-drafts] When are missing Q-thingey references fatal? (#1176)

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Apr 2018 10:34:37 -0700

#1314 includes the stream error, but it has the drawbacks mentioned here.  A better option that fits within the current model might be this:  Rather than the encoder counting all blocks as out-of-scope after it resets a stream, the decoder sends an acknowledgment either when it reads a header block from a stream or when it discards all remaining data from a stream.

This would require a second type of acknowledgement that is triggered by a reset stream, which is a little icky.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1176#issuecomment-384016964

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 25 Apr 2018 13:51:31 +0000 (UTC)

+1 to @afrind for catching this.

Perhaps the HoL minimization/stream reset interplay is indeed a general issue, as @krasic points out, and is never going away.  In that case, we have to deal with it.

I think that having the decoder return a stream error is not so bad:
- If the encoder knows that the stream was reset, it can ignore this error;
  - This adds a requirement that the application (HQ layer) notify the encoder that it reset the stream.
- Otherwise, the encoder can escalate (promote?) this to a connection error and close the connection.

Introducing the concept of allowed stream errors on reset streams is better than dipping into the transport layer or using timers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1176#issuecomment-384294172

---

From: afrind <[email-masked]>
Date: Thu, 26 Apr 2018 08:51:55 -0700

Closed #1176 via #1314.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1176#event-1596882098