Subject: [quicwg/base-drafts] Remove term "application-owned streams" (#1303)

From: Lucas Pardue <[email-masked]>
Date: Wed, 18 Apr 2018 16:04:07 +0000 (UTC)

Fixes #1297. 

Just a proposal, shoot it down...
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1303

-- Commit Summary --

  * Remove term "application-owned streams"

-- File Changes --

    M draft-ietf-quic-transport.md (35)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1303.patch
https://github.com/quicwg/base-drafts/pull/1303.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Apr 2018 21:13:10 +0000 (UTC)

MikeBishop requested changes on this pull request.

Deleting the offending words without replacing the meaning they conveyed doesn't quite get us there, I think.

> @@ -1202,28 +1202,27 @@ An endpoint MAY use the following transport parameters:
 initial_max_streams_bidi (0x0002):
 
 : The initial maximum bidirectional streams parameter contains the initial
-  maximum number of application-owned bidirectional streams the peer may
-  initiate, encoded as an unsigned 16-bit integer.  If this parameter is absent
-  or zero, application-owned bidirectional streams cannot be created until a
-  MAX_STREAM_ID frame is sent.  Note that a value of 0 does not prevent the
-  cryptographic handshake stream (that is, stream 0) from being used. Setting
-  this parameter is equivalent to sending a MAX_STREAM_ID
-  ({{frame-max-stream-id}}) immediately after completing the handshake
-  containing the corresponding Stream ID. For example, a value of 0x05 would be
-  equivalent to receiving a MAX_STREAM_ID containing 20 when received by a
-  client or 17 when received by a server.
+  maximum number of bidirectional streams the peer may initiate, encoded as
+  an unsigned 16-bit integer.  Note that the cryptographic handshake stream
+  (that is, stream 0) is exempt, a value of zero does not prevent it from being

The issue is that stream 0 is still (pending design team) a bidirectional stream initiated by the peer.  So a valid interpretation of this new text would be:

- 0:  Special case, can still use crypto stream
- 1:  One bidirectional stream permitted, which is the crypto stream
- 2:  Two bidirectional streams permitted, one of which is the crypto stream
...and so on.

The point of "application-owned" is not just that zero can't be blocked by this setting, but to clarify that the number available to the application isn't one less than this value due to 0.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#pullrequestreview-113393990

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Apr 2018 21:14:19 +0000 (UTC)

Oh, and your build failures are from trailing whitespace on lines 1222-1224.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#issuecomment-382531544

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 18 Apr 2018 15:38:46 -0700

The intent of the change is that stream 0 is (right now) always exempt from calculation. I.e it is reserved and should not be included in the conversion from number of streams to stream ID. The conversion is non-intuitive to the unfamiliar reader. So, I think we agree in principle but disagree on phrasing.

More broadly, if the term application-owned stream is not used anywhere else, I see little value in coining it here. It makes assumption that all non 0 streams are application owned. Why may be the a different topic of discussion, hence the tussle here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#issuecomment-382551247

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 19 Apr 2018 09:37:14 +0000 (UTC)

@LPardue pushed 1 commit.

09be352  trailing whitespace fix

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303/files/12cd0b58a863ab621599c828421c8d40c46a6965..09be3527a2bf34cc7b2c3668cf0f0ede3c527098

---

From: Mike Bishop <[email-masked]>
Date: Thu, 19 Apr 2018 20:02:41 +0000 (UTC)

I agree, we're trying to say the same thing, that zero doesn't count for purposes of this setting.  But still, saying nothing about it except the example doesn't fix the problem, because instead of being confused a reader might reach the wrong conclusion and keep going.

Perhaps "maximum number of bidirectional streams the peer may initiate **in addition to stream 0**..."?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#issuecomment-382863111

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 23 Apr 2018 19:21:07 +0000 (UTC)

Putting this on hold until #1310 is resolved. I'll rebase on the outcome.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#issuecomment-383691942

---

From: Martin Thomson <[email-masked]>
Date: Thu, 26 Apr 2018 07:24:26 +0000 (UTC)

martinthomson commented on this pull request.

I agree with Mike.  Perhaps there is a simplerr way of solving this, namely using words and not hyphenating words.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1303#discussion_r184292136