Subject: Re: [quicwg/base-drafts] Tls restore compat (#1256)

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Apr 2018 06:58:12 +0000 (UTC)

martinthomson commented on this pull request.

I'm not a fan of making this sort of change.  It seems that it's a product of the idiosyncratic API provided by picotls more than anything else.  

Don't take that as an indictment on the goals of the API.  I really like the idea that the details of determining keys and IVs are kept contained.  I only wish that NSS were anywhere near as principled.  We have to break the PKCS#11 boundary to get HKDF to work.

For mine, a more principled AEAD API would take two labels: one for the key and one for the label, and avoid baking in the specific details of the TLS HKDF info structure.  A hacky API change could distinguish between a NULL hash and an empty hash.

In summation, I'd prefer not to have to explain to future users of QUIC that this isn't a null terminator on the string, but a product of a design decision made before QUIC even really existed.

> @@ -703,12 +703,13 @@ structure:
 struct {
    uint16 length = Length;
    opaque label<6..255> = "QUIC " + Label;
+   uint8 hashLength = 0;

This needs to be explained, or people will ask why the hash is zero length.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1256#pullrequestreview-109208113

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 04 Apr 2018 04:54:59 -0700

@martinthomson 
> In summation, I'd prefer not to have to explain to future users of QUIC that this isn't a null terminator on the string, but a product of a design decision made before QUIC even really existed.

Thank you for your comments. While I understand and have sympathy to your arguments, I wonder if there's a strong reason to divert from the structure defined in TLS 1.3 considering the fact that the quic-tls draft depends on TLS 1.3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1256#issuecomment-378574118

---

From: ekr <[email-masked]>
Date: Wed, 04 Apr 2018 05:59:20 -0700

It's not just PicoTLS. This is an issue for Minq as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1256#issuecomment-378590889