Subject: [quicwg/base-drafts] Permit CONNECTION_CLOSE in Handshake (#1274)

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Apr 2018 00:10:29 +0000 (UTC)

Closes #1270.

@janaiyengar, anyone, can you remember why we allow PATH_* frames in Handshake messages?  They don't seem to serve any particular purpose.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1274

-- Commit Summary --

  * Permit CONNECTION_CLOSE in Handshake

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1274.patch
https://github.com/quicwg/base-drafts/pull/1274.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274

---

From: ianswett <[email-masked]>
Date: Mon, 09 Apr 2018 13:11:23 +0000 (UTC)

ianswett approved this pull request.

Maybe PATH_CHALLENGE/PATH_RESPONSE was for doing proof of address without any handshake data?  But if so, we should probably explain that's the intent?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#pullrequestreview-110447054

---

From: Nick Banks <[email-masked]>
Date: Mon, 09 Apr 2018 06:26:21 -0700

If the client can acknowledge any of the server's Handshake packets, doesn't that prove ownership of the address, assuming the server's packet numbers are not predictable?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#issuecomment-379750868

---

From: ianswett <[email-masked]>
Date: Mon, 09 Apr 2018 06:28:56 -0700

An acknowledgement only proves the peer saw the right packet number, which may be possible to guess, depending on what we decide with packet number randomization/etc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#issuecomment-379751708

---

From: Nick Banks <[email-masked]>
Date: Mon, 09 Apr 2018 06:34:09 -0700

I agree it can only work if the packet number isn't predictable, and that depends on the final scheme we decide to use for packet numbers. But if it isn't predictable, receiving a packet from an IP address that you sent the packet to, containing information that could only be retrieved from that original packet seems to me, to prove they can receive any packets sent to that IP address.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#issuecomment-379753489

---

From: Mike Bishop <[email-masked]>
Date: Mon, 09 Apr 2018 12:00:34 -0700

It's for the server's three-packet limit.  If the server's first flight is more than three packets, it includes a PATH_CHALLENGE in each of those three.  The client can send back a Handshake frame that contains only a PATH_RESPONSE, permitting the server to finish sending its first flight as soon as it gets any of them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#issuecomment-379858469

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Apr 2018 22:46:31 +0000 (UTC)

Merged #1274.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1274#event-1567338031