Subject: [quicwg/base-drafts] Stateless Reset during Path Migration (#1258)

From: Mike Bishop <[email-masked]>
Date: Mon, 02 Apr 2018 10:20:58 -0700

Observation while creating #1251 -- if a server's address is an Anycast address, then attempting connection migration will cause you to reach a different server from your new address.  That server might well send you a Stateless Reset in response to your probe.

That doesn't mean that the connection actually gets aborted (if you're sane), it just means your probe failed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1258

---

From: Mike Bishop <[email-masked]>
Date: Fri, 13 Apr 2018 21:23:51 +0000 (UTC)

Per discussion on #1259, the correct solution to this in a deployment is that, if you aren't the server that minted the CID, you shouldn't have the key to generate the Stateless Reset.  We need Security Considerations text around that, because DoS attacks open up if servers get this wrong.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1258#issuecomment-381264130