Subject: [quicwg/base-drafts] Deemphasize TCP SACKs reference in ACK frame description (#1312)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 20 Apr 2018 15:24:59 +0000 (UTC)

It is odd to describe something by saying what is *not* like.  In
addition, not all readers of the document will be familiar with
TCP SACKs.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1312

-- Commit Summary --

  * Deemphasize TCP SACKs reference in ACK frame description

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1312.patch
https://github.com/quicwg/base-drafts/pull/1312.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312

---

From: Martin Thomson <[email-masked]>
Date: Tue, 24 Apr 2018 07:41:36 -0700

martinthomson requested changes on this pull request.

> @@ -2581,9 +2581,9 @@ received and processed.  A sent packet that has never been acknowledged is
 missing. The ACK frame contains any number of ACK blocks.  ACK blocks are
 ranges of acknowledged packets.
 
-Unlike TCP SACKs, QUIC acknowledgements are irrevocable.  Once a packet has
-been acknowledged, even if it does not appear in a future ACK frame,
-it remains acknowledged.
+QUIC acknowledgements are irrevocable:  Once a packet has been acknowledged,

Period, not colon.

> @@ -2581,9 +2581,9 @@ received and processed.  A sent packet that has never been acknowledged is
 missing. The ACK frame contains any number of ACK blocks.  ACK blocks are
 ranges of acknowledged packets.
 
-Unlike TCP SACKs, QUIC acknowledgements are irrevocable.  Once a packet has
-been acknowledged, even if it does not appear in a future ACK frame,
-it remains acknowledged.
+QUIC acknowledgements are irrevocable:  Once a packet has been acknowledged,
+even if it does not appear in a future ACK frame, it remains acknowledged.
+(This is unlike TCP SACKs.)

Don't include an entire sentence in a parenthetical.  It would be fine to remove the paretheses here.

Of course, now that you touched this, I notice that we don't have a TCP SACK reference here, and you can't just use an unexpanded acronym like this without both expansion and a reference.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312#pullrequestreview-114815487

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 25 Apr 2018 05:42:39 -0700

@dtikhonov pushed 1 commit.

520f722  Improve the irrevokable ACK frame paragraph; add SACK RFC ref

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312/files/8024912366b384fbdbdadda558cea1e0d8f01771..520f722efb1457fd3f50403e2b9efbe4d04d5931

---

From: ianswett <[email-masked]>
Date: Wed, 25 Apr 2018 06:09:52 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312#pullrequestreview-115167199

---

From: janaiyengar <[email-masked]>
Date: Wed, 25 Apr 2018 22:50:55 +0000 (UTC)

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312#pullrequestreview-115381635

---

From: janaiyengar <[email-masked]>
Date: Wed, 25 Apr 2018 15:52:13 -0700

I think this addresses Martin's comments, so I'll merge.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312#issuecomment-384458543

---

From: janaiyengar <[email-masked]>
Date: Wed, 25 Apr 2018 15:52:23 -0700

Merged #1312.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1312#event-1595274216