Subject: [quicwg/base-drafts] QUIC is QUIC, and does not stay for anything. (#1282)

From: Ariel Otilibili <[email-masked]>
Date: Tue, 10 Apr 2018 08:32:03 +0000 (UTC)

https://www.ietf.org/mail-archive/web/quic/current/msg03855.html
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1282

-- Commit Summary --

  * QUIC is QUIC, and does not stay for anything.

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1282.patch
https://github.com/quicwg/base-drafts/pull/1282.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282

---

From: MikkelFJ <[email-masked]>
Date: Tue, 10 Apr 2018 08:38:53 +0000 (UTC)

mikkelfj commented on this pull request.

> @@ -137,6 +137,9 @@ protocol, including the conceptual design, wire format, and mechanisms of the
 QUIC protocol for connection establishment, stream multiplexing, stream and
 connection-level flow control, connection migration, and data reliability.
 
+QUIC used to be known as 'Quick UDP  Internet Connections', but the present
+document advises it be used no  more: QUIC does not stand for anything.
+
 Accompanying documents describe QUIC's loss detection and congestion control

I belive the feedback on the mailing list was that the RFC is not the place to make historical references.

>QUIC used to be known as 'Quick UDP  Internet Connections', but the present
 +document advises it be used no  more: QUIC does not stand for anything.

could perhaps be reformulated as

> QUIC is a name and not an acronym.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#pullrequestreview-110739783

---

From: Ariel Otilibili <[email-masked]>
Date: Tue, 10 Apr 2018 08:59:56 +0000 (UTC)

@ariel-anieli pushed 1 commit.

4d8ab11  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282/files/3485ca9572f8455565fd376b32eb71021da7f610..4d8ab11608a9a7909998787edd20db134c93de4e

---

From: Ariel Otilibili <[email-masked]>
Date: Tue, 10 Apr 2018 09:02:19 +0000 (UTC)

@mikkelfj, here is the new pull.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380027532

---

From: Ariel Otilibili <[email-masked]>
Date: Tue, 10 Apr 2018 10:26:05 +0000 (UTC)

ariel-anieli commented on this pull request.

Fixed in the new pull, @mikkelfj. Have you seen it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#discussion_r180369045

---

From: MikkelFJ <[email-masked]>
Date: Tue, 10 Apr 2018 04:12:17 -0700

now I have :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#discussion_r180381491

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Apr 2018 09:56:49 -0700

I'm a little dubious of throwing this sentence as a stand-alone paragraph in the Introduction, as it seems unrelated to most of the other text there.  Maybe it would fit better at the end of Section 2, when we're defining other terms and notations?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380173199

---

From: Ariel Otilibili <[email-masked]>
Date: Tue, 10 Apr 2018 19:34:49 +0000 (UTC)

Right, @MikeBishop. A new pull will change it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380221063

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Apr 2018 00:45:27 +0000 (UTC)

Thanks Mike, I had the same objection, but didn't think of the suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380291050

---

From: Ariel Otilibili <[email-masked]>
Date: Wed, 11 Apr 2018 00:03:13 -0700

07ea187  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282/files/4d8ab11608a9a7909998787edd20db134c93de4e..07ea187d86a460b4f97d01084f129489a24cdca3

---

From: Ariel Otilibili <[email-masked]>
Date: Wed, 11 Apr 2018 07:05:00 +0000 (UTC)

Fixed, @MikeBishop.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380349163

---

From: Mike Bishop <[email-masked]>
Date: Wed, 11 Apr 2018 10:42:19 -0700

MikeBishop approved this pull request.

WFM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#pullrequestreview-111333259

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Apr 2018 18:49:22 -0700

Merged #1282.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#event-1569926819

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Apr 2018 18:49:39 -0700

So few words, so much effort.  Thanks @ariel-anieli.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1282#issuecomment-380648846