Subject: [quicwg/base-drafts] Largest Reference too big (#1404)

From: Martin Thomson <[email-masked]>
Date: Wed, 30 May 2018 21:20:30 -0700

Clearly, a decoder is expected to fail decoding if Largest Reference is too small.  Chances are it will be referencing values that aren't in the table already.

But if the value is too big, should we let that pass, require a failure, or just permit a failure?  Policing this is a little annoying because you have to track the actual largest reference as you decode, so I'd be mildly against requiring failure, but don't care otherwise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404

---

From: afrind <[email-masked]>
Date: Thu, 31 May 2018 16:46:47 +0000 (UTC)

I don't think we should require the decoder to fail the stream if it doesn't actually make a reference as large as Largest Reference.  Making it larger than needed will only delay decoding (possibly indefinitely).  I think it can only happen because there's a bug in the encoder or the encoder is attacking the decoder.  

It's seems odd to say the decoder MAY fail the stream/connection when this happens.  I feel like we should say it's an error or it's not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-393597561

---

From: Mike Bishop <[email-masked]>
Date: Thu, 31 May 2018 16:49:24 +0000 (UTC)

It *is* an error, but it's not required for compatibility that a decoder actually validate that it was correct.  Validating your peer isn't buggy and tempting deadlocks seems like a good way to improve the ecosystem, so I also think it should be permitted behavior.  Thus, I tend toward MAY.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-393598344

---

From: Martin Thomson <[email-masked]>
Date: Thu, 31 May 2018 16:08:58 -0700

As do I.  Especially in light of discussions I've had recently.  Tolerance of errors like this is a downward spiral.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-393710544