Subject: Re: [quicwg/base-drafts] Retain use of SETTINGS_ENABLE_PUSH (#718)

From: Martin Thomson <[email-masked]>
Date: Tue, 08 May 2018 15:34:28 -0700

MAX_PUSH_ID does this, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-387563698

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 08 May 2018 16:38:24 -0700

I think the original issue and discussion are still valid up to draft 11 at least. MAX_PUSH_ID controls push enablement. Lost or delayed packets with this or SETTINGS are subject to the same consideration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-387575294

---

From: Mike Bishop <[email-masked]>
Date: Thu, 10 May 2018 16:38:51 +0000 (UTC)

I see the issue -- on the server, you don't know whether you're temporarily blocked or permanently disabled.  A server could heuristically guess that if it hasn't seen a MAX_PUSH_ID frame after a RTT or so then one isn't coming, but there's some value in an affirmative declaration of "don't bother deciding what to push."

We actually don't have this with SETTINGS, as each peer is currently required to have seen the other side's SETTINGS frame before sending request/response data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-388110190

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 May 2018 17:40:02 -0700

Maybe just allow MAX_PUSH_ID to appear before SETTINGS and contain the problem that way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-388226000

---

From: Mike Bishop <[email-masked]>
Date: Fri, 11 May 2018 10:12:19 -0700

"Allow" doesn't actually solve the issue; just because it wasn't before SETTINGS doesn't mean it won't be after.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-388426675

---

From: Martin Thomson <[email-masked]>
Date: Fri, 11 May 2018 17:34:07 -0700

Allow means that we might also (strongly) recommend sending it then.  A server that doesn't see it could assume that it's permanent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/718#issuecomment-388516995