Subject: [quicwg/base-drafts] Table resize can't be acknowledged (#1365)

From: Martin Thomson <[email-masked]>
Date: Sun, 20 May 2018 22:51:23 -0700

Acknowledgments encode the number of insertions, which is nice because that's what you need to track for other reasons.  However, this makes resizing the table invisible and not acknowledged.  I think that's OK, but it means that an encoder can't rely on increased space being available until it receives acknowledgment for the next insertion after the resize.

I think that's worth calling out in the description of the Dynamic Table Size Update instruction.

(Marking this design in case someone disagrees with my conclusion.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365

---

From: afrind <[email-masked]>
Date: Tue, 22 May 2018 09:09:34 -0700

The inserts and the table size updates all happen on the encoder stream, which is in-order and reliable.  Why can't the encoder assume the additional space is available immediately after encoding the table size update?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365#issuecomment-391048958

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 May 2018 11:07:18 -0700

Indeed, HPACK has no acknowledgements for this.  HPACK has acknowledgements (via H2 SETTINGS) for changes in the decoder's maximum table size, but that's mostly immutable in HQ.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365#issuecomment-391087025

---

From: afrind <[email-masked]>
Date: Fri, 25 May 2018 16:25:16 -0700

@martinthomson : are we good to close this with no-action or you think we could benefit from editorial text explaining the similarity to HPACK in this regard?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365#issuecomment-392212540

---

From: Martin Thomson <[email-masked]>
Date: Sun, 27 May 2018 02:39:27 -0700

"I think that's worth calling out in the description of the Dynamic Table Size Update instruction." - just a few words noting that the change isn't important from the perspective of the encoder, so it doesn't get acknowledged, except transitively.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365#issuecomment-392318219

---

From: afrind <[email-masked]>
Date: Thu, 31 May 2018 15:44:32 -0700

Closed #1365 via #1401.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1365#event-1657142140