Subject: [quicwg/base-drafts] Proposal for adding ECN support to QUIC. (#1372)

From: Magnus Westerlund <[email-masked]>
Date: Tue, 22 May 2018 18:25:16 +0000 (UTC)

This pull request contains an initial adaptation of what was in the design teams Wiki, but with more explanatory glue, and modifications to places where ACK or ACK_ECN frames can be used for example. 

Recovery draft changes are only pseudo code level so far and need a bit more work. 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1372

-- Commit Summary --

  * According to text in wiki. Some MD fixes to get right formating.
  * Modified proposed text to integrate better and take care of issues around connection migration, ensure more straightforward checks.
  * Fixed a typo on anchor creation
  * According to text in wiki. Some MD fixes to get right formating.
  * Modified proposed text to integrate better and take care of issues around connection migration, ensure more straightforward checks.
  * Fixed a typo on anchor creation
  * Merge branch 'ecn' of https://github.com/gloinul/base-drafts into ecn
  * Clarified that ACK or ACK_ECN can be used for acknowledgment in handshake. Clarified what the first packets that can be marked as ECT are in a connection.
  * Added ECN intro paragraph. Various editorial improvements of ECN text.
  * Fixed bullet list, Added parenthis around section refs.
  * Fixed indentation and formating

-- File Changes --

    M draft-ietf-quic-recovery.md (20)
    M draft-ietf-quic-transport.md (111)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1372.patch
https://github.com/quicwg/base-drafts/pull/1372.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 22 May 2018 11:37:51 -0700

@gloinul pushed 1 commit.

f14134f  Spelling fixed

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/88f76dc5db467f42addaae270548c19a86e4f2d4..f14134fff1963dfe2660b446cad1bab53922e02e

---

From: IngJohEricsson <[email-masked]>
Date: Thu, 24 May 2018 03:37:56 -0700

As regards to the pseudo code. 
Is there any formalized syntax for identification of frame types 
Now we have 

if (ack is of type ACK_ECN):

guess that is perhaps not correct syntax or ?
Other that I believe that input from other is appreciated.
/Ingemar

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372#issuecomment-391668528

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 24 May 2018 07:01:16 -0700

71c2794  Rewrote the ECN check algorithm for connection migration to be robust.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/f14134fff1963dfe2660b446cad1bab53922e02e..71c2794fcb6427d72678f7b6604fd32cbf7247e9

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 24 May 2018 07:20:58 -0700

2ff5ac9  Removed trailing spaces.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/71c2794fcb6427d72678f7b6604fd32cbf7247e9..2ff5ac9aacbe0e62408b21290da73849675693c9

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 24 May 2018 07:27:19 -0700

19d3b53  Fixed trailing spaces in recovery.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/2ff5ac9aacbe0e62408b21290da73849675693c9..19d3b53be3d3729bee1f7ec296f51e8ad64d35db

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 24 May 2018 07:52:57 -0700

f71e933  Rewraped text in both recovery and transport. Added a new sub-section on continous verification.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/19d3b53be3d3729bee1f7ec296f51e8ad64d35db..f71e93395c552cf4a2b2b6c4a4be050d5cd0e3ee

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 28 May 2018 11:04:13 -0700

fc94546  Added textual description of ECN-CE indicating congestion events.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/f71e93395c552cf4a2b2b6c4a4be050d5cd0e3ee..fc945461c759b99307ca848a13523ce384adf508

---

From: Martin Thomson <[email-masked]>
Date: Mon, 28 May 2018 17:45:10 -0700

@gloinul, thanks for putting this together.  I have opened a pull request on your repo that you should check and merge.  I've fixed typos and the build-related problems.  Once we're done with that, we can talk about the other editorial comments I have for you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372#issuecomment-392623369

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 29 May 2018 00:31:22 -0700

@gloinul pushed 2 commits.

66505a3  Editorial fixes
d525046  Merge pull request #1 from quicwg/ecn

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/fc945461c759b99307ca848a13523ce384adf508..d5250461b6ddb815fd8fd2422d80a2df8ed670a3

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 29 May 2018 09:02:09 -0700

28ef4c1  Editing some formulations. Rewraping more text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/d5250461b6ddb815fd8fd2422d80a2df8ed670a3..28ef4c144069f807f468912e5f62ef529398d2da

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 30 May 2018 01:45:46 -0700

6dd9237  Fixed trailing spaces and remaining line length issues, I hope.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/28ef4c144069f807f468912e5f62ef529398d2da..6dd9237e1a1988ce26349d7b306fe3821fbf18a0

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 30 May 2018 01:49:47 -0700

0bb5bad  Reflowing now saved

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1372/files/6dd9237e1a1988ce26349d7b306fe3821fbf18a0..0bb5bad97e1d13094463938fcefaa8917f23ffb6