Subject: [quicwg/base-drafts] Move setting registrations into QPACK (#1358)

From: Mike Bishop <[email-masked]>
Date: Fri, 18 May 2018 14:28:59 -0700

Fixes #1323.  Trying to describe how the max table size was used made me realize we never actually say, which is why I also wrote #1357; there's a reference that needs to be updated in whichever PR lands second.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1358

-- Commit Summary --

  * Move setting registrations into QPACK

-- File Changes --

    M draft-ietf-quic-http.md (11)
    M draft-ietf-quic-qpack.md (32)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1358.patch
https://github.com/quicwg/base-drafts/pull/1358.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358

---

From: Mike Bishop <[email-masked]>
Date: Fri, 18 May 2018 17:12:27 -0700

@MikeBishop pushed 1 commit.

7d2f71d  Heading

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358/files/ebef3c030dae51a9581420e5ae15a0bf6620619a..7d2f71dbe42af7d0647c2331b929cee5a39ed200

---

From: afrind <[email-masked]>
Date: Tue, 22 May 2018 14:13:51 -0700

afrind commented on this pull request.

> @@ -777,18 +777,13 @@ Settings which are integers use the QUIC variable-length integer encoding.
 
 #### Defined SETTINGS Parameters {#settings-parameters}
 
-The following settings are defined in HTTP/QUIC:
-
-  SETTINGS_HEADER_TABLE_SIZE (0x1):
-  : An integer with a maximum value of 2^30 - 1.  The default value is 4,096
-    bytes.
+The following setting is defined in HTTP/QUIC:
 
   SETTINGS_MAX_HEADER_LIST_SIZE (0x6):

Does anything in this document explain what SETTINGS_MAX_HEADER_LIST_SIZE does?

   SETTINGS_MAX_HEADER_LIST_SIZE (0x6):
   : An integer with a maximum value of 2^30 - 1.  The default value is
     unlimited.
 
-  SETTINGS_QPACK_BLOCKED_STREAMS (0x7):
-  : An integer with a maximum value of 2^16 - 1.  The default value is 100.
+Additional settings MAY be defined by extensions to HTTP/QUIC.

Are we calling QPACK an extension to HTTP/QUIC?  Or it is for purposes of SETTINGS?

> @@ -1418,13 +1413,11 @@ The entries in the following table are registered by this document.
 |----------------------------|------|-------------------------|
 | Setting Name               | Code | Specification           |
 |----------------------------|:----:|-------------------------|
-| HEADER_TABLE_SIZE          | 0x1  | {{settings-parameters}} |

It strikes me as bizarre that 0x1 is omitted from this table / or that QPACK - as an extension or subordinate document - gets to define the lowest numbered setting value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358#pullrequestreview-122354286

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 May 2018 16:04:44 +0000 (UTC)

MikeBishop commented on this pull request.

 

Good point.  RFC7540 doesn't have much, but it has more than HQ does currently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358#discussion_r190307364

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 May 2018 09:06:09 -0700

Kind of.  It's required to parse HEADERS and PUSH_PROMISE, but it is its own thing.  Kind of a mandatory extension, I suppose?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358#discussion_r190307779

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 May 2018 09:06:52 -0700

I agree.  That's because we're trying to keep consistency with the setting codes in HTTP/2, where this is defined in the HTTP draft and the value passed to HPACK as a parameter.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358#discussion_r190308019

---

From: afrind <[email-masked]>
Date: Fri, 25 May 2018 16:03:31 -0700

Merged #1358.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1358#event-1647621456