Subject: [quicwg/base-drafts] Payload length zero = "to end of UDP packet" (#1338)

From: Lars Eggert <[email-masked]>
Date: Fri, 04 May 2018 17:39:05 +0000 (UTC)

Is there any reason why an encoding for the payload length wasn't chosen that would allow something like setting it to zero mean "QUIC packet extends to end of UDP packet"? 

That would make it more straightforward to encode non-coalesced long-header packets, where the payload length may not be known by the time the packet header is being encoded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1338

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 04 May 2018 18:00:23 +0000 (UTC)

I think it is discussed in #1301.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1338#issuecomment-386685753

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 May 2018 18:45:59 +0000 (UTC)

Closed #1338.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1338#event-1610541174

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 May 2018 18:45:58 +0000 (UTC)

Thanks, I searched but missed that issue

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1338#issuecomment-386697714