Subject: [quicwg/base-drafts] plaintext in quic transmission (#1340)

From: howard <[email-masked]>
Date: Mon, 07 May 2018 07:29:57 +0000 (UTC)

quic by default only support ciphertext transmission, in some cases, for example when we're handling multi media that is not data-safe required, plaintext transmission works more efficiently. I have modified the quic source code in TLS negotiation for server to accept plaintext transmission and it work through. So i think plaintext transmission should be presented in new drafts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340

---

From: MikkelFJ <[email-masked]>
Date: Mon, 07 May 2018 08:26:00 +0000 (UTC)

This is a reasonable use case, but I do not think you will get much traction on this proposal:

The main driver for encryption is that it becomes impossible to create new future protocol versions if data is not encrypted and encryption is considered to be fast.

A single core can encrypt 1GB/s with common hardware accelleration. (Some high end micro controllser have AES accelleration but still lack the CLMUL instruction needed for fast GCM tags, but that will likely change). This covers 10gbps bandwidth with a single core, and it is not uncommon to have multiple cores.

Privacy also has the additional problem that if you can opt out, you can be forced to either opt out or be flagged as suspect. Therefore optional encryption is not good for privacy.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#issuecomment-386995367

---

From: Lars Eggert <[email-masked]>
Date: Mon, 07 May 2018 11:33:02 +0000 (UTC)

Keep in mind that our WG charter explicitly tasked us with producing an **encrypted** protocol, not a sometimes-encrypted protocol. Even if the WG came to consensus on this addition, it woudl certainly require a recharter.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#issuecomment-387037282

---

From: howard <[email-masked]>
Date: Mon, 07 May 2018 12:40:43 +0000 (UTC)

i suggest that quic is a hypertext transportation protocol over udp, while http is over tcp. http has it's hypertext transmitted in plaintext, why can't we do the same thing with quic. as far as i know, basically from the test result, quic has more cpu consumption than https. it is really nonsense to enable encryption  in some cases. encryption opt should be out to client. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#issuecomment-387051910

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 07 May 2018 13:28:23 +0000 (UTC)

The IETF version of QUIC is a transport protocol, independent of the application mapping. 

A secure transport provides potential benefit over TCP and UDP for many application protocols. Without encryption, QUIC just might not be so useful in comparison to these.

I'd suggest that where a strong case for plaintext HTTP exists, then HTTP over TCP is a suitable option. That's a clear client opt-out possible today.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#issuecomment-387064655

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 May 2018 17:29:39 -0700

Closed as [out of scope](https://github.com/quicwg/base-drafts/issues/1340#issuecomment-387037282).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#issuecomment-387247002

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 May 2018 17:29:39 -0700

Closed #1340.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1340#event-1614176050