Subject: [quicwg/base-drafts] Add changelog entries for -12 (#1360)

From: Martin Thomson <[email-masked]>
Date: Sun, 20 May 2018 18:44:49 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1360

-- Commit Summary --

  * Add changelog entries for -12

-- File Changes --

    M draft-ietf-quic-http.md (5)
    M draft-ietf-quic-qpack.md (16)
    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1360.patch
https://github.com/quicwg/base-drafts/pull/1360.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1360

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 May 2018 13:56:14 -0700

MikeBishop requested changes on this pull request.

Minor nits.

> @@ -769,3 +769,19 @@ those authors is gratefully acknowledged, as well as ideas from:
 * Ian Swett
 
 * Dmitri Tikhonov
+
+
+# Change Log
+
+> **RFC Editor's Note:**  Please remove this section prior to publication of a
+> final version of this document.
+
+## Since draft-ietf-quic-qpack-00

I think you mean "Since draft-ietf-quic-qcram-00" -- this will be qpack-00, and needs to be submitted as replacing -qcram.

> @@ -4253,7 +4253,12 @@ Issue and pull request numbers are listed with a leading octothorp.
 
 ## Since draft-ietf-quic-transport-11
 
-- Enable server to transition connections to a preferred address (#560,#1251).
+- Enable server to transition connections to a preferred address (#560,#1251)
+- Packet numbers are encrypted (#1174, #1043, #1048, #1034, #850, #990, #734,
+  #1079)
+- Packet numbers use a variable-length encoding (#989, #1334)
+- Servers can set a preferred address (#560, #1251)

Duplicative with the first item.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1360#pullrequestreview-122349182

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 May 2018 15:33:21 -0700

@martinthomson pushed 1 commit.

1f4d791  qcram is the last one

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1360/files/27839e43e878a5d6bbd1e7bb4163398c76f79a5d..1f4d791da4f29abc10c85f4df5b299824468753a

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 May 2018 15:34:23 -0700

891e1a4  Remove duplicate

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1360/files/1f4d791da4f29abc10c85f4df5b299824468753a..891e1a44695b345aef66421423df5ba575232128

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 May 2018 15:36:10 -0700

Merged #1360.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1360#event-1640513645