Subject: [quicwg/base-drafts] Current Code for Recovery period misscounts (#1440)

From: Magnus Westerlund <[email-masked]>
Date: Tue, 12 Jun 2018 02:25:07 -0700

Recovery draft:

   InRecovery(packet_number):
     return packet_number <= end_of_recovery

end_of_recovery = largest_sent_packet

To my understanding the end of recovery will be when one ACKs the packet that is one larger than the largest sent when the congestion event happens. Thus, the InRecovery function should use only < as long as end_of_recovery is not assigned to largest_sent_packet+1 (assuming all PNs are used). 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1440

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jun 2018 05:41:44 -0700

So end_of_recovery is assigned to the largest sent when recovery starts, as you said.

Say the largest sent when recovery starts is 10.  So when 11 is acked, we are no longer in recovery.

InRecovery(10) returns true, and InRecovery(11) returns false, so I believe it's correct?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1440#issuecomment-396575169

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 13 Jun 2018 06:44:30 +0000 (UTC)

Closed #1440.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1440#event-1677929358

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 13 Jun 2018 06:44:30 +0000 (UTC)

Yes, you are correct. Closing. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1440#issuecomment-396831410