Subject: [quicwg/base-drafts] Crypto cleanup (#1476)

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Jun 2018 18:12:57 -0700

This is two changes: a mechanical renaming of CRYPTO_HS to CRYPTO.  Then it's a reflowing of a bunch of paragraphs.  Both are mechanical in nature, though I did notice and correct a couple of typos in the process (which I'll have to dig out if we decide this is a bad idea).
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1476

-- Commit Summary --

  * Rename CRYPTO_HS to CRYPTO
  * Reflow paragraphs

-- File Changes --

    M draft-ietf-quic-recovery.md (220)
    M draft-ietf-quic-tls.md (438)
    M draft-ietf-quic-transport.md (363)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1476.patch
https://github.com/quicwg/base-drafts/pull/1476.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476

---

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Jun 2018 18:30:45 -0700

@martinthomson pushed 1 commit.

cadc2c9  Didn't save some of the recovery tweaks

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476/files/2378dc70f15dfd0c9b16aafb80912285bcfd579d..cadc2c9ac74f46fc637dc3ce755e53ffb3e4e452

---

From: Christopher Wood <[email-masked]>
Date: Tue, 26 Jun 2018 12:15:47 +0000 (UTC)

My $0.02: I'm not a fan of CRYPTO_HS or CRYPTO. I'd much prefer them to be named HANDSHAKE. Pushback to that stemmed from the collision with packet type names, which I'm not convinced is confusing. (I'd expect handshake packets to carry handshake frames after all.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400285915

---

From: MikkelFJ <[email-masked]>
Date: Tue, 26 Jun 2018 05:18:43 -0700

>  I'd much prefer them to be named HANDSHAKE.

But some communication happens post handshake, such as rekeying.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400286741

---

From: ekr <[email-masked]>
Date: Tue, 26 Jun 2018 13:09:14 +0000 (UTC)

I also prefer HANDSHAKE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400301512

---

From: ianswett <[email-masked]>
Date: Tue, 26 Jun 2018 06:18:42 -0700

ianswett approved this pull request.

The reflow makes this more difficult to review, but otherwise looks good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#pullrequestreview-132013419

---

From: Nick Banks <[email-masked]>
Date: Tue, 26 Jun 2018 06:24:51 -0700

I prefer CRYPTO over HANDSHAKE personally, for the same reason @mikkelfj indicated. It is used post handshake. There are other names similar to CRYTPO that work too; something like SECURITY or SEC_STREAM work too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400306763

---

From: ianswett <[email-masked]>
Date: Tue, 26 Jun 2018 06:59:04 -0700

I also prefer CRYPTO over HANDSHAKE FWIW

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400318912

---

From: Christopher Wood <[email-masked]>
Date: Tue, 26 Jun 2018 07:40:04 -0700

Regarding post-handshake events -- I consider these part of the handshake path. They simply occur later in time. This really is a minor detail. I just don't like the name CRYPTO. I'm also not fond of SECURITY or SEC_STREAM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400333619

---

From: janaiyengar <[email-masked]>
Date: Tue, 26 Jun 2018 11:57:43 -0700

Such reflow. Wow.

I prefer CRYPTO. But either is better than the current CRYPTO_HS.

All this reflow is going to rot rapidly, so if you want to keep discussing this name, I'd at least submit the reflow/typo changes and discuss the name separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400425564

---

From: janaiyengar <[email-masked]>
Date: Tue, 26 Jun 2018 11:57:50 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#pullrequestreview-132160665

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jun 2018 13:44:46 -0700

MikeBishop approved this pull request.

+1 to Jana's suggestion to merge this quickly.  A reflow without any text changes, I would probably just have committed directly to master.

It will break any open PRs that aren't already bitrotten, so do it quickly before there are any.

> @@ -255,11 +252,11 @@ than 1.25 * max(SRTT, latest_RTT) since when it was sent.
 Using max(SRTT, latest_RTT) protects from the two following cases:
 
 * the latest RTT sample is lower than the SRTT, perhaps due to reordering where
-packet whose ack triggered the Early Retransit process encountered a shorter
-path;
+  packet whose ack triggered the Early Retransit process encountered a shorter

**the** packet

 ### Crypto Handshake Timeout
 
-Data in CRYPTO_HS frames is critical to QUIC transport and crypto negotiation,
-so a more aggressive timeout is used to retransmit it.  Below, the word
-handshake packet is used to refer to packets containing CRYPTO_HS frames,
-not packets with the specific long header packet type Handshake.
+Data in CRYPTO frames is critical to QUIC transport and crypto negotiation, so a
+more aggressive timeout is used to retransmit it.  Below, the word handshake
+packet is used to refer to packets containing CRYPTO frames, not packets with

(Unmodified text, but you touch it, you own it.)  "handshake packet" isn't actually *a* word.  Perhaps "the term," and put "handshake packet" in quotes to designate it as the term you're discussing for clarity?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#pullrequestreview-132194801

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 00:21:34 +0000 (UTC)

ec1e39f  This text is ugly

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476/files/5a4a9906b6cf982cb897043c988d61c85c47db3f..ec1e39fe2309ac2108fd8752d1136babfceec026

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 17:23:24 -0700

Merged #1476.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#event-1702742231

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 17:24:28 -0700

Discussed with editors; CRYPTO is fine.  Naming is an area where editors have some discretion, but we will continue to accept suggestions for new names for things.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1476#issuecomment-400503987