Subject: [quicwg/base-drafts] Soften SNI requirement (#1459)

From: Martin Thomson <[email-masked]>
Date: Mon, 18 Jun 2018 22:33:30 -0700

hq mandates use of the server_name extension rather too strongly.  

> The Server Name Indication (SNI) extension [RFC6066] MUST be included in the TLS handshake.

RFC 7540 is much weaker on this point.

> The TLS implementation MUST support the Server Name Indication (SNI) [TLS-EXT] extension to TLS.  HTTP/2 clients MUST indicate the target domain name when negotiating TLS.

If we are to allow SNI encryption, then we should adopt similar language.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jun 2018 12:46:24 -0700

I'm fine with that change.  It seems a little bit of a stretch to read into that language that an alternative to SNI is acceptable, though.  I'm almost inclined to add "...MUST indicate the target domain name when negotiating TLS using SNI or another mechanism." just to highlight that SNI isn't the only compliant option.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459#issuecomment-398522087

---

From: Martin Thomson <[email-masked]>
Date: Tue, 19 Jun 2018 15:25:37 -0700

Closed #1459 via #1462.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459#event-1689828850

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jun 2018 16:52:37 -0700

Reopened #1459.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459#event-1689934727

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Jun 2018 16:52:37 -0700

@martinthomson, the point of my previous comment was that I don't believe Jana's PR clearly fixes this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459#issuecomment-398580927

---

From: janaiyengar <[email-masked]>
Date: Wed, 20 Jun 2018 18:59:19 -0700

Closed #1459 via #1466.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1459#event-1692563553