Subject: [quicwg/base-drafts] Modify codepoints on decoder and request/push streams for consistency (#1472)

From: afrind <[email-masked]>
Date: Fri, 22 Jun 2018 11:40:51 -0700

The prefix lengths remain the same but the instruction bits now follow the rule that each instruction has at most one '1' bit.

Fixes #1471
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1472

-- Commit Summary --

  * Modify codepoints on decoder and request/push streams for consistency

-- File Changes --

    M draft-ietf-quic-qpack.md (28)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1472.patch
https://github.com/quicwg/base-drafts/pull/1472.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 Jun 2018 11:50:18 -0700

MikeBishop approved this pull request.

>  two-bit pattern.  If the entry is in the dynamic table with an absolute index
-greater than Base Index, the representation starts with the '0101' four-bit
+greater than Base Index, the representation starts with the '0000' four-bit
 pattern.

This change is fine, but didn't we separate out the Post-Base things to their own headers?  Did we miss one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#pullrequestreview-131307888

---

From: afrind <[email-masked]>
Date: Fri, 22 Jun 2018 12:24:50 -0700

afrind commented on this pull request.

It has its own section but the normative text is in this section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#discussion_r197546038

---

From: Martin Thomson <[email-masked]>
Date: Mon, 25 Jun 2018 02:47:55 -0700

martinthomson approved this pull request.

More changes.  Interop gets that much further away.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#pullrequestreview-131537303

---

From: afrind <[email-masked]>
Date: Mon, 25 Jun 2018 09:58:14 -0700

I'm not concerned about this change delaying interop dramatically.  Implicit acks landed last week and was a bigger change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#issuecomment-400022519

---

From: afrind <[email-masked]>
Date: Mon, 25 Jun 2018 12:59:11 -0700

@afrind pushed 1 commit.

5a38c97  Swap TSS and Stream Cancellation codepoints

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472/files/eedc1d3ff8f1991272b4e59614294129c5f50e9d..5a38c97d2c208743bdb916d6af0d3b33b7afc2a8

---

From: afrind <[email-masked]>
Date: Tue, 26 Jun 2018 15:22:43 +0000 (UTC)

Merged #1472.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#event-1701724198

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jun 2018 13:31:40 -0700

@martinthomson, that's perhaps technically true, but I don't think this pushes out interop noticeably.  The bit sequences are the same length they previously were, and were always arbitrary bit sequences.  This should be a trivial change to incorporate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1472#issuecomment-400451844