Subject: Re: [quicwg/base-drafts] QPACK encoding requires two passes (#1138)

From: Hristo Venev <[email-masked]>
Date: Thu, 21 Jun 2018 12:51:04 -0700

Does it make sense for the base index to be greater than the largest reference? Won't then all post-base references be illegal?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1138#issuecomment-399222163

---

From: Mike Bishop <[email-masked]>
Date: Thu, 21 Jun 2018 13:51:49 -0700

Yes, they would be illegal because they would by definition be referring to values greater than the Largest Reference.  That doesn't mean it's nonsensical -- a single-pass encoder will pick a Base Index before it knows what references it will make; if it doesn't insert any entries, then it won't need to make post-base references.

A two-pass encoder will probably make them always equal and never make post-base references.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1138#issuecomment-399239646