Subject: [quicwg/base-drafts] Speed handshake recovery when only undecryptable packets arrive (#1414)

From: ianswett <[email-masked]>
Date: Tue, 05 Jun 2018 02:12:13 -0700

There are a few cases in the handshake where the decryptable packets may be lost, but undecryptable packets may arrive.

Examples include the client Initial followed by 0RTT packets and the server's Handshake packets followed by 1(/2)RTT packets.

In those cases, no packets can be acknowledged because packets must be decrypted and processed before being acknowledged, but it is possible to indicate to the peer that something has arrived.

DTLS uses an empty ack frame to instigate a faster than standard retransmission of handshake data.  QUIC could adopt a similar mechanism or come up with something slightly different, depending upon how much feedback it wants to provide.  One question is whether the encrypted packet number of the undecryptable packet should be provided in a feedback frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1414

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jun 2018 03:07:39 -0700

Discussed in Kista and the consensus of the room was to punt this to v2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1414#issuecomment-395017180