Subject: Re: [quicwg/base-drafts] Clarify PADDING vs PING frames (#838)

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Jun 2018 07:11:39 -0700

PADDING doesn't elicit ACK.  PING does.

A packet containing only ACK and PADDING counts towards bytes-in-flight.  But that means that you will consume bytes-in-flight by sending these, and maybe never an ACK.  So, send a PING sometimes, and you get your bytes-in-flight back.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/838#issuecomment-394368550

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 04 Jun 2018 15:28:02 -0700

Ok.  This is not what "Special Considerations for Packetization Layer PMTU Discovery" section says.  I'll s/PADDING/PING/g in that section in my PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/838#issuecomment-394520542