Subject: [quicwg/base-drafts] Retry Token Makeup (#1474)

From: Nick Banks <[email-masked]>
Date: Mon, 25 Jun 2018 06:31:26 -0700

This issue is related to the new Stream 0 dt PR (#1450).

Is a client allowed to change its connection ID in response to a Retry packet from a server?

The reason I ask is that it is possible to conceive of a server generating a token for a stateless Retry that encodes the client's original CID (among other things) in it for validation purposes. If the client is allowed to change its CID, then that obviously would break. So I feel we should have text either explicitly saying the client may (which I don't see how we could prevent) change its CID, and that a server shouldn't try to use the CID for stateless Retry validation or that a client must not change its CID so the server can use it for validation in stateless Retry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1474

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 16:00:32 -0700

My thought would be a token that is carried in a Retry would be bound strongly to the connection ID.  It's very different to NEW_TOKEN in that way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1474#issuecomment-400489654

---

From: Nick Banks <[email-masked]>
Date: Wed, 27 Jun 2018 09:23:06 -0700

Should we add text to say that the client SHOULD NOT change their source CID in response to a Retry packet? If so, I can send a PR to that effect.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1474#issuecomment-400739456

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 16:35:27 -0700

Closed #1474 via #1491.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1474#event-1705140305