Subject: [quicwg/base-drafts] Stream 0 DT proposal conflicts with PRIORITY (#1421)

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Jun 2018 13:14:31 -0700

After the design team output, all client-initiated bidirectional streams are used for requests, including Stream 0.  Since Stream 0 will be a valid, actual client request, this creates a conflict with the use of Stream ID 0 in PRIORITY to indicate the root of the priority tree.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1421

---

From: Martin Thomson <[email-masked]>
Date: Fri, 08 Jun 2018 13:31:11 +0000 (UTC)

Yep, placeholders FTW.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1421#issuecomment-395761401

---

From: ianswett <[email-masked]>
Date: Fri, 08 Jun 2018 20:30:41 +0000 (UTC)

Or/And we can start stream IDs at 1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1421#issuecomment-395881547

---

From: MikkelFJ <[email-masked]>
Date: Fri, 08 Jun 2018 13:46:48 -0700

if SID >= 1 at http level, that would be require handling stream 0 actually being used.

If enforced at transport layer then max stream ID = 0 as default suddenly enables not allowing any streams without resorting to stream counts in TP. That could be a good thing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1421#issuecomment-395885453

---

From: Mike Bishop <[email-masked]>
Date: Tue, 26 Jun 2018 21:22:06 -0700

Closed #1421 via #1422.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1421#event-1702952631