Subject: [quicwg/base-drafts] HTTP/QUIC: "Streams SHOULD be used sequentially, with no gaps." ambiguity. (#1417)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jun 2018 06:48:04 -0700

With a pedant hat on.

Section 3 discusses stream mapping and usage. The following sentence stands alone, but follows discussion on stream identifier usage.

> Streams SHOULD be used sequentially, with no gaps.

I presume this means that stream identifiers should be used sequentially, rather than lower-lever STREAM offset gaps? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1417

---

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Jun 2018 01:30:21 -0700

Saying that Stream IDs should be used sequentially feels a little odd, since the application doesn't actually have control on the Stream IDs themselves.  I'm having trouble coming up with a better wording; perhaps when I'm back on my own time zone.  ;-)

Suggestions welcome.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1417#issuecomment-395337879

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 11 Jun 2018 04:23:57 -0700

One idea (discussed in-person) is to simply remove the offending statement. However, that seems to lose some of context. 

Perhaps we could join this sentance with earlier paragraph 

> When HTTP headers and data are sent over QUIC, the QUIC layer handles most of the stream management.

and some fluffier text might help?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1417#issuecomment-396210365

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Jun 2018 14:20:48 -0700

Given that QUIC will be swinging back to implicit-open streams, this requirement at the application layer seems unnecessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1417#issuecomment-397090754

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Jun 2018 14:22:32 -0700

Closed #1417 via 5245f6b901660842f6bee198c9f18a4e1cddf64b.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1417#event-1679782666