Subject: [quicwg/base-drafts] HTTP/QUIC: Enhance guidance of using "hq" (#1415)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Jun 2018 06:33:47 -0700

Section 2 deals with HTTP/QUIC connection establishment and touches on the "hq" Alt-Svc APLN value. However, it's not until section 2.2.1 is it made clear that "hq" should only be used for the *final* RFC version.

Do you think it would help to add a short forward reference to 2.2.1, to help mitigate wasted cycles caused by the wrong ALPN getting used when broader interop happens?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1415

---

From: Mike Bishop <[email-masked]>
Date: Tue, 05 Jun 2018 08:54:16 -0700

Perhaps, but it's easier to ask the RFC Editor to drop an entire section than to delete a forward reference to the section, and I'm worried we'd end up with an erratum from a hanging reference.  Let me see if I can move 2.2.1 earlier in the section instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1415#issuecomment-394763028

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 06 Jun 2018 00:46:16 -0700

Yeah I'm sympathetic with making the RFC editor life easier (and mitigating future problems).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1415#issuecomment-394973901

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Jun 2018 10:45:16 -0700

Closed #1415 via #1427.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1415#event-1674488345