Subject: Re: [quicwg/base-drafts] Stateless Reset needs "on-path" proof (#1230)

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Jun 2018 02:34:29 -0700

@martinduke made a good point about this, which made me reconsider this idea.  A man-on-the-side attacker can copy whatever details they need from packets an endpoint sends in its use of a stateless reset oracle.  That is, if the stateless reset depends on data in a packet that an endpoint sends (and it can't depend on anything more than that), then the attacker simply copies whatever it needs from a genuine packet.  A liveness check therefore only really makes the attackers job harder.  Since the fix here that forces the attacker to be live is to make the stateless reset more complex, we should be very careful to consider the trade-off.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1230#issuecomment-395007821

---

From: MikkelFJ <[email-masked]>
Date: Wed, 06 Jun 2018 02:51:42 -0700

A loose thought, but intuition suggests:

With more roundtrips it would probably be possible to design a challenge response scheme. Dead endpoint issues a stateless reset challenge. Live endpoint responds by hashing the challenge with a negotiated reset key. Dead end point issues a new reset by hashing the live response.

MITM cannot use observed packets to issue new resets without triggering a roundtrip with proper routing between the endpoints, and the supposedly dead endpoint would not cooperate if it isn't dead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1230#issuecomment-395012757

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jun 2018 09:10:22 -0700

Discussed in Kista.  Conclusion was that the marginal benefit was minor, if not non-existent, and the cost was significant.  A man-on-the-side could build the oracle.  We will instead concentrate on documenting the constraints on the routing infrastructure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1230#issuecomment-396298189

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Jun 2018 16:10:23 +0000 (UTC)

Closed #1230.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1230#event-1674290442