Subject: [quicwg/base-drafts] ECN Proposal with only two counters (#1460)

From: Magnus Westerlund <[email-masked]>
Date: Tue, 19 Jun 2018 06:44:57 -0700

This is an evolution based on #1372 but using @martinthomson proposal of only two counters tracking only the CE and non-default ECT marking. 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1460

-- Commit Summary --

  * According to text in wiki. Some MD fixes to get right formating.
  * Modified proposed text to integrate better and take care of issues around connection migration, ensure more straightforward checks.
  * Fixed a typo on anchor creation
  * According to text in wiki. Some MD fixes to get right formating.
  * Modified proposed text to integrate better and take care of issues around connection migration, ensure more straightforward checks.
  * Fixed a typo on anchor creation
  * Merge branch 'ecn' of https://github.com/gloinul/base-drafts into ecn
  * Clarified that ACK or ACK_ECN can be used for acknowledgment in handshake. Clarified what the first packets that can be marked as ECT are in a connection.
  * Added ECN intro paragraph. Various editorial improvements of ECN text.
  * Fixed bullet list, Added parenthis around section refs.
  * Fixed indentation and formating
  * Spelling fixed
  * Rewrote the ECN check algorithm for connection migration to be robust.
  * Removed trailing spaces.
  * Fixed trailing spaces in recovery.
  * Rewraped text in both recovery and transport. Added a new sub-section on continous verification.
  * Added textual description of ECN-CE indicating congestion events.
  * Editorial fixes
  * Merge pull request #1 from quicwg/ecn
  * Editing some formulations. Rewraping more text
  * Fixed trailing spaces and remaining line length issues, I hope.
  * Reflowing now saved
  * Merge branch 'master' of https://github.com/quicwg/base-drafts into ecn
  * Merge branch 'master' of https://github.com/quicwg/base-drafts into ecn
  * Changed so that additional ECN-CE marks are sent in immediate ACKs to avoid unclarity in regards to CE marks and receovery period.
  * Fixed lint issues
  * Adding security consideration around ECN into transport.
  * Reverting some rewrapping that are not necessary to reduce clutter.
  * Addressing issues raised by Ian Sweet on 180611. Editorial improvements, new psuedo code function.
  * Clarifying that both cases are capability checks. Correcting a number of editorial things.
  * Fixed a too too much
  * Addressing Martin Thomson's comments. Several editorial changes. The biggest on the ECN block definition.
  * Added paragraph on dealing with persistent loss of acknowledgement of some sent packets. Removed editorial note that are covered by issue #1402.
  * Fixing typo in new paragraph.
  * Merge branch 'master' of https://github.com/quicwg/base-drafts into ecn
  * Added requirement on ECN marking suppression for packet duplicates.
  * Clarifying that idefinite state are not requeired in duplication detection.
  * Martin Thomson's editorial suggestions. Restructured pseudo code sections. Changed capability check and connection migration text significantly.
  * Rewrote using two counter fields.

-- File Changes --

    M draft-ietf-quic-recovery.md (112)
    M draft-ietf-quic-transport.md (203)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1460.patch
https://github.com/quicwg/base-drafts/pull/1460.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1460

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 15:56:12 -0700

we're making progress on the other, so let's close this

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1460#issuecomment-400488884

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 22:56:16 +0000 (UTC)

Closed #1460.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1460#event-1702650051