Subject: [quicwg/base-drafts] Idempotency of Frame Types (#1424)

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Jun 2018 14:35:51 -0700

In the repeated discussions of duplicated packets and what happens if an implementation accidentally processes them, it has become clear that an important property of QUIC in this respect is that every frame type is idempotent.  It doesn't matter if you receive them once or a dozen times, nor how they are reordered (only provided they're not received before they're sent, of course).  All that matters is that each reliable frame, or the information it carries, is received.

This is perhaps an important property to document, both for future iterations of the WG who are expanding QUIC, and for extension frames as they will need to have this property as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424

---

From: MikkelFJ <[email-masked]>
Date: Wed, 06 Jun 2018 14:49:04 -0700

>  (only provided they're not received before they're sent, of course)
I once had a discussion with a well-known danish physicist who seriously argued that it might be possible to receive data before they were transmitted and he considered had been contemplating putting up an experiment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#issuecomment-395225071

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 11 Jun 2018 04:19:56 -0700

This seems like an important property to capture. Some of the HTTP/QUIC text sort of falls into this category but would benefit from clearer language in the transport.

The only question I have is: is this an invariant?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#issuecomment-396209491

---

From: ianswett <[email-masked]>
Date: Mon, 11 Jun 2018 05:21:06 -0700

Agreed this would be useful to explicitly state.

I don't think we'd benefit from making this an invariant, though I would expect it to continue to be true in future versions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#issuecomment-396224405

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Jun 2018 10:17:38 -0700

Can't be an invariant; the existence of frames isn't an invariant, so their properties are even less so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#issuecomment-396318233

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 12 Jun 2018 06:16:23 -0700

Understood, thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#issuecomment-396585178

---

From: Martin Thomson <[email-masked]>
Date: Wed, 13 Jun 2018 19:51:08 -0700

Closed #1424 via #1441.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1424#event-1680163158