Subject: [quicwg/base-drafts] Coalesced packets and handshake packet limiting (#1458)

From: Mike Bishop <[email-masked]>
Date: Mon, 18 Jun 2018 14:49:45 -0700

Both current and DT output text restricts the server from sending more than three "packets" to the client until address validation has occurred.  However, in the presence of coalesced packets, three packets could be contained in a single UDP datagram:  Initial, Handshake, 1-RTT with response to the client's 0-RTT requests.

Is this text actually intending to limit the transmission to three *datagrams*?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458

---

From: Nick Banks <[email-masked]>
Date: Mon, 18 Jun 2018 14:53:33 -0700

I've always assumed it meant three UDP datagrams, and not QUIC packets. I think that makes the most sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398207770

---

From: Mike Bishop <[email-masked]>
Date: Mon, 18 Jun 2018 15:09:18 -0700

I think when we wrote that, we didn't have coalesced packets, so they were equivalent statements.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398211383

---

From: ianswett <[email-masked]>
Date: Tue, 19 Jun 2018 06:27:31 -0700

3 datagrams is better.

It's possibly 3*num_received_bytes makes even more sense, given the goal is to avoid amplification attacks?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398398426

---

From: janaiyengar <[email-masked]>
Date: Tue, 19 Jun 2018 12:14:57 -0700

Nice catch. Yes, we definitely meant that for 3 datagrams, and we did not have coalesced packets back then.  I suspect 3 datagrams is simpler than 3 * num_bytes_received, so I'm in favor of 3 datagrams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398513037

---

From: ekr <[email-masked]>
Date: Tue, 19 Jun 2018 12:22:35 -0700

+1 for 3 datagrams

On Tue, Jun 19, 2018 at 12:14 PM, janaiyengar <[email-masked]>
wrote:

> Nice catch. Yes, we definitely meant that for 3 datagrams, and we did not
> have coalesced packets back then. I suspect 3 datagrams is simpler than 3 *
> num_bytes_received, so I'm in favor of 3 datagrams.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398513037>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1obQt9qXdNzYnPTBmkJ1Gb_Xcn0PYks5t-U2vgaJpZM4Ush7e>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1458#issuecomment-398515158