Subject: [quicwg/base-drafts] Statement of idempotency (#1441)

From: Mike Bishop <[email-masked]>
Date: Tue, 12 Jun 2018 14:59:00 -0700

Fixes #1424.

Marked as editorial, since this is just a statement of what is already true about all frames anyway.  However, it's implicit that this should also be true of frames defined in the future or in extensions, so it's a bit broader than the usual editorial change.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1441

-- Commit Summary --

  * Statement of idempotency

-- File Changes --

    M draft-ietf-quic-transport.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1441.patch
https://github.com/quicwg/base-drafts/pull/1441.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441

---

From: ianswett <[email-masked]>
Date: Tue, 12 Jun 2018 15:05:31 -0700

ianswett commented on this pull request.

> @@ -906,6 +906,11 @@ explained in more detail as they are referenced later in the document.
 | 0x10 - 0x17 | STREAM            | {{frame-stream}}            |
 {: #frame-types title="Frame Types"}
 
+All QUIC frames are idempotent.  That is, the state of the connection is
+unchanged regardless of whether a frame is processed one time or multiple times,
+and a frame can be received and processed without error at any point between the

Not all frames are processed without errors, so this is a bit awkward

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#pullrequestreview-128166406

---

From: Mike Bishop <[email-masked]>
Date: Tue, 12 Jun 2018 15:09:05 -0700

MikeBishop commented on this pull request.

Perhaps that it never produces an error on a subsequent processing that it didn't produce the first time?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194903957

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jun 2018 15:12:16 -0700

martinthomson commented on this pull request.

How about: A valid frame does not change the state of the connection as a result of being received more than once.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#pullrequestreview-128168050

---

From: MikkelFJ <[email-masked]>
Date: Tue, 12 Jun 2018 15:18:17 -0700

mikkelfj commented on this pull request.

It could affect the state in terms of congestion logic and timeouts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194905820

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jun 2018 15:38:47 -0700

I think that it's packets and (specifically) ACKs that affect congestion and loss recovery state.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194909930

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Jun 2018 15:43:05 -0700

A valid frame does not cause undesirable side effects or errors when received more than once.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194910785

---

From: janaiyengar <[email-masked]>
Date: Tue, 12 Jun 2018 15:43:38 -0700

janaiyengar commented on this pull request.

@mikkelfj, presumably you are talking about receiving ACK frames. It shouldn't affect the state of congestion control or timeouts, since it all relies on whether an ACK frame has new information or not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194909040

---

From: janaiyengar <[email-masked]>
Date: Tue, 12 Jun 2018 15:44:13 -0700

I like this last re"framing"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194910977

---

From: MikkelFJ <[email-masked]>
Date: Tue, 12 Jun 2018 22:18:55 -0700

Idle timeout?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#discussion_r194958210

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Jun 2018 14:52:47 -0700

@MikeBishop pushed 1 commit.

10c5e89  Re-"framing"

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441/files/411966117c5b2a7d235273dda5a587c341bb5376..10c5e89d9f0a1d0ddaceb70332d35951070f9b26

---

From: Martin Thomson <[email-masked]>
Date: Wed, 13 Jun 2018 19:50:45 -0700

@martinthomson pushed 1 commit.

c805623  exercise editorial discretion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441/files/10c5e89d9f0a1d0ddaceb70332d35951070f9b26..c805623cc0d1984756edea4d21f60cc5e030625f

---

From: Martin Thomson <[email-masked]>
Date: Wed, 13 Jun 2018 19:51:08 -0700

Merged #1441.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1441#event-1680163157