Subject: [quicwg/base-drafts] Added change logs for -13 (#1488)

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 23:05:55 -0700

These are big, so I would appreciate a second pair of eyes.  That gives @MikeBishop a chance to fixup #1359, which I would like to see in -13 (let's concentrate all the large changes on the one version).
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1488

-- Commit Summary --

  * Added change logs

-- File Changes --

    M draft-ietf-quic-http.md (9)
    M draft-ietf-quic-qpack.md (8)
    M draft-ietf-quic-recovery.md (7)
    M draft-ietf-quic-tls.md (10)
    M draft-ietf-quic-transport.md (32)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1488.patch
https://github.com/quicwg/base-drafts/pull/1488.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 06:39:14 +0000 (UTC)

@martinthomson pushed 1 commit.

6802896  Dirty edit buffer had a few more things in it

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488/files/89a889049d2f78bdcdf4f0beb745b91d4c79c770..6802896796a2114977c4215a47160eb1efffd351

---

From: ekr <[email-masked]>
Date: Wed, 27 Jun 2018 05:11:31 -0700

ekr approved this pull request.

LGTM

> @@ -4786,17 +4786,35 @@ Issue and pull request numbers are listed with a leading octothorp.
 
 ## Since draft-ietf-quic-transport-12
 
-- Enable server to transition connections to a preferred address (#560, #1251).
-- Moved the cryptographic handshake off stream 0 and into CRYPTO frames.
-- Move stateless retry to the QUIC layer.
-- Added token fields to Initial packet header.
-- Added NEW_TOKEN frame.
+- Enable server to transition connections to a preferred address (#560, #1251,
+  #1373)
+- Added ECN feedback mechanisms and handling; new ACK_ECN frame (#804, #805,
+  #1372)
+- Changes to integration of the TLS handshake (#829, #1018, #1094, #1165, #1190,
+  #1233, #1242, #1252, #1450)
+  - The cryptographic handshake uses CRYPTO frames, not stream 0
+  - QUIC packet protection is used in place of TLS record protection
+  - Separate QUIC packet number spaces are used for the handshake
+  - Changed Retry to be independent of the cryptographic handshake

I would promote this

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488#pullrequestreview-132402703

---

From: ianswett <[email-masked]>
Date: Wed, 27 Jun 2018 12:49:18 +0000 (UTC)

ianswett approved this pull request.

I can't find anything you missed in recovery or transport.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488#pullrequestreview-132417528

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Jun 2018 11:08:43 -0700

@MikeBishop pushed 1 commit.

be00478  A couple more

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488/files/6802896796a2114977c4215a47160eb1efffd351..be00478a5e4c5eb2f5350e7d0db0494cc3834c54

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Jun 2018 11:13:34 -0700

MikeBishop approved this pull request.

Added a couple things directly.  Ship it!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488#pullrequestreview-132549411

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 14:51:31 -0700

ee2d80d  Promote TLS changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488/files/be00478a5e4c5eb2f5350e7d0db0494cc3834c54..ee2d80d54b68f12433cc53c4e10ac7bb809edc96

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Jun 2018 14:52:25 -0700

Merged #1488.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1488#event-1705001635