Subject: [quicwg/base-drafts] Can a client send 0-RTT data when receiving Retry? (#1507)

From: Kazuho Oku <[email-masked]>
Date: Fri, 29 Jun 2018 17:26:48 -0700

In previous drafts (up to -12), use of 0-RTT was forbidden when the server sends a Retry (due to the restriction of TLS 1.3). The restriction no longer exists in -13, most likely due to the fact that retry no longer involves a TLS handshake that had that restriction.

Hence the question: is a client allowed to send 0-RTT data when receiving a Retry?

My view is that, while there is no need to prohibit that, we should state that:
* servers might want to reject 0-RTT when under attack, because it is an useful tool for an attacker to consume server CPU / memory (one example of such an attack is to send a copy of ClientHello and 0-RTT data containing idempotent HTTP requests)
* clients are recommended to NOT send 0-RTT data after seeing a Retry packet because it is a sign of server being under an attack, though such a server _might_ still accept 0-RTT data that has been sent

relates to: #1498

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1507

---

From: Nick Banks <[email-masked]>
Date: Fri, 29 Jun 2018 18:11:00 -0700

I think that 0-RTT should be allowed. Generally, DDoS mitigation is just trying to prove source address ownership and then everything should continue as normal, including 0-RTT. I don't think we should have a MUST for the server to support it, but I think we should allow it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1507#issuecomment-401507288

---

From: ekr <[email-masked]>
Date: Fri, 29 Jun 2018 21:09:33 -0700

I think the client should be allowed to send 0-RTT.

I wonder if we should have a field in the Retry that says "don't send 0-RTT". Of course, you'd want to somehow protect that, which would be a pain

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1507#issuecomment-401515661