Subject: Re: [quicwg/base-drafts] Largest Reference too big (#1404)

From: afrind <[email-masked]>
Date: Fri, 01 Jun 2018 13:13:16 -0700

If tolerance of errors like this is a downward spiral, I guess I don't understand MAY instead of MUST.  Then there will be some implementations that don't treat it as an error (perhaps many, because tracking this is annoying), and the buggy encoder can just say "well it works with so-and-so".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-393996538

---

From: Martin Thomson <[email-masked]>
Date: Fri, 01 Jun 2018 16:07:26 -0700

You only need a few to police these things: https://medium.com/incerto/the-most-intolerant-wins-the-dictatorship-of-the-small-minority-3f1f83ce4e15

In some cases (this might be that case), the mere possibility of enforcement can suffice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-394031920

---

From: afrind <[email-masked]>
Date: Fri, 01 Jun 2018 16:51:22 -0700

I can't imagine a scenario where a non-buggy, non-malicious encoder would do this on purpose and needs only the threat of an error to prevent it.  But I don't want to prevent a server from calling it an error either.  If everyone likes MAY I can live with it.

Related question: If a decoder is required to treat something as an error and it doesn't, does the encoder treat the decoder's permissiveness as an error?  No encoder would ever check that, so it's really just about declaring your implementation conforms to the specification?  Or guidance so you don't accidentally get yourself into trouble?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-394037495

---

From: Mike Bishop <[email-masked]>
Date: Fri, 01 Jun 2018 20:56:13 -0700

No *production* encoder would ever check that, but there are test suites that intentionally violate certain prohibitions to confirm that the tested peer does, in fact, kill the session.  But ultimately, it's about declaring conformance.  At Microsoft, there was a procedural step where we had to disclose and document any deviations from the protocol, and complying with MUSTs is part of that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#issuecomment-394055831

---

From: afrind <[email-masked]>
Date: Fri, 22 Jun 2018 13:06:18 -0700

Closed #1404 via #1469.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1404#event-1696720256