Subject: [quicwg/base-drafts] QPACK could use some examples (#1454)

From: afrind <[email-masked]>
Date: Fri, 15 Jun 2018 22:01:01 +0000 (UTC)

>From an external researcher hoping to build an implementation: 

"The HPACK RFC authors made a wise choice to include several carefully crafted examples. I managed to create a HPACK implementation and to verify it using those examples. A similar list of examples could be considered for QPACK to make it easy to verify QPACK implementations. However, QPACK has some extra signaling, meaning constructing the examples list may not be as easy as it is for HPACK."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1454

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 15 Jun 2018 15:04:47 -0700

That is good feedback. Examples are non-normative, so one angle is to provide test vectors (outside of documentation) that helps implementers 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1454#issuecomment-397753884

---

From: afrind <[email-masked]>
Date: Fri, 15 Jun 2018 15:06:19 -0700

See also: https://github.com/quicwg/base-drafts/wiki/QPACK-Offline-Interop

I'm planning to put up some sample HAR files and their QPACK encodings under various params and assumptions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1454#issuecomment-397754143