Subject: [quicwg/base-drafts] Frame type field in APPLICATION_CLOSE (#1508)

From: Igor Lubashev <[email-masked]>
Date: Fri, 29 Jun 2018 21:46:51 -0700

I would like to see some guidance on how to set Frame Type in APPLICATION_CLOSE. If this field should always be set to "unknown", it probably should not exist in APPLICATION_CLOSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508

---

From: ianswett <[email-masked]>
Date: Sat, 30 Jun 2018 04:41:53 -0700

My intuition is this doesn't belong in APPLICATION_CLOSE, only CONNECTION_CLOSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-401535802

---

From: Mike Bishop <[email-masked]>
Date: Sat, 30 Jun 2018 20:15:32 -0700

This is probably accidental -- the field was added to CONNECTION_CLOSE without consideration that APPLICATION_CLOSE is defined to have an identical payload.  Either the payloads have now diverged, or the APPLICATION_CLOSE section should recommend a value.  (Probably STREAM or unknown, given that the error is being provoked at the application layer.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-401580144

---

From: Igor Lubashev <[email-masked]>
Date: Sat, 30 Jun 2018 21:14:49 -0700

If there is always one value (STREAM or Unknown), this provides no information. (And STREAM could be misleading -- it could be due to RST_STREAM or nothing to do with any stream at all.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-401581809