Subject: Re: [quicwg/base-drafts] Tracking of header blocks for reset streams (#1371)

From: Mike Bishop <[email-masked]>
Date: Mon, 04 Jun 2018 05:04:08 -0700

@ianswett pointed out that this could also be solved by taking the blocking setting back to a Boolean, and @afrind said he doesn't feel as strongly about the integer limit now that he's implemented it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1371#issuecomment-394331148

---

From: ianswett <[email-masked]>
Date: Mon, 04 Jun 2018 05:14:20 -0700

As Mike said, I prefer getting rid of the limit on blocking refs unless there is a very compelling reason to keep it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1371#issuecomment-394333474

---

From: afrind <[email-masked]>
Date: Thu, 07 Jun 2018 01:31:48 -0700

Discussed in Kista.  Because the problem exists for eviction races as well, and those stream level errors MAY be promoted to a connection level error at the decoder's discretion, we need to have application level acks for reset streams, which will solve both problems.  If there is strong sentiment to replace MAX_BLOCKED_STREAMS with a boolean, please open a separate issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1371#issuecomment-395338310

---

From: afrind <[email-masked]>
Date: Fri, 15 Jun 2018 11:49:23 -0700

Closed #1371 via 031f07f40bf91b8d13f0a766cf22fcc10e7e5cec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1371#event-1684058241