Subject: [quicwg/base-drafts] Guidance for flow control and ACK of extension frames (#1487)

From: MikkelFJ <[email-masked]>
Date: Tue, 26 Jun 2018 21:21:26 -0700

Given the past history, it is easy to overlook the complixity of ACK and flow control when adding new frames, so some guidance could be useful.

One option could be to define a few classes of behavior such as now flow no ACK, etc. and use an existing frame such as PING, PAD, etc. as example.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1487

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Jun 2018 21:47:52 -0700

Good idea.  We should document what an extension needs to consider in defining a new frame type.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1487#issuecomment-400541509