Subject: [quicwg/base-drafts] Discuss headers in more detail (#1516)

From: Mike Bishop <[email-masked]>
Date: Tue, 03 Jul 2018 16:28:18 -0700

Fixes #1461 by pulling in a bit of RFC7540 language and referencing lots more.  I think we've assumed all of this, but the document didn't actually say.

(If you disagree that this is what we already intended to specify, scream now.)
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1516

-- Commit Summary --

  * Discuss headers in more detail

-- File Changes --

    M draft-ietf-quic-http.md (20)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1516.patch
https://github.com/quicwg/base-drafts/pull/1516.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 03 Jul 2018 16:33:34 -0700

LPardue commented on this pull request.

One comment, what about new pseudo headers defined since RFC 7540 i.e. : protocol in H2 WebSockets

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#pullrequestreview-134200415

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jul 2018 20:25:57 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#pullrequestreview-134227783

---

From: MikkelFJ <[email-masked]>
Date: Tue, 03 Jul 2018 22:15:04 -0700

What are the exact valid header name characters? Can space and control characters be included? Ditto values - us that ASCII only, or also UTF-8? A reference to RFC would be ok, but “like earlier HTTP versions” is vague.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#issuecomment-402365397

---

From: Mike Bishop <[email-masked]>
Date: Thu, 05 Jul 2018 09:27:09 -0700

@LPardue, that's defined by an extension to HTTP/2.  To be used with HTTP/QUIC, a suspiciously similar extension would need to define it for HTTP/QUIC.  Of course, we probably need to bring in the RFC 7540 language that permits such extensions....

@mikkelfj, I was just reusing the RFC7540 language, but I agree it's a little bit loose.  I'll reference the specific section in RFC 7230.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#issuecomment-402779131

---

From: Mike Bishop <[email-masked]>
Date: Thu, 05 Jul 2018 16:36:39 +0000 (UTC)

@MikeBishop pushed 1 commit.

0538a30  Reference 7230 for allowed header characteristics

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516/files/ee0943ec7324c0e1db88e390d19834da05437140..0538a301f50eae84aa1db10a05cf8cc958db60f0

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:56:02 -0700

janaiyengar approved this pull request.

Seems fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#pullrequestreview-135153250

---

From: Mike Bishop <[email-masked]>
Date: Fri, 06 Jul 2018 14:39:26 -0700

Merged #1516.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1516#event-1721127970