Subject: [quicwg/base-drafts] Simplify receiver verification of ECN counters (#1565)

From: janaiyengar <[email-masked]>
Date: Sat, 14 Jul 2018 14:26:43 -0700

This mechanism modifies the response proposed in #1555. It isn't perfect, but it's straightforward, and addresses the fragility problem adequately I think.

Fixes #1481.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1565

-- Commit Summary --

  * Simplify receiver verification of ECN corruption

-- File Changes --

    M draft-ietf-quic-transport.md (25)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1565.patch
https://github.com/quicwg/base-drafts/pull/1565.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565

---

From: janaiyengar <[email-masked]>
Date: Sat, 14 Jul 2018 14:34:18 -0700

@janaiyengar pushed 1 commit.

0af5876  add text about allowing endpoints to detect corruption

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565/files/9fed56d1af31c535c1bc48199b8611cf271a8453..0af587657ad17ecb2a7a84d4d7e6a52ad31fcc02

---

From: Martin Thomson <[email-masked]>
Date: Sat, 14 Jul 2018 14:34:27 -0700

martinthomson approved this pull request.

> @@ -1771,20 +1772,18 @@ the expectation that either the network or the peer no longer supports ECN.
 To protect the connection from arbitrary corruption of ECN codepoints by the
 network, an endpoint verifies the following when an ACK_ECN frame is received:
 
-* The total increase in ECT(0), ECT(1), and CE counters reported in the ACK_ECN
-  frame MUST be equal to the total number of packets newly acknowledged in this
-  ACK_ECN frame.
-
-* The increase in ECT(0) and ECT(1) counters MUST be no greater than the number
+* The increase in ECT(0) and ECT(1) counters MUST be no lesser than the number

"no lesser" isn't a turn of phrase I'm comfortable with.  "MUST be at least the number of newly acknowledged packets"

>    of packets newly acknowledged that were sent with the corresponding codepoint.
 
-* If the increase in the ECT(0), ECT(1) and CE counters are greater than
-  the number of newly acknowledged packets, and the received ACK's
-  smallest acknowledged is larger than the previous largest acknowledged,
-  then it's likely acknowledgements were missed, and the above comparison
-  MUST NOT be performed. Instead a new comparison point is stored by the
-  sender so that only changes after this point will be used in the future
-  comparisons.
+* The total increase in ECT(0), ECT(1), and CE counters reported in the ACK_ECN
+  frame MUST be no lesser than the total number of packets newly acknowledged in

ditto

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565#pullrequestreview-137249097

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 15:14:20 -0700

ianswett commented on this pull request.

lg, minus Martin's comments about "no lesser"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565#pullrequestreview-137249947

---

From: Magnus Westerlund <[email-masked]>
Date: Sun, 15 Jul 2018 11:53:40 -0700

gloinul commented on this pull request.

I think this is okay given that the "no lesser" is addressed. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565#pullrequestreview-137274865

---

From: janaiyengar <[email-masked]>
Date: Tue, 17 Jul 2018 21:20:34 +0000 (UTC)

037b418  no more no lesser

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565/files/0af587657ad17ecb2a7a84d4d7e6a52ad31fcc02..037b418f7b2d5a20bfc839063031a808a46948f1

---

From: janaiyengar <[email-masked]>
Date: Tue, 17 Jul 2018 21:21:54 +0000 (UTC)

I've taken in the suggestion. Merging.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565#issuecomment-405732247

---

From: janaiyengar <[email-masked]>
Date: Tue, 17 Jul 2018 14:22:04 -0700

Merged #1565.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1565#event-1738756346