Subject: [quicwg/base-drafts] ACK_ECN type value is not incremented (#1520)

From: Daiki AMINAKA <[email-masked]>
Date: Wed, 04 Jul 2018 01:05:35 -0700

ACK_ECN type should be 0x1a if you expect the type to be incremented by 1. Or is this(0x20) expected value?

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1520

-- Commit Summary --

  * ACK_ECN type value is not incremented

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1520.patch
https://github.com/quicwg/base-drafts/pull/1520.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1520

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Jul 2018 02:10:40 -0700

martinthomson approved this pull request.

Probably best. This is the second time we (well, me mostly) have made this particular mistake. My only concern here is churn. Maybe we defer this fix and do a big rearrangement later. @janaiyengar, WDYT?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1520#pullrequestreview-134297754

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:53:31 -0700

@martinthomson : I think this is fine, given that I don't expect that anyone has implemented the ACK_ECN frame yet. We can reduce later pain if we take this in now, I think. I'll merge.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1520#issuecomment-403144164

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:53:41 -0700

janaiyengar approved this pull request.

@martin

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1520#pullrequestreview-135152657

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:53:47 -0700

Merged #1520.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1520#event-1721065439