Subject: [quicwg/base-drafts] use varints in transport parameters (#1608)

From: Marten Seemann <[email-masked]>
Date: Sun, 29 Jul 2018 15:27:40 -0700

Using varints instead of fixed size fields would allow us to save bytes in the common case, while allowing for a wider range of values if needed. Most importantly, we'd be more consistent in how we encode values across the protocol.
I'm not sure how to correctly write that in the TLS presentation language though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1608

---

From: ekr <[email-masked]>
Date: Sun, 29 Jul 2018 15:36:58 -0700

The TLS presentation language doesn't currently support varints. I suppose one could add it as a feature.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1608#issuecomment-408711045

---

From: ianswett <[email-masked]>
Date: Sun, 29 Jul 2018 15:41:34 -0700

SGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1608#issuecomment-408711275

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 29 Jul 2018 16:52:06 -0700

I think that it makes sense to use varints for representing the **values** of the TransportParameters (i.e. the values defined in [section 6.6.1 Transport Parameter Definitions](
https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.6.6.1)).

I do not oppose to using varint for TransportParameterId.

OTOH, (I do not necessarily assume that you meant this, but) I would oppose to using varints for QuicVersion, or using varint for representing the size of the blocks (i.e. the length of the block represented using `<x..y>` notation). This is because QuicVersion is a fixed length integer in QUIC as well, and because we do not have a way to express an optional block in QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1608#issuecomment-408714923

---

From: Marten Seemann <[email-masked]>
Date: Sun, 29 Jul 2018 17:24:40 -0700

> I think that it makes sense to use varints for representing the values of the TransportParameters (i.e. the values defined in section 6.6.1 Transport Parameter Definitions).

That's exactly what I meant. Thanks for clarifying.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1608#issuecomment-408717000