Subject: [quicwg/base-drafts] Only ack headers that have non-zero declared Largest Reference (#1605)

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 25 Jul 2018 07:52:51 -0700

Acknowledging headers that do not reference the dynamic table convey no useful information to the encoder.

I took the liberty to remove the part that a header block is "on a request or push stream."  This qualification is not required in the context of the changed sentence.  This information is also included in several places elsewhere in the document.

Resolves issue #1603.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1605

-- Commit Summary --

  * Only ack headers that have non-zero declared Largest Reference

-- File Changes --

    M draft-ietf-quic-qpack.md (10)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1605.patch
https://github.com/quicwg/base-drafts/pull/1605.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605

---

From: Mike Bishop <[email-masked]>
Date: Fri, 27 Jul 2018 16:40:48 -0700

MikeBishop approved this pull request.

I thought it might be worth adding a matching reference where tracking of header blocks is discussed, noting that blocks with no references don't need to be tracked and won't be acknowledged.  However, I don't see any such text that doesn't still hold true, so I think this is fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#pullrequestreview-141295927

---

From: Martin Thomson <[email-masked]>
Date: Sun, 29 Jul 2018 18:08:12 -0700

martinthomson approved this pull request.

WFM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#pullrequestreview-141369093

---

From: Martin Thomson <[email-masked]>
Date: Tue, 31 Jul 2018 06:58:06 +0000 (UTC)

I implemented this just now and it was simple enough.  And it saves a few octets in some critical cases.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#issuecomment-409116077

---

From: afrind <[email-masked]>
Date: Tue, 31 Jul 2018 09:22:00 -0700

Should we also augment the text in the reference tracking section (around line 859): 

> In order to enable this, the encoder will need to track outstanding (unacknowledged) header blocks and table updates using feedback received from the decoder.

eg: do we need to add '...with Largest Reference not equal to zero...' in there?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#issuecomment-409281351

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 31 Jul 2018 17:55:44 +0000 (UTC)

I'd leave it as-is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#issuecomment-409311140

---

From: Martin Thomson <[email-masked]>
Date: Tue, 31 Jul 2018 18:52:07 -0700

I thought the same thing, but reached the same conclusion as @dtikhonov.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1605#issuecomment-409422663