Subject: [quicwg/base-drafts] Extensions in HTTP/QUIC (#1524)

From: Mike Bishop <[email-masked]>
Date: Thu, 05 Jul 2018 09:47:09 -0700

The text currently says that extensions can define stream types and settings.  It says that they'll need to register the frame types they define, but doesn't actually say they're permitted to do so.  (I guess we consider that implied.)  It doesn't permit them to define pseudoheaders (e.g. `:protocol`).

We probably need the equivalent language of 7540 which permits them to `alter any aspect of the protocol` subject to certain constraints, and spell out those constraints.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1524

---

From: Mike Bishop <[email-masked]>
Date: Fri, 06 Jul 2018 16:49:07 -0700

Closed #1524 via #1526.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1524#event-1721245591