Subject: [quicwg/base-drafts] Grease the reserved bits (#1519)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jul 2018 23:23:54 -0700

Closes #1511.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1519

-- Commit Summary --

  * Grease the reserved bits

-- File Changes --

    M draft-ietf-quic-transport.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1519.patch
https://github.com/quicwg/base-drafts/pull/1519.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519

---

From: Marten Seemann <[email-masked]>
Date: Tue, 03 Jul 2018 23:32:30 -0700

marten-seemann commented on this pull request.

> @@ -444,7 +444,10 @@ Google QUIC Demultipexing Bit:
 Reserved:
 
 : The sixth, seventh, and eighth bits (0x7) of octet 0 are reserved for
-  experimentation.
+  experimentation.  Endpoints can MUST ignore these bits unless they are

c̶a̶n̶

gQUIC 44 is using the Long Header according to draft-11 (?), where the last two bits are used to encode the packet number length. So technically, the bits are not ignored there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#pullrequestreview-134250980

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jul 2018 23:37:00 -0700

@martinthomson pushed 1 commit.

f1d3bab  ~~can~~

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519/files/fe19ebe0ee6081b2ac1ab28228ea93942066d2ca..f1d3babd76791b69c22d1b14a0ee6999dcf34200

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Jul 2018 23:37:46 -0700

martinthomson commented on this pull request.

 Reserved:

This is version-specific text, so I think that we're OK.  Even if qQUIC doesn't use the invariants (yet) to identify versions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#discussion_r200020787

---

From: Rui Paulo <[email-masked]>
Date: Wed, 04 Jul 2018 15:23:27 -0700

LGTM Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#issuecomment-402566737

---

From: Lars Eggert <[email-masked]>
Date: Thu, 05 Jul 2018 01:45:21 -0700

larseggert approved this pull request.

 Reserved:
 
 : The sixth, seventh, and eighth bits (0x7) of octet 0 are reserved for
-  experimentation.
+  experimentation.  Endpoints MUST ignore these bits unless they are

s/ignore these bits/ignore these bits on receipt/

 Reserved:
 
 : The sixth, seventh, and eighth bits (0x7) of octet 0 are reserved for
-  experimentation.
+  experimentation.  Endpoints MUST ignore these bits unless they are
+  participating in an experiment that uses these bits.  An endpoint not
+  actively using these bits SHOULD set the value randomly to protect against

s/should set the value randomly/should randomize these bits on transmit/

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#pullrequestreview-134556366

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jul 2018 02:57:11 -0700

b7234c1  On send/receive

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519/files/f1d3babd76791b69c22d1b14a0ee6999dcf34200..b7234c1a2247ef8c9e72b896b05fca74f16b9e1f

---

From: Lars Eggert <[email-masked]>
Date: Thu, 05 Jul 2018 10:47:49 +0000 (UTC)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#pullrequestreview-134598337

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jul 2018 17:03:42 -0700

Merged #1519.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1519#event-1719245903