Subject: [quicwg/base-drafts] CANCEL_PUSH, MAX_PUSH_ID and GOAWAY specify the length of the ID twice (#1620)

From: afrind <[email-masked]>
Date: Tue, 31 Jul 2018 09:38:39 -0700

>From #1556: 

CANCEL_PUSH, MAX_PUSH_ID and GOAWAY have a variable length frame length but the frame contains only a single variable length integer, so its length is effectively specified twice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1620

---

From: Martin Thomson <[email-masked]>
Date: Tue, 31 Jul 2018 16:44:44 -0700

The advantage of having that redundancy is consistency.  All frame types have a length, which allows us to send frames of unknown types.

It seems that QUIC-the-transport leans more heavily toward the schema-aware grammar than hq or TLS, which both have redundant lengths.  The transport therefore needs prior agreement for every extension - which is fitting for something at that layer.

hq has just two instances of this sort of redundancy that I can identify: frames and settings.  I don't think that either is particularly problematic, especially in light of existing needs.  That is, you need to be able to send either without knowing that your peer will understand it.

I don't think that this needs to change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1620#issuecomment-409403052