Subject: Re: [quicwg/base-drafts] Make Packet Number a standard varint, with no inference (#1502)

From: Martin Thomson <[email-masked]>
Date: Sun, 01 Jul 2018 17:49:41 -0700

> pretty bad consequences for connection integrity (e.g. acking packets that weren't actually received)

If you reconstruct the wrong packet number, all that happens is that you can't decrypt the packet.  That's not fatal, it just looks like loss.  The damage is limited to a reduction in throughput.

In addition to the concern @ianswett raised, a 2-bit-prefixed varint can use the one octet encoding less often.  Audio is probably OK to use a one octet encoding; the one-octet/6-bit encoding can't be used at around a 640ms RTT for the most common 20ms latency, which is a pretty long hop for real-time audio.  Add video and higher packet rates and lower latency encodings start to have to use 2 octets on a shorter RTT.  The current encoding allows the rate or RTT to double before spilling over.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1502#issuecomment-401645415

---

From: Subodh Iyengar <[email-masked]>
Date: Sun, 01 Jul 2018 18:33:01 -0700

Size overhead also becomes important in use cases like text messaging where the message size becomes comparable to the protocol overhead. With this change we would rollover to 2 bytes with 256 packets which in effect means 256 messages. Sending a lol to someone where the protocol overhead itself is larger than the message.

One alternative which might be interesting is var length encoding of the truncated packet number so that we don’t need the 4 byte packet number type in the short header

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1502#issuecomment-401649131

---

From: martinduke <[email-masked]>
Date: Sun, 01 Jul 2018 21:12:42 -0700

@martinthomson Good point on the drops. I know when I'm licked. Closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1502#issuecomment-401667574

---

From: martinduke <[email-masked]>
Date: Sun, 01 Jul 2018 21:12:43 -0700

Closed #1502.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1502#event-1710654743