Subject: Re: [quicwg/base-drafts] Connection migration should be indistinguishable from a new connection (#203)

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Jul 2018 16:27:40 -0700

This proposes a change to the invariants.  By definition, then, it can't be v2.  My feeling is that we've sufficiently stabilized our choices in the invariants and we should close this with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/203#issuecomment-403997182

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Jul 2018 15:10:34 -0700

> This proposes a change to the invariants. By definition, then, it can't be v2. My feeling is that we've sufficiently stabilized our choices in the invariants and we should close this with no further action.

+1.

FWIW, my understanding is that the Invariants draft does not require long header packets to be used for connection establishment. Therefore, my understanding is that we will still have the chance to fix the issue in v2 or later versions, by starting to send everything in short packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/203#issuecomment-404326683

---

From: Mike Bishop <[email-masked]>
Date: Wed, 11 Jul 2018 15:15:12 -0700

Actually, that is in the invariants:

> A QUIC endpoint that receives a packet with a long header and a version it either does not understand or does not support might send a Version Negotiation packet in response. Packets with a short header do not trigger version negotiation and are always associated with an existing connection.

So if we want to change this, we need to change it now.  And I haven't heard any appetite to swallow that change at this point in the process.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/203#issuecomment-404327701

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Jul 2018 16:35:37 -0700

Thank you for pointing that out. I had missed that. Created PR #1550.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/203#issuecomment-404342931

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jul 2018 21:15:25 -0700

This is in the really hard bucket right now.  Other than genuinely doing a handshake (maybe with a PSK), this is easily detectable, if not trivially so.  Given the late stage of the process, unless a serious proposal emerges, this is not likely to change.

It's also questionable as to whether this is something we want to do.  The QUIC handshake tends to leak information in ways that a connection migration currently does not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/203#issuecomment-409089047