Subject: [quicwg/base-drafts] Retry in response to 0-RTT (#1547)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Jul 2018 21:26:19 -0700

It's entirely possible that a box that might be inclined to send a Retry packet could receive 0-RTT packets before an Initial packet.  Right now, that box has to drop the 0-RTT, it is prohibited from sending a Retry.

There doesn't seem to be a strong reason to prohibit sending Retry here.  Nor is there any strong reason to disallow it.  

In favour of the existing text are some weak arguments:
* Allowing Retry here means that the number of Retry packets in flight might exceed the number of Initial packets.  But we already have text about ignoring old and redundant Retry packets.
* A server that is sending Retry does so primarily to avoid taking on extra work and dropping the 0-RTT and waiting for an Initial is the easiest thing to do.

In favour of the change are equally weak arguments:
* This would allow Retry to be faster in cases where an Initial is reordered or dropped.
* A Retry sent in response to 0-RTT is indistinguishable from one sent in response to Initial packets.

Did I miss anything?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Jul 2018 23:01:09 -0700

I remain in favor of changing this to "MAY wait for Initial"; servers shouldn't be required to do anything here, but there's no reason to prohibit it and it improves performance in some not-unreasonable cases.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547#issuecomment-404054478

---

From: ianswett <[email-masked]>
Date: Wed, 11 Jul 2018 06:22:20 -0700

MAY or SHOULD are both fine with me.  However, if we say MAY, are we obliged to recommend some reasonable rate-limiting strategy to avoid sending a RETRY for every single incoming packet?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547#issuecomment-404166666

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 16:54:01 -0700

1:1 shouldn't cause any problems, even if Retry is larger than the 0-RTT packets (which it shouldn't be).  With the changes in #1498, the client can easily identify and filter out extra Retry packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547#issuecomment-404345890

---

From: Christian Huitema <[email-masked]>
Date: Thu, 12 Jul 2018 16:59:18 -0700

The obvious point against "must not" is that it is not enforceable. Suppose that a box sometimes sends retry after receiving a 0-RTT packet. The receiver does not know whether this was sent in response to Initial, or whether Initial was lost and this was sent in response to 0-RTT. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547#issuecomment-404685990

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jul 2018 22:14:45 -0700

Closed #1547 via #1552.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1547#event-1761808748