Subject: [quicwg/base-drafts] Allow Retry in response to 0-RTT packets (#1552)

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 21:54:59 -0700

Closes #1547.

(Note the target of this PR.  This is blocked on #1498.)
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1552

-- Commit Summary --

  * Allow Retry in response to 0-RTT packets

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1552.patch
https://github.com/quicwg/base-drafts/pull/1552.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552

---

From: ekr <[email-masked]>
Date: Thu, 12 Jul 2018 05:36:20 -0700

ekr commented on this pull request.

> @@ -594,7 +594,9 @@ of subsequent packets that it sends.
 A Retry packet does not include a packet number and cannot be explictly
 acknowledged by a client.
 
-A server MUST only send a Retry in response to a client Initial packet.
+A server MUST NOT send a Retry in response to packets other than Initial
+or 0-RTT packets.  A server MAY discard 0-RTT packets and only send Retry in
+response to Initial packets.

I would invert this last sentence:

"A server MAY choose to send Retry in response to Initial packets and discard or buffer 0-RTT packets corresponding to unvalidated client addresses."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552#pullrequestreview-136629384

---

From: Mike Bishop <[email-masked]>
Date: Thu, 12 Jul 2018 08:24:03 -0700

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552#pullrequestreview-136703194

---

From: Martin Thomson <[email-masked]>
Date: Sat, 14 Jul 2018 06:52:38 -0700

@martinthomson pushed 1 commit.

452d1ee  ekr's inversion of the sentence

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552/files/af69bf62c88dd9971c3c3f3ada16e0d6178e909d..452d1ee077503b307374439c6e179cf63d296e84

---

From: Martin Thomson <[email-masked]>
Date: Sat, 14 Jul 2018 06:52:45 -0700

martinthomson commented on this pull request.

Yes, that it better.  Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552#discussion_r202515614

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Jul 2018 22:14:46 -0700

Merged #1552.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1552#event-1761808747