Subject: [quicwg/base-drafts] qpack: successful header block processing as opposed to what? (#1586)

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 18 Jul 2018 14:35:38 -0700

"Successful" processing is mentioned twice in the draft (see State Synchronization).  This may raise the question on the part of the reader [1]:  _As opposed to an unsuccessful processing?_  Since an unsuccessful decoding of a header block results in a QPACK error, we should drop the "successful" part.

If successful is used to mean "processing the header block to the end so that all references in it can be decremented," we should use "complete," e.g. "header block was processed completely."

My vote would be just to drop "successful" for good.

1. The mental load required to grok an RFC should be reduced.  The fewer questions the reader may ask himself, the better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1586

---

From: afrind <[email-masked]>
Date: Thu, 19 Jul 2018 17:53:49 +0000 (UTC)

I think I prefer complete/completely to nothing at all.  Do you think saying "Completed processing of a header block" increases mental load?  Just saying "processing of a header block" might mean that processing has started.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1586#issuecomment-406361662

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 19 Jul 2018 11:06:57 -0700

I agree, it is important to indicate completion.

One alternative to using the word "complete" and its variants is to use a perfect tense:

```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1586#issuecomment-406365529