Subject: [quicwg/base-drafts] Add Definitions (#1557)

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 07:25:38 -0700

Add a separate definitions section, similar to the transport doc.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1557

-- Commit Summary --

  * Add Definitions

-- File Changes --

    M draft-ietf-quic-recovery.md (36)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1557.patch
https://github.com/quicwg/base-drafts/pull/1557.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 07:27:08 -0700

@ianswett pushed 1 commit.

abe0954  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557/files/e6afeb79c7106eeae7643fa2b4dc240c81aeb757..abe09541b3c7f8d300e5e0643012f34afa3ac1d7

---

From: janaiyengar <[email-masked]>
Date: Sat, 14 Jul 2018 11:09:18 -0700

janaiyengar commented on this pull request.

 The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD",
 "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and "OPTIONAL" in this
 document are to be interpreted as described in BCP 14 {{!RFC2119}} {{!RFC8174}}
 when, and only when, they appear in all capitals, as shown here.
 
+Definitions of terms that are used in this document:
+
+Sender:
+
+: The endpoint sending QUIC packets.
+
+Receiver:
+
+: The endpoint receiving QUIC packets and sending acknowledgements in
+  response.
+

I don't think we need the above ones. In fact they may be more confusing than useful (sender of acks, for instance)

 The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD",
 "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and "OPTIONAL" in this
 document are to be interpreted as described in BCP 14 {{!RFC2119}} {{!RFC8174}}
 when, and only when, they appear in all capitals, as shown here.
 
+Definitions of terms that are used in this document:
+
+Sender:
+
+: The endpoint sending QUIC packets.
+
+Receiver:
+
+: The endpoint receiving QUIC packets and sending acknowledgements in
+  response.
+
+ACK-only:

I think this includes PADDING. Also, you'll want to fix all uses in the doc (ack-only, ack only)

 The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD",
 "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and "OPTIONAL" in this
 document are to be interpreted as described in BCP 14 {{!RFC2119}} {{!RFC8174}}
 when, and only when, they appear in all capitals, as shown here.
 
+Definitions of terms that are used in this document:
+
+Sender:
+
+: The endpoint sending QUIC packets.
+
+Receiver:
+
+: The endpoint receiving QUIC packets and sending acknowledgements in
+  response.
+
+ACK-only:
+
+: Any packet containing only an ACK or ACK_ECN frame. The rest of this
+  document uses "ACK frames" to refer to both ACK and ACK_ECN frames.

This second sentence doesn't seem to fit in this definition. I would separate it out into a new definition for now.

> +: The endpoint sending QUIC packets.
+
+Receiver:
+
+: The endpoint receiving QUIC packets and sending acknowledgements in
+  response.
+
+ACK-only:
+
+: Any packet containing only an ACK or ACK_ECN frame. The rest of this
+  document uses "ACK frames" to refer to both ACK and ACK_ECN frames.
+
+In-flight:
+
+: Packets are considered in-flight because they have been sent
+  and neither acknowledged or considered lost, and they are not

s/or/nor/

> +
+: The endpoint sending QUIC packets.
+
+Receiver:
+
+: The endpoint receiving QUIC packets and sending acknowledgements in
+  response.
+
+ACK-only:
+
+: Any packet containing only an ACK or ACK_ECN frame. The rest of this
+  document uses "ACK frames" to refer to both ACK and ACK_ECN frames.
+
+In-flight:
+
+: Packets are considered in-flight because they have been sent

s/because/when/

> +
+ACK-only:
+
+: Any packet containing only an ACK or ACK_ECN frame. The rest of this
+  document uses "ACK frames" to refer to both ACK and ACK_ECN frames.
+
+In-flight:
+
+: Packets are considered in-flight because they have been sent
+  and neither acknowledged or considered lost, and they are not
+  ACK-only.
+
+Retransmittable:
+
+: Packets that contain frames besides ACK, ACK_ECN, or PADDING elicit
+  an ACK from the receiver and are called retransmittable.

I think you should define retransmittable frames, and packets containing a retransmittable frame as a retransmittable packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#pullrequestreview-137244854

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 11:21:06 -0700

ianswett commented on this pull request.

+
+Receiver:
+

Hmm, I think it's or.  But I changed considered to declared.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#discussion_r202521851

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 11:25:43 -0700

f4e8d10  Jana's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557/files/abe09541b3c7f8d300e5e0643012f34afa3ac1d7..f4e8d10d7a53cccdb257640c02f8dc7b8cc03b75

---

From: ianswett <[email-masked]>
Date: Sat, 14 Jul 2018 11:28:00 -0700

aa14549  ack-only

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557/files/f4e8d10d7a53cccdb257640c02f8dc7b8cc03b75..aa14549136b34e08411ea572ad5eeeada251e4f7

---

From: MikkelFJ <[email-masked]>
Date: Sat, 14 Jul 2018 12:41:49 -0700

mikkelfj commented on this pull request.

+Definitions of terms that are used in this document:
+
+ACK frames:
+
+: ACK frames refer to both ACK and ACK_ECN frames in this
+  document.
+
+ACK-only:
+
+: Any packet containing only an ACK frame.
+

Suggest being specific about ACK and ACK_ECN here

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#pullrequestreview-137246994

---

From: Martin Thomson <[email-masked]>
Date: Sat, 14 Jul 2018 14:20:55 -0700

martinthomson approved this pull request.

+In-flight:
+
+: Packets are considered in-flight when they have been sent
+  and neither acknowledged or declared lost, and they are not
+  ACK-only.
+
+Retransmittable Frames:
+
+: All frames besides ACK, ACK_ECN, or PADDING are considered
+  retransmittable.
+
+Retransmittable Packets:
+
+: Packets that contain retransmittable frames elicit an ACK from
+  the receiver and are called retransmittable packets.

Both packets and frames aren't classified as retransmittable or not.  It would be better if this used a different label.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#pullrequestreview-137248862

---

From: janaiyengar <[email-masked]>
Date: Tue, 17 Jul 2018 14:24:29 -0700

+In-flight:
+

@martinthomson : I don't understand your comment. Can you rephrase?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#discussion_r203183565

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Jul 2018 14:55:37 -0700

martinthomson commented on this pull request.

+In-flight:
+

The notion that a packet is retransmittable is a misnomer because it creates the impression that you can retransmit the packet.  Similarly, we don't retransmit frames either.  The distinction that is relevant to your uses of these terms is not whether the packet is able to be retransmitted, but whether the packet contains frames other than ACK/ACK_ECN/PADDING.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#discussion_r203194364

---

From: ianswett <[email-masked]>
Date: Mon, 23 Jul 2018 09:04:06 -0700

+In-flight:
+

I opened issue #1595 for splitting up the terms, but I'd prefer do that separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#discussion_r204459182

---

From: ianswett <[email-masked]>
Date: Mon, 30 Jul 2018 06:37:20 -0700

6e3468e  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557/files/1ea3ce044d12cea6035a1e4b15090d0c8469ceaf..6e3468e7f9cc1c730f708a985dbec6c3201d3d30

---

From: ianswett <[email-masked]>
Date: Mon, 30 Jul 2018 06:42:30 -0700

Merged #1557.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1557#event-1760198201