Subject: Re: [quicwg/base-drafts] Frame type field in APPLICATION_CLOSE (#1508)

From: Martin Thomson <[email-masked]>
Date: Sun, 01 Jul 2018 21:14:51 -0700

Yes, mea culpa.  I never intended APPLICATION_CLOSE to gain the new field.  I'll fix that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-401667820

---

From: Igor Lubashev <[email-masked]>
Date: Thu, 05 Jul 2018 19:49:03 -0700

Thanks, @martinthomson .

While on the subject of the Frame Type field, the draft leaves its format ambiguous.  It is marked (i), which usually suggests a variable-length encoding, but all other fields that use variable-length encoding spell this out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-402909872

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Jul 2018 21:16:14 -0700

@igorlord, Section 5 says:

> The Frame Type field uses a variable length integer encoding (see Section 7.1) [...]

Is that enough?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-402920869

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:37:23 -0700

Closed #1508 via #1528.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#event-1721040340

---

From: Igor Lubashev <[email-masked]>
Date: Fri, 06 Jul 2018 14:48:26 -0700

@martinthomson, yes, that section as well as Section 2.1. Notational Conventions point to the same thing.

Nevertheless, in all places but two variance-length encoded integers are explicitly stated to be such in frame descriptions.  A very rare departure from this convention would cause an unnecessary confusion that the departure was purposeful.

I'd just add the appropriate language to those places...  See PR #1534.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1508#issuecomment-403155042