Subject: Re: [quicwg/base-drafts] How to recover from loss of 3 Handshake packets without receiving PATH_RESPONSE (#1257)

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Jul 2018 03:18:26 -0700

This was addressed in the stream0 design team changes.  Don't send more than 3 datagrams without receiving acknowledgments, and any acknowledgment is enough to provide address validation, after which any number is OK (short of limits on congestion control, etc...).  Reopen if you think we need more words.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-403431493

---

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Jul 2018 03:18:28 -0700

Closed #1257.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#event-1722760998

---

From: Mike Bishop <[email-masked]>
Date: Mon, 09 Jul 2018 15:04:00 -0700

Any *acknowledgement*?  That seems odd, given how easy it would be to forge an acknowledgement of Initial packets with easily-guessed sequence numbers.  Clearly receiving anything under Handshake keys verifies actual receipt, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-403635039

---

From: Martin Thomson <[email-masked]>
Date: Mon, 09 Jul 2018 16:16:07 -0700

Imprecision in my comment only.  The text in the draft is clearer.  It says any acknowledgment with Handshake keys.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1257#issuecomment-403649104