Subject: [quicwg/base-drafts] Fix: replace "control stream" with "Encoder Stream" (#1588)

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 19 Jul 2018 19:34:32 -0700

"control stream" is not defined and in all instances it was used to refer to the Encoder Stream.

Fixes issue #1583.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1588

-- Commit Summary --

  * Fix: replace "control stream" with "Encoder Stream"

-- File Changes --

    M draft-ietf-quic-qpack.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1588.patch
https://github.com/quicwg/base-drafts/pull/1588.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588

---

From: Martin Thomson <[email-masked]>
Date: Fri, 20 Jul 2018 09:20:02 -0700

martinthomson approved this pull request.

Seems fine, though I'm not sure that we need Capitalization.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588#pullrequestreview-139123538

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 20 Jul 2018 10:42:59 -0700

```
[dmitri@ubuntu-dmitri base-drafts]$ grep '[Ee]ncoder [Ss]tream' draft-ietf-quic-qpack.txt
     5.2.  QPACK Encoder Stream  . . . . . . . . . . . . . . . . . .  11
   Entries are added by instructions on the Encoder Stream (see
   while interpreting instructions on the encoder stream.
   o  The encoder stream is a unidirectional stream of type "0x48"
   All table updates occur on the encoder stream.  Request streams and
5.2.  QPACK Encoder Stream
   The contents of the encoder stream are an unframed sequence of the
         | QPACK Encoder Stream | 0x48 | Section 5     | Both   |
   o  Removed framing from encoder stream (#1361,#1467)
```

Outside of tables and headers, _Encoder Stream_ is used once, while _encoder stream_ is used three times.  We should pick one and go with it.  I, too, think that Encoder Stream looks odd (as this is not XVIII century), so I'd vote for the lowercase version.

P.S. Why does not GitHub allow one to insert polls...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588#issuecomment-406674963

---

From: Martin Thomson <[email-masked]>
Date: Fri, 20 Jul 2018 13:40:16 -0700

Only one of the uppercase instances is not a title.

Either way, this seems like a matter of editorial discretion. Alan can make a call.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588#issuecomment-406720714

---

From: afrind <[email-masked]>
Date: Tue, 24 Jul 2018 08:22:51 -0700

I think I prefer lowercase as well

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588#issuecomment-407446393

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 24 Jul 2018 15:36:59 +0000 (UTC)

@dtikhonov pushed 1 commit.

dfb2af7  Use lowercase "encoder stream" except in titles and figures

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1588/files/b03d0ec6c7e6f6be43cb5201e975e423d91fe71b..dfb2af749e46c6576ac80348658a24b5152227e2