Subject: [quicwg/base-drafts] Be more explicit about key derivation (#1568)

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jul 2018 07:05:42 -0700

The text on key derivation is extremely thin and this is causing some people trouble.  We should expand this and be more explicit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jul 2018 07:28:08 -0700

Discussion at hackathon concluded that the current interpretation would be that all invocations of HKDF-Expand-Label in QUIC would use the "quic " label prefix.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405095723

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 15 Jul 2018 07:29:44 -0700

IIRC some of us slightly leaned to using "tls13 " as the prefix for traffic secrets, so that we could use a session ticket obtained using TLS 1.3 over TCP in QUIC.

It would give us 1-RTT reduction when switching from H2 to HQ using alt-svc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405095804

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Jul 2018 07:36:27 -0700

I don't see how resumption from h2 to hq is relevant.

Traffic secrets are generated by TLS, using "tls13 ", the only one that we have to worry about is the initial secrets, which QUIC derives.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405096204

---

From: ianswett <[email-masked]>
Date: Sun, 15 Jul 2018 07:40:31 -0700

@kazuho for more discussion of resumption from TLS over TCP, see Issue #941 which is v2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405096468

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 15 Jul 2018 07:42:25 -0700

> Traffic secrets are generated by TLS, using "tls13 ", the only one that we have to worry about is the initial secrets, which QUIC derives.

My understanding is that (at least for the interop) we have agreed to use "quic " for traffic secrets as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405096563

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 15 Jul 2018 07:49:21 -0700

@ianswett Thanks for the pointer. I left my comment there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1568#issuecomment-405096970