Subject: [quicwg/base-drafts] Consider encrypting the long header payload length as part of packet number encryption (#1576)

From: David Schinazi <[email-masked]>
Date: Tue, 17 Jul 2018 08:34:54 -0700

Encrypting the long header payload length would make all non-invariant bytes of QUICv1 encrypted (apart from the first byte). It wouldn't give us a significant privacy win because the length can be computed from the UDP length and/or searching for cleartext version numbers further in the payload - but obfuscating this could help reduce yet another possibility for ossification.

If we decide to move forward with #1575, then PNE for long header would just encrypt 8 bytes starting from the start of the payload length.

Apologies if this has been discussed before, I wasn't able to find it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576

---

From: Rui Paulo <[email-masked]>
Date: Tue, 17 Jul 2018 09:03:03 -0700

This would break coalesced packets (multiple QUIC packets in one UDP frame).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576#issuecomment-405636044

---

From: David Schinazi <[email-masked]>
Date: Tue, 17 Jul 2018 11:00:16 -0700

How so? You decrypt one length/packet number at a time. Or am I missing something?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576#issuecomment-405672073

---

From: MikkelFJ <[email-masked]>
Date: Tue, 17 Jul 2018 11:28:55 -0700

You do not necessarily have all the keys for all the packets in the datagram. You are required to ignore those you don't understand. That is hard if the length is unkown.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576#issuecomment-405682041

---

From: David Schinazi <[email-masked]>
Date: Tue, 17 Jul 2018 11:45:20 -0700

Closed #1576.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576#event-1738447614

---

From: David Schinazi <[email-masked]>
Date: Tue, 17 Jul 2018 19:16:16 +0000 (UTC)

@mikkelfj good point. This would break that scenario, thanks for bringing it up. Closing this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1576#issuecomment-405687097