Subject: Re: [quicwg/base-drafts] What to do when part of a coalesced packet is invalid? (#1319)

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 22:03:36 -0700

Closed #1319.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1319#event-1729433600

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 22:03:36 -0700

I believe that the current text is clear on this point:

> Every QUIC packet that is coalesced into a single UDP datagram is separate and
 complete.  [...] If one or more
 packets in a datagram cannot be processed yet (because the keys are not yet
 available) or processing fails (decryption failure, unknown type, etc.), the
 receiver MUST still attempt to process the remaining packets.

Yes, this leads to the possibility of padding with junk.  The only restriction on that is to match the connection ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1319#issuecomment-404390160

---

From: Mike Bishop <[email-masked]>
Date: Wed, 11 Jul 2018 22:29:33 -0700

(To be fair, that text was added after this issue was filed, and that PR probably should have closed this issue.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1319#issuecomment-404393866

---

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Jul 2018 23:26:17 -0700

It could actively be used to carry secondary protocols over a QUIC connection. For example routing information. It could be used by middleware to inject tracking information, or even on-path-attackers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1319#issuecomment-404403328

---

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Jul 2018 23:27:49 -0700

There is no reason to permit secondary payload outside of the early handshake - it is just an open invitation to all sorts of unpredictable and unwanted behavior.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1319#issuecomment-404403569