Subject: Re: [quicwg/base-drafts] Eliminating the fixed minimum RTO (#1017)

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 17 Jul 2018 19:09:10 -0700

RTO should be a function of the RTT and should also account for MAD, and we should have exponential backoff. As long as this is true, I agree that there is no need for minrto. What about initial, handshake and 0-RTT packets though when RTT information is not available? We still need to mandate a minimum for these packets?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1017#issuecomment-405785692

---

From: ianswett <[email-masked]>
Date: Tue, 17 Jul 2018 20:53:15 -0700

Prior to handshake completion, QUIC only retransmits handshake packets, so the mechanism is slightly different, and therefore we should not need a MinRTO because the RTO timer isn't active.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1017#issuecomment-405800767