Subject: [quicwg/base-drafts] Move HTTP_*PACK_COMPRESSION_FAILED to QPACK (#1532)

From: Mike Bishop <[email-masked]>
Date: Fri, 06 Jul 2018 11:14:46 -0700

Closes #1529; finishes what #1358 started.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1532

-- Commit Summary --

  * Move HTTP_*PACK_COMPRESSION_FAILED to QPACK

-- File Changes --

    M draft-ietf-quic-http.md (6)
    M draft-ietf-quic-qpack.md (24)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1532.patch
https://github.com/quicwg/base-drafts/pull/1532.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532

---

From: janaiyengar <[email-masked]>
Date: Fri, 06 Jul 2018 13:39:41 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532#pullrequestreview-135148937

---

From: afrind <[email-masked]>
Date: Tue, 10 Jul 2018 14:59:56 -0700

afrind commented on this pull request.

> @@ -975,6 +984,21 @@ The entries in the following table are registered by this document.
 | QPACK Decoder Stream         | 0x68   | {{wire-format}}           | Both   |
 | ---------------------------- | ------ | ------------------------- | ------ |
 
+## Error Code Registration
+
+This document establishes one new error code in the "HTTP/QUIC Error Code"
+registry established in {{QUIC-HTTP}}.
+
+Name:
+: HTTP_QPACK_DECOMPRESSION_FAILED
+
+Code:
+: 0x06
+
+Description:
+: QPACK failed to decompress a frame and cannot continue.

I'm not sure 'frame' is the right term here.  This is basically any decoding error of any kind, which may occur outside of a frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532#pullrequestreview-136026651

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Jul 2018 15:03:10 -0700

MikeBishop commented on this pull request.

Good point -- just stale text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532#discussion_r201510138

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Jul 2018 15:07:21 -0700

@MikeBishop pushed 1 commit.

0ded987  instructions, not frames

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532/files/c8a8e6c58323837edbe7d5907e691d2637fbc87a..0ded987f7870852530197071281bf244db73185c

---

From: afrind <[email-masked]>
Date: Tue, 10 Jul 2018 16:42:42 -0700

Merged #1532.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1532#event-1726765694