Subject: [quicwg/base-drafts] Remove the discussion about when to use long header (#1550)

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Jul 2018 16:35:11 -0700

I think current text is a bit too restrictive, and that it might cause misunderstanding.

* V2 and later versions should have the freedom to decide when to trigger version negotiation (note: version negotiation requires the use of long header packets).
* Removes the false impression that the use of a path always start with a long header. That is not the case for v1 due to involuntary NAT rebinding.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1550

-- Commit Summary --

  * Remove the discussion about when to use long header. Reasons:

-- File Changes --

    M draft-ietf-quic-invariants.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1550.patch
https://github.com/quicwg/base-drafts/pull/1550.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1550

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 17:19:54 -0700

While the text is correct in the sense that you can't do version negotiation without packets that use the long header, I see your point here.  This is more consistent with the minimalist nature of the doc, which avoids implying basically anything about what use of any of these packets implies.

My natural inclination would have been to address this sort of concern with an example in the appendix along the lines of:

* the first packets exchanged in a flow use the long header

Do you think that we should add that as well?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1550#issuecomment-404350173

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Jul 2018 17:37:52 -0700

> Do you think that we should add that as well?

I think that it would be a good idea to add that as well, under the premise that it would be written as an anticipation rather than a requirement that all the future versions of QUIC will comply with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1550#issuecomment-404353084

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 17:57:04 -0700

@martinthomson pushed 1 commit.

3a05e54  Add another bad assumption

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1550/files/3a54198a6fbab323f430550f7dab18ddb995f87e..3a05e5472c55e77370596a3ed3b15c71dcd4bcfa

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Jul 2018 17:57:42 -0700

Merged #1550.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1550#event-1729224836