Subject: [quicwg/base-drafts] Other congestion controllers (#1633)

From: ianswett <[email-masked]>
Date: Thu, 02 Aug 2018 15:48:43 -0700

Fixes #1625 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1633

-- Commit Summary --

  * Other congestion controllers

-- File Changes --

    M draft-ietf-quic-recovery.md (16)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1633.patch
https://github.com/quicwg/base-drafts/pull/1633.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Aug 2018 16:09:02 -0700

martinthomson approved this pull request.

Yeah, this is good.  Wondering if we need to say more, but I'll leave that to your discretion.

 QUIC hosts MUST NOT send packets if they would increase bytes_in_flight
-(defined in {{vars-of-interest}}) beyond the available congestion window, unless
-the packet is a probe packet sent after the TLP or RTO timer expires, as
-described in {{tlp}} and {{rto}}.
+(defined in {{vars-of-interest}}) beyond the available congestion window,
+unless the packet is a probe packet sent after the TLP or RTO timer expires,
+as described in {{tlp}} and {{rto}}.
+
+Implementations MAY use other congestion control algorithms.

Do we also need to say that endpoints don't need to use the same congestion controller?  IOW, "Implementations MAY use a different congestion control algorithm, even within the same connection.  The signals that QUIC provides for congestion control are generic and can support different congestion control regimens."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633#pullrequestreview-143008398

---

From: ianswett <[email-masked]>
Date: Fri, 03 Aug 2018 14:10:59 +0000 (UTC)

@ianswett pushed 1 commit.

7048686  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633/files/8044e531b7d9ece947d0cd14785eb787cec42624..70486864a7b09e45acb9400a7d1a7f565b012e4b

---

From: ianswett <[email-masked]>
Date: Fri, 03 Aug 2018 07:11:25 -0700

Thanks Martin, I added your comment about the signals being generic.  Changing congestion controllers mid-connection is certainly possible, but I think it ends up being more confusing than clarifying.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633#issuecomment-410261598

---

From: Martin Thomson <[email-masked]>
Date: Fri, 03 Aug 2018 07:35:51 -0700

I never intended to imply a change mid-connection, just that the choice was unilateral.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633#issuecomment-410270998

---

From: ianswett <[email-masked]>
Date: Fri, 03 Aug 2018 15:44:32 +0000 (UTC)

c7baa15  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633/files/70486864a7b09e45acb9400a7d1a7f565b012e4b..c7baa15cb308c8dddec7b5eb85d610dc38eca9cd

---

From: ianswett <[email-masked]>
Date: Fri, 03 Aug 2018 13:49:17 -0700

Merged #1633 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1633#event-1770820299