Subject: [quicwg/base-drafts] "Payload" vs. "content" (#1676)

From: Mike Bishop <[email-masked]>
Date: Thu, 16 Aug 2018 11:21:49 -0700

@mirjak points out that payload and content are both used to refer to the body of QUIC packets.  Worth doing a pass to ensure that these are used consistently.  My first pass at definitions:

- "Payload" is the collection of frames in the encrypted body of the packet.
- "Content" is the conceptual set of information conveyed by those frames, but probably not something we reference very often in the spec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1676

---

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 11:30:41 -0700

Yes, I agree with this definition there might actually only a few cases where its not correct but further I think it would be important to actually define this somewhere explicitly.

Or to say your definition in other words
Payload is the thing in a PACKET that follows the header.
Content is any information or data carried in a FRAME.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1676#issuecomment-413642009

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Aug 2018 22:13:30 -0700

Closed #1676 via #1703.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1676#event-1812145160