Subject: [quicwg/base-drafts] Should coalescing order be enforced? (#1702)

From: Christian Huitema <[email-masked]>
Date: Fri, 24 Aug 2018 17:30:09 +0000 (UTC)

Draft-transport-14 says:
```
   Senders SHOULD coalesce packets in order of increasing encryption
   levels (Initial, Handshake, 0-RTT, 1-RTT), as this makes it more
   likely the receiver will be able to process all the packets in a
   single pass.  A packet with a short header does not include a length,
   so it will always be the last packet included in a UDP datagram.
```
The use of normative language here is interesting, and raises a few questions:

1) The spec says SHOULD. This implicitly means "MAY do something else". What, why, under which circumstances?

2) Are the peers supposed to enforce that requirement in any way?

In any case, the natural order in which packets are processed is not (Initial, Handshake, 0-RTT, 1-RTT), but rather (Initial, 0-RTT, Handshake, 1-RTT), as in "ACK of Server Hello", "EOED", "Client Finished", "Application data". I suggest rewriting to:

```
   Coalescing packets in order of increasing encryption
   levels (Initial, 0-RTT, Handshake, 1-RTT) makes it more
   likely the receiver will be able to process all the packets in a
   single pass.  A packet with a short header does not include a length,
   so it will always be the last packet included in a UDP datagram.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1702

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 22:23:24 -0700

This is the result of discussion on #1287, but I like your rewording of this and will commit that change :)

Did I make submitting PRs too difficult?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1702#issuecomment-416117549

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 22:24:41 -0700

Closed #1702 via 4600624baccaaa3af1c1d1e98a97f1d2a0f3a8c1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1702#event-1809787788