Subject: [quicwg/base-drafts] PN of CLOSE (#1674)

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 09:52:24 -0700

The spec provides an exeption for packet with closing frames to be re-send with the same PN (and then all state could be removed and only the packet must be stored). However, the packet could be store and before send out again the PN could be increased by one. Yes this requires to re-do PNE but that only needs very limited addtional state. Is that really necessary?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674

---

From: MikkelFJ <[email-masked]>
Date: Thu, 16 Aug 2018 17:45:16 +0000 (UTC)

If you close when you run out of packet numbers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#issuecomment-413628393

---

From: ianswett <[email-masked]>
Date: Thu, 16 Aug 2018 17:58:46 +0000 (UTC)

Changing the PN requires re-encrypting the entire packet, which requires enough state to do that, which is likely larger than storing the payload of a connection close packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#issuecomment-413632485

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 Aug 2018 12:13:16 -0700

Yep.  If the packet number weren't the IV to the payload encryption, you could keep the encrypted payload and just PNE a new packet number.  However, because of how that's connected, changing the packet number requires you to start over from the plaintext of the payload.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#issuecomment-413654296

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 Aug 2018 17:17:07 -0700

The allowance [here](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#immediate-close) isn't harmful.  And we don't say that endpoints can't regenerate the closing packet with new packet numbers.

So what is the exact problem here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#issuecomment-413721317

---

From: mirjak <[email-masked]>
Date: Fri, 17 Aug 2018 01:43:35 -0700

Closed #1674.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#event-1794167186

---

From: mirjak <[email-masked]>
Date: Fri, 17 Aug 2018 01:43:35 -0700

I thought it's just not necessary but didn't realize that you have to re-encode the payload as well. So that's fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1674#issuecomment-413799270