Subject: [quicwg/base-drafts] Does the first byte of stateless reset include random bits? (#1678)

From: Christian Huitema <[email-masked]>
Date: Thu, 16 Aug 2018 14:56:17 -0700

Section 6.13.4 of draft-transport-14 defines the first byte of the stateless reset packet as:
```
   +-+-+-+-+-+-+-+-+
   |0|K|1|1|0|0|0|0|
   +-+-+-+-+-+-+-+-+
```
I notice that the first byte is slightly different from the specification of the short header in section 4.2:
```
   +-+-+-+-+-+-+-+-+
   |0|K|1|1|0|R R R|
   +-+-+-+-+-+-+-+-+
```
Is that deliberate, or just an oversight?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1678

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 Aug 2018 17:25:21 -0700

It was deliberate, but only as a simplification.  Once we know what those R values are, we can fix this too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1678#issuecomment-413722505