Subject: [quicwg/base-drafts] Start indexing dynamic QPACK table beginning at zero (#1650)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 10 Aug 2018 11:17:58 -0700

Based on discussion in [issue #1644](https://github.com/quicwg/base-drafts/issues/1644#issuecomment-411949968).

To avoid potential for confusion around zero the raw _Largest Reference_ value and zero the smallest valid absolute index, I introduced a term "specified:" the _Largest Reference_ value is either specified or not.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1650

-- Commit Summary --

  * Start indexing dynamic QPACK table beginning at zero

-- File Changes --

    M draft-ietf-quic-qpack.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1650.patch
https://github.com/quicwg/base-drafts/pull/1650.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 Aug 2018 13:41:01 -0700

MikeBishop approved this pull request.

Seems reasonable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650#pullrequestreview-145391391

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Aug 2018 18:00:49 -0700

martinthomson commented on this pull request.

I don't think that the largest reference needs to be described this way, as I said in https://github.com/quicwg/base-drafts/issues/1644#issuecomment-412382372.

Rather than describe things this way, describe this as the size of the table at the time of reference.  That's a name change, I guess, but functionally equivalent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650#pullrequestreview-145494845

---

From: afrind <[email-masked]>
Date: Fri, 17 Aug 2018 16:38:27 -0700

Is this intended to stand on its own or only as part of the stack with #1644.  @martinthomson had a comment on that issue about what it means to be not-specified.  This field is required so how can it be not specified?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650#issuecomment-414013107

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sat, 18 Aug 2018 09:25:43 -0700

After discussing #1644 at length, I am no longer convinced that starting the dynamic table at 0 is better that 1.  I now think it makes no difference.  Closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650#issuecomment-414069788

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sat, 18 Aug 2018 09:25:43 -0700

Closed #1650.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1650#event-1796034764