Subject: [quicwg/base-drafts] TLS dependencies and packet number encryption (#1669)

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 09:22:35 -0700

Given that PN encryption is not TLS specific and could/should be performed the same way even if a different crypto handshake protocol is used, I wonder if that part should rather go in the tranport draft. Not that the tls draft is actually named "Using Transport Layer Security (TLS) to Secure QUIC".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1669

---

From: MikkelFJ <[email-masked]>
Date: Thu, 16 Aug 2018 10:43:56 -0700

The same argument could be made about transport parameters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1669#issuecomment-413627992

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 Aug 2018 12:11:00 -0700

@mikkelfj, transport parameters *are* in the transport doc.  The TLS doc simply defines a TLS extension capable of transporting the blob QUIC hands it.  That bit is TLS-specific.

I tend to think that all of packet protection belongs in the transport document, not the TLS document. TLS produces keys; QUIC consumes keys from its crypto handshake (which in this version is TLS).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1669#issuecomment-413653702

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 Aug 2018 17:14:29 -0700

Closed #1669.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1669#event-1793631330

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 Aug 2018 17:14:30 -0700

One of the pieces of restructuring we have considered is moving the packet protection completely across.  That's tracked by #411. We'll address that there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1669#issuecomment-413720973