Subject: [quicwg/base-drafts] The server shouldn't use a token for much (#1647)

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Aug 2018 18:33:14 -0700

The token that a server provides in Retry or NEW_TOKEN isn't authenticated.  It can be used multiple times and it isn't folded into the handshake.  This is an explicit limitation of the design.  Neither client nor server can therefore rely on its contents for much.  A server can ensure that the token is self-authenticating (by including a MAC or self encrypting it with an AEAD, for instance), but it shouldn't really use the information beyond its immediate purpose: address validation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1647

---

From: MikkelFJ <[email-masked]>
Date: Fri, 10 Aug 2018 00:29:41 -0700

If adding such advice, please be specific about encryption is not authentication. Although QUIC implementers would or should now, it could easily be missed by infrastructure operators. Merely stating AEAD or MAC can easily be misread as golang.encrypt(x) should be fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1647#issuecomment-412000360

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Aug 2018 22:13:59 -0700

Closed #1647 via #1704.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1647#event-1812145581