Subject: Re: [quicwg/base-drafts] Use of "supports ECN" is confusing (#1587)

From: mirjak <[email-masked]>
Date: Wed, 01 Aug 2018 08:08:11 -0700

see PR #1631

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1587#issuecomment-409608543

---

From: janaiyengar <[email-masked]>
Date: Tue, 07 Aug 2018 12:11:30 -0700

I don't think this distinction is useful, and I don't understand it. An endpoint can choose to not support ECN, for whatever reason, one of them being that the ECN codepoints are not accessible. If it helps to clarify this, I'm happy to write something that clarifies what "endpoint support of ECN" means... I don't think we need more than a sentence to clarify this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1587#issuecomment-411168016

---

From: mirjak <[email-masked]>
Date: Thu, 09 Aug 2018 16:54:35 +0000 (UTC)

There are two parts of "support": one is using it on the forward path and the other one is to provide feedback to the other end that decided to use ECN on its forward path. These are two independent decision and that's why "supports ECN" is confusing. It could be "use ECN" and "supoort ECN feedback" but I would rather recommend to just be clear and try to avoid any confusion at all. 

Another point is that in TCP no ECN support can also mean that ECN is not implemented because it's an extension that was added later (and therefore you need to negotiate it in the handshake). This should not be the case for quic and we should not give the impression that the providing feedback is an optional feature for implementation. 

Also I think, If the other end wants to use ECN on its forward pass and you are able to access the IP ECN bits, you respect the design of the other end and send feedback. I guess we could make a stronger point about this...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1587#issuecomment-411825362

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 23:13:23 -0700

Closed #1587.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1587#event-1809837304

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 23:13:24 -0700

Closed by #1631.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1587#issuecomment-416124901