Subject: [quicwg/base-drafts] ACKs imply stream state transitions (#1667)

From: Mike Bishop <[email-masked]>
Date: Wed, 15 Aug 2018 19:11:31 +0000 (UTC)

We have text from a long-ago issue that says:

> A packet MUST NOT be acknowledged until packet protection has been successfully removed and all frames contained in the packet have been processed.  **Any stream state transitions triggered by the frame MUST have occurred.**

Since the move to MAX_STREAM_ID and the updated stream state machine, implementations no longer need to track the stream state transitions on the peer, only locally.  Do we still need this requirement?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1667

---

From: ianswett <[email-masked]>
Date: Wed, 15 Aug 2018 13:15:38 -0700

I don't think so?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1667#issuecomment-413321556

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Aug 2018 16:00:55 -0700

I don't think that there are any state transitions that would be illegal that would result from this.  The "all frames have been processed clause" covers this anyway.  Let me double-check the state machines, but I think that this is OK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1667#issuecomment-413366021

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 22:46:13 -0700

Closed #1667 via d9b1d6b74fe32f23f1bcfeac70ef72e227a3b694.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1667#event-1809807602