Subject: Re: [quicwg/base-drafts] Need to prevent amplification attack for any case where the server's response is big (#1309)

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Aug 2018 15:29:54 -0700

Closed #1309.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1309#event-1768800985

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Aug 2018 15:29:54 -0700

OK, as discussed on #1616:

If there is no valid token we already have text that says that you can't send more than 3 datagrams.  That covers 0-RTT as well has the handshake.  If there is a valid token, limiting the amount of data sent to a valid peer is a job for a congestion controller.  In this case, the initial congestion window is sufficient (or, as ekr put it: YOLO).

With recommended settings, that moves from 3 packets to 10, which isn't a big enough increase to be problematic, especially considering the amount of processing involved in accepting and responding to 0-RTT.  Servers won't want to do that without a reasonable assurance that the data is wanted, so the amplification attack surface is reduced.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1309#issuecomment-410087950