Subject: [quicwg/base-drafts] Recommendation for rate limits (#1673)

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 09:45:14 -0700

There are to recommended/required rate limits in the transport draft:

"an endpoint MAY
   limit the rate at which it sends PATH_RESPONSE frames"

and

"Until a peer's address is deemed valid, an endpoint MUST
   limit the rate at which it sends data to this address."

Can we maybe provide more guidance what those rate limits should be or at least an upper bound because otherwise using normative language doesn't help much...?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1673

---

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 09:47:19 -0700

Same is true for re-tries:

"An endpoint SHOULD abandon path validation after sending some number
   of PATH_CHALLENGE frames or after some time has passed."

"A receiver MAY send
   MAX_STREAM_DATA frames in multiple packets..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1673#issuecomment-413611141

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 22:38:39 -0700

> an endpoint MAY limit the rate at which it sends PATH_RESPONSE frames

This needs no recommendation in my view.  This only allows for PATH_CHALLENGE to be dropped by a recipient, like the network might do.

> Until a peer's address is deemed valid, an endpoint MUST limit the rate at which it sends data to this address.

This needs to use the IW rules.

> An endpoint SHOULD abandon path validation after sending some number of PATH_CHALLENGE frames or after some time has passed

No recommendation needed here.

> A receiver MAY send MAX_STREAM_DATA frames in multiple packets

Or here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1673#issuecomment-416119563