Subject: [quicwg/base-drafts] Reconcile 'content' and 'payload' (#1703)

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Aug 2018 22:33:49 -0700

I did a complete pass through and it wasn't that bad.  As we agreed,
payload is the bytes that we protect, content is the more abstract
notion of what needs to be communicated (for which we use frames).  That
was already mostly right, apart from a few places.

Closes #1676.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1703

-- Commit Summary --

  * Reconcile 'content' and 'payload'

-- File Changes --

    M draft-ietf-quic-transport.md (31)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1703.patch
https://github.com/quicwg/base-drafts/pull/1703.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1703

---

From: Mike Bishop <[email-masked]>
Date: Mon, 27 Aug 2018 17:33:15 +0000 (UTC)

MikeBishop approved this pull request.

Thanks for doing this.

> @@ -1109,7 +1109,7 @@ Stateless Reset do not contain frames.
 |                          Frame N (*)                        ...
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 ~~~
-{: #packet-frames title="Contents of Protected Payload"}
+{: #packet-frames title="QUIC Payload"}
 
 Protected payloads MUST contain at least one frame, and MAY contain multiple

You removed the term "protected payload" from the title of the figure, but not from the following paragraph.

> @@ -566,8 +566,8 @@ wishes to perform a stateless retry (see {{stateless-retry}}).
 
 A Retry packet (shown in {{retry-format}}) only uses the invariant portion of
 the long packet header {{QUIC-INVARIANTS}}; that is, the fields up to and
-including the Destination and Source Connection ID fields.  The contents of the
-Retry packet are not protected.  Like Version Negotiation, a Retry packet
+including the Destination and Source Connection ID fields.  The Payload of a

Could go either way, but I'd lean toward not capitalizing this usage, or saying "The Payload field"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1703#pullrequestreview-149806422

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Aug 2018 17:08:12 -0700

@martinthomson pushed 1 commit.

b6f4315  Fixups

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1703/files/d6cff092de7f48cfeb39b584f70966316259b837..b6f431537d7613a4910ea92560581b32780ea41b

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Aug 2018 17:09:23 -0700

martinthomson commented on this pull request.

I realized that we say that it has a Payload here, then say that it doesn't in the next sentence, so I changed this more.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1703#discussion_r213151913

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Aug 2018 22:13:29 -0700

Merged #1703 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1703#event-1812145159