Subject: [quicwg/base-drafts] Greasing version negotiation (#1668)

From: mirjak <[email-masked]>
Date: Thu, 16 Aug 2018 16:14:22 +0000 (UTC)

I know this was discussed and concluded early on but I would like to bring this up again as probably the plan for versioning quic quickly has changed since.

The transport draft currently says:
"Versions that follow the pattern 0x?a?a?a?a are reserved for use in
   forcing version negotiation to be exercised.  That is, any version
   number where the low four bits of all octets is 1010 (in binary).  A
   client or server MAY advertise support for any of these reserved
   versions."

My question: Are people actually implemening and using this? Because forcing version negotiation means additional latency. I would assume that publishing a next version quickly and actually using version negotiation as indented is the better greasing.

So basically this is a quick check if we still want to have that text. I assume we can quickly agree and close this issue again!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1668

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 Aug 2018 13:25:17 -0700

Yes, actually *using* multiple versions is the best way, but this has value as well.  I'd expect to see this in servers mostly, padding out VN packets with reserved versions.  Clients that aren't latency sensitive might do an initial probe with a junk payload and a reserved version occasionally, but I don't expect browsers will very often.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1668#issuecomment-413673499