Subject: [quicwg/base-drafts] Change packet types (#1655)

From: Udip Pant <[email-masked]>
Date: Mon, 13 Aug 2018 09:01:00 -0700

For initial and 0-rtt packets, we're planning on using the 5-tuple in our L4 load balancer, and the connid for other packet types. To do this we need to look at the packet types as to whether or not we should look at the connid. However with the current packet format, we need an extra shift instruction to process whether or not we need to look at the connid. A simple reorganization of the packet types as:

Initial 0x7F
0-RTT Protected 0x7E
Retry 0x7D
Handshake 0x7C

will help us determine whether or not to use connid with one instruction : ( pkt_type ^ FF ) > 1

In environments, such as bpf program, number of instructions matter. Further, this provides an easy win, and intuitive separation of packet types with and without server chosen connection id.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1655

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Aug 2018 21:37:57 +0000 (UTC)

I was considering a similar change, for completely different reasons.  Let's keep this as a reminder.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1655#issuecomment-412673720

---

From: Udip Pant <[email-masked]>
Date: Mon, 13 Aug 2018 15:04:24 -0700

Thank you @martinthomson . Happy to submit a P.R. if you'd prefer so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1655#issuecomment-412680838

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Aug 2018 16:36:03 -0700

The reason this is up for review is the discussion about the first octet.  The working group mailing list has [a discussion on that](https://mailarchive.ietf.org/arch/msg/quic/N2lbdSFFxkhAYtwCCBlNHBZeCEU).  I'd prefer to wait for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1655#issuecomment-412701490