Subject: [quicwg/base-drafts] Error for not receiving SETTINGS frame as the first frame on a control stream (#1697)

From: Dragana Damjanovic <[email-masked]>
Date: Wed, 22 Aug 2018 23:41:11 -0700

The paragraph says the a SETTING frame must be the first frame on a control stream but it does not specifies which error should be sent if that is not the case.

>  A SETTINGS frame MUST be sent as the first frame of either control stream (see {{stream-mapping}}) by each peer, and MUST NOT be sent subsequently or on any other stream. If an endpoint receives an SETTINGS frame on a different stream, the endpoint MUST respond with a connection error of type HTTP_WRONG_STREAM. If an endpoint receives a second SETTINGS frame, the endpoint MUST respond with a connection error of type HTTP_MALFORMED_FRAME.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1697

---

From: Mike Bishop <[email-masked]>
Date: Thu, 23 Aug 2018 10:51:38 -0700

Also, the control streams are now not so prominent in the referenced section.  I'm thinking a more generally clean-up is warranted, and perhaps even separating control vs. request/response streams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1697#issuecomment-415509888