Subject: [quicwg/base-drafts] add code points for 1, 2 and 3 byte connection IDs (#1628)

From: Marten Seemann <[email-masked]>
Date: Wed, 01 Aug 2018 02:05:52 -0700

This PR changes the invariants and the transport document to allow 1, 2 and 3 byte connection IDs as well.

Fixes #1570.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1628

-- Commit Summary --

  * add code points for 1, 2 and 3 byte connection IDs

-- File Changes --

    M draft-ietf-quic-invariants.md (8)
    M draft-ietf-quic-transport.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1628.patch
https://github.com/quicwg/base-drafts/pull/1628.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1628

---

From: MikkelFJ <[email-masked]>
Date: Wed, 01 Aug 2018 02:17:16 -0700

Perhaps some advisory text on a CID lengths below 32 cannot be expected to be have the same uniqueness and unlinkability properties as longer CID's and should be considered for special purposes only, such as internal server P2P.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1628#issuecomment-409509528

---

From: ianswett <[email-masked]>
Date: Tue, 07 Aug 2018 13:08:00 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1628#pullrequestreview-144163516

---

From: ekr <[email-masked]>
Date: Tue, 07 Aug 2018 15:11:10 -0700

As I noted in email, I think this really would need a new WG consensus call

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1628#issuecomment-411219621

---

From: ianswett <[email-masked]>
Date: Tue, 07 Aug 2018 15:18:03 -0700

Agreed, this needs a new WG consensus call.  I was giving my approval of the text and direction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1628#issuecomment-411221207