Subject: [quicwg/base-drafts] Stateless Reset and CID Recovery (#1639)

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Aug 2018 20:22:45 +0000 (UTC)

[6.13.4.2](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.6.13.4.2) discusses the need to request a non-zero-length CID if you want to be able to generate Stateless Resets:

> An endpoint that loses state can use the same method to generate a valid Stateless Reset Token. The connection ID comes from the packet that the endpoint receives.
> 
> This design relies on the peer always sending a connection ID in its packets so that the endpoint can use the connection ID from a packet to reset the connection. An endpoint that uses this design cannot allow its peers to send packets with a zero-length destination connection ID.

However, it doesn't discuss the fact that the length of the CID isn't identifiable from a short-header packet, and therefore even this algorithm works only if you either use a constant CID length or embed a length indicator in your CIDs.  This might be a worthwhile piece to mention.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1639

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Aug 2018 15:47:32 -0700

Closed #1639 via #1640.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1639#event-1778964028