Subject: Re: [quicwg/base-drafts] CANCEL_PUSH, MAX_PUSH_ID and GOAWAY specify the length of the ID twice (#1620)

From: afrind <[email-masked]>
Date: Thu, 02 Aug 2018 22:25:50 +0000 (UTC)

I think what I'm asking about, for both frames and SETTINGS in the linked issue, is whether QUIC varints are the best choice for representing integers in HQ.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1620#issuecomment-410087118

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Aug 2018 12:40:00 -0700

I think that's a fair question, and I'm coming around to the idea of length-prefixed non-varint values for SETTINGS.  It's a level of complexity that seemed like we might need it coming out of HTTP/2, and a few years later that need hasn't proven itself out.

For these frames, we're referencing Stream IDs / Push IDs.  Stream IDs are a transport layer concept and I'm reluctant to introduce an alternative encoding.  We already have at least one place (PRIORITY) where Push and Stream IDs are encoded in the same field, which argues for using the same encoding for both.  If not varint, what?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1620#issuecomment-411177005