Subject: [quicwg/base-drafts] Receiving same New Connection ID twice (#1738)

From: Christian Huitema <[email-masked]>
Date: Mon, 10 Sep 2018 16:15:09 -0700

All frames are idempotent. I read that to mean that if the same New Connection ID frame is received twice, the second transmission should be a no-op. I assume that "same frame" here means the same connection ID, the same reset secret, and the same sequence if we still care about sequences. That much is fine. But what if the two frames are almost the same, say with the same connection ID and a different reset secret? Should the node update the previously received secret, or should it signal a protocol violation?

A variation of that happens if the node sends a "New Connection ID" frame, and the connection ID is the same as the source ID used by that node. I assume it is a protocol violation. Or is it just a nice way for clients to tell servers about their reset secret?

(I realize that there may be work in progress in some secret PR -- but then, please submit it to the main repo.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738

---

From: erickinnear <[email-masked]>
Date: Mon, 10 Sep 2018 16:36:00 -0700

@huitema I'm not aware of any secret PR. 
What I think you're referring to is the output from the Connection ID design team, which will be submitted as a PR to the main repo after all members of that DT have had a chance to review the latest proposal (hopefully tonight). It seems reasonable to make sure that everyone on the DT is happy with its output before submitting it to the main repo and representing it as such. 

Regardless, I don't believe that any of that work currently has impact on this issue, which is both a very good point and something that should probably be clarified. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#issuecomment-420095402

---

From: Christian Huitema <[email-masked]>
Date: Mon, 10 Sep 2018 18:47:54 -0700

OK, will submit a separate PR then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#issuecomment-420118691

---

From: Christian Huitema <[email-masked]>
Date: Mon, 10 Sep 2018 18:54:33 -0700

@erickinnear The parenthesis was because after I flagged a similar issue (#1729), @martinthomson asked me to "Please see erickinnear#4 - that address this problem (and some others)." I read that, wanted to comment, and could not because of some access control. And I wasn't even aware that the CNXID design team was still working on something, since in theory draft 13 was incorporating the team's design. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#issuecomment-420119732

---

From: Christian Huitema <[email-masked]>
Date: Mon, 10 Sep 2018 23:09:09 -0700

Entered PR #1739 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#issuecomment-420158007

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Sep 2018 11:46:08 -0700

Closed by #1739.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#issuecomment-422126987

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Sep 2018 11:46:09 -0700

Closed #1738.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1738#event-1850544599