Subject: [quicwg/base-drafts] Receive MAX_STREAM_DATA for non-existent stream (#1805)

From: Vidhi Goel <[email-masked]>
Date: Wed, 26 Sep 2018 10:33:57 -0700

Assuming I am client and I want to create a new bidi stream. When creating a new stream, I would set the max stream data as initial_max_stream_data_bidi_remote transport parameter received during handshake. 

But what if before opening the stream, server sends me MAX_STREAM_DATA frame? I understand that the draft says, quote
"If an endpoint receives a frame for a stream that it expects to initiate (i.e., odd-numbered for the client or even-numbered for the server), but which it has not yet opened, it MUST close the connection with error code STREAM_STATE_ERROR"

Does this apply to all stream related frames (MAX_STREAM_DATA, STREAM_BLOCKED, STREAM_ID_BLOCKED etc.)?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1805

---

From: Vidhi Goel <[email-masked]>
Date: Wed, 26 Sep 2018 13:05:31 -0700

I realized it is explained later in the Section 9.2.2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1805#issuecomment-424851463

---

From: Vidhi Goel <[email-masked]>
Date: Wed, 26 Sep 2018 20:05:31 +0000 (UTC)

Closed #1805.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1805#event-1869391989