Subject: [quicwg/base-drafts] NEW_CONNECTION_ID in Probing Packets (#1746)

From: Mike Bishop <[email-masked]>
Date: Fri, 14 Sep 2018 12:18:34 -0700

#1730 encourages probes to include a NEW_CONNECTION_ID frame, but doing so makes it a "non-probing packet."  From a client, that initiates a hand-over; from a server, that's prohibited until the client has sent a non-probing packet.

The simple fix is to expand the definition of probing packets to include NCID frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1746

---

From: Christian Huitema <[email-masked]>
Date: Fri, 14 Sep 2018 14:20:12 -0700

Creating or repeating NCID in the probe is the right thing to do, because of fate sharing, etc. But then, probes are by definition unreliable. Some will get lost. You may not want to repeat the probe, but if it contained an NCID you do want to repeat that. So there is some amount of book-keeping required. If a probe is abandoned without being acknowledged, the NCID needs to be resent on a "normal" packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1746#issuecomment-421487527

---

From: janaiyengar <[email-masked]>
Date: Mon, 24 Sep 2018 16:12:46 -0700

Closed #1746 via #1790.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1746#event-1864396154