Subject: [quicwg/base-drafts] Stateless reset is now available to both peers (#1735)

From: Martin Thomson <[email-masked]>
Date: Sun, 09 Sep 2018 17:41:44 -0700

Also, don't create the impression that stateless reset can be used when
a packet can't be decrypted.

Closes #1728.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1735

-- Commit Summary --

  * Stateless reset is now available to both peers

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1735.patch
https://github.com/quicwg/base-drafts/pull/1735.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735

---

From: Rui Paulo <[email-masked]>
Date: Sun, 09 Sep 2018 19:21:48 -0700

Thanks @martinthomson, this looks great.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735#issuecomment-419768814

---

From: ianswett <[email-masked]>
Date: Mon, 10 Sep 2018 07:11:16 -0700

ianswett commented on this pull request.

> @@ -1278,6 +1278,9 @@ IDs, QUIC processes the packet as part of that connection. Endpoints MUST drop
 packets with zero-length Destination Connection ID fields if they do not
 correspond to a single connection.
 
+Endpoints SHOULD send a Stateless Reset ({{stateless-reset}}) for any packets

I think this should be restricted to short-header packets, correct?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735#pullrequestreview-153792302

---

From: Rui Paulo <[email-masked]>
Date: Mon, 10 Sep 2018 13:59:08 -0700

rpaulo commented on this pull request.

We already have text in the Stateless Reset section saying an endpoint MAY send a stateless reset for a LH packet.  I can't really understand how an implementation would do that, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735#discussion_r216470683

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Sep 2018 17:41:17 -0700

Merged #1735 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735#event-1837355892

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Sep 2018 17:41:09 -0700

martinthomson commented on this pull request.

Yes, let's not reiterate that discussion.  Right now, it's basically impossible to except in a very narrow window during the handshake, but we agreed that there was no reason not to allow it.  If the long header is used after the handshake completes (for reasons we come up with later), then we don't have to worry about stateless reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1735#discussion_r216516475