Subject: [quicwg/base-drafts] The server needs to acknowledge that a Retry happened (#1793)

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 16:55:05 -0700

Closes #1710, #1486.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1793

-- Commit Summary --

  * The server needs to acknowledge that a Retry happened

-- File Changes --

    M draft-ietf-quic-transport.md (21)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1793.patch
https://github.com/quicwg/base-drafts/pull/1793.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793

---

From: Nick Banks <[email-masked]>
Date: Tue, 25 Sep 2018 07:54:23 -0700

nibanks requested changes on this pull request.

Why is the design such that the client validates instead of the server? Can we not have such a design where the client updates its TP to include the original CID, and the server validates this? It is the one that knows if it expected a Retry or not. In the case of a completely independent DoS protection device, that the server wants to allow for, it doesn't necessarily know the original CID, and could then just generally allow any changes. I just think the server should be the one doing the validation, as it know the deployment state; not the client.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#pullrequestreview-158583928

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 20:14:43 +0000 (UTC)

To clarify, the server can't generate a retry itself IF there's also a DoS device in front of it.  If the DoS device is the server, I don't see why that wouldn't work?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#issuecomment-424485433

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 20:18:00 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#pullrequestreview-158726139

---

From: Nick Banks <[email-masked]>
Date: Tue, 25 Sep 2018 20:23:12 +0000 (UTC)

To be specific, the server can't generate a Retry if the DoS device already generated one. If the DoS device is only present some of the time, the those other times, the server can still do it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#issuecomment-424488143

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Sep 2018 21:09:32 +0000 (UTC)

> Why is the design such that the client validates instead of the server? 

It creates the right incentives.  This way, server implementations can't cheap out and not implement the check or coordination.  If servers didn't check, middleboxes could come to rely on them not checking.  That leads to Retry coming from middleboxes, which I heard pretty firmly that we don't want.

Given how easy this is to manage with a tiny bit of coordination (Azure could simply publish their scheme for encoding the connection ID into the token, for instance), this scheme seems like the best way to avoid that class of problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#issuecomment-424502381

---

From: janaiyengar <[email-masked]>
Date: Tue, 25 Sep 2018 15:36:08 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#pullrequestreview-158772700

---

From: Mike Bishop <[email-masked]>
Date: Tue, 25 Sep 2018 15:36:51 -0700

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#pullrequestreview-158772879

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Sep 2018 15:45:40 -0700

Merged #1793 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1793#event-1867046374