Subject: [quicwg/base-drafts] Is zero a valid argument for the Table State Synchronize instruction? (#1736)

From: Kazuho Oku <[email-masked]>
Date: Sun, 09 Sep 2018 18:14:16 -0700

The QPACK draft is unclear about if insert count of zero should be considered a valid argument of the Table State Synchronize instruction.

I think we should better clarify that to avoid interoperability issues (my fear is that if some minor portion of QUIC stacks consider insert_count of zero to be invalid, some QUIC stacks might get shipped without noticing the existence of such stacks. Then, we would see interoperability issues in the wild).

FWIW, my weak preference goes to prohibiting use of zero as the argument. One way of achieving that would be to change the argument of the insruction to _number_of_inserts - 1_.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1736

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sun, 09 Sep 2018 19:33:44 -0700

We can make zero invalid and keep the zero byte as a potential extension mechanism.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1736#issuecomment-419770413

---

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Sep 2018 21:58:28 +0000 (UTC)

If it's valid, the literal interpretation of it would be no-op.  I would be opposed to allowing an instruction that would move the value backwards, but having no effect seems relatively unobjectionable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1736#issuecomment-420075153

---

From: afrind <[email-masked]>
Date: Tue, 11 Sep 2018 08:29:39 -0700

There's never a reason to send TSS/0, unless your implementation is buggy or lazy about calculating when to send it.  I'm not sure I see it as an extension point, but making zero invalid seems reasonable to me.  I prefer that to sending inserts - 1, which seems like another opportunity for off-by-one errors.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1736#issuecomment-420315398

---

From: afrind <[email-masked]>
Date: Thu, 27 Sep 2018 15:46:15 -0700

Closed #1736 via #1762.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1736#event-1872305369