Subject: [quicwg/base-drafts] OnPacketAcked issue (#1774)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Sep 2018 17:48:27 +0000 (UTC)

Issue for what I described to @ianswett at dinner yesterday.

When `OnRetransmissionTimeoutVerified` is called from `OnPacketAcked` for the highest ACK in a block, all earlier packets are marked as lost, even if they are contained in that same block. That seems suboptimal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1774

---

From: ianswett <[email-masked]>
Date: Wed, 19 Sep 2018 17:51:59 +0000 (UTC)

Yeah, this is not intended behavior, so I'll clarify that both the text and pseudocode.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1774#issuecomment-422897792