Subject: Re: [quicwg/base-drafts] s/does not/SHOULD NOT/ (b8c0e60)

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Sep 2018 07:19:12 -0700

Why SHOULD NOT?  Why would I choose one over the other?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b8c0e60a0ab3124111ec93977ca53a465148667b#commitcomment-30547420

---

From: afrind <[email-masked]>
Date: Tue, 18 Sep 2018 07:34:50 -0700

Are you asking for more text explaining this, or disagreeing that SHOULD NOT is the right choice?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b8c0e60a0ab3124111ec93977ca53a465148667b#commitcomment-30547640

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Sep 2018 11:08:17 -0700

when you use should not, it means that you have reasons for recommending the behaviour, and occasional reasons for not following that recommendation.  It also means that you need to explain that choice.

it would be easier to use MUST NOT, but that creates problems for the encoder, as I described (poorly, I see now)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/b8c0e60a0ab3124111ec93977ca53a465148667b#commitcomment-30550853