Subject: [quicwg/base-drafts] Considerations about when to send Stateless Reset (#1728)

From: Rui Paulo <[email-masked]>
Date: Fri, 07 Sep 2018 21:50:04 -0700

Section 6.2.2. Server Packet Handling, says, at the end:

> Servers MUST drop incoming packets under all other circumstances. They SHOULD send a Stateless Reset (Section 6.13.4) if they are able.

The last sentence is a bit dangerous.  A stateless reset should NOT be sent when the endpoint has access to the connection state and can't decrypt a packet.  Otherwise any random packet would kill a connection.  Saying "if they are able" might be interpreted incorrectly.  Can we just change it to "They SHOULD send a Stateless Reset (Section 6.13.4) when they no longer have access to the complete connection state."

The way I understand it, a stateless reset token would be something that the endpoint saves in non-volatile memory which can be used to reset connections after a crash/reboot.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1728

---

From: Martin Thomson <[email-masked]>
Date: Sun, 09 Sep 2018 17:40:35 -0700

This also doesn't reflect the symmetric nature of stateless reset.  I will adjust.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1728#issuecomment-419757565

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Sep 2018 17:41:15 -0700

Closed #1728 via #1735.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1728#event-1837355895