Subject: [quicwg/base-drafts] MAX_DATA doesn't comply with MAX_STREAM_DATA (#1812)

From: Vidhi Goel <[email-masked]>
Date: Fri, 28 Sep 2018 14:09:55 -0700

Based on the draft, a receiver can compute MAX_DATA as below:

"A receiver might use a sum of bytes consumed on all contributing streams to determine the maximum data limit to be advertised."

But if the receiver misbehaves and advertises MAX_DATA (for example, 2MB) that doesn't comply with MAX_STREAM_DATA (for example, 3MB), does that mean that the sender is blocked if it has already sent up to 2MB?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1812

---

From: Marten Seemann <[email-masked]>
Date: Fri, 28 Sep 2018 14:11:38 -0700

Yes, that's exactly the point of connection-level flow control.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1812#issuecomment-425567282

---

From: Mike Bishop <[email-masked]>
Date: Fri, 28 Sep 2018 14:47:51 -0700

Closed #1812.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1812#event-1874529585

---

From: Mike Bishop <[email-masked]>
Date: Fri, 28 Sep 2018 14:47:52 -0700

That's not misbehavior, it's reflecting the fact that stream- and connection-level flow control may have different constraints.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1812#issuecomment-425575377