Subject: Re: [quicwg/base-drafts] Subsequent Initial Packets with Token Field (#1649)

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Sep 2018 12:07:48 -0700

The rule here is that the first packet that the server receives needs to be both padded to 1200+ AND include a token.  All other Initial packets have neither requirement.  So the "server receives" part here is funny because it encompasses Initial after Retry and Initial after Version Negotiation.  We should write this down.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1649#issuecomment-422133800

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 16:08:01 -0700

Rule here is, in light of #1764, that the client needs to send 1200+ datagram until it knows (for certain) that the server has validated the client source address.  The way servers validate the client's source address in the handshake is by receiving packets with Handshake keys (or higher, but we know that 1-RTT packets aren't read until Handshake packets are all read).  So the way the client learns that the server is OK is to get an ACK at the Handshake encryption level (or higher, see above).

The token only appears in the first one, and the packet sent in response to a Retry.  That is probably more aggressive than necessary, but it keeps things simple.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1649#issuecomment-424154721