Subject: [quicwg/base-drafts] QPACK: make TSS=0 a connection error (#1762)

From: afrind <[email-masked]>
Date: Mon, 17 Sep 2018 18:42:50 -0700

Fixes #1736
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1762

-- Commit Summary --

  * QPACK: make TSS=0 a connection error

-- File Changes --

    M draft-ietf-quic-qpack.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1762.patch
https://github.com/quicwg/base-drafts/pull/1762.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 18 Sep 2018 13:41:01 -0700

dtikhonov requested changes on this pull request.

> @@ -587,9 +587,10 @@ entries might cause a stream to become blocked, as described in
 ~~~~~~~~~~
 {:#fig-size-sync title="Table State Synchronize"}
 
-An encoder that receives an Insert Count that is greater than the number of
-dynamic table entries beyond the current Largest Known Received entry MUST treat
-this as a connection error of type `HTTP_QPACK_DECODER_STREAM_ERROR`.
+An encoder that receives an Insert Count equal to zero, or that is greater than

I don't like the "that" in "or that:" does it refer to the insert count or to the encoder?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#pullrequestreview-156559201

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 18 Sep 2018 20:44:57 +0000 (UTC)

dtikhonov commented on this pull request.

 ~~~~~~~~~~

Perhaps something along the lines of:

> The Insert Count value cannot be zero and it cannot be greater than the current Largest Known Received value.  An encoder that receives an invalid Insert Count value MUST treat it...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#discussion_r218588228

---

From: afrind <[email-masked]>
Date: Wed, 19 Sep 2018 18:16:06 +0000 (UTC)

afrind commented on this pull request.

 ~~~~~~~~~~

The constraint is tighter than < Largest Known Received, the text here captures it.  LKR + IC must be < Base Index

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#discussion_r218910561

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 19 Sep 2018 11:20:02 -0700

~~~~~~~~~~

OK, mine was just an example.  I'd split the sentence into two to make it unambiguous and easier to read.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#discussion_r218911754

---

From: Mike Bishop <[email-masked]>
Date: Wed, 26 Sep 2018 11:33:32 -0700

MikeBishop approved this pull request.

This is fine, but one suggestion for readability.

"...greater than the number of dynamic table entries beyond the current Largest Known Received" is correct, but not immediately comprehensible.  Maybe framing that as "...which indicates receipt of an entry which has not been sent" would help it be obvious why that number is a problem?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#pullrequestreview-159139221

---

From: afrind <[email-masked]>
Date: Thu, 27 Sep 2018 11:56:46 -0700

@afrind pushed 1 commit.

44c0124  Mike's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762/files/14d456668ed9ebe5c23fb104d17e35de0d2945af..44c01245c7cd1c6211b72a7e81fdd21cf8c5c57f

---

From: afrind <[email-masked]>
Date: Thu, 27 Sep 2018 15:46:16 -0700

Merged #1762 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1762#event-1872305364