Subject: Re: [quicwg/base-drafts] Unified ACK frame (#1706)

From: mirjak <[email-masked]>
Date: Mon, 03 Sep 2018 10:11:30 -0700

I still think is better to have ECT(0) and ECT(1) merged in to one type (instead of ECT(1) and non-ECT) because that gives the other end the change to experiment with ECT(1) without requiring any support/deployment of changes to the receiver-side.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#issuecomment-418163701

---

From: Martin Thomson <[email-masked]>
Date: Mon, 03 Sep 2018 17:30:21 -0700

@mirjak, whichever way we merge, some information is lost.  You are arguing for erasing the distinction between ECT(1) and ECT(0), where this PR makes ECT(1) and unmarked indistinguishable.  Or, to state differently, this allows a receiver to distinguish between ECT(0) and ECT(1), but you would prefer to distinguish between unmarked and ECT(any).

I am assuming that an experiment that varies markings will care more about switching between ECT markings than it will between marked and unmarked.  What property would you (and others) prefer?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#issuecomment-418209579

---

From: mirjak <[email-masked]>
Date: Thu, 06 Sep 2018 01:54:45 -0700

Currently, the assumption for experiments with ECT(1) is that you only use ECT(1) (and no ECT(0)) on such a connection to enable a new kind of behavior. Therefore the difference between ECT(0) and ECT(1) is not important (expect for probing) as you should only see one or the other on one connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#issuecomment-419017717

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 14 Sep 2018 04:20:13 -0700

So based on the discussion and my further analysis I think we should not adopt this pull request. I think counters are the best option, and I am fine with optimizing their representation as it will definitely save a number of bytes per ACK for long lived connections.  

When it comes to marking in this one. I think unless one have an explicit mechanism for sender to signal to receiver which ECT codepoints that are the one used then having one ECT(any) would be the better choice. Using both ECT codepoints needs additional extensions as some of the experiments with marking, like L4S does mean that packets marked with different ECT values sees different paths. Thus, there need to be mechanisms in place to handle this. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#issuecomment-421328718

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 15:08:14 -0700

Agreed in NYC not to do this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#issuecomment-424141806

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 15:08:18 -0700

Closed #1706.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1706#event-1864308108