Subject: [quicwg/base-drafts] Merge ACK and ACK_ECN (#1801)

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:02:45 -0700

Fixes #1778
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1801

-- Commit Summary --

  * Merge ACK and ACK_ECN

-- File Changes --

    M draft-ietf-quic-transport.md (107)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1801.patch
https://github.com/quicwg/base-drafts/pull/1801.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:04:04 -0700

@ianswett pushed 1 commit.

c7e3e10  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/bb364d6cc97ae849dda2f134f7fa5758fbae82b9..c7e3e10a08a709e4bb9bcc0ba1c30ad92f7a49ea

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 02:05:47 +0000 (UTC)

ddd62cb  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/c7e3e10a08a709e4bb9bcc0ba1c30ad92f7a49ea..ddd62cb4d9f578e575025f64406c56b6ebec27ea

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:06:49 -0700

bd85b7b  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/ddd62cb4d9f578e575025f64406c56b6ebec27ea..bd85b7b5bdcac11eee97d8632855fb5fe33a6e75

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:08:57 -0700

09e9db0  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/bd85b7b5bdcac11eee97d8632855fb5fe33a6e75..09e9db0465840e38bdbd8747b1a02ac1203ecf90

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:16:16 -0700

0d14b5c  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/09e9db0465840e38bdbd8747b1a02ac1203ecf90..0d14b5c6e996656606874ec9d6f2d22a6d9f24be

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:22:03 -0700

12a4d9a  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/0d14b5c6e996656606874ec9d6f2d22a6d9f24be..12a4d9adbb787dbb6f0033acdb7ad3981aeb420d

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:28:07 -0700

481260f  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/12a4d9adbb787dbb6f0033acdb7ad3981aeb420d..481260f22146d263d351ae7b5245671429148483

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 19:29:12 -0700

064b237  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/481260f22146d263d351ae7b5245671429148483..064b237fea02ccb15d633eef1f134230464acf5b

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Sep 2018 08:39:15 -0700

martinthomson commented on this pull request.

I might have done a more thorough renumber, but this is a nice minimal change.  We can kick around the renumbering thing later.

 Gap and ACK Block fields use a relative integer encoding for efficiency.  Though
 each encoded value is positive, the values are subtracted, so that each ACK
 Block describes progressively lower-numbered packets.  As long as contiguous
 ranges of packets are small, the variable-length integer encoding ensures that
 each range can be expressed in a small number of octets.
 
+The ACK frame uses the least significant bit(type=0x1b) to indicate ECN feedback

"bit (that is, type 0x1b)"

> @@ -3374,9 +3373,11 @@ Application Error Code:
 
 ## ACK Frame {#frame-ack}
 
-Receivers send ACK frames (type=0x0d) to inform senders which packets they have
-received and processed. The ACK frame contains any number of ACK blocks.
-ACK blocks are ranges of acknowledged packets.
+Receivers send ACK frames (types=0x1a - 0x1b) to inform senders of packets they

(types 0x1a and 0x1b)

> @@ -3374,9 +3373,11 @@ Application Error Code:
 
 ## ACK Frame {#frame-ack}
 
-Receivers send ACK frames (type=0x0d) to inform senders which packets they have
-received and processed. The ACK frame contains any number of ACK blocks.
-ACK blocks are ranges of acknowledged packets.
+Receivers send ACK frames (types=0x1a - 0x1b) to inform senders of packets they
+have received and processed. The ACK frame contains one or more ACK blocks. ACK

should we be capitalizing the B in ACK Blocks?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801#pullrequestreview-159060395

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 15:52:05 +0000 (UTC)

da050dd  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/064b237fea02ccb15d633eef1f134230464acf5b..da050dd8207a2981a1a198d199265350bbc63087

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 08:53:15 -0700

I decided against the big renumber.  I thought it'd be best done interactively by 2 or 3 people together.

Block wasn't consistently capitalized, so I made it so everywhere.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801#issuecomment-424764959

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 08:56:09 -0700

a5b115d  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801/files/da050dd8207a2981a1a198d199265350bbc63087..a5b115df606ca2f21f63b1777382d8aee62e9431

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 18:06:54 -0700

Any other comments?  Martin or Jana, would you be willing to merge this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801#issuecomment-424920926

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Sep 2018 17:17:32 +0000 (UTC)

Merged #1801 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1801#event-1871667215