Subject: Re: [quicwg/base-drafts] Restructure document (#411)

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 21:40:12 +0000 (UTC)

Discussed on 2018-09-24:

Proposed structure w/ notes:

1. Introduction
2. Overview
3. Streams (might be multiple top-level sections)
   a. concepts
   b. lifecycle
   c. flow control
4. Connection Handshake
   a. Example Handshake (high level)
   b. Packet Handling
   c. Version Negotiation
   d. Retry (tokens, etc....)
   e. Handshake Packets (cite TLS drafts)
   f. Transport parameters (what they are for, not the format)
5. Connection Migration
6. Connection Shutdown
7. Packets and Frames (format, layout, coalescing)
8. Sending and Resending Packets
9. Acknowledging Packets
10. Packet Size (Initial size, PMTUD etc...)
11. Version Numbers
12. Long and Short Headers
13. Packet Formats
14. Transport Parmeters
15. Frame Formats
16. Error Codes
17. Security Considerations
18. IANA
19. Other stuff...

>From Section 11 onwards, try to keep to pure format and only have minimal description of semantics.  Most of the semantic stuff should already be covered.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/411#issuecomment-424135023

---

From: ianswett <[email-masked]>
Date: Tue, 25 Sep 2018 00:32:09 -0700

It seems odd to put connection migration so early when things like Sending and Acknowledging packets is much later(though having those adjacent I think makes sense).  Is there a reason connection migration needs to be that early, such as it's introducing text used later?

Re 8: QUIC doesn't resent packets

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/411#issuecomment-424237154

---

From: mirjak <[email-masked]>
Date: Tue, 25 Sep 2018 02:54:19 -0700

I guess you will also need to have the "Packets and Frame" section much earlier in the doc and I would think that the "Short and Long Headers" might be a subsection of that...? Also "Packet Size" might also be rather a subsection somewhere.

However, I also have to say that the split in the current doc between section 5 "Frames and Frame Types" and 7 "Frame Types and Formats" is rather awkward, so I not sure I would recommend to keep it that way but maybe that's currently rather an editorial issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/411#issuecomment-424279558

---

From: Brian Trammell <[email-masked]>
Date: Wed, 26 Sep 2018 07:05:49 +0000 (UTC)

wrt §7, it's probably useful to split this into sections for the non-encrypted part of the wire image (basically the packet headers) and everything inside. Otherwise it seems easy to get confused about what's encrypted and what's in the clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/411#issuecomment-424608381