Subject: [quicwg/base-drafts] Send Stream State starts with "Send" for peer-initiated bidi streams (#1802)

From: Kazuho Oku <[email-masked]>
Date: Tue, 25 Sep 2018 21:30:22 -0700

The change fixes #1797, and also clarifies that deferring the allocation of stream ID while in "Ready" state does not apply to pere-initated bidi streams.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1802

-- Commit Summary --

  * sending part of bidi stream initiated by peer starts from "Send" state
  * update the diagram accordingly
  * better clarification

-- File Changes --

    M draft-ietf-quic-transport.md (70)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1802.patch
https://github.com/quicwg/base-drafts/pull/1802.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802

---

From: ianswett <[email-masked]>
Date: Wed, 26 Sep 2018 07:50:41 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802#pullrequestreview-159038016

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Sep 2018 14:44:56 -0700

martinthomson commented on this pull request.

> -       |                           |
-       | Send STREAM + FIN         |
-       v                           v
-   +-------+                   +-------+
-   | Data  | Send RST_STREAM   | Reset |
-   | Sent  |------------------>| Sent  |
-   +-------+                   +-------+
-       |                           |
-       | Recv All ACKs             | Recv ACK
-       v                           v
-   +-------+                   +-------+
-   | Data  |                   | Reset |
-   | Recvd |                   | Recvd |
-   +-------+                   +-------+
+   o
+   | Create Bidirectional Stream (Peer-initiated)

The decision we reached before was to make the same event trigger two transitions: one to create, one to move to "Send".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802#pullrequestreview-159211292

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 26 Sep 2018 17:48:09 -0700

@kazuho pushed 3 commits.

9a19840  Revert "better clarification"
43dd858  Revert "update the diagram accordingly"
fc0f3e6  initial state is always "Ready"

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802/files/cb87fd9a04e352eb515a462319484f87edd60858..fc0f3e6e538e3b8f4d6a002970ce4079f440322a

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 26 Sep 2018 17:48:43 -0700

kazuho commented on this pull request.

-       | Send STREAM + FIN         |
-       v                           v
-   +-------+                   +-------+

Thank you for pointing that out. Reverted the changes to the diagram and updated the text in fc0f3e6.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802#discussion_r220765843

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Sep 2018 11:01:15 -0700

@martinthomson pushed 1 commit.

24fd415  transitions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802/files/fc0f3e6e538e3b8f4d6a002970ce4079f440322a..24fd4151ff2b14a1db842f8e453add9e6f9204b5

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Sep 2018 11:01:21 -0700

Merged #1802 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1802#event-1871762163