Subject: [quicwg/base-drafts] Does DCID change after HelloRetryRequest? (#1757)

From: Mike Bishop <[email-masked]>
Date: Mon, 17 Sep 2018 19:09:22 +0000 (UTC)

When the client needs to send a subsequent Initial packet in response to the server's Initial packet (after HRR, containing ACKs, etc.), does it continue to use the same DCID as the first Initial packet, or does it update the DCID to the SCID from the server's Initial packet?

If the DCID changes, then load balancers cannot reliably identify which packets contain server-selected CIDs.  If the DCID does *not* change, then the Initial packet cannot be coalesced with Handshake packets due to the requirement that all packets in a datagram contain the same DCID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1757

---

From: Christian Huitema <[email-masked]>
Date: Thu, 20 Sep 2018 07:18:18 -0700

There is no such thing as a HelloRetryRequest in Quic. There are just some bits produced by the TLS component, telling QUIC to please send this over Initial or Handshakes packet. So the answer to the question is very simple: NO, the CID should not change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1757#issuecomment-423200560

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 16:18:34 -0700

Fixed in #1788.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1757#issuecomment-424156597

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 16:18:34 -0700

Closed #1757.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1757#event-1864403146