Subject: [quicwg/base-drafts] Connections ID's are not required to appear random (#1740)

From: MikkelFJ <[email-masked]>
Date: Wed, 12 Sep 2018 00:01:06 -0700

When sending a new connection ID it is understood that this is to prevent linkability, but it is not required that the actual ID is hard to correlate to previous ID's.

It may be tempting to use a random router prefix and a local counter in the ID.

If a client migrates the client can choose a strong new ID, but if the server responds with a weak ID in the opposite direction, that isn't very helpful. Since the client cannot influence that, servers could be coerced into using weak ID's for monitoring purposes without actually violating the protocol.

At the same time it is necessary to encode useful routing information and therefore the CID must be easy to decode.

In conclusion, at least some guidance is needed on how to construct connection ID's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740

---

From: Christian Huitema <[email-masked]>
Date: Wed, 12 Sep 2018 23:06:09 -0700

@mikkelfj you cannot win that particular battle. If the server collaborates with the tracker it can provide connection IDs that appear random but are in fact the encryption of the weak ID with a key known to the monitoring service. The best you can do is develop the argument and put it in the security considerations.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740#issuecomment-420894086

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Sep 2018 17:29:10 -0700

Happy to take a PR (if we don't have text on this, we should).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740#issuecomment-421193214

---

From: MikkelFJ <[email-masked]>
Date: Sun, 16 Sep 2018 00:08:42 -0700

Note that the PR mentions correlation across connections as well as paths.
I would have said that random CID is only required for TP `disable_migration`, but that does not address different connections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740#issuecomment-421713129

---

From: mirjak <[email-masked]>
Date: Tue, 18 Sep 2018 08:14:20 +0000 (UTC)

We also have an issue on this for the ops-drafts (29).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740#issuecomment-422298812

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Sep 2018 15:19:15 -0700

Closed #1740 via #1750.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1740#event-1864324000