Subject: Re: [quicwg/base-drafts] QPACK improvement: wrap absolute index values (#1644)

From: afrind <[email-masked]>
Date: Fri, 14 Sep 2018 16:29:20 +0000 (UTC)

I implemented the simplest form of the PR -- just encoding the LR value mod MaxEntries and reconstructing the value in the decoder.  It shows a 148 byte or .26% wire savings encoding a browser session with a few hundred requests.  It took ~20 lines of code in the encoder and decoder to make it work, including handling a new error case (encoded LR > MaxEntries * 2 + 1).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1644#issuecomment-421412920

---

From: afrind <[email-masked]>
Date: Thu, 27 Sep 2018 12:03:50 -0700

Discussed this at the NYC interim considering three outcomes:

1) Do nothing
2) Encode LR mod 2*MaxEntries
3) Redefine Absolute Indices to wrap at 2*MaxEntries

We took a hum to gauge consensus around doing something or doing nothing, and the room was split.

I'm planning to move forward with option 2.  Please review and comment on #1763.  Note that the concepts from option 3 are not precluded and I'd be ok including text describing an implementation that wrapped all absolute indexes internally.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1644#issuecomment-425207302

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 27 Sep 2018 12:22:06 -0700

> We took a hum to gauge consensus around doing something or doing nothing, and the room was split.

...with the [outcome that we do something](https://github.com/quicwg/wg-materials/blob/master/interim-18-09/minutes.md#qpack-index-wrapping---alan-frindell) -- option 2 or option 3 -- as interpreted by the chairs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1644#issuecomment-425212861