Subject: [quicwg/base-drafts] TLP is getting triggered too early (#1748)

From: DenisLug <[email-masked]>
Date: Sat, 15 Sep 2018 00:15:54 -0700

When the function `SetLossDetectionTimer()` has been implemented like shown [in the draft](https://tools.ietf.org/html/draft-ietf-quic-recovery-14#section-4.5.7.4) I get the problem that the `tlp_timeout` gets the default value of 10ms when sending the first paket, because the `UpdateRTT()` has not been invoked yet. This leads into sending of probe shortly after sending the first packet.

Does anyone has experienced the same behaviour? Would a non-zero initial value for the srtt be a solution for this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1748

---

From: Subodh Iyengar <[email-masked]>
Date: Sat, 15 Sep 2018 11:09:33 -0700

If update rtt hasn’t been invoked yet it seems like you would still have handshake packets outstanding right? Could you elaborate on the situation that triggers this behavior 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1748#issuecomment-421609575

---

From: ianswett <[email-masked]>
Date: Mon, 17 Sep 2018 07:25:22 -0700

Yes, the intent is that the handshake has to complete before TLP is active, and in order for it to complete, an RTT measurement must have been taken.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1748#issuecomment-422037437

---

From: DenisLug <[email-masked]>
Date: Fri, 21 Sep 2018 23:55:10 -0700

Thank you for your responses. In fact we had not considered the handshake packets before. Now the TLP is working without any problems.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1748#issuecomment-423722177

---

From: ianswett <[email-masked]>
Date: Thu, 27 Sep 2018 13:59:30 -0700

Closed #1748.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1748#event-1872132413