Subject: [quicwg/base-drafts] Build a version negotiation mechanism that mostly doesn't add round trips (#1773)

From: ekr <[email-masked]>
Date: Wed, 19 Sep 2018 17:01:49 +0000 (UTC)

In QUIC, version upgrade doesn't work w/o aditional RTs.

Consider the case where the client and server start out supporting version N. Then the client starts supporting N+1. If it offers N+1, then it's going to basically take an extra RT with every server, so it has to offer N, but then when the server upgrades to N+1, you have to take a RT to get to N+1. See #1755 for one such design

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1773

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Sep 2018 17:17:07 -0700

We discussed this in NYC and agreed as a WG that this is good in principle, but the PR needed a little more work.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1773#issuecomment-423701677