Subject: [quicwg/base-drafts] Optional packet length field in the short header? (#1831)

From: Lars Eggert <[email-masked]>
Date: Wed, 03 Oct 2018 23:05:00 -0700

I'm wondering if it would be useful to optionally allow SH packets to carry a packet length field, as LH packets do. This would allow SH packets to be coalesced behind SH packets, which might be useful?

We could burn a flag bit to indicate the presence of said packet length field, but before doing a more detailed design I'd like to understand if coalescing of SH packets behind SH packets is something that anyone cares about?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831

---

From: MikkelFJ <[email-masked]>
Date: Wed, 03 Oct 2018 23:30:30 -0700

If you do that, you should also consider it in the context of transports other than UDP. I.e. ensure that the context ID (there, I said it, it is not a connection ID) is sufficient over header less transports such as a RS232 bus.

As to coalescing just for the sake of coalescing, I think it will just complicate things. As soon as you have short headers, you can do all sorts of optimizations with packet delivery and processing, but if you must also deal with coalescing at this level, it complicates things, so there need to be a good reason for that.

I'm not sure why coalescing would be useful for its own sake, over a UDP transport.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-426900526

---

From: Nick Banks <[email-masked]>
Date: Thu, 04 Oct 2018 13:27:45 +0000 (UTC)

At least with my implementation, I don't see a need to coalesce SH packets. I fill each SH packet to the max of the UDP payload size and then move to the next packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-427018136

---

From: Brian Trammell <[email-masked]>
Date: Thu, 04 Oct 2018 07:57:26 -0700

I also don't see the point here; LH* SH? seems to be sufficient given the semantics of the two header types.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-427051263

---

From: MikkelFJ <[email-masked]>
Date: Thu, 04 Oct 2018 15:05:58 +0000 (UTC)

I do think it might be a good idea to reserve the bit for use cases such as non-UDP transport, but that is not to say that has to happen in V1, or ever over UDP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-427054455

---

From: ianswett <[email-masked]>
Date: Mon, 08 Oct 2018 14:25:20 +0000 (UTC)

I would prefer to not add a length, since I don't expect I'd ever use it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-427855421

---

From: Lars Eggert <[email-masked]>
Date: Wed, 10 Oct 2018 07:02:51 -0700

Thanks for the feedback

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#issuecomment-428584043

---

From: Lars Eggert <[email-masked]>
Date: Wed, 10 Oct 2018 07:02:51 -0700

Closed #1831.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1831#event-1895607331