Subject: [quicwg/base-drafts] Minor edits to amplification attack text (#1895)

From: martinduke <[email-masked]>
Date: Fri, 19 Oct 2018 15:45:28 -0700

I had a late review to PR #1824 because @ianswett had to get it into draft-15, and he encouraged me to file a PR. I believe he has no problem with at least one of these.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1895

-- Commit Summary --

  * Minor edits to amplification attack text

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1895.patch
https://github.com/quicwg/base-drafts/pull/1895.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895

---

From: ianswett <[email-masked]>
Date: Fri, 19 Oct 2018 16:34:41 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#pullrequestreview-166724682

---

From: Marten Seemann <[email-masked]>
Date: Fri, 19 Oct 2018 16:41:45 -0700

marten-seemann approved this pull request.

>  verified through an address validation token (delivered via a Retry packet or
-a NEW_TOKEN frame) or by processing any message from the client encrypted using
-the Handshake keys.  This limit exists to mitigate amplification attacks.
+a NEW_TOKEN frame), by processing any message from the client encrypted using
+the Handshake keys, or by processing a TLS client hello with a valid

s/client hello/ClientHello

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#pullrequestreview-166725474

---

From: martinduke <[email-masked]>
Date: Sat, 20 Oct 2018 21:54:40 -0700

@martinduke pushed 1 commit.

34c3ff7  Fixed Martin S. issue.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895/files/6ee3df8514b129a2aa5368939b22a09d0090a98f..34c3ff7d6ac993194a7766aeacb0f768bb07e006

---

From: Martin Thomson <[email-masked]>
Date: Sun, 21 Oct 2018 02:15:54 -0700

martinthomson requested changes on this pull request.

Remove that last clause please.

-a NEW_TOKEN frame) or by processing any message from the client encrypted using
-the Handshake keys.  This limit exists to mitigate amplification attacks.
+a NEW_TOKEN frame), by processing any message from the client encrypted using
+the Handshake keys, or by processing a TLS ClientHello with a valid
+pre-shared key.  This limit exists to mitigate amplification attacks.

This last is not sufficient for address validation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#pullrequestreview-166776923

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 18:31:15 -0700

martinthomson commented on this pull request.

That isn't right either.  Willingness to complete the handshake is a decision the server makes, and it does not need to be based on a test of the liveness of the remote address.

It's possible that TLS resumption (0-RTT or not) could bundle a token in the session ticket that allows for address validation, as we used to do.  But we no longer require that to happen.

A server can accept 0-RTT from an unvalidated client address.  The amount that you can send is limited, but it's not unreasonable.  The server doesn't need to send a certificate, so it can probably send some responses.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#discussion_r227617645

---

From: ianswett <[email-masked]>
Date: Tue, 23 Oct 2018 19:10:39 -0700

ianswett commented on this pull request.

Given this is in the validation section, why not remove this entire sentence?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#discussion_r227622516

---

From: ianswett <[email-masked]>
Date: Tue, 23 Oct 2018 19:12:04 -0700

> @@ -1194,13 +1194,14 @@ server then needs to validate that the client owns the address that it claims.
 QUIC therefore performs source address validation during connection
 establishment.
 
-Servers MUST NOT send more than three times as many bytes as the number of bytes
-received prior to verifying the client's address.  Source addresses can be
+Prior to verifying the client's address, servers MUST NOT send more than three

Q: Is this actually less awkward?  It's ok, but seems neutral to me.  Both sentences are a bit odd.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#pullrequestreview-167706365

---

From: martinduke <[email-masked]>
Date: Wed, 24 Oct 2018 14:36:04 -0700

martinduke commented on this pull request.

"prior to verifying the client's address" could be construed as modifying "bytes received". When I remove all context for what I know about this, that's how I read the sentence. A new reader would have to reason a bit to understand what you mean, IMO.

if you're neutral I'll stick with it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#discussion_r227968818

---

From: martinduke <[email-masked]>
Date: Wed, 24 Oct 2018 21:36:23 +0000 (UTC)

Ah, OK, it's my fundamental misunderstanding.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#discussion_r227968912

---

From: martinduke <[email-masked]>
Date: Wed, 24 Oct 2018 14:40:21 -0700

ed30d4f  Addressed Ian's issue

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895/files/34c3ff7d6ac993194a7766aeacb0f768bb07e006..ed30d4f1dcc428e7271a91d2655eeb966d7b56e2

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 17:06:28 -0700

I've gone and messed with this section considerably.  So this won't merge.  I can take the SHOULD>MUST change easily, and will do that directly if you agree.  The other changes seem to have been subsumed by the other changes, can you confirm that I haven't missed something important?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#pullrequestreview-168167617

---

From: martinduke <[email-masked]>
Date: Wed, 24 Oct 2018 19:59:21 -0700

@martinthomson Where is your redo?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#issuecomment-432897241

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 20:11:52 -0700

I think that it was #1888.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#issuecomment-432899312

---

From: martinduke <[email-masked]>
Date: Thu, 25 Oct 2018 09:30:37 -0700

@martinthomson You've covered the main points in the editor's draft. I'll close this one. I have one complaint, which I'll file a new PR for.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#issuecomment-433118936

---

From: martinduke <[email-masked]>
Date: Thu, 25 Oct 2018 09:30:39 -0700

Closed #1895.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#event-1926750055

---

From: Mike Bishop <[email-masked]>
Date: Mon, 29 Oct 2018 10:30:51 -0700

MikeBishop commented on this pull request.

I understand the old sentence, but the alternate reading risks confusion.  The resulting outcome is obviously nonsensical, so I hope no one would actually implement it, but better to be clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1895#discussion_r229023907