Subject: [quicwg/base-drafts] change the STREAM_ID_BLOCKED frame to encode stream 0 (#1851)

From: Marten Seemann <[email-masked]>
Date: Thu, 11 Oct 2018 06:21:04 -0700

Fixes #1850.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1851

-- Commit Summary --

  * change the STREAM_ID_BLOCKED frame to encode stream 0

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1851.patch
https://github.com/quicwg/base-drafts/pull/1851.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 11 Oct 2018 11:44:13 -0700

kazuho commented on this pull request.

> @@ -3254,8 +3254,8 @@ The STREAM_ID_BLOCKED frame contains a single field.
 
 Stream ID:
 
-: A variable-length integer indicating the highest stream ID that the sender
-  was permitted to open.
+: A variable-length integer indicating the stream ID of the stream that the
+  sender was not able to open due to the maximum stream ID limit.

To avoid ambiguity, would it make sense to clarify that the value is "the maximum stream ID among the streams that the sender is willing to open"?

Consider the case of a client that received from server a `initial_max_bidi_stream` of zero. If the client want to open two bidirectional streams (i.e. stream ID 0 and 4), should it send `STREAM_ID_BLOCKED` frame with stream ID of 0? My intent is to clarify that sending 4 in allowed such case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#pullrequestreview-163960401

---

From: Marten Seemann <[email-masked]>
Date: Thu, 11 Oct 2018 12:03:54 -0700

I’d argue that sending 4 in that case is not correct. Streams are opened sequentially, so you’re blocked on opening stream 0, not on opening stream 4.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-429080606

---

From: Mike Bishop <[email-masked]>
Date: Thu, 11 Oct 2018 12:14:43 -0700

The original reason for adding the Stream ID was to deduplicate and tell whether a frame was delayed or if the peer is still blocked.  Including that you'd like to open "up to" Stream 4 is actually more informative, since it tells the recipient that merely allowing a single additional stream doesn't unblock you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-429083850

---

From: Marten Seemann <[email-masked]>
Date: Thu, 11 Oct 2018 20:09:30 +0000 (UTC)

You’re right. This is how it should work. This goes beyond the intent of this PR, which was supposed to just fix an encoding issue. I’ll update it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-429100686

---

From: Marten Seemann <[email-masked]>
Date: Thu, 11 Oct 2018 13:48:43 -0700

@marten-seemann pushed 1 commit.

35bb9e3  use the maximum stream ID

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851/files/06f472683b5f3c966c3ea49e2447472e500ab8bf..35bb9e3e3ca53a41de467d4809ee32d8415dc8b1

---

From: Marten Seemann <[email-masked]>
Date: Thu, 11 Oct 2018 13:51:38 -0700

marten-seemann commented on this pull request.

 Stream ID:

Done. PHAL.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#discussion_r224600216

---

From: Martin Thomson <[email-masked]>
Date: Thu, 11 Oct 2018 14:41:29 -0700

>  Including that you'd like to open "up to" Stream 4 is actually more informative

Yes, but that creates a new manner in which this frame differs from the other frames.  If we make this change, then we need to be clearer about the semantics of this and the other `*_BLOCKED` frames.  Looking now, I'm not clear on whether STREAM_BLOCKED sends the current window, or the maximum offset that the sender wanted to send.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-429128691

---

From: Marten Seemann <[email-masked]>
Date: Mon, 15 Oct 2018 02:10:36 -0700

@martinthomson: Would it help if I deleted the last commit to move this PR forward?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-429766709

---

From: Martin Thomson <[email-masked]>
Date: Mon, 15 Oct 2018 15:02:26 -0700

> A variable-length integer indicating the maximum stream ID when the sender was unable to open a stream.

That makes it closer to the effective definition of the other limits.  Then we need to modify the others to match.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-430030089

---

From: ianswett <[email-masked]>
Date: Mon, 15 Oct 2018 18:48:44 -0700

ianswett commented on this pull request.

 Stream ID:
 
-: A variable-length integer indicating the highest stream ID that the sender
-  was permitted to open.
+: A variable-length integer indicating the maximum stream ID of the streams that

nit: I would remove "of the streams that" because I think it makes this sentence less clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#pullrequestreview-164957702

---

From: janaiyengar <[email-masked]>
Date: Tue, 30 Oct 2018 15:43:03 -0700

OBE. See #1906.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#issuecomment-434496532

---

From: janaiyengar <[email-masked]>
Date: Tue, 30 Oct 2018 22:43:05 +0000 (UTC)

Closed #1851.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1851#event-1936486085