Subject: [quicwg/base-drafts] When to ignore coalesced packets and when to terminate the connection (#1840)

From: Igor Lubashev <[email-masked]>
Date: Mon, 08 Oct 2018 09:06:36 -0700

[QUIC Transport "Coalescing Packets" section](https://tools.ietf.org/html/draft-ietf-quic-transport-15#section-4.9) states:

> If one or more packets in a datagram cannot be processed yet (because the keys are not yet
> available) or processing fails (decryption failure, unknown type, etc.), the receiver MUST still
> attempt to process the remaining packets.

The "etc" needs to be clarified.

There are many conditions under which the receiver MUST (or SHOULD or MAY) terminate the connection.  It is not clear when the requirement to terminate the connection trumps the requirement to attempt to process remaining packets and when it does not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1840

---

From: Mike Bishop <[email-masked]>
Date: Mon, 08 Oct 2018 18:34:16 +0000 (UTC)

My interpretation would be that fatal errors can only occur *while processing* a packet, which is to say that protection has been successfully removed and you're consuming frames out of the payload.  Errors that prevent you from doing any processing in the first place, however, should cause you to keep going to other packets.

In other words, for most purposes, handle the packets independently -- if they were in separate datagrams and one was garbage, you'd move to the next-received datagram.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1840#issuecomment-427936644

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 21:15:34 -0700

Closed as part of the reorg.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1840#issuecomment-432908863

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 04:15:34 +0000 (UTC)

Closed #1840.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1840#event-1925161896