Subject: [quicwg/base-drafts] No octets (#1921)

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 17:15:37 -0700

This will get rotty pretty quickly, but the changes are fairly easy to make mechanically for the most part.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1921

-- Commit Summary --

  * Use octets rather than bytes throughout
  * Use octets for units; size for packet sizes
  * Use bytes instead of octets throughout
  * Reflow

-- File Changes --

    M draft-ietf-quic-http.md (32)
    M draft-ietf-quic-invariants.md (28)
    M draft-ietf-quic-qpack.md (22)
    M draft-ietf-quic-recovery.md (103)
    M draft-ietf-quic-spin-exp.md (2)
    M draft-ietf-quic-tls.md (60)
    M draft-ietf-quic-transport.md (226)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1921.patch
https://github.com/quicwg/base-drafts/pull/1921.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921

---

From: MikkelFJ <[email-masked]>
Date: Fri, 26 Oct 2018 01:55:42 -0700

mikkelfj commented on this pull request.

> @@ -908,15 +907,15 @@ both the median and mean min_rtt typically observed on the public internet.
 
 # Congestion Control
 
-QUIC's congestion control is based on TCP NewReno {{?RFC6582}}.  NewReno is
-a congestion window based congestion control.  QUIC specifies the congestion
+QUIC's congestion control is based on TCP NewReno {{?RFC6582}}.  NewReno is a
+congestion window based congestion control.  QUIC specifies the congestion

congestion control algorithm?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#pullrequestreview-168728672

---

From: MikkelFJ <[email-masked]>
Date: Fri, 26 Oct 2018 09:07:25 +0000 (UTC)

> @@ -965,8 +964,8 @@ losses or increases in the ECN-CE counter.
 ## Tail Loss Probe
 
 A TLP packet MUST NOT be blocked by the sender's congestion controller. The
-sender MUST however count these bytes as additional bytes-in-flight, since a TLP
-adds network load without establishing packet loss.
+sender MUST however count TLP packets against bytes-in-flight, since a TLP adds

inconsistent use of bytes-in-flight vs bytes_in_flight - technically one might be for text the other for pseudo code.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#pullrequestreview-168731910

---

From: ianswett <[email-masked]>
Date: Fri, 26 Oct 2018 06:20:46 -0700

ianswett approved this pull request.

Thanks Martin, this looks great.

> @@ -443,8 +442,8 @@ sent as a probe into the network prior to establishing any packet loss, prior
 unacknowledged packets SHOULD NOT be marked as lost.
 
 A packet sent on an RTO timer MUST NOT be blocked by the sender's congestion
-controller. A sender MUST however count these bytes as additional bytes in
-flight, since this packet adds network load without establishing packet loss.
+controller. A sender MUST however count these bytes as being in flight, since

```suggestion
controller. A sender MUST however count these packets as being in flight, since
```

> @@ -618,9 +617,9 @@ sent_packets:
 : An association of packet numbers to information about them, including a number
   field indicating the packet number, a time field indicating the time a packet
   was sent, a boolean indicating whether the packet is ack-only, a boolean
-  indicating whether it counts towards bytes in flight, and a bytes
-  field indicating the packet's size.  sent_packets is ordered by packet number,
-  and packets remain in sent_packets until acknowledged or lost.  A sent_packets
+  indicating whether it counts towards bytes in flight, and a size field that
+  indicates the packet's size.  sent_packets is ordered by packet number, and

```suggestion
  indicates the packet's size in bytes.  sent_packets is ordered by packet number, and
```

 ## Tail Loss Probe

Good point, how about we remove the - here, because it's spelled "bytes in flight" everywhere else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#pullrequestreview-168816001

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:27:14 -0700

@martinthomson pushed 1 commit.

38d9628  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921/files/a3efac0fd8064c6b67cf20464563dc86fc6c46fa..38d96287b35d012da67be362c751fef27e8929aa

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:27:21 -0700

0f88ed8  clarify

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921/files/38d96287b35d012da67be362c751fef27e8929aa..0f88ed8881384debb293150c7e72667ae10eb53a

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 23:27:54 +0000 (UTC)

martinthomson commented on this pull request.

 ## Tail Loss Probe

```suggestion
sender MUST however count TLP packets against bytes in flight, since a TLP adds
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#pullrequestreview-169115687

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:28:12 -0700

dcab276  unhypenate - the name of my new startup

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921/files/0f88ed8881384debb293150c7e72667ae10eb53a..dcab27610349c604d6339f0cab88306ee1de6ea4

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:50:54 -0700

Merged manually.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#issuecomment-433754080

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:50:54 -0700

Closed #1921.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1921#event-1931041883