Subject: [quicwg/base-drafts] Use octets rather than bytes throughout (#1912)

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 21:08:23 -0700

I have a feeling that Ian isn't going to like this because it messes with the notion of "bytes in flight" that we use in -recovery.  I would prefer to be consistent though.  For the transport, "bytes in flight" only appeared once, but its use wasn't critical.

Also closes #1863.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1912

-- Commit Summary --

  * Use octets rather than bytes throughout

-- File Changes --

    M draft-ietf-quic-transport.md (49)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1912.patch
https://github.com/quicwg/base-drafts/pull/1912.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912

---

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 21:14:12 -0700

@martinthomson pushed 1 commit.

92c7dca  Use octets for units; size for packet sizes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912/files/8526309cac0a845600cb84495ee0545f11f4721d..92c7dcaa0632da455c74aea7b506775440e15220

---

From: MikkelFJ <[email-masked]>
Date: Wed, 24 Oct 2018 22:07:43 -0700

mikkelfj commented on this pull request.

> @@ -618,8 +617,8 @@ sent_packets:
 : An association of packet numbers to information about them, including a number
   field indicating the packet number, a time field indicating the time a packet
   was sent, a boolean indicating whether the packet is ack-only, a boolean
-  indicating whether it counts towards bytes in flight, and a bytes
-  field indicating the packet's size.  sent_packets is ordered by packet number,
+  indicating whether it counts towards bytes in flight, and a size field

It says bytes in flight

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#pullrequestreview-168209821

---

From: ianswett <[email-masked]>
Date: Thu, 25 Oct 2018 06:32:08 -0700

Q: Why not standardize on bytes?  All the TCP RFCs use byte, and the word octet does not occur in any TCP RFCs I can find.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433052205

---

From: Nick Banks <[email-masked]>
Date: Thu, 25 Oct 2018 13:34:13 +0000 (UTC)

I would also prefer `bytes` over `octets`, if we are taking a vote.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433052962

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 25 Oct 2018 06:38:50 -0700

I vote for **bytes**.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433054523

---

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 07:10:39 -0700

bytes are not quantifiable. They could be 6-bit (as if I care).

Why not also little endian now we are at it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433066459

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 22:30:36 +0000 (UTC)

Right now, we're inconsistent.  I don't believe that there is any problem along the lines @mikkelfj describes with using bytes - that ship sailed a long time ago - but HTTP/2 went with octets and we've been inconsistent.  I can easily do a search and replace in the other direction; and I don't personally care.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433227222

---

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 15:35:02 -0700

then bytes it is - I have never heard of bandwidth measured in MOps

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433228194

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 17:21:54 -0700

See #1921.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-433247393

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 17:21:56 -0700

Closed #1912.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#event-1927652185

---

From: Mike Bishop <[email-masked]>
Date: Mon, 29 Oct 2018 11:04:56 -0700

@mikkelfj, see [here](https://www.sospc2424.ch/site/images/web4glossary/image_vignette2/Unite_mesure_Conversion-5557698e4fa77.jpg), for example.  Capacities are described in Go, Mo, etc. in French.  Bandwidth is usually still in bits, though.

Bytes have historically varied in size, as large as 64 bits.  The C and C++ standards define a byte as being **at least** eight bits in size.  (See their FAQ [here](https://isocpp.org/wiki/faq/intrinsic-types#very-large-bytes).)  I'm very much in favor of retaining octets, because that's not a platform-specific term.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-434015497

---

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Oct 2018 18:14:07 +0000 (UTC)

@MikeBishop yeah - I discovered the french connection subsequently but more often MOps means mega outputs pers second or mega operations per second or similar.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-434018907

---

From: MikkelFJ <[email-masked]>
Date: Mon, 29 Oct 2018 11:28:15 -0700

The french also invented the decimal system. For a short while they also had decimal time. Wonder why it never took off...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1912#issuecomment-434024810