Subject: [quicwg/base-drafts] Permitted frame types (#1880)

From: Rui Paulo <[email-masked]>
Date: Wed, 17 Oct 2018 18:52:58 -0700

In section 9.2.3:

>The sender of a stream sends just three frame types that affect the state of a stream at either sender or receiver: STREAM (Section 7.20), STREAM_BLOCKED (Section 7.11), and RST_STREAM (Section 7.3).

However, MAX_STREAM_DATA can also affect the state of the stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1880

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 17 Oct 2018 20:38:13 -0700

I think the text is correct because the subject here is "the sender of a stream."

MAX_STREAM_DATA is sent by "the receiver of a stream," which is discussed later in the section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1880#issuecomment-430864647

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Oct 2018 09:19:35 -0700

Closed #1880.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1880#event-1912725984

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Oct 2018 09:19:32 -0700

Yep.

> The receiver of a stream sends MAX_STREAM_DATA (Section 7.7) and STOP_SENDING frames (Section 7.14).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1880#issuecomment-431072214