Subject: [quicwg/base-drafts] Sequence for Connection IDs, RETIRE (#1829)

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 17:17:48 -0700

Suggestions for your PR, as discussed.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1829

-- Commit Summary --

  * Connection ID changes

-- File Changes --

    M draft-ietf-quic-transport.md (58)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1829.patch
https://github.com/quicwg/base-drafts/pull/1829.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829

---

From: ianswett <[email-masked]>
Date: Tue, 02 Oct 2018 19:23:21 -0700

ianswett approved this pull request.

> @@ -1249,8 +1252,11 @@ using the NEW_CONNECTION_ID frame ({{frame-new-connection-id}}).
 ### Issuing Connection IDs
 
 The initial connection ID issued by an endpoint is the Source Connection ID
-during the handshake.  Subsequent connection IDs are communicated to the peer
-using NEW_CONNECTION_ID frames ({{frame-new-connection-id}}).
+during the handshake.  The sequence number of the initial connection ID is 0. If

Q: Is it really necessary to allocate IDs to connection IDs during the handshake?  To me, it makes more sense to only allocate IDs to those that are post-handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#pullrequestreview-160976656

---

From: MikkelFJ <[email-masked]>
Date: Wed, 03 Oct 2018 00:27:37 -0700

mikkelfj commented on this pull request.

That would result in complications with non-unique 5-tuples if I understand you correctly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222208084

---

From: ianswett <[email-masked]>
Date: Wed, 03 Oct 2018 06:08:24 -0700

ianswett commented on this pull request.

I was thinking that the handshake connection IDs exist, but they don't need an identifier?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222301195

---

From: MikkelFJ <[email-masked]>
Date: Wed, 03 Oct 2018 06:18:13 -0700

Ah, the id of the id, that is different.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222304456

---

From: Mike Bishop <[email-masked]>
Date: Wed, 03 Oct 2018 19:03:27 +0000 (UTC)

MikeBishop commented on this pull request.

We can avoid that if the entire CID is sent in the RETIRE_CID frame.  That would mean, instead, that issuers need to stop using the contained CID for the current connection iff they are and absorb duplicates by silently consuming RETIRE messages for CIDs which aren't associated with the connection.

By having the sequence number in the RETIRE_CID frame, we make it shorter (one varint) and enable using the same deduplicating code as the consumer of NEW_CID messages.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222430109

---

From: janaiyengar <[email-masked]>
Date: Wed, 03 Oct 2018 12:18:55 -0700

janaiyengar commented on this pull request.

I like the use of seq num here. It does serve the dedup purpose, and is easier on implementations as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222435113

---

From: janaiyengar <[email-masked]>
Date: Wed, 03 Oct 2018 12:20:11 -0700

The initial connection ID issued by an endpoint is the Source Connection ID
-during the handshake.  Subsequent connection IDs are communicated to the peer
-using NEW_CONNECTION_ID frames ({{frame-new-connection-id}}).
+during the handshake.  The sequence number of the initial connection ID is 0. If
+the preferred_address transport parameter is sent, the sequence number of the
+supplied connection ID is 1. Subsequent connection IDs are communicated to the
+peer using NEW_CONNECTION_ID frames ({{frame-new-connection-id}}), and the
+sequence number on each newly-issued connection ID MUST increase by 1.

I think this should say something about CIDs on Retry (that they don't really count).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#pullrequestreview-161321508

---

From: janaiyengar <[email-masked]>
Date: Wed, 03 Oct 2018 12:24:26 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#pullrequestreview-161323102

---

From: ianswett <[email-masked]>
Date: Wed, 03 Oct 2018 19:24:30 +0000 (UTC)

So these are given numbers so they can be retired?  If so, that makes sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#discussion_r222436930

---

From: Mike Bishop <[email-masked]>
Date: Wed, 03 Oct 2018 13:27:20 -0700

@MikeBishop pushed 1 commit.

23c93d1  Discuss pre-handshake CIDs

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829/files/f6382a6759471aaaf13088ba2a364e6f29ac733f..23c93d142fd117fec3bba4ea661a4bda23bfcde4

---

From: Mike Bishop <[email-masked]>
Date: Wed, 03 Oct 2018 13:39:31 -0700

aa94c8b  not contains

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829/files/23c93d142fd117fec3bba4ea661a4bda23bfcde4..aa94c8bbe2b199b319460500d3e1482b792db2b1

---

From: janaiyengar <[email-masked]>
Date: Wed, 03 Oct 2018 14:01:33 -0700

Merged #1829 into ncid.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1829#event-1883036895