Subject: [quicwg/base-drafts] ACK-only feedback loop in recovery instead of transport (#1860)

From: Robin Marx <[email-masked]>
Date: Tue, 16 Oct 2018 05:29:15 -0700

Currently, it's the transport draft that mentions ACK-sending behaviour for ACK-only packets:

> Implementations MUST NOT generate packets that only contain ACK
   frames in response to packets which only contain ACK and PADDING
   frames.

and

> To avoid creating an indefinite
   feedback loop, an endpoint MUST NOT send an ACK frame in response to
   a packet containing only ACK or PADDING frames, even if there are
   packet gaps which precede the received packet.

and

> Because ACK frames are not sent in response to ACK-only packets, a
   receiver that is only sending ACK frames will only receive
   acknowledgements for its packets if the sender includes them in
   packets with non-ACK frames.  A sender SHOULD bundle ACK frames with
   other frames when possible.

This feels like it should be moved or at least mentioned again in the recovery document (e.g., in the current [4.4 Generating Acknowledgements](https://tools.ietf.org/html/draft-ietf-quic-recovery-15#section-4.4)). 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1860

---

From: ianswett <[email-masked]>
Date: Thu, 18 Oct 2018 08:40:03 -0700

Agreed.  We have a few things which are mostly duplicates between recovery and transport, which is unfortunate, but I think ends up being helpful in cases like this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1860#issuecomment-431058150

---

From: ianswett <[email-masked]>
Date: Tue, 30 Oct 2018 18:55:44 -0700

I'm not sure what the right answer is here, but I'm assigning this to Jana, since he's an editor on both docs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1860#issuecomment-434533562