Subject: [quicwg/base-drafts] BLOCKED frames and potential deadlocks (#1867)

From: ianswett <[email-masked]>
Date: Wed, 17 Oct 2018 08:13:24 -0700

I believe there are a few potential issues with the BLOCKED frame text.
 1) STREAM_ID_BLOCKED is a MAY, but the other two BLOCKED frames are a SHOULD.  I suggest changing STREAM_ID_BLOCKED to a SHOULD for consistency.  https://tools.ietf.org/html/draft-ietf-quic-transport-15#section-7.12
 2) There's discussion of STREAM_BLOCKED and BLOCKED in the "Blocking on Flow Control" section, but no mention of STREAM_ID_BLOCKED in "Stream Limit Increment" https://tools.ietf.org/html/draft-ietf-quic-transport-15#section-10.2  I think there should be, even if it's just the next suggestoin.
 3) In 10.2.1, "A receiver SHOULD NOT wait for a BLOCKED or STREAM_BLOCKED frame before sending MAX_DATA or MAX_STREAM_DATA, since doing so will mean that a sender is unable to send for an entire round trip." - Unless we're going to change sending BLOCKED to a MUST, I believe this needs to be a MUST NOT, and we should explain that it's because the receiver is not guaranteed to receive a BLOCKED frame.  I believe it'd be worth adding similar text to the "Stream Limit Increment" section.
4) It would be nice to add some more guidance on when to send MAX_STREAM_ID if we think we can provide it.  This sentence: "A receiver MAY also advance the maximum stream ID based on current activity, system conditions, and other environmental factors." doesn't seem very helpful to me.

I'd fix these myself, but the transport doc is being heavily restructured.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1867

---

From: Martin Thomson <[email-masked]>
Date: Mon, 22 Oct 2018 22:10:52 -0700

Closed #1867 via #1897.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1867#event-1919291005