Subject: [quicwg/base-drafts] Heartbeats (#1876)

From: Demi Marie Obenour <[email-masked]>
Date: Wed, 17 Oct 2018 15:09:31 -0700

QUIC should periodically send packets through the channel, even if no data is being transferred.  This ensures that NATs keep the channel open, and allows dead peers to be recognized.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1876

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Oct 2018 16:50:46 -0700

PING packets exist to provide this functionality, though when/whether to use them is implementation-dependent, with guidance from the application layer.  The HTTP mapping [already recommends when to do this](https://quicwg.org/base-drafts/draft-ietf-quic-http.html#idle-connections).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1876#issuecomment-430828135

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Oct 2018 16:50:50 -0700

Closed #1876.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1876#event-1910947450