Subject: [quicwg/base-drafts] Don't amplify accidentally when closing (#1911)

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 04:03:32 +0000 (UTC)

A minor point, and we might not even regret this, but it's not worth
risking it.

Closes #1905.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1911

-- Commit Summary --

  * Don't amplify accidentally when closing

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1911.patch
https://github.com/quicwg/base-drafts/pull/1911.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911

---

From: Marten Seemann <[email-masked]>
Date: Wed, 24 Oct 2018 21:15:42 -0700

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911#pullrequestreview-168203441

---

From: ianswett <[email-masked]>
Date: Thu, 25 Oct 2018 07:05:05 -0700

ianswett commented on this pull request.

> @@ -2228,6 +2228,12 @@ Note:
   control, which are not expected to be relevant for a closed connection.
   Retransmitting the final packet requires less state.
 
+New packets from unverified addresses could be used to create an amplification
+attack (see {{address-validation}}).  To avoid this, endpoints MUST either limit
+transmission of closing frames to validated addresses - which implies retaining

I'd remove the "- which implies retraining knowledge of validated addresses -" because it makes the sentence a bit awkward and I think it's unnecessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911#pullrequestreview-168399181

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 22:28:14 +0000 (UTC)

@martinthomson pushed 1 commit.

e06269b  Always like removing text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911/files/7a9e8e45aaf92da9f4c543300136459252347085..e06269b6caf4b685156b1b5dda65dcf8d9f8a857

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 16:36:44 -0700

3ef0fab  redundant word whack-a-mole

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911/files/e06269b6caf4b685156b1b5dda65dcf8d9f8a857..3ef0fab462ed64b69e4680b6751cd9f29ae7fb9b

---

From: ianswett <[email-masked]>
Date: Fri, 26 Oct 2018 19:24:15 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911#pullrequestreview-168967339

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:55:51 -0700

Merged #1911 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1911#event-1931044211