Subject: [quicwg/base-drafts] Section 4.2.6 PUSH_PROMISE does not indicate on which stream type this frame is allowed (#1920)

From: macoxms <[email-masked]>
Date: Thu, 25 Oct 2018 15:01:54 -0700

All other frame types in section 4 explicitly call out which stream types are allowed.

For example DATA:

  If a DATA frame is received on either control stream, the recipient MUST
  respond with a connection error (Section 8) of type
  HTTP_WRONG_STREAM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1920

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 29 Oct 2018 05:54:06 -0700

FWIW this is explained in section 5.

> The header of the request message is carried by a PUSH_PROMISE frame (see Section 4.2.6) on the request stream which generated the push.

But I agree that conistency in the frame descriptions could help.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1920#issuecomment-433898812