Subject: [quicwg/base-drafts] Limiting the number of active connection ids (#1924)

From: plakhera <[email-masked]>
Date: Sat, 27 Oct 2018 09:37:34 -0700

It looks like the spec should provide some more guidelines around connection ID management by endpoints.

In summary, an endpoint should have mechanism in place to avoid allocating excessive resources if the  remote endpoint ends up sending too many NEW_CONNECTION_ID frames without necessarily retiring the old ones.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1924

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:58:28 -0700

This was discussed at some length by the working group and we decided not to add any mechanisms to limit the number of connection IDs.

The protection mechanisms we rely on are that a recipient isn't obligated to remember *or retire* connection IDs if it doesn't intend to use them.  That limits the costs of too many connection IDs to the bandwidth cost (which can be wasted in many other ways anyway).

Note that you seem to have misunderstood the function of RETIRE_CONNECTION_ID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1924#issuecomment-433754635

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:58:28 -0700

Closed #1924.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1924#event-1931045302

---

From: plakhera <[email-masked]>
Date: Sun, 28 Oct 2018 18:24:40 -0700

Aah, I see it better now after getting corrected! Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1924#issuecomment-433761960