Subject: [quicwg/base-drafts] ECN counters and Coalescing of QUIC packets (#1838)

From: Magnus Westerlund <[email-masked]>
Date: Sun, 07 Oct 2018 03:02:51 -0700

I realize there exist a need to clarify the text regarding ECN on the relation between IP packets and QUIC packets. As QUIC tracks QUIC packets, and not IP packets, this relation when coaleing occurs needs to be clarified. What I think is needed are:
- In Section 6.8: Using Explicit Congestion Notification should be updated to be explicit about when it talks about IP packet and when about QUIC packets. 
- State explicitly that for coalesed QUIC packets, the IP packet's ECN field value is reported for each QUIC packet. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Oct 2018 15:51:33 -0700

Sounds good.  I'm sure that we'd appreciate getting a PR for this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838#issuecomment-430428636

---

From: Magnus Westerlund <[email-masked]>
Date: Wed, 17 Oct 2018 02:39:11 -0700

So how do we deal with the different packet number spaces here. I see two options:
Either say that we totally ignore Initial packets in the perspective of ECN handling. Which basically delays the ECN verification until one sees ACKs for the 0- or 1-RTT packets. Or one requires one set of counters per packet number space. What are peoples preference here? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838#issuecomment-430561057

---

From: Martin Thomson <[email-masked]>
Date: Wed, 17 Oct 2018 02:48:45 -0700

I'm thinking that you count separately, in the interests of keeping ACK accounting separate (and consistent).  But no special handling, or disabling ECN for different phases.  You can still use Initial/Handshake to verify that the path supports ECN.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838#issuecomment-430564126

---

From: ianswett <[email-masked]>
Date: Wed, 17 Oct 2018 06:08:26 -0700

Agreed, each PN space has its own set of counters, and an ACK frame sent in a PN space conveys the counters of that PN space.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838#issuecomment-430620889

---

From: Martin Thomson <[email-masked]>
Date: Mon, 29 Oct 2018 01:54:14 -0700

Closed #1838 via #1913.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1838#event-1931605055