Subject: [quicwg/base-drafts] Section 4.2.17 references HTTP_UNEXPECTED_GOAWAY which doesn't exist (#1918)

From: macoxms <[email-masked]>
Date: Thu, 25 Oct 2018 14:39:18 -0700

HTTP_UNEXPECTED_GOAWAY is referenced in section 4.2.17 as the connection error to generate when getting an unexpected goaway, but this is not defined in section 8.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918

---

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 14:43:38 -0700

otherwise it wouldn't be unexpected

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918#issuecomment-433215946

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Oct 2018 16:06:08 -0700

Fixed in #1910.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918#issuecomment-433234459

---

From: Luca Niccolini <[email-masked]>
Date: Sat, 27 Oct 2018 11:44:33 -0700

@martinthomson, was it really fixed ? 
can't find anything related to GOAWAY in #1910 commits

and the draft editor's copy still has the undefined reference

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918#issuecomment-433645426

---

From: Luca Niccolini <[email-masked]>
Date: Sat, 27 Oct 2018 12:22:26 -0700

similar to how GOAWAY is not allowed from client to server, MAX_PUSH_ID is not allowed from server to client. 
should we use and define UNEXPECTED_MAX_PUSH_ID in the same way ? 

current text:
> A client MUST treat the receipt of a MAX_PUSH_ID frame as a connection error of type HTTP_MALFORMED_FRAME

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918#issuecomment-433648181

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:59:40 -0700

My bad, I assumed it was a bad section reference.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1918#issuecomment-433754716