Subject: [quicwg/base-drafts] HTTP: State that an empty SETTINGS frame is legal (#1832)

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 04 Oct 2018 14:20:31 -0700

[draft-ietf-quic-http-15](https://tools.ietf.org/html/draft-ietf-quic-http-15#section-4.2.6) states:

```
   A SETTINGS frame MUST be sent as the first frame of either control
   stream (see Section 3) by each peer [...]
```

Because both HTTP settings have default values, one should be able to send an empty _SETTINGS_ frame to indicate that the defaults are used.  Nevertheless, this is not specified in the draft.  I think it should be.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1832

---

From: Mike Bishop <[email-masked]>
Date: Thu, 04 Oct 2018 14:35:39 -0700

A reasonable clarification.  I don't think anything currently *prohibits* a SETTINGS frame from being empty, but we should explicitly state that it contains zero or more values.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1832#issuecomment-427177652

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 04 Oct 2018 18:54:15 -0700

Closed #1832.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1832#event-1886082677

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 04 Oct 2018 18:54:18 -0700

Upon closer reading, I discovered this:

```
   The payload of a SETTINGS frame consists of zero or more parameters,
```

Closing the issue: invalid.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1832#issuecomment-427222686