Subject: [quicwg/base-drafts] Specify the packets that carry closing frames (#1890)

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Oct 2018 22:09:34 -0700

I decided to reword #1818 after reading it.

I think that the second piece to #1786 , which was to make allowances for
fatal errors arising from Initial packets won't be necessary.  I'm happy
to see a PR, of course, but the sentiment I've heard expressed is that
it is very hard to manage this, and the spec wouldn't expressly prevent
someone from trying to build a system that was resilient to
maliciously-crafted Initial packets, but we wouldn't take steps in this
document to deal with that.  As previously agreed, if you are attacked
and the attacker was able to modify Initial packets, then they can deny
you the ability to connect.

Closes #1818, #1786.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1890

-- Commit Summary --

  * I decided to reword this after reading it.  It missed a few key things.

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1890.patch
https://github.com/quicwg/base-drafts/pull/1890.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890

---

From: martinduke <[email-masked]>
Date: Fri, 19 Oct 2018 15:56:05 -0700

martinduke commented on this pull request.

> @@ -2302,6 +2302,12 @@ the application requests that the connection be closed.  The application
 protocol can use an APPLICATION_CLOSE message with an appropriate error code to
 signal closure.
 
+If the endpoint believes that a connection has been successfully established, it

I find this condition a little vague for a MUST. How about "has received a short header from the peer"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890#pullrequestreview-166719402

---

From: ianswett <[email-masked]>
Date: Mon, 22 Oct 2018 18:46:29 -0700

ianswett commented on this pull request.

> @@ -2313,6 +2304,13 @@ the application requests that the connection be closed.  The application
 
+If the connection has been successfully established, endpoints MUST send any
+closing frames in a 1-RTT packet.  Prior to connection establishment, endpoints
+SHOULD send closing frames in a Handshake packet.  An endpoint MAY send closing

Does this need a caveat like "...SHOULD send closing frames in a Handshake packet if possible."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890#pullrequestreview-167178417

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:39:16 -0700

@martinthomson pushed 2 commits.

86445c9  Ian's suggestion
6742d4f  Merge branch 'master' into how-to-protect-close

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890/files/8c2aaa3650e5cd214df3171c9b94b3aa4d4f2f2b..6742d4fce98eb81fc6b9913b5a9992af0e236e2d

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:44:00 -0700

martinthomson commented on this pull request.

> @@ -2251,6 +2242,13 @@ the application requests that the connection be closed.  The application
 
+If the connection has been successfully established, endpoints MUST send any
+closing frames in a 1-RTT packet.  Prior to connection establishment, endpoints
+SHOULD send closing frames in a Handshake packet if possible.  An endpoint MAY
+send closing frames in an Initial packet.  Closing frames might be replicated
+into packets at different encryption levels, which can then be coalesced (see
+{{packet-coalesce}} to facilitate retransmission.

```suggestion
{{packet-coalesce}}) to facilitate retransmission.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890#pullrequestreview-167682003

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:44:46 -0700

@martinthomson pushed 1 commit.

a5b112c  missing paren

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890/files/6742d4fce98eb81fc6b9913b5a9992af0e236e2d..a5b112c8438042e99e74f9ce4f1f2ae7b3bcda7c

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:50:23 -0700

0169c89  reword

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890/files/d513b05d9f3efb1442fae4e9ab0476fc9cdeaec7..0169c8952a2f2e998e57ed8c98edcab7c726abe7

---

From: janaiyengar <[email-masked]>
Date: Tue, 23 Oct 2018 16:50:41 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890#pullrequestreview-167683408

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:50:41 -0700

Merged #1890 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1890#event-1922026055