Subject: [quicwg/base-drafts] Changelog for -15 (#1825)

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 11:43:21 -0700

Starting with contents of #1815.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1825

-- Commit Summary --

  * transport: Initialize a changelog for draft-15

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1825.patch
https://github.com/quicwg/base-drafts/pull/1825.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825

---

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 11:46:18 -0700

@MikeBishop pushed 1 commit.

e3c5f82  Line wrapping

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825/files/44f8a01dfbde8bbadeafa2f80b7827f1e35db15b..e3c5f82ad0ba9fb5751e364724807d38afda37ff

---

From: Nick Banks <[email-masked]>
Date: Tue, 02 Oct 2018 18:48:48 +0000 (UTC)

nibanks commented on this pull request.

> @@ -5248,6 +5248,13 @@ DecodePacketNumber(largest_pn, truncated_pn, pn_nbits):
 
 Issue and pull request numbers are listed with a leading octothorp.
 
+## Since draft-ietf-quic-transport-14
+- Merge ACK and ACK_ECN (#1801)
+- Add 2 transport parameters: max_ack_delay(12) and original_connection_id(13)
+  (#981, #1710, #1486)
+- Remove sequence field from NEW_CONNECTION_ID (#1742)
+- Add RETIRE_CONNECTION_ID type (#1742)

Idle timeout TP was made optional, and the max limit on the value was removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825#pullrequestreview-160870090

---

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 19:01:43 +0000 (UTC)

3e9158c  HTTP changelog

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825/files/e7251cbcac2e078eff50cfffdca049fb0b40985b..3e9158cc490d8c7f3e3dfb13de6a98dc613cad3a

---

From: ianswett <[email-masked]>
Date: Tue, 02 Oct 2018 19:23:38 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825#pullrequestreview-160883939

---

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 12:33:11 -0700

98e26a2  More detail on TP changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825/files/3e9158cc490d8c7f3e3dfb13de6a98dc613cad3a..98e26a2efdb355bca4e9593fc7f080f10c04f98f

---

From: Nick Banks <[email-masked]>
Date: Tue, 02 Oct 2018 12:46:50 -0700

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825#pullrequestreview-160892725

---

From: afrind <[email-masked]>
Date: Tue, 02 Oct 2018 14:12:29 -0700

@afrind pushed 1 commit.

509e6ba  QPACK changelog

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825/files/98e26a2efdb355bca4e9593fc7f080f10c04f98f..509e6ba817327062b7aa2413ed51f9133a554873

---

From: ianswett <[email-masked]>
Date: Tue, 02 Oct 2018 14:45:15 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825#pullrequestreview-160936792

---

From: Mike Bishop <[email-masked]>
Date: Tue, 02 Oct 2018 22:55:52 +0000 (UTC)

Merged #1825 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1825#event-1880621416