Subject: [quicwg/base-drafts] WIP: HTTP Doc Reorganization (#1837)

From: Mike Bishop <[email-masked]>
Date: Fri, 05 Oct 2018 10:40:41 -0700

Per discussion post-interim, rearranges document to a similar format as RFC7540:

- Intro
- Connection Setup & Maintenance
- Streams
- Frames
- HTTP Requests
- Closure
- Extensions
- Error Handling
- Appendix:  H2 Considerations

At this point, it's mostly unaltered text landing in different sections; if you see dangling text or ordering that no longer makes sense, feel free to point it out and I'll clean it up as I go.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1837

-- Commit Summary --

  * Move content into a Request Lifecycle section
  * Move Extensions before Error Handling
  * Move H2 Considerations to an appendix

-- File Changes --

    M draft-ietf-quic-http.md (1163)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1837.patch
https://github.com/quicwg/base-drafts/pull/1837.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837

---

From: Mike Bishop <[email-masked]>
Date: Thu, 11 Oct 2018 16:17:46 -0700

@MikeBishop pushed 12 commits.

6305be8  Expand introduction, discuss relationship with HTTP and TCP
d755aac  Fix reserved version example
3fadd85  Narrow restriction on server sending before SETTINGS
971da60  Better discussion of QUIC streams
f3f5acc  Fix references, reorder unidirectional stream section
aefe5a4  General framing layer fixups
a8036b2  PRIORITY fixups; fixes #1848
15d51bb  CANCEL_PUSH fixups
9e863ab  SETTINGS fixups
de88400  Import definition of MAX_HEADER_LIST_SIZE
ce52c50  PUSH_PROMISE fixups
78de8d6  MAX_PUSH_ID fixup

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837/files/9bd4e44f9e6d7b2d0b598ffa34df3735418f111e..78de8d628b0d51145214dd5b1426b6f865e78904

---

From: Mike Bishop <[email-masked]>
Date: Fri, 12 Oct 2018 10:54:19 -0700

@MikeBishop pushed 6 commits.

5be7761  Headers and message formatting fixups
ec75492  Cancellation and CONNECT fixups
d9ae519  Tighten some redundancies
c353495  Explicitly mention error upgrades
f23e01b  Generalize varint text in Security Considerations
febb274  Keep H2 Considerations up-to-date

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837/files/78de8d628b0d51145214dd5b1426b6f865e78904..febb274725311d6b41f8880c250aabd7fe06e6c3

---

From: Mike Bishop <[email-masked]>
Date: Fri, 12 Oct 2018 10:56:03 -0700

@MikeBishop pushed 1 commit.

f7e9118  has incorporates

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837/files/febb274725311d6b41f8880c250aabd7fe06e6c3..f7e9118a3c97b0d1e523ac65af82b13c697ffe5a

---

From: Mike Bishop <[email-masked]>
Date: Fri, 12 Oct 2018 18:02:04 +0000 (UTC)

b2d119e  Use a/the consistently

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837/files/f7e9118a3c97b0d1e523ac65af82b13c697ffe5a..b2d119eb5d6bb2ec9a8bf54a8d9ec8b389345fe0

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 12 Oct 2018 20:01:18 +0000 (UTC)

LPardue commented on this pull request.

> @@ -980,8 +716,8 @@ server to client, as in HTTP/2.
 The payload consists of:
 
 Push ID:
-: A variable-length integer that identifies the server push request.  A push ID
-  is used in push stream header ({{server-push}}), CANCEL_PUSH frames
+: A variable-length integer that identifies the server push operation.  A push

s/push/Push

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837#pullrequestreview-164389275

---

From: Mike Bishop <[email-masked]>
Date: Fri, 12 Oct 2018 15:40:46 -0700

d57c08d  Lucas's s/p/P/

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837/files/b2d119eb5d6bb2ec9a8bf54a8d9ec8b389345fe0..d57c08d436598eb20a1ab59dbcee1af8251c9e3f

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Oct 2018 11:22:23 -0700

Merged #1837 into reorganize.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1837#event-1910341378