Subject: [quicwg/base-drafts] Limit retransmission of closing packet (#1905)

From: Martin Thomson <[email-masked]>
Date: Wed, 24 Oct 2018 16:19:52 -0700

@mikkelfj observes that we permit rate limiting of connection close frames, but they might be used to create an amplification attack if the closing endpoint is naive in its handling.  The fix is easy - the endpoint needs to remember a validated address for its peer along with the closing packet.  Packets from other remote addresses need to be dropped or only responded to if the size of the incoming packet is > 1/3 of the closing packet.  In most cases, this won't change anything.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1905

---

From: Martin Thomson <[email-masked]>
Date: Sun, 28 Oct 2018 16:55:52 -0700

Closed #1905 via #1911.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1905#event-1931044216