Subject: [quicwg/base-drafts] Make Client TP Optional (#1892)

From: Nick Banks <[email-masked]>
Date: Fri, 19 Oct 2018 15:12:47 +0000 (UTC)

With Draft 15 all client transport parameters are now optional. I assume we will try to continue with that design as we add new ones (perhaps none in V1). Does it make sense to make inclusion of the QUIC TP extension as a whole optional, for the client?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1892

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 19 Oct 2018 15:30:05 -0700

While that could be possible, I wonder what the benefit of making it optional is. I would assume that every implementation will be sending some non-default settings value (e.g., initial_max_data), which means that making TP optional is essentially adding a conditional branch that will always turn on one side.

Additionally, we would be required to revisit the following requirement in QUIC-TLS section 8.2: _Endpoints MUST NOT send this extension in a TLS connection that does not use QUIC (such as the use of TLS with TCP defined in [TLS13]). A fatal unsupported_extension alert MUST be sent if this extension is received when the transport is not QUIC._

Considering these two aspects, I prefer mandating the use of TP as we do now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1892#issuecomment-431517494

---

From: ianswett <[email-masked]>
Date: Fri, 19 Oct 2018 16:01:39 -0700

Agreed, always sending it is a lot easier than sometimes sending it.  Additionally, I believe it'll always end up being necessary in real applications(ie: HTTP), so there's no real-world savings in omitting it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1892#issuecomment-431522514

---

From: Martin Thomson <[email-masked]>
Date: Sun, 21 Oct 2018 04:30:42 -0700

No mention of version negotiation depending on them.  I'm a little disappointed.  Of course, I agree with the other comments recommending the current mandate be retained.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1892#issuecomment-431661172

---

From: Nick Banks <[email-masked]>
Date: Sun, 21 Oct 2018 12:52:04 -0700

Closed #1892.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1892#event-1916806766