Subject: [quicwg/base-drafts] Reorganizes drafts (#1884)

From: janaiyengar <[email-masked]>
Date: Thu, 18 Oct 2018 14:31:50 -0700

This PR reorganizes the contents of the transport, http, and qpack drafts.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1884

-- Commit Summary --

  * Editorial commitment
  * Move content into a Request Lifecycle section
  * Move Extensions before Error Handling
  * Move H2 Considerations to an appendix
  * Expand introduction, discuss relationship with HTTP and TCP
  * Fix reserved version example
  * Narrow restriction on server sending before SETTINGS
  * Better discussion of QUIC streams
  * Fix references, reorder unidirectional stream section
  * General framing layer fixups
  * PRIORITY fixups; fixes #1848
  * CANCEL_PUSH fixups
  * SETTINGS fixups
  * Import definition of MAX_HEADER_LIST_SIZE
  * PUSH_PROMISE fixups
  * MAX_PUSH_ID fixup
  * Headers and message formatting fixups
  * Cancellation and CONNECT fixups
  * Tighten some redundancies
  * Explicitly mention error upgrades
  * Generalize varint text in Security Considerations
  * Keep H2 Considerations up-to-date
  * has incorporates
  * Use a/the consistently
  * Moved stream stuff up and added intro text to describe structure of doc
  * Lucas's s/p/P/
  * Moved major sections around.
  * created packets and frames section and moved things about
  * modified intro, made error codes first level section
  * Done through connection migration section
  * addresses mt's comments.
  * detailed structure in intro
  * most of martinduke comments
  * added initial values in flow control
  * lint
  * max_stream_id
  * parenthesize
  * parenthesize
  * stream-id-blocked frame
  * s/intertwines/combines
  * unnecessary text
  * connection id para
  * connection id contd
  * connection id contd
  * s/subsequent/additional
  * shorter sentences
  * packet protection TODO
  * packet protection TODO contd
  * s/the/a
  * s/acks/acknowledges
  * unnecessary text
  * unnecessary text
  * last of mt's comments
  * lint
  * lint
  * Merge pull request #1857 from quicwg/reorganize_transport
  * correct changelog

-- File Changes --

    M draft-ietf-quic-http.md (1386)
    M draft-ietf-quic-qpack.md (4)
    M draft-ietf-quic-transport.md (6084)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1884.patch
https://github.com/quicwg/base-drafts/pull/1884.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1884

---

From: janaiyengar <[email-masked]>
Date: Thu, 18 Oct 2018 14:36:33 -0700

@janaiyengar pushed 1 commit.

fb27f31  Merge branch 'master' into reorganize

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1884/files/84b5c577281f159f67aa76873f311eb16031a7a4..fb27f313196b980d62d100a67cba585604c2c862

---

From: janaiyengar <[email-masked]>
Date: Thu, 18 Oct 2018 14:51:40 -0700

bce33e2  fix structure in intro

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1884/files/fb27f313196b980d62d100a67cba585604c2c862..bce33e240951c6546e3f064b4658ec3c335fd17a

---

From: janaiyengar <[email-masked]>
Date: Thu, 18 Oct 2018 16:53:44 -0700

Merged #1884 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1884#event-1913611575