Subject: [quicwg/base-drafts] Should the key update expansion use "quic " or "tls13 "? (#1845)

From: Christian Huitema <[email-masked]>
Date: Mon, 08 Oct 2018 18:44:45 -0700

I am looking at the details of the key update mechanism. The TLS draft says that "_A receiving endpoint detects an update when the KEY_PHASE bit doesn’t match what it is expecting. It creates a new secret (see Section 7.2 of [TLS13]) and the corresponding read key and IV._" That means using HKDF-Expand-Label.

I assume that we are going to use the prefix “quic “ rather than “tls13 “, since that's what we do at all the other places that use HKDF-Expand-Label. But the spec is silent. Maybe it should have a mention about theprefix for the label expansion?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1845

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Oct 2018 15:52:21 -0700

I think that folks in slack settled on "quic ".  We need to write that down though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1845#issuecomment-430428822

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Oct 2018 16:43:33 -0700

Closed #1845 via #1899.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1845#event-1922017000