Subject: [quicwg/base-drafts] Version negotiation might never terminate (#1919)

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 14:41:31 -0700

facts:
client does not support version C but does support A and B.
server X and Y are exposed as two separate IP addresses on the same domain.
client always chooses the next IP round robin when sending and initial packet nr.0.
server X supports version B, C
server Y supports version A, C

scenario
forever {
client sends Initial packet in version A and server X responds with vneg B, C
client sends Initial packet in version B and server Y responds with vneg A, C
}

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1919

---

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 15:01:16 -0700

Closing as the following text prevents the above scenario:

"Similarly, a client MUST ignore a Version Negotiation packet if it has already received and acted on a Version Negotiation packet."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1919#issuecomment-433220618

---

From: MikkelFJ <[email-masked]>
Date: Thu, 25 Oct 2018 22:01:16 +0000 (UTC)

Closed #1919.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1919#event-1927471583