Subject: [quicwg/base-drafts] Avoid having multiple ways to encode Delta Base Index of zero (#2005)

From: Kazuho Oku <[email-masked]>
Date: Wed, 14 Nov 2018 15:33:01 -0800

As discussed in #2002, there are two ways to encode Delta Base Index of zero at the wire level; i.e. (sign-bit, delta-base-index)=(0, 0) and (1, 0).

To avoid having multiple ways to represent one value, we prohibit the latter form from being used.  A receiver is required to raise an error when it sees the latter.

This is not only an unnecessary complexity but also contradicts from the approach we use for Post-Base Indexes.  In case of Post-Base Indexes, we introduce an offset of one so that the Post-Base
Index of zero and a non-Post-Base Index of zero do not overlap.

The commit adopts the approach to Delta Base Index; giving us consistency in the design and also removing an error check at the cost of requiring one subtraction.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2005

-- Commit Summary --

  * Avoid having multiple ways to encode Delta Base Index of zero.

-- File Changes --

    M draft-ietf-quic-qpack.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2005.patch
https://github.com/quicwg/base-drafts/pull/2005.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2005

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 14 Nov 2018 18:31:37 -0800

dtikhonov approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2005#pullrequestreview-175168650

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Nov 2018 11:16:52 -0800

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2005#pullrequestreview-176455370