Subject: Re: [quicwg/base-drafts] Rename "retransmittable" frames and packets (#1595)

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 05 Nov 2018 09:05:13 -0800

I say we use "[ackent](https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435465202)".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-435953239

---

From: MikkelFJ <[email-masked]>
Date: Mon, 05 Nov 2018 09:14:13 -0800

> Victor suggested "tracked" FYI

I was also considering that, but didn't fully convince myself.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-435956411

---

From: Lars Eggert <[email-masked]>
Date: Mon, 05 Nov 2018 17:50:36 -0800

+1 for wack :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-436102977

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 05 Nov 2018 21:18:49 -0800

I think ACK-eliciting (or some such) is both technically correct and
obviously understandable. Something like "wack", "tracked", "ackent" don't
have obvious english language interpretations and hence require another
layer of jargon/indirection in order to understand.

On Mon, Nov 5, 2018 at 5:50 PM, Lars Eggert <[email-masked]>
wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/1595#issuecomment-436102977>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ASp6yk87O80LAb11cnJzjjGeOs0D1AoKks5usOrsgaJpZM4VbQ_8>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-436134039

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sat, 10 Nov 2018 16:39:36 -0800

> Something like "wack", "tracked", "ackent" don't have obvious english language interpretations

I disagree.  While _wack_ (not an adjective!) and _tracked_ (only implies action tangentially) are indeed poor choices, _ackent_ belongs to a family of English adjectives ending with **ent** wherein **ent** implies action related to the suffixed part of the word:

- astringent
- indulgent
- pestilent
- propellent
- prurient
- quiescent
- somnolent
- truculent
- urgent

**Ackent**: causing ACKs.  Sounds logical and English to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437633615

---

From: Christian Huitema <[email-masked]>
Date: Sat, 10 Nov 2018 17:00:57 -0800

On 11/11/2018 7:39 AM, Dmitri Tikhonov wrote:
> I disagree. While /wack/ (not an adjective!) and /tracked/ (only
> implies action tangentially) are indeed poor choices, /ackent/ belongs
> to a family of English adjectives ending with *ent* wherein *ent*
> implies action related to the suffixed part of the word:
>
>   * astringent
>   * indulgent
>   * pestilent
>   * propellent
>   * prurient
>   * quiescent
>   * somnolent
>   * truculent
>   * urgent
>
> *Ackent*: causing ACKs. Sounds logical and English to me.
>

I would rather use "truculent"

-- Christian Huitema

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437634575

---

From: Ryan Hamilton <[email-masked]>
Date: Sat, 10 Nov 2018 19:51:26 -0800

On Sat, Nov 10, 2018 at 4:39 PM, Dmitri Tikhonov <[email-masked]>
wrote:

> I disagree. While *wack* (not an adjective!) and *tracked* (only implies
> action tangentially) are indeed poor choices, *ackent* belongs to a
> family of English adjectives ending with *ent* wherein *ent* implies
> action related to the suffixed part of the word:
>
>    - astringent
>    - indulgent
>    - pestilent
>    - propellent
>    - prurient
>    - quiescent
>    - somnolent
>    - truculent
>    - urgent
>
While I appreciated that it is possible to construct a rule by which
"ackent" means "causes an ACK", it's simply the case that "ackent" is not a
word. When I read the word "ackent" it does not in any way trigger the
meaning "causes an ACK". As such, it no different to me than any other
piece of jargon. It's easy enough to memorize what a piece of jargon means,
so it's no different in this way than any number of other
terms. ACK-eliciting (or some such), on the other hand, is unambiguous and
does not require memorization.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437641637

---

From: Ryan Hamilton <[email-masked]>
Date: Sat, 10 Nov 2018 19:59:14 -0800

On Sat, Nov 10, 2018 at 7:51 PM, Ryan Hamilton <[email-masked]> wrote:

> On Sat, Nov 10, 2018 at 4:39 PM, Dmitri Tikhonov <[email-masked]
> > wrote:
>
>> It's perhaps worth pointing out that an "indulgent" person is a person
who indulges. Which might imply that an ackent packet is packet that
ACKs... meaning a packet which contains an ACK as opposed to a packet which
elicits an ACK :/

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437641914

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sat, 10 Nov 2018 21:17:17 -0800

> it's simply the case that "ackent" is not a word.

Sure it is: you just used it several times above.  A dictionary is not a legal document.

> It's perhaps worth pointing out that an "indulgent" person is a person who indulges. [...]

I listed "indulgent" thinking of being "indulgent to" -- that is, deriving from the transitive version of the verb "to indulge" (which is the first meaning).  My thinking was that being indulgent to someone is to invite (cause) more behavior of the same kind.  Thinking more about this, however, makes me realize that this adjective is not part of the group listed about, as "indulgent" does not cause indulgence.

> "Truculent," various +1, smiling emojis:

I'll see how you laugh when the "ack-eliciting" beast lands and you have to a) say or think it and b) make enums like `FRAME_ACK_ELICITING`.  Blech!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437644640

---

From: MikkelFJ <[email-masked]>
Date: Sun, 11 Nov 2018 00:51:42 -0800

ACK-inducing, -prompting, -triggering, -requesting

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437653373

---

From: Dmitri Tikhonov <[email-masked]>
Date: Sun, 11 Nov 2018 06:18:49 -0800

Ackigenous

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1595#issuecomment-437673969