Subject: [quicwg/base-drafts] Rename QPACK to HPACK3? (#2041)

From: Lucas Pardue <[email-masked]>
Date: Thu, 22 Nov 2018 02:24:36 -0800

Since we renamed HTTP/QUIC to HTTP/3, perhaps we should rename QPACK to avoid its linkage with QUIC. :smiling_imp: 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041

---

From: MikkelFJ <[email-masked]>
Date: Thu, 22 Nov 2018 10:36:25 +0000 (UTC)

Wouldn't HPACK/3, as opposed to HPACK3, be the more correct term?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-440987468

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 22 Nov 2018 02:56:57 -0800

I am not sure if H of HPACK stands for HTTP. I had always assumed that it is the first letter of “header.” It is also my understanding that QPACK tries not to be HTTP-specific.

Assuming that they are correct, I think keeping the name QPACK might be better, reflecting the fact that it is a compression algorithm designed for QUIC.

Just my two cents.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-440993131

---

From: Daniel Stenberg <[email-masked]>
Date: Thu, 22 Nov 2018 02:59:20 -0800

I agree with @kazuho here. It isn't really a version three of HPACK so I think implying that in name would be unfortunate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-440993774

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 22 Nov 2018 07:23:46 -0800

I prefer to keep the QPACK name.

If we were to rename it, HPACK 2, not 3, is more appropriate (and forget the slash).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-441061693

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 22 Nov 2018 15:26:37 +0000 (UTC)

Thanks for the feedback.

As the ticket raiser, I also vote for keeping QPACK.

Closing this as I've had sensible answers to a stupid question.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-441062485

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 22 Nov 2018 07:26:38 -0800

Closed #2041.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#event-1982768034

---

From: MikkelFJ <[email-masked]>
Date: Thu, 22 Nov 2018 17:22:10 -0800

I can the see the argument for QPACK being a generic quic compressor, but as it stands, it is fairly tightly coupled to HTTP. The title says

"QPACK: Header Compression for HTTP over QUIC"

And the static table is fairly tightly coupled to HTTP as well.

At the very least the static table should be negotiable in QUIC TP if the intend is to provide a generic compressor. This could be very useful BTW.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-441140653

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 22 Nov 2018 20:54:52 -0800

My view is that it’s only the static table that’s HTTP-specific.

And we do not need a TP for having different static tables for each protocol; the use of protocol is negotiated by using ALPN, and static table selection can naturally depend on that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2041#issuecomment-441156333