Subject: [quicwg/base-drafts] Fast Retransmit triggered by single ACK (#2059)

From: Vidhi Goel <[email-masked]>
Date: Tue, 27 Nov 2018 17:24:52 -0800

>From Recovery draft,
"An unacknowledged packet is marked as lost when an acknowledgment is received for a packet that was sent a threshold number of packets (kReorderingThreshold) and/or a threshold amount of time after the unacknowledged packet."

Lets say sender sends packet# 1, 2, 3, 4 and 5 and kReorderingThreshold  = 3. The sender receives ACK for packet# 5. Will that trigger FR? Does this mean that FR will be triggered by a "single ACK"?

TCP causes FR only after receiving 3-Dup ACKs or corresponding SACK. The mechanism described in QUIC recovery draft is a major deviation from TCP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2059

---

From: ianswett <[email-masked]>
Date: Wed, 28 Nov 2018 02:08:30 +0000 (UTC)

This behavior is documented in: https://tools.ietf.org/html/rfc7414#section-8 and I believe is widely implemented.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2059#issuecomment-442291354

---

From: Subodh Iyengar <[email-masked]>
Date: Tue, 27 Nov 2018 18:16:20 -0800

I don't think it is a major deviation from TCP. The spirit of the FR mechanism in TCP is to FR when it sees 3 packets out of order which a receiver can only do via SACKs or duplicate cumulative acks. Since QUIC does not have cumulative ACKs, the notion of DUP acks would not make sense, so an ACK for a packet which is 3 packets out of order would imply that 2 packets before it were lost. It's cleaner and easier to implement.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2059#issuecomment-442292937

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Nov 2018 21:44:16 -0800

Is there any change required to the specification here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2059#issuecomment-442327366

---

From: Vidhi Goel <[email-masked]>
Date: Tue, 27 Nov 2018 22:13:57 -0800

Thanks Ian.
@martinthomson,
I think a reference to FACK paper (Forward Acknowledgement: Refining TCP Congestion Control) in the Fast Recovery section of the draft would be helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2059#issuecomment-442332379