Subject: [quicwg/base-drafts] what is the default dependent stream of pushed streams (#1959)

From: Subodh Iyengar <[email-masked]>
Date: Sat, 03 Nov 2018 05:04:27 -0700

in http/2 the default dependency of the pushed stream was it's associated stream. However in h3 we now have push ids and not associated streams. Should we have a default priority here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 03 Nov 2018 05:23:25 -0700

Any PUSH_PROMISE is still triggered by a request and sent back on that bidi stream. Would it suffice to assume that one's priority?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959#issuecomment-435583775

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 05:56:02 -0700

Yes, PUSH_PROMISE can be used, but which PUSH_PROMISE?

The pushed response is what would be prioritized, and multiple requests can point at the same pushed response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959#issuecomment-435585820

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 03 Nov 2018 06:17:06 -0700

So I always look at Priortisation from the server's perspective - if it wants to push a thing, how should it assign resources to that in keeping with how the client already expressed it's priority preferences.

So in other words, what I said is then: the pushed pseudo-request assumes it's parent request's priority by default. A client could then repriortise that particular pseudo-request by using the PRIORITY frame with the Push ID.

Logically, the reprioritisation would point the dependency at some other request (Stream ID), a different Push promise ID (reprioritising to self means what??), or some placeholder ID.

Now, here's where I get told all my assumption have been wrong :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959#issuecomment-435587256

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 09:03:43 -0700

I can put the same PUSH_PROMISE (promising the same push) on two request streams.  Which of those does the pushed stream depend on?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959#issuecomment-435598998

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 03 Nov 2018 09:12:00 -0700

Good point. The last one?

What about assuming no default priority as a solution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1959#issuecomment-435599702