Subject: [quicwg/base-drafts] Late alarms and max_ack_delay (#1960)

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 05:23:24 -0700

Add some text on how to correctly specify max_ack_delay on systems where the alarm may fire late.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1960

-- Commit Summary --

  * Late alarms and max_ack_delay

-- File Changes --

    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1960.patch
https://github.com/quicwg/base-drafts/pull/1960.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 05:54:44 -0700

martinthomson commented on this pull request.

> @@ -3929,8 +3929,11 @@ max_ack_delay (0x000b):
 
 : The maximum ACK delay is an integer value indicating the
   maximum amount of time in milliseconds by which the endpoint will delay
-  sending acknowledgments.  If this value is absent, a default of 25
-  milliseconds is assumed.
+  sending acknowledgments.  This value should include the receiver's expected
+  delays in alarms firing.  For example, if a receiver specifies a 5ms
+  max_ack_delay and alarms commonly fire up to 1ms late, then it should set
+  a timer for 4ms.  If this value is absent, a default of 25 milliseconds is

I would do this the other way around.  If a receiver sets ack delay timers at 5ms and alarms could fire up to 1ms late, then it should advertise a max_ack_delay of 6ms.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960#pullrequestreview-171326683

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 06:29:32 -0700

@ianswett pushed 1 commit.

f67fe97  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960/files/f39262803d4a772877b0b303caed8f574d725d52..f67fe97f9eb9082c82bf6bcbb8fbf7585d365d2a

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 09:00:42 -0700

> @@ -3929,8 +3929,10 @@ max_ack_delay (0x000b):

```suggestion
  sending acknowledgments.  This value SHOULD include the receiver's expected
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960#pullrequestreview-171332334

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 09:01:19 -0700

@martinthomson pushed 1 commit.

fc2858f  Use SHOULD as appropriate

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960/files/f67fe97f9eb9082c82bf6bcbb8fbf7585d365d2a..fc2858f20a571f3d9fc228ff2442bfa768d3f287

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 09:01:42 -0700

Merged #1960 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960#event-1944438269

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 13:23:27 -0700

Martin, thanks of fixing this up and landing it!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1960#issuecomment-435618049