Subject: Re: [quicwg/base-drafts] register UDP port 443 for HQ? (#1944)

From: mirjak <[email-masked]>
Date: Sat, 03 Nov 2018 03:35:04 -0700

Udp 443 is already registered for "http protocol over TLS/SSL". However it would certainly be good to update the existing entry to adda reference to the quic RFC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#issuecomment-435577294

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 03 Nov 2018 03:49:50 -0700

I'd missed all the progress on this in the OPs drafts. 

The IANA table is available at https://www.iana.org/assignments/service-names-port-numbers/service-names-port-numbers.xhtml?search=443v for anyone that was struggling to find it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#issuecomment-435578258

---

From: Mike Bishop <[email-masked]>
Date: Sat, 03 Nov 2018 19:31:11 -0700

FWIW, nothing in HTTP/QUIC depends on a particular port number.  A default port number is a property of a scheme, so until we define a QUIC-specific scheme, using UDP 443 is merely a widespread convention.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#issuecomment-435636954

---

From: Lars Eggert <[email-masked]>
Date: Sat, 03 Nov 2018 20:21:24 -0700

Yeah, we looked into this and had UDP/443 reassigned to the IETF a while ago. See #428.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#issuecomment-435638794

---

From: Lars Eggert <[email-masked]>
Date: Sat, 03 Nov 2018 20:21:38 -0700

Closed #1944.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#event-1944653531

---

From: Kazuho Oku <[email-masked]>
Date: Sat, 03 Nov 2018 20:27:44 -0700

@larseggert Thanks you for the pointer. Does that mean that the official port for HQ is UDP 443?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1944#issuecomment-435639019