Subject: [quicwg/base-drafts] Why ignore MAX_STREAM_DATA or MAX_DATA that don't increase the flow control limits (#2082)

From: ekr <[email-masked]>
Date: Fri, 30 Nov 2018 18:04:51 -0800

S 4.1. says:

```
A receiver can advertise a larger offset by sending MAX_STREAM_DATA or MAX_DATA
frames at any time during the connection.  A receiver cannot renege on an
advertisement however.  That is, once a receiver advertises an offset,
advertising a smaller offset has no effect.  A sender MUST therefore ignore any
MAX_STREAM_DATA or MAX_DATA frames that do not increase flow control limits.
```

It seems like it would be more helpful if implementations were to remember the PN of the last advertisement and generate an error in this case. I get that this would be more work, but why is this prohibited?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082

---

From: Marten Seemann <[email-masked]>
Date: Fri, 30 Nov 2018 18:13:58 -0800

We discussed this in #1612 and decided to not prohibit this. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443391030

---

From: ekr <[email-masked]>
Date: Fri, 30 Nov 2018 18:24:03 -0800

Well, I think this was wrongly decided, but I'm willing to accept the consensus on the normative effect, but then this language is terrible, because it just looks like a clumsily written levy on the sender. Instead it should say:

"That is, once a receiver advertises an offset, it MAY send a packet with a smaller offset, but this has no effect."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443391733