Subject: [quicwg/base-drafts] What is the default root of the priority tree (#1958)

From: Subodh Iyengar <[email-masked]>
Date: Sat, 03 Nov 2018 05:02:18 -0700

In http/2 the default root is stream 0x00, however this is now a request stream so we clearly can't depend on that any more.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1958

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 03 Nov 2018 05:20:27 -0700

My take: there are now 3 types of dependency and the root is an untyped abstract value that is assumed if no other type is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1958#issuecomment-435583595

---

From: Mike Bishop <[email-masked]>
Date: Sat, 03 Nov 2018 19:29:03 -0700

There are actually four, and root is explicitly called out as a dependency type.  See [here](https://quicwg.org/base-drafts/draft-ietf-quic-http.html#rfc.section.4.2.3)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1958#issuecomment-435636852

---

From: Mike Bishop <[email-masked]>
Date: Sat, 03 Nov 2018 19:29:05 -0700

Closed #1958.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1958#event-1944641703