Subject: [quicwg/base-drafts] Include the QUIC version in the transport key labels (#1997)

From: Martin Thomson <[email-masked]>
Date: Mon, 12 Nov 2018 14:59:45 -0800

@adl suggests in #1991: "it could make sense to also include the QUIC version in the transport key labels"

A simple hack would be to (ab)use the unused `context` field, and include the 4 octet version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1997

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 13 Nov 2018 00:31:45 +0000 (UTC)

+1 to adding QUIC version.

(Ab)using the `context` field sounds attractive, though I would prefer having text in the label specify the version, partly because it is what TLS 1.3 does (i.e. `tls13 ` prefix), and partly because we might want to use the `context` in a version-specific way in the future.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1997#issuecomment-438082646

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Nov 2018 15:59:49 -0800

Addressed by the extra text added to #1991.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1997#issuecomment-440473694

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Nov 2018 15:59:49 -0800

Closed #1997.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1997#event-1978780084