Subject: [quicwg/base-drafts] Remove "quic " HKDF label (#1976)

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Nov 2018 19:07:05 -0800

Closes #1971.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1976

-- Commit Summary --

  * Remove "quic " HKDF label

-- File Changes --

    M draft-ietf-quic-tls.md (15)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1976.patch
https://github.com/quicwg/base-drafts/pull/1976.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1976

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 06 Nov 2018 19:49:53 -0800

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1976#pullrequestreview-172331763

---

From: Kyle Nekritz <[email-masked]>
Date: Wed, 07 Nov 2018 11:52:57 -0800

knekritz commented on this pull request.

> @@ -710,16 +710,14 @@ based on the client's initial Destination Connection ID, as described in
 {{initial-secrets}}.
 
 The keys used for packet protection are computed from the TLS secrets using the
-method described in Section 7.3 of {{!TLS13}}), except that the label for
-HKDF-Expand-Label uses the prefix "quic " rather than "tls13 ". A different
-label provides key separation between TLS and QUIC.
+method described in Section 7.3 of {{!TLS13}}).
 
 For example, where TLS might use a label of 0x002009746c733133206b657900 to
 derive a key, QUIC uses 0x00200871756963206b657900.

Cut the example

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1976#pullrequestreview-172669518

---

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Nov 2018 17:49:13 -0800

@martinthomson pushed 1 commit.

5920b4a  Remove example

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1976/files/36c68c3f600722cd6a52f28622e60f9423ffc3f3..5920b4a56f32464a5fecc4b8c4abfc81bd405324

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Nov 2018 14:58:17 -0800

Closed #1976 via #1991.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1976#event-1978690379