Subject: [quicwg/base-drafts] Mention BBR as an example of an alternative congestion control mechanism (#1975)

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 06 Nov 2018 04:52:06 -0800

At least one known implementation is using BBR:
https://cs.chromium.org/chromium/src/net/third_party/quic/core/congestion_control/bbr_sender.cc?g=0
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1975

-- Commit Summary --

  * Mention BBR as an alternative congestion control mechanism
  * Formatting fix

-- File Changes --

    M draft-ietf-quic-recovery.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1975.patch
https://github.com/quicwg/base-drafts/pull/1975.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975

---

From: ekr <[email-masked]>
Date: Tue, 06 Nov 2018 18:13:29 -0800

I don't think it's helpful to specifically cite BBR here. There are a lot of alternatives.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-436479078

---

From: Martin Thomson <[email-masked]>
Date: Tue, 06 Nov 2018 18:19:10 -0800

I don't think that you could reasonably say that the authors were unaware of BBR.  You might then conclude that not mentioning BBR was intentional.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-436480207

---

From: ianswett <[email-masked]>
Date: Tue, 06 Nov 2018 18:25:43 -0800

Now that Cubic is an RFC(https://tools.ietf.org/html/rfc8312), mentioning it may make sense, but I'd prefer to not mention BBR, since it's not done and not an RFC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-436481375

---

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 13 Nov 2018 06:47:06 +0000 (UTC)

@ianswett i understand better now. I can change the PR to mention Cubic instead. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-438156136

---

From: Loganaden Velvindron <[email-masked]>
Date: Mon, 12 Nov 2018 22:47:22 -0800

@martinthomson understood.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-438156190

---

From: janaiyengar <[email-masked]>
Date: Mon, 12 Nov 2018 22:52:24 -0800

janaiyengar commented on this pull request.

Editorial suggestions, and replace BBR with Cubic

> @@ -918,7 +918,10 @@ packet is a probe packet sent after the TLP or RTO timer expires, as described
 in {{tlp}} and {{rto}}.
 
 Implementations MAY use other congestion control algorithms, and endpoints MAY
-use different algorithms from one another. The signals QUIC provides for
+use different algorithms from one another. An example would be the

```suggestion
use other algorithms, such as Cubic {{?RFC8312}}.  The signals QUIC provides for
```

> @@ -918,7 +918,10 @@ packet is a probe packet sent after the TLP or RTO timer expires, as described
 in {{tlp}} and {{rto}}.
 
 Implementations MAY use other congestion control algorithms, and endpoints MAY
-use different algorithms from one another. The signals QUIC provides for
+use different algorithms from one another. An example would be the
+experimental BBR Congestion Control Mechanism

```suggestion
```

> @@ -918,7 +918,10 @@ packet is a probe packet sent after the TLP or RTO timer expires, as described
 in {{tlp}} and {{rto}}.
 
 Implementations MAY use other congestion control algorithms, and endpoints MAY
-use different algorithms from one another. The signals QUIC provides for
+use different algorithms from one another. An example would be the
+experimental BBR Congestion Control Mechanism
+{{?I-D.cardwell-iccrg-bbr-congestion-control}} which minimises induced

```suggestion
```

> @@ -918,7 +918,10 @@ packet is a probe packet sent after the TLP or RTO timer expires, as described
 in {{tlp}} and {{rto}}.
 
 Implementations MAY use other congestion control algorithms, and endpoints MAY
-use different algorithms from one another. The signals QUIC provides for
+use different algorithms from one another. An example would be the
+experimental BBR Congestion Control Mechanism
+{{?I-D.cardwell-iccrg-bbr-congestion-control}} which minimises induced
+latency along delivery path. The signals QUIC provides for

```suggestion
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#pullrequestreview-174213733

---

From: Loganaden Velvindron <[email-masked]>
Date: Mon, 12 Nov 2018 23:03:00 -0800

@loganaden pushed 1 commit.

7497ea8  Remove BBR and mention CUBIC which has standardized in RFC8312

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975/files/561aea6732b7ea1a069ef1d98d47f1a3220193e2..7497ea8cd9aca4fe538de358bdce22f4b05cb362

---

From: janaiyengar <[email-masked]>
Date: Mon, 12 Nov 2018 23:13:34 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#pullrequestreview-174218369

---

From: janaiyengar <[email-masked]>
Date: Mon, 12 Nov 2018 23:14:08 -0800

Merged #1975 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#event-1962210823

---

From: MikkelFJ <[email-masked]>
Date: Tue, 13 Nov 2018 08:01:23 +0000 (UTC)

mikkelfj commented on this pull request.

Note ongoing proposal for dynamic ACK frequency elsewhere. The generic signal mentioned here should perhaps be updated to reflect this, if proposal goes through.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#pullrequestreview-174230260

---

From: Loganaden Velvindron <[email-masked]>
Date: Tue, 13 Nov 2018 00:15:50 -0800

@mikkelfj noted. I will work on updating the generic signal section if it goes through.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-438175392

---

From: Mike Bishop <[email-masked]>
Date: Wed, 14 Nov 2018 10:48:50 -0800

Belated, but I don't like this change.  The original text makes two points:
- You don't have to use the congestion control mechanism we describe here
- Each peer can choose independently

The changed text says the first point twice, and drops the second one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1975#issuecomment-438774568