Subject: [quicwg/base-drafts] Sequence Number between CID length and CID is wired (#1952)

From: Kazuho Oku <[email-masked]>
Date: Sat, 03 Nov 2018 02:13:07 -0700

The frame layout is defined as below, placing Sequence Number between Length field (that designates the length of the Connection ID field) and the Connection ID field.

This is wired. We should move Sequence Number to front so that Length and Connection ID become adjacent fields.

```
 0                   1                   2                   3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|   Length (8)  |            Sequence Number (i)              ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                    Connection ID (32..144)                  ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                                                               |
+                                                               +
|                                                               |
+                   Stateless Reset Token (128)                 +
|                                                               |
+                                                               +
|                                                               |
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952

---

From: Martin Thomson <[email-masked]>
Date: Sun, 04 Nov 2018 16:53:11 -0800

FWIW, it is weird.  I think that we can fix this, but it will be disruptive.  Do we want to use a varint length at the same time?  Or is that just more weird?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952#issuecomment-435725603

---

From: ianswett <[email-masked]>
Date: Sun, 04 Nov 2018 16:56:24 -0800

Yes, we should move the length next to the CID, but I don't think there's any reason to move to a varint here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952#issuecomment-435725880

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 04 Nov 2018 16:57:20 -0800

> Do we want to use a varint length at the same time? Or is that just more weird?

Considering the fact that CID length is expressed using a fixed number of bits in the long header, I think it would be more consistence to continue using a fixed-length encoding here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952#issuecomment-435725980

---

From: Martin Thomson <[email-masked]>
Date: Sun, 04 Nov 2018 17:02:37 -0800

Sold.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952#issuecomment-435726537

---

From: janaiyengar <[email-masked]>
Date: Mon, 12 Nov 2018 03:08:46 -0800

Closed #1952 via #1963.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1952#event-1959987586