Subject: [quicwg/base-drafts] Receipt of STOP_SENDING on already-closed stream (#2048)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 23 Nov 2018 08:05:16 -0800

As of today, the draft states the following:

> Receiving a STOP_SENDING frame for a locally-initiated send stream that is “Ready” or non-existent MUST be treated as a connection error of type PROTOCOL_VIOLATION.

Due to packet loss, it is possible for a _STOP_SENDING_ frame to arrive after the stream initiator closes the stream.  In this case, it should not be an error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2048

---

From: MikkelFJ <[email-masked]>
Date: Fri, 23 Nov 2018 08:29:42 -0800

There are many other reasons why this could happen, but I don't think this is a problem. A stream does not cease to exist just because it is closed. From memory that state chart should be ok. But since you raise this point, perhaps clarification is needed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2048#issuecomment-441281165

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 23 Nov 2018 08:31:58 -0800

The term "non-existent" is only used once in the entire draft.  I presumed it meant "not yet opened."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2048#issuecomment-441281614

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Nov 2018 23:26:09 +0000 (UTC)

Closed #2048 via #2050.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2048#event-1988169251