Subject: [quicwg/base-drafts] Editorial changes to abstract and intro (#1949)

From: janaiyengar <[email-masked]>
Date: Fri, 02 Nov 2018 22:38:54 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1949

-- Commit Summary --

  * Editorial changes to abstract and intro

-- File Changes --

    M draft-ietf-quic-transport.md (110)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1949.patch
https://github.com/quicwg/base-drafts/pull/1949.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949

---

From: janaiyengar <[email-masked]>
Date: Fri, 02 Nov 2018 22:42:52 -0700

@janaiyengar pushed 1 commit.

a7881a5  lint

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949/files/3a54d24683085bcdaf359a88d73019bbe8e2abc8..a7881a5cfacb4dfc8c968fb2d10cdbb8d019f6e1

---

From: janaiyengar <[email-masked]>
Date: Fri, 02 Nov 2018 23:03:37 -0700

ba03547  more terms

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949/files/a7881a5cfacb4dfc8c968fb2d10cdbb8d019f6e1..ba0354731a1040e14a8feccc8a340a3191b2418a

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 02:33:13 -0700

martinthomson commented on this pull request.

> @@ -92,10 +92,9 @@ informative:
 
 --- abstract
 
-This document defines the core of the QUIC transport protocol.  This document
-describes connection establishment, packet format, multiplexing, and
-reliability.  Accompanying documents describe the cryptographic handshake and
-loss detection.
+This document describes the core of the QUIC transport protocol.  Accompanying

I think that definition >> description here.

> @@ -92,10 +92,9 @@ informative:
 
 --- abstract
 
-This document defines the core of the QUIC transport protocol.  This document
-describes connection establishment, packet format, multiplexing, and
-reliability.  Accompanying documents describe the cryptographic handshake and
-loss detection.
+This document describes the core of the QUIC transport protocol.  Accompanying
+documents describe QUIC's loss detection and congestion control
+{{QUIC-RECOVERY}}, and the use of TLS 1.3 for key negotiation {{QUIC-TLS}}.

```suggestion
{{QUIC-RECOVERY}} and the use of TLS 1.3 for key negotiation {{QUIC-TLS}}.
```

>    - {{packets-frames}} describes concepts related to packets and frames,
   - {{packetization}} defines models for the transmission, retransmission, and
-    acknowledgement of information, and
-  - {{packet-size}} contains a rules for managing the size of packets.
+    acknowledgement of packets and frames, and

If you make this change, then I think that just packets is less confusing.

```suggestion
    acknowledgement of packets, and
```

 ## Conventions and Definitions
 
-The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD",
+### Keywords

No empty sections please.
```suggestion
```

>  "SHOULD NOT", "RECOMMENDED", "NOT RECOMMENDED", "MAY", and "OPTIONAL" in this
 document are to be interpreted as described in BCP 14 {{!RFC2119}} {{!RFC8174}}
 when, and only when, they appear in all capitals, as shown here.
 
-Definitions of terms that are used in this document:
+### Terms

```suggestion
```

 Endpoint:
 
-: The client or server end of a connection.
+: An entity that can participate in a QUIC conversation by generating,
+  receiving, and fully processing QUIC packets. There are only two types of

```suggestion
  receiving, and processing QUIC packets. There are only two types of
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949#pullrequestreview-171318484

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 02:34:03 -0700

-## Notational Conventions
+### Notational Conventions

```suggestion
## Notational Conventions
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949#pullrequestreview-171322069

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:23:36 -0700

8d76c1b  mt comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949/files/ba0354731a1040e14a8feccc8a340a3191b2418a..8d76c1b0b687b34c8ca679c59baa84d14881343f

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:24:53 -0700

7d8fd80  data

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949/files/8d76c1b0b687b34c8ca679c59baa84d14881343f..7d8fd80e896d957a4f1ef316338bd13fbcaaff14

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:32:04 -0700

Merged #1949 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1949#event-1944327106