Subject: [quicwg/base-drafts] Loss recovery draft section 4.3.1.1 clarification (#1983)

From: Nasif Ekiz <[email-masked]>
Date: Thu, 08 Nov 2018 13:43:11 -0800

Section 4.3.1.1 of draft 16 says:
A Retry or Version Negotiation packet causes a client to send another
   Initial packet, effectively restarting the connection process.

Either packet indicates that the Initial was received but not
   processed.  Neither packet can be treated as an acknowledgment for
   the Initial, but they MAY be used to improve the RTT estimate.

Should we clear handshake_count when an Retry or Version Negotiation packet is received after Initial is sent (maybe multiple times)? Otherwise, the new Initial could be delayed extra if Initial is lost and needs retransmission. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1983

---

From: ianswett <[email-masked]>
Date: Tue, 20 Nov 2018 10:39:06 -0800

My mental model is that Retry or VN basically restart the connection, so I think it makes sense to set handshake_count back to 0.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1983#issuecomment-440385019

---

From: janaiyengar <[email-masked]>
Date: Mon, 26 Nov 2018 22:41:33 -0800

Closed #1983 via #2040.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1983#event-1988695038