Subject: [quicwg/base-drafts] Prohibit clients from declaring placeholders (#2056)

From: Mike Bishop <[email-masked]>
Date: Mon, 26 Nov 2018 12:46:12 -0800

Fixes #2010.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2056

-- Commit Summary --

  * Prohibit clients from declaring placeholders

-- File Changes --

    M draft-ietf-quic-http.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2056.patch
https://github.com/quicwg/base-drafts/pull/2056.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 26 Nov 2018 21:02:50 +0000 (UTC)

dtikhonov approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#pullrequestreview-178498762

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Nov 2018 15:31:46 -0800

OMFG, moar erroar cohdz.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#issuecomment-441840602

---

From: janaiyengar <[email-masked]>
Date: Mon, 26 Nov 2018 22:53:29 -0800

Heh. I like that 0x01 is getting used now, but can't you use UNEXPECTED_FRAME for this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#issuecomment-441948424

---

From: janaiyengar <[email-masked]>
Date: Mon, 26 Nov 2018 22:53:37 -0800

janaiyengar commented on this pull request.

> @@ -1028,7 +1028,9 @@ the prioritization the client had attempted to express.
 In HTTP/3, a number of placeholders are explicitly permitted by the server using
 the `SETTINGS_NUM_PLACEHOLDERS` setting. Because the server commits to maintain

s/maintain/maintaining

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#pullrequestreview-178630462

---

From: Mike Bishop <[email-masked]>
Date: Tue, 27 Nov 2018 10:44:05 -0800

It's a setting, not a frame.  We could expand the scope of that error code, if folks think that's preferable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#issuecomment-442171088

---

From: Mike Bishop <[email-masked]>
Date: Tue, 27 Nov 2018 10:46:12 -0800

@MikeBishop pushed 1 commit.

d800df0  maintaining

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056/files/43d3843729c3ba8ee31fd7c083b9f11a34b8c1be..d800df0cd2375bf7ad66c5f90580b3adee055196

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Nov 2018 15:59:23 -0800

Merged #2056 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2056#event-1993914248