Subject: Re: [quicwg/base-drafts] Change retransmittable to Ack-eliciting (#1942)

From: MikkelFJ <[email-masked]>
Date: Thu, 01 Nov 2018 01:27:05 -0700

Yeah - retransmittable doesn’t mean it have to, only that it can be.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-434969093

---

From: ianswett <[email-masked]>
Date: Thu, 01 Nov 2018 07:42:27 -0700

I'm not set on this being what we go with, but I think it reads reasonably well and I'm really unhappy with retransmittable, since I think it's just confusing.  If there's another alternative you'd like to see me create a PR for, feel free to suggest it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435054645

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 01 Nov 2018 08:19:47 -0700

Does the English language have a suffix that means that something _must_ be done ("ack`$foo`") rather than that _can_ be done ("ackable")?  What's `$foo`? 😖 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435068980

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 02 Nov 2018 12:22:31 -0700

Based on [this list of English suffixes](https://www.learnthat.org/pages/view/suffix.html), I propose that we use _ackent_ instead of ack-eliciting.  The suffix _ENT_ means "one who performs/causes."

Thus, instead of

> Packets that contain **ack-eliciting** frames elicit an ACK from the receiver within the maximum ack delay and are called **ack-eliciting** packets.

we will have

> Packets that contain **ackent** frames elicit an ACK from the receiver within the maximum ack delay and are called **ackent** packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435465202

---

From: MikkelFJ <[email-masked]>
Date: Fri, 02 Nov 2018 13:34:34 -0700

resilient

> Packets that contain resilient frames elicit an ACK from the receiver within the maximum ack delay and are called resilient packets.

unforgettable
https://www.youtube.com/watch?v=2HSt7LWsm-A

> Packets that contain unforgettable frames elicit an ACK from the receiver within the maximum ack delay and are called unforgettable packets.

unmissable

> Packets that contain unmissable frames elicit an ACK from the receiver within the maximum ack delay and are called unmissable packets.

robust

> Packets that contain robust frames elicit an ACK from the receiver within the maximum ack delay and are called robust packets.

stateful

> Packets that contain stateful frames elicit an ACK from the receiver within the maximum ack delay and are called stateful packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435492363

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 02 Nov 2018 20:58:36 +0000 (UTC)

@mikkelfj, my suggestion was in earnest.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435502291

---

From: MikkelFJ <[email-masked]>
Date: Fri, 02 Nov 2018 14:36:33 -0700

Mine was only half in jest. I kind of like resilient.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1942#issuecomment-435516471