Subject: Re: [quicwg/base-drafts] Renumber transport parameters (#1946)

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 02:44:17 -0700

janaiyengar commented on this pull request.

-initial_max_stream_data_bidi_local (0x0000):
+initial_max_stream_data_bidi_local (0x0005):
 
 : The initial stream maximum data for bidirectional, locally-initiated streams

```suggestion
: The parameter specifying the initial limit on stream data for bidirectional, locally-initiated
  streams is a 32-bit integer that contains the initial flow control limit for
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322326

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 02:51:12 -0700

This parameter is a 32-bit integer specifying the initial flow control limit for locally-initiated bidirectional streams. This limit applies to newly created bidirectional streams opened by the endpoint that sends the transport parameter.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#discussion_r230550356

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 02:59:45 -0700

-original_connection_id (0x000d):
+: The ACK delay exponent is an 8-bit unsigned integer value indicating an
+  exponent used to decode the ACK Delay field in the ACK frame, see

```suggestion
  exponent used to decode the ACK Delay field in the ACK frame ({{frame-ack}}).
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322673

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:00:06 -0700

-original_connection_id (0x000d):
+: The ACK delay exponent is an 8-bit unsigned integer value indicating an
+  exponent used to decode the ACK Delay field in the ACK frame, see
+  {{frame-ack}}.  If this value is absent, a default value of 3 is assumed

```suggestion
  If this value is absent, a default value of 3 is assumed
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322681

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 10:00:22 +0000 (UTC)

-A server MAY include the following transport parameters:
+: The maximum ACK delay is an 8 bit unsigned integer value indicating the

```suggestion
: The maximum ACK delay is an 8-bit unsigned integer value indicating the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322688

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:00:43 -0700

-: The Stateless Reset Token is used in verifying a stateless reset, see
-  {{stateless-reset}}.  This parameter is a sequence of 16 bytes.
+: The disable migration transport is included if the endpoint does not support

```suggestion
: The disable migration transport parameter is included if the endpoint does not support
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322700

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:02:59 -0700

@martinthomson pushed 1 commit.

2c353a3  Reword initial flow control

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/eefaec97368db4cbfe4a8fad4ddba71666057d9f..2c353a36e4f5241a1fba2553ed933c17421bd83e

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:03:54 -0700

d90ad2b  simplify

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/2c353a36e4f5241a1fba2553ed933c17421bd83e..d90ad2bce54e95c8f0b6db2f0cb6426728591aba

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:04:10 -0700

b7b9ea0  remove extra

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/d90ad2bce54e95c8f0b6db2f0cb6426728591aba..b7b9ea079cf0d707a28b826b9711e2a6baf4a214

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:05:46 -0700

ac47e24  hyphen

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/b7b9ea079cf0d707a28b826b9711e2a6baf4a214..ac47e24e229b8ccfcf9336d48f0ccfbd1f5f6fb8

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:05:58 -0700

86d2489  parameter

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/ac47e24e229b8ccfcf9336d48f0ccfbd1f5f6fb8..86d2489c9577cd82d6c0ffbb3fe85341f6302d54

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 03:07:30 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#pullrequestreview-171322862

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:09:32 -0700

3b6d193  Reflow

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946/files/86d2489c9577cd82d6c0ffbb3fe85341f6302d54..3b6d1934013deb23c193c8a2151f27a6f64efd09

---

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 03:10:06 -0700

Merged #1946 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1946#event-1944320933