Subject: [quicwg/base-drafts] Define server behavior for initial packets with < 8 byte DCID (#1981)

From: Ryegöng Crane <[email-masked]>
Date: Wed, 07 Nov 2018 10:59:32 -0800

The spec states that initial packets sent by clients which have not previously received a Retry packet must populate the Destination Connection ID field with an unpredictable value, and that the value MUST be at least 8 bytes in length.

However, the spec doesn’t say what a server receiving a packet from a client which violates this condition should do. There are already discrepancies in various implementations that a change to the spec could help to remedy.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1981

---

From: Marten Seemann <[email-masked]>
Date: Wed, 07 Nov 2018 18:55:29 -0800

Isn't this covered by 5.2.2?

> If the packet is an Initial packet fully conforming with the specification, the server proceeds with the handshake (Section 7). This commits the server to the version that the client selected.
> [...]
> Servers MUST drop incoming packets under all other circumstances.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1981#issuecomment-436855807

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Nov 2018 02:45:20 -0800

Thanks for finding that one @marten-seemann .

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1981#issuecomment-436951972

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Nov 2018 02:45:20 -0800

Closed #1981.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1981#event-1953946141

---

From: Ryegöng Crane <[email-masked]>
Date: Thu, 08 Nov 2018 09:06:51 -0800

Thanks, Mart[ie]n[!duke]

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1981#issuecomment-437079249