Subject: [quicwg/base-drafts] Restore "What packet information to track and send (#1939)" (#1956)

From: Martin Thomson <[email-masked]>
Date: Sat, 03 Nov 2018 04:07:02 -0700

@ianswett, I'm hearing a bunch of negative feedback on this one.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1956

-- Commit Summary --

  * Restore "What packet information to track and send (#1939)"

-- File Changes --

    M draft-ietf-quic-recovery.md (85)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1956.patch
https://github.com/quicwg/base-drafts/pull/1956.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 04:43:10 -0700

ianswett approved this pull request.

I think this looks fine, but isn't this the same PR I just merged?  Confused...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171324900

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 21:36:49 -0700

janaiyengar commented on this pull request.

> @@ -509,6 +509,57 @@ frames containing them could be lost. In this case, the loss recovery algorithm
 may cause spurious retransmits, but the sender will continue making forward
 progress.
 
+## Tracking Sent Packets {#tracking-sent-packets}
+
+QUIC stores information about every packet sent. It's expected implementations

```suggestion
QUIC implementations store information about every packet sent. It is
expected that implementations
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171349568

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:37:45 -0700

@ianswett pushed 1 commit.

6ed3cf0  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/4875ba79f9ea3a33f22ac42dee5a07ba06ee6f25..6ed3cf00d866afbbe1ce94929655df5ef5c017d3

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:39:04 -0700

c036e36  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/6ed3cf00d866afbbe1ce94929655df5ef5c017d3..c036e365d5b7cfb199c7307a59ebb6689cb434c5

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 21:39:28 -0700

+## Tracking Sent Packets {#tracking-sent-packets}
+
+QUIC stores information about every packet sent. It's expected implementations
+will index this information by packet number and crypto context and store the
+per-packet fields detailed below for loss recovery and congestion control.

```suggestion
per-packet fields ({{sent-packet-fields}}) for loss recovery and congestion control.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171349614

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 21:39:48 -0700

```suggestion
will index this information by packet number and crypto context and store
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171349622

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:40:08 -0700

fa9069c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/c036e365d5b7cfb199c7307a59ebb6689cb434c5..fa9069c0b90a89fea13caed8f4cf528ede38eb67

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:42:54 -0700

d4a1036  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/fa9069c0b90a89fea13caed8f4cf528ede38eb67..d4a10361b952c6eb03431daae2627c9714e6d696

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:45:29 -0700

2a012dd  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/d4a10361b952c6eb03431daae2627c9714e6d696..2a012dd5898ce1a4ba5a67fdb90b3b1adc7c7461

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 21:46:12 -0700

> @@ -509,6 +509,56 @@ frames containing them could be lost. In this case, the loss recovery algorithm
 
+## Tracking Sent Packets {#tracking-sent-packets}
+
+QUIC implementations store information about every packet sent. It is expected
+implementations will index this information by packet number and crypto context
+and store the per-packet fields detailed below for loss recovery and congestion
+control.
+
+If a packet is lost, the QUIC transport needs to recover from that loss, such
+as by retransmitting the data, sending an updated frame, or abandoning the
+frame.  For more information, see Section 13.2 of {{QUIC-TRANSPORT}}.
+
+Packets MUST be tracked until acknowledged or lost in order to correctly

```suggestion
Every sent packet MUST be tracked until it is acknowledged or lost to correctly
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171349701

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:48:09 -0700

cfa4bcc  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/2a012dd5898ce1a4ba5a67fdb90b3b1adc7c7461..cfa4bccc3bf65703ade0875df471cdaf7d1c9906

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:50:26 -0700

2a367b0  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/cfa4bccc3bf65703ade0875df471cdaf7d1c9906..2a367b0b288ea1a76756d6c68a0fc93af0d13fa0

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 21:50:39 -0700

> @@ -509,6 +513,52 @@ frames containing them could be lost. In this case, the loss recovery algorithm
 
+Retrasnmittable packets MUST be tracked until acknowledged or lost in order to

Move this first sentence up and replace the first sentence of the section.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171349752

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:53:14 -0700

a3bf689  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/2a367b0b288ea1a76756d6c68a0fc93af0d13fa0..a3bf6890d37e3e6e67e5cdfcfa2848b5ac6b9b2f

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 21:53:34 -0700

b0f4e87  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/a3bf6890d37e3e6e67e5cdfcfa2848b5ac6b9b2f..b0f4e8709d97be28e2e60198211ca9ad8bdd83a5

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 22:00:58 -0700

948807f  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/b0f4e8709d97be28e2e60198211ca9ad8bdd83a5..948807f095c3813f7d3996383e9c979304b98d8f

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 22:07:21 -0700

@janaiyengar pushed 1 commit.

6423b96  mo nits

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/948807f095c3813f7d3996383e9c979304b98d8f..6423b966dc706c68b56f2c5931770ce45d235ca9

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 22:14:00 -0700

c4194e7  grammar

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/6423b966dc706c68b56f2c5931770ce45d235ca9..c4194e7380cb0491a3c5b1d6738fff02ce29d572

---

From: janaiyengar <[email-masked]>
Date: Sat, 03 Nov 2018 22:14:12 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#pullrequestreview-171350053

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 22:14:24 -0700

72af4fc  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956/files/c4194e7380cb0491a3c5b1d6738fff02ce29d572..72af4fc4ec9991f599b2af80c75fdff207c6e30b

---

From: ianswett <[email-masked]>
Date: Sat, 03 Nov 2018 22:17:00 -0700

Merged #1956 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1956#event-1944678373