Subject: [quicwg/base-drafts] Do no define connection as a conversation (#2077)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 30 Nov 2018 05:48:51 -0800

The target audience is not likely to be confused by the use of the term _connection_.  On the other hand, _conversation_ is not defined in this document; it is a superfluous addition.

_Encryption context_ is similarly not defined and the only reference to it removed in this change.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2077

-- Commit Summary --

  * Do no define connection as a conversation

-- File Changes --

    M draft-ietf-quic-transport.md (15)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2077.patch
https://github.com/quicwg/base-drafts/pull/2077.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077

---

From: Marten Seemann <[email-masked]>
Date: Fri, 30 Nov 2018 14:04:50 +0000 (UTC)

marten-seemann requested changes on this pull request.

> @@ -865,11 +861,10 @@ longer if the peer chooses to not send STREAMS_BLOCKED frames.
 
 # Connections {#connections}
 
-A QUIC connection is a single conversation between two QUIC endpoints.  QUIC's
-connection establishment combines version negotiation with the cryptographic
-and transport handshakes to reduce connection establishment latency, as
-described in {{handshake}}.  Once established, a connection may migrate to a
-different IP or port at either endpoint as
+QUIC's connection establishment combines version negotiation with the
+cryptographic and transport handshakes to reduce connection establishment
+latency, as described in {{handshake}}.  Once established, a connection
+may migrate to a different IP or port at either endpoint as

We only specify client-side migration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#pullrequestreview-180278030

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 30 Nov 2018 06:07:48 -0800

dtikhonov commented on this pull request.

 

This is reflowed verbiage: I only made changes related to the "connection is a conversation" bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#discussion_r237871418

---

From: ianswett <[email-masked]>
Date: Fri, 30 Nov 2018 06:10:03 -0800

ianswett approved this pull request.

> @@ -192,14 +192,10 @@ QUIC packet:
 
 Endpoint:
 
-: An entity that can participate in a QUIC conversation by generating,
+: An entity that can participate in a QUIC connection by generating,

```suggestion
: An entity that participates in a QUIC connection by generating,
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#pullrequestreview-180280032

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 30 Nov 2018 06:24:10 -0800

Endpoint:

I thought about `s/can participate/participates/` but then I realized that during the handshake the endpoints send and receive QUIC packets before the connection is established -- perhaps that's why it was written this way.  I also want to limit this change only to the connection/conversation business.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#discussion_r237876363

---

From: ianswett <[email-masked]>
Date: Fri, 30 Nov 2018 06:27:20 -0800

ianswett commented on this pull request.

 Endpoint:

SGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#discussion_r237877286

---

From: Mike Bishop <[email-masked]>
Date: Fri, 30 Nov 2018 09:13:33 -0800

MikeBishop commented on this pull request.

 

@marten-seemann, I think this is an artifact of the effort to specify the migration primitives generically, even if only clients can migrate freely in v1.  Given the SPA mechanism, this is literally true as written, but more constrained that one might infer from this text.  Feel free to open a separate editorial issue for this, but I don't think we should make @dtikhonov fix it in his unrelated PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#discussion_r237935418

---

From: Mike Bishop <[email-masked]>
Date: Fri, 30 Nov 2018 09:13:40 -0800

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#pullrequestreview-180363628

---

From: janaiyengar <[email-masked]>
Date: Fri, 30 Nov 2018 18:04:44 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#pullrequestreview-180506348

---

From: janaiyengar <[email-masked]>
Date: Fri, 30 Nov 2018 18:04:51 -0800

Merged #2077 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2077#event-1999292926