Subject: [quicwg/base-drafts] Add spin bit to transport draft (#1988)

From: Brian Trammell <[email-masked]>
Date: Sat, 10 Nov 2018 08:08:48 -0800

This PR adds the spin bit to the short header in the transport draft, referring to draft-ietf-quic-spin-exp for details. This reference is temporary, while the details of the spin bit are worked out in that document. The intention is then to take the content of spin-exp and incorporate it into the transport and manageability drafts. 

It also changes the status of spin-exp to Standards Track, to avoid a downref from -transport to an Experimental draft.

Note that the details of which bit is the spin bit will change when the first octet discussion resolves; this PR is only meant to establish the reference.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/1988

-- Commit Summary --

  * add spin bit to transport
  * typofix; make spin-exp std

-- File Changes --

    M draft-ietf-quic-spin-exp.md (2)
    M draft-ietf-quic-transport.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/1988.patch
https://github.com/quicwg/base-drafts/pull/1988.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988

---

From: Marten Seemann <[email-masked]>
Date: Sat, 10 Nov 2018 20:53:18 -0800

marten-seemann requested changes on this pull request.

>  Reserved:
 
-: The sixth, seventh, and eighth bits (0x7) of byte 0 are reserved for
+: The seventh and eighth bits (0x3) of byte 0 are reserved for

I don't think we're reserving any more bits for experimentation at this point.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988#pullrequestreview-173684584

---

From: Alexandre Ferrieux <[email-masked]>
Date: Sun, 11 Nov 2018 01:12:47 -0800

ferrieux commented on this pull request.

By un-reserving them you're shorting any hope for other measurement, like loss bits. DO you decide this kind of things single-handedly ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988#discussion_r232479745

---

From: ianswett <[email-masked]>
Date: Sun, 11 Nov 2018 01:20:06 -0800

ianswett commented on this pull request.

The current v1 proposal says to encrypt them.  As such, they'll look like noise.  That's as good a way as any to preserve them for future use, measurement or otherwise.  I don't think added text indicating that is helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988#discussion_r232480001

---

From: Martin Thomson <[email-masked]>
Date: Sun, 11 Nov 2018 21:59:06 -0800

So this will change completely, so what the transport doc says doesn't really matter.  Merging.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988#issuecomment-437765842

---

From: Martin Thomson <[email-masked]>
Date: Sun, 11 Nov 2018 21:59:23 -0800

Merged #1988 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1988#event-1959418224