Subject: Re: [quicwg/base-drafts] Add the TLS bits, refine some of the transport bits (a132666)

From: Alexandre Ferrieux <[email-masked]>
Date: Fri, 16 Nov 2018 01:12:09 -0800

Taking these two reserved bits under the crypto umbrella is a strong brake for future (post-v1) experiments in the area of on-path measurement. Indeed, it may be useful to set up asymmetric experiments where only the server puts some path-observable data in these bits (e.g. loss bits), allowing unexpensive, massive field tests with unmodified clients. That's not possible if (1) the bits are encrypted or (2) the client rejects any nonzero value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/a13266667d30e1fd872375675aab96bf76038f06#commitcomment-31324550

---

From: Nicolas Kuhn <[email-masked]>
Date: Mon, 19 Nov 2018 05:58:47 -0800

Having only one spin bit for in-network measurements make it very hard to identify issues in the network. To do so, you may need loss and latency measurements that can hardly be achieved with a single bit. What is the rationale behind including these bits under the the header protection ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/a13266667d30e1fd872375675aab96bf76038f06#commitcomment-31350384

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Nov 2018 16:26:01 -0800

This is working group consensus.  Take it up with [email-masked] if you disagree, but be prepared for disappointment - the working group has debated this point at considerable length and has recently concluded that discussion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/a13266667d30e1fd872375675aab96bf76038f06#commitcomment-31358462

---

From: MikkelFJ <[email-masked]>
Date: Mon, 19 Nov 2018 17:59:23 -0800

@NicoKos Have you seen the paper by Trammel et al? In most circumstances one bit is sufficient, and 3 bits are better but not enough to justify the complexity and probably also not the potential security implications of extra exposure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/a13266667d30e1fd872375675aab96bf76038f06#commitcomment-31359057