Subject: [quicwg/base-drafts] Don't let the PMTU drop below 1280 (#2069)

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Nov 2018 19:58:47 -0800

The loss of packets on the path will be the signal that we use here.

Closes #2063.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2069

-- Commit Summary --

  * Don't let the PMTU drop below 1280

-- File Changes --

    M draft-ietf-quic-transport.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2069.patch
https://github.com/quicwg/base-drafts/pull/2069.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069

---

From: Marten Seemann <[email-masked]>
Date: Wed, 28 Nov 2018 20:01:10 -0800

marten-seemann commented on this pull request.

> @@ -3100,9 +3100,11 @@ Further validation can also be provided:
   use for validation (for example, the IP ID or UDP checksum).
 
 The endpoint SHOULD ignore all ICMP messages that are not validated or do not
-carry sufficient quoted packet payload to perform validation.  Any reduction in
-the QUIC maximum packet size MAY be provisional until QUIC's loss detection
-algorithm determines that the quoted packet has actually been lost.
+carry sufficient quoted packet payload to perform validation.  ICMP messages
+that suggest that the PMTU has decreased below 1280 bytes SHOULD also be

Why only a SHOULD? We say that QUIC depends on a PMTU of at least 1280 bytes, so I think a MUST would be justified here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069#pullrequestreview-179621200

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Nov 2018 20:59:27 -0800

martinthomson commented on this pull request.

Oops, forgot to checkin my second pass.  I had exactly the same thought.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069#discussion_r237353454

---

From: Marten Seemann <[email-masked]>
Date: Wed, 28 Nov 2018 21:06:17 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069#pullrequestreview-179630071

---

From: ianswett <[email-masked]>
Date: Thu, 29 Nov 2018 11:51:58 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069#pullrequestreview-179984317

---

From: Martin Thomson <[email-masked]>
Date: Thu, 29 Nov 2018 14:48:34 -0800

Merged #2069 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2069#event-1996615599