Subject: [quicwg/base-drafts] Test vectors (#2274)

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Dec 2018 17:01:44 -0800

This takes @rpaulo's example and expands on it, hopefully without destroying it.

In summary:

* the output is condensed a little, which keeps the giant client Initial somewhat more in check
* added formula and variable names consistent with the rest of the spec for context
* added packet protection

The known bug here is that the ClientHello doesn't include transport parameters.  The ServerHello should be OK.  And I think that the ACK is correct also.  I did try to get the connection IDs and packet numbers correct.

I would appreciate someone checking my work.  I don't have a convenient method of testing this.

Closes #1573.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2274

-- Commit Summary --

  * Add an appendix containing test vectors for "Initial".
  * Merge remote-tracking branch 'upstream/master' into test-vectors-initial
  * Fix a problem with the encoded labels.
  * Lint checks.
  * Merge remote-tracking branch 'upstream/master' into test-vectors-initial
  * Update sample vector to match draft 17.
  * Improve formatting, add more context, add packets

-- File Changes --

    M draft-ietf-quic-tls.md (198)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2274.patch
https://github.com/quicwg/base-drafts/pull/2274.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2274

---

From: Benjamin Saunders <[email-masked]>
Date: Sun, 30 Dec 2018 19:46:59 -0800

I've independently replicated the key derivation and the server initial encryption given here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2274#issuecomment-450605367

---

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Dec 2018 23:05:33 -0800

Another question: would checking in the script I used to produce these be helpful for anyone?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2274#issuecomment-450614614