Subject: [quicwg/base-drafts] Recomment sending a token (#2121)

From: ekr <[email-masked]>
Date: Wed, 12 Dec 2018 06:29:10 -0800

S 8.1.2 says

```
If the client has a token received in a NEW_TOKEN frame on a previous connection
to what it believes to be the same server, it can include that value in the
Token field of its Initial packet.
```

Shouldn't this "can" be a SHOULD

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2121

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Dec 2018 14:57:49 -0800

Ugh.  SHOULD would be added to promote interoperability or some other thing we value.  There's no interop hazard if the token isn't added.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2121#issuecomment-446776073

---

From: janaiyengar <[email-masked]>
Date: Wed, 12 Dec 2018 18:25:36 -0800

It does make sense to say SHOULD if we want to encourage lower connection establishment latency, which we do (we state this as one of QUIC's features). I'd be fine with a SHOULD here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2121#issuecomment-446819251