Subject: [quicwg/base-drafts] Clarification on Setting the Loss Detection Timer in the loss recovery draft (#2093)

From: Nasif Ekiz <[email-masked]>
Date: Mon, 03 Dec 2018 21:01:18 +0000 (UTC)

Setting the Loss Detection Timer section states:

    // Don't arm timer if there are no retransmittable packets
    // in flight.
    if (bytes_in_flight == 0):
      loss_detection_timer.cancel()
      return

If a QUIC sender sends multiple retransmittable packets and some ACK/PADDING packets and only retransmittable packets are ACKed, it leaves the bytes_in_flight > 0 but no retransmittable packets inflight. In this case, Loss Detection Timer need not be scheduled as there is not retransmittable packets inflight but the above check results in scheduling the timer again.

if (bytes_in_flight == 0): check does not seem enough by itself to decide if there are outstanding retransmittable packets. Do we need to update that section? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2093

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 17:23:09 -0800

@nekiz : Good point. You are right that the timer should only be running when there are retransmittable packets outstanding. 

I have a few changes underway right now, but I'd like to wait until those land before addressing this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2093#issuecomment-443933879

---

From: ianswett <[email-masked]>
Date: Mon, 17 Dec 2018 18:46:57 -0800

Closed #2093 via #2117.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2093#event-2031894139