Subject: [quicwg/base-drafts] High BDP and adapted congestion control (#2091)

From: Nicolas Kuhn <[email-masked]>
Date: Mon, 03 Dec 2018 01:17:56 -0800

In the context of high BDP networks, inadequate congestion control and its initial parameterization can result in very low QoE. 
As shown at IETF103, the web page download time can double with Google-QUIC as opposed to using tuned TCP proxy. 
We should let the QUIC server know that we are on a high BDP network. 
One solution would be to set the IW to a higher value (along with pacing) but other adaptations could be relevant. 
This issue could be relevant to other networks (data-centers, DOCSIS).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2091

---

From: ianswett <[email-masked]>
Date: Mon, 03 Dec 2018 18:41:31 -0800

I agree this is a problem, but I'm very unsure what the WG can do about it.  Can you provide some specific suggestions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2091#issuecomment-443949149

---

From: Nicolas Kuhn <[email-masked]>
Date: Tue, 04 Dec 2018 05:08:59 -0800

I wonder whether we should ask for specific parameter (such as the IW value - and above a certain threshold pacing msut be considered) or a more generic parameter saying 'you are on a high BDP network'. 
Those could be transport parameters, such as discussed in https://tools.ietf.org/html/draft-ietf-quic-transport-16#section-22.1 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2091#issuecomment-444093797

---

From: janaiyengar <[email-masked]>
Date: Tue, 11 Dec 2018 15:13:41 -0800

At the moment, endpoints are free to choose an alternate congestion controller. Let's open this issue again when there is a specific controller with a specific transport parameter that is needed for it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2091#issuecomment-446398971

---

From: janaiyengar <[email-masked]>
Date: Tue, 11 Dec 2018 15:13:41 -0800

Closed #2091.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2091#event-2020125192