Subject: [quicwg/base-drafts] RESET_STREAM.final_offset is ambiguous (#2262)

From: Kazuho Oku <[email-masked]>
Date: Wed, 26 Dec 2018 17:32:58 -0800

Current definition of "Final Offset" is: _a variable-length integer indicating the absolute byte offset of the end of data written on this stream by the RESET_STREAM sender._

This is not crisp-clear; if it means the maximum offset among the byte being sent, or number of bytes that has been sent excluding overlaps (due to retransmissions). Of course, we want to specify the latter; otherwise, you cannot send RESET_STREAM before even sending a single byte of data.

Maybe it's worth considering using the term "Maximum Stream Data" instead, that we now use for MAX_STREAM_DATA.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2262

---

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Dec 2018 18:09:20 -0800

Happy to look at a PR.  Though "Max[imum] Stream Data" is a limit, so it might be confusing if it were also used to refer to the used amount as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2262#issuecomment-450601397

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 30 Dec 2018 20:58:54 -0800

> Though "Max[imum] Stream Data" is a limit, so it might be confusing if it were also used to refer to the used amount as well.

Agreed. Maybe something like "Committed Bytes"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2262#issuecomment-450608504