Subject: Re: [quicwg/base-drafts] Why are error codes not a varint? (#1940)

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Dec 2018 21:40:29 -0800

I'm going to suggest that the statute of limitations has expired on this one.  Does anyone want to drive this, or should I close it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446848983

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 12 Dec 2018 22:01:21 -0800

My not-so-strong preference goes to closing the issue. It's not a bug to use uint16_t, this issues should not block -17, once -17 ships we should only make changes that are essential for the protocol to work correctly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446852260

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Dec 2018 22:05:14 -0800

Right.  That's my thinking also.  Though I don't think that -17 will be as firm as you might have liked, unless we decide to reject some of the proposals we have in flight.  I personally want to reject a lot of those, but we'll see how that goes.  Current plan is to ship 24 hours.  I'll hold this open until then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446852879

---

From: Marten Seemann <[email-masked]>
Date: Wed, 12 Dec 2018 22:29:19 -0800

I'm ok with closing this issue. I just wanted to make sure that this is a deliberate decision we're making.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446857264

---

From: MikkelFJ <[email-masked]>
Date: Thu, 13 Dec 2018 01:07:14 -0800

Are there any big endian integer encoding besides error codes and TP? I think the compelling case would be if QUIC has NO big endian encoding at all. Otherwise it is a matter of taste.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446893704

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 13 Dec 2018 01:26:27 -0800

Packet numbers are big endian. Also, IIRC we discussed about endian in IETF 98 (maybe) and we concluded to use big endian.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446899619

---

From: MikkelFJ <[email-masked]>
Date: Thu, 13 Dec 2018 09:39:51 +0000 (UTC)

I'm not arguing against big endian per se (well I would, in a separate discussion), but the endianness is a moot point if all encodings are opaque or varint - and it would be nice to sidestep that discussion if there are only a few hold-outs left.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-446903714

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 15:22:44 -0800

Versions are fixed size also.  Packet numbers are similarly special.

Thanks all.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#issuecomment-447157450

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 15:22:45 -0800

Closed #1940.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1940#event-2025601795