Subject: [quicwg/base-drafts] Limit sending while in RTO (#2162)

From: janaiyengar <[email-masked]>
Date: Thu, 13 Dec 2018 13:49:57 -0800

A sender might have unused cwnd left when it enters the RTO phase of recovery. The spec currently does not prohibit sending under these conditions. In other words, a sender that is RTOing might suddenly send a cwnd's worth of data. We may want to disallow this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2162

---

From: ianswett <[email-masked]>
Date: Mon, 24 Dec 2018 10:25:03 -0800

Personally, I haven't seen many cases in traces where this is a problem, so I'd be inclined to leave the text as is.

One could validly use this CWND to be more aggressive about PTO, as you've previously suggested to me, and  I wouldn't want to prevent that use case.

We could add text that allows more aggressive PTOs than described when CWND is available, but prevent using this CWND after the first full PTO is sent?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2162#issuecomment-449761566