Subject: Re: [quicwg/base-drafts] Why ignore MAX_STREAM_DATA or MAX_DATA that don't increase the flow control limits (#2082)

From: MikkelFJ <[email-masked]>
Date: Sat, 01 Dec 2018 00:38:05 -0800

It would be wasteful to track all that state for very little benefit. Reordering us likely, invalid max sequencing less so. For future multipath it would get complicated.

A peer could also schedule packets out of order due to concurrent pipelines, so checking PN could be damaging.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443410379

---

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Dec 2018 19:39:48 +0000 (UTC)

Also because a naive implementation that just blindly retransmitted frames from lost packets would then be invalid, rather than simply unoptimized.  While that behavior isn't something we want to encourage, it's not clear that we want to outlaw it, either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443842295

---

From: ekr <[email-masked]>
Date: Mon, 03 Dec 2018 20:01:22 +0000 (UTC)

I don't find this persuasive, but as I said, I recognize I'm in the rough. Regardless, if that's the behavior we want, the text needs some rework

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443849879

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 03 Dec 2018 21:40:48 +0000 (UTC)

> It's consistent with our decision elsewhere that frames which are valid when sent remain valid for the duration of the connection no matter how delayed (though they might get ignored as irrelevant).

FWIW, I am not sure if all the frames have such property; retransmitting an ACK frame is not a good idea because you would have an incorrect value in the ack delay field...

However I do agree that retransmission of MAX_* frames should be allowed. Or put it another way, I do not think that the endpoints should be mandated to detect rollback of max values in the succeeding frames and call that an error. It's something not easy to implement when reordering is involved.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443880681

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 17:18:37 -0800

@ekr: Is the text you've proposed above your suggested rewording? That's not enough, because it doesn't capture what the sender needs to do when it receives a frame out of order. I'm happy to put together a PR but I'm not sure what you are after.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-443932966

---

From: Mike Bishop <[email-masked]>
Date: Tue, 04 Dec 2018 17:52:38 +0000 (UTC)

I think the requirement on the sender is still correct.  Regardless of where it occurs (packet scheduling, retransmission, or wire), this is fundamentally a statement about reordering tolerance on the recipient of MAX(_STREAM)?_DATA, which is the sender of data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-444193899

---

From: ekr <[email-masked]>
Date: Tue, 11 Dec 2018 17:51:38 -0800

@janaiyengar that was intended as an addition, I agree you still need to say ignore.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#issuecomment-446431473

---

From: janaiyengar <[email-masked]>
Date: Wed, 12 Dec 2018 21:57:44 -0800

Closed #2082 via #2136.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2082#event-2023343111