Subject: Re: [quicwg/base-drafts] Recovery uses both time and packet thresholds (#1974)

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 18:51:41 -0800

@janaiyengar pushed 9 commits.

86cb551026bbe831f73b7ccf5dbf82a0cafa974e  Editorial rework
e8ae5ad0bd8e7ae4b72c26e9c5a08ada7791f300  lint
6ad1106e093e75e2413a19733bca12ac8a41531e  clean up RACK reference
1088bb6e26d782d13ee05b85aa2985111ee33c5c  more changes
8a695c9e94c50c800ef44ed1f0153a6fc68bce6e  Update draft-ietf-quic-recovery.md
006843e6dd84ca4a6123814deac552c7fdb2a716  Ian comments
d0959523e25f3958808ce205c68a2bb066737334  edit
000f6127997a5836baf513180cfbd7b64f10bf17  lint
8b42d9539890e986a485f2d76c00ea3d5306715c  Merge pull request #2080 from quicwg/editorial-changes

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1974/files/ddfe711e11ce216154b7b566433e5ebb12dcb97a..8b42d9539890e986a485f2d76c00ea3d5306715c

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 19:00:12 -0800

@janaiyengar pushed 1 commit.

a06d6797096e1e0475db2993e2df5a93525e07f0  small fix

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1974/files/8b42d9539890e986a485f2d76c00ea3d5306715c..a06d6797096e1e0475db2993e2df5a93525e07f0

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 19:05:55 -0800

Merged #1974 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1974#event-2003170233

---

From: MikkelFJ <[email-masked]>
Date: Tue, 04 Dec 2018 03:42:47 -0800

I'm late on this. But two questions:

1) Should not `delay_until_lost` include peers ack delay? If you have a very fast network a nearby peer may have larger delay than the RTT.

2) Should not the `delta` in pseudocode for detecting lost packets by packet number take gaps into consideration. Notably gaps are used for optimistic ACK protection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1974#issuecomment-444071455