Subject: [quicwg/base-drafts] Handling failed migration (#2131)

From: ekr <[email-masked]>
Date: Wed, 12 Dec 2018 09:01:46 -0800

S 9.3. says:

```
After changing the address to which it sends non-probing packets, an endpoint
could abandon any path validation for other addresses.
```

And 9.3.2. says:
```
Note that receipt of packets with higher packet numbers from the legitimate peer
address will trigger another connection migration.  This will cause the
validation of the address of the spurious migration to be abandoned.
```

Which one of these is right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2131

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Dec 2018 09:48:27 -0800

I'm not seeing the conflict -- they seem to work in concern.  Can you explain the failure mode in more detail?  In what circumstance do these instruct the server to do contradictory things?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2131#issuecomment-446679047

---

From: ekr <[email-masked]>
Date: Wed, 12 Dec 2018 11:22:41 -0800

The first paragraph says that you *could* abandon validation and the other says that you *will* abandon it. If you *could* abandon it, then you also are allowed no to,

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2131#issuecomment-446711421

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Dec 2018 16:22:17 -0800

Yeah, this is a problem.  I think that the latter needs to change.  We want to allow paths to be validated at any time for any reason.

The consequence is that a spurious migration might continue being validated, but as long as it isn't actively *used*, we have a defense.  There might need to be some tweaking of the surrounding text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2131#issuecomment-446795313