Subject: [quicwg/base-drafts] Rename ACK block something else? (#2178)

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 16:49:46 -0800

An ACK frame currently consists of:

- A header
- An ACK block count (N)
- A field called ACK blocks which consists of
   - A single field called "First ack block" (if N > 0)
   - N-1 repeats of a pair of fields called respectively "gap" and "Additional ACK block"

(Please correct me if I have misread this).

It's a bit weird to call these fields "blocks" because really they are the length of something, rather than a block. Perhaps "ACK Range"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2178

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 17:23:42 -0800

This is approximately correct.  I don't like this layout, but that's the basic format

The first ack block/range is always present so I think we should move the description of that out of the ranges.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2178#issuecomment-447180602

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 17:26:00 -0800

I see, I misread.

```
   Each ACK Block acknowledges a contiguous range of packets by
   indicating the number of acknowledged packets that precede the
   largest packet number in that block.  A value of zero indicates that
   only the largest packet number is acknowledged.  Larger ACK Block
```

So, actually, it's N repeats.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2178#issuecomment-447180992

---

From: janaiyengar <[email-masked]>
Date: Fri, 14 Dec 2018 17:51:02 -0800

How about "ack range" and "missing range"?

I like the idea of moving the "First ack block" out of the "ack block"
section and into the fixed section. Ack Block Count refers to the number of
Gaps+AckBlocks anyways, so that would work out fine, I think.

On Thu, Dec 13, 2018 at 5:26 PM ekr <[email-masked]> wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2178#issuecomment-447180992>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1KckOFO2rLvcBWx48FpAKBW-TT9fks5u4v4ogaJpZM4ZSsP6>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2178#issuecomment-447527089