Subject: [quicwg/base-drafts] Varint h3 unidirectional stream types (#2275)

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Dec 2018 17:10:12 -0800

Continuing on from #2253, I realized that the spontaneous push example might be something better supported by a unidirectional stream.  And here, the same arguments about uncoordinated, spontaneous use apply.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2275

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 30 Dec 2018 17:33:03 -0800

That's how my h3 extension worked, reserving 0xTBD.

This would have the effect of changing the current stream type greasing 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2275#issuecomment-450599767

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 31 Dec 2018 06:19:05 -0800

I'll support this if the current stream types in HTTP/3 and QPACK get values of 63 or smaller, making the encodable in a single byte.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2275#issuecomment-450650740

---

From: Martin Thomson <[email-masked]>
Date: Mon, 31 Dec 2018 17:50:34 -0800

Yes, that would be the only sensible plan, as it was with QUIC frame types.  These are important enough to spec at the beginning, so we take prime positions.  I would also recommend the same registration rules: to 0x3f = Standards Action or IESG Review, to 0x3fff = Specification Required, all other values = Private Use.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2275#issuecomment-450704422