Subject: [quicwg/base-drafts] Packet Number encoding in draft-17 (#2217)

From: Yang Chi <[email-masked]>
Date: Thu, 20 Dec 2018 11:31:29 -0800

In Section 12.3, the transport specs says: 

> Where present, packet numbers are encoded as a variable-length integer (see Section 16). 

But in both 17.2 (Long Header) and 17.3 (Short Header), Packet Number field in the packet is noted as the following format:
> Packet Number (8/16/24/32)
which suggest it isn't variable-length integers.

Can we get some clarification regarding this? Thank you!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2217

---

From: janaiyengar <[email-masked]>
Date: Thu, 20 Dec 2018 12:20:26 -0800

Section 17.2/17.3 is correct -- PNs are _not_ encoded using the varint form in Sec 16.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2217#issuecomment-449123704

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 17:52:00 -0800

Closed #2217 via #2218.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2217#event-2039817368