Subject: [quicwg/base-drafts] Embed QUIC version in expansion (#2170)

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 23:54:02 +0000 (UTC)

This may duplicate a previous issue, but there has been a lot of aggressive closing. Instead of using "quic hp", etc. we should use a label that reflects the QUIC version. Assuming I am counting correctly, we can do:

"qxxxxxxxx hp" where xx is the version in hex.

This would match TLS practice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2170

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 21:21:48 -0800

My expectation was that we would have "quic" and then "quic2", etc...  Maybe that doesn't have the effect that is desired, because it's less obvious, but I prefer to proceed as though this were the only version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2170#issuecomment-447217066

---

From: ianswett <[email-masked]>
Date: Fri, 14 Dec 2018 11:29:23 -0800

Martin's suggested plan SGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2170#issuecomment-447429942

---

From: ekr <[email-masked]>
Date: Fri, 14 Dec 2018 22:02:13 +0000 (UTC)

I don't strongly object, but it seems like if we know this is v1, we might want to indicate that, but ultimately I agree it's a matter of taste

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2170#issuecomment-447492212