Subject: [quicwg/base-drafts] Clarify In-flight (#2200)

From: ianswett <[email-masked]>
Date: Mon, 17 Dec 2018 08:47:24 -0800

I'm not sure this is necessary, but I've had at least 2 people be unsure about whether a packet is still in flight if all the stream data in it is cancelled, so maybe it's worth stating this explicitly?
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2200

-- Commit Summary --

  * Clarify In-flight

-- File Changes --

    M draft-ietf-quic-recovery.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2200.patch
https://github.com/quicwg/base-drafts/pull/2200.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200

---

From: MikkelFJ <[email-masked]>
Date: Mon, 17 Dec 2018 08:54:31 -0800

mikkelfj commented on this pull request.

> @@ -102,7 +102,8 @@ In-flight:
 
 : Packets are considered in-flight when they have been sent
   and neither acknowledged nor declared lost, and they are not
-  ACK-only.
+  ACK-only.  Packets are still considered in-flight even if
+  their payloads no longer need to be delivered.

```suggestion
  their payloads no longer need to be delivered in order to maintain the congestion window.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#pullrequestreview-185691846

---

From: ianswett <[email-masked]>
Date: Mon, 17 Dec 2018 11:45:32 -0800

ianswett commented on this pull request.

I'm confused about what you're trying to add here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#discussion_r242290619

---

From: MikkelFJ <[email-masked]>
Date: Mon, 17 Dec 2018 12:26:31 -0800

Maybe I got the in-flight concept wrong, but in order to make the definition significant, there must be a reason for it, otherwise it is just semantics. I.e. why does it matter whether.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#discussion_r242303874

---

From: ianswett <[email-masked]>
Date: Mon, 17 Dec 2018 20:29:41 +0000 (UTC)

In-flight packets count towards bytes in flight, which is defined in the pseudocode section, but we could move that definition up here if it's helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#discussion_r242304847

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Dec 2018 08:56:51 +0000 (UTC)

martinthomson commented on this pull request.

I'm not sure that this is necessary or even helpful.  If we accept that information is what is repaired, rather than packets or frames, then we don't need to concern ourselves with this clarification.  To that end, packets are disposable, just as frames are.  What matters here is that packets are neither lost nor acknowledged, which the existing text covers nicely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#pullrequestreview-185959986

---

From: ianswett <[email-masked]>
Date: Tue, 18 Dec 2018 18:36:29 -0800

@ianswett pushed 1 commit.

66f455dbab18e52f2eb82cf87a7687cc22c8df35  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200/files/49ecfc025ac2dcb87f93ff10f88d92be9908e965..66f455dbab18e52f2eb82cf87a7687cc22c8df35

---

From: ianswett <[email-masked]>
Date: Tue, 18 Dec 2018 18:40:41 -0800

I updated this to be a clarifying example, which I think is more helpful than re-iterating the previous sentence.  PTAL.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#issuecomment-448448955

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Dec 2018 19:20:21 -0800

> @@ -102,7 +102,9 @@ In-flight:
 
 : Packets are considered in-flight when they have been sent
   and neither acknowledged nor declared lost, and they are not
-  ACK-only.
+  ACK-only.  For example, packets containing STREAM frames are

I think that the "for example" is missing context.  Perhaps:

> : Packets are considered in-flight when they have been sent and neither acknowledged nor declared lost.  ACK-only packets are not considered in-flight, though all other packets are, including packets that contain data that would not otherwise be sent again, such as a packet containing only STREAM frames for a reset stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#pullrequestreview-186374476

---

From: ianswett <[email-masked]>
Date: Tue, 18 Dec 2018 19:45:59 -0800

That works for me.  @janaiyengar what do you think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#discussion_r242783772

---

From: ianswett <[email-masked]>
Date: Wed, 19 Dec 2018 13:23:13 -0800

372ac1c098acf3270b5435eef3172c17d1fbc93c  in_flight, not ack_eliciting

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200/files/66f455dbab18e52f2eb82cf87a7687cc22c8df35..372ac1c098acf3270b5435eef3172c17d1fbc93c

---

From: ianswett <[email-masked]>
Date: Wed, 19 Dec 2018 13:25:21 -0800

After starting to add this in, I don't think it reads as clearly as I'd like, so I didn't.  However, I did fix an error in the pseudocode below involving ACK-only packets not being considered in-flight.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#discussion_r243080528

---

From: ianswett <[email-masked]>
Date: Fri, 21 Dec 2018 13:22:46 -0800

Closed #2200.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#event-2041676557

---

From: ianswett <[email-masked]>
Date: Fri, 21 Dec 2018 13:22:47 -0800

I fixed the pseudo-code issue in #2219 so I'm going to close this, since I think it's doing more harm than good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2200#issuecomment-449501592