Subject: Re: [quicwg/base-drafts] Client port for new connections (#2061)

From: Kazuho Oku <[email-masked]>
Date: Sun, 02 Dec 2018 17:34:35 -0800

I think the fear we have with QUIC is that some NATs are going to run out of UDP ports, or that they would be reusing ports at a rate so fast that we would be seeing involuntary migrations with connections that are idle for just a small fraction of time.

Reusing the client-side tuple for multiple connections do mitigate the issue.

The trade-off here is the privacy concern that @martinthomson pointed out. I agree that it is a concern, however I might also argue that hiding who's behind does not have a practical benefit for small NATs (e.g. home routers). And huge NATs (e.g. carrier-grade) might have an observer within the NAT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2061#issuecomment-443563374

---

From: hardie <[email-masked]>
Date: Mon, 03 Dec 2018 14:08:23 -0800

On Sun, Dec 2, 2018 at 5:34 PM Kazuho Oku <[email-masked]> wrote:

> I think the fear we have with QUIC is that some NATs are going to run out
> of UDP ports, or that they would be reusing ports at a rate so fast that we
> would be seeing involuntary migrations with connections that are idle for
> just a small fraction of time.
>
> Given that there is sparse data on this, I tend to support
@martinthomson's view that we ought to let practice emerge here rather than
trying to specify it.  Getting the right behavior for small NATs,
enterprises, and CGNs may not be one-size fits all for these trade offs.

regards,

Ted

> The trade-off here is the privacy concern that @martinthomson
> <https://github.com/martinthomson> pointed out. I agree that it is a
> concern, however I might also argue that hiding who's behind does not have
> a practical benefit for small NATs (e.g. home routers). And huge NATs (e.g.
> carrier-grade) might have an observer within the NAT.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2061#issuecomment-443563374>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABVb5NX-YqodGcamKlUksQIS36HGa2Q_ks5u1H-pgaJpZM4Y29B6>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2061#issuecomment-443889007

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 17:11:27 -0800

My concern was what @kazuho mentions.  There's anecdotal data that NATs are less generous with UDP ports than they are with TCP ports, and there is a scaling concern with QUIC because of that.

I'm not particularly concerned about linkability concerns here because multiple connection IDs can be used within a connection, and that is something we might want to encourage in general.

That said, the counterpoints raised here are good ones. I am fine with not specifying this in the draft, and seeing how best practices evolve.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2061#issuecomment-443931582

---

From: janaiyengar <[email-masked]>
Date: Tue, 11 Dec 2018 15:15:33 -0800

I don't think there's interest in adding any recommendations, so I'll close this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2061#issuecomment-446399376

---

From: janaiyengar <[email-masked]>
Date: Tue, 11 Dec 2018 15:15:34 -0800

Closed #2061.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2061#event-2020127956