Subject: Re: [quicwg/base-drafts] Stream terminology (#2081)

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Dec 2018 11:37:30 -0800

(For those following along at home, this is the transport draft.)

3.0 states:
> Unidirectional streams use the applicable state machine directly. **Bidirectional streams use both state machines.** For the most part, the use of these state machines is the same whether the stream is unidirectional or bidirectional. The conditions for opening a stream are slightly more complex for a bidirectional stream because the opening of either send or receive sides causes the stream to open in both directions.

I think it's actually perfectly reasonable to consider a bidirectional stream as consisting of two unidirectional streams with some limited ways that one stream's state change can cause the other stream's state change.  However, it's probably worth making sure the terminology is consistent throughout.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2081#issuecomment-443841539

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Dec 2018 20:08:22 -0800

Closed #2081 via #2242.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2081#event-2042722631