Subject: [quicwg/base-drafts] TLP and RTO arbitrariness (#2166)

From: janaiyengar <[email-masked]>
Date: Thu, 13 Dec 2018 22:30:31 +0000 (UTC)

There is some arbitrariness around TLP, RTO, and crypto timeouts  as they are described in the draft. 

- TLP computation includes smoothed_rtt but not rttvar, where RTO includes both. There's no clear rationale for not using rttvar in TLP.  This is what the TLP draft (individual, expired) says and what Linux TCP implements, but there's little justification beyond that. rttvar should be included here.
- minTLP is 10ms and minRTO is 200ms. This choice of 10ms is a bit arbitrary, but is based on what Linux TCP implements.
- The crypto timeout uses minTLP, which does not seem intuitive.

We should include rttvar in TLP, and we should either justify the 10ms min timeout or use the same 200ms timeout for TLP.  We should also use a different min for the crypto timeout than min TLP.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2166

---

From: janaiyengar <[email-masked]>
Date: Fri, 14 Dec 2018 17:59:44 -0800

Closed #2166 via #2114.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2166#event-2028260159