Subject: [quicwg/base-drafts] Can I send non-data frames on CONNECT streams? (#2229)

From: ekr <[email-masked]>
Date: Thu, 20 Dec 2018 15:08:47 -0800

S 5.2.

Can you send anything other than DATA on a CONNECT stream?

```
All DATA frames on the stream correspond to data sent or received on the TCP
connection. Any DATA frame sent by the client is transmitted by the proxy to the
TCP server; data received from the TCP server is packaged into DATA frames by
the proxy. Note that the size and number of TCP segments is not guaranteed to
map predictably to the size and number of HTTP DATA or QUIC STREAM frames.
```

You don't say that I can't send anything else, but you don't say
I can't either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 18:28:14 -0800

It doesn't *mean* anything (because we haven't assigned semantics), but we should probably just forbid the use of other frames (of those defined in this document).  This is probably a shortcoming of 7540 as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229#issuecomment-449219525

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 20 Dec 2018 18:41:50 -0800

Wouldn’t it be better to just prohibit the HEADERS stream?

We might want to introduce a frame that changes the priority of a stream (e.g., max bitrate). I do not think there’s a strong reason to forbid such kind of extensions only on CONNECT stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229#issuecomment-449221731

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 20:14:55 -0800

I don't want to prohibit extension frames, but the frames defined in the current spec don't serve any purpose.  That is why I said "of those defined in this document".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229#issuecomment-449240901