Subject: [quicwg/base-drafts] Clarify packet number representation (#2218)

From: janaiyengar <[email-masked]>
Date: Thu, 20 Dec 2018 13:02:04 -0800

Closes #2217.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2218

-- Commit Summary --

  * Clarify packet number representation

-- File Changes --

    M draft-ietf-quic-tls.md (2)
    M draft-ietf-quic-transport.md (16)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2218.patch
https://github.com/quicwg/base-drafts/pull/2218.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218

---

From: janaiyengar <[email-masked]>
Date: Thu, 20 Dec 2018 13:03:08 -0800

@janaiyengar pushed 1 commit.

ff67c2f39cd9085b6f5854720841b3bb5be3c388  nit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218/files/6980d7b25048d53a9c5ca16729d3767d424ae761..ff67c2f39cd9085b6f5854720841b3bb5be3c388

---

From: Subodh Iyengar <[email-masked]>
Date: Thu, 20 Dec 2018 13:06:46 -0800

siyengar commented on this pull request.

> @@ -3297,9 +3300,10 @@ value of fields.
 
 ## Packet Number Encoding and Decoding {#packet-encoding}
 
-Packet numbers in long and short packet headers are encoded in 1 to 4 bytes.
-The number of bits required to represent the packet number is reduced by
-including the least significant bits of the packet number.
+Packet numbers are integers in the range 0 to 2^62-1 ({{packet-numbers}}).  When
+present in long or short packet headers, they are encoded in 1 to 4 bytes.  The

do we have to say here that they are big endian encoded?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218#pullrequestreview-187184556

---

From: janaiyengar <[email-masked]>
Date: Thu, 20 Dec 2018 21:09:49 +0000 (UTC)

janaiyengar commented on this pull request.

 

We say that at the top, [here](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#packet-formats).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218#discussion_r243418494

---

From: ianswett <[email-masked]>
Date: Thu, 20 Dec 2018 13:34:40 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218#pullrequestreview-187193949

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 17:52:01 -0800

Merged #2218 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2218#event-2039817362