Subject: [quicwg/base-drafts] Congestion window reduced on ACK (#2244)

From: janaiyengar <[email-masked]>
Date: Fri, 21 Dec 2018 12:29:07 -0800

Closes #2243.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2244

-- Commit Summary --

  * Congestion window reduced on ACK

-- File Changes --

    M draft-ietf-quic-recovery.md (23)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2244.patch
https://github.com/quicwg/base-drafts/pull/2244.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244

---

From: janaiyengar <[email-masked]>
Date: Fri, 21 Dec 2018 12:31:20 -0800

@janaiyengar pushed 1 commit.

92a6dcf5e34fda818fe4e96be2602f62b71c31c8  some more work

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244/files/3902222bc38670e7521ffdff7274d2d61eb440ae..92a6dcf5e34fda818fe4e96be2602f62b71c31c8

---

From: ianswett <[email-masked]>
Date: Fri, 21 Dec 2018 13:07:52 -0800

ianswett approved this pull request.

Thanks for fixing this.  Some editorial suggestions, but LG otherwise.

> @@ -1023,15 +1027,13 @@ kLossReductionFactor:
   The RECOMMENDED value is 0.5.
 
 kPersistentCongestionThreshold:
-: Number of consecutive PTOs after which network is considered to be
+: Number of consecutive PTOs after which network might be considered to be

```suggestion
: Number of consecutive PTOs after which the network is considered to be
```

I prefer "is" instead of "might be" given you already have considered.

>    experiencing persistent congestion.  The rationale for this threshold is to
-  enable a sender to use initial PTOs for aggressive probing, similar to Tail
-  Loss Probe (TLP) in TCP {{TLP}} {{RACK}}.  Once the number of consecutive PTOs
-  reaches this threshold - that is, persistent congestion is established - the
-  sender responds by collapsing its congestion window to kMinimumWindow, similar
-  to a Retransmission Timeout (RTO) in TCP {{RFC5681}}.  The RECOMMENDED value
-  for kPersistentCongestionThreshold is 2, which is equivalent to having two
-  TLPs before an RTO in TCP.
+  enable a sender to use initial PTOs for aggressive probing, as TCP does with
+  Tail Loss Probe (TLP) {{TLP}} {{RACK}}, before establishing persistent
+  congestion, as TCP does with a Retransmission Timeout (RTO) {{?RFC5681}}.  The
+  RECOMMENDED value for kPersistentCongestionThreshold is 2, which is equivalent
+  to having two TLPs before an RTO in TCP.

```suggestion
  to two TLPs before an RTO in TCP.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244#pullrequestreview-187538518

---

From: janaiyengar <[email-masked]>
Date: Fri, 21 Dec 2018 13:20:00 -0800

janaiyengar commented on this pull request.

I don't want to say "is" because that implies that persistent congestion has happened. As Marten notes, that is only done when the ACK is received.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244#discussion_r243694637

---

From: janaiyengar <[email-masked]>
Date: Fri, 21 Dec 2018 13:20:08 -0800

d21fbb46ef58134513dec3e19f5d07a95b517e61  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244/files/92a6dcf5e34fda818fe4e96be2602f62b71c31c8..d21fbb46ef58134513dec3e19f5d07a95b517e61

---

From: ianswett <[email-masked]>
Date: Fri, 21 Dec 2018 13:26:16 -0800

ianswett commented on this pull request.

I think "considered" is sufficient.  Might be considered is double vague in my opinion. 

But considered isn't great anyway.  Maybe "Number of consecutive PTOs after which the congestion controller assumes persistent congestion."?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244#discussion_r243695670

---

From: ianswett <[email-masked]>
Date: Fri, 21 Dec 2018 13:26:31 -0800

Or concludes instead of assumes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2244#discussion_r243695710