Subject: [quicwg/base-drafts] persistent congestion can never happen (#2208)

From: Marten Seemann <[email-masked]>
Date: Wed, 19 Dec 2018 06:31:10 +0000 (UTC)

The collapse of the congestion window (which used to happen after an RTO was verified) happens in `CongestionEvent`, if `pto_count > kPersistentCongestionThreshold`.
`CongestionEvent` is called from `OnPacketsLost`, which is called from `DetectLostPackets`, which in the case of a tail is only called when a new ACK is received from `OnAckReceived`. However, `OnAckReceived` resets the `pto_count` to 0 *before* calling `DetectLostPackets`, so the condition that leads to the collapse of the congestion window can never occur.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2208

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Dec 2018 00:54:02 -0800

Marking as design, because it will affect interop if this is implemented as documented.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2208#issuecomment-448517306

---

From: Marten Seemann <[email-masked]>
Date: Wed, 19 Dec 2018 01:04:39 -0800

Why is this design? The intention of the pseudo code was clearly that the congestion window is collapsed, and the text states this as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2208#issuecomment-448520533

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Dec 2018 12:01:21 -0800

It's bug that probably needs to go into change logs, that's all.  (We really need a 'bug' label for this sort of thing.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2208#issuecomment-448725424

---

From: ianswett <[email-masked]>
Date: Wed, 19 Dec 2018 21:08:35 +0000 (UTC)

Closed #2208 via #2209.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2208#event-2036764463