Subject: [quicwg/base-drafts] Increase the odds of a stateless reset? (#2153)

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 12:55:09 -0800

```
An endpoint can increase the odds that a packet will trigger a Stateless Reset
if it cannot be processed by padding it to at least 38 bytes.
```

Why does this increase the odds? It seems like the test here is deterministic.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2153

---

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Dec 2018 22:11:03 +0000 (UTC)

The previous paragraphs allow the receiver to ignore the MUST-be-smaller if it can use state to avoid looping.  Even if the packet is large enough, the receiver is also allowed to rate-limit the SRs.  It's never guaranteed that you'll trigger one.  It might actually be deterministic on the receiver side, but that isn't knowable by the sender.

However, sending a packet that's bigger than 38 bytes eliminates one big reason the receiver might ignore without generating a SR, so you improve your odds by doing that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2153#issuecomment-447138736