Subject: [quicwg/base-drafts] More generic keep-alive text (#2092)

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Dec 2018 12:05:52 -0800

In #2068, the direction of the discussion is that PING frames are an application-layer concept that won't necessarily be directly under the application-layer's control.  The HTTP draft currently says:
> HTTP clients are expected to use QUIC PING frames to keep connections open while there are responses outstanding for requests or server pushes. If the client is not expecting a response from the server, allowing an idle connection to time out is preferred over expending effort maintaining a connection that might not be needed. A gateway MAY use PING to maintain connections in anticipation of need rather than incur the latency cost of connection establishment to servers. Servers SHOULD NOT use PING frames to keep a connection open.

This should be reworded in terms of requesting the transport stack to keep the connection from idling out, rather than directly discussing PING frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2092

---

From: MikkelFJ <[email-masked]>
Date: Mon, 03 Dec 2018 12:23:14 -0800

Or maybe we just need to kinds of PING?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2092#issuecomment-443856703

---

From: janaiyengar <[email-masked]>
Date: Mon, 03 Dec 2018 18:05:13 -0800

Gah! Not more types of PING please!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2092#issuecomment-443942271

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 03 Dec 2018 18:11:11 -0800

KEEPTHECARRUNNING frame (ID=0xAF)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2092#issuecomment-443943409