Subject: [quicwg/base-drafts] packet size is header + payload (#2107)

From: Igor Lubashev <[email-masked]>
Date: Sun, 09 Dec 2018 19:11:05 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2107

-- Commit Summary --

  * packet size is header + payload

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2107.patch
https://github.com/quicwg/base-drafts/pull/2107.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107

---

From: MikkelFJ <[email-masked]>
Date: Mon, 10 Dec 2018 00:00:15 -0800

mikkelfj commented on this pull request.

It also included AEAD tag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#pullrequestreview-183062933

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 10 Dec 2018 08:15:17 -0800

The current wording is fine.  The sentence is not meant to be exclusive; rather, it is to clarify which headers are included into the packet size calculation and which aren't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#issuecomment-445873402

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 10 Dec 2018 09:08:04 -0800

@dtikhonov 

> The QUIC packet size includes the QUIC header and integrity check, but not [...]

The current wording is not making sense to me.  Words _"integrity check"_ do not appear anywhere else anywhere else in any of the QUIC drafts.  The _"integrity check"_ is not a concept that is taking up bytes to be accounted for in _"QUIC packet size"_.

Sections 17.2 (_Long Header Packet_) and 17.3 (_Short Header Packet_) of the Transport draft define QUIC packets to contain the Header and Payload parts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#issuecomment-445893083

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 10 Dec 2018 19:04:10 +0000 (UTC)

You're right about "integrity check."  What's probably meant is the AEAD tag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#issuecomment-445932614

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Dec 2018 17:09:41 -0800

martinthomson approved this pull request.

Yeah, I think that this wasn't clear and this is an improvement anyway.  I would be a little more precise though.

> @@ -3047,8 +3047,8 @@ traverse network elements that drop or corrupt ECN codepoints in the IP header.
 
 # Packet Size {#packet-size}
 
-The QUIC packet size includes the QUIC header and integrity check, but not the
-UDP or IP header.
+The QUIC packet size includes the QUIC header and payload, but not the UDP or IP

```suggestion
The QUIC packet size includes the QUIC header and protected payload, but not the UDP or IP
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#pullrequestreview-183472843

---

From: Igor Lubashev <[email-masked]>
Date: Mon, 10 Dec 2018 17:51:51 -0800

@igorlord pushed 1 commit.

e371b7786f5af343cd92699e234c3fa6e64ef0ad  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107/files/e21ed8eafaaf4b680f52bab00c0015ebc813fc68..e371b7786f5af343cd92699e234c3fa6e64ef0ad

---

From: Igor Lubashev <[email-masked]>
Date: Tue, 11 Dec 2018 01:53:47 +0000 (UTC)

4f5e6e76ac20e87e8ee99bc78ba8fb4c9cf7f421  Reflow text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107/files/e371b7786f5af343cd92699e234c3fa6e64ef0ad..4f5e6e76ac20e87e8ee99bc78ba8fb4c9cf7f421

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Dec 2018 22:36:04 -0800

Merged #2107 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2107#event-2023387632