Subject: Re: [quicwg/base-drafts] ICMP DOS (#2063)

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 12:59:28 -0800

Reopened #2063.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#event-2025319013

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 20:59:27 +0000 (UTC)

I just caught this and I don't think that mandating it like this is appropriate. There are other ways to  get a lower MTU (e.g., your interface MTU shrinks). I'm happy to have it forbid lowering in response to ICMP, but this is too broad.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447118661

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 16:37:26 -0800

I disagree.  The fix was to specifically a prohibition against accepting an ICMP PTB.  We also had consensus not to support QUIC on paths that had a lower PMTU, but we don't have any text suggesting others.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447172289

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 16:51:19 -0800

I agree we had consensus not to support QUIC on paths with a lower MTU, but the problem is the over-specific requirement that I do something about it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447174722

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 17:05:10 -0800

What are you being asked to do?  The only requirement in text is that you ignore ICMP PTB with a size of <1280.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447177175

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 17:07:35 -0800

the relevant text is in 14.1.

```
   If a QUIC endpoint determines that the PMTU between any pair of local
   and remote IP addresses has fallen below the size needed to support
   the smallest allowed maximum packet size, it MUST immediately cease
   sending QUIC packets on the affected path.  An endpoint MAY terminate
   the connection if an alternative path cannot be found.
```

This would apply to other methods than ICMP PTB, for instance, Ethernet or VPN MTU reduction

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447177675

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 17:16:43 -0800

Yep.  We had consensus for that text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447179366

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 17:23:36 -0800

Can you please point me to where that consensus call was taken?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447180584

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 17:30:50 -0800

This text is in -02, and the chairs made a call here: https://mailarchive.ietf.org/arch/msg/quic/ZGN6z-5oYnEXRGafi_zvqKjDcnM

That lists "#139 - Minimum MTU"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447181853

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 17:44:22 -0800

I don't really read the thread that way, but It's not worth fighting over.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#issuecomment-447184218

---

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 17:44:23 -0800

Closed #2063.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2063#event-2025784818