Subject: [quicwg/base-drafts] Server Ignore VN Packets (#2088)

From: Nick Banks <[email-masked]>
Date: Sat, 01 Dec 2018 10:11:37 -0800

To prevent the possibility of two servers being tricked into sending endless VN packets between themselves, a server should never respond to a VN packet.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2088

-- Commit Summary --

  * Server Ignore VN Packets

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2088.patch
https://github.com/quicwg/base-drafts/pull/2088.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088

---

From: ianswett <[email-masked]>
Date: Sat, 01 Dec 2018 12:20:46 -0800

I think this is a sensible change, but is there ever a good reason for either client or server to respond to a VN with a VN?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#issuecomment-443455513

---

From: MikkelFJ <[email-masked]>
Date: Sat, 01 Dec 2018 13:25:16 -0800

I also wonder - what about the probably many other invalid frames a client or a server could receive. Maybe we need a more generic approach?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#issuecomment-443459682

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 Dec 2018 15:14:09 -0800

martinthomson approved this pull request.

With the adjustment, lgtm.

> @@ -1108,7 +1108,9 @@ is a mutually supported version.
 
 If the version selected by the client is not acceptable to the server, the
 server responds with a Version Negotiation packet (see {{packet-version}}).
-This includes a list of versions that the server will accept.
+This includes a list of versions that the server will accept.  A server MUST NOT
+send a Version Negotiation packet in response to receiving a Version Negotiation
+packet because it could trigger and endless back and forth between two servers.

```suggestion
packet.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#pullrequestreview-180583385

---

From: Nick Banks <[email-masked]>
Date: Sun, 02 Dec 2018 16:02:25 -0800

@nibanks pushed 1 commit.

603b5e9  Remove some text.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088/files/51b94e07a12ac3ae0b83c553f1445262889bd5a4..603b5e9e16666f1b275f3bf58067fb531940d253

---

From: Martin Thomson <[email-masked]>
Date: Mon, 03 Dec 2018 05:49:30 -0800

@martinthomson pushed 1 commit.

4e97591  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088/files/603b5e9e16666f1b275f3bf58067fb531940d253..4e97591bed0108943d5cc43223ebda9b49e74fc9

---

From: Martin Thomson <[email-masked]>
Date: Mon, 03 Dec 2018 05:49:38 -0800

Merged #2088 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#event-2001452040

---

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Dec 2018 13:18:07 -0800

@ianswett, this is a follow-up from an old issue.  The text previously said that you send VN in response to a version you don't speak, and for some implementations, version 0 is a version they don't speak, so....

This effectively clarifies that you **do** speak version 0, and if you're not a client attempting a connection, the appropriate action in that version is to drop it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#issuecomment-443873726

---

From: ianswett <[email-masked]>
Date: Mon, 03 Dec 2018 14:32:33 -0800

Thanks for the explanation Mike, the idea of a QUIC implementation that doesn't support version 0 is a bit weird, but that's fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2088#issuecomment-443896037