Subject: [quicwg/base-drafts] Reserved stream types (plural?) (#2216)

From: Paŭlo Ebermann <[email-masked]>
Date: Thu, 20 Dec 2018 19:14:21 +0000 (UTC)

[3.2.3.  Reserved Stream Types](https://tools.ietf.org/html/draft-ietf-quic-http-17#section-3.2.3) of the HTTP draft says currently:

>   Stream types of the format "0x1f * N" are reserved to exercise the
>   requirement that unknown types be ignored.

The stream type is a single byte. So how is this `"0x1f * N"` to be understood? Is this just a single stream type `0x1f`?

Also, `0x1f * N` doesn't seem to be valid ABNF syntax at all.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2216

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 20 Dec 2018 12:24:35 -0800

Check out section 10.6
<https://tools.ietf.org/html/draft-ietf-quic-http-17#section-10.6>.

Additionally, each code of the format 0xb + (0x1f * N) for values of N in
the range (0..7) (that is, 0xb, 0x2a, 0x49, 0x68, 0x87, 0xa6, 0xc5, and 0xe4),
the following values should be registered:

On Thu, Dec 20, 2018 at 11:14 AM Paŭlo Ebermann <[email-masked]>
wrote:

> 3.2.3. Reserved Stream Types
> <https://tools.ietf.org/html/draft-ietf-quic-http-17#section-3.2.3> of
> the HTTP draft says currently:
>
> The stream type is a single byte. So how is this "0x1f * N" to be
> understood? Is this just a single stream type 0x1f?
>
> Also, 0x1f * N doesn't seem to be valid ABNF syntax at all.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2216>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ASp6ygZfX2LlBubWN1mpWtsw-IttbPasks5u6-GNgaJpZM4Zcwl5>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2216#issuecomment-449124703

---

From: Paŭlo Ebermann <[email-masked]>
Date: Thu, 20 Dec 2018 13:49:53 -0800

Ah, simple mathematics here. Sorry, I somehow didn't expect actual multiplication with hex digits. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2216#issuecomment-449146556

---

From: Paŭlo Ebermann <[email-masked]>
Date: Thu, 20 Dec 2018 13:49:54 -0800

Closed #2216.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2216#event-2039484152