Subject: [quicwg/base-drafts] Verification of RTO no longer necessary (#2168)

From: janaiyengar <[email-masked]>
Date: Thu, 13 Dec 2018 22:43:08 +0000 (UTC)

The changes to loss recovery in #1974 allow for some simplification in RTO response. The recovery draft says about an ACK after an RTO:
```
When an ACK is received that acknowledges only one or more packets sent on an RTO event, all unacknowledged packets with lower packet numbers MUST be marked as lost. If packets sent prior to the first RTO are acknowledged in the same ACK, the RTO is considered spurious and standard loss detection rules apply.
```
If the ACK acknowledges only packets sent after an RTO, everything sent earlier is marked lost. With time-threshold loss detection in #1974, that is exactly what standard loss detection will do. As a result, in both the conditions described in the text quoted above, standard loss detection does the right thing.

We can remove the two cases (remove OnRetransmissionTimeoutVerified) and always simply use standard loss detection when an ACK is received.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2168

---

From: janaiyengar <[email-masked]>
Date: Fri, 14 Dec 2018 18:00:44 -0800

Closed #2168.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2168#event-2028260651

---

From: janaiyengar <[email-masked]>
Date: Fri, 14 Dec 2018 18:00:44 -0800

Closed by #2114.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2168#issuecomment-447528050