Subject: [quicwg/base-drafts] References in Section 12 are awkward (#2165)

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Dec 2018 14:15:42 -0800

> Packets that carry the long header are Initial Section 17.5, Retry Section 17.7, Handshake Section 17.6, and 0-RTT Protected packets Section 12.1.

These references should be delimited with parentheses, as is done in the other paragraphs:

> QUIC endpoints communicate by exchanging packets. Packets are carried in UDP datagrams (see Section 12.2) and have confidentiality and integrity protection (see Section 12.1).
>
> This version of QUIC uses the long packet header (see Section 17.2) during connection establishment and the short header (see Section 17.3) once 1-RTT keys have been established.

It also seems odd that our references are to subsections (5, 7, 6) rather than matching the order of the actual sections, and that three of the references are to 17.x while one is to 12.1.  Can we make these a little more symmetric?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2165

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Dec 2018 21:01:33 -0800

PRs welcome.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2165#issuecomment-447214047