Subject: [quicwg/base-drafts] s/RTO/PTO/g and consequences (#2238)

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Dec 2018 01:44:16 +0000 (UTC)

Closes #2206.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2238

-- Commit Summary --

  * s/RTO/PTO/g and consequences
  * Fix TLS too

-- File Changes --

    M draft-ietf-quic-tls.md (8)
    M draft-ietf-quic-transport.md (21)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2238.patch
https://github.com/quicwg/base-drafts/pull/2238.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238

---

From: ianswett <[email-masked]>
Date: Thu, 20 Dec 2018 18:04:18 -0800

ianswett commented on this pull request.

> @@ -1790,8 +1790,13 @@ abandons its attempt to validate the path.
 
 Endpoints SHOULD abandon path validation based on a timer. When setting this
 timer, implementations are cautioned that the new path could have a longer
-round-trip time than the original.  A value of three times the current
-Retransmittion Timeout (RTO) as defined in {{QUIC-RECOVERY}} is RECOMMENDED.
+round-trip time than the original.  A value of three times the larger of the
+current Probe Timeout (PTO) or the initial timeout (that is, kInitialRtt*2) as

I think you might be conflating one type of path validation, which is prior to handshake completion, with post-handshake path validation?  Or is there an intent to this text I am missing?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238#pullrequestreview-187251297

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 18:31:39 -0800

martinthomson commented on this pull request.

Yes.  The point - as discussed - was that the PTO is based on the RTT of the old path and so might have little relationship with the RTT of the new path.  If the new RTT is much longer, we might time out unnecessarily.

When we had a minimum RTO, that was our safety net.  But PTO has no minimum, so we have no such safety net.  The initial timeout is therefore our stand-in for RTT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238#discussion_r243474614

---

From: ianswett <[email-masked]>
Date: Thu, 20 Dec 2018 18:38:02 -0800

ianswett approved this pull request.

LG, one suggestion.

Thanks, after re-reading, that makes sense.

```suggestion
 current Probe Timeout (PTO) or the initial timeout (that is, 2*kInitialRtt) as
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238#pullrequestreview-187255871

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 19:20:04 -0800

grr, leading spaces on suggestions are the worst

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238#discussion_r243479614

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 19:20:49 -0800

@martinthomson pushed 1 commit.

db109ff92c8345b41d2a104509cac129dc14d141  Put multiplier first as suggested

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238/files/ddde99caa98edce9ed9f343b5db7885c4b582647..db109ff92c8345b41d2a104509cac129dc14d141

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 20:29:40 -0800

Merged #2238 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2238#event-2039975755