Subject: [quicwg/base-drafts] Retry is not a long header (#2157)

From: ekr <[email-masked]>
Date: Thu, 13 Dec 2018 12:59:45 -0800

```
A Retry packet uses a long packet header with a type value of 0x3. It carries
an address validation token created by the server. It is used by a server that
wishes to perform a stateless retry (see {{validate-handshake}}).
```

This is not correct b/c the long header has length and PN.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2157

---

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Dec 2018 22:17:53 +0000 (UTC)

Retry uses a long header as defined in Invariants, but doesn't include the extra fields defined for the long header in v1.  Perhaps we need a different name for the two long-header references, or perhaps the length/PN should be defined as part of the body of each packet type.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2157#issuecomment-447140628