Subject: [quicwg/base-drafts] stateless reset packet detection when SCID is not zero length (#2269)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 28 Dec 2018 11:08:47 -0800

[S 10.4.1](https://tools.ietf.org/html/draft-ietf-quic-transport-17#section-10.4.1) states:

```
   An endpoint detects a potential stateless reset when a packet with a
   short header either cannot be decrypted or is marked as a duplicate
   packet.
```

This only works for endpoints whose SCID is zero length.  If SCID is not zero length, the connection corresponding to the stateless reset packet will not be found.  This latter case should be included in the stateless reset detection algorithm.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2269

---

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Dec 2018 19:19:36 -0800

Closed #2269 via #2270.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2269#event-2048645738