Subject: [quicwg/base-drafts] In-flight not outstanding (#2120)

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 02:26:17 +0000 (UTC)

Issue noticed when reviewing PR #2117
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2120

-- Commit Summary --

  * In-flight not outstanding

-- File Changes --

    M draft-ietf-quic-recovery.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2120.patch
https://github.com/quicwg/base-drafts/pull/2120.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120

---

From: janaiyengar <[email-masked]>
Date: Wed, 12 Dec 2018 15:06:06 -0800

janaiyengar commented on this pull request.

Using "data in flight" is fine without the hyphenation.

> @@ -400,7 +400,7 @@ On each consecutive expiration of the crypto timer without receiving an
 acknowledgement for a new packet, the sender SHOULD double the crypto
 retransmission timeout and set a timer for this period.
 
-When crypto packets are outstanding, the TLP and RTO timers are not active.
+When crypto packets are in-flight, the TLP and RTO timers are not active.

```suggestion
When crypto packets are in flight, the TLP and RTO timers are not active.
```

> @@ -436,9 +436,9 @@ conditions:
   PTO SHOULD be scheduled for min(RTO, PTO).
 
 QUIC includes MaxAckDelay in all probe timeouts, because it assumes the ack
-delay may come into play, regardless of the number of packets outstanding.
-TCP's TLP assumes if at least 2 packets are outstanding, acks will not be
-delayed.
+delay may come into play, regardless of the number of packets ack-eliciting
+packets in-flight. TCP's TLP assumes if at least 2 ack-eliciting packets are

```suggestion
packets in flight. TCP's TLP assumes if at least 2 ack-eliciting packets are
```

> @@ -436,9 +436,9 @@ conditions:
   PTO SHOULD be scheduled for min(RTO, PTO).
 
 QUIC includes MaxAckDelay in all probe timeouts, because it assumes the ack
-delay may come into play, regardless of the number of packets outstanding.
-TCP's TLP assumes if at least 2 packets are outstanding, acks will not be
-delayed.
+delay may come into play, regardless of the number of packets ack-eliciting

```suggestion
delay may come into play, regardless of the number of ack-eliciting
```

> @@ -436,9 +436,9 @@ conditions:
   PTO SHOULD be scheduled for min(RTO, PTO).
 
 QUIC includes MaxAckDelay in all probe timeouts, because it assumes the ack
-delay may come into play, regardless of the number of packets outstanding.
-TCP's TLP assumes if at least 2 packets are outstanding, acks will not be
-delayed.
+delay may come into play, regardless of the number of packets ack-eliciting
+packets in-flight. TCP's TLP assumes if at least 2 ack-eliciting packets are
+in-flight, acks will not be delayed.

```suggestion
in flight, acks will not be delayed.
```

> @@ -796,7 +796,7 @@ Pseudocode for SetLossDetectionTimer follows:
       loss_detection_timer.cancel()
       return
 
-    if (crypto packets are outstanding):
+    if (crypto packets are in-flight):

```suggestion
    if (crypto packets are in flight):
```

> @@ -837,7 +837,7 @@ Pseudocode for OnLossDetectionTimeout follows:
 
 ~~~
    OnLossDetectionTimeout():
-     if (crypto packets are outstanding):
+     if (crypto packets are in-fight):

```suggestion
     if (crypto packets are in flight):
```

> @@ -1043,7 +1043,7 @@ kMaxDatagramSize:
   windows. The RECOMMENDED value is 1200 bytes.
 
 kInitialWindow:
-: Default limit on the initial amount of outstanding data in bytes.  Taken from
+: Default limit on the initial amount of in-flight data in bytes.  Taken from

```suggestion
: Default limit on the initial amount of data in flight, in bytes.  Taken from
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120#pullrequestreview-184436678

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:41:42 -0800

@ianswett pushed 1 commit.

d4c3b58aa865d987152b639ddef49d7c6294f2dd  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/6763689ad4e09b4157b03e948a33e411954b8d86..d4c3b58aa865d987152b639ddef49d7c6294f2dd

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:42:05 -0800

11ff347f004e3a47c02aa3458de79ab302c34833  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/d4c3b58aa865d987152b639ddef49d7c6294f2dd..11ff347f004e3a47c02aa3458de79ab302c34833

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:42:18 -0800

dfdf208f52931f5a82136336a209d06df64fc210  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/11ff347f004e3a47c02aa3458de79ab302c34833..dfdf208f52931f5a82136336a209d06df64fc210

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:42:24 -0800

023db98503f9fae6092ab97f64f08061b7d0cd73  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/dfdf208f52931f5a82136336a209d06df64fc210..023db98503f9fae6092ab97f64f08061b7d0cd73

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:42:30 -0800

b82ab255abea03a1ec833cbe4ed998e8bfc1bf8b  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/023db98503f9fae6092ab97f64f08061b7d0cd73..b82ab255abea03a1ec833cbe4ed998e8bfc1bf8b

---

From: ianswett <[email-masked]>
Date: Thu, 13 Dec 2018 02:42:45 +0000 (UTC)

2e3fea69be7b344a92125aa1846b2a530c31ffdf  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/b82ab255abea03a1ec833cbe4ed998e8bfc1bf8b..2e3fea69be7b344a92125aa1846b2a530c31ffdf

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:43:00 -0800

de325956206f63e236a3f334ec190e28b1302c04  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120/files/2e3fea69be7b344a92125aa1846b2a530c31ffdf..de325956206f63e236a3f334ec190e28b1302c04

---

From: ianswett <[email-masked]>
Date: Wed, 12 Dec 2018 18:43:46 -0800

@janaiyengar Suggestions accepted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120#issuecomment-446822590

---

From: janaiyengar <[email-masked]>
Date: Wed, 12 Dec 2018 18:53:06 -0800

Merged #2120 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2120#event-2023151464