Subject: [quicwg/base-drafts] Make the ECN requirements match the the discussion in #2156. Fixes #2156 (#2201)

From: ekr <[email-masked]>
Date: Mon, 17 Dec 2018 09:45:44 -0800

1. Implementations are free to enable sending or not.
2, Implementations MAY read the ECN code points if they
   can and send ECN ACKs.
3. Implementations MUST accept the 0x03 ACK type and if they are
   sending ECN SHOULD use the ECN section.

I recognize that some people want to have stronger language here, based
on this discussion I think this is where we are. I'll defer to the
chairs to judge whether more is needed here and can change the PR as
required.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2201

-- Commit Summary --

  * Make the ECN requirements match the the discussion in #2156. Fixes #2156

-- File Changes --

    M draft-ietf-quic-transport.md (28)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2201.patch
https://github.com/quicwg/base-drafts/pull/2201.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201

---

From: Martin Thomson <[email-masked]>
Date: Mon, 17 Dec 2018 20:19:10 -0800

martinthomson approved this pull request.

> @@ -3014,11 +3016,11 @@ the 1-RTT packet number space will be increased by two.
 
 Each endpoint independently verifies and enables use of ECN by setting the IP
 header ECN codepoint to ECN Capable Transport (ECT) for the path from it to the
-other peer. Even if ECN is not used on the path to the peer, the endpoint MUST
-provide feedback about ECN markings received (if accessible).
+other peer. Even if not setting ECN codepoints on packets it transmits, the
+endpoint MAY provide feedback about ECN markings received (if accessible).

SHOULD?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#pullrequestreview-185901814

---

From: ekr <[email-masked]>
Date: Tue, 18 Dec 2018 03:42:00 -0800

I took the discussion to be "MAY" but obviously this is easily changed if
the chairs judge consensus otherwise.

On Mon, Dec 17, 2018 at 8:19 PM Martin Thomson <[email-masked]>
wrote:

> *@martinthomson* approved this pull request.
> ------------------------------
>
> In draft-ietf-quic-transport.md
> <https://github.com/quicwg/base-drafts/pull/2201#discussion_r242402632>:
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/2201#pullrequestreview-185901814>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oRt2EbSqbfKSyUhZ6ug38oB5aX__ks5u6Gy7gaJpZM4ZW1UG>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#issuecomment-448192650

---

From: ianswett <[email-masked]>
Date: Tue, 18 Dec 2018 15:16:06 +0000 (UTC)

ianswett commented on this pull request.

LG, minus one MAY/SHOULD

SHOULD SGTM.

Also, can you remove the parens around if accessible?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#pullrequestreview-186118275

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Dec 2018 15:17:34 -0800

@martinthomson pushed 1 commit.

029d7294a27ff24dd6f027bba50feb0b289b871f  SHOULD ECN

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201/files/9d20ea501c0c72ffe593af6179ebbdad9d2abf87..029d7294a27ff24dd6f027bba50feb0b289b871f

---

From: janaiyengar <[email-masked]>
Date: Tue, 18 Dec 2018 15:18:01 -0800

janaiyengar commented on this pull request.

> @@ -4133,7 +4135,9 @@ Receivers send ACK frames (types 0x02 and 0x03) to inform senders of packets
 they have received and processed. The ACK frame contains one or more ACK Blocks.
 ACK Blocks are ranges of acknowledged packets. If the frame type is 0x03, ACK
 frames also contain the sum of QUIC packets with associated ECN marks received
-on the connection up until this point.
+on the connection up until this point. QUIC implementations MUST properly handle
+both types 0x02 and 0x03 and if they have enabled ECN for packets they send,

```suggestion
 both types 0x02 and 0x03, and if they have enabled ECN for packets they send,
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#pullrequestreview-186327581

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Dec 2018 15:20:50 -0800

81997cff08fd13b598b532cfb9adb83ef27089b9  Merge branch 'master' into ecn_reqs

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201/files/029d7294a27ff24dd6f027bba50feb0b289b871f..81997cff08fd13b598b532cfb9adb83ef27089b9

---

From: ianswett <[email-masked]>
Date: Tue, 18 Dec 2018 23:22:26 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#pullrequestreview-186328786

---

From: janaiyengar <[email-masked]>
Date: Tue, 18 Dec 2018 15:24:34 -0800

@janaiyengar pushed 1 commit.

2941ecca0823f0f6fcda1930bd120824f616841d  editorial nit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201/files/81997cff08fd13b598b532cfb9adb83ef27089b9..2941ecca0823f0f6fcda1930bd120824f616841d

---

From: Martin Thomson <[email-masked]>
Date: Tue, 18 Dec 2018 23:25:09 +0000 (UTC)

Merged #2201 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2201#event-2034369166