Subject: [quicwg/base-drafts] How do I generate an RST? (#2228)

From: ekr <[email-masked]>
Date: Thu, 20 Dec 2018 15:08:06 -0800

S 5.2.

```
A TCP connection error is signaled with QUIC RESET_STREAM frame. A proxy treats
any error in the TCP connection, which includes receiving a TCP segment with the
RST bit set, as a stream error of type HTTP_CONNECT_ERROR
({{http-error-codes}}).  Correspondingly, a proxy MUST send a TCP segment with
the RST bit set if it detects an error with the stream or the QUIC connection.
```

I don't believe this is possible on UNIX. What system call do I use to
generate RST? Neither close() nor shutdown() does it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228

---

From: afrind <[email-masked]>
Date: Thu, 20 Dec 2018 16:21:01 -0800

You set SO_LINGER to {1, 0}, then close.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449185471

---

From: janaiyengar <[email-masked]>
Date: Thu, 20 Dec 2018 16:34:02 -0800

I don't think there's a question here about the -http draft, is there?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449187712

---

From: ekr <[email-masked]>
Date: Thu, 20 Dec 2018 16:44:02 -0800

The question is if it's possible on standard OSes. Sounds like it is on Unix. How about Windows? @nibanks 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449189625

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 21 Dec 2018 14:21:19 -0800

This is the same requirement as in HTTP/2. A "MUST (but we know you probably won't)" ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449512803

---

From: ekr <[email-masked]>
Date: Fri, 21 Dec 2018 18:02:02 -0800

Well, that was a joke in 6919, so probably we shouldn't do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449537212

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Dec 2018 22:21:39 -0800

This is not that.  We know that some implementations use TCP half-closed in HTTP.  Some even rely on it to the point that things break if you don't do it.  Not that things don't break for those people, but they have a narrow set of peers that they interact with.

Of course, whether that set of endpoints is ALSO the same set of endpoints using CONNECT is hard to know.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449691617

---

From: ekr <[email-masked]>
Date: Mon, 24 Dec 2018 06:18:42 -0800

Note that this particular issue is not about half-closed. In half-closed,
you generate a FIN and then keep receiving data. This is about sending an
RST.

On Sun, Dec 23, 2018 at 10:21 PM Martin Thomson <[email-masked]>
wrote:

> This is not that. We know that some implementations use TCP half-closed in
> HTTP. Some even rely on it to the point that things break if you don't do
> it. Not that things don't break for those people, but they have a narrow
> set of peers that they interact with.
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449691617>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/ABD1oWZ-xOHvA2hcEMiW0hrPR7Hq2xiBks5u8HJxgaJpZM4ZdD1t>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-449739438