Subject: [quicwg/base-drafts] description of persistent congestion threshold is wrong (#2243)

From: Marten Seemann <[email-masked]>
Date: Fri, 21 Dec 2018 15:34:21 +0000 (UTC)

The text says
> If a threshold number of consecutive PTOs have occurred (pto_count is more than kPersistentCongestionThreshold, see Section 7.9.1), the network is considered to be experiencing persistent congestion, and the sender’s congestion window MUST be reduced to the minimum congestion window.

Similar text exists for the description of kPersistentCongestionThreshold.

We actually only collapse the congestion window when receiving an ACK for a probe packet, and only if this ACK leads us to declare any packet(s) lost.
Specifically, this means that pto_count may grow larger than kPersistentCongestionThreshold, if no acknowledgements are received.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2243

---

From: janaiyengar <[email-masked]>
Date: Fri, 21 Dec 2018 20:31:45 +0000 (UTC)

Good point. Sent #2244.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2243#issuecomment-449491391