Subject: [quicwg/base-drafts] Confusing text around push streams (#2225)

From: ekr <[email-masked]>
Date: Thu, 20 Dec 2018 15:05:47 -0800

S 3.2.2.

```
A push stream is indicated by a stream type of `0x50` (ASCII 'P'), followed by
the Push ID of the promise that it fulfills, encoded as a variable-length
integer. The remaining data on this stream consists of HTTP/3 frames, as defined
in {{frames}}, and fulfills a promised server push.  Server push and Push IDs
are described in {{server-push}}.
```

This isn't understandable without knowing what push is or what a PUSH
promise is. Am I supposed to get that from 7540? In either case, you
should clearly state that a push stream can only be used for a single
push promise (this is implied by the formatting). Happy to supply a PR if
we can agree on what's wanted?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2225

---

From: Martin Thomson <[email-masked]>
Date: Thu, 20 Dec 2018 17:57:56 -0800

Yes, as currently written, a push stream corresponds 1:1 with a PUSH_PROMISE.  Which is consistent again with 7540 (we had a period where it was not).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2225#issuecomment-449213071

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 21 Dec 2018 14:30:41 -0800

Well. A push stream corresponds one-to-one with a push ID. You can duplicate promises using the DUPLICATE_PUSH frame.

I think this is what was attempted to be described by the term "promised server push" as abstract from the frames that might get sent. If the language needs to improve to make this clearer then lets do it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2225#issuecomment-449514285