Subject: [quicwg/base-drafts] clarify that INITCWND caps amount of data sent to a client before address validation (#2341)

From: Kazuho Oku <[email-masked]>
Date: Thu, 17 Jan 2019 03:27:27 +0000 (UTC)

Clarifies how we prohibit a server from sending too many packets to a client prior to validating the address.

Closes #2135.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2341

-- Commit Summary --

  * clarify that INITCWND caps amount of data sent to an unvalidated client

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2341.patch
https://github.com/quicwg/base-drafts/pull/2341.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Jan 2019 19:36:25 -0800

martinthomson commented on this pull request.

I think that you have this backwards.  The point here is that the client is limited by INITCWND.  The server has to abide by the x3 rule.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#pullrequestreview-193449112

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 19:43:53 -0800

@kazuho pushed 1 commit.

f7b0187521bb60349e258eb7222e53c877a8b887  the restriction is in the opposite direction

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341/files/7c7c506db978425c6259ec5b937346768185cc44..f7b0187521bb60349e258eb7222e53c877a8b887

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 19:44:55 -0800

@martinthomson That's definitely true. Addressed in f7b0187.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455031945

---

From: Marten Seemann <[email-masked]>
Date: Wed, 16 Jan 2019 19:57:52 -0800

I'm not sure if this is correct. If a packet is declared lost, it can be retransmitted, so in that case the amount of data sent is larger than initial cwnd.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455034013

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 19:59:57 -0800

@marten-seemann That's a good point. Does changing the text to refer to "congestion avoidance algorithm" instead of "initial congestion window" resolve the concern?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455034336

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Jan 2019 20:26:14 -0800

This looks fine, but I have a new concern: this makes it appear as though the congestion window doesn't apply to the server.  It does.  Would this be better?

> The amount that servers are permitted to send is also constrained by the limit set by the congestion avoidance algorithm.  Clients are only constrained in what they can send prior to address validation by congestion control.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455038161

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 20:36:39 -0800

@kazuho pushed 1 commit.

5522bd547d040512ada19513ffd2cbbfad386d87  MT's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341/files/f7b0187521bb60349e258eb7222e53c877a8b887..5522bd547d040512ada19513ffd2cbbfad386d87

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 20:36:59 -0800

@martinthomson Thanks. Applied in 5522bd5.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455039616

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 09:43:22 +0000 (UTC)

ianswett commented on this pull request.

> @@ -1579,6 +1579,10 @@ the client during connection establishment with a Retry packet (see
 {{validate-retry}}) or in a previous connection using the NEW_TOKEN frame (see
 {{validate-future}}).
 
+The amount that servers are permitted to send is also constrained by the limit

Suggestion: "In addition to sending limits imposed prior to address validation, servers are also constrained in what they can send by the limits set by the congestion avoidance algorithm.  Clients are only constrained by the congestion avoidance algorithm."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#pullrequestreview-193532676

---

From: janaiyengar <[email-masked]>
Date: Thu, 17 Jan 2019 12:56:47 -0800

janaiyengar commented on this pull request.

s/congestion avoidance algorithm/congestion controller.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#discussion_r248837453

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 17 Jan 2019 22:45:12 -0800

@kazuho pushed 1 commit.

00bed2ccf53f2fbb9653b05d54d9664516c5c9d5  Ian's suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341/files/5522bd547d040512ada19513ffd2cbbfad386d87..00bed2ccf53f2fbb9653b05d54d9664516c5c9d5

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 17 Jan 2019 22:45:40 -0800

kazuho commented on this pull request.

@ianswett @janaiyengar Thank you! Applied the suggestions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#discussion_r248941152

---

From: ianswett <[email-masked]>
Date: Sat, 19 Jan 2019 00:35:05 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#pullrequestreview-194349649

---

From: Martin Thomson <[email-masked]>
Date: Sun, 20 Jan 2019 20:14:04 -0800

Merged #2341 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#event-2085411695

---

From: Martin Thomson <[email-masked]>
Date: Sun, 20 Jan 2019 20:14:17 -0800

Thanks everyone.  This looks nothing like what it did when it started, but it's much clearer as a result.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2341#issuecomment-455943228