Subject: [quicwg/base-drafts] kGranularity and max_ack_delay possibly should be added after exponential backoff (#2393)

From: ianswett <[email-masked]>
Date: Wed, 30 Jan 2019 22:14:58 +0000 (UTC)

Right now, exponential backoff occurs last.  But it's reasonable to consider adding/maxing them at the end after exponential backoff.

On the one hand, the current pseudocode provides true exponential backoff.  On the other hand, it might be overly conservative in some cases.  This only applies on subsequent PTOs, so maybe this is an academic question.

I'm opening this in the interest in discussing design issues on issues and not on PRs, but I'm also fine with it being closed as not being important and/or needing more information.

This came up in #2365 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393

---

From: Nick Banks <[email-masked]>
Date: Wed, 30 Jan 2019 22:43:44 +0000 (UTC)

I also agree `kGranularity` and `max_ack_delay` should be applied after the exponential; especially `kGranularity` which is only there to account for clocks/timers that have a minimum time you can set. No need to compound that inaccuracy inside the exponent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393#issuecomment-459140068