Subject: [quicwg/base-drafts] Define RTT (#2362)

From: ianswett <[email-masked]>
Date: Tue, 22 Jan 2019 17:00:02 -0800

Explicitly state that round trip time is abbreviated as RTT
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2362

-- Commit Summary --

  * Define RTT

-- File Changes --

    M draft-ietf-quic-recovery.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2362.patch
https://github.com/quicwg/base-drafts/pull/2362.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 20:00:04 -0800

martinthomson commented on this pull request.

> @@ -293,10 +293,10 @@ continue making forward progress.
 
 # Computing the RTT estimate
 
-RTT is calculated when an ACK frame arrives by computing the difference between
-the current time and the time the largest acked packet was sent.  An RTT sample
-MUST NOT be taken for a packet that is not newly acknowledged or not
-ack-eliciting.
+Round trip time, abbreviated RTT, is calculated when an ACK frame arrives by

```suggestion
Round trip time (RTT) is calculated when an ACK frame arrives by
```

Just make sure that you add the parenthetical the first time you see the acronym.  If that is prior to this section in the document, then you probably need to expand the first usage as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362#pullrequestreview-195339003

---

From: ianswett <[email-masked]>
Date: Tue, 22 Jan 2019 20:07:14 -0800

@ianswett pushed 1 commit.

1328ea5d59099c40902fa644064c4a76eb8d60a7  Fix earlier uses and remove an obsolete sentence

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362/files/717ae94a335b956f195648c0af8b8b928d4aea3d..1328ea5d59099c40902fa644064c4a76eb8d60a7

---

From: ianswett <[email-masked]>
Date: Tue, 22 Jan 2019 20:09:28 -0800

00fe359052fc890cf8ff3444e9d64bd78308af6f  Match TCP RFCs use of

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362/files/1328ea5d59099c40902fa644064c4a76eb8d60a7..00fe359052fc890cf8ff3444e9d64bd78308af6f

---

From: ianswett <[email-masked]>
Date: Tue, 22 Jan 2019 20:09:55 -0800

ianswett commented on this pull request.

 

Done and changed to round-trip time, which matches TCP RFCs

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362#discussion_r250050334

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 23 Jan 2019 17:05:20 -0800

Merged #2362 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2362#event-2093247113