Subject: [quicwg/base-drafts] HTTP/3: is the recommended size of max bidi streams normative? (#2337)

From: Lucas Pardue <[email-masked]>
Date: Wed, 16 Jan 2019 14:38:52 +0000 (UTC)

> It is recommended that initial_max_bidi_streams be no smaller than 100, so as to not unnecessarily limit parallelism.

Is this normative? It can be detected...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2337

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Jan 2019 19:27:01 +0000 (UTC)

RFC7540 used a lower-case "recommended", and the text was picked up from there.  I don't know that there's any harm if we made it "RECOMMENDED", but I'm not sure there's a ton of benefit either.  It's a value the implementation can set (or expose via configuration), and we're giving some guidance.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2337#issuecomment-454907586

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 20 Jan 2019 15:24:15 -0800

Closing this because of the parity with HTTP/2, lets reopen if anyone asks the same question in the coming weeks/months.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2337#issuecomment-455912486

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 20 Jan 2019 15:24:18 -0800

Closed #2337.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2337#event-2085212751