Subject: [quicwg/base-drafts] Articulate principles for definition of error codes (#2388)

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Jan 2019 06:06:28 +0000 (UTC)

We don't really have any real principles that we agree on for deciding what error codes we are describing.

Proposal:

1. if the error carries distinct semantics (like stream rejection in HTTP), then it gets a new error code

2. if the error is frequent or particularly significant, then it gets a new error code

3. otherwise, target a more generic error code that identifies the broad area of the protocol

4. finally, if there is no more specific applicable error code, use PROTOCOL_VIOLATION

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2388

---

From: ianswett <[email-masked]>
Date: Wed, 30 Jan 2019 06:12:16 +0000 (UTC)

#1989 is example of an issue discussed where it would have been useful to have principles.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2388#issuecomment-458824927