Subject: [quicwg/base-drafts] What if a client sends a NEW TOKEN frame? (#2382)

From: Christian Huitema <[email-masked]>
Date: Mon, 28 Jan 2019 18:00:04 -0800

Should the server just ignore it, or is is a protocol violation?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382

---

From: ianswett <[email-masked]>
Date: Mon, 28 Jan 2019 18:01:25 -0800

I vote for protocol violation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-458377738

---

From: Christian Huitema <[email-masked]>
Date: Mon, 28 Jan 2019 18:10:15 -0800

The spec says nothing...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-458379498

---

From: Martin Thomson <[email-masked]>
Date: Mon, 28 Jan 2019 20:31:29 -0800

Yeah, there's no need to vote, this is just an omission.  A protocol violation (or similar) is what we should mandate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-458404022

---

From: Christian Huitema <[email-masked]>
Date: Mon, 28 Jan 2019 20:54:20 -0800

Playing devils' advocate: what about p2p apps? The token says, you can call me back from that address, I will accept it. The client is not saying anything untrue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-458407423