Subject: Re: [quicwg/base-drafts] Can I send non-data frames on CONNECT streams? (#2229)

From: Mike Bishop <[email-masked]>
Date: Mon, 07 Jan 2019 12:21:43 -0800

Well, there's technically nothing preventing the use of push....  ;-)

More seriously, I don't feel like the prohibition adds much.  This maps the definition of the CONNECT method into H3 framing -- DATA frames == TCP payload.  In any other respect, it's an HTTP request and frames mean what they otherwise mean.

Is there a particular frame that *needs* to be prohibited?  HEADERS would indicate a trailer block; it might be worth upstreaming to the updated semantic draft that a CONNECT tunnel can't have trailers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229#issuecomment-452068777

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:04:14 -0800

Discussed in Tokyo; after the CONNECT takes effect, all frames other than DATA are prohibited unless an extension specifically provides otherwise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2229#issuecomment-459226998