Subject: [quicwg/base-drafts] Stronger protocol negotiation requirement (#2284)

From: Martin Thomson <[email-masked]>
Date: Wed, 02 Jan 2019 15:35:59 -0800

The transport already requires that the cryptographic handshake provide
authenticated negotiation of application protocol.  However, the TLS doc
was a little weak on whether ALPN should be used.  This clears that up.

Closes #2263.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2284

-- Commit Summary --

  * Stronger protocol negotiation requirement

-- File Changes --

    M draft-ietf-quic-tls.md (21)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2284.patch
https://github.com/quicwg/base-drafts/pull/2284.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 02 Jan 2019 15:42:33 -0800

Authenticated *application* protocol

On Wed, 2 Jan 2019, 23:35 Martin Thomson <[email-masked] wrote:

> Closes #2263 <https://github.com/quicwg/base-drafts/issues/2263>.
> ------------------------------
> Commit Summary
>    - Stronger protocol negotiation requirement
>
> File Changes
>
>    - *M* draft-ietf-quic-tls.md
>    <https://github.com/quicwg/base-drafts/pull/2284/files#diff-0> (21)
>
> Patch Links:
>
>    - https://github.com/quicwg/base-drafts/pull/2284.patch
>    - https://github.com/quicwg/base-drafts/pull/2284.diff
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/2284>, or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AGRFtbkHEXjk4Qk_GE5IB6j37iWno7aCks5u_UJfgaJpZM4ZnYap>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284#issuecomment-451019657

---

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 17:49:16 -0800

janaiyengar commented on this pull request.

> @@ -1208,15 +1208,18 @@ protection for the QUIC negotiation.  This does not prevent version downgrade
 prior to the completion of the handshake, though it means that a downgrade
 causes a handshake failure.
 
-TLS uses Application Layer Protocol Negotiation (ALPN) {{!RFC7301}} to select an
-application protocol.  The application-layer protocol MAY restrict the QUIC
-versions that it can operate over.  Servers MUST select an application protocol
-compatible with the QUIC version that the client has selected.
-
-If the server cannot select a compatible combination of application protocol and
-QUIC version, it MUST abort the connection. A client MUST abort a connection if
-the server picks an incompatible combination of QUIC version and ALPN
-identifier.
+QUIC requires that the cryptographic handshake provide authenticated protocol
+negotiation.  TLS uses Application Layer Protocol Negotiation (ALPN)
+{{!RFC7301}} to select an application protocol.  Clients and servers MUST use
+ALPN to negotiate an application protocol, unless another mechanism is used for
+agreeing on an application protocol.

Suggested rephrase: "Unless another mechanism is used for agreeing on an application protocol, endpoints MUST use ALPN for this purpose."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284#pullrequestreview-189245568

---

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 17:51:57 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284#pullrequestreview-189245834

---

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 17:52:28 -0800

One suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284#issuecomment-451334033

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 14:09:01 -0800

@martinthomson pushed 1 commit.

892c371961089ca58657396f164c7473a34bad6a  Suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284/files/fce75453e774abba3b9db9d01bb2257dcb6dcf62..892c371961089ca58657396f164c7473a34bad6a

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 14:09:09 -0800

Merged #2284 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2284#event-2056478435