Subject: Re: [quicwg/base-drafts] only require RESET_STREAM on STOP_SENDING in Ready and Sent state (#2268)

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Jan 2019 11:06:18 -0800

Receiving a FIN isn't enough to complete the state machine, though some implementations might short-circuit it when sending a STOP_SENDING.  The reliability machinery expects to send all data declared lost unless there's a RESET_STREAM.  I think the language needs to be something like:

> ...MUST send a RESET_STREAM frame if the stream is in the Ready or Send state.  If the stream is in the Data Sent state and any outstanding data is declared lost, an endpoint SHOULD send a RESET_STREAM frame in lieu of a retransmission.

(This effectively makes a new side state from Data Sent where you're waiting to decide if you need to send a RESET_STREAM.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2268#issuecomment-452415035

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 16:13:28 -0800

Closed #2268 via #2361.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2268#event-2090317760