Subject: [quicwg/base-drafts] Add a maximum for max_ack_delay (#2301)

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 15:54:34 -0800

As discussed on the issue, 640k should be enough for anyone.

Closes #2282.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2301

-- Commit Summary --

  * Add a maximum for max_ack_delay

-- File Changes --

    M draft-ietf-quic-transport.md (1)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2301.patch
https://github.com/quicwg/base-drafts/pull/2301.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 06 Jan 2019 15:55:57 -0800

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#pullrequestreview-189651113

---

From: ianswett <[email-masked]>
Date: Sun, 06 Jan 2019 19:39:41 -0800

ianswett commented on this pull request.

> @@ -4086,6 +4086,7 @@ max_ack_delay (0x000b):
   delays in alarms firing.  For example, if a receiver sets a timer for 5ms
   and alarms commonly fire up to 1ms late, then it should send a max_ack_delay
   of 6ms.  If this value is absent, a default of 25 milliseconds is assumed.
+  Values of 2^14 or greater are invalid.

Can you clarify what should happen if the value is invalid?  ie: Should the receiver cap the value at 2^14 or should the peer close the connection?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#pullrequestreview-189669364

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 Jan 2019 15:14:40 -0800

martinthomson commented on this pull request.

I thought that we already had text to that effect (the adjacent parameters are similarly terse).  Added one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#discussion_r245830604

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 Jan 2019 23:14:47 +0000 (UTC)

@martinthomson pushed 1 commit.

1186b28ab35699b9dc7356d3127def55c110c263  Invalid transport parameters are invalid.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301/files/ca08d5fae11b80513d462332986b199b02e42d82..1186b28ab35699b9dc7356d3127def55c110c263

---

From: janaiyengar <[email-masked]>
Date: Mon, 07 Jan 2019 18:21:12 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#pullrequestreview-190071289

---

From: ianswett <[email-masked]>
Date: Mon, 07 Jan 2019 19:57:13 -0800

Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#discussion_r245871492

---

From: ianswett <[email-masked]>
Date: Mon, 07 Jan 2019 19:57:32 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#pullrequestreview-190085075

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 Jan 2019 21:21:27 -0800

Merged #2301 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2301#event-2059283687