Subject: Re: [quicwg/base-drafts] Guidelines for Retransmitting Lost Data (#2103)

From: ianswett <[email-masked]>
Date: Thu, 10 Jan 2019 19:23:15 -0800

Can this issue be closed now that #2212 has been merged and we're referencing quic-transport?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2103#issuecomment-453363879

---

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 10:15:42 -0800

The current text, which was written after this issue was filed is:
"Probe packets sent on a PTO MUST be ack-eliciting. A probe packet SHOULD carry new data when possible. A probe packet MAY carry retransmitted unacknowledged data when new data is unavailable, when flow control does not permit new data to be sent, or to opportunistically reduce loss recovery delay. Implementations MAY use alternate strategies for determining the content of probe packets, including sending new or retransmitted data based on the application's priorities."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2103#issuecomment-454494918

---

From: martinduke <[email-masked]>
Date: Tue, 15 Jan 2019 10:28:40 -0800

The current text is fine as a normative spec. The point of the issue, though, is to provide some suggestions on how to pick the "retransmitted unacknowledged data". It is not certainly not obvious to me how this logic should go.

There's a somewhat broader discussion about how we're defining loss and loss response that isn't going to go well over github. Can we leave this open until I can try to explain to you and Jana in Tokyo?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2103#issuecomment-454499260

---

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 10:32:25 -0800

Sure, let's discuss in person.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2103#issuecomment-454500539

---

From: ianswett <[email-masked]>
Date: Mon, 28 Jan 2019 23:05:11 -0800

Closed #2103 via #2380.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2103#event-2102797912