Subject: Re: [quicwg/base-drafts] Why do control streams need to be typed? (#2224)

From: Mike Bishop <[email-masked]>
Date: Mon, 07 Jan 2019 13:17:12 -0800

I think it's been established that we have consensus to have typed streams.  It would be possible to pre-assign Stream IDs to the control streams and only use a type byte on higher stream IDs.  However, it seems more consistent to use a single mechanism for all unidirectional streams than creating such a hybrid scheme.

> Is this isolation principle formulated anywhere btw., transport, or a companion governance'ish draft?

The principle I've attempted to maintain is that a stream, once received from the transport, has properties which include the ID, uni/bidi, direction, etc.  However, any relationship between those things is the transport's business and the HTTP layer doesn't make assumptions about them.  Likewise, the application shouldn't ever have to go to the transport and get a particular stream by ID, because that encodes implicit assumptions about the type, direction, etc.

That's primarily been articulated in discussions; it's not a formal protocol property.  However, it helps to ensure that HTTP/3 doesn't have to be revved for future versions of the transport which might change those relationships.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2224#issuecomment-452084827

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:05:07 -0800

Closed #2224.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2224#event-2108509070

---

From: Mike Bishop <[email-masked]>
Date: Thu, 31 Jan 2019 06:05:06 +0000 (UTC)

Discussed in Tokyo; close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2224#issuecomment-459227141