Subject: [quicwg/base-drafts] "PRIORITY frame expresses priority of a stream" (#2321)

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 10:43:27 +0000 (UTC)

Draft 17 says

> The PRIORITY (type=0x02) frame specifies the client-advised priority of a stream.

If I understand H3 Placeholders correctly, the PRIORITY frame would be used to set their priority too. Perhaps we can say:

`The PRIORITY (type=0x02) frame specifies the client-advised priority of a stream or placeholder`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 09 Jan 2019 02:52:06 -0800

To me it seems that the current text is more accurate.

While a PRIORITY frame might use a placeholder to designate the target, what is actually prioritized is the stream that carries the response. The transmission of the placeholder itself is never prioritized.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452654766

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 02:56:05 -0800

But the PRIORITY frame contains the Prioritized Element ID field, that allows us to set the priority of Placeholder type. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452655952

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 09 Jan 2019 03:03:00 -0800

Yeah, my view is that it is an act of prioritizing a stream by specifying a placeholder ID that maps to the stream. Section 5.3 talks about prioritizing "streams".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452657822

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 03:08:38 -0800

That's a good observation, so I'd go further say that IMO the textual description of H3 prioritisation is not completely aligned the protocol mechanisms. Cue @MikeBishop to tell me I am completely off the mark :) 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452659360

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 03:13:57 -0800

Also, the table of prioritized element types in [section 4.2.3](https://tools.ietf.org/html/draft-ietf-quic-http-17#section-4.2.3) seems to be duplicated

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452660789

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 09 Jan 2019 05:53:13 -0800

The two tables in section 4.2.3 are slightly different.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452703545

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 05:54:37 -0800

Correct, I just independently spotted that. Its logical but a bit annoying 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452703979

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 14:48:04 +0000 (UTC)

#2322 makes some basic edits to section 4.2.3, adding Table captions and linking to them from the paragraph above.

It reworks 5.3 slightly to reframe the language toward describing a tree of abstract elements but still provides concrete examples of request prioritisation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452722004

---

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 18:13:42 +0000 (UTC)

Yeah, there was originally one table and I had to split it to accommodate the current design.  If anyone sees an elegant way to recombine them, I'm fully supportive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452791632

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 09 Jan 2019 18:58:28 +0000 (UTC)

I thought perhaps make the labels multi line and then combine the last two
columns of the second table onto the first. So there would be two colums
containing two sub columns each, plus the left most bits column. I don't
know the Markdown foo to make that happen though.

On Wed, 9 Jan 2019, 18:13 Mike Bishop <[email-masked] wrote:

> Yeah, there was originally one table and I had to split it to accommodate
> the current design. If anyone sees an elegant way to recombine them, I'm
> fully supportive.
>
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452791632>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AGRFtQGNai52JvZe7RdR_XGVa1yhKpjxks5vBjFUgaJpZM4Z3N8q>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452801045

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 09 Jan 2019 13:10:35 -0800

@LPardue My bad. I was confused. I now understand the issue and think that the PR will provide us the necessary fixes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-452835809

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Jan 2019 08:58:49 +0000 (UTC)

A comment on this text: we should be prioritizing *requests* and maybe *pushes*, not streams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-453019177

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 10 Jan 2019 01:05:12 -0800

That's a fair point I'll see if I can incorporate that into the PR

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#issuecomment-453021082

---

From: Mike Bishop <[email-masked]>
Date: Fri, 11 Jan 2019 09:45:49 -0800

Closed #2321 via #2322.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2321#event-2069157086