Subject: [quicwg/base-drafts] Ipv6 flow label (#2399)

From: Christian Huitema <[email-masked]>
Date: Fri, 01 Feb 2019 01:47:38 +0000 (UTC)

Recommendation to set the IPv6 flow label in accordance to RFC 6437, as agreed in Tokyo.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2399

-- Commit Summary --

  * Merge pull request #11 from quicwg/master
  * Setting the flow label per RFC 6437.

-- File Changes --

    M draft-ietf-quic-transport.md (15)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2399.patch
https://github.com/quicwg/base-drafts/pull/2399.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399

---

From: Martin Thomson <[email-masked]>
Date: Thu, 31 Jan 2019 17:55:50 -0800

martinthomson approved this pull request.

Mostly good, though plenty of nits.  Let's get chair confirmation before merging though.

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and migration {ipv6-flow-label}

```suggestion
## Use of IPv6 Flow-Label and Migration {#ipv6-flow-label}
```

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and migration {ipv6-flow-label}
+
+Quic nodes that send data using IPv6 SHOULD document the IPv6 flow label

```suggestion
Endpoints that send data using IPv6 SHOULD apply an IPv6 flow label
```

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and migration {ipv6-flow-label}
+
+Quic nodes that send data using IPv6 SHOULD document the IPv6 flow label
+in compliance with {{!RFC6437}}, unless the local API does not allow
+setting this parameter.
+
+The IPv6 flow label should be a pseudo-random function of the source

```suggestion
The IPv6 flow label SHOULD be a pseudo-random function of the source
```

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and migration {ipv6-flow-label}
+
+Quic nodes that send data using IPv6 SHOULD document the IPv6 flow label
+in compliance with {{!RFC6437}}, unless the local API does not allow
+setting this parameter.
+
+The IPv6 flow label should be a pseudo-random function of the source
+and destination addresses, source and destination UDP ports, and the destination
+CID. The flow label generation MUST be designed to minimize the chances of
+collision with a previously used flow label, as this would enable linkability

```suggestion
linkability with a previously used flow label, as this would enable correlating activity on multiple paths
```

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and migration {ipv6-flow-label}
+
+Quic nodes that send data using IPv6 SHOULD document the IPv6 flow label
+in compliance with {{!RFC6437}}, unless the local API does not allow
+setting this parameter.
+
+The IPv6 flow label should be a pseudo-random function of the source
+and destination addresses, source and destination UDP ports, and the destination
+CID. The flow label generation MUST be designed to minimize the chances of
+collision with a previously used flow label, as this would enable linkability
+of multiple paths (see {{migration-linkability}}).
+
+A possible implementation is to compute the flow label as a one way
+hash function of the source and destination addresses, source and
+destination UDP ports, destination CID and a local secret.

```suggestion
destination UDP ports, destination CID, and a local secret.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#pullrequestreview-198899307

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 21:55:29 -0800

@huitema pushed 1 commit.

56f6450b4b2a45242112070b1c153b8c0eab68ed  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/35387128d9b0cb4729f8655fec292f6bd02fef4a..56f6450b4b2a45242112070b1c153b8c0eab68ed

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 21:55:38 -0800

850b0a2bef1ef76ca0fcc69444af2148b9a11c63  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/56f6450b4b2a45242112070b1c153b8c0eab68ed..850b0a2bef1ef76ca0fcc69444af2148b9a11c63

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 21:55:52 -0800

9b39f9e343fb2e9e3cfa96d655b3644cc0656df1  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/850b0a2bef1ef76ca0fcc69444af2148b9a11c63..9b39f9e343fb2e9e3cfa96d655b3644cc0656df1

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 21:56:28 -0800

7cd07227f76681bd6efd916443727f305c214eb7  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/9b39f9e343fb2e9e3cfa96d655b3644cc0656df1..7cd07227f76681bd6efd916443727f305c214eb7

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 21:56:38 -0800

d256eb9edbe8734257d8b20818f118db28309792  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/7cd07227f76681bd6efd916443727f305c214eb7..d256eb9edbe8734257d8b20818f118db28309792

---

From: Christian Huitema <[email-masked]>
Date: Thu, 31 Jan 2019 22:03:16 -0800

a122343dec6cbe70c07f62798916ec9d04e2c260  Fixing a repeated words nit.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/d256eb9edbe8734257d8b20818f118db28309792..a122343dec6cbe70c07f62798916ec9d04e2c260