Subject: Re: [quicwg/base-drafts] Should retiring all CIDs be an error? (#2101)

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Jan 2019 21:20:33 -0800

Assigning this to @dtikhonov : endpoints MUST NOT retire a connection ID in a packet that contains that connection ID.  Endpoints MAY generate an error in that case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458815733

---

From: Marten Seemann <[email-masked]>
Date: Tue, 29 Jan 2019 21:33:36 -0800

That doesn’t solve the issue. You can use two connection IDs and retire CID A in B and CID B in A.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458817814

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 29 Jan 2019 21:46:59 -0800

This true.  I thought the consensus was to prohibit retiring all connection IDs, @martinthomson?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458820093

---

From: Mike Bishop <[email-masked]>
Date: Tue, 29 Jan 2019 22:00:20 -0800

Consensus was to prohibit retiring the CID used in the packet which contains it.  The intent is that RETIRE means "I have ceased using this CID," so the cross-retiring is technically possible but still against the intent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458822607

---

From: ianswett <[email-masked]>
Date: Tue, 29 Jan 2019 22:00:22 -0800

My understanding is that CIDs must be used in order.  Given that, if you retire CID A in a packet with CID B then you can't then send CID A in a subsequent packet.  And vice versa, so I think we're ok assuming CIDs must be used in order.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458822616

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 29 Jan 2019 22:01:20 -0800

OK, sounds good.  I will make a PR to that effect.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458822821

---

From: Marten Seemann <[email-masked]>
Date: Tue, 29 Jan 2019 22:20:45 -0800

> My understanding is that CIDs must be used in order. Given that, if you retire CID A in a packet with CID B then you can't then send CID A in a subsequent packet. And vice versa, so I think we're o…

@ianswett I don't think we have that requirement. You're allowed to use multiple CIDs at the same time. Or did I miss any text in the spec?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458826481

---

From: Mike Bishop <[email-masked]>
Date: Tue, 29 Jan 2019 22:22:53 -0800

Not "used in order," but you can't use the CID after retiring it.  One of those two packets would violate that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2101#issuecomment-458826886