Subject: [quicwg/base-drafts] Client can't prioritize streams it can't open (#2326)

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 19:44:16 +0000 (UTC)

Generalizes HTTP_PUSH_LIMIT_EXCEEDED to HTTP_LIMIT_EXCEEDED and mandates use of that error code where a PRIORITY frame attempts to prioritize a frame the client isn't permitted to open yet.  This has the effect of bounding priority tree state to requests the client *could* initiate (though might not have yet).

Fixes #2144.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2326

-- Commit Summary --

  * Client can't prioritize streams it can't open
  * Update dangling reference to HTTP_PUSH_LIMIT_EXCEEDED

-- File Changes --

    M draft-ietf-quic-http.md (19)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2326.patch
https://github.com/quicwg/base-drafts/pull/2326.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Jan 2019 15:43:28 -0800

martinthomson commented on this pull request.

> @@ -1385,8 +1385,9 @@ HTTP_VERSION_FALLBACK (0x09):
 HTTP_WRONG_STREAM (0x0A):
 : A frame was received on a stream where it is not permitted.
 
-HTTP_PUSH_LIMIT_EXCEEDED (0x0B):
-: A Push ID greater than the current maximum Push ID was referenced.
+HTTP_LIMIT_EXCEEDED (0x0B):
+: An identifier greater than the current maximum for that identifier was
+  referenced.

I think that you can (and should) list the types of identifiers this applies to.  I assume that this is limited to push IDs and priority placeholders.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326#pullrequestreview-190995751

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Jan 2019 15:44:29 -0800

-A PRIORITY frame that references a non-existent Push ID or a Placeholder ID
-greater than the server's limit MUST be treated as an HTTP_MALFORMED_FRAME
-error.
+A PRIORITY frame that references a non-existent Push ID, a Placeholder ID
+greater than the server's limit, or a Stream ID the client is not permitted to

For stream IDs, is this "not **yet** permitted"?  The previous paragraph establishes the use of HTTP_MALFORMED_FRAME for the wrong type of stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326#pullrequestreview-190995974

---

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 15:45:12 -0800

MikeBishop commented on this pull request.

And stream IDs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326#discussion_r246592581

---

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 15:47:12 -0800

@MikeBishop pushed 1 commit.

cb02e6026a221238025d51e512e5c4acb3521deb  Martin's requested precisions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326/files/6d121319c71dfd21a49a1bceacf66be31188d445..cb02e6026a221238025d51e512e5c4acb3521deb

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 10 Jan 2019 04:11:40 -0800

dtikhonov approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326#pullrequestreview-191175064

---

From: Mike Bishop <[email-masked]>
Date: Thu, 10 Jan 2019 09:54:10 -0800

Merged #2326 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2326#event-2066565626