Subject: [quicwg/base-drafts] What does a server do with Handshake packets not belonging any connection? (#2333)

From: Marten Seemann <[email-masked]>
Date: Sun, 13 Jan 2019 22:37:26 -0800

This could e.g. happen if a server loses state after sending the ServerHello, and comes back up before the client gives up. Or it could just be an incorrectly routed Handshake packet.

Currently, the spec doesn't say anything explicitly about this case, so the general case about receiving a packet that is not associated with any connection applies, thus we'd send a Stateless Reset. There are two problems with this solution:

* We clearly can do better than sending a random data, since we have access to the source connection ID on the incoming packet, so in principle we are able to ensure correct routing of the stateless reset.
* That doesn't really help though, since the client might not have received the stateless reset token yet, and would just drop the stateless reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2333

---

From: Marten Seemann <[email-masked]>
Date: Sun, 13 Jan 2019 22:43:53 -0800

I just saw that we already have text about that:
> An endpoint MAY send a stateless reset in response to a packet with a long header. This would not be effective if the stateless reset token was not yet available to a peer. In this QUIC version, packets with a long header are only used during connection establishment. Because the stateless reset token is not available until connection establishment is complete or near completion, ignoring an unknown packet with a long header might be more effective.

Sorry for the noise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2333#issuecomment-453913245

---

From: Marten Seemann <[email-masked]>
Date: Sun, 13 Jan 2019 22:43:53 -0800

Closed #2333.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2333#event-2071031491