Subject: Re: [quicwg/base-drafts] DATA frame encoding is inefficient for long dynamically generated bodies (#1885)

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 21:18:29 -0800

PR reverted; reopened for discussion in Tokyo.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#issuecomment-459219139

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 21:18:29 -0800

Reopened #1885.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#event-2108455920

---

From: ianswett <[email-masked]>
Date: Wed, 30 Jan 2019 21:18:29 -0800

Reopening because this was merged and then reverted without a proper resolution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#issuecomment-459219143

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 21:55:57 -0800

Closed #1885.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#event-2108498130

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 21:55:57 -0800

Discussed in Tokyo; this is viewed as an important optimization.  There are ways to solve this by modifying the HTTP/3 framing layer, but it has challenges, notably for proxies.  This can be solved by extensions (EXTERNAL_DATA, END_OF_FRAMES).  We should do so to learn more.

However, the "optimal" solution might be a QUIC stream-of-messages feature in the future, which is already being discussed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#issuecomment-459225491

---

From: Luca Niccolini <[email-masked]>
Date: Wed, 30 Jan 2019 22:03:04 -0800

@MikeBishop, since the revert was partial, the net effect of this issue was to remove the text that was forbidding DATA frames with zero length. 
https://tools.ietf.org/rfcdiff?url2=draft-ietf-quic-http-17.txt

So now the RFC is in an inconsistent state, where zero-len DATA frames are allowed, but we don't know what they are. Are they just not an error but should be ignored ? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1885#issuecomment-459226772