Subject: Re: [quicwg/base-drafts] Ignore loss of undecryptable packets (#2028)

From: ianswett <[email-masked]>
Date: Sun, 06 Jan 2019 13:32:01 -0800

@ianswett pushed 1 commit.

bcfebcc5a8f1ed9058e8126da7dd70c664676de6  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028/files/a0ecdfddb002a75e041e3bd549d1766a282d939a..bcfebcc5a8f1ed9058e8126da7dd70c664676de6

---

From: ianswett <[email-masked]>
Date: Sun, 06 Jan 2019 13:32:36 -0800

1f88d44eb8967af230db9dd9885d75cdf5506d9a  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028/files/bcfebcc5a8f1ed9058e8126da7dd70c664676de6..1f88d44eb8967af230db9dd9885d75cdf5506d9a

---

From: ianswett <[email-masked]>
Date: Sun, 06 Jan 2019 13:33:06 -0800

e33155329947afb75d7dc97373578fd6f1319844  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028/files/1f88d44eb8967af230db9dd9885d75cdf5506d9a..e33155329947afb75d7dc97373578fd6f1319844

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 20:47:05 -0800

There are a few suggestions outstanding here.  @ianswett?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028#issuecomment-452570695

---

From: ianswett <[email-masked]>
Date: Wed, 09 Jan 2019 06:19:06 -0800

ianswett commented on this pull request.

> @@ -1000,6 +999,17 @@ The recovery period limits congestion window reduction to once per round trip.
 During recovery, the congestion window remains unchanged irrespective of new
 losses or increases in the ECN-CE counter.
 
+## Loss of protected packets during the handshake
+
+0RTT and 1RTT packets sent prior to handshake completion can arrive before
+the peer has keys to unprotect them.  In those cases, the peer may decide
+not to buffer the packets.  This will cause the packets to never be
+acknowledged and eventually declared lost, despite being delivered to
+the peer.  If the server rejects 0RTT, then the congestion controller

Done in the other PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028#discussion_r246397227

---

From: ianswett <[email-masked]>
Date: Thu, 10 Jan 2019 11:28:43 -0800

Closing in favor of #2327

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028#issuecomment-453222884

---

From: ianswett <[email-masked]>
Date: Thu, 10 Jan 2019 19:28:43 +0000 (UTC)

Closed #2028.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2028#event-2066775766