Subject: [quicwg/base-drafts] Restrict PUSH_PROMISE to request streams (#2323)

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 19:29:47 +0000 (UTC)

Fixes #1920.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2323

-- Commit Summary --

  * Restrict P_P to request streams

-- File Changes --

    M draft-ietf-quic-http.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2323.patch
https://github.com/quicwg/base-drafts/pull/2323.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Jan 2019 23:41:10 +0000 (UTC)

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#pullrequestreview-190995132

---

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 15:42:38 -0800

@MikeBishop pushed 1 commit.

54b47960490aae7a35b6a15cd81fd4b988377e71  Gah, you know what I meant

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323/files/e316d3a02b3bd9965c4735122d909c5828321d43..54b47960490aae7a35b6a15cd81fd4b988377e71

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 09 Jan 2019 17:44:21 -0800

kazuho commented on this pull request.

> @@ -723,7 +723,7 @@ with its 0-RTT data.
 ### PUSH_PROMISE {#frame-push-promise}
 
 The PUSH_PROMISE frame (type=0x05) is used to carry a promised request header
-set from server to client, as in HTTP/2.
+set from server to client on a request stream, as in HTTP/2.

Isn't the use of a PUSH_PROMISE frame also possible on a Push Stream?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#pullrequestreview-191020999

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Jan 2019 19:34:27 -0800

martinthomson commented on this pull request.

I don't believe so.  I guess it could, but then you would have to propagate the push to all the streams that referenced that push with PUSH_PROMISE/DUPLICATE_PUSH.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#discussion_r246627604

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 09 Jan 2019 21:19:18 -0800

Thank you for the clarification. I think having the restriction is fine, because now I realize that RFC 7540 has the same restriction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#discussion_r246638614

---

From: Mike Bishop <[email-masked]>
Date: Thu, 10 Jan 2019 09:21:23 -0800

MikeBishop commented on this pull request.

Right -- same as 7540.  The reason for this is that once a request stream is closed, you know the full set of pushes that are expected in relation to that request.  However, if you allow new promises on push streams, you have to wait until all pushes are satisfied to get a complete set.

I'd be open to a discussion on loosening that requirement, but it's unrelated to QUIC -- write an HTTPbis draft advocating the change if you want it.  :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#discussion_r246849126

---

From: Mike Bishop <[email-masked]>
Date: Tue, 15 Jan 2019 15:29:40 -0800

Merged #2323 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2323#event-2076056206