Subject: Re: [quicwg/base-drafts] Introduce terms dynamic table capacity and maximum dynamic table capacity. (#2115)

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 20:50:42 -0800

martinthomson approved this pull request.

This is a good change.

> @@ -650,32 +656,31 @@ entries which are frequently referenced, both to avoid the need to resend the
 header and to avoid the entry in the table blocking the ability to insert new
 headers.
 
-### Dynamic Table Size Update {#size-update}
+### Dynamic Table Capacity Update {#capacity-update}

```suggestion
### Set Dynamic Table Capacity {#set-capacity}
```

Is this a better formulation?  Set is more direct.

Note that there are more places to fix than this, but you get the idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115#pullrequestreview-190572704

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 08 Jan 2019 20:56:09 -0800

kazuho commented on this pull request.

> @@ -1011,7 +1016,7 @@ represented as an 8-bit prefix string literal.
 
 QPACK defines two settings which are included in the HTTP/3 SETTINGS frame.
 
-  SETTINGS_HEADER_TABLE_SIZE (0x1):
+  SETTINGS_MAXIMUM_DYNAMIC_TABLE_CAPACITY (0x1):

I think we'd better have either "QPACK" or "HEADER" as part of the name, to avoid confusion. Other than that, the PR looks good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115#pullrequestreview-190573387

---

From: Mike Bishop <[email-masked]>
Date: Wed, 09 Jan 2019 23:44:34 +0000 (UTC)

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115#pullrequestreview-190995996

---

From: afrind <[email-masked]>
Date: Thu, 10 Jan 2019 23:04:38 +0000 (UTC)

@afrind pushed 1 commit.

9a64833f87beed5de7b375f1ae81fff2fb1d2dc4  * Changed setting to SETTINGS_QPACK_MAX_TABLE_CAPACITY

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115/files/2153fc72d25018fd2b6ad4de9f6f00824736c96a..9a64833f87beed5de7b375f1ae81fff2fb1d2dc4

---

From: afrind <[email-masked]>
Date: Thu, 10 Jan 2019 23:15:04 +0000 (UTC)

@afrind pushed 1 commit.

fcf41f0b3e6fe780f5fd58093f52d87c262597e1  * Missed the setting name update in a couple places

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115/files/9a64833f87beed5de7b375f1ae81fff2fb1d2dc4..fcf41f0b3e6fe780f5fd58093f52d87c262597e1

---

From: afrind <[email-masked]>
Date: Thu, 10 Jan 2019 15:48:13 -0800

Merged #2115 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2115#event-2067287788