Subject: Re: [quicwg/base-drafts] persistent congestion is more aggressive than RTO verified (#2255)

From: ianswett <[email-masked]>
Date: Mon, 07 Jan 2019 20:30:11 -0800

I believe the text is now correct, but the pseudocode is still incorrect in the way you describe.

I think we should introduce a largest_sent_before_congestion variable as a replacement, but I'm open to other solutions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2255#issuecomment-452171684

---

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 14:45:56 -0800

I'm removing design.  I consider this a bug fix, but still very important.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2255#issuecomment-454581225

---

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 22:50:57 +0000 (UTC)

See #2293 which I believe fixes the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2255#issuecomment-454582493

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Jan 2019 16:17:40 -0800

I've been using `design` to mark things that will result in changes that affect implementations.  This would seem to fit that description.  Whether you consider it worth discussing is different.  If it isn't worth discussing, maybe it will just be fixed by #2293 and everything will be fine without discussion in Tokyo.

WIthout the label, this won't make the change log, and that might be a problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2255#issuecomment-454602051

---

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 16:23:05 -0800

Fair point, I think #2293 fixes the text, but I'll re-label this as design to ensure it's included in the changelogs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2255#issuecomment-454603076