Subject: [quicwg/base-drafts] Specify DCID of 0-RTT packets (#2398)

From: MikkelFJ <[email-masked]>
Date: Thu, 31 Jan 2019 10:08:13 +0000 (UTC)

This has been discussed before, but after reorg. of text, I can't find any clear statement in Transport Draft about how to create DCID for 0-RTT. The DCID field is not mentioned for 0-RTT packets in transport draft.

https://github.com/quicwg/base-drafts/issues/1513
https://github.com/quicwg/base-drafts/issues/1721

Note: I got the think about this in the context of replay attack prevention which would be simpler of the 0-RTT DCID is not random. But that discussion was already closed in the above issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2398

---

From: Martin Thomson <[email-masked]>
Date: Thu, 31 Jan 2019 03:00:05 -0800

We previously discussed this and the conclusion was to change to the server-selected connection ID once a packet has been received from the server.  Until then, the random value would be used.  If this is missing, then we just need some text in the 0-RTT packet section to cover this.  This probably just needs to reference [Section 7.2](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#negotiating-connection-ids), which says:

>  Upon receiving a packet, each endpoint sets the Destination Connection ID it sends to match the value of the Source Connection ID that they receive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2398#issuecomment-459303491