Subject: [quicwg/base-drafts] HTTP/3 should use TLV (#2395)

From: ianswett <[email-masked]>
Date: Wed, 30 Jan 2019 15:31:58 -0800

TLS uses TLV and QUIC use TV.  HTTP/2 uses LTV, but HTTP/3 frames are so different from HTTP/2's frames that there's no code reuse benefit of LTV, so making HTTP/3 similar to those two seems like a better choice in my opinion.

Benefits originally cited:
 You can switch on the frame type before you even read a variable-length value
 You can have special-case (negotiated) frame types with no lengths

As discussed in #2235 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2395

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 20:58:27 -0800

Discussed in Tokyo; no opposition to this change and some support.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2395#issuecomment-459215682