Subject: Re: [quicwg/base-drafts] How many datagrams can a client send prior to validating the path? (#2135)

From: ianswett <[email-masked]>
Date: Tue, 15 Jan 2019 15:29:03 -0800

@kazuho I don't see anyone objecting to that approach, is there some text you'd like added to one of the drafts?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454591693

---

From: MikkelFJ <[email-masked]>
Date: Wed, 16 Jan 2019 09:13:53 +0000 (UTC)

I was thinking:

The client creates a valid connection. Then initiates a migration to a new path that it does not own for the sole purpose of DoS'ing some other poor individual. While there is a setup cost, the migration can be repeated for the same or different targets until the peer decides it is enough and closes.

How is the initial CWND sufficient protection against that?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454706369

---

From: ianswett <[email-masked]>
Date: Wed, 16 Jan 2019 07:53:32 -0800

@mikkelfj Malicious clients can always send an unlimited number of packets anywhere.  QUIC doesn't change that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454830134

---

From: MikkelFJ <[email-masked]>
Date: Wed, 16 Jan 2019 08:02:34 -0800

@ianswett I mean that the client causes the peer to respond to a fake migration attempt and coerces the peer into sending packets elsewhere. I'm not sure if that can amplify, e.g. via PMTU probe.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454833900

---

From: MikkelFJ <[email-masked]>
Date: Wed, 16 Jan 2019 08:04:25 -0800

I think we had a similar discussion twice, getting some text, and later removed. But I don't recall anymore.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454834611

---

From: ianswett <[email-masked]>
Date: Wed, 16 Jan 2019 16:57:11 +0000 (UTC)

There's a section on address validation which should prevent reflection attacks: https://tools.ietf.org/html/draft-ietf-quic-transport-17#section-8

This issue is about what the client can send.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454855460

---

From: MikkelFJ <[email-masked]>
Date: Wed, 16 Jan 2019 09:29:33 -0800

@ianswett thanks, that covers it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-454867312

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Jan 2019 19:30:48 -0800

@ianswett 
> I don't see anyone objecting to that approach, is there some text you'd like added to one of the drafts?

Filed #2341. I do not have a strong opinion on whether this needs to be clarified, therefore I would not oppose if the PR gets refused.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-455029746

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 01:38:05 -0800

Thanks for the PR.  I'm not against clarification, I'm just not sure what to write and I'd like to close this before Tokyo if we can.  Taking a look at the PR now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#issuecomment-455105747

---

From: Martin Thomson <[email-masked]>
Date: Sun, 20 Jan 2019 20:14:04 -0800

Closed #2135 via #2341.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2135#event-2085411696