Subject: [quicwg/base-drafts] HTTP/3: Push stream description diagram is ambiguous (#2338)

From: Lucas Pardue <[email-masked]>
Date: Wed, 16 Jan 2019 07:53:20 -0800

Push streams are special, compared to other unidirectional streams, because they requires some some additional preface (Push ID) before allowing frames.

Reading through section 3.2 again. It seems like a reader could be mislead by the combination of figure 1 and 2.

The usual convention across QUIC and HTTP/3 specs is to define a frame header, then later section define the frame body. The Push stream shown in figure 2 duplicates the stream header field, and I think it could be misread as saying there are two stream headers.

Do others think this is a problem? We could fix the diagram or remove it completely. Or something else entirely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2338

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Jan 2019 11:29:36 -0800

I'm not sold on this being a problem, but let's see what others think.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2338#issuecomment-454908486