Subject: [quicwg/base-drafts] endpoints are allowed to retransmit entire payload of a lost packet (#2312)

From: Kazuho Oku <[email-masked]>
Date: Mon, 07 Jan 2019 12:15:29 -0800

In #1612 we agreed on this.

Considering that the decision affects handling of multiple frames, I think it's worth clarifying the general rule in the draft. For discussions regarding specific frames, please refer:
* MAX_STREAMS, MAX_DATA, MAX_STREAM_DATA - #1622
* RESET_STREAM, STOP_SENDING - #2268
* ACK  - #2205

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2312

-- Commit Summary --

  * endpoints are allowed to retransmit entire payload of a packet that's deemed lost; see #1612

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2312.patch
https://github.com/quicwg/base-drafts/pull/2312.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312

---

From: MikkelFJ <[email-masked]>
Date: Mon, 07 Jan 2019 20:47:34 +0000 (UTC)

If you want to be explicit, perhaps also mention that stream ranges can be retransmitted with different boundaries or partially, if this isn't already covered by some existing text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#issuecomment-452076253

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 07 Jan 2019 13:39:03 -0800

@mikkelfj While that's possible, I think we should better handle retransmission rules of specific frames in separate PRs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#issuecomment-452091190

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 Jan 2019 15:45:28 -0800

martinthomson requested changes on this pull request.

While I think that we permit this, this has the effect of encouraging it.  I would move this statement to [Section 13.2](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#retransmission-of-information) and include a little more framing.  That would put it in context better.  That is, endpoints are strongly encouraged to generate new frames for sending information that didn't make it, but they need to be tolerant of peers that just regurgitate the same frames multiple times.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#pullrequestreview-190042307

---

From: ianswett <[email-masked]>
Date: Mon, 07 Jan 2019 20:11:38 -0800

I agree that I'd like to discourage this a bit more than this PR does.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#issuecomment-452169422

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 07 Jan 2019 20:47:37 -0800

@martinthomson @ianswett Your comments make sense to me. I'll update the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#issuecomment-452174026

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 08 Jan 2019 10:33:46 +0000 (UTC)

Moved to 13.2, expanding the text to encourage reassembling frames containing up-to-date information.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#issuecomment-452251344

---

From: ianswett <[email-masked]>
Date: Tue, 08 Jan 2019 21:22:55 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#pullrequestreview-190448351

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 14:23:38 -0800

martinthomson approved this pull request.

> @@ -2985,6 +2985,12 @@ Endpoints SHOULD prioritize retransmission of data over sending new data, unless
 priorities specified by the application indicate otherwise (see
 {{stream-prioritization}}).
 
+Even though a sender is encouraged to assemble frames containing up-to-date
+information every time it sends a packet, it is not forbidden to retransmit
+frames of lost packets as they are.  A receiver MUST accept packets containing

```suggestion
copies of frames from lost packets.  A receiver MUST accept packets containing
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#pullrequestreview-190471406

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 14:27:26 -0800

Merged #2312 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2312#event-2061495526