Subject: [quicwg/base-drafts] Version field in Retry packets (#2397)

From: Lars Eggert <[email-masked]>
Date: Wed, 30 Jan 2019 16:09:37 -0800

Consensus on Slack seems to be that a server should set the version field of a Retry packet to v1 (i.e., echo the version from the client Initial ), and that a client should verify that a received Retry packet echoes the version it sent.

However, I cannot find corresponding text in the documents.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397

---

From: Lars Eggert <[email-masked]>
Date: Wed, 30 Jan 2019 16:26:24 -0800

Talking to @nibanks, the issue should maybe be rephrased more generally, in that the document should make it clear(er) that incoming long-header packets need to pass an "invariant check" before any further processing. The version match check on Retry is part of that more general check. Renaming the issue accordingly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397#issuecomment-459165917

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 16:41:00 -0800

Well, Retry is a packet type defined in version 1.  If you receive a v2 packet and you don't speak v2, you have no idea what that packet means, even if it superficially *looks* like a Retry packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397#issuecomment-459168891

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 16:53:52 -0800

Also, from 5.2.1:
> If a client receives a packet that has an unsupported version, it MUST discard that packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397#issuecomment-459171544

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Jan 2019 18:46:17 -0800

Tokyo conclusion: editorial.  You discard packets from versions other than the negotiated version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397#issuecomment-459194179

---

From: MikkelFJ <[email-masked]>
Date: Wed, 30 Jan 2019 23:53:49 -0800

> So the answer by current spec might be different for a v1+2-capable client which sent a v1 Initial versus a v1-only client.

That's interesting. Probably not the intention, but it would allow a v2 SuperRetry packet to be retrofitted into an otherwise v1 connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2397#issuecomment-459249779