Subject: Re: [quicwg/base-drafts] It's annoying that one can't send push in 0.5RTT (#2227)

From: ianswett <[email-masked]>
Date: Fri, 04 Jan 2019 00:40:18 -0800

One question on: "Using the request as context is what made it possible to support push at all in cases where there are multiple users of the same connection (a common occurrence)."
I thought browsers don't pool connections from different users?  That seems sensible from a user-expectation and privacy perspective.

Proxies may, but they should really be providing some other user-isolation besides a push ID to ensure the response doesn't get pushed back to the wrong user.  Or they should only use push from the server to end user, which I suspect is actually what happens.

I'm not arguing for replacing the current push design with unbound push, but we should be willing to make changes to push in cases the original assumptions didn't turn out to be true.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-451384724

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 14:15:54 -0800

The original requirement was, I think, from HTTP.SYS, so @MikeBishop might be able to provide more insight there.  There, you can have different applications sharing the same connection, I recall.  Whether that is advisable, I haven't thought through fully.  I think that gateways/reverse proxies were a case for this more than (forward) proxies.

Even within a browser, requests from the same origin can share connections (though not always).  Even there, you might want to know whether the push was attributed to a page load in one context vs. another.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-451780072

---

From: ianswett <[email-masked]>
Date: Mon, 07 Jan 2019 07:25:37 -0800

I can imagine someone saying that a reverse proxy might want to be able to do this, I just don't think reverse proxies actually proxy pushes that are otherwise end-to-end.  But I haven't worked with every reverse proxy out there, so maybe some do?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-451970790

---

From: afrind <[email-masked]>
Date: Tue, 08 Jan 2019 09:08:38 -0800

Maybe I'm not understanding @ianswett's comment, but our reverse proxy is capable of proxying HTTP/2 pushes (by virtue of the fact that they are bound to a request).  That said, given that push is an optimization anyways, a reverse proxy could always drop or cancel an unbound push if it couldn't figure out which client(s) to send it to.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-452376532

---

From: ianswett <[email-masked]>
Date: Tue, 08 Jan 2019 10:28:28 -0800

Thanks @afrind , good to know.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-452402501

---

From: ianswett <[email-masked]>
Date: Tue, 08 Jan 2019 10:29:13 -0800

Thanks for quicv2-ing this Martin.  That seems appropriate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2227#issuecomment-452402761