Subject: [quicwg/base-drafts] extended unidirectional streams can be closed or reset (#2332)

From: Kazuho Oku <[email-masked]>
Date: Sat, 12 Jan 2019 16:43:59 -0800

closes #2331.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2332

-- Commit Summary --

  * extended unidirectional streams can be closed or reset

-- File Changes --

    M draft-ietf-quic-http.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2332.patch
https://github.com/quicwg/base-drafts/pull/2332.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 12 Jan 2019 17:05:52 -0800

LPardue commented on this pull request.

I think this is almost there. There is already some text recommending RESET_STREAM logic for push streams, which are not extensions (see section 4.2.4).

Perhaps we can generalise the statement?

Also typo a minor typo "s/torelate/tolerate"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#pullrequestreview-191957033

---

From: Kazuho Oku <[email-masked]>
Date: Sat, 12 Jan 2019 17:24:55 -0800

@kazuho pushed 1 commit.

ac04348e4b471f4906224a9d6121b90c550ba3f7  fix typo

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332/files/081cd369fcf752124aa13fbbb18d8de884d6ddbf..ac04348e4b471f4906224a9d6121b90c550ba3f7

---

From: Kazuho Oku <[email-masked]>
Date: Sat, 12 Jan 2019 17:27:43 -0800

@LPardue Do you have a specific suggestion re how we can generalize? My assumption has been that we cannot generalize, because control stream and QPACK streams can never be closed or reset.

And thank you for catching the typo. Fixed that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#issuecomment-453794273

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 12 Jan 2019 17:42:39 -0800

Something like lose the first sentence and say instead "Some unidirectional  stream types are allowed to be closed or reset during a connection. A receiver MUST tolerate unidirectional stream close or reset prior to reception of the type byte."

Not sure my version is any better...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#issuecomment-453794895

---

From: Kazuho Oku <[email-masked]>
Date: Sat, 12 Jan 2019 17:50:36 -0800

@kazuho pushed 1 commit.

05e411e7f26774ed6d25b530dda6328c9e931084  designate the streams that MUST NOT be closed

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332/files/ac04348e4b471f4906224a9d6121b90c550ba3f7..05e411e7f26774ed6d25b530dda6328c9e931084

---

From: Kazuho Oku <[email-masked]>
Date: Sat, 12 Jan 2019 17:53:21 -0800

@LPardue Thank you for the clarification. I agree that we should refrain from having a text that might seen as to imply that a push stream cannot be reset prior to sending the type byte.

I've changed the approach to clarify the general rule (that the streams can be reset or closed) then name out the exceptions. Does that look better?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#issuecomment-453795287

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 13 Jan 2019 01:45:58 -0800

Lgtm, thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#issuecomment-453815680

---

From: Martin Thomson <[email-masked]>
Date: Sun, 13 Jan 2019 14:51:53 -0800

martinthomson approved this pull request.

> @@ -334,6 +334,10 @@ them.  However, stream types which could modify the state or semantics of
 existing protocol components, including QPACK or other extensions, MUST NOT be
 sent until the peer is known to support them.
 
+A sender can close or reset a unidirectional stream unless specified otherwise.
+A receiver MUST tolerate unidirectional streams being closed or reset prior to
+the reception of the unidirecitonal stream header.

```suggestion
the reception of the unidirectional stream header.
```

> @@ -588,9 +588,9 @@ instruction space:
 <!-- s/exactly/no more than/  ? -->
 There MUST be exactly one of each unidirectional stream type in each direction.
 Receipt of a second instance of either stream type MUST be treated as a
-connection error of HTTP_WRONG_STREAM_COUNT.  Closure of either unidirectional
-stream MUST be treated as a connection error of type
-HTTP_CLOSED_CRITICAL_STREAM.
+connection error of HTTP_WRONG_STREAM_COUNT.  The streams MUST NOT be closed.

```suggestion
connection error of HTTP_WRONG_STREAM_COUNT.  These streams MUST NOT be closed.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#pullrequestreview-191994530

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 13 Jan 2019 15:37:10 -0800

@kazuho pushed 1 commit.

29b9935a474f1e0ae94fc0d547cb438bf9047a6d  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332/files/05e411e7f26774ed6d25b530dda6328c9e931084..29b9935a474f1e0ae94fc0d547cb438bf9047a6d

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 13 Jan 2019 15:37:38 -0800

@kazuho pushed 1 commit.

53268acc79cda7151fd3f7325f5f9a0e703891e3  Update draft-ietf-quic-qpack.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332/files/29b9935a474f1e0ae94fc0d547cb438bf9047a6d..53268acc79cda7151fd3f7325f5f9a0e703891e3

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Jan 2019 17:46:33 +0000 (UTC)

MikeBishop approved this pull request.

Looks good.

```suggestion
A sender can close or reset a unidirectional stream unless otherwise specified.
```
This is the more usual word ordering, though I admit I don't know why.  :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#pullrequestreview-192276265

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 14 Jan 2019 09:56:31 -0800

https://books.google.com/ngrams/graph?content=unless+specified+otherwise%2C+unless+otherwise+specified&year_start=1800&year_end=2000&corpus=15&smoothing=3&share=&direct_url=t1%3B%2Cunless%20specified%20otherwise%3B%2Cc0%3B.t1%3B%2Cunless%20otherwise%20specified%3B%2Cc0

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#discussion_r247593825

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Jan 2019 09:59:10 -0800

MikeBishop commented on this pull request.

Interesting data, but it doesn't argue strongly either direction.  One is vastly more common but having a decline, while the other is uncommon but gaining.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#discussion_r247594836

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 14 Jan 2019 19:11:43 -0800

@kazuho pushed 1 commit.

ac56fb43c6d200a35271c120c274fcdc703ecd9e  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332/files/53268acc79cda7151fd3f7325f5f9a0e703891e3..ac56fb43c6d200a35271c120c274fcdc703ecd9e

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 14 Jan 2019 19:13:02 -0800

kazuho commented on this pull request.

Thank you for the suggestion and the discussion. I've applied the suggested fix assuming that @LPardue would not complain "unless otherwise specified" to be incorrect.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#discussion_r247752052

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Jan 2019 16:30:58 +0000 (UTC)

Merged #2332 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2332#event-2077905634