Subject: [quicwg/base-drafts] MAX_STREAM_DATA risk unbounded state (#2353)

From: MikkelFJ <[email-masked]>
Date: Sat, 19 Jan 2019 02:40:10 -0800

MAX_STREAM_DATA should not be able to be transmitted on uni-directional until frames have been received on the same or a higher numbered stream of same type. Or until the stream is created for bidi streams.

If this is not the case, a peer can force the initiator to track unbounded state and frames or risk frames being received when an endpoint is not ready to handle them.

See discussion here

https://github.com/quicwg/base-drafts/pull/2352#issuecomment-455767160

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353

---

From: Marten Seemann <[email-masked]>
Date: Sat, 19 Jan 2019 02:45:48 -0800

As I said in that discussion, I don't think there's an unresolved issue here. [We already have text about that](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#frame-max-stream-data):

> An endpoint that receives a MAX_STREAM_DATA frame for a send-only stream it has not opened MUST terminate the connection with error STREAM_STATE_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353#issuecomment-455769293

---

From: MikkelFJ <[email-masked]>
Date: Sat, 19 Jan 2019 02:49:38 -0800

Sorry if that is the case. My impression was that you used it as an example to where we did not have such protection, and didn't care. I'll leave it open for now since the term "has not opened" is also a bit vague. Exactly what state must the sender be in for this to count?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353#issuecomment-455769549

---

From: Martin Thomson <[email-masked]>
Date: Sun, 20 Jan 2019 20:39:59 -0800

This is a non-issue, with the clarifications in the PRs incoming.  That is, you can only receive MAX_STREAM_DATA for a stream that you have decided to open.  At that point you have decided to track considerably more state than a flow control limit.  We can leave this until #2354 or similar lands.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353#issuecomment-455946353

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 11:48:45 -0800

Closed #2353 via 387bdf44ac7dcf676b4a6e4ed497195f1d71710d.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353#event-2089794035

---

From: MikkelFJ <[email-masked]>
Date: Tue, 22 Jan 2019 12:50:23 -0800

Thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2353#issuecomment-456558158