Subject: Re: [quicwg/base-drafts] Why are setting identifiers not varints? (#2233)

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 20:47:01 -0800

In Tokyo, agreed to do this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2233#issuecomment-459213811

---

From: MikkelFJ <[email-masked]>
Date: Thu, 31 Jan 2019 00:35:09 -0800

With minimal encoding.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2233#issuecomment-459260254

---

From: Martin Thomson <[email-masked]>
Date: Thu, 31 Jan 2019 02:55:50 -0800

No, the conclusion was to not require minimal encoding for anything.  There is a performance argument for QUIC frames because they are used very frequently, but even that has been challenged.  The minimal encoding is only a miniscule amount more efficient, and it's more annoying to create.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2233#issuecomment-459302278

---

From: MikkelFJ <[email-masked]>
Date: Thu, 31 Jan 2019 07:45:58 -0800

It makes it slower to parse than JSON

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2233#issuecomment-459392986