Subject: [quicwg/base-drafts] Allow extra data after self-terminating h3 frames (#2289)

From: David Schinazi <[email-masked]>
Date: Thu, 03 Jan 2019 17:02:32 -0800

The current spec is overly restrictive when it comes to self-terminating h3 frames. If implementations ignore extra data after the expected bytes, this will allow us to add fields down the road without the need to specify new frame types.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2289

-- Commit Summary --

  * Allow extra data after self-terminating h3 frames

-- File Changes --

    M draft-ietf-quic-http.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2289.patch
https://github.com/quicwg/base-drafts/pull/2289.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2289

---

From: David Schinazi <[email-masked]>
Date: Thu, 03 Jan 2019 17:05:25 -0800

@DavidSchinazi pushed 1 commit.

df39c65b16f5a42351af03377a42f88f14cdf5eb  fix line length

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2289/files/12ab695e81cbe88312dad67441303bb22603c3e8..df39c65b16f5a42351af03377a42f88f14cdf5eb

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 03 Jan 2019 17:19:01 -0800

I think I get part of the motivation for this but don't understand how this change on it's own allows extensibility with robust interop. Or in other words, how do endpoints make sure they process postfix fields, as expected by the sender, that arent defined anywhere? 

Channelling the editors, it seems this PR needs an issue to discuss the broader use cases and design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2289#issuecomment-451329694

---

From: David Schinazi <[email-masked]>
Date: Thu, 03 Jan 2019 17:30:18 -0800

@LPardue created issue #2291.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2289#issuecomment-451331208