Subject: [quicwg/base-drafts] Indicate which frames go on which stream types (#2351)

From: Mike Bishop <[email-masked]>
Date: Fri, 18 Jan 2019 13:28:44 -0800

While each frame's description indicates the stream type(s) on which it is allowed, there isn't one unified place to indicate which frames are expected on which streams.  QPACK subdivides the instruction space per stream, which has the nice property that you _can't_ put something on the wrong stream.  While that's overkill for H3 (too dramatic a departure from H2, multiple IANA registries, etc.), having a table to indicate which frames are permitted on which streams would be helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2351

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 18 Jan 2019 13:32:21 -0800

I like the table idea for both. Want a PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2351#issuecomment-455694158

---

From: Mike Bishop <[email-masked]>
Date: Fri, 18 Jan 2019 13:35:54 -0800

Text always welcome.  🙂

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2351#issuecomment-455695209

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 20 Jan 2019 15:25:48 -0800

I'll submit two PRs in next day or so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2351#issuecomment-455912585