Subject: Re: [quicwg/base-drafts] Adjust autotuning recommendations (#2240)

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 20:10:27 -0800

janaiyengar commented on this pull request.

>  advertised additional credit based on a round-trip time estimate and the rate at
 which the receiving application consumes data, similar to common TCP
-implementations.
+implementations.  Sending frames related to flow control only when there are
+other frames to send or when a peer is blocked ensures that flow control doesn't

Suggestion: "As an optimization, sending frames ..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2240#discussion_r245200338

---

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 20:10:45 -0800

Looks fine, one suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2240#issuecomment-451349624

---

From: janaiyengar <[email-masked]>
Date: Thu, 03 Jan 2019 20:10:54 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2240#pullrequestreview-189259318

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 14:10:40 -0800

@martinthomson pushed 1 commit.

ac630214da1db388e8cde6428431312517d278b1  Optimization suggestion only

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2240/files/59df95fa2e9f856dfee2d03b163108944122a5bf..ac630214da1db388e8cde6428431312517d278b1

---

From: Martin Thomson <[email-masked]>
Date: Sun, 06 Jan 2019 14:10:47 -0800

Merged #2240 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2240#event-2056479036