Subject: Re: [quicwg/base-drafts] Is Retry a new connection or what? (#2180)

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Jan 2019 18:39:10 -0800

Tokyo conclusion: It's the same connection.  We will prohibit changing the cryptographic handshake message based on receiving Retry.

You can think of this as re-sending a lost Initial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2180#issuecomment-459192852

---

From: MikkelFJ <[email-masked]>
Date: Thu, 31 Jan 2019 00:52:07 -0800

> You can think of this as re-sending a lost Initial.

Not quite, since a retry has a fixed target DCID (stateful) whereas a lost initial has a random OCID that can reach a random server (stateless)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2180#issuecomment-459265142

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 31 Jan 2019 14:05:16 -0800

IIUC, we are going to require the Hello to be the same and to not reset the PN when receiving a Retry.

Assuming that is true, do we need to keep the statement that says that the server CID "MUST not be equal to the Destination Connection ID field of the packet sent by the client"?

I think we can remove it now (for simplicity).

See also: #2179

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2180#issuecomment-459524221

---

From: Martin Thomson <[email-masked]>
Date: Thu, 31 Jan 2019 15:12:39 -0800

@kazuho, that requirement also exists to ensure that the server doesn't fake out the ODCID transport parameter. I think we're should keep that bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2180#issuecomment-459542895

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 31 Jan 2019 16:52:13 -0800

@martinthomson Ah thank you for pointing out that. Agreed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2180#issuecomment-459564697