Subject: Re: [quicwg/base-drafts] When can you coalesce connections (#2223)

From: ianswett <[email-masked]>
Date: Fri, 04 Jan 2019 00:44:04 -0800

Yes, it'd be good to capture something more up-to-date if we can come to consensus on that.

Is explicit signal meant to indicate DNS and/or ORIGIN frame?  If so, maybe call those two out as examples?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2223#issuecomment-451385337

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 04 Jan 2019 00:52:23 -0800

@ianswett I think the dilemma is that some of those things don't exist yet for H3. For example, Mike did some earlier work to redefine ALTSVC frame for H3 but there is yet to be equivalent for ORIGIN or secondary certs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2223#issuecomment-451386793

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Jan 2019 11:36:46 -0800

Yes, it's intentional.  RFC7540 allows coalescing based on the cert and DNS, because you're connected to the authoritative origin.  However, HTTP/3 is never connected on the authoritative endpoint for an http(s?):// URL, so you need something else to tell you that's okay.  This could be an Alt-Svc record for that origin delegating to the same UDP port.  This could be an ORIGIN-for-H3 frame telling you to throw caution to the wind and trust the cert, if the client thinks that's sensible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2223#issuecomment-452424782