Subject: Re: [quicwg/base-drafts] Recommend discarding bad, unauthenticated packets (#2141)

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 20:54:32 -0800

@martinthomson pushed 1 commit.

dfc6b63e956aa4c5153a0eee0157be8dc54bb90f  use MAY

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141/files/71e6434d8b366d776313fbfa67bebb39c0b97677..dfc6b63e956aa4c5153a0eee0157be8dc54bb90f

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 08 Jan 2019 20:57:59 -0800

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141#pullrequestreview-190573637

---

From: Marten Seemann <[email-masked]>
Date: Tue, 08 Jan 2019 21:00:31 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141#pullrequestreview-190573949

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Jan 2019 21:00:58 -0800

In reviewing this, I've watered this down to MAY.  I don't think that it is a real defense against off-path DoS attacks, because it's relatively easy to construct a packet that will avoid detection until the TLS Finished is validated, but I don't think that it's obviously harmful either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141#issuecomment-452572647

---

From: ianswett <[email-masked]>
Date: Wed, 09 Jan 2019 14:34:04 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141#pullrequestreview-190754090

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Jan 2019 14:22:50 -0800

Merged #2141 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2141#event-2064401089