Subject: [quicwg/base-drafts] Spoofed retry token attack on IP authentication (#2394)

From: MikkelFJ <[email-masked]>
Date: Wed, 30 Jan 2019 22:41:42 +0000 (UTC)

If a Man on the Side attacker (A) is able to observe a Retry token from server (S) intended for a legitimate client (C), then (A) can either race (C) to use the token, or hope that the token can be reused within a limited time frame and use the token if if (C) has already done so.

(A) can now start a new apparently legitimate connection by spoofing the source address to that of (C) since it can observe packets sent to that address.

If (S) issued the Retry token in the hope of verifying that it speaks to a trusted machine on the network, then (A) might be able escalate privilege to that of (C).

The defence would be for (S) to not authenticate (C) based solely on its IP, but the Retry facility might lead some operators to believe that a Retry is a reasonably safe identity mechanism.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2394

---

From: MikkelFJ <[email-masked]>
Date: Wed, 30 Jan 2019 16:06:36 -0800

@marten-seemann mentioned that a retry always lands on the same server so it is feasible to require a reset token to always be accepted at most once (assuming there is a reasonable timeout).

However, (A) can then still race (C) to gain privilege.

A less likely attack is that (A) downloads a large file to flood (C) since (C) gets mirrored traffic. But (A) must also be able accept the traffic to maintain ACK's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2394#issuecomment-459161801