Subject: Re: [quicwg/base-drafts] How do I generate an RST? (#2228)

From: janaiyengar <[email-masked]>
Date: Fri, 04 Jan 2019 16:42:24 -0800

Perhaps the text should be "SHOULD", and if the platform doesn't allow it, to "close the connection".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-451610660

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Jan 2019 20:03:06 +0000 (UTC)

There's risk with that too, though.  We encountered issues where the TCP connection was closed cleanly instead of aborted, and the client interpreted a truncated response as the (cacheable) response.  It gets ugly.

If you can't force a RST on the other side, you perhaps shouldn't be implementing CONNECT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-452432900

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:01:03 -0800

Discussed in Tokyo; MUST close the connection, SHOULD close with a RST.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2228#issuecomment-459226376