Subject: Re: [quicwg/base-drafts] Invalid Largest Reference is a connection error. (#2249)

From: Mike Bishop <[email-masked]>
Date: Mon, 07 Jan 2019 14:49:24 -0800

I'm confused -- if LR is invalid, the HEADERS frame can't be interpreted, I agree.  It's unclear why a failure to decode anything on a request stream could constitute an encoder stream error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2249#issuecomment-452110105

---

From: Bence Béky <[email-masked]>
Date: Fri, 11 Jan 2019 17:40:25 -0800

> I'm confused -- if LR is invalid, the HEADERS frame can't be interpreted, I agree. It's unclear why a failure to decode anything on a request stream could constitute an encoder stream error.

Good point.  Let's make it a stream error (with the usual code HTTP_QPACK_DECOMPRESSION_FAILED) then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2249#issuecomment-453708524

---

From: Bence Béky <[email-masked]>
Date: Tue, 22 Jan 2019 19:22:18 -0800

I rebased on #2111, incorporated the suggestion by @MikeBishop above to make it a stream error instead of a connection error, and reconciled that sometimes InsertCount and sometimes ReqInsertCount was used in the decoding algorithm.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2249#issuecomment-456654907