Subject: [quicwg/base-drafts] Connection migration attacks may have other side effects (#2311)

From: Rui Paulo <[email-masked]>
Date: Mon, 07 Jan 2019 10:33:08 -0800

I think the sections that describe connection migration attacks should mention that, when the endpoint detects a spurious migration, it should revert back to using the same CC state and ECN state as before.  Otherwise, an attacker could degrade the performance of a connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2311

---

From: Rui Paulo <[email-masked]>
Date: Tue, 29 Jan 2019 19:39:23 -0800

Perhaps the tag should be recovery, not transports.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2311#issuecomment-458800182

---

From: ianswett <[email-masked]>
Date: Tue, 29 Jan 2019 19:41:03 -0800

I can see it going either way.  @janaiyengar what do you think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2311#issuecomment-458800459