Subject: [quicwg/base-drafts] What scheme should be used for HTTP/3 (#2384)

From: Masaori Koshiba <[email-masked]>
Date: Mon, 28 Jan 2019 21:37:22 -0800

During interop session in Tokyo, @dtikhonov pointed out that current HTTP draft (-17) does not say anything about what `:scheme` should be used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2384

---

From: Mike Bishop <[email-masked]>
Date: Mon, 28 Jan 2019 21:45:39 -0800

This is another variant of #253, actually.  In the current draft, H3 can *only* be used as the target from an Alt-Svc entry.  So the scheme is the scheme of whatever the origin is which gave you an H3 alternate.  That's probably https://, but it could also be http:// (see RFC 8164).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2384#issuecomment-458415388

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:23:37 -0800

Discussed in Tokyo; this is out-of-scope for QUIC and needs to be resolved by the HTTP WG.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2384#issuecomment-459230638

---

From: Mike Bishop <[email-masked]>
Date: Wed, 30 Jan 2019 22:31:23 -0800

Closed #2384.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2384#event-2108542403