Subject: [quicwg/base-drafts] The initial table capacity is zero (#2363)

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 20:11:01 -0800

Which means that encoders have to send a table capacity change instruction as the first instruction they send on the table update stream.  This is never stated clearly in the draft.

It might be possible to assume - incorrectly - that the table capacity is initially set to the maximum value.  We even contemplated this possibility until the complexities of 0-RTT and stream concurrency squashed those dreams.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2363

---

From: hardie <[email-masked]>
Date: Sun, 27 Jan 2019 17:09:19 -0800

Where do you believe the clarification should occur?  3.2.1?  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2363#issuecomment-457971648

---

From: afrind <[email-masked]>
Date: Sun, 27 Jan 2019 19:14:25 -0800

CC: @ekr  who also asked why it's not just set to the maximum, and wants to remove this requirement I think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2363#issuecomment-457986786

---

From: afrind <[email-masked]>
Date: Sun, 27 Jan 2019 23:41:56 -0800

I added text specifying this to #2330 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2363#issuecomment-458026335