Subject: Re: [quicwg/base-drafts] frame type field of CONNECTION_CLOSE provides little value (#1989)

From: ianswett <[email-masked]>
Date: Thu, 10 Jan 2019 12:36:42 -0800

I thought in Paris we agreed to remove a bunch of error codes and then we'd add more back later when we knew which ones we wanted.  I would consider Tokyo "later".

But yes, the frame type is mostly useless, and I'd rather have a more specific error code than PROTOCOL_VIOLATION for the cases when there are frame specific errors.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1989#issuecomment-453244336

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Jan 2019 22:11:48 -0800

Tokyo conclusion: keep the field, over @marten-seemann's objection.  Will confirm on the list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1989#issuecomment-458824837

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Jan 2019 22:11:48 -0800

Closed #1989.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/1989#event-2105620855