Subject: [quicwg/base-drafts] Add note about frequent RTT estimates (#2340)

From: janaiyengar <[email-masked]>
Date: Wed, 16 Jan 2019 18:28:51 -0800

Closes #2067.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2340

-- Commit Summary --

  * Add note about frequent RTT estimates

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2340.patch
https://github.com/quicwg/base-drafts/pull/2340.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340

---

From: erickinnear <[email-masked]>
Date: Wed, 16 Jan 2019 20:48:14 -0800

Looks good to me, always nice to pull that note out of the reference and make sure people see it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#issuecomment-455041278

---

From: erickinnear <[email-masked]>
Date: Wed, 16 Jan 2019 20:48:37 -0800

erickinnear approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-193459184

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 01:46:50 -0800

ianswett commented on this pull request.

> @@ -292,6 +292,10 @@ ack delay field should be ignored.
 Like TCP, QUIC calculates both smoothed RTT and RTT variance similar to those
 specified in {{?RFC6298}}.
 
+A sender might take multiple samples per RTT, and as suggested in {{?RFC6298}},

```suggestion
Taking a sample from every ACK with a larger largest acked is likely to cause a sender to take multiple samples per RTT, and as suggested in {{?RFC6298}},
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-193534236

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 09:47:46 +0000 (UTC)

Suggestion on the text, but I'm happy with the addition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-193534640

---

From: janaiyengar <[email-masked]>
Date: Thu, 17 Jan 2019 20:48:11 +0000 (UTC)

@janaiyengar pushed 1 commit.

e69874c32b91cf82711594194a898ffe2db5ca6d  some more text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/3c1388d952919186d67c5a91f0a65fdf19bf463b..e69874c32b91cf82711594194a898ffe2db5ca6d

---

From: janaiyengar <[email-masked]>
Date: Thu, 17 Jan 2019 12:48:22 -0800

janaiyengar commented on this pull request.

I've rephrased, take a look

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#discussion_r248834876

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 13:45:07 -0800

> @@ -289,8 +289,14 @@ be subtracted from the RTT as long as the result is larger than the min_rtt.
 If the result is smaller than the min_rtt, the RTT should be used, but the
 ack delay field should be ignored.
 
-Like TCP, QUIC calculates both smoothed RTT and RTT variance similar to those
-specified in {{?RFC6298}}.
+A sender calculates both smoothed RTT and RTT variance similar to those
+specified in {{?RFC6298}}, see {{on-ack-received}}.
+
+A sender will commonly receive ACK frames that acknowledge larger packet numbers

Please add text on why this is relevant.  Suggestion "that increase largest acked and therefore generate an RTT sample."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-193857094

---

From: ianswett <[email-masked]>
Date: Thu, 17 Jan 2019 13:49:14 -0800

+than before.  A sender might therefore take multiple samples per RTT (see

Suggestion: replace "A sender..." on with: "When multiple samples are generated within an RTT, the smoothed RTT may retain inadequate RTT history, as suggested in {{?RFC6298}}.  Utilizing multiple RTT samples per RTT in smoothed RTT and RTT variance in a different way is currently an open research question."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-193858610

---

From: janaiyengar <[email-masked]>
Date: Thu, 17 Jan 2019 17:22:13 -0800

f68a65af4ea7d6ed714bcb6ef2c4df06545c787a  more smithing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/e69874c32b91cf82711594194a898ffe2db5ca6d..f68a65af4ea7d6ed714bcb6ef2c4df06545c787a

---

From: janaiyengar <[email-masked]>
Date: Thu, 17 Jan 2019 17:22:18 -0800

I've taken your suggestion but rephrased to avoid a run-on sentence.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#discussion_r248898815

---

From: ianswett <[email-masked]>
Date: Sat, 19 Jan 2019 00:30:36 -0800

I really am not in love with the "A sender might" start.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#discussion_r249238682

---

From: ianswett <[email-masked]>
Date: Sat, 19 Jan 2019 00:34:20 -0800

> @@ -289,8 +289,15 @@ be subtracted from the RTT as long as the result is larger than the min_rtt.
 
+A sender might take multiple samples per RTT because ACK frames that are

Suggestion: "A sender will take multiple samples per RTT when ACK frames are received within an RTT that acknowledge larger packet numbers than before("

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-194349635

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 15:50:34 -0800

martinthomson commented on this pull request.

A sender will take multiple samples per RTT.  RTT samples are taken when the largest acknowledged packet number is increased by an acknowledgment (see).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#discussion_r250007030

---

From: Jana Iyemgar <[email-masked]>
Date: Tue, 22 Jan 2019 15:53:16 -0800

0ee1cd194a04c859809376e7cd8695735223c353  more smithing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/f68a65af4ea7d6ed714bcb6ef2c4df06545c787a..0ee1cd194a04c859809376e7cd8695735223c353

---

From: ianswett <[email-masked]>
Date: Tue, 22 Jan 2019 15:55:30 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-195289951

---

From: Jana Iyemgar <[email-masked]>
Date: Tue, 22 Jan 2019 15:56:39 -0800

e24aa4546545ee99d966bd4b3fe5f242762b6be6  more smithing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/0ee1cd194a04c859809376e7cd8695735223c353..e24aa4546545ee99d966bd4b3fe5f242762b6be6

---

From: Jana Iyemgar <[email-masked]>
Date: Tue, 22 Jan 2019 15:58:58 -0800

c3b713c856e97cfc8869d8aee95dac90b214cb56  split sentence

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/e24aa4546545ee99d966bd4b3fe5f242762b6be6..c3b713c856e97cfc8869d8aee95dac90b214cb56

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Jan 2019 16:10:56 -0800

-Like TCP, QUIC calculates both smoothed RTT and RTT variance similar to those
-specified in {{?RFC6298}}.
+A sender calculates both smoothed RTT and RTT variance similar to those
+specified in {{?RFC6298}}, see {{on-ack-received}}.
+
+A sender takes an RTT sample when an ACK frame is received that acknowledges a
+larger packet number than before (see {{on-ack-received}}).  A sender will take
+multiple RTT samples per RTT when multiple such ACK frames are received within
+an RTT.  When multiple samples are generated within an RTT, the smoothed RTT and
+RTT variance may retain inadequate history, as suggested in {{?RFC6298}}.

```suggestion
RTT variance could retain inadequate history, as suggested in {{?RFC6298}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#pullrequestreview-195293715

---

From: Jana Iyemgar <[email-masked]>
Date: Tue, 22 Jan 2019 16:30:04 -0800

5de160dd752d3d3897ce9064e189b0400c02b0f2  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340/files/c3b713c856e97cfc8869d8aee95dac90b214cb56..5de160dd752d3d3897ce9064e189b0400c02b0f2

---

From: Jana Iyemgar <[email-masked]>
Date: Tue, 22 Jan 2019 16:33:46 -0800

merging, so we can get this into -18

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#issuecomment-456619891

---

From: Jana Iyemgar <[email-masked]>
Date: Wed, 23 Jan 2019 00:33:51 +0000 (UTC)

Merged #2340 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2340#event-2090345236