Subject: [quicwg/base-drafts] Reserved versions are not version-dependent (#2434)

From: Marten Seemann <[email-masked]>
Date: Thu, 07 Feb 2019 01:06:01 +0000 (UTC)

We only talk about reserved versions in the transport document. Since they're used to trigger VN, they need to be version independent. Should they be moved to the invariants?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Feb 2019 18:09:11 -0800

I would say no.  We don't need to make any particular version invariant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-461263374

---

From: Marten Seemann <[email-masked]>
Date: Wed, 06 Feb 2019 18:43:53 -0800

If you include reserved versions for greasing purposes in the VN packet, and we later define a QUIC version with that version number, a client might pick this previously reserved version. So to me it looks like the reserved versions have to be stable between different versions. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-461269199

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Feb 2019 19:13:24 -0800

The registry is stable.  There was talk about moving that, but it never happened.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-461273775