Subject: Re: [quicwg/base-drafts] Ipv6 flow label (#2399)

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Feb 2019 01:08:19 -0800

janaiyengar commented on this pull request.

> @@ -2203,6 +2203,21 @@ address before path validation is complete.
 A client that migrates to a new address SHOULD use a preferred address from the
 same address family for the server.
 
+## Use of IPv6 Flow-Label and Migration {#ipv6-flow-label}
+
+Endpoints that send data using IPv6 SHOULD apply an IPv6 flow label
+in compliance with {{!RFC6437}}, unless the local API does not allow
+setting this parameter.
+
+The IPv6 flow label SHOULD be a pseudo-random function of the source
+and destination addresses, source and destination UDP ports, and the destination
+CID. The flow label generation MUST be designed to minimize the chances of
+linkability with a previously used flow label, as this would enable correlating
+activity on multiple paths (see {{migration-linkability}}).
+
+A possible implementation is to compute the flow label as a one way

```suggestion
A possible implementation is to compute the flow label as a one-way
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#pullrequestreview-199485645

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Feb 2019 01:08:23 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#pullrequestreview-199485673

---

From: Lars Eggert <[email-masked]>
Date: Mon, 04 Feb 2019 03:13:43 -0800

larseggert approved this pull request.

Can we give an example of a suitable one-way has function?

```suggestion
Endpoints that send data using IPv6 SHOULD set an IPv6 flow label for a QUIC connection
```

```suggestion
setting IPv6 flow labels.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#pullrequestreview-199534379

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 12:20:31 -0800

@huitema pushed 1 commit.

d4ea7cf250fbff0a42078506a229c3b1fbbb0111  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/a122343dec6cbe70c07f62798916ec9d04e2c260..d4ea7cf250fbff0a42078506a229c3b1fbbb0111

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 12:22:57 -0800

huitema commented on this pull request.

It is actually per path, not per connection, and is explained in the next paragraph.
@martinthomson suggested replacing "set" by "apply" in a previous comment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#discussion_r253631109

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 12:23:29 -0800

89fbee7952d4192b2a58d0abf1c0c6080c5c2cb7  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/d4ea7cf250fbff0a42078506a229c3b1fbbb0111..89fbee7952d4192b2a58d0abf1c0c6080c5c2cb7

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 20:26:12 +0000 (UTC)

@larseggert I am a bit concerned that specifying the hash function would be overkill. SHA256, HMAC, do we really care? Are we really that concerned that developers are dumb and we must hold their hand?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#issuecomment-460399707

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Feb 2019 13:14:58 -0800

I think that all @larseggert was asking for was an example.  Even saying "a function based on a cryptographic hash" might help.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#issuecomment-460415391

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 13:48:19 -0800

bdd348c613657dff1ba37e0c75f64dd322ddd236  Crypotographic hash for the flow label.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/89fbee7952d4192b2a58d0abf1c0c6080c5c2cb7..bdd348c613657dff1ba37e0c75f64dd322ddd236

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 21:50:21 +0000 (UTC)

OK. I specified a "cryptographic hash"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#issuecomment-460427014

---

From: Christian Huitema <[email-masked]>
Date: Mon, 04 Feb 2019 13:52:14 -0800

5017bc3fca43f71070c39db4e76f023c401bc51c  Split long line.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399/files/bdd348c613657dff1ba37e0c75f64dd322ddd236..5017bc3fca43f71070c39db4e76f023c401bc51c

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Feb 2019 15:28:27 -0800

Merged #2399 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#event-2119945351

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 08 Feb 2019 11:17:30 -0800

fwiw [RFC6437](https://tools.ietf.org/html/rfc6437) is (intentionally) non-specific about the hash function. It says "If a hash algorithm is used, as suggested in Section 3, it SHOULD include a step that makes the flow label value significantly difficult to predict [RFC4086], even with knowledge of the algorithm being used." We didn't see any real need to specify a crypto hash for this purpose, but it's certainly OK. (The example in Appendix A of 6437 stinks and I regret it.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2399#issuecomment-461914419