Subject: [quicwg/base-drafts] Change Idle Timeout Units of Milliseconds (#2453)

From: Nick Banks <[email-masked]>
Date: Mon, 11 Feb 2019 22:27:23 +0000 (UTC)

Currently, the t[ransport parameter for specifying Idle Timeout](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.18.1) is in units of seconds. This seems to be too restrictive and not very future proof. Additionally, from an API perspective, most other timers are settable on the millisecond scale, so it creates a kind of ugly discrepancy between all the different timers settable by the app if just one of them has units of seconds.

I propose we change the units from seconds to milliseconds. The change both for implementations and spec should be minimal, and it makes things (timers) a little more consistent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453

---

From: ianswett <[email-masked]>
Date: Mon, 11 Feb 2019 14:33:32 -0800

This seems sensible to me both for consistency and I can imagine cases when one would want to specify a fraction(ie: 1/2 of a second).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462521973

---

From: Praveen Balasubramanian <[email-masked]>
Date: Mon, 11 Feb 2019 14:54:39 -0800

Agreed. A second is an eternity for a intra-datacenter connection for example. For future proofing all time units should be at least msec IMO.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462527998

---

From: Rui Paulo <[email-masked]>
Date: Tue, 12 Feb 2019 16:18:47 +0000 (UTC)

Don't we want to specify a minimum value now?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462825419

---

From: Nick Banks <[email-masked]>
Date: Tue, 12 Feb 2019 08:24:20 -0800

No, I don't think so. Even before, if you had a greater than 1 sec RTT (somehow...) if you set an idle timeout of 1 second it would cause you problems. I think bottom line you be smart about your idle timeout values. If you set too small a value you can unnecessarily kill your own connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462827885

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 12 Feb 2019 20:09:34 +0000 (UTC)

As @nibanks says, actual idle timeout depends on RTT, and that’s what we have adopted in #2404.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462914879

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 12 Feb 2019 15:52:55 -0800

This SGTM. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-462992230

---

From: David Schinazi <[email-masked]>
Date: Tue, 12 Feb 2019 16:21:49 -0800

I support this

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-463000325

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Feb 2019 23:10:23 -0800

I think this has rough consensus. Tagging as such and reassigning.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#issuecomment-463085042

---

From: Martin Thomson <[email-masked]>
Date: Wed, 13 Feb 2019 12:35:15 -0800

Closed #2453 via #2454.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2453#event-2137867930