Subject: [quicwg/base-drafts] skip draining period in case of idle timeout (#2404)

From: Kazuho Oku <[email-masked]>
Date: Sun, 03 Feb 2019 19:12:29 -0800

Changes are:
* define idle timeout as `max(TP.idle_timeout, 3*PTO)`
* skip draining period when idle timeout expires

closes #2347
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2404

-- Commit Summary --

  * idle_timeout = max(3*PTO, TP.idle_timeout), skip draining period

-- File Changes --

    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2404.patch
https://github.com/quicwg/base-drafts/pull/2404.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404

---

From: Marten Seemann <[email-masked]>
Date: Sun, 03 Feb 2019 19:21:39 -0800

marten-seemann commented on this pull request.

> @@ -2276,9 +2276,10 @@ source address.
 
 ## Idle Timeout {#idle-timeout}
 
-If the idle timeout is enabled, a connection that remains idle for longer than
-the advertised idle timeout (see {{transport-parameter-definitions}}) is closed.
-A connection enters the draining state when the idle timeout expires.
+If the idle timeout is enabled, a connection is closed when it remains idle for
+longer than the larger of the advertised idle timeout (see
+{{transport-parameter-definitions}}) or three times the current Probe Timeout

I don't think this captures your intention of taking the max of these two values.
Suggestion: longer than both ... and ...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#pullrequestreview-199428966

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 03 Feb 2019 19:28:14 -0800

@kazuho pushed 1 commit.

9a277826f4ac031b3a041ab1a2332c8b1441162c  apply @marten-seemann's suggestions, avoid discussing about "idle timeout" which is not the advertised one

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404/files/6f09658c18cfeca0df0c4b1fc435cceaf550b7e8..9a277826f4ac031b3a041ab1a2332c8b1441162c

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 03 Feb 2019 19:29:44 -0800

kazuho commented on this pull request.

 

Makes sense. Made the change in 9a27782 as well as consolidating the description of what to do when the timer expires.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#discussion_r253340833

---

From: Marten Seemann <[email-masked]>
Date: Sun, 03 Feb 2019 19:36:14 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#pullrequestreview-199430285

---

From: Martin Thomson <[email-masked]>
Date: Sun, 03 Feb 2019 19:46:56 -0800

martinthomson approved this pull request.

 
-If the idle timeout is enabled, a connection that remains idle for longer than
-the advertised idle timeout (see {{transport-parameter-definitions}}) is closed.
-A connection enters the draining state when the idle timeout expires.
+If the idle timeout is enabled, a connection is silently closed and the state is
+discarded immediately when it remains idle for longer than both the advertised

```suggestion
discarded when it remains idle for longer than both the advertised
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#pullrequestreview-199431198

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 03 Feb 2019 19:48:52 -0800

@kazuho pushed 1 commit.

3f194e6d19bb4e07ec4537012617fa6e640eb457  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404/files/9a277826f4ac031b3a041ab1a2332c8b1441162c..3f194e6d19bb4e07ec4537012617fa6e640eb457

---

From: ianswett <[email-masked]>
Date: Sun, 03 Feb 2019 21:53:28 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#pullrequestreview-199444134

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Feb 2019 09:06:37 +0000 (UTC)

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#pullrequestreview-199485033

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Feb 2019 01:06:45 -0800

Merged #2404 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#event-2115089011

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Feb 2019 12:42:33 -0800

@janaiyengar, a reminder not to merge things without chair approval.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#issuecomment-460405194

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 05 Feb 2019 01:26:42 -0800

@martinthomson -- yup, I realized it after, so discussed on slack (you're
on the thread)

On Tue, Feb 5, 2019 at 2:12 AM Martin Thomson <[email-masked]>
wrote:

> @janaiyengar <https://github.com/janaiyengar>, a reminder not to merge
> things without chair approval.
>
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/2404#issuecomment-460405194>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AKjg1PoPLiu5xPsXM9Wqac2TOewtH2qeks5vKJs4gaJpZM4agfDn>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2404#issuecomment-460567921