Subject: [quicwg/base-drafts] Close connection if peer becomes unreachable (#2406)

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Feb 2019 01:04:15 -0800

Closes #1638.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2406

-- Commit Summary --

  * Close connection if peer becomes unreachable

-- File Changes --

    M draft-ietf-quic-transport.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2406.patch
https://github.com/quicwg/base-drafts/pull/2406.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406

---

From: Nick Banks <[email-masked]>
Date: Mon, 04 Feb 2019 06:04:05 -0800

nibanks approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#pullrequestreview-199599391

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 04 Feb 2019 06:29:08 -0800

kazuho commented on this pull request.

> @@ -1862,6 +1862,11 @@ NAT rebinding is not connection migration as defined in this section, though an
 endpoint SHOULD perform path validation ({{migrate-validate}}) if it detects a
 change in the IP address of its peer.
 
+When a client finds the server unreachable over any path, the client might close
+its connection to the server (see {{termination}}).  A client capable of
+connection migration MAY wait for new paths to become available before declaring
+the server unreachable.

I think it might make sense to use "endpoint" rather than "client" and "server", because IIUC that's how we talk about connection migration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#pullrequestreview-199611636

---

From: ianswett <[email-masked]>
Date: Mon, 04 Feb 2019 06:55:13 -0800

ianswett commented on this pull request.

 * idle timeout ({{idle-timeout}})
 * immediate close ({{immediate-close}})
 * stateless reset ({{stateless-reset}})
 
+In addition, an endpoint MAY drop a connection and discard all connection state
+without informing the peer if it is unable to reach the peer.

How about "repeatedly unable to reach the peer."  Also, in this case, a connection close packet should still be sent in case the peer can receive packets, but packets it sends cannot reach you.

Also is 'reach the peer' obvious wording?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#pullrequestreview-199625471

---

From: MikkelFJ <[email-masked]>
Date: Mon, 04 Feb 2019 08:19:03 -0800

mikkelfj commented on this pull request.

I was wondering about this too, but assumed there was a clear definition in an earlier section. Even if you do not get a response, the peer might be able to hear a close. In that context, MAY seems fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#discussion_r253536718

---

From: Martin Thomson <[email-masked]>
Date: Mon, 04 Feb 2019 13:10:11 -0800

martinthomson commented on this pull request.

You need to say what "close" means, I think.

Maybe instead:

> An endpoint MAY discard connection state if it does not have a validated path on which it can send packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#pullrequestreview-199807338

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Feb 2019 17:05:26 -0800

@janaiyengar, this is annoyingly close to done.  Would you mind?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#issuecomment-462198902

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 21 Feb 2019 18:50:59 -0800

@martinthomson : Take a look.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#issuecomment-466254057

---

From: Martin Thomson <[email-masked]>
Date: Sat, 23 Feb 2019 19:36:22 -0800

Merged #2406 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2406#event-2159918321