Subject: Re: [quicwg/base-drafts] Make HTTP frames a TLV format (#2235)

From: Mike Bishop <[email-masked]>
Date: Tue, 05 Feb 2019 16:19:32 -0800

@MikeBishop pushed 1 commit.

2c691a52ac22d2b743c53658ac88e98987f85a39  ...

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2235/files/f5ac2dcc7058a116cdeeb95a5c8de75b21b68f9b..2c691a52ac22d2b743c53658ac88e98987f85a39

---

From: Mike Bishop <[email-masked]>
Date: Tue, 05 Feb 2019 16:20:31 -0800

Merged #2235 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2235#event-2120018482

---

From: MikkelFJ <[email-masked]>
Date: Wed, 06 Feb 2019 01:25:41 -0800

mikkelfj commented on this pull request.

>  +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 ~~~~~~~~~~
 {: #fig-frame title="HTTP/3 frame format"}
 
 A frame includes the following fields:
 
+  Type:
+  : An 8-bit type for the frame.
+
+
   Length:
   : A variable-length integer that describes the length of the Frame Payload.
     This length does not include the Type field.

With reordering the "Length" description no longer makes sense. If anything, length should state that it does not include itself.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2235#pullrequestreview-200476079