Subject: [quicwg/base-drafts] Connection IDs for 0-RTT packets (#2450)

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Feb 2019 00:26:35 -0800

For #2398 and @mikkelfj.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2450

-- Commit Summary --

  * Connection IDs for 0-RTT packets

-- File Changes --

    M draft-ietf-quic-transport.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2450.patch
https://github.com/quicwg/base-drafts/pull/2450.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450

---

From: MikkelFJ <[email-masked]>
Date: Mon, 11 Feb 2019 05:19:20 -0800

mikkelfj commented on this pull request.

> @@ -1355,6 +1355,9 @@ long enough to fulfill the minimum size for every QUIC version it supports.
 The client populates the Source Connection ID field with a value of its choosing
 and sets the SCIL field to match.
 
+The same Destination and Source Connection ID values are used for any 0-RTT
+packets the client sends.
+

This could be read as if the ID is the same in both directions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#pullrequestreview-202099761

---

From: MikkelFJ <[email-masked]>
Date: Mon, 11 Feb 2019 05:19:44 -0800

Thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#issuecomment-462324269

---

From: ianswett <[email-masked]>
Date: Mon, 11 Feb 2019 14:38:14 +0000 (UTC)

ianswett commented on this pull request.

Agreed, this is not completely clear.  How about: "The first flight of 0-RTT packets use the same Destination and Source Connection ID values as the client's first Initial."?

Also, on 1356, "sets the SCIL field to match." is not very clear.  I'd either drop the clause or say "and sets the SCIL field to indicate the length."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#discussion_r255533138

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Feb 2019 21:38:08 +0000 (UTC)

@martinthomson pushed 1 commit.

1f289026eb971051250e36d4bf28f056f99f0c17  A second pair of eyes and a bit of perspective

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450/files/1f2a08e8156b845d5820af48ace8270dd735e86a..1f289026eb971051250e36d4bf28f056f99f0c17

---

From: ianswett <[email-masked]>
Date: Mon, 11 Feb 2019 22:24:01 +0000 (UTC)

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#pullrequestreview-202370683

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 15:56:03 -0800

MikeBishop approved this pull request.

LGTM, given the incorporated changes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#pullrequestreview-202407170

---

From: MikkelFJ <[email-masked]>
Date: Mon, 11 Feb 2019 22:53:15 -0800

Note that section 17.2.3. 0-RTT does not mention 0-RTT CID but the following section 7.2.4. Handshake Packet does mention Handshake CID's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#issuecomment-462639064

---

From: Martin Thomson <[email-masked]>
Date: Tue, 12 Feb 2019 15:09:52 -0800

Merged #2450 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2450#event-2135218078