Subject: [quicwg/base-drafts] Add table to show what frames go on what streams (#2419)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Feb 2019 03:12:33 -0800

Fixes #2351 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2419

-- Commit Summary --

  * Add table to show what frames go on what streams

-- File Changes --

    M draft-ietf-quic-http.md (21)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2419.patch
https://github.com/quicwg/base-drafts/pull/2419.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2419

---

From: Mike Bishop <[email-masked]>
Date: Tue, 05 Feb 2019 14:03:05 -0800

MikeBishop commented on this pull request.

Minor nit; otherwise good.

Given that we have two frames that fall into this camp, might it be worth doing something like "(*) = only as the first frame"?

> @@ -396,9 +396,24 @@ implementation chooses.
 
 # HTTP Framing Layer {#http-framing-layer}
 
-As discussed above, frames are carried on QUIC streams and used on control
-streams, request streams, and push streams.  This section describes HTTP framing
-in QUIC.  For a comparison with HTTP/2 frames, see {{h2-frames}}.
+HTTP frames are carried on QUIC streams, as described in {{stream-mapping}}.
+HTTP/3 defines three stream types: control stream, request stream, and push
+stream. This section describes HTTP/3 frame formats and the streams types which
+they are permitted on, see {{stream-frame-mapping}} for an overiew.  A

"on which they are permitted; see ... overview"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2419#pullrequestreview-200325691

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Feb 2019 14:07:50 -0800

So a friendly pointer to detail that could be easily misinterpreted or missed? It seems like a table footnote is required but I'm not sure how to do that in Markdown.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2419#issuecomment-460823152

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Feb 2019 22:11:08 +0000 (UTC)

@LPardue pushed 1 commit.

2e9c4ed8998ed90af8037409aa041854341d0bdb  Mike's sentance nicening

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2419/files/20ce5884537111c45b82aa31d3f308fedee68e90..2e9c4ed8998ed90af8037409aa041854341d0bdb

---

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Feb 2019 00:01:14 +0000 (UTC)

Merged #2419 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2419#event-2119992846