Subject: [quicwg/base-drafts] Can VN and Retry packets be coalesced? (#2407)

From: Marten Seemann <[email-masked]>
Date: Mon, 04 Feb 2019 02:06:21 -0800

They don't have a length field, so the only place they could go is at the end of a packet.
As the spec currently stands, it's valid to send a packet like this.

There's little value in doing that. Do we want to continue to allow this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 04 Feb 2019 04:23:57 -0800

My understanding is that they are implicitly forbidden, because coalescing packets belonging to different connections are forbidden, and because there’s nothing to coalesce with when either of the two types of the packets is sent.

I am not sure if we need to be more clear on that, considering the fact we generally use MAY for the discarding rules for coalesced packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-460230824

---

From: ianswett <[email-masked]>
Date: Mon, 04 Feb 2019 06:18:42 -0800

VN certainly causes a new connection based on discussions in Tokyo.

Retry does not cause a new connection(ie: same ClientHello).

Clarifying this seems wise if it's not already clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-460265159

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 04 Feb 2019 06:25:49 -0800

> Retry does not cause a new connection(ie: same ClientHello).

Yes, however when a Retry packet is being sent, there's nothing a server can send along with.

Regarding if we need to clarify, while I do not think it's absolutely necessary, I can see that people might want to have it stated considering the fact that we do utilize corner case rules of coalesced packets (see #2402).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-460267585

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Feb 2019 01:13:47 -0800

So, is this editorial?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-465050318

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 21 Feb 2019 20:18:55 -0800

I'm with @kazuho, but I'm still wondering: what is the clarification that we can provide?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-466268039

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 21 Feb 2019 22:21:26 -0800

@janaiyengar Simply clarifying that "VN and Retry packets will never be coalesced" as part of the changes we would make in #2308 might be a good idea.

We do not need to use a RFC 2119 word here due to the editorial nature of the issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2407#issuecomment-466287568