Subject: Re: [quicwg/base-drafts] Describe the two processes. (9f6e285)

From: Lars Eggert <[email-masked]>
Date: Mon, 11 Feb 2019 04:30:43 -0800

The "issues list" - I think you mean the email list here? - is not open for discussion. Only the people who generate repo activity have posting rights, so their notifications make it to the list. We should say that they can be discussed "on the GitHub web page of the for the respective issue" or something like that. 

And maybe also remind people to not discuss on PRs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32267667

---

From: ianswett <[email-masked]>
Date: Mon, 11 Feb 2019 07:23:06 -0800

Are you saying that an issue could be closed, but no have consensus, and that would be indicated by a lack of the 'has-consensus' flag?  If so, that's confusing to me, since most closed issues at the moment aren't marked 'has-consensus'.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32270004

---

From: ianswett <[email-masked]>
Date: Mon, 11 Feb 2019 15:25:12 +0000 (UTC)

So either editors or chairs can merge PRs once the 'has-consensus' label is present?  Or should the chairs just do the merging when they add the label?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32270027

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 16:46:15 +0000 (UTC)

I interpret this to mean that discussion on the issue is acceptable (by parallel with the previous point), but given the overloaded meanings of "list," simply saying "on the mailing list or on the GitHub issue" would probably be clearer if so.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32271453

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 16:47:53 +0000 (UTC)

We'll be bulk-marking everything closed as `has-consensus` once we have WG consensus on the -18 drafts, i.e. after the e-mail asking for objections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32271472

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 08:49:17 -0800

The new organization puts this paragraph under the "Early-Stage Process," when I believe it's intended to apply to the regular process.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32271502

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 11 Feb 2019 16:22:52 -0800

That makes sense. Note that this text is cut-and-pasted from the current version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32277017

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 12 Feb 2019 00:23:08 +0000 (UTC)

Yes, that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32277024

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 12 Feb 2019 00:23:42 +0000 (UTC)

We've been doing them sporadically for all of the drafts, just not consistently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32277031

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 11 Feb 2019 16:24:06 -0800

The editors can still merge, once `has-consensus` is there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32277032

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 13 Feb 2019 19:17:43 -0800

We'll also mark the ones that are resolved but are pending PRs as `has-consensus`, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32312254

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 13 Feb 2019 19:18:20 -0800

s/issues-list/github issue

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32312256

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 13 Feb 2019 19:19:40 -0800

typpo: Transporrt

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32312260

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 13 Feb 2019 19:20:09 -0800

maybe list draft names here (draft-ietf-quic-http) ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32312261

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 13 Feb 2019 19:21:03 -0800

editorial nit: merge this para with the one above.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32312263

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 13 Feb 2019 22:34:19 -0800

@janaiyengar no. there are two ways to get a `has-consensus` flag:

* Under the early process, we canvas the list after the draft is published
* Under the late process, we establish consensus directly, before the issue is incorporated

Marking things as `has-consensus` without explicitly asking on the list is circumventing both of these.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32313482

---

From: ianswett <[email-masked]>
Date: Thu, 14 Feb 2019 06:53:09 -0800

What about the issues you recently included in your email that were discussed in Tokyo?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32319566

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 14 Feb 2019 12:38:29 -0800

@mnot: I wasn't suggesting that we not explicitly ask the list. As @ianswett notes, there are issues where we will have consensus but they are pending actual PRs. Those are the ones I was thinking of as "resolved".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32324635

---

From: Mark Nottingham <[email-masked]>
Date: Sun, 17 Feb 2019 20:41:45 -0800

We do *not* have consensus on those issues just because they were discussed in Tokyo. The resolution need to be confirmed on list. See my e-mail to the list about them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/9f6e285ad51c3439d5abd0ba24ad4ecd081c7a25#commitcomment-32353195