Subject: [quicwg/base-drafts] Clarify use of HTTP request with http scheme over HTTP/3 (#2439)

From: Magnus Westerlund <[email-masked]>
Date: Fri, 08 Feb 2019 16:09:25 +0000 (UTC)

It would be good if it could be clarified what will happen if someone needs/tries to send a HTTP request with an http:// uri over H3. I primarily see this to occur when you have a case where you have an HTTP proxy that receives an HTTP request and then have an HTTP/3 connection with the authorative server. If the expectation is that all requests are upgraded by the HTTP/3 sending side, then that needs to be made explicit. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 08 Feb 2019 08:44:40 -0800

I might propose this comes down to a discovery problem for the proxy. What method(s) do you envisage the proxy used to decide to make an HTTP/3 connection to the authorative server? This seems related to the discussion in HTTP WG - https://github.com/httpwg/http-core/issues/194

If Alt-Svc is being used, the flow might be that the proxy attempts to make a cleartext HTTP/1.1 connection to the authoritative server and does an upgrade, as described in RFC 7838, to HTTP/3. In which case I don't think any action is required. 

If the proxy wants to opportunistically upgrade via some happy eyeballs approach described on https://github.com/httpwg/http-core/issues/194, we might want to provide guidance that either 1) it shouldn't be done for client requests with http:// or 2) that it should always be done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439#issuecomment-461866344

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Feb 2019 17:24:31 +0000 (UTC)

This is another variant of #253 -- HTTP/2 and HTTP/3 explicitly include the scheme and the authority with all requests, so the server knows what it's being asked for.  The question is how the client decides that a QUIC endpoint is authoritative for this particular URL.

RFC 7838 describes how an https://-schemed request might come to be sent to an HTTP/3 endpoint and the resolution of the issue was to ask the HTTP WG to define other ways.  Adding RFC 8164 as well, an http://-schemed resource might also be requested over HTTP/3; it's up to the HTTPbis group whether they want to enable a direct upgrade there as well.

I don't currently see any text required for this, but if you have suggestions, I'm happy to review or expand the discussion to the list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439#issuecomment-461879685

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Feb 2019 17:00:24 -0800

I'd rather duplicate this to #253 and rely on [RFC 8164](https://tools.ietf.org/html/rfc8164) for this.  We were not very careful in that document to avoid mention of the specific HTTP version, but the technique is perfectly portable between versions.  We only really intended to put HTTP/1.x off limits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439#issuecomment-462198512

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 16:22:06 -0800

Perhaps "not very careful" was careful enough -- it says "such as HTTP/2," and mandates that the protocol needs a way to carry the scheme.  HTTP/3 does, so we're covered.  Do we think a reference to 8164 is warranted in the section about finding an HTTP/3 endpoint?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439#issuecomment-462552127

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Feb 2019 18:23:31 -0800

By "not very careful" I was mainly referring to the title :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2439#issuecomment-462586761