Subject: [quicwg/base-drafts] quic-tls nits (#2445)

From: martinduke <[email-masked]>
Date: Fri, 08 Feb 2019 17:50:33 -0800

I suspect these are uncontroversial.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2445

-- Commit Summary --

  * quic-tls nits

-- File Changes --

    M draft-ietf-quic-tls.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2445.patch
https://github.com/quicwg/base-drafts/pull/2445.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445

---

From: martinduke <[email-masked]>
Date: Fri, 08 Feb 2019 18:02:28 -0800

@martinduke pushed 1 commit.

325d2cbdab441cfb15c570aa084472dac88c09f1  One more

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445/files/4bf24681eee5235af5311fc939126195b16f6e40..325d2cbdab441cfb15c570aa084472dac88c09f1

---

From: martinduke <[email-masked]>
Date: Fri, 08 Feb 2019 18:02:57 -0800

5bb4241cf1d9f48798abd48450087e2188ae372b  argh stray character

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445/files/325d2cbdab441cfb15c570aa084472dac88c09f1..5bb4241cf1d9f48798abd48450087e2188ae372b

---

From: Marten Seemann <[email-masked]>
Date: Fri, 08 Feb 2019 18:07:03 -0800

marten-seemann requested changes on this pull request.

> @@ -788,7 +788,7 @@ The value of initial_salt is a 20 byte sequence shown in the figure in
 hexadecimal notation. Future versions of QUIC SHOULD generate a new salt value,
 thus ensuring that the keys are different for each version of QUIC. This
 prevents a middlebox that only recognizes one version of QUIC from seeing or
-modifying the contents of handshake packets from future versions.
+modifying the contents of Initial packets from future versions.

Initial is a version-dependent concept.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#pullrequestreview-201845491

---

From: martinduke <[email-masked]>
Date: Fri, 08 Feb 2019 20:24:57 -0800

martinduke commented on this pull request.

but the concept of the version 1 salt is directly related to Initial packets...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#discussion_r255287065

---

From: Marten Seemann <[email-masked]>
Date: Fri, 08 Feb 2019 20:58:37 -0800

marten-seemann commented on this pull request.

True, but you still can't talk about "Initial packets from future versions". Future version might not even have Initial packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#discussion_r255287762

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Feb 2019 16:18:59 -0800

martinthomson approved this pull request.

LGTM, with the one change altered.

@marten-seemann's point is right.  The intent here is to use a generic statement (packets that are part of the handshake process), as opposed to identifying a specific packet type in this version.

```suggestion
modifying the contents of packets from future versions.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#pullrequestreview-201931440

---

From: martinduke <[email-masked]>
Date: Sun, 10 Feb 2019 20:28:58 -0800

4d2821c5e79c741355ae8a69df024718e07835c9  Update draft-ietf-quic-tls.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445/files/5bb4241cf1d9f48798abd48450087e2188ae372b..4d2821c5e79c741355ae8a69df024718e07835c9

---

From: martinduke <[email-masked]>
Date: Sun, 10 Feb 2019 20:30:31 -0800

All three Mart[ie]ns now agree, no further objections allowed. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#issuecomment-462217145

---

From: Marten Seemann <[email-masked]>
Date: Sun, 10 Feb 2019 21:15:02 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#pullrequestreview-201953143

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 Feb 2019 21:55:01 -0800

Merged #2445 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2445#event-2129724789