Subject: [quicwg/base-drafts] Migration in Security Considerations (#2427)

From: Mike Bishop <[email-masked]>
Date: Tue, 05 Feb 2019 16:45:42 -0800

Fixes #2279.

Separately from this, I note that Security Considerations is becoming more of a jumbled bag of waving at various concerns.  Some organization and expanded text around each topic might be warranted.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2427

-- Commit Summary --

  * Migration in Security Considerations

-- File Changes --

    M draft-ietf-quic-http.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2427.patch
https://github.com/quicwg/base-drafts/pull/2427.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427

---

From: Martin Thomson <[email-masked]>
Date: Tue, 05 Feb 2019 17:00:50 -0800

martinthomson commented on this pull request.

Seems mostly right.  Though I would prefer something that simply highlighted the fact that a remote address is not expected to be stable over the lifetime of a connection.  Therefore, decisions that use an address as input need to either keep up to date, or accept the consequences of not doing so.

I would also point out that this is true even if migration is disabled.

> @@ -1463,6 +1463,13 @@ could pose a security risk to an incautious implementer.  An implementation MUST
 ensure that the length of a frame exactly matches the length of the fields it
 contains.
 
+Certain HTTP implementations use the client address for logging or
+access-control purposes.  Since QUIC supports path migration (and future
+versions might support simultaneous use of multiple paths), such implementations
+will need to actively retrieve the client's current address or addresses when

... will need to either actively retrieve the current address, or explicitly accept that the original address might change.

I don't think that they have to do either as long as the original requirement is recognized.  Of course, I would prefer to say that address-based access control is silly, but it is unfortunately still widely used, and not just for DoS mitigation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427#pullrequestreview-200376535

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 05 Feb 2019 19:09:13 -0800

kazuho approved this pull request.

The text looks great. I really appreciate the fact that we have a recommendation on what IP address we should associate with logging (and address-based authentication).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427#pullrequestreview-200399288

---

From: ianswett <[email-masked]>
Date: Wed, 06 Feb 2019 02:05:53 -0800

ianswett commented on this pull request.

Can you add a sub-heading(##) for each of these considerations, like in the transport draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427#pullrequestreview-200493793

---

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Feb 2019 10:26:53 -0800

MikeBishop commented on this pull request.

Yes, but I think I'd rather do that as a separate organization PR and keep this one focused on this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427#discussion_r254810977

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Feb 2019 16:06:38 -0800

@MikeBishop pushed 1 commit.

35fc05435fe02d42850cabb68f57d961b7ea1440  Better incorporate Martin's feedback

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427/files/55218b78c248abe2580a730b1ac2d1971838928c..35fc05435fe02d42850cabb68f57d961b7ea1440

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Feb 2019 16:06:55 -0800

Merged #2427 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2427#event-2128432556