Subject: [quicwg/base-drafts] Provide address validation token in Alt-Svc (#2488)

From: Alessandro Ghedini <[email-masked]>
Date: Tue, 26 Feb 2019 11:42:48 -0800

Similarly to how the server can provide tokens for future connections with the `NEW_TOKEN` frame, it could be useful to be able to do the same with Alt-Svc. This way the server can decide to be more aggressive about requiring a token for new connections while avoiding the additional round-trip caused by `Retry` when a client has never connected over QUIC before.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2488

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 26 Feb 2019 12:16:42 -0800

One might choose to do this with a new Alt-Svc parameter. Theres some interesting interrelation with the ma and persist parameters that might happen. 

If I understand correctly, a server would need to generate a unique token per client. Presently, as far as I've observed, Alt-Svc is used a bit more as a blanket hint. I don't think there is anything preventing it from being more targeted but there are challenges.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2488#issuecomment-467596294

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Feb 2019 19:51:51 +0000 (UTC)

`persist=false` seems to cover it quite nicely; of course, to get the "right" behavior, you'd have to include two entries -- one non-persistent and with a token, the other persistent.  It would be simpler to define that, even on a persistent entry, the token can only be used on the same network where it was issued.

I'm not convinced this needs to be in the core spec, though the VN hint technically doesn't need to be either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2488#issuecomment-468005454

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 27 Feb 2019 20:06:38 +0000 (UTC)

When you say VN, do you mean the Alt-Svc version hint in the HTTP/3 document? (Just for clarification purposes)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2488#issuecomment-468010542

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 Feb 2019 12:08:48 -0800

Yes -- the hint as to which QUIC versions the server intends to support.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2488#issuecomment-468011311