Subject: [quicwg/base-drafts] Reserved versions will "probably" never represent a real protocol? (#2430)

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Feb 2019 10:58:21 -0800

This seems unnecessarily wishy-washy.  Either they're reserved by definition, and therefore **will never** represent a real protocol, or they're available for use.

We should remove the "probably" unless there's a good reason to keep it that I'm missing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2430

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Feb 2019 18:18:34 -0800

Use of that word was entirely intentional.  If there is certainty about this status, then it creates a temptation to apply certain optimizations that could be disruptive.  What if middleboxes cached Version Negotiation packets from servers and helpfully provided responses to greased connection attempts?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2430#issuecomment-461264948

---

From: Mike Bishop <[email-masked]>
Date: Thu, 07 Feb 2019 23:15:10 +0000 (UTC)

We fear that someone might ossify if they discover that these are *definitely* not real protocol versions.  On the other hand, the thing that breaks is use of these as real protocol versions, which I don't believe we're trying to achieve.  If the middlebox is generating *accurate* VN packets, that seems entirely reasonable (and indistinguishable from actual VN packets).  If they're generating inaccurate VN packets, then our anti-downgrade protections that we've decided to implement RSN will break.

On the other hand, if these ever are real protocol versions, then a junk grease packet using the reserved version will fail to parse as a valid Initial and will just fail rather than eliciting a VN response.

This seems like an impossible battle to win, and a lot of subtlety to expect of middlebox vendors.  Write what we mean and move on.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2430#issuecomment-461627963