Subject: [quicwg/base-drafts] Why InitialWindow = 14600? (#2491)

From: martinduke <[email-masked]>
Date: Thu, 28 Feb 2019 15:29:17 -0800

In the Recovery Draft pseudocode section:

> kInitialWindow: : Default limit on the initial amount of data in flight, in bytes. Taken from {{?RFC6928}}. The RECOMMENDED value is the minimum of 10 * kMaxDatagramSize and max(2* kMaxDatagramSize, 14600)).

Why 14600? This looks like 10 * MSS, but for UDP this should be 14720. It would lead to neat MSS multiples were that code ever executed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491

---

From: ianswett <[email-masked]>
Date: Thu, 28 Feb 2019 15:38:39 -0800

This was taken from RFC6928: https://tools.ietf.org/html/rfc6928

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-468483562

---

From: martinduke <[email-masked]>
Date: Thu, 28 Feb 2019 16:01:35 -0800

Well, yes, but that is for TCP and I'm arguing that 14720 makes a lot more sense for QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-468488767