Subject: [quicwg/base-drafts] Clarify what to do when ALPN negotiation fails (#2483)

From: Alessandro Ghedini <[email-masked]>
Date: Wed, 20 Feb 2019 05:57:55 -0800

Just so you don't have to read the whole RFC7301.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2483

-- Commit Summary --

  * Clarify what to do when ALPN negotiation fails

-- File Changes --

    M draft-ietf-quic-tls.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2483.patch
https://github.com/quicwg/base-drafts/pull/2483.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2483

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Feb 2019 16:53:51 +0000 (UTC)

martinthomson commented on this pull request.

RFC 7301 only specifies that the server use this alert.  A server can always pretend not to support the extension.  A client that sends no_application_protocol in that case might still be valid, but it's not defined behaviour in 7301.  I think that you need to reword this slightly to allow for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2483#pullrequestreview-205877409

---

From: Alessandro Ghedini <[email-masked]>
Date: Wed, 20 Feb 2019 17:29:37 +0000 (UTC)

Yeah I was thinking about that. I wonder if it would make sense for the client to simply send PROTOCOL_VIOLATION instead of a TLS alert.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2483#issuecomment-465677177

---

From: Alessandro Ghedini <[email-masked]>
Date: Wed, 27 Feb 2019 09:24:25 -0800

@martinthomson I added a clarification to allow clients to send no_application_negotiated as well. Should I send an email to the mailing list for discussion now that the new process is in effect?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2483#issuecomment-467952974

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Feb 2019 20:46:32 +0000 (UTC)

Unfortunately yes.  This is a design change so it will need an issue as well.

I like it and we should do it, but can you add the error code we would use in CONNECTION_CLOSE to the text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2483#issuecomment-468023545