Subject: Re: [quicwg/base-drafts] Consider making h3 frame types varint (#2253)

From: Lucas Pardue <[email-masked]>
Date: Tue, 05 Feb 2019 17:31:43 -0800

If we varint all the things, how likely is it that malformed frames occur? 

Many frames carry just a varint payload, so malformed seems mostly to be that frame length (i.e. payload length) mismatches the sum of received payload parts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2253#issuecomment-460870715

---

From: ianswett <[email-masked]>
Date: Tue, 05 Feb 2019 17:54:25 -0800

That was one of the core points of #2396, FYI.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2253#issuecomment-460874645

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Feb 2019 16:52:02 -0800

Closed #2253 via #2437.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2253#event-2132254932