Subject: [quicwg/base-drafts] Specify what occurs when the maximum Stream Id exceeds 2^62 - 1 in MAX_STREAMS (#2487)

From: ianswett <[email-masked]>
Date: Thu, 21 Feb 2019 13:48:38 -0800

Currently, stream IDs are as high as 2^62-1.  The MAX_STREAMS frame specifies a limit as a varint that has a max value of 2^62-1 that translates to a Stream ID of 4 * max_streams + initial_stream_id_for_type.  This is larger than the max expressible stream ID, so we should specify what happens in this case.

I'm suggesting that we allow all streams to be opened and MUST NOT close the connection in PR #2486

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2487

---

From: MikkelFJ <[email-masked]>
Date: Thu, 21 Feb 2019 14:00:43 -0800

Good idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2487#issuecomment-466184402

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 21 Feb 2019 20:58:16 -0800

I don't have a strong opinion, but this seems like a bug at the peer. I would be inclined to specify that an endpoint MUST NOT advertise max streams that are too large, and close the connection (with PROTOCOL_VIOLATION) if a value is received that is too large.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2487#issuecomment-466274109

---

From: Marten Seemann <[email-masked]>
Date: Fri, 22 Feb 2019 09:15:29 +0000 (UTC)

I'd also lean towards closing the connection (probably with a TRANSPORT_PARAMETER_ERROR, not a PROTOCOL_VIOLATION though).

Interestingly, we have the following definition for packet numbers
> Packet numbers are integers in the range 0 to 2^62-1

but no such thing for stream IDs, although this is implied by the way we encode them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2487#issuecomment-466328808

---

From: ianswett <[email-masked]>
Date: Mon, 25 Feb 2019 06:16:27 -0800

I'm happy to close the connection as well, as long as the behavior is well-defined.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2487#issuecomment-467026890