Subject: [quicwg/base-drafts] SPA ad Infinitum (#2462)

From: MikkelFJ <[email-masked]>
Date: Wed, 13 Feb 2019 05:30:59 -0800

As far as I can tell, there is currently no protection against infinite loops in Server Preferred Address redirection.

In comparison, Retry only permits one hop.

A server should of course not send its own address, but it might not aways know it.
It is also possible for two servers to prefer each other.
A client should not keep shopping for a better connection endlessly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2462

---

From: ianswett <[email-masked]>
Date: Wed, 13 Feb 2019 05:34:23 -0800

Server's preferred address does not cause a new handshake.  It merely changes the server IP the client is communicating with for the existing handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2462#issuecomment-463200857

---

From: MikkelFJ <[email-masked]>
Date: Wed, 13 Feb 2019 05:37:31 -0800

Uhh, so I am mixing up Retry with SPA.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2462#issuecomment-463201773

---

From: Marten Seemann <[email-masked]>
Date: Wed, 13 Feb 2019 05:37:34 -0800

How can there be a loop? SPA is only used to tell the client to migrate, not to initiate a new connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2462#issuecomment-463201786

---

From: MikkelFJ <[email-masked]>
Date: Wed, 13 Feb 2019 05:37:34 -0800

Closed #2462.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2462#event-2136724938