Subject: [quicwg/base-drafts] Remove size optimization for Initial packets (#2522)

From: Martin Thomson <[email-masked]>
Date: Thu, 14 Mar 2019 18:33:57 -0700

Initial packets need to be in 1200 byte datagrams for DoS amplification reasons. We have an exception for the case where an ACK for a Handshake packet has been received from the peer.  In that case, we remove the requirement to pad.

That condition is extraordinarily obscure, especially if we are suggesting that endpoints not send any more Initial packets once they have Handshake keys.  Removing this text is the right answer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2522

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 15 Mar 2019 13:16:58 -0700

+1 to the proposed resolution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2522#issuecomment-473427147