Subject: [quicwg/base-drafts] Change illegal PRIORITY frame to a conn error (#2508)

From: martinduke <[email-masked]>
Date: Fri, 08 Mar 2019 21:10:39 +0000 (UTC)

Fixes #2507.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2508

-- Commit Summary --

  * Change illegal PRIORITY frame to a conn error

-- File Changes --

    M draft-ietf-quic-http.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2508.patch
https://github.com/quicwg/base-drafts/pull/2508.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508

---

From: ianswett <[email-masked]>
Date: Fri, 08 Mar 2019 13:11:43 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508#pullrequestreview-212481391

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Mar 2019 17:02:01 -0800

Merged #2508 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508#event-2191514208

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 08 Mar 2019 19:16:00 -0800

Has this been the only case where a protocol violation resulted in a stream error? Or should we check if there are similar cases and file PRs as necessary?

I ask this, because IIUC at least some of us considered the proposal as a change of design principle, to stop localizing such errors, and I wonder if the change made in this PR is a tip of an iceberg.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508#issuecomment-471140814

---

From: martinduke <[email-masked]>
Date: Fri, 08 Mar 2019 20:49:37 -0800

I haven't comprehensively reviewed the draft, but having just implemented the HTTP/3 frame parser, I can say that other UNEXPECTED_FRAME instances are connection errors.

Furthermore, PRIORITY frames can arrive on the control stream. If there were a stream error there it would have to take down the connection anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508#issuecomment-471145520

---

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Mar 2019 22:47:47 -0800

@kazuho, that's a good question.  Previously, the philosophy has been that connection errors are ones which screw up the state so badly you can't trust the connection to proceed correctly.  It's a reasonable, but not bulletproof, argument that a peer which doesn't obey the protocol has the same implication -- you can't trust the connection.

If you see other protocol violations which are stream-local errors, please file issues and we'll discuss.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2508#issuecomment-471151993