Subject: Re: [quicwg/base-drafts] RETIRE_KEYS proposal (#2492)

From: Rui Paulo <[email-masked]>
Date: Thu, 07 Mar 2019 12:52:14 -0800

Wouldn't it be safer to still discard initial/handshake keys after some time?  I'm worried that if an implementation blindly follows what another implementation is doing the keys might never be retired.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2492#issuecomment-470689353

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 07 Mar 2019 13:12:54 -0800

> Wouldn't it be safer to still discard initial/handshake keys after some time?

I can see that argument for Initial keys. At the moment, we require endpoints to drop the Initial keys at the earliest moments. There's a trade-off between relying on an explicit signal (that might get missed) vs. having a uniform way of retiring keys.

OTOH, I think we should solely rely on an explicit signal for dropping handshake keys. There is no risk in keeping the key forever (because only the peer can send Handshake packets that successfully validates), and because there is a tail.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2492#issuecomment-470696256

---

From: Rui Paulo <[email-masked]>
Date: Thu, 07 Mar 2019 15:56:19 -0800

@kazuho yes, that makes sense to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2492#issuecomment-470749301

---

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 12:48:14 -0700

I find this proposal tp be most straightforward of the three. It is clear and unambiguous signal with a minimum-size frame that allows us to drop keys without fussing with timers or messy logic around what the peer has "proven".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2492#issuecomment-475000865