Subject: [quicwg/base-drafts] Push stream data and PUSH_PROMISE reordering clarification (#2527)

From: Robin Marx <[email-masked]>
Date: Mon, 18 Mar 2019 02:44:04 -0700

As discussed on Slack, currently the text makes no mention of the case where the PUSH_PROMISE arrives behind (some of) the data on the push stream itself. However, it does mention this situation for the DUPLICATE_PUSH frame. 

This proposed change recommends buffering pushed data for an unknown PUSH_ID and using flow control to prevent this from being a problem. 

I am unsure if more text is needed (e.g., what happens if the PUSH_ID is never resolved (which would mean a misbehaving server)), but I think the proposed change should suffice. 

This is also related to issue #2526.
Thanks to @LPardue for his help. 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2527

-- Commit Summary --

  * Push stream data and PUSH_PROMISE reordering clarification

-- File Changes --

    M draft-ietf-quic-http.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2527.patch
https://github.com/quicwg/base-drafts/pull/2527.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 18 Mar 2019 14:07:41 -0700

LGTM. Non-normative language seems to be the best form of guidance here

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527#issuecomment-474101554

---

From: Martin Thomson <[email-masked]>
Date: Mon, 18 Mar 2019 15:22:37 -0700

martinthomson approved this pull request.

Seems like a good editorial improvement.

> @@ -1207,7 +1207,14 @@ the requests if the requested resource is already being pushed.
 When a server later fulfills a promise, the server push response is conveyed on
 a push stream (see {{push-streams}}). The push stream identifies the Push ID of
 the promise that it fulfills, then contains a response to the promised request
-using the same format described for responses in {{request-response}}.
+using the same format described for responses in {{request-response}}. Due to
+reordering, data on a push stream can arrive before the corresponding
+PUSH_PROMISE, in which case both the associated client request and the pushed
+request headers are unknown. Clients which receive a new push stream with an

CMOS change:
```suggestion
request headers are unknown. Clients that receive a new push stream with an
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527#pullrequestreview-215881913

---

From: Robin Marx <[email-masked]>
Date: Tue, 19 Mar 2019 02:47:13 -0700

@rmarx pushed 1 commit.

dbba914d996d274c209d8e592c7aa080291b4e2c  CMOS change for consistency

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527/files/84b4cc4e1b11ddfbcaa02149b7bf84417b39fee9..dbba914d996d274c209d8e592c7aa080291b4e2c

---

From: Robin Marx <[email-masked]>
Date: Tue, 19 Mar 2019 02:48:03 -0700

rmarx commented on this pull request.

That was based on identical text for DUPLICATE_PUSH a few lines up. I've now also changed that to keep consistency. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527#discussion_r266802290

---

From: Mike Bishop <[email-masked]>
Date: Sun, 24 Mar 2019 01:52:12 -0700

MikeBishop commented on this pull request.

You haven't changed it _here_, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527#discussion_r268423736

---

From: Robin Marx <[email-masked]>
Date: Sun, 24 Mar 2019 01:55:00 -0700

@rmarx pushed 1 commit.

32327c1739625f81cddf8e59bf9ee5fa53ecb696  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527/files/dbba914d996d274c209d8e592c7aa080291b4e2c..32327c1739625f81cddf8e59bf9ee5fa53ecb696

---

From: Robin Marx <[email-masked]>
Date: Sun, 24 Mar 2019 01:56:32 -0700

Sorry, wasn't sure if I should do this or the editors before merge. Should be accepted now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2527#discussion_r268423876