Subject: [quicwg/base-drafts] Clarify what to do when ALPN negotiation fails (#2495)

From: Alessandro Ghedini <[email-masked]>
Date: Mon, 04 Mar 2019 07:23:35 -0800

PR #2314 added a requirement for end-points to terminate a connection if ALPN negotiation fails, but doesn't specify an error code for this situation.

RFC7301 defines the `no_application_protocol` alert that must be used by TLS servers, so QUIC servers should probably use that as well. As for clients, RFC7301 doesn't specify a behaviour, but it also doesn't forbid use of `no_application_protocol` in clients, and it seems better if QUIC clients use the same error code as the servers.

Proposed wording change is in #2483.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2495

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 06 Mar 2019 17:10:48 -0800

My :+1: goes to making the change, though I would like to confirm that it wouldn't be illegal for a client to close the connection with `no_application_protocol` error _after it sends ClientFinished_.

I ask this because depending on the design of the TLS stack, the QUIC stack might not be able to see the result of ALPN before the TLS stack generates a ClientFinished (note that EE.ALPN and ServerFinished might arrive in one packet).

It's my understanding that the intent of the issue is to not allow the client to send any application data on ALPN failure. Assuming that's true, sending the alert after ClientFinished should be fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2495#issuecomment-470341990

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Mar 2019 17:41:25 -0800

Yes, I think that would be fine.  I don't think that we would be able to guarantee that the alert goes out before sending ClientFinished either.  It's certainly possible, but I can see how it might be tricky.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2495#issuecomment-470348543

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Mar 2019 01:19:51 -0700

This was fixed with #2483.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2495#issuecomment-477031317

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Mar 2019 01:19:50 -0700

Closed #2495.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2495#event-2232243119