Subject: Re: [quicwg/base-drafts] kGranularity and max_ack_delay possibly should be added after exponential backoff (#2393)

From: ianswett <[email-masked]>
Date: Wed, 20 Mar 2019 18:55:54 -0700

In an effort to align with TCP, kGranularity is now considered here:
 PTO = smoothed_rtt + max(4*rttvar, kGranularity) + max_ack_delay

In TCP, is the exponential backoff done before kGranularity is considered?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393#issuecomment-475090438

---

From: Praveen Balasubramanian <[email-masked]>
Date: Mon, 25 Mar 2019 14:56:09 -0700

TCP does not use kGranularity because minRTO already accounts for it indirectly i.e. minRTO values have never been allowed to be set lower than the timer granularity. But yes in TCP minRTO is included in the exponential backoff so it makes sense to keep the equation as is. I think we are effectively using kGranularity as minRTO here. 

In any case I think max_ack_delay is going to be the dominant value here in practice unless delayed ACKs are turned off. I wonder if another option is this:
PTO = smoothed_rtt + max(4*rttvar) + max(max_ack_delay, kGranularity)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393#issuecomment-476393056

---

From: ianswett <[email-masked]>
Date: Tue, 26 Mar 2019 03:34:53 -0700

As discussed in Prague, the feeling is the current formula is safe, correct, and follows RFC6298.

This formula was recently adjusted as a result of #2472

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393#issuecomment-476566083

---

From: ianswett <[email-masked]>
Date: Tue, 26 Mar 2019 10:34:53 +0000 (UTC)

Closed #2393.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2393#event-2229224464