Subject: Re: [quicwg/base-drafts] Rework Key Update (#2237)

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 12:45:16 -0700

I thought we were moving towards *key* separation between QUIC and TCP/TLS, but not *secret* separation. Even with key update, we get key separation when using the quic labels for key and iv, and I see no reason to also worry about the label when we update the secret.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2237#issuecomment-474999802

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Mar 2019 14:05:50 -0700

It is true that we separate keys, and not secrets, but the change to the update label is a more pragmatic one.  You don't want to have a situation where TLS key updates and QUIC key updates end up mixed.  Yes, you can't trigger TLS key updates in QUIC, but how else would you get the TLS secrets to roll over.

Mostly, that change was to ensure that the process for updating secrets was documented.  When reading the current drafts, I challenge you to find where it says what to do.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2237#issuecomment-475028091

---

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 16:30:32 -0700

Section 6 of quic-tls refers me to 7.2 of RFC 8446. I read and implemented this (literally) last week and found this to be totally unambiguous, as other sections of quic-tls clearly indicate the labels used to derive key and iv. Perhaps others found it less clear.

I am not sure how TCP and QUIC would be mixed. Key update doesn't change resumption secrets, and if TCP and QUIC are sharing the same TLS instance (?) you're going to have a problem with or without this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2237#issuecomment-475067616

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 Mar 2019 06:03:59 -0700

@martinthomson pushed 1 commit.

1c9fe31ee9b164bcb0e29d13974051349750d20f  Merge branch 'master' into simultaneous-update

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2237/files/331d3a7b9751c86be54655d3aa6c5ea6794c063c..1c9fe31ee9b164bcb0e29d13974051349750d20f