Subject: [quicwg/base-drafts] What happens if STREAM offset exceeds 2^62 -1 (#2538)

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 16:57:42 -0700

Sec 19.8 says:
The first byte in the stream has an offset of 0.  The largest offset
   delivered on a stream - the sum of the offset and data length - MUST
   be less than 2^62.

It certainly possible to express a STREAM frame that violates this rule. What action should we take?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2538

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Mar 2019 18:04:20 -0700

I don't know if we ever wrote this down, but I think that we might say if you catch a peer violating the spec, then you can send an error of any type you like.  But for this case, PROTOCOL_VIOLATION is entirely appropriate (as with many others of this sort).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2538#issuecomment-475083436

---

From: MikkelFJ <[email-masked]>
Date: Thu, 21 Mar 2019 18:07:09 +0000 (UTC)

Not just offset, but offset + content size of stream frame, otherwise there is no fixed limit on stream sizes, which is unfortunate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2538#issuecomment-475342576