Subject: [quicwg/base-drafts] Usage of "epoch" term (#2566)

From: Andy Grover <[email-masked]>
Date: Fri, 29 Mar 2019 17:55:24 +0000 (UTC)

In watching the [streams of the IETF QUIC sessions](https://www.youtube.com/watch?v=9xDS27UBi4U) there's a lot of discussion around "epoch", but this term is not defined in any of the quic draft documents, and is only mentioned (as "recovery epoch" and "congestion epoch") in the sample code in the -recovery appendices.

It is defined and discussed in the [DTLS RFC](https://tools.ietf.org/html/rfc4347), however.

I'm not sure if mention of "epoch" should be purged or expanded, but it struck me as unclear currently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2566

---

From: Martin Thomson <[email-masked]>
Date: Fri, 29 Mar 2019 19:13:23 +0000 (UTC)

Hopefully there is no mention of epoch in TLS or transport. Though we use the concept in discussion as a shorthand and to help reason through the complicated key update cases we were discussing, taking the meaning from DTLS, QUIC currently doesn't have that concept. And it probably won't have to grow that concept either. 

Should this issue be used to track the lack of definition of those terms in the recovery draft?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2566#issuecomment-478117370

---

From: Andy Grover <[email-masked]>
Date: Fri, 29 Mar 2019 14:36:59 -0700

Sounds good to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2566#issuecomment-478157501

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 29 Mar 2019 19:29:15 -0700

> is only mentioned (as "recovery epoch" and "congestion epoch") in the sample code in the -recovery appendices.
> 
> It is defined and discussed in the DTLS RFC, however.

Doesn't "epoch" used in the sample code in -recovery have different meaning than that used in DTLS? IIUC, the recovery draft is talking about the distinction of each loss event by using the term.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2566#issuecomment-478198152

---

From: David Schinazi <[email-masked]>
Date: Sun, 31 Mar 2019 10:59:43 -0700

If the "epoch" in question here is the one in my slides on discarding old 1-RTT keys after a key update, then I indeed meant it in the DTLS sense, and I apologize for the confusion. The TLS 1.3 spec refers to this concept as a "generation", so perhaps I should have used that instead here. But I agree with Martin that this concept might not necessarily need to be named in the spec if we can clarify the key update edge cases without it.

If the "epoch" in question is the one in recovery, then this is specific to recovery concepts that do not involve (D)TLS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2566#issuecomment-478363700