Subject: Re: [quicwg/base-drafts] Why InitialWindow = 14600? (#2491)

From: ianswett <[email-masked]>
Date: Fri, 01 Mar 2019 06:12:11 -0800

That seems reasonable, I was only trying to add an explanation of how we ended up with 14600.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-468677348

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 01 Mar 2019 09:32:19 -0800

@martinduke Did you mean 14520? 1472 as MSS seems too big if you assume MTU of 1500.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-468745574

---

From: martinduke <[email-masked]>
Date: Fri, 01 Mar 2019 17:34:58 +0000 (UTC)

@ghedo I was thinking IPv4. Perhaps we should make the value dependent on the IP version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-468746368

---

From: ianswett <[email-masked]>
Date: Sun, 03 Mar 2019 09:34:23 -0800

I believe the goal is no more than 10 1500 byte packets, so it could be IP version dependent.

But TCP doesn't bother making it IP version dependent, so I'm leaning towards specifying 14720 with the rationale that TCP has 20 bytes of overhead vs UDP's 8 bytes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-469045261

---

From: ianswett <[email-masked]>
Date: Sun, 03 Mar 2019 09:50:54 -0800

PR #2494 sent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#issuecomment-469046635

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Mar 2019 00:49:05 +0000 (UTC)

Closed #2491 via #2494.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2491#event-2176625067