Subject: [quicwg/base-drafts] Add normative language for stateless reset (#2574)

From: Martin Thomson <[email-masked]>
Date: Sun, 31 Mar 2019 23:42:01 -0700

Fixes #2471.

I know that we made this a design issue, and these do change 2119 language, but those normative requirements were implied anyway.  That is, the text used cannot vs. MUST NOT.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2574

-- Commit Summary --

  * Allow use of long header for stateless reset
  * Move the mandatory check to the detecting section
  * Use normative language about CID reuse

-- File Changes --

    M draft-ietf-quic-transport.md (45)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2574.patch
https://github.com/quicwg/base-drafts/pull/2574.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574

---

From: MikkelFJ <[email-masked]>
Date: Mon, 01 Apr 2019 06:47:09 +0000 (UTC)

mikkelfj commented on this pull request.

> @@ -2391,13 +2387,16 @@ the packet other than the last 16 bytes for carrying data.
 
 ### Detecting a Stateless Reset
 
-An endpoint detects a potential stateless reset when a incoming packet
-with a short header either cannot be associated with a connection,
-cannot be decrypted, or is marked as a duplicate packet.  The endpoint
-then compares the last 16 bytes of the packet with the Stateless Reset
-Token provided by its peer, either in a NEW_CONNECTION_ID frame or
-the server's transport parameters.  If these values are identical,
-the endpoint MUST enter the draining period and not send any further
+An endpoint detects a potential stateless reset when a incoming packet with a

```suggestion
An endpoint detects a potential stateless reset when an incoming packet with a
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#pullrequestreview-220942796

---

From: MikkelFJ <[email-masked]>
Date: Sun, 31 Mar 2019 23:48:55 -0700

-An endpoint detects a potential stateless reset when a incoming packet
-with a short header either cannot be associated with a connection,
-cannot be decrypted, or is marked as a duplicate packet.  The endpoint
-then compares the last 16 bytes of the packet with the Stateless Reset
-Token provided by its peer, either in a NEW_CONNECTION_ID frame or
-the server's transport parameters.  If these values are identical,
-the endpoint MUST enter the draining period and not send any further
+An endpoint detects a potential stateless reset when a incoming packet with a
+short header either cannot be associated with a connection, cannot be decrypted,
+or is marked as a duplicate packet.  The endpoint MUST then compare the last 16
+bytes of the packet with all Stateless Reset Tokens provided by its peer, either

Is there a potential for abuse here: all stateless resets could be a lot?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#pullrequestreview-220943270

---

From: Martin Thomson <[email-masked]>
Date: Sun, 31 Mar 2019 23:55:03 -0700

martinthomson commented on this pull request.

 

That's a risk you take when you send packets with lots of different connection IDs.  I notice that I don't mention those that are retired though.  I'll fix that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#discussion_r270733556

---

From: Martin Thomson <[email-masked]>
Date: Sun, 31 Mar 2019 23:55:13 -0700

@martinthomson pushed 1 commit.

43a7b94d19cbe28bb02c67cbb5cfb35f73cfa1f2  a an

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574/files/6c0f157c2bc99d20be5ae7b31db96d673a7bbc68..43a7b94d19cbe28bb02c67cbb5cfb35f73cfa1f2

---

From: Martin Thomson <[email-masked]>
Date: Sun, 31 Mar 2019 23:58:25 -0700

4367e0f6213cd877d9b165d7cfb057b9367438a8  Mention retired connection IDs too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574/files/43a7b94d19cbe28bb02c67cbb5cfb35f73cfa1f2..4367e0f6213cd877d9b165d7cfb057b9367438a8