Subject: [quicwg/base-drafts] STOP_SENDING on Critical Stream (#2509)

From: Mike Bishop <[email-masked]>
Date: Fri, 08 Mar 2019 16:43:14 -0800

> Perhaps I'm missing it but the spec doesn't say how to handle a STOP_SENDING received on a control stream. Should this peer issue a RESET_STREAM in response (causing the other peer to blow up) or should it just close the connection itself?

_Originally posted by @LPardue in https://github.com/quicwg/base-drafts/issues/2498#issuecomment-470316968_

There are three reasonable places to blow up:
- When you decide to stop reading a critical stream (i.e. when STOP_SENDING is sent)
- When you discover the peer has stopped reading a critical stream (i.e. when STOP_SENDING is received)
- When you discover the peer has closed a critical stream (when RESET_STREAM or FIN is received)

My inclination would be to advise against FIN/S_S/R_S on a critical stream and mandate connection termination on receipt of any of them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2509

---

From: Ryan Hamilton <[email-masked]>
Date: Fri, 08 Mar 2019 16:48:05 -0800

On Fri, Mar 8, 2019 at 4:43 PM Mike Bishop <[email-masked]> wrote:

> Perhaps I'm missing it but the spec doesn't say how to handle a
> STOP_SENDING received on a control stream. Should this peer issue a
> RESET_STREAM in response (causing the other peer to blow up) or should it
> just close the connection itself?
>
> *Originally posted by @LPardue <https://github.com/LPardue> in #2498
> (comment)
> <https://github.com/quicwg/base-drafts/issues/2498#issuecomment-470316968>*
>
> My inclination would be to advise against FIN/S_S/R_S on a critical stream
> and mandate connection termination on receipt of any of them.
>
Completely agree. This seems like the simplest and most obvious solution.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2509#issuecomment-471127297

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 08 Mar 2019 16:50:12 -0800

SGTM mike

On Sat, 9 Mar 2019, 00:48 Ryan Hamilton, <[email-masked]> wrote:

> > <
> https://github.com/quicwg/base-drafts/issues/2498#issuecomment-470316968>*
> >
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/2509#issuecomment-471127297>,
> or mute the thread
> <https://github.com/notifications/unsubscribe-auth/AGRFtRhsQgPDbduCLj7FTaENXQkzkKwuks5vUwTEgaJpZM4bmXtm>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2509#issuecomment-471127599

---

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 13:17:49 -0700

Note that this PR does NOT address #2498, just a comment that came up there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2509#issuecomment-475011026