Subject: [quicwg/base-drafts] MAX_PACKET_SIZE frame (#2545)

From: Igor Lubashev <[email-masked]>
Date: Sat, 23 Mar 2019 04:40:27 -0700

This is likely a v2 feature, as we discussed on the list.

There are several ongoing efforts in IETF to have network deliver PMTU information to the intended destination, in addition to sending the traditional ICMP PTB message to the sender from an on-path device.

The efforts include [draft-hinden-6man-mtu-option](https://tools.ietf.org/html/draft-hinden-6man-mtu-option), [draft-leddy-6man-truncate attempts](https://tools.ietf.org/html/draft-leddy-6man-truncate attempts), [draft-ioametal-ippm-6man-ioam-ipv6-options](https://tools.ietf.org/html/draft-ioametal-ippm-6man-ioam-ipv6-options), [draft-ietf-ippm-ioam-data](https://tools.ietf.org/html/draft-ietf-ippm-ioam-data).

In all cases, if an endpoint learns the PMTU from the sender to itself, there is still a problem of passing that information back to the sender.  We know that ICMP PTB has only limited chances of getting back to the sender, even if sent directly by the receiver.  However, a QUIC packet with MAX_PACKET_SIZE frame that updates the “max_packet_size” transport parameter solves the problem.  Hence the proposed new frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2545

---

From: ianswett <[email-masked]>
Date: Sat, 23 Mar 2019 17:45:14 -0700

As I've suggested for other similar situations, an UPDATE_TRANSPORT_PARAMS frame seems potentially very useful for this and other params(ie: max_ack_delay).

However, I'll admit it's less useful in a multipath scenario where two paths are likely to have different MTUs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2545#issuecomment-475917508

---

From: Martin Thomson <[email-masked]>
Date: Sun, 24 Mar 2019 02:33:56 -0700

Done is a feature.  This should be v2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2545#issuecomment-475942694