Subject: [quicwg/base-drafts] SOCKS over QUIC (#2518)

From: madhanraj <[email-masked]>
Date: Tue, 12 Mar 2019 02:59:48 -0700

Currently, the SOCKS and QUIC don't work straight forward. 
When SOCKS is used, a REQUEST (method, dest port, dest IP) has to be sent during each time of connection establishment. This is straight forward in TCP but in QUIC we establish the connection once with the SOCKS server and multiplex the streams amongst it. 
**Hence, a new method for SOCKS over QUIC is proposed where the REQUEST and RESPONSE are modified according to the QUIC design**

Another important issue with SOCKS is the initial overhead. In our real-time results with Samsung Smartphones, we observed that most the application are short-lived and socks delay impacts the user experience.  Hence we have to decide the packets to be packed one the 0-RTT and also if the tunnel can be pre-established with one-time authentication messages being transferred. 

**We would like to know, if there is similar work going on or shall we submit a fresh RFC including the problem and our approaches**

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2518

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Mar 2019 05:26:38 -0700

Closed #2518.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2518#event-2196952676

---

From: Lars Eggert <[email-masked]>
Date: Tue, 12 Mar 2019 05:26:40 -0700

This is unfortunately outside the charter of the working group, which you can find at https://datatracker.ietf.org/wg/quic/about/. You may of course submit an Internet Draft if you wish and ask the group for feedback, but our current charter prevents us from doing any work in this space.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2518#issuecomment-471979262

---

From: David Schinazi <[email-masked]>
Date: Tue, 12 Mar 2019 14:36:41 -0700

Hi @madhanraj, I think your work sounds interesting. I would recommend creating a new internet draft and sharing it on the QUIC mailing list please!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2518#issuecomment-472191017

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 12 Mar 2019 15:30:35 -0700

@madhanraj I too think this is interesting and second @DavidSchinazi  recommendation. There are some people thinking about this area and more use cases are welcome, even if we are tangential to the main focus of the group.

I recommend some of the following resources:

https://datatracker.ietf.org/doc/draft-olteanu-intarea-socks-6/
https://tools.ietf.org/html/draft-pauly-quic-datagram-02
https://tools.ietf.org/html/draft-pardue-httpbis-http-network-tunnelling-01

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2518#issuecomment-472206300