Subject: Re: [quicwg/base-drafts] Minor TLS draft editorial corrections (#2446)

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 13:09:46 -0700

martinduke commented on this pull request.

> @@ -269,7 +271,7 @@ At a high level, there are two main interactions between the TLS and QUIC
 components:
 
 * The TLS component sends and receives messages via the QUIC component, with
-  QUIC providing a reliable stream abstraction to TLS.
+  QUIC providing a reliable stream and record abstraction to TLS.

I don't want to hold up this PR forever on this point, but do @mt and @mikkelfj still disagree that QUIC is providing a record abstraction?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2446#discussion_r267524573

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Mar 2019 14:51:35 -0700

martinthomson commented on this pull request.

 components:

I think that this would be a mistake.  TLS only requires a stream abstraction.  QUIC has its own need for a record-like abstraction (we call them packets), but that is not relevant here.

If you revert this, I can merge it.

(@martinduke, be careful who you are tagging...)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2446#discussion_r267559854

---

From: martinduke <[email-masked]>
Date: Wed, 20 Mar 2019 16:32:48 -0700

@martinduke pushed 1 commit.

3c383577676d512c4aba0f9ae7b9f26f9e56967d  In which I surrender

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2446/files/83793ef5f0c83635d9bface209af0c2f8d18bfd8..3c383577676d512c4aba0f9ae7b9f26f9e56967d

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Mar 2019 18:22:33 -0700

Ahh, the sweet taste of surrender.  Thanks Martin.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2446#issuecomment-475085914

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 Mar 2019 18:22:38 -0700

Merged #2446 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2446#event-2218598102