Subject: Re: [quicwg/base-drafts] Be clearer about the purpose of disable_migration (#2389)

From: Jana Iyengar <[email-masked]>
Date: Wed, 27 Mar 2019 09:46:11 +0000 (UTC)

Having re-read the minutes from Tokyo, I would re-articulate the problem statement a bit. As you said, disable_migration is an indication from a server that the serving infrastructure cannot handle client address changes. I don't think there's any confusion on this purpose. The pending question IMO is what a server should do if it disables migration and then receives packets on the connection from a different address.

@martinthomson : Do you agree?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-477066276

---

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Mar 2019 07:45:13 +0000 (UTC)

That sounds about right, but I draw two conclusions:

There are some editorial improvements we might consider in light of this analysis.

The pending question about what to do in those scenarios is complex, but the conclusion might just be a better explanation of the sorts of trade-offs that servers work on.  As you imply, that might be editorial as well, but I suspect that we'll uncover ways in which conflicting interpretations of working group participants come to light.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-477484954

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 28 Mar 2019 01:03:00 -0700

Yes, that is what I had in mind as well. We may want to add some text around what a client might expect when it continues sending packets after switching networks to a server that has disable_migration set.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-477489847