Subject: [quicwg/base-drafts] bytes_in_flight might be reduced twice for lost packets (#2571)

From: Jana Iyengar <[email-masked]>
Date: Sat, 30 Mar 2019 14:26:00 -0700

The pseudo-code reduces bytes_in_flight on loss and on acked, but a packet might be acked after marked as lost (it might still be in the sent_map). Pseudo code fix needed.

Thanks, @kazuho, for this catch.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2571

---

From: ianswett <[email-masked]>
Date: Sat, 30 Mar 2019 16:22:07 -0700

We call remove() when a packet is acked or lost.  We can be more specific about what remove() does, but my intent was that removed the packet from the sent_packets data structure, so it could only be acked or lost, not both.

Admittedly, this does not allow detection of spurious losses, but I thought we decided that was out of scope for the pseudocode?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2571#issuecomment-478297938