Subject: Re: [quicwg/base-drafts] Server's preferred address (#1251)

From: GuShuhengSimon <[email-masked]>
Date: Mon, 18 Mar 2019 18:09:39 -0700

@MikeBishop, seems this support is removed ? now it's covered by {Connection Migration} part?
Then server's anycast IP => unicast IP migration would still not well supported by QUIC currently? Since the {Connection Migration} requires the "endpoint"(Server in this case) sustain a stable address, and need a full handshake being performed, but in this case, the next CHLO from client during 1-RTT would possibly routed to another "anycast" IP servers which makes anyCast IP => uniCast IP failure. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1251#issuecomment-474159034

---

From: David Schinazi <[email-masked]>
Date: Tue, 19 Mar 2019 10:25:54 -0700

Hi @GuShuhengSimon this feature is supported by QUIC. It uses the `preferred_address` transport parameter.

See [Section 9.6 of draft-19](https://tools.ietf.org/html/draft-ietf-quic-transport-19#section-9.6)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1251#issuecomment-474480589