Subject: [quicwg/base-drafts] Recommend of per-connection ID randomness for spin bit (#2628)

From: mirjak <[email-masked]>
Date: Wed, 17 Apr 2019 05:15:30 -0700

This was discussed on the original PR. While it is perfectly okay for an endpoint to set a per-packet random value (because there is also nothing we could even do to avoid that), I strongly think that this document should RECOMMEND per-flow/conn-ID randomness.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2628

-- Commit Summary --

  * Recommend of per-connection ID randomness for spin bit

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2628.patch
https://github.com/quicwg/base-drafts/pull/2628.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 17 Apr 2019 10:03:37 -0700

@mirjak: I don't think this is editorial.  Can you file an issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628#issuecomment-484176996

---

From: mirjak <[email-masked]>
Date: Thu, 18 Apr 2019 01:46:42 -0700

If you don't think it's editorial, I don't think it was okay to merge this sentence without consensus.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628#issuecomment-484411561

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 18:41:05 +0000 (UTC)

@mnot, @larseggert, the proposed change here was discussed [previously](https://github.com/quicwg/base-drafts/pull/2564#discussion_r270914240) on #2564, but wasn't acted upon.  I read the previous comment as saying she disagrees that there was consensus to merge #2564 without addressing that discussion.  That makes this a larger issue than a single PR, and belongs to the chairs.

The proposed change is *technically* editorial, because it's guidance rather than a hard protocol requirement.  However, given the contentious nature of everything related to the spin bit, I'm inclined to think that this is worth at least running by the list and tracking with an issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628#issuecomment-484634406

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2019 03:38:51 -0700

This seems more like a question of policy rather than protocol engineering.  Is there a specific issue that this addresses?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628#issuecomment-485750195

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 23 Apr 2019 16:13:06 -0700

@mirjak if you'd like the WG to consider this, please file an issue (preferred), or bring it up on the WG mailing list. While the editors do sometimes take purely editorial PRs, it's not how we discuss anything that's not purely editorial.

Editors, please do not label PRs with `design`. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2628#issuecomment-486007420