Subject: [quicwg/base-drafts] Fix stale reference and edge case in GOAWAY text (#2634)

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 14:15:46 -0700

Makes two minor fixes in the GOAWAY text, both editorial:
- Correctly references the MAX_STREAMS frame instead of the MAX_STREAM_ID frame
- Notes that servers need not (and cannot) send a GOAWAY if the client has used up all the possible stream IDs; the client simply won't be making any more requests.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2634

-- Commit Summary --

  * Correct name of QUIC frame, fixes #2629
  * No GOAWAY at the limit

-- File Changes --

    M draft-ietf-quic-http.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2634.patch
https://github.com/quicwg/base-drafts/pull/2634.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634

---

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 18 Apr 2019 21:24:31 +0000 (UTC)

dtikhonov approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#pullrequestreview-228513303

---

From: ianswett <[email-masked]>
Date: Thu, 18 Apr 2019 14:27:41 -0700

ianswett approved this pull request.

> @@ -1318,6 +1318,10 @@ connection to become idle, or MAY initiate an immediate closure of the
 connection.  An endpoint that completes a graceful shutdown SHOULD use the
 HTTP_NO_ERROR code when closing the connection.
 
+If a client has consumed all available bidirectional stream IDs with requests,

This is true, but would the HTTP layer know this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#pullrequestreview-228514564

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 21:41:36 +0000 (UTC)

MikeBishop commented on this pull request.

It has to be tracking the greatest stream ID it has received a request on in order to put that value in a GOAWAY frame.  So, yes.  Another implementation might be to retrieve this number and then find that it's out-of-bounds, but it amounts to the same thing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#discussion_r276844458

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 13:19:03 -0700

janaiyengar commented on this pull request.

+If a client has consumed all available bidirectional stream IDs with requests,
+the server need not send a GOAWAY frame; the client is unable to make further

```suggestion
the server need not send a GOAWAY frame, since the client is unable to make further
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#pullrequestreview-228814637

---

From: Mike Bishop <[email-masked]>
Date: Tue, 23 Apr 2019 22:29:14 +0000 (UTC)

@MikeBishop pushed 1 commit.

857b754ff62c69c94f32cd2253fab6f2ac257478  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634/files/428febf7d4505dc97123c706bf3c8f67e687e4ca..857b754ff62c69c94f32cd2253fab6f2ac257478

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2019 22:30:34 +0000 (UTC)

martinthomson approved this pull request.

This is a whatever...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#pullrequestreview-229827968

---

From: Mike Bishop <[email-masked]>
Date: Tue, 23 Apr 2019 15:30:39 -0700

Merged #2634 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2634#event-2295541538