Subject: Re: [quicwg/base-drafts] Discuss considerations for max_ack_delay (#2186)

From: ianswett <[email-masked]>
Date: Mon, 15 Apr 2019 08:48:02 -0700

@janaiyengar, Is this closed the host delay section of #2568 ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2186#issuecomment-483308537

---

From: Praveen Balasubramanian <[email-masked]>
Date: Mon, 15 Apr 2019 08:56:56 -0700

What about scheuler delays? I've been thinking about max_ack_delay and I think we need more than just one timer tick here since its supposed to be the worst case. If we get this wrong then we will have lot of unnecessary firing of the TLP timer when only the tail packet is due. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2186#issuecomment-483312095

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 15 Apr 2019 13:17:31 -0700

Closed #2186.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2186#event-2277748166

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 15 Apr 2019 20:17:35 +0000 (UTC)

@pravb: I've proposed separating platform delays from stack-controllable delays in #2596. My thinking has moved since this issue was first filed, and I now think that max-ack-delay should only include stack-controllable delays. Any additional delays will go into the smoothed_rtt anyways, so any timers should account for those delays via the increase in the smoothed_rtt. At any rate, I propose that we move discussion of that specific question to #2596.

I'm closing this issue, let's open new issues for any other more specific concerns.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2186#issuecomment-483402315