Subject: [quicwg/base-drafts] Bring back AEAD_AES_128_CCM_8 now that we pad the plaintext (#2581)

From: David Schinazi <[email-masked]>
Date: Mon, 01 Apr 2019 16:15:30 -0700

As discussed in #2019, we did not originally have a good way to make AEAD_AES_128_CCM_8 work in QUIC, because it needs a 16 byte sample but produces an 8 byte auth tag. However, since then we have merged #2030, and it's therefore easy to pad short packets by 8 extra bytes when using CCM_8. There might be QUIC use-cases that could benefit from the shorter tags, and it feels nice to have QUIC support all the original TLS 1.3 ciphersuites.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2581

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 01 Apr 2019 16:20:37 -0700

+1

CCM_8 is big in environments like broadcast production

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2581#issuecomment-478782026

---

From: MikkelFJ <[email-masked]>
Date: Mon, 01 Apr 2019 22:03:47 -0700

This just adds an odd error-prone special case for padding, and the key benefit of being short is lost on short packets due to padding.

________________________________
Fra: Lucas Pardue <[email-masked]>
Sendt: tirsdag, april 2, 2019 1:20 AM
Til: quicwg/base-drafts
Cc: Subscribed
Emne: Re: [quicwg/base-drafts] Bring back AEAD_AES_128_CCM_8 now that we pad the plaintext (#2581)

+1

—
You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub<https://github.com/quicwg/base-drafts/issues/2581#issuecomment-478782026>, or mute the thread<https://github.com/notifications/unsubscribe-auth/AALzN4LaoQB75iVwpJQr8bUDaNjmScFOks5vcpRDgaJpZM4cW0cg>.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2581#issuecomment-478845674

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 01 Apr 2019 22:25:05 -0700

I think we can accommodate this in QUIC v1.

The change has zero impact on implementations not supporting CCM8. Code can be left as-is.

Specification-wise the required change would be to alter the definition of minimal payload size from 4 to `pn_sample_size - aead_tag_size + 4`).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2581#issuecomment-478849533

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 01 Apr 2019 22:35:29 -0700

> the key benefit of being short is lost on short packets due to padding.

I disagree. It's only the very short packets that do not have the benefit. Longer packets do not require additional padding, and will benefit from the use of the shorter tag.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2581#issuecomment-478851454