Subject: [quicwg/base-drafts] Construction of address validation token (#2587)

From: Erik Sy <[email-masked]>
Date: Wed, 03 Apr 2019 04:43:52 -0700

The draft describes that a client SHOULD NOT reuse a token in different connections (https://tools.ietf.org/html/draft-ietf-quic-transport-19#section-8.1.2). However, I miss the argument that the server SHOULD NOT construct the same token multiple times.
This argument addresses the risks of client tracking via tokens if a deterministic approach is used to construct them.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 03 Apr 2019 22:32:47 -0700

Maybe #2543?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-479756243

---

From: Lars Eggert <[email-masked]>
Date: Tue, 09 Apr 2019 07:57:09 +0000 (UTC)

@kazuho do you mean @2543 already covers this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-481144524

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 09 Apr 2019 05:39:14 -0700

Yes, my view is that #2543 and the corresponding mailing list thread (https://mailarchive.ietf.org/arch/msg/quic/qLx9IncF8iV-37IJ6H0TM8hjP28) covers this issue. They discuss about unlinkability between the tokens issued by a server.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-481233672

---

From: Lars Eggert <[email-masked]>
Date: Tue, 09 Apr 2019 17:03:24 +0000 (UTC)

@kirsey do you agree that this is (mostly) covered by #2543? If yes, can we close this issue and resolve it as part of #2453?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-481337235

---

From: Erik Sy <[email-masked]>
Date: Tue, 09 Apr 2019 19:47:10 +0000 (UTC)

No, #2543 does not cover this particular point. #2543 makes the point that a network observer should not be able to derive information such as a timestamp from observed tokens.

However, this issue says that the construction of the token should not be deterministic. To illustrate this problem, assume that the token is more or less the hash of the client's source address. Thus, the client receives upon repeat connections the each time the same token, if its source address is identical. As a result, even if the client uses each token only a single time the corresponding connections established with these tokens can be correlated to each other by a network observer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-481407927

---

From: Lars Eggert <[email-masked]>
Date: Tue, 16 Apr 2019 00:52:29 -0700

@kirsey could #2543 be modified to cover your issue? could you comment there?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-483551473

---

From: Erik Sy <[email-masked]>
Date: Tue, 16 Apr 2019 08:49:53 +0000 (UTC)

Closed #2587.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#event-2278953089

---

From: Erik Sy <[email-masked]>
Date: Tue, 16 Apr 2019 01:49:53 -0700

@larseggert Ok, I will make proposals within #2543 to cover this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-483570618

---

From: Lars Eggert <[email-masked]>
Date: Tue, 16 Apr 2019 04:48:01 -0700

@mnot the automation failed here - this should not be moved to "Text Incorporated", it should just be closed

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2587#issuecomment-483626567