Subject: [quicwg/base-drafts] client should send PING in Initial or Handshake, but PINGs are forbidden in these packets (#2640)

From: Marten Seemann <[email-masked]>
Date: Mon, 22 Apr 2019 21:48:15 -0700

The [text about the crypto timer](https://quicwg.org/base-drafts/draft-ietf-quic-recovery.html#crypto-retransmission-timeout) says:
> If the crypto retransmission timer expires before the client has 1-RTT keys, it is possible that the client may not have any crypto data to retransmit. However, the client MUST send a new packet, containing only PING or PADDDING frames if necessary, to allow the server to continue sending data. If Handshake keys are available to the client, it MUST send a Handshake packet, and otherwise it MUST send an Initial packet in a UDP datagram of at least 1200 bytes.

PING frames are forbidden in both Initial and Handshake packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2640

---

From: ianswett <[email-masked]>
Date: Tue, 23 Apr 2019 14:45:26 +0000 (UTC)

The smallest change is to only send PADDING without a PING, since the purpose here is to allow the server to send, not for the client to receive an ACK.  The PING doesn't really add any value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2640#issuecomment-485834297

---

From: ianswett <[email-masked]>
Date: Tue, 23 Apr 2019 07:46:29 -0700

Closed #2640 via b71cf743fe3ebdcfa8ee2e650f1d585db8d321dc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2640#event-2294349874

---

From: ianswett <[email-masked]>
Date: Tue, 23 Apr 2019 14:49:06 +0000 (UTC)

Reopened #2640.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2640#event-2294358505

---

From: ianswett <[email-masked]>
Date: Tue, 23 Apr 2019 07:51:07 -0700

Sorry for the churn.  I sent out the smallest fix possible.  We can also change the transport doc to allow PING in Initial and Handshake.  Functionally, I don't think it matters for recovery, but both are reasonable options in my opinion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2640#issuecomment-485836875