Subject: Re: [quicwg/base-drafts] Reserved versions are not version-dependent (#2434)

From: Lars Eggert <[email-masked]>
Date: Tue, 16 Apr 2019 08:02:47 +0000 (UTC)

@martinthomson are you saying that because the version registry is stable across versions, its contents in effect become part of the invariants? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-483554886

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 16 Apr 2019 01:02:54 -0700

Would it make sense to refer to the version registry (or at least its definition) in invariants? If that's all this is about, we could just call this editorial< I think.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-483554921

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 16:15:39 -0700

There's a balancing act here.  From an architecture standpoint, the registry and reserved versions belong in the invariants, because they're inherently part of the cross-version properties of QUIC.

However, there's also the political answer, which is that Invariants describes what we want outside observers to focus on about the wire image.  The idea that certain versions aren't "real" is explicitly *not* something we want outside observers to pay attention to.  Thus, the current location is a(n exceptionally weak) form of security by obscurity.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-484719757

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 22 Apr 2019 23:55:07 -0700

That sounds like an argument to close this issue with no action. @marten-seemann do you feel strongly about this? Anyone else?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-485667309

---

From: Marten Seemann <[email-masked]>
Date: Tue, 23 Apr 2019 09:02:33 +0000 (UTC)

@MikeBishop's argument sounds reasonable to me. I'm ok with closing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#issuecomment-485714995

---

From: Lars Eggert <[email-masked]>
Date: Tue, 23 Apr 2019 05:31:28 -0700

Closed #2434.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2434#event-2293921646