Subject: [quicwg/base-drafts] HTTP/3 reserved value range (#2606)

From: Lucas Pardue <[email-masked]>
Date: Wed, 10 Apr 2019 21:42:01 +0000 (UTC)

The definition of reserved ranges (AKA GREASE values) seems a bit off, e.g. section 10.3 in draft 19:

```
   Additionally, each code of the format "0x1f * N + 0x21" for integer
   values of N (that is, "0x21", "0x40", ..., through
   "0x3FFFFFFFFFFFFFFE") MUST NOT be assigned by IANA.
```

The frame type is sent on the wire using a varint, which is limited to a value of 2^62. Should we only reserve frame types that can be sent on the wire?

This applies also to settings parameters and unidirectional stream types.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Apr 2019 18:23:58 -0700

Are you suggesting that there is a world in which a frame type outside of the range that can be expressed in the protocol can be reserved?  That would seem to be a little academic.  

There was a discussion of defining frame types to be integers in the 0..2^62-1 range, but I don't know if we ever got to writing that down.  If we do anything, that would be what I would do.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606#issuecomment-481929729

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 11 Apr 2019 02:02:43 -0700

On Thu, 11 Apr 2019, 02:23 Martin Thomson, <[email-masked]> wrote:

> Are you suggesting that there is a world in which a frame type outside of
> the range that can be expressed in the protocol can be reserved? That would
> seem to be a little academic.
>

I think we agree this situation is odd.

> There was a discussion of defining frame types to be integers in the
> 0..2^62-1 range, but I don't know if we ever got to writing that down. If
> we do anything, that would be what I would do.
>
As a start, I'll make a PR to fix up all reserved ranges to fall into
sensible limits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606#issuecomment-482031610

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 11 Apr 2019 19:46:20 +0000 (UTC)

While looking again at this I think the reserved values fall in valid limits, it is just unclear. I'm now confused by the text that explains that certain ranges are restricted to being allocated to IESG or for private use. 

So I'll attempt an editorial PR that tries to  clarify things.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606#issuecomment-482278878

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 12 Apr 2019 03:26:56 -0700

Closed #2606.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606#event-2272031142

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 12 Apr 2019 03:26:56 -0700

On reflection, I think the HTTP document does enough to describe everything - I have no positive editorial changes to make at this time. Closing this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2606#issuecomment-482524184