Subject: [quicwg/base-drafts] Recovery release notes for draft 20 (#2625)

From: ianswett <[email-masked]>
Date: Tue, 16 Apr 2019 21:48:20 +0000 (UTC)

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2625

-- Commit Summary --

  * Recovery release notes for draft 20

-- File Changes --

    M draft-ietf-quic-recovery.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2625.patch
https://github.com/quicwg/base-drafts/pull/2625.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625

---

From: ianswett <[email-masked]>
Date: Wed, 17 Apr 2019 12:00:32 -0700

@ianswett pushed 1 commit.

fbdcbb92a4aefeeac7d8ae530f8ef15f5178966f  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625/files/adb45ef8e73fd2a70cc1f88ee7aedcaac834ee95..fbdcbb92a4aefeeac7d8ae530f8ef15f5178966f

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Apr 2019 14:38:50 -0700

janaiyengar commented on this pull request.

> @@ -1500,6 +1500,17 @@ are detected lost.
 Issue and pull request numbers are listed with a leading octothorp.
 
 ## Since draft-ietf-quic-recovery-19
+
+- Send a PING if the PTO timer fires and there's nothing to send (#2624)
+- Set loss delay to at least kGranularity (#2617)
+- Merge application limited and sending after idle sections. Always limit
+  burst size instead of requiring resetting CWND to initial CWND after
+  idle (#2605)
+- Rewrite RTT estimation, allow RTT samples where a newly acked packet is
+  ack-eliciting, but the largest_acked is not (#2592)

```suggestion
  ack-eliciting but the largest_acked is not (#2592)
```

> @@ -1500,6 +1500,17 @@ are detected lost.
 Issue and pull request numbers are listed with a leading octothorp.
 
 ## Since draft-ietf-quic-recovery-19
+
+- Send a PING if the PTO timer fires and there's nothing to send (#2624)
+- Set loss delay to at least kGranularity (#2617)
+- Merge application limited and sending after idle sections. Always limit
+  burst size instead of requiring resetting CWND to initial CWND after
+  idle (#2605)
+- Rewrite RTT estimation, allow RTT samples where a newly acked packet is
+  ack-eliciting, but the largest_acked is not (#2592)
+- No longer arm the handshake timer if there is no handshake data (#2590)

```suggestion
- Don't arm the handshake timer if there is no handshake data (#2590)
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625#pullrequestreview-228518335

---

From: ianswett <[email-masked]>
Date: Thu, 18 Apr 2019 14:39:53 -0700

06d23a117fe0a0ec7d289cee989ba987c6d353f5  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625/files/fbdcbb92a4aefeeac7d8ae530f8ef15f5178966f..06d23a117fe0a0ec7d289cee989ba987c6d353f5

---

From: ianswett <[email-masked]>
Date: Thu, 18 Apr 2019 14:39:59 -0700

3608dac87b2108b29aeb0235b617e496c190a19d  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625/files/06d23a117fe0a0ec7d289cee989ba987c6d353f5..3608dac87b2108b29aeb0235b617e496c190a19d

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 20:26:26 +0000 (UTC)

@janaiyengar pushed 1 commit.

eac6ace12ee84e867139a5cd08d67e86cfa23607  Nit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625/files/3608dac87b2108b29aeb0235b617e496c190a19d..eac6ace12ee84e867139a5cd08d67e86cfa23607

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 13:28:54 -0700

5dfc14ce51ebf2698782234f96bad96a8431a60f  undo nit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625/files/eac6ace12ee84e867139a5cd08d67e86cfa23607..5dfc14ce51ebf2698782234f96bad96a8431a60f

---

From: ianswett <[email-masked]>
Date: Fri, 19 Apr 2019 16:20:35 -0700

Merged #2625 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2625#event-2289164242