Subject: [quicwg/base-drafts] Frames of unknown type cause connection close (#2601)

From: Jana Iyengar <[email-masked]>
Date: Tue, 09 Apr 2019 16:09:41 -0700

This was always intended (and also written in the description of FRAME_ENCODING_ERROR), but didn't show up in the text somehow.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2601

-- Commit Summary --

  * Frames of unknown type cause connection close

-- File Changes --

    M draft-ietf-quic-transport.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2601.patch
https://github.com/quicwg/base-drafts/pull/2601.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2601

---

From: ianswett <[email-masked]>
Date: Tue, 09 Apr 2019 17:54:20 -0700

ianswett approved this pull request.

> @@ -2701,10 +2701,10 @@ frames. -->
 {: #packet-frames title="QUIC Payload"}
 
 QUIC payloads MUST contain at least one frame, and MAY contain multiple frames
-and multiple frame types.
+and multiple frame types.  Frames MUST fit within a single QUIC packet and MUST

This last bit is true, but it's not just a MUST, it seems impossible given the framing we have.  I'm wondering if a can not is more appropriate, given it's essentially impossible?

But I guess this is pre-existing normative text, so in the interest in keeping this PR editorial, this is fine by me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2601#pullrequestreview-224718313

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Apr 2019 19:12:03 -0700

martinthomson commented on this pull request.

I agree with @ianswett about the MUSTs that you shuffled around are statements of fact, not interoperability requirements, but the addition is fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2601#pullrequestreview-224732691

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Apr 2019 02:12:09 +0000 (UTC)

Merged #2601 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2601#event-2264687376