Subject: Re: [quicwg/base-drafts] ECN text refers to RTO (#2534)

From: ianswett <[email-masked]>
Date: Tue, 16 Apr 2019 07:26:32 -0700

Fixing the naming(retransmission timeout to probe timeout) is trivial, but I'm not sure what to recommend here for when to disable ECN.  Also, probe timeouts don't occur until the handshake is complete, is that a problem?

One idea that's somewhat in keeping with RFC3168 would be to disable ECN on crypto handshake timeouts and probe timeouts, and if the un-marked packets get through and the marked do not, disable ECN.  But even that is subject to random loss and I believe is likely to spuriously trigger.  We could disable ECN temporarily on only the second timeout, to reduce the chance of spurious disabling?

RFC8311(https://tools.ietf.org/html/rfc8311#section-4.3) says we can do something different from 3168 if we document it, but doesn't specify what.

Is there some useful RFC I can cite that I haven't found, or are we on our own in designing a mechanism here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-483682698

---

From: ianswett <[email-masked]>
Date: Tue, 16 Apr 2019 07:27:44 -0700

@larseggert I reclassified this as design, because it's not just the name update.  If we decide to just fix the name, then we can change it back.  Correct me if I'm wrong.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-483683295

---

From: MikkelFJ <[email-masked]>
Date: Tue, 16 Apr 2019 20:31:11 +0000 (UTC)

How about probing ECN on even packet numbers for the first N packets before making a decision, where N is tunable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-483831593

---

From: mirjak <[email-masked]>
Date: Wed, 17 Apr 2019 07:46:05 +0000 (UTC)

I believe what the text was actually meant to say was that if you set the ECT code point and you loose ALL packet which the code point set, you MAY disable it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-483975597

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 17:08:09 -0700

What @mirjak says makes sense. We don't need to document a full algorithm here, but the proposed text works for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-485041719