Subject: [quicwg/base-drafts] HTTP/2 to HTTP/3 mapping section of http/3 is stale (#2627)

From: ianswett <[email-masked]>
Date: Tue, 16 Apr 2019 18:51:09 -0700

I'm not sure exactly what needs to be updated, but it's fairly clear this section is out of date.

Example: "Below is a listing of how each HTTP/2 frame type is mapped:" and below.
ie: "As described above, the PRIORITY region of HEADERS is not supported. ..."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 18 Apr 2019 03:11:04 -0700

I'm not sure I 100% agree

This statement is still correct, although perhaps it is more accurate to say something like:

```
HEADERS (0x1):
: The PRIORITY region of HEADERS is not defined in HTTP/3 frames. A separate PRIORITY frame is used in all cases. Padding is not defined in HTTP/3 frames.
```

Likewise, the statement below that appears earlier in the section isn't wrong but doesn't describe that PRIORITY frame can appear as the first frame on a request stream

> To achieve in-order delivery of priority changes in HTTP/3,
PRIORITY frames are sent on the control stream and exclusive prioritization
has been removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627#issuecomment-484438023

---

From: ianswett <[email-masked]>
Date: Thu, 18 Apr 2019 05:58:18 -0700

Thanks Lucas, your text makes it clear what was intended.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627#issuecomment-484495976

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 09:32:51 -0700

Are there additional changes here, or does #2633 address it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627#issuecomment-484583911

---

From: ianswett <[email-masked]>
Date: Thu, 18 Apr 2019 09:33:30 -0700

I'm happy with the text in #2633

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627#issuecomment-484584089

---

From: Mike Bishop <[email-masked]>
Date: Thu, 18 Apr 2019 11:17:16 -0700

Closed #2627.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2627#event-2286518827