Subject: [quicwg/base-drafts] RTT measurement using PATH_* frames (#2644)

From: Rui Paulo <[email-masked]>
Date: Tue, 23 Apr 2019 09:55:56 -0700

Should the recovery draft explain how to gather RTT samples during connection migration using PATH_CHALLENGE and PATH_RESPONSE?

This is explained in:
- https://tools.ietf.org/html/draft-paulo-quic-migration-00#section-3.3

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2019 20:39:01 -0700

Is there any expectation that the response is sent immediately?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-486054870

---

From: Rui Paulo <[email-masked]>
Date: Tue, 23 Apr 2019 21:46:04 -0700

Section 8.4:

> On receiving a PATH_CHALLENGE frame, an endpoint MUST respond immediately by echoing the data contained in the PATH_CHALLENGE frame in a PATH_RESPONSE frame.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-486065906

---

From: ianswett <[email-masked]>
Date: Wed, 24 Apr 2019 07:11:11 -0700

If PR#2637 lands, we'd need to restrict this to cases when the PATH_RESPONSE arrived on the same path the PATH_CHALLENGE was sent on.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-486258540

---

From: Rui Paulo <[email-masked]>
Date: Wed, 24 Apr 2019 08:28:59 -0700

@ianswett don't we already have text about that?

> To ensure that packets can be both sent to and received from the peer, the PATH_RESPONSE MUST be sent on the same path as the triggering PATH_CHALLENGE. That is, from the same local address on which the PATH_CHALLENGE was received, to the same remote address from which the PATH_CHALLENGE was received.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-486291402