Subject: [quicwg/base-drafts] Two Loss bits (Q&R) (#2594)

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 12:27:56 -0700

Just two bits in clear to enable full on-path loss location
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2594

-- Commit Summary --

  * Add files via upload
  * Minor edits
  * Update draft-ietf-quic-lossbits-exp.md
  * Merge pull request #1 from hamchaoui/patch-1
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Merge pull request #2 from quicwg/master
  * Nits
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Update draft-ietf-quic-lossbits-exp.md
  * Refine R-for-payload description
  * Update draft-ietf-quic-lossbits-exp.md

-- File Changes --

    A draft-ietf-quic-lossbits-exp.md (183)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2594.patch
https://github.com/quicwg/base-drafts/pull/2594.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 12:40:01 -0700

@ferrieux pushed 1 commit.

004cc7c09bc65a984b322d40aeedae16d95bc6f6  Update draft-ietf-quic-lossbits-exp.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594/files/9120cdfacbf45862a4892a47d2a0822fd7ccbb8e..004cc7c09bc65a984b322d40aeedae16d95bc6f6

---

From: ianswett <[email-masked]>
Date: Mon, 08 Apr 2019 19:43:43 +0000 (UTC)

Unless I'm missing something, this seems more appropriate for an individual draft rather than a QUIC WG document in this repo?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480978572

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 19:45:54 +0000 (UTC)

96fbd734312ebad4f3db646a4573515d2f1b6e99  Update draft-ietf-quic-lossbits-exp.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594/files/004cc7c09bc65a984b322d40aeedae16d95bc6f6..96fbd734312ebad4f3db646a4573515d2f1b6e99

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 12:48:25 -0700

> Unless I'm missing something, this seems more appropriate for an individual draft rather than a QUIC WG document in this repo?

Quite possibly: what is the appropriate place ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480980126

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 08 Apr 2019 12:50:05 -0700

@ferrieux: This draft is an individual draft and not a wg document. A couple of suggestions:
1. This is a repo for documents that are adopted by the QUIC wg, not for individual drafts. Use the internet drafts repository to post new individual drafts: https://datatracker.ietf.org/submit/
2. The draft should be renamed to reflect that it's not a wg document. See Section 7 of https://www.ietf.org/standards/ids/guidelines/ for more, but I would recommend renaming it to draft-ferriux-hamchaoui-quic-lossbits-exp.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480980743

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 19:53:53 +0000 (UTC)

2bb68e2ba4a64c59fe62a9adc8713fecbf47ce83  Update draft-ietf-quic-lossbits-exp.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594/files/96fbd734312ebad4f3db646a4573515d2f1b6e99..2bb68e2ba4a64c59fe62a9adc8713fecbf47ce83

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 12:58:14 -0700

> 2. The draft should be renamed to reflect that it's not a wg document. See Section 7 of https://www.ietf.org/standards/ids/guidelines/ for more, but I would recommend renaming it to draft-ferriux-h…

Unless I'm mistaken, the spin bit draft started its life in this exact place. The reasoning being similar (a proposed extension to the main drafts, without preconceptions about where it should eventually land), I assumed it would be fine to do the same. Why is different ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480983638

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 12:59:12 -0700

3316ee4ad1266ed9f9eaaa17679339502e21a656  Update draft-ietf-quic-lossbits-exp.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594/files/2bb68e2ba4a64c59fe62a9adc8713fecbf47ce83..3316ee4ad1266ed9f9eaaa17679339502e21a656

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 08 Apr 2019 20:04:04 +0000 (UTC)

@ferrieux: The spin bit document started here: https://tools.ietf.org/html/draft-trammell-quic-spin-00. It wasn't a part of the base-drafts repository.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480985761

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 13:07:39 -0700

8bb745e3a273257a4ff68ceb15e5b1c150b9537c  Reflow

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594/files/3316ee4ad1266ed9f9eaaa17679339502e21a656..8bb745e3a273257a4ff68ceb15e5b1c150b9537c

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 13:13:16 -0700

> @ferrieux: The spin bit document started here: https://tools.ietf.org/html/draft-trammell-quic-spin-00. It wasn't a part of the base-drafts repository.

OK, will do so, then. Is there a way of somehow linking to there from within quicwg documentation, beyond a mention on the mailing list ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480989155

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 08 Apr 2019 20:17:24 +0000 (UTC)

> OK, will do so, then. Is there a way of somehow linking to there from within quicwg documentation, beyond a mention on the mailing list ?

That's a question for the chairs. I would: (i) close this PR, (ii) submit an individual draft to the drafts repo, (iii) ask the chairs for how to proceed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480990715

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 08 Apr 2019 13:19:10 -0700

IMO this is clearly beyond the scope of QUICv1. Not all work going on with QUIC deserves a link from the main repo. It is straightforward to set up a separate GitHub repo following MTs instructions if you want your document source to be available. 

I also recommend the above suggestions, post an Individual Draft and promote the work on the mailing list. The working group can, at the chairs discretion, give consideration on if there is support to adopt the document etc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480991387

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 20:36:14 +0000 (UTC)

> I also recommend the above suggestions, post an Individual Draft and promote the work on the mailing list. The working group can, at the chairs discretion, give consideration on if there is support…

So, I take it that the prerequisite to suggesting any new idea  now amounts to writing a bona fide I-D, regardless of how incremental the idea is wrt existing wg material ?

Isn't there a more lightweight approach, allowing to reuse the nice github workflow for new material, but in a separate "not approved yet" area ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-480997638

---

From: David Schinazi <[email-masked]>
Date: Mon, 08 Apr 2019 20:48:53 +0000 (UTC)

Hi @ferrieux, creating a separate draft is pretty lightweight. Especially when you've already written it, all you need to do is submit it - there is no need for a GitHub to start the discussion. I personally have several individual drafts in this state. Once you've submitted your draft all you need to do is email the mailing list to get feedback on it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481002113

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 08 Apr 2019 14:01:19 -0700

You've clearly put the effort in to write this draft, which is great. However, we should ensure we respect the chair's process; several QUIC drafts are now in the late stage process as described in CONTRIBUTING.md (https://github.com/quicwg/base-drafts/blob/master/CONTRIBUTING.md#late-stage-process). 

I'd encourage you to file an issue that articulates the problem statement and the benefits of the proposal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481006392

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 14:12:26 -0700

> I'd encourage you to file an issue that articulates the problem statement and the benefits of the proposal.

Oh, the intent was not *at all* to hijack the v1 late-stage convergence. This draft is here to convey a simple idea that'd most appropriately be implemented in a post-v1, negotiated experimental version among those that are expected to proliferate after RFC publication. So I won't disrupt the already tight schedule with it. I'm mereley looking for an appropriate landing site for a simply formatted md file (as opposed to a full I-D with its constrained layout).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481010026

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 08 Apr 2019 21:27:27 +0000 (UTC)

I can see how maybe it seems easier to fork this repo and work in that but it is a bit confusing for the rest of us. 

Depending exactly what you're trying to achieve, you might find it easier to create a Wiki page. This is what the ECN work did: https://github.com/quicwg/base-drafts/wiki/ECN-in-QUIC. It would allow simple markup and collaboration.

If you do want IETF-submission-compatible formats, these instructions for setting up your own separate repo don't take much time: https://github.com/martinthomson/i-d-template/blob/master/doc/REPO.md

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481014807

---

From: Alexandre Ferrieux <[email-masked]>
Date: Mon, 08 Apr 2019 14:47:44 -0700

> If you do want IETF-submission-compatible formats, these instructions for setting up your own separate repo don't take much time: https://github.com/martinthomson/i-d-template/blob/master/doc/REPO.…

Thanks. Indeed those are options, but none comes close to the workflow efficiency of fork/commit/pullrequest/comment on github, right ? It would seem that just creating a separate "provisional" repo at the wg toplevel would solve the problem in one swell foop ; there, people could just take advantage of the tool suite, visibility & ease of collaboration without in any way claiming automatic community validation....

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481020841

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 08 Apr 2019 14:55:04 -0700

@ferrieux : It's perfectly fine to not submit a draft and to keep this on github -- that is entirely your prerogative. The reason you're getting these process comments is that you've generated a PR against the base-drafts repository for what is effectively a new draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481022896

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 08 Apr 2019 15:20:33 -0700

The suggested workflow is at odds with how this WG works. As a sample point, this PR has little context to explain itself without looking at all the text in unrendered markdown. I subscribe to this repo and I got multiple notifications for each commit made after the PR was opened. This is noisy and distracts the WG from focusing on delivering our chartered items.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481029530

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 08 Apr 2019 15:38:04 -0700

Closed #2594.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#event-2261185445

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 08 Apr 2019 15:38:04 -0700

Hi @ferrieux. You need to submit new drafts to the [datatracker](https://datatracker.ietf.org/submit/) and bring them to the attention of the Working Group for them to be discussed.

As mentioned, this repo is for adopted drafts only; until then, it's best in your own repo.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481033739

---

From: Alexandre Ferrieux <[email-masked]>
Date: Tue, 09 Apr 2019 00:18:33 -0700

> The suggested workflow is at odds with how this WG works. As a sample point, this PR has little context to explain itself without looking at all the text in unrendered markdown. I subscribe to this…

Understood; apologies for the noise. Now, if there was a separate repo (named "proposals", "extensions", "side orders", "ancillary drafts" or whatever), to which you obviously wouldn't subscribe, all new ideas would have a natural place to sit. Since the explicit intent is to have a wealth of new versions post-v1, such a place would come in handy, wouldn't it ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481132828

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 09 Apr 2019 00:24:37 -0700

That is effectively the Internet-Drafts repository. I'm locking this discussion; if you have further questions, please take it up on-list or with the WG chairs directly. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2594#issuecomment-481134486