Subject: [quicwg/base-drafts] Use short headers for stateless reset (#2599)

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Apr 2019 15:49:10 -0700

We don't want to prohibit the use of long headers in other versions - in case they want to share the stateless reset design, but there is no sense in sending long headers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599

---

From: MikkelFJ <[email-masked]>
Date: Wed, 10 Apr 2019 05:33:57 +0000 (UTC)

While I agree with the issue, the PR says that other versions might want to reset with a long header and therefore the receiver must inspect long headers anyway. I can see this, but given that, I think it is pointless to require the current version to only send resets for short headers. A general advice ought to suffice since the MUST is not enforceable anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-481539994

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Apr 2019 18:12:32 -0700

The requirement exists to protect those packets from detection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-481927764

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2019 22:16:12 +0000 (UTC)

Closed #2599 via #2600.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#event-2295517280

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Apr 2019 00:01:06 -0700

Reopened #2599.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#event-2296191053

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Apr 2019 00:01:07 -0700

Please don't close issues until AFTER consensus is declared (not just called).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-486094579

---

From: ianswett <[email-masked]>
Date: Wed, 24 Apr 2019 14:21:26 +0000 (UTC)

I suspect Martin was confused because this issue was tagged has-proposal 15 days ago.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-486262602

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 24 Apr 2019 15:56:43 -0700

Right. The trigger is `has-consensus`, not `has-proposal`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-486457815

---

From: ianswett <[email-masked]>
Date: Wed, 24 Apr 2019 16:13:36 -0700

But it's understandable Martin would have assumed this was one of the issues that was sent out in the batch of issues a week and a half ago, given this has been tagged with has-proposal for 15 days.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2599#issuecomment-486461091