Subject: Re: [quicwg/base-drafts] Awkward text in "Sending Probe Packets" (#2493)

From: ianswett <[email-masked]>
Date: Mon, 15 Apr 2019 16:04:05 +0000 (UTC)

The pseudocode now uses SendOneOrTwoPackets(), but the last paragraph pretty clearly violates the previous MUST, which is very bad.

The simplest fix would be to change the MUST to a "SHOULD unless otherwise specified", but I'm increasingly thinking we should stick with the MUST and if you get into a situation you have nothing to send, require sending something ack-eliciting to ensure in-flight packets are removed from flight.

Thoughts?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2493#issuecomment-483314934

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Apr 2019 14:42:09 -0700

Closed #2493 via #2624.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2493#event-2286994595