Subject: [quicwg/base-drafts] Packet-threshold loss detection poorly interacts with packet coalescing (#2653)

From: Jana Iyengar <[email-masked]>
Date: Wed, 24 Apr 2019 23:26:11 -0700

Packet threshold uses difference in packet number as a proxy for datagrams, which is not true with packet coalescing. 

Fortunately, coalescing is only used during the handshake, and packet-threshold detection is not very useful for Initial and Handshake packets. One proposal is to not use packet-threshold detection for detecting losses of Initial or Handshake packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2653

---

From: ianswett <[email-masked]>
Date: Thu, 25 Apr 2019 05:39:29 -0700

Can you be more specific about the issue you're seeing and how packet coalescing is relevant, because I don't understand the issue.

If you were allocating packet numbers from a single space when doing multiple PN spaces, then unless you adjust for that, you could become very sensitive to reordering, but that is implementation specific and doesn't involve coalescing.

We could disable packet threshold for Initial and Handshake PN spaces, and it likely wouldn't matter during the handshake since it's rare to have 3 packets outstanding at once anyway, so time threshold is likely to kick in sooner.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2653#issuecomment-486655306