Subject: Re: [quicwg/base-drafts] introduce a max_connection_ids transport parameter (#1998)

From: Marten Seemann <[email-masked]>
Date: Wed, 17 Apr 2019 20:16:52 -0700

@marten-seemann pushed 2 commits.

81cf8f25c02f8e937c4b1f8796d6d63fb76923ff  Merge branch 'master' into conn-id-tp
da0a1445330f53a6e4785625c17c9e19b0fb33a3  don't store max_connection_ids for 0-RTT connections

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998/files/95a13b37bfe63289a7c67985857e27eaeed99944..da0a1445330f53a6e4785625c17c9e19b0fb33a3

---

From: Marten Seemann <[email-masked]>
Date: Wed, 17 Apr 2019 21:55:28 -0700

@marten-seemann pushed 1 commit.

ab31430781608a67e0bd8146b523959082ab7f62  fix whitespace

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998/files/da0a1445330f53a6e4785625c17c9e19b0fb33a3..ab31430781608a67e0bd8146b523959082ab7f62

---

From: Marten Seemann <[email-masked]>
Date: Thu, 18 Apr 2019 16:55:32 -0700

I updated the text after #2467 got merged. Is there anything else I need to change to move forward with this PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#issuecomment-484726312

---

From: ianswett <[email-masked]>
Date: Fri, 19 Apr 2019 08:18:32 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#pullrequestreview-228726296

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 19 Apr 2019 19:55:39 +0000 (UTC)

janaiyengar commented on this pull request.

Just a couple of editorial comments, and then I think this is ready.

>  An endpoint SHOULD ensure that its peer has a sufficient number of available and
-unused connection IDs.  While each endpoint independently chooses how many
-connection IDs to issue, endpoints SHOULD provide and maintain at least eight
-connection IDs.  The endpoint SHOULD do this by supplying a new connection ID
-when a connection ID is retired by its peer or when the endpoint receives a
-packet with a previously unused connection ID.  However, it MAY limit the
-frequency or the total number of connection IDs issued for each connection to
-avoid the risk of running out of connection IDs (see {{reset-token}}).
+unused connection IDs. Endpoints store received connection IDs for future use.
+An endpoint uses a transport parameter to advertise the number of connection IDs
+it can store for future use. An endpoint SHOULD NOT provide more connection IDs
+than this limit. If an endpoint has provided its peer with the maximum number of

```suggestion
than the peer's limit. If an endpoint has provided its peer with the maximum number of
```

> @@ -4195,6 +4192,12 @@ A client MUST NOT include an original connection ID, a stateless reset token, or
 a preferred address.  A server MUST treat receipt of any of these transport
 parameters as a connection error of type TRANSPORT_PARAMETER_ERROR.
 
+max_connection_ids (0x000e):
+
+: The maximum number of connection IDs that the peer is willing to store.

```suggestion
: The maximum number of connection IDs from the peer that an endpoint is willing to store.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#pullrequestreview-228805161

---

From: Marten Seemann <[email-masked]>
Date: Fri, 19 Apr 2019 17:52:59 -0700

3527f4afad8674f6b85937959bf30a4765323b30  Jana's suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998/files/ab31430781608a67e0bd8146b523959082ab7f62..3527f4afad8674f6b85937959bf30a4765323b30

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Apr 2019 01:18:35 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#pullrequestreview-229406265

---

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Apr 2019 20:37:15 -0700

martinthomson approved this pull request.

I don't care much for this idea, but if that is the working group consensus, this is a fine way to do it.

I will float an idea that might help reduce one potential source of confusion: rename this to active_connection_ids.  The max_* transport parameters all have a similar credit-based design, where this is a count of the number of concurrently active of the identified resource.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#pullrequestreview-229886664

---

From: ianswett <[email-masked]>
Date: Wed, 24 Apr 2019 07:18:05 -0700

Good point on our use of max_ meaning an absolute value.  Maybe active_connection_id_limit or connection_id_limit?  active_connection_ids implies the TP is providing active connection IDs in the transport param.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#issuecomment-486261299

---

From: Marten Seemann <[email-masked]>
Date: Sat, 27 Apr 2019 19:16:02 -0700

38ee9e3391d4ce9da76951006b7db3609a36d923  rename max_connection_ids to active_connection_id_limit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998/files/3527f4afad8674f6b85937959bf30a4765323b30..38ee9e3391d4ce9da76951006b7db3609a36d923

---

From: Marten Seemann <[email-masked]>
Date: Sat, 27 Apr 2019 19:16:35 -0700

Thanks for the suggestion. I renamed the TP to active_connection_id_limit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#issuecomment-487334719

---

From: ianswett <[email-masked]>
Date: Mon, 29 Apr 2019 13:06:37 -0700

ianswett commented on this pull request.

```suggestion
An endpoint uses the active_connection_id_limit transport parameter to advertise the number of connection IDs
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998#pullrequestreview-231875407

---

From: Marten Seemann <[email-masked]>
Date: Mon, 29 Apr 2019 17:15:22 -0700

2c8375fbf033aeced76e7e5ead87c8113d101c86  Ian's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/1998/files/38ee9e3391d4ce9da76951006b7db3609a36d923..2c8375fbf033aeced76e7e5ead87c8113d101c86