Subject: Re: [quicwg/base-drafts] all HTTP/3 protocol violations should lead to connection errors (#2510)

From: Mike Bishop <[email-masked]>
Date: Wed, 01 May 2019 16:08:13 -0700

Resolved merge conflicts and rearranged the PRIORITY section to have a single list of impossible PRIORITY frames that provoke HTTP_MALFORMED_FRAME.  (Of course, this breaks #2662; sorry, @LPardue.)  I suspect there's better wording possible here, so feel free to bash on it.

Went to fix the items mentioned [here](https://github.com/quicwg/base-drafts/pull/2510#issuecomment-479754799), but they seem to already have been covered in @kazuho's original text, so no change needed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2510#issuecomment-488480288

---

From: Mike Bishop <[email-masked]>
Date: Wed, 01 May 2019 16:10:04 -0700

@MikeBishop pushed 1 commit.

b7f070819f557aff603a89757e4d8c940007f408  Add missing word

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2510/files/60e38ef45e318b7cd4f4c0c1d9be031a463a905e..b7f070819f557aff603a89757e4d8c940007f408

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 02 May 2019 09:54:49 +0000 (UTC)

The impact on #2662 is easily overcome.

This change has been through review and has support, strongly in favour of shipping it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2510#issuecomment-488615998

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 May 2019 03:00:13 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2510#pullrequestreview-232924543

---

From: Mike Bishop <[email-masked]>
Date: Thu, 02 May 2019 10:02:19 -0700

Merged #2510 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2510#event-2315125725