Subject: Re: [quicwg/base-drafts] STREAM_LIMIT_ERROR vs MAX_STREAMS (#2661)

From: Lucas Pardue <[email-masked]>
Date: Wed, 01 May 2019 07:02:08 -0700

To push back, the transport document has a lot of text that describes or uses the term "stream limit". Therefore IMO an error related to these requirements is logically a STREAM_LIMIT_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#issuecomment-488290242

---

From: MikkelFJ <[email-masked]>
Date: Wed, 01 May 2019 07:34:12 -0700

No argument there, my preferred change is to rename MAX_STREAMS to STREAM_LIMITS and leave the errors alone.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#issuecomment-488298955

---

From: Marten Seemann <[email-masked]>
Date: Wed, 01 May 2019 07:42:19 -0700

I don't think we should rename the MAX_STREAMS frame. It's a form of flow control, and we use MAX_DATA and MAX_STREAM_DATA for data limits.
If you were suggesting to rename those to DATA_LIMIT and STREAM_DATA_LIMIT, your renaming would at least be consistent. I'd push back against that as well though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#issuecomment-488301361

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 May 2019 07:50:04 -0700

Anyone who cares about this is free to open a PR.  However, the chairs have given editors some leeway when it comes to naming, and this doesn't seem to be particularly important, so we might close this issue without action.  I'll give people a chance to suggest alternatives though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#issuecomment-488303549

---

From: MikkelFJ <[email-masked]>
Date: Wed, 01 May 2019 20:09:44 +0000 (UTC)

I don't have a strong opinion, although I do find it mildly confusing. So if consensus ranges from meh to moderate push back I'd be inclined to close this - but as Martin says, let's give people a chance.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#issuecomment-488400462

---

From: MikkelFJ <[email-masked]>
Date: Thu, 02 May 2019 10:44:20 -0700

Closed #2661.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2661#event-2315228832