Subject: [quicwg/base-drafts] Clarify PATH_RESPONSE lack of retransmission in Path Validation (#2724)

From: ianswett <[email-masked]>
Date: Mon, 20 May 2019 07:01:40 -0700

We have a must for PATH_CHALLENGE "The endpoint MUST use unpredictable data in every PATH_CHALLENGE frame so that it can associate the peer's response with the corresponding PATH_CHALLENGE."

"On receiving a PATH_CHALLENGE frame, an endpoint MUST respond immediately by echoing the data contained in the PATH_CHALLENGE frame in a PATH_RESPONSE frame."

This text should clarify that an endpoint MUST respond exactly once as well.  Saving PATH_RESPONSEs for later retransmission could be a memory attack.  If one wanted to be particularly careful you could also limit how many you buffer if you're congestion control limited.

https://tools.ietf.org/html/draft-ietf-quic-transport-20#section-8.2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2724

---

From: Eric Kinnear <[email-masked]>
Date: Mon, 20 May 2019 07:34:33 -0700

Good call. Note that this is already indicated in [Section 13.2](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.13.2), way down at the bottom of the bulleted list, but I agree that we should have this be MUST NOT save for retransmission/MUST response exactly once.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2724#issuecomment-494013484

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 May 2019 07:38:57 -0700

This is technically design, but trivial.  Do you want to take this @erickinnear ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2724#issuecomment-494015306

---

From: Eric Kinnear <[email-masked]>
Date: Mon, 20 May 2019 07:40:16 -0700

Yup, I'll put up a PR for this

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2724#issuecomment-494015869