Subject: [quicwg/base-drafts] Define abandonment (#2674)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 17:01:43 -0700

Just in case it wasn't perfectly clear from the choice of words.

Closes #2671.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2674

-- Commit Summary --

  * Define abandonment

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2674.patch
https://github.com/quicwg/base-drafts/pull/2674.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674

---

From: Nick Banks <[email-masked]>
Date: Wed, 08 May 2019 00:02:23 +0000 (UTC)

nibanks approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#pullrequestreview-234814556

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 May 2019 17:04:14 -0700

marten-seemann commented on this pull request.

Do we really need to define "abandon"?
And if so, don't we need to define what "discarding" means?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#pullrequestreview-234814963

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 17:08:55 -0700

I know how you feel.  We'll be defining "the" eventually.  I don't know where the line is, but I think that it helps in this case to be doubly explicit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#issuecomment-490298489

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 May 2019 17:20:05 -0700

I'm wondering how one could possibly misinterpret "abandoning" here. Furthermore, I don't think it's relevant for the server here if the client actually discarded the connection state, as long as it doesn't any more packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#issuecomment-490300637

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:22:35 -0700

janaiyengar commented on this pull request.

> @@ -1130,6 +1130,8 @@ This system allows a server to process packets with unsupported versions without
 retaining state.  Though either the Initial packet or the Version Negotiation
 packet that is sent in response could be lost, the client will send new packets
 until it successfully receives a response or it abandons the connection attempt.
+As a result, the client discards all state for the connection and does not send
+any more packets.

```suggestion
any more packets on the connection.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#pullrequestreview-234818617

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 17:23:19 -0700

@martinthomson pushed 1 commit.

a23a5e7fba793c73466cd188a702541325d174b3  This isn't THAT broad a requirement.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674/files/fd597dfafdd02774372cec765ae1e2a0a29b655a..a23a5e7fba793c73466cd188a702541325d174b3

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:24:04 -0700

I don't think we need to spend a lot of energy here. I agree that this doesn't seem necessary, but I'm not going to fight it either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#issuecomment-490301373

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:24:22 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#pullrequestreview-234818895

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:26:28 -0700

Merged #2674 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2674#event-2325840568