Subject: [quicwg/base-drafts] Change error codes from 16-bit to varints (#2680)

From: ianswett <[email-masked]>
Date: Thu, 09 May 2019 13:57:24 +0000 (UTC)

Changes CONNECTION_CLOSE, STOP_SENDING, and RESET_STREAM to varint error codes.

Fixes #2672
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2680

-- Commit Summary --

  * Change error codes from 16-bit to varints

-- File Changes --

    M draft-ietf-quic-transport.md (38)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2680.patch
https://github.com/quicwg/base-drafts/pull/2680.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680

---

From: Nick Banks <[email-masked]>
Date: Thu, 09 May 2019 07:14:46 -0700

nibanks approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-235615172

---

From: ianswett <[email-masked]>
Date: Thu, 09 May 2019 09:28:47 -0700

@ianswett pushed 1 commit.

10176ae9245d406729b263a3c14994618d484c81  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680/files/f9dd7a0221e4433548dc0752e5a3971c0da019b1..10176ae9245d406729b263a3c14994618d484c81

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 09 May 2019 10:01:34 -0700

kazuho approved this pull request.

Thank you for the work!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-235709540

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 May 2019 16:12:02 -0700

martinthomson requested changes on this pull request.

Two relatively important things here.

> @@ -5550,7 +5554,7 @@ The initial contents of this registry are tabulated in {{frame-types}}.
 IANA \[SHALL add/has added] a registry for "QUIC Transport Error Codes" under a
 "QUIC Protocol" heading.
 
-The "QUIC Transport Error Codes" registry governs a 16-bit space.  This space is
+The "QUIC Transport Error Codes" registry governs a 62-bit space.  This space is
 split into two spaces that are governed by different policies.  Values with the

I think that we want to crib from the frame types (or other varint registries) when it comes to policies.  There isn't really a "first byte" any more.

> @@ -5456,7 +5460,7 @@ ID can be selected to route later packets to the same server.
 IANA \[SHALL add/has added] a registry for "QUIC Transport Parameters" under a
 "QUIC Protocol" heading.
 
-The "QUIC Transport Parameters" registry governs a 16-bit space.  This space is

You overdid it here.  It's still 16 for transport parameters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-235865595

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 01:32:26 -0700

ianswett commented on this pull request.

I did not know that, reverted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#discussion_r282793454

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 08:40:20 +0000 (UTC)

44f7c59ecf8e13640bd63ffd38a56b3e41716694  Martin's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680/files/10176ae9245d406729b263a3c14994618d484c81..44f7c59ecf8e13640bd63ffd38a56b3e41716694

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 01:40:30 -0700

Thanks, done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#discussion_r282796117

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 10 May 2019 08:13:56 -0700

For consistency you probably want to update HTTP too, e.g. there are some references to 16-bit error code there too

https://tools.ietf.org/html/draft-ietf-quic-http-20#section-10.5

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#issuecomment-491324854

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 17:55:22 +0000 (UTC)

6e404dea448afe44136a1b612e21ae009c82c395  Fix http error code registry length

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680/files/44f7c59ecf8e13640bd63ffd38a56b3e41716694..6e404dea448afe44136a1b612e21ae009c82c395

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 11:02:17 -0700

Thanks for pointing that out @LPardue, http updated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#issuecomment-491379473

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 May 2019 12:11:11 -0700

MikeBishop commented on this pull request.

> @@ -4537,8 +4537,9 @@ Stream ID:
 
 Application Protocol Error Code:
 
-: A 16-bit application protocol error code (see {{app-error-codes}}) which
-  indicates why the stream is being closed.
+: A variable-length integer indicating the application protocol error

Two uses of "indicat[e|ing]" in the same sentence might not flow so well.
```suggestion
: A variable-length integer containing the application protocol error
```

> @@ -4579,8 +4580,8 @@ Stream ID:
 
 Application Error Code:
 
-: A 16-bit, application-specified reason the sender is ignoring the stream (see
-  {{app-error-codes}}).
+: A variable-length integer carrying the application-specified reason the

Whatever word you choose at 4540, use it here too.

 Registrations MUST include the following fields:
 
 Value:
 
 : The numeric value of the assignment (registrations will be between 0x0000 and
-  0xfeff).
+  0x3fff).

```suggestion
  0x3fffffffffffffff).
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-236268408

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 12:20:22 -0700

b8284eb5f7af3d781bf6eaa1e1bfa8e8fa1424b1  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680/files/6e404dea448afe44136a1b612e21ae009c82c395..b8284eb5f7af3d781bf6eaa1e1bfa8e8fa1424b1

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 12:21:44 -0700

6e0f8c85c13cec1723598180b310602c1f23e79d  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680/files/b8284eb5f7af3d781bf6eaa1e1bfa8e8fa1424b1..6e0f8c85c13cec1723598180b310602c1f23e79d

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 12:25:36 -0700

Value:

I took this from adjacent text "QUIC Frame Type Registry": https://tools.ietf.org/html/draft-ietf-quic-transport-20#section-22.2

I'm honestly now sure what the correct value is, but I think we should be consistent?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#discussion_r283014079

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 May 2019 19:44:42 +0000 (UTC)

Value:

Actually, you had it right, because the range is subdivided above in the text you also borrowed from Frame Types.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#discussion_r283019638

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 13:00:13 -0700

Thanks Mike, I think I fixed all your suggestions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#issuecomment-491412632

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 10 May 2019 18:18:51 -0700

janaiyengar approved this pull request.

Thanks for adding the registry text. LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-236356152

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 May 2019 18:31:31 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2680#pullrequestreview-236990384