Subject: Re: [quicwg/base-drafts] Avoid creating QPACK codec streams when unnecessary (#2100)

From: afrind <[email-masked]>
Date: Thu, 23 May 2019 07:05:31 -0700

Discussed and clarified in London.

1. HTTP MUST set initial_max_uni_streams to at least 3
2. HTTP does not have to keep granting more credit if the peer burns the stream credits on grease/push/extensions.
3. Peers SHOULD create control, qpack encoder and decoder as their first 3 streams if they plan to use them, since there's no guarantee of ever getting more credit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2100#issuecomment-495233158

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 31 May 2019 11:15:25 -0700

Created #2762 in addition to the existing PR #2529 to also update the -http requirements as per the discussion in London.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2100#issuecomment-497810172