Subject: [quicwg/base-drafts] Checking duplicate TPs is onerous (#2689)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 10 May 2019 07:42:06 -0700

Unlike HTTP/3 settings, receipt of [duplicated transport parameters must be treated as an error](https://tools.ietf.org/html/draft-ietf-quic-transport-20#section-7.3):

```
                                                    An endpoint MUST
   treat receipt of duplicate transport parameters as a connection error
   of type TRANSPORT_PARAMETER_ERROR.
```

Why the inconsistency?

The checks for duplicated transport (or settings) parameters are expensive, because one has to maintain an arbitrarily-sized set of possibly large numbers.

I propose we switch the duplicate transport parameters enforcement to "MAY treat as error."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2689

---

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 08:12:07 -0700

I'm fine with MUST not send duplicates, MAY treat receipt as an error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2689#issuecomment-491324224

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 May 2019 09:14:44 -0700

Fine by me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2689#issuecomment-491345389

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 10 May 2019 18:24:52 -0700

Yup, seems sensible to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2689#issuecomment-491468180