Subject: Re: [quicwg/base-drafts] RTT measurement using PATH_* frames (#2644)

From: Jana Iyengar <[email-masked]>
Date: Wed, 08 May 2019 19:43:09 -0700

@rpaulo, #2637 removes that text. @ianswett is right, we'll need to caveat this at a minimum. I think it gets a bit tricky to use the PATH_CHALLENGE/RESPONSE for RTT if the RESPONSE can arrive on any path. The endpoint does not know what path will be used for data/acks, and it would have to assume that the path for CHALLENGE/RESPONSE will be the one used for data/acks, if it is to set its RTT estimate.

Perhaps we could say that an endpoint can use the CHALLENGE/RESPONSE RTT as a hint.

This will need some more thought.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-490721850

---

From: ianswett <[email-masked]>
Date: Thu, 09 May 2019 05:16:13 -0700

How about "MAY use the delay between sending a PATH_CHALLENGE and receiving a PATH_RESPONSE to seed initial_rtt for a new path, but MUST not be considered an RTT sample."?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-490878762

---

From: Rui Paulo <[email-masked]>
Date: Thu, 23 May 2019 02:35:28 -0700

Discussed with Ian in London: I'm okay with just using the PATH_CHALLENGE/PATH_RESPONSE RTT as the initial RTT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-495143685

---

From: ianswett <[email-masked]>
Date: Thu, 23 May 2019 02:36:56 -0700

Thanks @rpaulo can you review the outstanding PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#issuecomment-495144271

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 30 May 2019 15:42:01 -0700

Closed #2644 via #2687.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2644#event-2379499635