Subject: Re: [quicwg/base-drafts] Largest acked in ACK frame MUST NOT decrease (#2205)

From: Jana Iyengar <[email-masked]>
Date: Wed, 22 May 2019 06:47:54 -0700

I think this is mostly addressed and what's left is OBE. There's text in the draft now that says: "Processing counts out of order can result in verification failure. An endpoint SHOULD NOT perform this verification if the ACK frame is received in a packet with packet number lower than a previously received ACK frame. Verifying based on ACK frames that arrive out of order can result in disabling ECN unnecessarily."

This would be adequate, but there's other text (thanks to #2312) that says old ACKs can be resent. I think we simply add a note about that in the para above, which should be adequate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2205#issuecomment-494810073

---

From: Lars Eggert <[email-masked]>
Date: Wed, 22 May 2019 06:50:21 -0700

Discussed in London: @janaiyengar to prepare a PR for those remaining bits

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2205#issuecomment-494811031