Subject: [quicwg/base-drafts] Prohibit other frame types on CONNECT (#2702)

From: Mike Bishop <[email-masked]>
Date: Wed, 15 May 2019 10:31:44 -0700

Fixes #2229.

This still seems like a pointless restriction to me, but it's what we agreed in Tokyo, so here it is.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2702

-- Commit Summary --

  * Prohibit other frame types on CONNECT; fixes #2229

-- File Changes --

    M draft-ietf-quic-http.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2702.patch
https://github.com/quicwg/base-drafts/pull/2702.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702

---

From: ianswett <[email-masked]>
Date: Wed, 15 May 2019 11:52:07 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702#pullrequestreview-238007995

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 15 May 2019 18:38:09 -0700

janaiyengar approved this pull request.

nits

> @@ -1209,6 +1209,11 @@ TCP server; data received from the TCP server is packaged into DATA frames by
 the proxy. Note that the size and number of TCP segments is not guaranteed to
 map predictably to the size and number of HTTP DATA or QUIC STREAM frames.
 
+Once the CONNECT method has completed, only DATA frames are permitted
+to be sent on the stream.  (Extension frames MAY be used, if specifically

```suggestion
to be sent on the stream.  Extension frames MAY be used if specifically
```

> @@ -1209,6 +1209,11 @@ TCP server; data received from the TCP server is packaged into DATA frames by
 the proxy. Note that the size and number of TCP segments is not guaranteed to
 map predictably to the size and number of HTTP DATA or QUIC STREAM frames.
 
+Once the CONNECT method has completed, only DATA frames are permitted
+to be sent on the stream.  (Extension frames MAY be used, if specifically
+permitted by the extensions definition.)  Receipt of any other frame type

```suggestion
permitted by the definition of the extension.  Receipt of any other frame type
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702#pullrequestreview-238143912

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 12:04:56 -0700

@MikeBishop pushed 1 commit.

2de0e363c8e4ce20468d6b574877a960318d3531  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702/files/f8a051679038caa3a0bc8bf471cd3b5a3c4dd171..2de0e363c8e4ce20468d6b574877a960318d3531

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 16 May 2019 17:24:24 -0700

@MikeBishop 
> This still seems like a pointless restriction to me

I think I share the concern (though I am not sure how much I care). HTTP/3 is expected to allow extension frames to be used without coordination; this PR forbids that to happen on a stream that uses the CONNECT method.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702#issuecomment-493275012

---

From: Mike Bishop <[email-masked]>
Date: Fri, 17 May 2019 13:42:11 -0700

Merged #2702 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2702#event-2350405818