Subject: [quicwg/base-drafts] Automatic applicability of new TLS cipher suites (#2742)

From: ekr <[email-masked]>
Date: Wed, 22 May 2019 02:51:41 -0700

Suppose that we had a future TLS cipher suite such as AES_OCB_SHA256. Would that work with QUIC without a new QUIC draft? The AEAD part is already clearly defined and given that AES-OCB uses AES, the same HP mechanism as we currently use with GCM can be used here. 
>From my perspective, the desirable property is that if we add new TLS cipher suites with analogous cipher cores (block cipher and/or nonce-based stream cipher) to the existing spec, then no new QUIC document should be required.

An alternative design would be to just require a "QUIC applicability" paragraph in new TLS cipher suites analogous to the DTLS-OK IANA flag.

(see also #2019).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2742

---

From: MikkelFJ <[email-masked]>
Date: Wed, 22 May 2019 03:29:12 -0700

How about header protection which depends on being defined for the negotiated AEAD?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2742#issuecomment-494746435

---

From: ekr <[email-masked]>
Date: Wed, 22 May 2019 03:37:02 -0700

That's what paragraph 2 above is about.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2742#issuecomment-494748700

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 May 2019 07:17:02 -0700

Closed #2742 via #2743.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2742#event-2359488046