Subject: [quicwg/base-drafts] New paths may seed initial_rtt (#2687)

From: ianswett <[email-masked]>
Date: Fri, 10 May 2019 03:14:27 -0700

Fixes #2644
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2687

-- Commit Summary --

  * New paths may seed initial_rtt

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2687.patch
https://github.com/quicwg/base-drafts/pull/2687.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 10 May 2019 16:11:35 -0700

janaiyengar commented on this pull request.

> @@ -521,6 +521,10 @@ is available, or if the network changes, the initial RTT SHOULD be set to 500ms,
 resulting in a 1 second initial handshake timeout as recommended in
 {{?RFC6298}}.
 
+A new path on an existing connection MAY use the delay between sending a

can you fix this sentence? the path does not use the delay

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-236343413

---

From: ianswett <[email-masked]>
Date: Sat, 11 May 2019 08:27:02 -0700

@ianswett pushed 1 commit.

5eb311bba9a4ccaf61c167eabb619238ce6353c9  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687/files/8cbfed717229511b8a50f7c046d39ddd6a93617b..5eb311bba9a4ccaf61c167eabb619238ce6353c9

---

From: ianswett <[email-masked]>
Date: Sat, 11 May 2019 08:27:10 -0700

ianswett commented on this pull request.

Better?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#discussion_r283100837

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 13 May 2019 07:02:47 -0700

dtikhonov commented on this pull request.

+A connection MAY use the delay between sending a PATH_CHALLENGE and receiving
+a PATH_RESPONSE to seed initial_rtt for a new path, but MUST not be considered

Consider adding "the delay" -- "..., but _the delay_ MUST not be considered..."

In the current form, the sentence suggests that the connection must not be considered an RTT sample.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-236696336

---

From: ianswett <[email-masked]>
Date: Mon, 13 May 2019 07:13:34 -0700

c35d5f1357c04739a44b84dbdb5a45aacbb9f0f8  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687/files/5eb311bba9a4ccaf61c167eabb619238ce6353c9..c35d5f1357c04739a44b84dbdb5a45aacbb9f0f8

---

From: ianswett <[email-masked]>
Date: Mon, 13 May 2019 07:13:46 -0700

Thanks, done.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#discussion_r283366560

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 May 2019 18:29:13 -0700

1. Do we really want to keep the requirement to respond with a PATH_RESPONSE *immediately*?

2. This doesn't talk about paths.  Now, we might infer from this that the RTT to a peer isn't likely to dramatically change when paths change, but we'd want to be saying that directly.

3. How does this sit with the change in #2637?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-492044123

---

From: MikkelFJ <[email-masked]>
Date: Mon, 13 May 2019 23:31:31 -0700

On 2.: if you roam from 5G to 3G you could see significant latency spikes. Phasing out 3G networks and keeping 2G could move traffic to 2G EDGE in areas of thin coverage. Traffic could also move to narrow band IoT (if it is possible to run QUIC on these at all) with MUCH higher latency. Endpoints could choose stay on narrow band most of the time to save battery and perhaps online costs, but use 5G when a device wakes up for real (I could see a use case for that). Though of course might be served with separate connections for such extreme transitions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-492097186

---

From: ianswett <[email-masked]>
Date: Tue, 14 May 2019 02:57:32 -0700

1. I think this is OK as long as we limit how many path responses we send immediately?  Realistically, it's not that different from a generate_204, but it's something to be aware of.
2. I think we need to add a whole section on paths and connection migration in recovery. See #2684   I can do that in this PR if people want? 
3. #2367 decreases the value of this, since you may only see one half of the path.  It might still be better than nothing?  Initial RTT doesn't need to be correct, but getting it within a factor of 2 is helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-492171320

---

From: David Schinazi <[email-masked]>
Date: Tue, 14 May 2019 09:41:00 -0700

@ianswett I don't think you meant 2367

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-492315461

---

From: ianswett <[email-masked]>
Date: Tue, 14 May 2019 10:10:58 -0700

Thanks David, fixed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-492326327

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 16 May 2019 18:06:35 -0700

I'm split on this. While I understand the urge to optimize here, I'm not sure that documenting it here is necessary. 

Saying that an endpoint MAY use this signal gives permission, but does so without noting the potential issues. At a minimum, you would need to talk about the problems that are lurking ... especially in light of #2637, as I've noted in [my comment on #2644](https://github.com/quicwg/base-drafts/issues/2644#issuecomment-490721850).

Which leads me to wondering if it's really worth documenting this here without more experimentation and data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-493282070

---

From: ianswett <[email-masked]>
Date: Fri, 17 May 2019 05:56:26 -0700

I'm a fan of forbidding it's use as an actual RTT measurement, which would be one reason to say something?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-493443384

---

From: Rui Paulo <[email-masked]>
Date: Thu, 23 May 2019 02:36:45 -0700

I'd prefer that it's NOT forbidden.  I'm fine with waiting for experimentation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-495144181

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 23 May 2019 03:56:26 -0700

+A connection MAY use the delay between sending a PATH_CHALLENGE and receiving
+a PATH_RESPONSE to seed initial_rtt for a new path, but the delay MUST not be

```suggestion
a PATH_RESPONSE to seed initial_rtt for a new path, but the delay MUST NOT be
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-241128629

---

From: ianswett <[email-masked]>
Date: Tue, 28 May 2019 11:57:11 -0700

7beb5ef2b03ed4281e1d12cad18531d7bbb47269  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687/files/c35d5f1357c04739a44b84dbdb5a45aacbb9f0f8..7beb5ef2b03ed4281e1d12cad18531d7bbb47269

---

From: ianswett <[email-masked]>
Date: Tue, 28 May 2019 12:03:49 -0700

5a6461ef8016071d5474563e93453287c842be33  MUST NOT to SHOULD NOT

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687/files/7beb5ef2b03ed4281e1d12cad18531d7bbb47269..5a6461ef8016071d5474563e93453287c842be33

---

From: ianswett <[email-masked]>
Date: Tue, 28 May 2019 12:04:26 -0700

I changed this to SHOULD NOT from MUST NOT to allow some experimentation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#issuecomment-496647229

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 28 May 2019 12:05:04 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-242865111

---

From: Rui Paulo <[email-masked]>
Date: Tue, 28 May 2019 13:15:49 -0700

rpaulo approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-242897405

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 28 May 2019 22:53:59 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#pullrequestreview-243050090

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 30 May 2019 15:42:01 -0700

Merged #2687 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2687#event-2379499630