Subject: Re: [quicwg/base-drafts] Stop requiring remote address to match during path validation (#2637)

From: Eric Kinnear <[email-masked]>
Date: Wed, 01 May 2019 20:51:00 +0000 (UTC)

erickinnear commented on this pull request.

> @@ -1714,12 +1714,6 @@ meets the following criteria:
   acknowledgment for a packet containing a PATH_CHALLENGE frame is not adequate
   validation, since the acknowledgment can be spoofed by a malicious peer.
 
-- It was sent from the same remote address to which the corresponding
-  PATH_CHALLENGE was sent. If a PATH_RESPONSE frame is received from a different
-  remote address than the one to which the PATH_CHALLENGE was sent, path
-  validation is considered to have failed, even if the data matches that sent in
-  the PATH_CHALLENGE.
-
 - It was received on the same local address from which the corresponding
   PATH_CHALLENGE was sent.

Makes sense, thanks! Will add.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#discussion_r280211502

---

From: Eric Kinnear <[email-masked]>
Date: Wed, 01 May 2019 17:05:19 -0700

@erickinnear pushed 1 commit.

d4926d28d4424f0b405c5000f8e51b0af8b42257  Review comment redefining endpoint address

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637/files/4b9c212e8b7b54f213b812b4233ec9e330403f3f..d4926d28d4424f0b405c5000f8e51b0af8b42257

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 15:24:20 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#pullrequestreview-234790578

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 15:25:03 -0700

martinthomson requested changes on this pull request.

@erickinnear can you make that change, or should I?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#pullrequestreview-234790748

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 15:26:27 -0700

@martinthomson pushed 1 commit.

1e74be464007c1634455e76bedd558a5292fdddb  Remove extra requirement

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637/files/d4926d28d4424f0b405c5000f8e51b0af8b42257..1e74be464007c1634455e76bedd558a5292fdddb

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 15:26:44 -0700

Nevermind, I did it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#pullrequestreview-234791283

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:14:34 -0700

janaiyengar approved this pull request.

Looks great, and thanks for working through this @erickinnear 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#pullrequestreview-234817106

---

From: Eric Kinnear <[email-masked]>
Date: Wed, 08 May 2019 01:08:05 +0000 (UTC)

One other section, can we leave this as-is?
Section 8.4
```
To ensure that packets can be both sent to and received from the peer, the 
PATH_RESPONSE MUST be sent on the same path as the triggering 
PATH_CHALLENGE. That is, from the same local address on which
 the PATH_CHALLENGE was received, to the same remote address 
from which the PATH_CHALLENGE was received.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#issuecomment-490308768

---

From: Eric Kinnear <[email-masked]>
Date: Tue, 07 May 2019 18:09:20 -0700

Latest text looks great, thanks @martinthomson!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#issuecomment-490308978

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 19:31:35 -0700

a9fb45aaf09b85706cb988c6a866b075eb94f1e2  Delete contradictory text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637/files/1e74be464007c1634455e76bedd558a5292fdddb..a9fb45aaf09b85706cb988c6a866b075eb94f1e2

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 19 May 2019 09:57:04 -0700

@mnot and @larseggert, I think we’re good to go on this one, pending validating consensus on the list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2637#issuecomment-493773255