Subject: [quicwg/base-drafts] Break up H2 Frame Considerations (#2698)

From: Mike Bishop <[email-masked]>
Date: Tue, 14 May 2019 10:19:53 -0700

Splitting out Ian's suggestion to break up A.2 further.  Based on #2683.

**DO NOT MERGE** without changing target branch after #2683 lands.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2698

-- Commit Summary --

  * Break up H2 considerations

-- File Changes --

    M draft-ietf-quic-http.md (64)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2698.patch
https://github.com/quicwg/base-drafts/pull/2698.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2698

---

From: ianswett <[email-masked]>
Date: Tue, 14 May 2019 10:27:21 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2698#pullrequestreview-237393721

---

From: Lucas Pardue <[email-masked]>
Date: Sat, 18 May 2019 04:02:53 -0700

LPardue approved this pull request.

Made a small suggestion but oterwise LGTM.

> +PRIORITY frame on the request stream, if any, always comes first is explicitly
+stated.
+
+Exclusive prioritization has been removed, since implicitly reprioritizing other
+streams which might or might not exist yet is prone to race conditions even with
+the assumptions used to permit initial PRIORITY frames on request streams.
+
+HTTP/3 permits the prioritization of requests, pushes and placeholders that each
+exist in separate identifier spaces. The HTTP/3 PRIORITY frame replaces the
+stream dependency field with fields that can identify the element of interest
+and its dependency.
+
+### Header Compression Differences
+
+HPACK was designed with the assumption of in-order delivery. A sequence of
+encoded header blocks must arrive (and be decoded) at an endpoint in the same

```suggestion
encoded header block fragments must arrive (and be decoded) at an endpoint in the same
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2698#pullrequestreview-239194312

---

From: Martin Thomson <[email-masked]>
Date: Sun, 19 May 2019 23:40:21 -0700

martinthomson commented on this pull request.

+stated.
+

The concept of header block fragments is an h2 thing.  h3 provides the entire header block in one go, more or less, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2698#discussion_r285444160

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 20 May 2019 02:38:10 -0700

LPardue commented on this pull request.

+stated.
+

yeah I was looking at this from the wrong perspective. Header blocks is fine, I take back the suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2698#discussion_r285505428