Subject: Re: [quicwg/base-drafts] ECN text disables ECN too aggressively (#2534)

From: Magnus Westerlund <[email-masked]>
Date: Wed, 22 May 2019 02:02:08 -0700

So the intention here is that if you hit an ECN blackhole that you disable ECT marking the sent packet in a timely fashion to minimize the impact on connection establishment. And I don't think a single sender behavior is necessary. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-494717786

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 May 2019 02:30:22 -0700

@janaiyengar mentioned that this should be triggered on persistent congestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-494727283

---

From: Lars Eggert <[email-masked]>
Date: Wed, 22 May 2019 02:30:33 -0700

Agreed in London for @janaiyengar to write a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-494727355

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 22 May 2019 02:39:45 -0700

Just to clarify: RFC8311 permits other uses that are specified by an RFC: i.e., currently this is RFC8511, and the expected RFC to be published by the L4S work items in TSVWG (expecting to be Lc'ed later in 2019).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-494730361

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 22 May 2019 02:41:35 -0700

There seems two things:

• What to do during handshake (maybe is described in transport)

• Disabling after handshake which I think is in the loss/recovery draft, rather than transport? - I thought I heard Jana argue that this reaction depends on the loss/marking observations on the path - which I would agree with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2534#issuecomment-494730972