Subject: [quicwg/base-drafts] Push SHOULD precede reference (#2704)

From: Mike Bishop <[email-masked]>
Date: Wed, 15 May 2019 10:45:18 -0700

Fixes #2230's remaining issue by importing text from HTTP/2.  PUSH_PROMISE and DUPLICATE_PUSH SHOULD precede the piece of the response that references the resource, but MAY come at any point in the server's response, including between the trailers and the end of the stream.  That's exceptionally stupid server behavior, but not illegal.

I consider this editorial, because no MUSTs are modified and the SHOULD was already incorporated by reference to 7540.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2704

-- Commit Summary --

  * Push SHOULD precede reference

-- File Changes --

    M draft-ietf-quic-http.md (20)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2704.patch
https://github.com/quicwg/base-drafts/pull/2704.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704

---

From: ianswett <[email-masked]>
Date: Wed, 15 May 2019 20:14:39 +0000 (UTC)

ianswett commented on this pull request.

 The same server push can be associated with additional client requests using a
-DUPLICATE_PUSH frame (see {{frame-duplicate-push}}).  Ordering of a
-DUPLICATE_PUSH in relation to certain parts of the response is similarly
-important.
+DUPLICATE_PUSH frame (see {{frame-duplicate-push}}).
+
+Ordering of a PUSH_PROMISE or DUPLICATE_PUSH in relation to certain parts of the
+response is important. The server SHOULD send PUSH_PROMISE or DUPLICATE_PUSH
+frames prior to sending any frames that reference the promised responses.  This

```suggestion
frames prior to sending any DATA frames that reference the promised responses.  This
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#pullrequestreview-238046624

---

From: Mike Bishop <[email-masked]>
Date: Wed, 15 May 2019 21:12:47 -0700

MikeBishop commented on this pull request.

Could be HEADERS frames, too.  (Link headers, for example.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#discussion_r284533089

---

From: Martin Thomson <[email-masked]>
Date: Thu, 16 May 2019 05:28:18 -0700

martinthomson approved this pull request.

+avoids a race where clients issue requests prior to receiving any PUSH_PROMISE

This ensures that clients do not issue a request for resources that will be pushed by the server.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#pullrequestreview-238358124

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 11:05:32 -0700

@MikeBishop pushed 1 commit.

d14a4238f65b0f7c46cef78faf600ee41d8677ed  Reduces MT's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704/files/ac42216a6d978d3ea0934e195e0ac135478ff681..d14a4238f65b0f7c46cef78faf600ee41d8677ed

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 16 May 2019 16:05:00 -0700

janaiyengar approved this pull request.

Presumably this includes DATA frames that include a reference? Is it worth calling that out explicitly?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#pullrequestreview-238677469

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 16:08:48 -0700

Either HEADERS or DATA, which are all the frame types you would expect to be interleaved with.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#discussion_r284930178

---

From: ianswett <[email-masked]>
Date: Fri, 17 May 2019 06:01:10 -0700

```suggestion
frames prior to sending HEADERS or DATA frames that reference the promised responses.  This
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#pullrequestreview-238911094

---

From: ianswett <[email-masked]>
Date: Fri, 17 May 2019 06:01:26 -0700

Suggesting a change, since Jana and I had the same comment :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#discussion_r285115614

---

From: Mike Bishop <[email-masked]>
Date: Fri, 17 May 2019 11:02:29 -0700

cf3b3844a3d9f6b1b9965f8d3e4e0117d4ba43b0  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704/files/5f7481d880e2d805d4dc9a34686e31d51d54b4ab..cf3b3844a3d9f6b1b9965f8d3e4e0117d4ba43b0

---

From: Mike Bishop <[email-masked]>
Date: Fri, 17 May 2019 11:04:26 -0700

Merged #2704 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2704#event-2350073819