Subject: [quicwg/base-drafts] Specify error on receipt a DATA frame before a HEADERS frame on a request stream (#2712)

From: Daan De Meyer <[email-masked]>
Date: Thu, 16 May 2019 13:51:44 +0000 (UTC)

The current draft doesn't mention what to do when receiving a DATA frame before a HEADERS frame on a request stream. This pr explicitly requires recipients to respond with a connection error of type HTTP_UNEXPECTED_FRAME.

I'm not entirely sure the DATA frame definition section is the best place for this addition (if it's a valid addition). Another possibility would be the HTTP Message Exchanges section. Any input on this is appreciated.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2712

-- Commit Summary --

  * Specify error on receipt a DATA frame before a HEADERS frame on a

-- File Changes --

    M draft-ietf-quic-http.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2712.patch
https://github.com/quicwg/base-drafts/pull/2712.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 16 May 2019 14:12:13 +0000 (UTC)

I think this is good text to add. I'll defer _exactly where_ to Mike.

Note that this problem also affects push streams, not just request streams. That is, the pushed DATA must not appear before the pushed HEADERS. 

So it seems to me that the Message Exchange section might help us cover all cases. But maybe not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712#issuecomment-493084346

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 11:46:13 -0700

I tend to lean toward the Message Exchange section -- this is a question of getting frames in an order that can't possibly carry a valid HTTP message.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712#issuecomment-493187141

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 11:48:02 -0700

Closed #2712.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712#event-2347376344

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 11:51:18 -0700

Ack, I was fixing the fact that #2701 broke everything and messed this up.  Once the PR closed, I lost access to @DaanDeMeyer's branch to un-mess it.  Moving to a quicwg branch.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712#issuecomment-493188843

---

From: Mike Bishop <[email-masked]>
Date: Thu, 16 May 2019 18:55:55 +0000 (UTC)

Bah, and it won't let me make this PR point to the new branch, either.  Grr, GitHub.  Grr.  This is now #2715.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2712#issuecomment-493190408