Subject: [quicwg/base-drafts] Specify push stream truncated last frame error. (#2722)

From: Daan De Meyer <[email-masked]>
Date: Fri, 17 May 2019 12:00:51 -0700

Until now, only bidirectional streams were specified to treat a truncated last frame on a cleanly terminated stream as an error. With this pr, the same logic applies to push streams as well.

I just slightly reworded the text from the bidirectional streams section and put it into the push stream section. Not sure if this is the best solution but I'm also not sure where to put the text if the text for both the bidirectional streams and push streams had to be combined.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2722

-- Commit Summary --

  * Specify push stream truncated last frame error.

-- File Changes --

    M draft-ietf-quic-http.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2722.patch
https://github.com/quicwg/base-drafts/pull/2722.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2722

---

From: Mike Bishop <[email-masked]>
Date: Mon, 20 May 2019 10:53:59 -0700

[7.1](https://quicwg.org/base-drafts/draft-ietf-quic-http.html#rfc.section.7.1) already contains this text:
> Each frame’s payload MUST contain exactly the fields identified in its description. A frame payload that contains additional bytes after the identified fields or a frame payload that terminates before the end of the identified fields MUST be treated as a connection error of type HTTP_MALFORMED_FRAME.

That's intended to cover any stream type with frames.  Perhaps we should consolidate the language from both sections into that, possibly leaving behind cross-references.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2722#issuecomment-494088012

---

From: Daan De Meyer <[email-masked]>
Date: Mon, 20 May 2019 11:26:15 -0700

I hadn't seen that paragraph yet. I'd propose to drop the text in the Bidirectional Streams section.

The reasoning is that when searching for what to do when a stream is closed with a truncated frame, I found (or rather was pointed to) the text in the Bidirectional Streams section. After finding a paragraph like that, I didn't expect to find any other text in the rfc related to truncated frames (which led to this pr). Without the text in the Bidirectional Streams section, I might have found the text in the Frame Layout section first which would have immediately answered my question.

This would also consolidate errors related to frames in the HTTP Framing Layer section which seems like the first place to go looking for frame related errors.

Should I make another pr (if this sounds like a good idea) or update this one with the proposed change?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2722#issuecomment-494099043

---

From: Mike Bishop <[email-masked]>
Date: Mon, 20 May 2019 11:29:11 -0700

Fine to just update this one.  Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2722#issuecomment-494100062

---

From: Daan De Meyer <[email-masked]>
Date: Mon, 20 May 2019 12:20:19 -0700

This is the best I could come up with. I had to relax the text from Frame Layout to allow truncated frames on abruptly closed streams. Maybe abruptly closed stream should be clarified better (I'm not sure if this is done elsewhere already?).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2722#issuecomment-494117121