Subject: Re: [quicwg/base-drafts] Add normative language for stateless reset (#2574)

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 May 2019 17:35:32 -0700

janaiyengar approved this pull request.

Thanks, @martinthomson, this LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#pullrequestreview-234820958

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 May 2019 19:29:34 -0700

Before I merge this, @mnot, @larseggert might want to check that I'm not making technical changes.  (There is new 2119 language, but my view is that this is converting from implied to express, but I want to give a chance to run a consensus call if you think that's appropriate.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#issuecomment-490323103

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 08 May 2019 05:05:19 +0000 (UTC)

Those sorts of conversions have surprised people before, and #2471 is design anyway, so let's do run that consensus call. If it's ready to go, add `has-proposal` and we'll run it up the virtual flagpole.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#issuecomment-490348680

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 May 2019 14:13:40 +0000 (UTC)

@martinthomson pushed 1 commit.

87daa3f5d94a641b0ef9b9b015b4329472d8ecfe  Moar normative text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574/files/dd121afa26088dd473e2dcf04c62d4a163bdc49c..87daa3f5d94a641b0ef9b9b015b4329472d8ecfe

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 May 2019 07:13:53 -0700

@martinduke take a look at what I just proposed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#issuecomment-494821047

---

From: martinduke <[email-masked]>
Date: Wed, 22 May 2019 07:43:39 -0700

martinduke approved this pull request.

Thank you, this addresses the original issue. One nit below.

> @@ -4010,7 +4014,9 @@ stateless_reset_token (0x0002):
 
 : A stateless reset token is used in verifying a stateless reset, see
   {{stateless-reset}}.  This parameter is a sequence of 16 bytes.  This
-  transport parameter is only sent by a server.
+  transport parameter MUST NOT be sent by a client, but MAY be sent by a server.
+  A server that does not send this transport parameter cannot use stateless
+  reset; see {{stateless-reset}}.

Unless it sends a NEW_CONNECTION_ID frame?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574#pullrequestreview-240676752

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 May 2019 07:49:54 -0700

375605a52a11cd7ba2aa23990f518bc31bf0153f  Only for that connection ID

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2574/files/87daa3f5d94a641b0ef9b9b015b4329472d8ecfe..375605a52a11cd7ba2aa23990f518bc31bf0153f