Subject: [quicwg/base-drafts] Unclear conditions in long header descr. (#2719)

From: MikkelFJ <[email-masked]>
Date: Fri, 17 May 2019 10:08:37 -0700

https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#long-header

> Long headers are used for packets that are sent prior to the establishment of 1-RTT keys. Once both conditions are met, a sender switches to sending packets using the short header (Section 17.3). 

What are these "both conditions"?

Also, can there be made a clear statement such that: all packets prior to Application PN space use long headers, and all packets in application PN space uses short headers?

And, the table of frames with section references, would it make sense to add PN space columns with an X where a frame is applicable?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2719

---

From: Mike Bishop <[email-masked]>
Date: Fri, 17 May 2019 11:10:23 -0700

Multiple issues listed here.  Please consider opening separate issues rather than lumping them all together.

(1) This is old language we agreed to in Chicago.  The requirement to shift to short headers was 1-RTT key availability and version agreement, to accommodate versions where the final keys might be available immediately (i.e. out-of-band agreement) but version negotiation still had to complete.

However, that's a principle for the invariants or such a version, not a requirement of this QUIC version -- and the version negotiation language this referenced is gone now.

(2) What is "Application PN space"?  0-RTT and 1-RTT?  If so, then no -- 0-RTT packets carry application data but are long-header packets.

(3) Unrelated editorial suggestion -- please open a separate issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2719#issuecomment-493547749

---

From: MikkelFJ <[email-masked]>
Date: Fri, 17 May 2019 11:41:30 -0700

(3) see  #2721

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2719#issuecomment-493557500