Subject: [quicwg/base-drafts] QPACK might be part of the exchange, but not (#2668)

From: Mike Bishop <[email-masked]>
Date: Mon, 06 May 2019 15:48:56 -0700

Fixes #2657.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2668

-- Commit Summary --

  * QPACK might be part of the exchange, but not

-- File Changes --

    M draft-ietf-quic-http.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2668.patch
https://github.com/quicwg/base-drafts/pull/2668.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 06 May 2019 16:11:07 -0700

LPardue commented on this pull request.

> @@ -942,6 +942,11 @@ A server MAY interleave one or more PUSH_PROMISE frames (see
 PUSH_PROMISE frames are not part of the response; see {{server-push}} for more
 details.
 
+The HEADERS and PUSH_PROMISE frames might reference updates to the QPACK table
+which are sent at the same time.  While these updates are not directly part

Maybe the first sentence could say something like

"The HEADERS and PUSH_PROMISE frames might referenced synchronised updates to the QPACK dynamic table."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668#pullrequestreview-234243324

---

From: Martin Thomson <[email-masked]>
Date: Mon, 06 May 2019 16:27:25 -0700

martinthomson approved this pull request.

or "HEADERS and PUSH_PROMISE frames might reference[!] concurrent updates to the QPACK dynamic table"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668#pullrequestreview-234243773

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 May 2019 16:01:00 +0000 (UTC)

@MikeBishop pushed 1 commit.

cd68989f810cbc43df39f6e625c91ef446256a62  Concurrent

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668/files/761e99e6f6b062a94687b8cfa86f0d7db21f8d8b..cd68989f810cbc43df39f6e625c91ef446256a62

---

From: afrind <[email-masked]>
Date: Tue, 07 May 2019 13:40:56 -0700

afrind approved this pull request.

+The HEADERS and PUSH_PROMISE frames might reference concurrent updates to the
+QPACK table.  While these updates are not directly part of the message exchange,

I agree with Martin that we should say 'QPACK dynamic table' here.  

I'm not crazy about 'concurrent'.  What if we just said 'might reference updates'?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668#pullrequestreview-234750166

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 May 2019 10:13:27 -0700

04b54fac3dfec33bcf0f28a5342131ebe8ac9cf7  Not concurrent

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668/files/cd68989f810cbc43df39f6e625c91ef446256a62..04b54fac3dfec33bcf0f28a5342131ebe8ac9cf7

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 May 2019 10:14:29 -0700

ed08281cac4eccdd7c2f547a525c664de947cd88  Not static

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668/files/04b54fac3dfec33bcf0f28a5342131ebe8ac9cf7..ed08281cac4eccdd7c2f547a525c664de947cd88

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 May 2019 10:16:30 -0700

Merged #2668 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2668#event-2337663129