Subject: Re: [quicwg/base-drafts] Clients cannot abandon Initial packets while server can still send initial close (#2541)

From: Christian Huitema <[email-masked]>
Date: Tue, 07 May 2019 20:51:41 -0700

Note the trade-off there: once the handshake is established, the peers have a secure channel modulo possible MITM. Critical messages like connection close really ought to be sent on the secure channel. The client that accepts connection close on the Initial channel opens itself to the equivalent of a spoofed TCP RST. Secure implementations must be allowed to ignore all Initial packets once handshake is established.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2541#issuecomment-490336977

---

From: ekr <[email-masked]>
Date: Wed, 22 May 2019 02:53:58 -0700

See also #2741 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2541#issuecomment-494735347