Subject: Re: [quicwg/base-drafts] Be clearer about the purpose of disable_migration (#2389)

From: Igor Lubashev <[email-masked]>
Date: Mon, 13 May 2019 15:05:05 -0700

> what a client might expect when it continues sending packets after switching networks to a server that has disable_migration set.

It is my understanding that "disable_migration set" means that packets sourced from a different IP or port are likely to be blackholed.  Hence, the client SHOULD reconnect instead of attempting a connection migration.

As for the servers that specified "disable_migration", they are free to blockhole packets for migrating connections or to honor connection migration (after an ordinary path validation).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-492004255

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 16 May 2019 18:56:04 -0700

@igorlord, yes that sounds about right, but we probably want to specify that a server that cannot validate a new source MUST blackhole packets from that source.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-493290129

---

From: Igor Lubashev <[email-masked]>
Date: Thu, 16 May 2019 21:09:43 -0700

Sure, though this is already what falls out from the text. There is already explicit text that source address validation is a MUST.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-493312358

---

From: MikkelFJ <[email-masked]>
Date: Thu, 16 May 2019 23:42:27 -0700

It may also be due to implementations not implementing path migration logic or maintain the necessary state, or servers that wish to use 0-length CIDs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-493340187

---

From: Lars Eggert <[email-masked]>
Date: Wed, 22 May 2019 06:20:25 -0700

Discussed in London: to be resolved together with #2342 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2389#issuecomment-494798965