Subject: [quicwg/base-drafts] Junk QUIC High Hardware Usage (#2795)

From: Dominic Guana <[email-masked]>
Date: Sat, 15 Jun 2019 02:10:00 -0700

According to research by Google, hardware usage using QUIC can reach upto 3.5x that of TCP+TLS, when optimized, this can be reduced to 2x hardware usage that of TCP+TLS. 

This means that if QUIC/HTTP3 becomes a new standard that needs about 2x the hardware needed to operate the Internet in the whole world. In addition, this means that it will consume two times more energy than the current energy usage. 

In summary, QUIC is 2x costly and 2x more crippling to the World Wide Network.

Here is the research article

https://static.googleusercontent.com/media/research.google.com/en//pubs/archive/46403.pdf

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2795

---

From: Lars Eggert <[email-masked]>
Date: Sat, 15 Jun 2019 04:52:37 -0700

If true, this only remains true until we have better hardware offload functionality.

I see nothing actionable for the WG here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2795#issuecomment-502359988

---

From: Martin Thomson <[email-masked]>
Date: Sat, 15 Jun 2019 23:03:52 -0700

Closed #2795.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2795#event-2415729173