Subject: Re: [quicwg/base-drafts] NUM_PLACEHOLDERS MUST NOT be zero (#2753)

From: Robin Marx <[email-masked]>
Date: Wed, 05 Jun 2019 02:13:09 -0700

> Fair point. I agree that placeholders becomes no longer a prerequisite for browsers once we bring back the "exclusive" bit (as proposed by #2754).

@kazuho could you clarify this comment a bit? Do you mean placeholders are no longer needed if we bring back the exclusive bit **AND allow streams to depend on other streams**? I don't follow you if that last part isn't implied.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2753#issuecomment-499004322

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 05 Jun 2019 04:03:00 -0700

@rmarx 
> Do you mean placeholders are no longer needed if we bring back the exclusive bit __AND allow streams to depend on other streams__?

Correct. IIUC, the context is if the browsers need to use a placeholder under current scheme (that already allows a stream to depend on another) with the exclusive bit being revived.

Let me be precise.

I think there is a rough consensus that a ideal tree looks like:

```
root
  +- JS1 (blocking)
      +- CSS1 (blocking)
        +- CSS2 (blocking)
            +- image1 (weight=X)
            +- image2 (weight=X)
            +- image3 (weight=X)
            +- image4 (weight=X)
```

HTML could be either within the root and JS1, or within CSS2 and image1.

The other thing that is missing in the chart above are the the asynchronously loaded scripts and CSS files. However, we could argue that prioritization of them is not important, as long as it receives comparable or less bandwidth than the images.

If we agree on that, there is no "need" for browsers to use placeholders (or idle streams as placeholders), neither in the HTTP/2 prioritization tree nor the current HTTP/3 scheme with the exclusive bit being revived.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2753#issuecomment-499038529

---

From: Mike Bishop <[email-masked]>
Date: Thu, 06 Jun 2019 16:31:24 -0700

> **AND allow streams to depend on other streams**? I don't follow you if that last part isn't implied.

Streams are allowed to depend on other streams.  While @ianswett has proposed removing that in some of the do-better-than-H2 discussion, it hasn't been removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2753#issuecomment-499705319

---

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 12:00:24 -0700

I'm really happy that we have a fairly clear idea of what the goal is in terms of prioritization.  There's certainly a bit of wiggle room and room for experimentation, but I do believe we have rough consensus that we want a mechanism that can accomplish what's in @kazuho post.

As @kazuho says, if that's true, then I don't think we need placeholders to accomplish that prioritization.  And if that's true, then there's no critical dependency on a non-zero number of placeholders.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2753#issuecomment-500547860