Subject: [quicwg/base-drafts] Remove HTTP_PUSH_ALREADY_IN_CACHE error (#2813)

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 05:11:23 -0700

Fixes #2812
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2813

-- Commit Summary --

  * Remove HTTP_PUSH_ALREADY_IN_CACHE error

-- File Changes --

    M draft-ietf-quic-http.md (13)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2813.patch
https://github.com/quicwg/base-drafts/pull/2813.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 07:05:30 -0700

@LPardue pushed 1 commit.

54e6a0cac182c5967de3e14c3c4279bc30c3076d  Apply Kazuho's suggestion to replace HTTP_PUSH_REFUSED with HTTP_REQUEST_CANCELLED

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813/files/017b22b6dac6c9ff845bea1674d21191d57195be..54e6a0cac182c5967de3e14c3c4279bc30c3076d

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Jun 2019 10:29:06 -0700

MikeBishop requested changes on this pull request.

Is there a reason to reserve the error codes we remove?

> @@ -785,10 +785,9 @@ amount of data a server may commit to the pushed stream.
 
 If a promised server push is not needed by the client, the client SHOULD send a
 CANCEL_PUSH frame. If the push stream is already open or opens after sending the
-CANCEL_PUSH frame, a QUIC STOP_SENDING frame with an appropriate error code can
-also be used (e.g., HTTP_PUSH_REFUSED, HTTP_PUSH_ALREADY_IN_CACHE; see
-{{errors}}). This asks the server not to transfer additional data and indicates
-that it will be discarded upon receipt.
+CANCEL_PUSH frame, a QUIC STOP_SENDING frame with an error code of
+HTTP_PUSH_REFUSED. This asks the server not to transfer additional data and

This sentence is missing a verb.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#pullrequestreview-251854183

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 10:54:49 -0700

My intention was to keep PRs somewhat atomic and fragment the error code space in each PR that separately removes or consolidates an error code.

Once complete, I would then defrag it on a PR that let's people weigh in on which error code should have which number.

(It also simplifies dependencies which having branches off branches)

Happy to do something different if you want.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#issuecomment-503664852

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 19 Jun 2019 17:48:07 -0700

kazuho approved this pull request.

To me the subject and the verb being omitted in this sentence was a bit surprising, but that might be due to me not being a native speaker.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#pullrequestreview-252036790

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 17:57:20 -0700

LPardue commented on this pull request.

It is an error, thanks for picking it up. I would convert this to

"a QUIC STOP_SENDING frame with an error code of HTTP_REQUEST_CANCELLED can be used."

Alternatively, elsewhere we talk about "triggering QUIC STOP_SENDING" which is under review as part of @MikeBishop #2805 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#discussion_r295578696

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 20 Jun 2019 04:12:41 -0700

8af1c7542fadd31e2cf517f383772bebfc20f46a  Fix broken grammar

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813/files/e246182970ee59dd3fe37dbdd577226b1f04f781..8af1c7542fadd31e2cf517f383772bebfc20f46a

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 16:56:37 -0700

martinthomson commented on this pull request.

> @@ -1903,9 +1901,9 @@ The entries in the following table are registered by this document.
 | ----------------------------------- | ---------- | ---------------------------------------- | ---------------------- |
 | HTTP_NO_ERROR                       | 0x0000     | No error                                 | {{http-error-codes}}   |
 | HTTP_WRONG_SETTING_DIRECTION        | 0x0001     | Setting sent in wrong direction          | {{http-error-codes}}   |
-| HTTP_PUSH_REFUSED                   | 0x0002     | Client refused pushed content            | {{http-error-codes}}   |
+| Reserved                            | 0x0002     | N/A                                      | N/A                    |

My sense is that we want to do a final cleanup for reserved error codes.  We might reserve some for keeping the relationship with RFC 7540 clean, but I don't think that a renumbering is a bad idea after all this work on fixing errors completes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#pullrequestreview-254326122

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 25 Jun 2019 17:01:08 -0700

Definitely. Not many good reasons exist to reserve codes for the shipped RFC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#discussion_r297439726

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Jun 2019 14:36:20 -0700

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#pullrequestreview-255493174

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Jun 2019 14:36:45 -0700

Merged #2813 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2813#event-2445648309