Subject: [quicwg/base-drafts] Keeping losing ACK for Handshake packet leads 0 cwnd (#2779)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 10 Jun 2019 01:42:05 -0700

>  Upon timeout, the sender MUST retransmit all unacknowledged CRYPTO data if possible. The sender MUST NOT declare in-flight crypto packets as lost when the crypto timer expires.

So timer expiration does not remove in-flight unacknowleged CRYPTO data from bytes_in_flight.  This means if ACK continues to be lost for Handshake packet, endpoint has no cwnd left to send any packet.  loss time based detection does not kick in because no ACK is received.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2779

---

From: MikkelFJ <[email-masked]>
Date: Mon, 10 Jun 2019 02:01:42 -0700

If the handshake cannot make progress here, perhaps it is better to give up?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2779#issuecomment-500344993

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Mon, 10 Jun 2019 02:21:10 -0700

It could, but why not reclaim data credit by making CRYPTO data lost?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2779#issuecomment-500350484

---

From: Marten Seemann <[email-masked]>
Date: Mon, 10 Jun 2019 02:26:42 -0700

I think the CRYPTO retransmissions are intended to be analogous to PTOs. For PTOs, we only declare any packet lost when we receive an acknowledgement.
If that's indeed the intention here, we would also need to treat CRYPTO retransmissions as probe packets, which are not blocked by the congestion controller.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2779#issuecomment-500352002

---

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 06:47:10 -0700

Marten is correct.  It's on my TODO list to try to merge these mechanisms(redo of #2655), but it takes very careful thought and that PR quickly became conflict-heavy.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2779#issuecomment-500422443