Subject: [quicwg/base-drafts] Exceeding Max STREAM ID should be a connection error (#2825)

From: ianswett <[email-masked]>
Date: Fri, 21 Jun 2019 11:30:54 -0700

In most places in QUIC, if an error is clearly avoidable(ie: only a buggy implementation would do so), then we advise closing the connection with an error, not just closing the stream with an error.

In section 4.5 of transport(https://tools.ietf.org/html/draft-ietf-quic-transport-20#section-4.5) it says:
"Endpoints MUST NOT exceed the limit set by their peer.  An endpoint
 that receives a STREAM frame with a stream ID exceeding the limit it
 has sent MUST treat this as a stream error of type STREAM_LIMIT_ERROR"

Came up in discussion of #2730 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825

---

From: ianswett <[email-masked]>
Date: Fri, 21 Jun 2019 13:30:21 -0700

As I commented in the updated PR description, section 19.11 already says this:
"An endpoint MUST terminate a connection
 with a STREAM_LIMIT_ERROR error if a peer opens more streams than was
 permitted."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#issuecomment-504563117

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 17:06:57 -0700

Closed #2825 via #2826.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#event-2439267319

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 17:07:02 -0700

Reopened #2825.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#event-2439267422

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 17:07:13 -0700

Reopening to keep this visible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#issuecomment-505666580

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 27 Jun 2019 00:13:20 -0700

#2826 is effectively the proposal, correct?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#issuecomment-506222972

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Jun 2019 01:01:47 -0700

Yes. It was editorial. So I merged it. But then this issue really isn't editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#issuecomment-506238481

---

From: ianswett <[email-masked]>
Date: Thu, 27 Jun 2019 05:20:46 -0700

Yes, I opened this issue, then found that text in section 19.11 in the doc said exceeding MAX_STREAM_ID was a connection error, so the PR ended up aligning the two sections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2825#issuecomment-506322647