Subject: [quicwg/base-drafts] Explicitly allow discard of packets <40 bytes (#2864)

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Jun 2019 17:12:14 -0700

The stateless reset text implied a lot, but never really explicitly said
what to do when going below the minimum recommended size.

This is a design change to an issue marked editorial.  Enjoy.

Closes #2153.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2864

-- Commit Summary --

  * Explicitly allow discard of packets <40 bytes

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2864.patch
https://github.com/quicwg/base-drafts/pull/2864.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864

---

From: Marten Seemann <[email-masked]>
Date: Sun, 30 Jun 2019 17:16:25 -0700

marten-seemann commented on this pull request.

> @@ -2525,9 +2526,6 @@ a small packet might result in Stateless Reset not being useful in detecting
 cases of broken connections where only very small packets are sent; such
 failures might only be detected by other means, such as timers.
 
-An endpoint can increase the odds that a packet will trigger a Stateless Reset

Why did you remove this sentence?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#pullrequestreview-256098272

---

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Jun 2019 17:18:31 -0700

martinthomson commented on this pull request.

See #2153.  Or were you asking for it to be retained?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#discussion_r298855805

---

From: Marten Seemann <[email-masked]>
Date: Sun, 30 Jun 2019 17:25:23 -0700

Yes. I think it's a good idea to always send a packet padded to > 40 bytes after quiescence, so you'd be able to quickly recover by receiving the stateless reset.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#discussion_r298856107

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 30 Jun 2019 23:04:57 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#pullrequestreview-256142776