Subject: Re: [quicwg/base-drafts] Stronger migration handshake (#2370)

From: Christian Huitema <[email-masked]>
Date: Tue, 04 Jun 2019 22:46:42 -0700

@huitema pushed 1 commit.

23bacec76b1a30d8cb2119f7cb8c085c02524973  Reference "handshake confrmed" for connection migration.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370/files/7312d63a4ee85cd125b97d3868a9572f129e0120..23bacec76b1a30d8cb2119f7cb8c085c02524973

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Jun 2019 00:53:18 -0700

I like the latest text referencing handshake confirmed 👍 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#issuecomment-498978047

---

From: Christian Huitema <[email-masked]>
Date: Wed, 05 Jun 2019 02:47:01 -0700

@DavidSchinazi I was waiting for #2673...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#issuecomment-499015759

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Jun 2019 04:20:49 -0700

@huitema I know :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#issuecomment-499043438

---

From: Eric Kinnear <[email-masked]>
Date: Wed, 05 Jun 2019 09:40:04 -0700

erickinnear approved this pull request.

Looking good!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#pullrequestreview-246126257

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 05 Jun 2019 13:55:59 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#pullrequestreview-246253593

---

From: ianswett <[email-masked]>
Date: Wed, 05 Jun 2019 13:59:06 -0700

ianswett approved this pull request.

> @@ -1794,9 +1793,10 @@ addresses (IP address and port), such as those caused by an
 endpoint migrating to a new network.  This section describes the process by
 which an endpoint migrates to a new address.
 
-An endpoint MUST NOT initiate connection migration before the handshake is
-finished and the endpoint has 1-RTT keys.  The design of QUIC relies on
+The design of QUIC relies on

nit: Please reflow this paragraph so this is a full line.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#pullrequestreview-246255010

---

From: Marten Seemann <[email-masked]>
Date: Wed, 05 Jun 2019 21:19:06 -0700

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#pullrequestreview-246356918

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Jun 2019 02:48:19 -0700

@martinthomson pushed 1 commit.

0cefaa1ddf7680bc5d04133fd93e8216c57ceae7  Whitespace edits

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370/files/23bacec76b1a30d8cb2119f7cb8c085c02524973..0cefaa1ddf7680bc5d04133fd93e8216c57ceae7

---

From: Christian Huitema <[email-masked]>
Date: Sat, 22 Jun 2019 22:41:57 -0700

huitema commented on this pull request.

>  endpoints retaining a stable address for the duration of the handshake.
+An endpoint MUST NOT initiate connection migration before the handshake is
+finished for it and its peer and the endpoint has 1-RTT keys. This means
+that the server MUST NOT initiate connection migration before it has
+received at least one 1-RTT data from the client, and the client 
+MUST NOT initiate connection migration before receiving 
+acknowledgement by the server of at least one of its
+1-RTT messages.

Solved in rewrite with dependency on "handshake confirmed".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2370#discussion_r296465803