Subject: Re: [quicwg/base-drafts] Semantics of SETTINGS_MAX_HEADER_LIST_SIZE (#2516)

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Jun 2019 09:22:46 -0700

Discussed in London; an implementation SHOULD NOT send its peer a message that's over the peer's advertised size.  Text clarifying that the peer is advertising the (approximate) limit at which it will refuse to accept a message, enabling the local implementation to fail more quickly and avoid the risk that the "refusal" might be a connection termination which would disrupt legitimate messages as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2516#issuecomment-498327244

---

From: MikkelFJ <[email-masked]>
Date: Mon, 03 Jun 2019 09:26:03 -0700

As long as it isn't a MUST. There might be pre-canned requested of a reasonable size that generally just works, and having to check these might not be worthwhile on the odd chance of a very restrictive peer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2516#issuecomment-498328567

---

From: Mike Bishop <[email-masked]>
Date: Tue, 18 Jun 2019 14:26:55 -0700

Closed #2516 via #2774.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2516#event-2422297832