Subject: Re: [quicwg/base-drafts] Increase the odds of a stateless reset? (#2153)

From: Mike Bishop <[email-masked]>
Date: Fri, 28 Jun 2019 11:41:53 -0700

Does this require text?  The explanation of how it might not be deterministic (from the client's perspective) is already present in the preceding sections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2153#issuecomment-506838267

---

From: Martin Thomson <[email-masked]>
Date: Sun, 30 Jun 2019 17:12:06 -0700

I'm going to punt this back to a potential design issue, requiring of a consensus call.  Why?  Because I think that the right answer is to explicitly permit endpoints to discard packets that are too small.

I'm recommending removal of the deterministic text in the process, for the reasons implicit in Mike's comments.  The rest should sort itself.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2153#issuecomment-507078955

---

From: MikkelFJ <[email-masked]>
Date: Sun, 30 Jun 2019 21:25:27 -0700

>  Because I think that the right answer is to explicitly permit endpoints to discard packets that are too small.

Yes, but I still suggest it can respond on some safe random fraction of these.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2153#issuecomment-507110945