Subject: Re: [quicwg/base-drafts] MAX_PUSH_ID: lower-than-previous value conn error seems too severe (#2412)

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Jun 2019 09:26:09 -0700

Discussed in London; there's no reason to reduce in value on an ordered stream (which presumably has synchronized access already).  The proposal of HTTP_ERROR_YOU_ARE_AN_IDIOT was likely facetious, but PROTOCOL_VIOLATION serves the same purpose.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2412#issuecomment-498328607

---

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Jun 2019 16:26:25 +0000 (UTC)

Closed #2412.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2412#event-2385492506

---

From: MikkelFJ <[email-masked]>
Date: Mon, 03 Jun 2019 09:30:11 -0700

You mean HTTP_GENERAL_PROTOCOL_ERROR? I don't think it is appropriate to send QUIC transport errors for application protocol errors. Perhaps we need language for this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2412#issuecomment-498330021