Subject: Re: [quicwg/base-drafts] HTTP/3 TLV length description is no longer precise (#2429)

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Jun 2019 11:40:44 -0700

This may be OBE.  Looking at the current version, it says:

```
A frame includes the following fields:

  Type:
  : A variable-length integer that identifies the frame type.

  Length:
  : A variable-length integer that describes the length of the Frame Payload.

  Frame Payload:
  : A payload, the semantics of which are determined by the Type field.
```

This appears to be fairly precise -- the Length field describes the length of the Frame Payload, which is a specified region of the frame.  I'm not inclined to add further disclaimers around what "length" means unless others feel it's unclear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2429#issuecomment-498376555

---

From: Mike Bishop <[email-masked]>
Date: Mon, 03 Jun 2019 11:40:46 -0700

Closed #2429.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2429#event-2385845281