Subject: [quicwg/base-drafts] Compare H2 PROTOCOL_ERROR with HTTP_GENERAL_PROTOCOL_ERROR (#2808)

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 03:29:03 -0700

Fixes #2807 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2808

-- Commit Summary --

  * Compare H2 PROTOCOL_ERROR with HTTP_GENERAL_PROTOCOL_ERROR

-- File Changes --

    M draft-ietf-quic-http.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2808.patch
https://github.com/quicwg/base-drafts/pull/2808.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 19 Jun 2019 05:46:54 -0700

kazuho commented on this pull request.

> @@ -2174,8 +2174,7 @@ NO_ERROR (0x0):
 : HTTP_NO_ERROR in {{http-error-codes}}.
 
 PROTOCOL_ERROR (0x1):
-: No single mapping.  See new HTTP_MALFORMED_FRAME error codes defined in
-  {{http-error-codes}}.
+: HTTP_GENERAL_PROTOCOL ERROR in {{http-error-codes}}.

Isn't it still the case that we have multiple error codes that map to HTTP_GENERAL_PROTOCOL error in HTTP/2?

Or are we going to merge all the connection-level error codes that do not map to an error code in HTTP/2 (e.g., WRONG_STREAM, UNEXPECTED_FRAME, CLOSED_CRITICAL_STREAM) to HTTP_GENERAL_PROTOCOL?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#pullrequestreview-251672846

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 06:00:58 -0700

LPardue commented on this pull request.

 PROTOCOL_ERROR (0x1):

I don't follow sorry. This section states:

> QUIC has the same concepts of “stream” and “connection” errors that HTTP/2 provides. However, there is no direct portability of HTTP/2 error codes.

The change is intended to address how the HTTP/2 error code PROTOCOL_ERROR for HTTP/3 non-connection errors (usually frame errors) are expressed.

How would you suggest improving this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#discussion_r295283365

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 19 Jun 2019 06:13:41 -0700

PROTOCOL_ERROR (0x1):

Maybe I should have stated that the removal of "No single mapping." is concerning, because IIUC we do not have one-to-one mapping between PROTOCOL_ERROR (of HTTP/2) and HTTP_GENEAL_PROTOCOL error (of HTTP/3).

What I had in mind is something like "Split into a few error codes, including HTTP_GENERAL_PROTOCOL, HTTP_WRONG_STREAM, HTTP_UNEXPECTED_FRAME, HTTP_CLOSED_CRITICAL_STREAM."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#discussion_r295289124

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 06:20:16 -0700

PROTOCOL_ERROR (0x1):

Thanks, I agree and would like to adopt that text. The annoying thing is that it add more references to error codes I'm looking to consolidate but I can try to update the text to match the state of the draft as the PRs get merged.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#discussion_r295292255

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 06:23:50 -0700

@LPardue pushed 1 commit.

5cda29125e14df3ab2e258538200a7ed93fb3666  Add Kazuho suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808/files/b73798eab51fe085aece5cbe14b3f5f34552b7c8..5cda29125e14df3ab2e258538200a7ed93fb3666

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Jun 2019 10:31:51 -0700

MikeBishop commented on this pull request.

Rather than making everything have an even footing, I'd be more inclined to say that GPE is *the* equivalent error code, but point out that more specific error codes have also been added for cases that would have been PE in H2.

> @@ -2174,7 +2174,9 @@ NO_ERROR (0x0):
 
 PROTOCOL_ERROR (0x1):
-: No single mapping.  See new HTTP_MALFORMED_FRAME error codes defined in
+: No single mapping. Split into a few error codes, including

```suggestion
: No single mapping. Split into multiple error codes, including
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#pullrequestreview-251855029

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Jun 2019 16:12:57 -0700

martinthomson commented on this pull request.

 PROTOCOL_ERROR (0x1):

I would say that "This is mapped to HTTP_GENERAL_PROTOCOL_ERROR except in cases where more specific error codes have been defined.  This includes HTTP_MALFORMED_FRAME, ...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#discussion_r296951281

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 27 Jun 2019 03:08:46 -0700

a0879093fe8d21782f99a704d6740174d289f149  Apply MTs suggested wording

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808/files/5cda29125e14df3ab2e258538200a7ed93fb3666..a0879093fe8d21782f99a704d6740174d289f149

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 27 Jun 2019 03:09:22 -0700

PROTOCOL_ERROR (0x1):

thanks, I applied your suggestion @martinthomson 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#discussion_r298102988

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Jun 2019 14:35:42 -0700

Merged #2808 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2808#event-2445646317