Subject: [quicwg/base-drafts] transport: fix dangling ref to recovery (#2853)

From: Julian Reschke <[email-masked]>
Date: Wed, 26 Jun 2019 22:42:29 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2853

-- Commit Summary --

  * transport: fix dangling ref to recovery

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2853.patch
https://github.com/quicwg/base-drafts/pull/2853.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2853

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Jun 2019 23:00:00 -0700

martinthomson requested changes on this pull request.

> @@ -2924,7 +2924,7 @@ messages are delayed or lost.  Note that the same limitation applies to other
 data sent by the server protected by the 1-RTT keys.
 
 Endpoints SHOULD send acknowledgments for packets containing CRYPTO frames with
-a reduced delay; see Section 6.2.1 of {{QUIC-RECOVERY}}.
+a reduced delay; see Section 6.4 of {{QUIC-RECOVERY}}.

```suggestion
a reduced delay; see Section 6.2 of {{QUIC-RECOVERY}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2853#pullrequestreview-255019028

---

From: Julian Reschke <[email-masked]>
Date: Wed, 26 Jun 2019 23:07:37 -0700

reschke commented on this pull request.

No, I think the change is correct. See <https://tools.ietf.org/html/draft-ietf-quic-transport-20#section-13.1.2> and <https://tools.ietf.org/html/draft-ietf-quic-recovery-20#section-6.2.1>.

(FWIW, it would be good if these checks could be made part of the toolset used for the build)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2853#discussion_r298019209

---

From: Martin Thomson <[email-masked]>
Date: Thu, 27 Jun 2019 01:00:26 -0700

martinthomson commented on this pull request.

There are changes in the editor's drafts. [Section 6.2](https://quicwg.org/base-drafts/draft-ietf-quic-recovery.html#crypto-retransmission-timeout) deals with crypto timeout now.

I would love to have time to build a means of cross referencing when using markdown. It is just a frightening prospect. I find ruby and kramdown-rfc2629 both really difficult to work in. I haven't worked out how to do it architecturally, either. If you have any suggestions (other than using XML as the source format ...) I would be interested, though that might still be insufficient from a time perspective. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2853#discussion_r298051419