Subject: Re: [quicwg/base-drafts] Trigger unhappy (#2677)

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 19:42:36 -0700

Trigger is used in exactly two spots, where are both fixed in this PR. Unless we're sure what to do going forward, how about landing this and deciding how to better name this later?

Also, I'm not a big fan of trigger as a term.  Cause and send are both preferable options in my opinion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2677#issuecomment-500664993

---

From: MikkelFJ <[email-masked]>
Date: Tue, 11 Jun 2019 03:57:53 -0700

trigger -> instigate ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2677#issuecomment-500791742

---

From: ianswett <[email-masked]>
Date: Tue, 11 Jun 2019 07:15:07 -0700

If we want to be more correct going forward, I think HTTP should avoid talking about transport frames entirely.

Better would be "Close the connection with application error code FOO", etc.  Because we don't only mean "Send a connection close frame", we actually mean "Close the connection and as part of that, send a connection close frame."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2677#issuecomment-500860851

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Jun 2019 16:39:59 -0700

In principle, I like that:  Note the use of "abort the stream" instead of RESET_STREAM in most cases.  However, somewhere there has to be a mapping of those terms into what it means for the transport, just so everyone's clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2677#issuecomment-501063748