Subject: [quicwg/base-drafts] Suggest removal of HTTP_WRONG_SETTING_DIRECTION error (#2810)

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 03:37:38 -0700

HTTP_WRONG_SETTING_DIRECTION presently applies to exactly one case, a client that sends NUM_PLACEHOLDERS. Declassifying this as an error seems like a sensible option. This frees up error code 0x1, which we can move HTTP_GENERAL_PROTOCOL_ERROR to (making HTTP/3 more similar to HTTP/2).

My preference is to state that servers MUST ignore this value if present. I'll prepare a PR to that effect.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2810

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 05:17:44 -0700

I forgot to mention that @MikeBishop made an observation that SETTINGS errors are presently also covered by MALFORMED_FRAME, which is also on the chopping block.

An alternative solution is therefore to create an `INVALID_SETTINGS` that covers all the ways that a SETTINGS frames coudl go wrong.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2810#issuecomment-503536169

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 19 Jun 2019 05:22:27 -0700

Thank you for opening the issues.

While I agree that we do not need an error code specific to SETTINGS going in the wrong direction, I am not sure if declassifying it as an error is the right option. Not that I have a strong opinion, but IIRC our consensus is to be more strict against misbehaving peers in HTTP/3 compared to HTTP/2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2810#issuecomment-503537665

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 19 Jun 2019 05:32:26 -0700

Thanks @kazuho, after suggesting this I changed my mind. I made #2814 to implement the change as you and Mike suggest. The nice side effect is that it takes one step away from MALFORMED_FRAME.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2810#issuecomment-503540695

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Jun 2019 14:43:55 -0700

Closed #2810 via #2814.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2810#event-2445662392