Subject: [quicwg/base-drafts] Bring back the Exclusive Flag (#2781)

From: Kazuho Oku <[email-masked]>
Date: Mon, 10 Jun 2019 20:31:19 -0700

Limits the PRIORITY frame to be only sent on the control stream, and brings back the Exclusive Flag.

Closes #2754.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2781

-- Commit Summary --

  * PRIORITY frame only on the control stream
  * exclusive bit
  * introduce "Exclusive Flag", incorporating text from RFC 7540

-- File Changes --

    M draft-ietf-quic-http.md (56)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2781.patch
https://github.com/quicwg/base-drafts/pull/2781.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Jun 2019 15:28:37 -0700

MikeBishop commented on this pull request.

Minor things; overall, looks good!

> @@ -620,9 +625,8 @@ When a prioritized element is first created, it has a default initial weight of
 orphan placeholder; pushes are dependent on the client request on which the
 PUSH_PROMISE frame was sent.
 
-Requests may override the default initial values by including a PRIORITY frame
-(see {{frame-priority}}) at the beginning of the stream. These priorities
-can be updated by sending a PRIORITY frame on the control stream.
+Requests may override the default initial values by sending a PRIORITY frame

Including it at stream creation is overriding the default priority.  I think I'd just call this "update" and say that everything has default priority when it's first created.

```suggestion
Priorities can be updated by sending a PRIORITY frame
```
\+ reflow

> @@ -1192,7 +1191,6 @@ of the associated Element ID fields.
 | 00      | Request stream   | Stream ID                       |
 | 01      | Push stream      | Push ID                         |
 | 10      | Placeholder      | Placeholder ID                  |
-| 11      | Current stream   | Absent                          |

Since the value of `11` was the only difference between these, we could re-combine them to a single table and simply say that prioritizing Root is invalid.  (Which you already have on line 1213.)

> @@ -1984,10 +1977,9 @@ commutative, both sender and receiver must apply them in the same order to
 ensure that both sides have a consistent view of the stream dependency tree.
 HTTP/2 specifies priority assignments in PRIORITY frames and (optionally) in
 HEADERS frames. To achieve in-order delivery of priority changes in HTTP/3,
-PRIORITY frames are sent as the first frame on a request stream or on the
-control stream and exclusive prioritization has been removed. HTTP/3 permits the
+PRIORITY frames are sent or on the control stream.  HTTP/3 permits the

```suggestion
PRIORITY frames are sent on the control stream.  HTTP/3 permits the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#pullrequestreview-248467903

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Jun 2019 15:41:06 -0700

@MikeBishop pushed 1 commit.

07749b54c469ce60cb767ff8676e999f5b8c6ecf  Merge remote-tracking branch 'origin/master' into kazuho-kazuho/reintroduce-exclusive-bit

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781/files/8a1417585c07c2aeaf38fb0743e7e3ba06440ddf..07749b54c469ce60cb767ff8676e999f5b8c6ecf

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Jun 2019 17:50:25 -0700

@kazuho pushed 1 commit.

c7e93859b7352307f890f5733f5002e3f7cef4d4  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781/files/07749b54c469ce60cb767ff8676e999f5b8c6ecf..c7e93859b7352307f890f5733f5002e3f7cef4d4

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Jun 2019 17:52:26 -0700

@kazuho pushed 1 commit.

6c417fe7aef8355fa1f592c06ed944d0a789c8d4  word wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781/files/c7e93859b7352307f890f5733f5002e3f7cef4d4..6c417fe7aef8355fa1f592c06ed944d0a789c8d4

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Jun 2019 18:05:22 -0700

@kazuho pushed 1 commit.

5cca97bb1ef93e8b4fb771bff435716d7cf7dd27  merge two element types

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781/files/6c417fe7aef8355fa1f592c06ed944d0a789c8d4..5cca97bb1ef93e8b4fb771bff435716d7cf7dd27

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Jun 2019 18:05:50 -0700

kazuho commented on this pull request.

That's a nice simplification! Done in 5cca97b.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#discussion_r292714092

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Jun 2019 11:26:29 -0700

> @@ -1155,22 +1151,25 @@ The PRIORITY frame payload has the following fields:
 
   PT (Prioritized Element Type):
   : A two-bit field indicating the type of element being prioritized (see
-    {{prioritized-element-types}}). When sent on a request stream, this MUST be
-    set to `11`.  When sent on the control stream, this MUST NOT be set to `11`.

We probably want to retain the "MUST NOT be set to `11` here, even if we call it out as an error later.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#pullrequestreview-248940127

---

From: ianswett <[email-masked]>
Date: Wed, 12 Jun 2019 14:02:48 -0700

ianswett approved this pull request.

Thanks, this LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#pullrequestreview-249017002

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 12 Jun 2019 14:14:39 -0700

@kazuho pushed 1 commit.

0fd27179d0dc3e4e4eb557efc650a22d162491ac  PT MUST NOT be sent to 11

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781/files/5cca97bb1ef93e8b4fb771bff435716d7cf7dd27..0fd27179d0dc3e4e4eb557efc650a22d162491ac

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 12 Jun 2019 14:15:38 -0700

Makes sense. Done in 0fd27179.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#discussion_r293121258

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Jun 2019 14:23:39 -0700

Merged #2781 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2781#event-2408760497