Subject: [quicwg/base-drafts] Remove QPACK settings maxima as useless (#2766)

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 04 Jun 2019 05:19:40 -0700

Both [QPACK settings](https://tools.ietf.org/html/draft-ietf-quic-qpack-08#section-5) specify the maximum value the decoder supports.  The encoder is free to pick and use a smaller value.  There is no reason to add artificial limits to the way an encoder is implemented.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2766

---

From: Mike Bishop <[email-masked]>
Date: Tue, 04 Jun 2019 15:06:02 -0700

This could be viewed as an alternative resolution to #2498.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2766#issuecomment-498861101

---

From: Mike Bishop <[email-masked]>
Date: Tue, 04 Jun 2019 15:16:50 -0700

Also, historical note:  These have maxima because settings used to be length-prefixed blobs.  By defining them to be integers of a maximum size, the length could be constrained.  Now that we use varints, there is a maximum structural size already.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2766#issuecomment-498863854

---

From: afrind <[email-masked]>
Date: Tue, 04 Jun 2019 15:17:22 -0700

Closed #2766 via #2767.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2766#event-2389612662