Subject: Re: [quicwg/base-drafts] Specify HEADERS on control stream error. (#2708)

From: Daan De Meyer <[email-masked]>
Date: Sun, 09 Jun 2019 09:04:53 -0700

@MikeBishop #2678 was closed. Is there anything else that's blocking this pr from being merged?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#issuecomment-500224652

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 09 Jun 2019 14:24:12 -0700

kazuho commented on this pull request.

> @@ -1076,7 +1076,9 @@ QPACK. See [QPACK] for more details.
 ~~~~~~~~~~
 {: #fig-headers title="HEADERS frame payload"}
 
-HEADERS frames can only be sent on request / push streams.
+HEADERS frames can only be sent on request / push streams.  If a HEADERS frame
+is received on either control stream, the recipient MUST respond with a

Maybe "on _a_ control stream"? I think that we do not normally talk about two control streams (in each direction) differently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#pullrequestreview-247415492

---

From: Daan De Meyer <[email-masked]>
Date: Sun, 09 Jun 2019 15:35:05 -0700

DaanDeMeyer commented on this pull request.

 ~~~~~~~~~~

Wouldn't `on the control stream` be better then? As far as I'm aware we still have only one of those.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#discussion_r291853050

---

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 11:57:08 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#pullrequestreview-247784988

---

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 11:57:46 -0700

@DaanDeMeyer I added @MikeBishop so he can review and merge this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#issuecomment-500546969

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Jun 2019 10:49:45 -0700

Merged #2708 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2708#event-2404994523