Subject: [quicwg/base-drafts] Refactor Push ID related errors (#2820)

From: Lucas Pardue <[email-masked]>
Date: Thu, 20 Jun 2019 08:26:47 -0700

Implements suggestions from #2818 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2820

-- Commit Summary --

  * Refactor Push ID related errors

-- File Changes --

    M draft-ietf-quic-http.md (24)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2820.patch
https://github.com/quicwg/base-drafts/pull/2820.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 21 Jun 2019 02:50:17 -0700

@LPardue pushed 1 commit.

a58ac71fa0d68e7faf137afa6ce78217339da8bb  Replace HTTP_LIMIT_EXCEEDED with HTTP_ID_ERROR

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820/files/f8c9a13137924d56ab4636d307ebf2274568d0b9..a58ac71fa0d68e7faf137afa6ce78217339da8bb

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 21 Jun 2019 02:51:01 -0700

Updated to replace HTTP_LIMIT_EXCEEDED and HTTP_PUSH_ID_ERROR with the single error HTTP_ID_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820#issuecomment-504366418

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 23 Jun 2019 21:01:43 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820#pullrequestreview-253191500

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Jun 2019 10:09:42 -0700

MikeBishop approved this pull request.

> @@ -1630,12 +1633,12 @@ HTTP_VERSION_FALLBACK (0x09):
 HTTP_WRONG_STREAM (0x0A):
 : A frame was received on a stream where it is not permitted.
 
-HTTP_LIMIT_EXCEEDED (0x0B):
-: A Stream ID, Push ID, or Placeholder ID greater than the current maximum for
-  that identifier was referenced.
+HTTP_ID_ERROR (0x0B):
+: A Stream ID, Push ID, or Placeholder ID was used incorrectly, such as
+  exceeding a limit, reducing a limit or being reused.

```suggestion
  exceeding a limit, reducing a limit, or being reused.
```

> @@ -1912,8 +1915,8 @@ The entries in the following table are registered by this document.
 | HTTP_EXCESSIVE_LOAD                 | 0x0008     | Peer generating excessive load           | {{http-error-codes}}   |
 | HTTP_VERSION_FALLBACK               | 0x0009     | Retry over HTTP/1.1                      | {{http-error-codes}}   |
 | HTTP_WRONG_STREAM                   | 0x000A     | A frame was sent on the wrong stream     | {{http-error-codes}}   |
-| HTTP_LIMIT_EXCEEDED                 | 0x000B     | An identifier limit was exceeded         | {{http-error-codes}}   |
-| HTTP_DUPLICATE_PUSH                 | 0x000C     | Push ID was fulfilled multiple times     | {{http-error-codes}}   |
+| HTTP_ID_ERROR                       | 0x000B     | An identifier used incorrectly           | {{http-error-codes}}   |

```suggestion
| HTTP_ID_ERROR                       | 0x000B     | An identifier was used incorrectly       | {{http-error-codes}}   |
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820#pullrequestreview-253543250

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 24 Jun 2019 10:50:35 -0700

646a60d93da36c688a0fb39261a1c7271e78a3a9  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820/files/a58ac71fa0d68e7faf137afa6ce78217339da8bb..646a60d93da36c688a0fb39261a1c7271e78a3a9

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Jun 2019 14:44:36 -0700

Merged #2820 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2820#event-2445664145