Subject: [quicwg/base-drafts] Use a higher seed RTT for new paths (#2789)

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Jun 2019 14:37:40 -0700

@gorryfair mentions on list:

>>   A connection MAY use the delay between sending a PATH_CHALLENGE and 
receiving a PATH_RESPONSE to seed initial_rtt for a new path, but the delay 
SHOULD NOT be considered an RTT sample.
>
> .... Maybe I am wrong, but I interpret RFC6298 as saying the seed value 
should be 1.5 x larger than this RTT value?
>
> (To account for RTT variance.)

I don't quite get the same reading from 6258 (the 0.5 seems to come from setting RTTVAR on the first sample, but that isn't fed into SRTT anywhere...), but this seems like a good idea, if only out of caution.  The new path might be longer.  But it's hard to say by how much.  Some hedging seems wise.  

The first RTT measurement will erase this, so it will only govern behaviour on unresponsive paths.  So it's probably not critical.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2789

---

From: Rui Paulo <[email-masked]>
Date: Fri, 14 Jun 2019 17:26:38 -0700

I also don't see where RFC6298 specifies 1.5x.  Can you clarify @gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2789#issuecomment-502317739

---

From: ianswett <[email-masked]>
Date: Mon, 17 Jun 2019 09:16:02 -0700

I reread 6298 and I also can't find the 1.5 text.  Can you point out which text you have in mind?

The goal is not to base the new path's congestion control properties on the previous path, but if there was a PATH_CHALLENGE/RESPONSE before migrating, then it's ok to use that to seed the initial_rtt.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2789#issuecomment-502751153