Subject: [quicwg/base-drafts] Does rejecting 0-RTT data prohibit ACKing 0-RTT data? (#2840)

From: Ryan Hamilton <[email-masked]>
Date: Mon, 24 Jun 2019 15:42:36 -0700

4.6 Of the TLS doc says:

   A server rejects 0-RTT by rejecting 0-RTT at the TLS layer.  This
   also prevents QUIC from sending 0-RTT data.

However, this doesn't explicitly say that it prevents QUIC from **receiving** 0-RTT data. I suspect this is implied, but it might be worth clarifying. 

I could imagine a server rejecting 0-RTT data, but attempting to ACK the client's 0-RTT packets in order to deliver a congestion signal to the client. I think this would be a rather terrible idea, so it would be nice to explicitly prohibit it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840

---

From: ianswett <[email-masked]>
Date: Mon, 24 Jun 2019 16:00:51 -0700

Throughout transport, there is the idea that you MUST not acknowledge packets you can't fully process, so this should be against the spec.  But it may be worth noting explicitly, probably in transport.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840#issuecomment-505212604

---

From: Ryan Hamilton <[email-masked]>
Date: Mon, 24 Jun 2019 16:02:34 -0700

Doing it in transport would make sense. Or perhaps in TLS by noting that if 0-RTT is rejected, 0-RTT keys must not be generated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840#issuecomment-505212986

---

From: Marten Seemann <[email-masked]>
Date: Mon, 24 Jun 2019 16:34:03 -0700

@RyanAtGoogle I just added text about that to my PR that's targeting #2829.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840#issuecomment-505219867

---

From: ianswett <[email-masked]>
Date: Mon, 24 Jun 2019 17:00:29 -0700

SG @marten-seemann  If so, can you update the CL description to indicate what issues it closes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840#issuecomment-505224924

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 18:07:06 -0700

I'm going so recommend that this be triaged as a design issue, even if it might seem trivial.  The prohibition in #2829 is the right response.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2840#issuecomment-505677088