Subject: [quicwg/base-drafts] clarify why the client MUST NOT reset the packet number after a Retry (#2831)

From: Marten Seemann <[email-masked]>
Date: Sun, 23 Jun 2019 00:23:32 -0700

As of #2746, the client MUST use the same handshake message.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2831

-- Commit Summary --

  * clarify why the client MUST NOT reset the packet number after a Retry

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2831.patch
https://github.com/quicwg/base-drafts/pull/2831.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831

---

From: Marten Seemann <[email-masked]>
Date: Sun, 23 Jun 2019 00:33:45 -0700

@marten-seemann pushed 1 commit.

11eca04ecf0524b488bb3bdfc159ff268d60571a  remove conflicting paragraph

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831/files/a3f3471aa65ca6d9890c462625f843686d3a9d7c..11eca04ecf0524b488bb3bdfc159ff268d60571a

---

From: ianswett <[email-masked]>
Date: Sun, 23 Jun 2019 06:47:13 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#pullrequestreview-253133658

---

From: Nick Banks <[email-masked]>
Date: Sun, 23 Jun 2019 08:23:43 -0700

nibanks approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#pullrequestreview-253137637

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 23 Jun 2019 21:16:05 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#pullrequestreview-253193527

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Jun 2019 09:52:38 -0700

MikeBishop commented on this pull request.

So, the effect of not changing the handshake message is that all previously-sent 0-RTT data is still valid, but has potentially been lost rather than queued.  Clients obviously MUST NOT reuse the packet number for different data, but in their not-resetting, they also can't change the data that they've already sent in those packets.

They'll need to retransmit it, because otherwise there's a potential DoS attack by delaying/replaying a 0-RTT packet by one RTT against a server that does Retries.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#pullrequestreview-253535028

---

From: Marten Seemann <[email-masked]>
Date: Mon, 24 Jun 2019 16:48:54 -0700

@MikeBishop That's quite complicated, and I'm not sure if we've chosen the right design here.
I'd like to keep this PR editorial though. I opened #2842 to discuss this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#issuecomment-505222799

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 24 Jun 2019 23:30:13 -0700

This PR looks good to me as an editorial improvement.

Regarding @MikeBishop's point, the transport draft explicitly states that a server sending a Retry can buffer 0-RTT packets that carried the original DCID, and process them after receiving a response to the Retry. To put it differently, I think we are clear on the semantics and that there are ways to implement this without having security concerns.

That said, I understand that @marten-seemann has opened a design issue (#2842) to discuss if that is the design we want to have.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#pullrequestreview-253793348

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Jun 2019 15:12:28 -0700

Merged #2831 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2831#event-2439088335