Subject: Re: [quicwg/base-drafts] Orphan Placeholder (#2690)

From: ianswett <[email-masked]>
Date: Mon, 03 Jun 2019 15:06:58 +0000 (UTC)

To clarify @kazuho, by 'this' do you mean the orphan placeholder, weight=0, or both?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2690#issuecomment-498296500

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 03 Jun 2019 20:04:51 -0700

@ianswett 
> To clarify @kazuho, by 'this' do you mean the orphan placeholder, weight=0, or both?

We've implemented the orphan placeholder (i.e. what the PR now suggests). Weight=0 no longer used in the text proposed by this PR.

FWIW, our HTTP/3 implementation with support for prioritization can be found at https://github.com/h2o/h2o/pull/1846 (specifically lib/http3/server.c deals with the prioritization tree, while lib/http2/scheduler.c is the scheduler itself), the most relevant commits related to orphan placeholder being e117fe9, 1280409, d8b187d.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2690#issuecomment-498501401

---

From: Mike Bishop <[email-masked]>
Date: Fri, 07 Jun 2019 14:19:30 -0700

Merged #2690 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2690#event-2398437025

---

From: ianswett <[email-masked]>
Date: Mon, 10 Jun 2019 10:55:00 -0700

Thanks for trying to move us back to a more H2-like prioritization scheme, but for some reason I was under the impression we were going to allow weights of 0 rather than creating an orphan placeholder, which seems like an entirely new concept and also makes H3 priorities subtly different from H2 priorities in a new way?

Admittedly, I can implement my priorities using the weight of 0 concept anyway, since the orphan placeholder is a completely theoretic construct which cannot be referenced by a client, but it's also a non-obvious construct to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2690#issuecomment-500515481