Subject: [quicwg/base-drafts] Coordinating spin (#2763)

From: Martin Thomson <[email-masked]>
Date: Sun, 02 Jun 2019 17:28:29 -0700

When multiple connections share the same network path or multiple connection IDs are used for the same path, using the spin bit is complicated by the difficulty in correlating forward and reverse flows.  There is currently text that uses RFC 6919 language in the draft recommending coordination of the spin to avoid this problem.

However, as [some have observed](https://github.com/quicwg/base-drafts/pull/2751#pullrequestreview-244603953), this coordination seems difficult and therefore unlikely.  It also creates a strong signal that indicates that all the connections on the path are terminated at the same endpoint on both ends.  Maybe we don't want to be generating that signal.

Also, because this coordination can't be guaranteed, the on-path observer is forced to build code for correlating/segregating measurements by connection ID in the case where there is no coordination.

Maybe it's best just to remove this recommendation entirely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2763

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 02 Jun 2019 18:47:40 -0700

+1 to removing the recommendation, or changing the statement to just a caution (e.g., if you are to coalesce connections that spin, then you'd better be aware of ...).

> It also creates a strong signal that indicates that all the connections on the path are terminated at the same endpoint on both ends.

FWIW I am not sure if I agree with this observation. IIUC, the connections sharing a 5-tuple will be terminated by the same endpoint on both ends; it is impossible for a middlebox to coalesce multiple QUIC connections. It is impossible because CIDs can change mid-connection, and a middlebox cannot determine to where the packets containing the new CID must be sent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2763#issuecomment-498087012

---

From: Martin Thomson <[email-masked]>
Date: Sun, 02 Jun 2019 18:54:50 -0700

There definitely needs to be a degree of coordination between the middlebox and the endpoints, but that doesn't mean that you can't use something like the quic-lb stuff on either end (or both ends).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2763#issuecomment-498087929

---

From: MikkelFJ <[email-masked]>
Date: Sun, 02 Jun 2019 23:08:58 -0700

Yes, I think it is better to remove that recommendation, but perhaps replace it with a note to observers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2763#issuecomment-498124982