Subject: [quicwg/base-drafts] Move Generating Acknowledgements to Transport (#2916)

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 06:58:31 -0700

Fixes #1860 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2916

-- Commit Summary --

  * Move Generating Acknowledgements to Transport

-- File Changes --

    M draft-ietf-quic-recovery.md (79)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2916.patch
https://github.com/quicwg/base-drafts/pull/2916.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 07:08:20 -0700

@ianswett pushed 1 commit.

a45e31e754c9289863fc82c4a52912b45a96c4a7  Move, don't just remove the text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/5c034934cd8fc64640112f90ffa115e58408277e..a45e31e754c9289863fc82c4a52912b45a96c4a7

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 07:13:46 -0700

483d20c66ef39e058d5280b9ccc00cb0bcc5c8de  Remove the "Crypto Handshake Data" section

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/a45e31e754c9289863fc82c4a52912b45a96c4a7..483d20c66ef39e058d5280b9ccc00cb0bcc5c8de

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 07:45:10 -0700

7f3f3494e6ff9f28818b1dbf0b23087a948eeb7a  Stop referencing QUIC Transport

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/483d20c66ef39e058d5280b9ccc00cb0bcc5c8de..7f3f3494e6ff9f28818b1dbf0b23087a948eeb7a

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 07:52:17 -0700

33f491c033d84b9e536fd4133e4899cc41a6fd60  Remove obsolete text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/7f3f3494e6ff9f28818b1dbf0b23087a948eeb7a..33f491c033d84b9e536fd4133e4899cc41a6fd60

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 08:04:34 -0700

550fe927af57e81eaeefac9da4da6be154161952  Stop referencing host-delay in Recovery

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/33f491c033d84b9e536fd4133e4899cc41a6fd60..550fe927af57e81eaeefac9da4da6be154161952

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 08:28:06 -0700

b1cd751bf703af2bc1fc2e0efec54dc83d10101a  Fix CircleCI (hopefully)

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/550fe927af57e81eaeefac9da4da6be154161952..b1cd751bf703af2bc1fc2e0efec54dc83d10101a

---

From: Nick Banks <[email-masked]>
Date: Sun, 21 Jul 2019 10:43:37 -0700

nibanks approved this pull request.

> @@ -2880,6 +2880,28 @@ packet.
 expectations about what implementations do with packets that have errors after
 valid frames? -->
 
+
+## Generating Acknowledgements {#generating-acks}
+
+An acknowledgement SHOULD be sent immediately upon receipt of a second
+ack-eliciting packet. QUIC recovery algorithms do not assume the peer sends
+an ACK immediately when receiving a second ack-eliciting packet.
+
+In order to accelerate loss recovery and reduce timeouts, the receiver SHOULD
+send an immediate ACK after it receives an out-of-order packet. It could send

What's the exact definition for `out-of-order`? If the last packet number received is `X`, are received packet numbers of `X+2` and `X-1` both considered out of order?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916#pullrequestreview-264547221

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 12:06:55 -0700

ianswett commented on this pull request.

+

Yes, both would be considered out of order.  I thought we already said to send an immediate ACK when the PN is not 1 larger than the largest processed packet number, but I can't find it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916#discussion_r305631524

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 12:13:41 -0700

34f06f467b1e4aee411948339734d339846da4c9  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2916/files/b1cd751bf703af2bc1fc2e0efec54dc83d10101a..34f06f467b1e4aee411948339734d339846da4c9