Subject: [quicwg/base-drafts] Non-ACK-eliciting packets never need to be ACKed (#2931)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 26 Jul 2019 13:50:23 -0700

By definition, non-ACK-eliciting packets never need to be ACKed.  Verbiage introduced in PR #2794 states:

> When only non-ACK-eliciting packets need to be acknowledged, ...

I am not sure what the intended meaning was.  Perhaps what was meant is "when only non-ACK-eliciting packets have not been acked,..."  We could try to find a more graceful way to phrase it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2931

---

From: MikkelFJ <[email-masked]>
Date: Fri, 26 Jul 2019 15:18:36 -0700

Non-ack-eliciting packets do need to be ack'ed, they just don't trigger the process.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2931#issuecomment-515615954

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 29 Jul 2019 05:51:09 -0700

OK -- closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2931#issuecomment-515978031

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 29 Jul 2019 05:51:10 -0700

Closed #2931.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2931#event-2516379638