Subject: [quicwg/base-drafts] QPACK [design] Decoder MUST emit Header Acknowledgement. (#2939)

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:03:22 -0700

Add MUST to sentence about requirement on decoder to emit a Header Acknowledgement instruction every time it decodes a header block with non-zero Required Insert Count.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2939

-- Commit Summary --

  * MUST emit Header Acknowledgement

-- File Changes --

    M draft-ietf-quic-qpack.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2939.patch
https://github.com/quicwg/base-drafts/pull/2939.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2019 15:12:31 -0700

martinthomson commented on this pull request.

This doesn't allow for a delay in sending an ack. That delay might be useful in reducing overheads. That might be a new issue though. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939#pullrequestreview-269310483

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 17:00:40 -0700

> This doesn't allow for a delay in sending an ack. That delay might be useful in reducing overheads. That might be a new issue though.

That's a good point, I haven't thought about it.  Would changing "When the decoder finishes decoding..." to "After the decoder finishes decoding..." be sufficient to allow for delayed ACKs?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939#issuecomment-517065949

---

From: Martin Thomson <[email-masked]>
Date: Wed, 31 Jul 2019 17:02:59 -0700

Works for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939#issuecomment-517066431

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 17:09:07 -0700

@bencebeky pushed 1 commit.

a0ca80b795fda219962c8c4fb428c14fd7cc2c4d  Change "when" to "after" to allow for delayed acknowledgements that might reduce overheads.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939/files/16ea45bf47318a229fc48f3d4f6969422e4fb52c..a0ca80b795fda219962c8c4fb428c14fd7cc2c4d

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 17:10:33 -0700

> Works for me.

Done.  Thanks for raising this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2939#issuecomment-517067907