Subject: [quicwg/base-drafts] QPACK [editorial] Update text on instructions and representations. (#2941)

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:37:22 -0700

* Use more uniform and more specific language in description of instructions, like "follows" instead of 
  "includes" or implicit mention of a field.
* Add references to integer and string encodings where missing.
* Prefer internal references to external ones (also in Section 1.2).
* Explicitly allow a header block to not have any instructions after the mandatory prefix.
* Refer to Literal Header Field With Name Reference section in Literal Header Field Without Name Reference instead of verbatim repeating text on 'N' bit.
* Reshuffle sentences, insert references instead, remove sentences where references suffice.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2941

-- Commit Summary --

  * clarify wire format

-- File Changes --

    M draft-ietf-quic-qpack.md (134)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2941.patch
https://github.com/quicwg/base-drafts/pull/2941.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2941

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:40:56 -0700

bencebeky commented on this pull request.

> @@ -798,13 +804,14 @@ as a 6-bit prefix integer.  See {{state-synchronization}}.
 
 ### Insert Count Increment
 
-The Insert Count Increment instruction begins with the '00' two-bit pattern.
-The instruction specifies the total number of dynamic table inserts and
-duplications since the last Insert Count Increment or Header Acknowledgement
-that increased the Known Received Count for the dynamic table (see
-{{known-received-count}}).  The Increment field is encoded as a 6-bit prefix
-integer. The encoder uses this value to determine which table entries might
-cause a stream to become blocked, as described in {{state-synchronization}}.
+The Insert Count Increment instruction begins with the '00' two-bit pattern,
+followed by the Increment encoded as a 6-bit prefix integer.  The value of the
+Increment is the total number of dynamic table insertions and duplications
+processed by the decoder since the last time it sent a Header Acknowledgement
+instruction that increased the Known Received Count (see

I'm swapping Header Acknowledgement and Insert Count Instruction to avoid the possibility that somebody get the impression that an Insert Count Increment might not increase the Known Received Count.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2941#pullrequestreview-269141914

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:42:43 -0700

> @@ -821,10 +828,13 @@ connection error of type `HTTP_QPACK_DECODER_STREAM_ERROR`.
 
 ## Header Block Representations
 
-Header blocks contain compressed representations of header lists and are carried

Representations of header lists?  Representations of header fields?  Also, plural hides that blocks and lists have a one-to-one correspondance.  These are my motivations to reword.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2941#pullrequestreview-269142869

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:43:38 -0700

>  The following bit, 'N', indicates whether an intermediary is permitted to add
 this header to the dynamic header table on subsequent hops. When the 'N' bit is
-set, the encoded header MUST always be encoded with a literal representation. In
-particular, when a peer sends a header field that it received represented as a

I do not see any clarity or value that the "In particular.." sentence adds, it just rewords the previous sentence.  I propose to remove it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2941#pullrequestreview-269143348

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:44:55 -0700

@bencebeky pushed 1 commit.

96df67439cf7ee1ad993f7a59d44c73f04992fd5  nits

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2941/files/ec8e7252dabf6c58b3b252afc9faa49c3ad4b5f4..96df67439cf7ee1ad993f7a59d44c73f04992fd5