Subject: [quicwg/base-drafts] Articulate error code principles (#2880)

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jul 2019 00:06:13 -0700

This just writes down what was proposed in #2388.

Closes #2388.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2880

-- Commit Summary --

  * Articulate error code principles

-- File Changes --

    M draft-ietf-quic-transport.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2880.patch
https://github.com/quicwg/base-drafts/pull/2880.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 09 Jul 2019 00:10:20 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#pullrequestreview-259305481

---

From: MikkelFJ <[email-masked]>
Date: Tue, 09 Jul 2019 01:44:30 -0700

Looks fine, but what about some guidance on stream vs connection errors? And also the principle of nearly always choosing a hard protocol violation error, or a more granular error with same effect?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509550574

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jul 2019 02:48:51 -0700

Stream vs. connection is something that application protocols (like HTTP) need to worry about.  The transport only concerns itself with connection errors.  The idea that you pick the most helpful error is not something that we need to codify (in my view).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509574253

---

From: MikkelFJ <[email-masked]>
Date: Tue, 09 Jul 2019 02:58:10 -0700

> Stream vs. connection is something that application protocols (like HTTP) need to worry about. 

Isn't that worth mentioning? Or do we already have such text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509577457

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 09 Jul 2019 03:01:21 -0700

> Isn't that worth mentioning? Or do we already have such text?

This is already discussed in Section 11, which makes me wonder if it would make more sense for text on this PR to be placed there too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509578537

---

From: MikkelFJ <[email-masked]>
Date: Tue, 09 Jul 2019 03:08:39 -0700

>  The idea that you pick the most helpful error is not something that we need to codify (in my view).

This I do not disagree with. I was merely suggesting that we explain why, as a general rule, a hard error is preferred as a design principle, not the nature of the error message which I do think should have a large degree of freedom.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509580881

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jul 2019 03:18:09 -0700

Maybe there is a followup needed for the HTTP draft.  If the principles are generally the same, we can copy the text and then add some more to cover the idea that we make most errors fatal to the connection rather than the stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509583920

---

From: ianswett <[email-masked]>
Date: Tue, 09 Jul 2019 07:10:43 -0700

I like Lucas suggestion of adding this text to the existing and already fairly complete text in section 11.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509658584

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jul 2019 23:47:22 -0700

@martinthomson pushed 1 commit.

9dbc2aa4c69a8cf5f9992cf9721edb88cd8a3575  Move some text up

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880/files/a0c255791a5bf269fc46501fd5daf9ab4e362cf9..9dbc2aa4c69a8cf5f9992cf9721edb88cd8a3575

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jul 2019 23:47:39 -0700

I moved the second paragraph up to the error handling section, but the text about how codes are selected really belongs with the codes themselves.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#issuecomment-509932374

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 09 Jul 2019 23:51:35 -0700

LPardue approved this pull request.

> @@ -5374,6 +5379,14 @@ CRYPTO_ERROR (0x1XX):
 
 See {{iana-error-codes}} for details of registering new error codes.
 
+In defining these error codes, several principles are applied.  Error conditions
+that might require specific action on the part of a recipient are giving unique

s/giving/given

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#pullrequestreview-259898405

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jul 2019 00:04:06 -0700

d69838e12322f1ec87e2fa220bfe6ae4ed97bbd9  Giving Lucas credit for a suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880/files/9dbc2aa4c69a8cf5f9992cf9721edb88cd8a3575..d69838e12322f1ec87e2fa220bfe6ae4ed97bbd9

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jul 2019 07:05:02 +0000 (UTC)

martinthomson commented on this pull request.

 

I'm almost surprised that I can update your comment, turn it into a suggestion, then cause a commit to be created under your name.  The power is going to my head...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#discussion_r301912674

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 10 Jul 2019 00:14:12 -0700

LPardue commented on this pull request.

 

I'd have made the suggestion myself but I'm on a mobile device that hides that widget. Good to know we have a workflow that makes my life easier ;)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#discussion_r301915378

---

From: ianswett <[email-masked]>
Date: Wed, 10 Jul 2019 08:18:01 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#pullrequestreview-260169088

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Jul 2019 08:46:06 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2880#pullrequestreview-265504886