Subject: [quicwg/base-drafts] Appendix A of quic-tls is wrong (#2885)

From: martinduke <[email-masked]>
Date: Tue, 09 Jul 2019 09:35:49 -0700

The initial salt changed in draft-21, but there is no change to the example initial keys.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2885

---

From: Martin Thomson <[email-masked]>
Date: Wed, 10 Jul 2019 00:08:17 -0700

Yes, we also didn't update the examples to include the new invariants.  Oh well.  There's updated test vectors in #2887, but those are for -23.  If you want test vectors for -22, you can tweak the version and salt in the .js file in the repo and run that.  If that doesn't work, let me know and we can work out what is wrong.

For now, I just have to humbly apologize again for the mess that I made of all these drafts this time around.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2885#issuecomment-509938177