Subject: [quicwg/base-drafts] Crypto Retransmission Timeout interacts poorly with Congestion Control (#2886)

From: Marten Seemann <[email-masked]>
Date: Tue, 09 Jul 2019 10:20:44 -0700

The crypto retransmission timeout works similar to the PTO timeout. On each timer expiration, you are supposed to send some data, and do an exponential backoff.
However, there's an important difference: PTO packets are not blocked by the congestion controller, whereas crypto retransmissions are. 

This can lead to a deadlock: Consider the case where the CFIN is lost, and the client sends all the available window of application data. When the crypto retransmission timer fires, the client would be supposed to retransmit the CFIN, but the congestion controller will not allow that. Furthermore, since the CFIN was lost, the server won't be able to read any of the 1-RTT packets, so cwnd will never be cleared.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2886

---

From: ianswett <[email-masked]>
Date: Tue, 09 Jul 2019 13:45:48 -0700

It was not intended for crypto timeout retransmissions to be blocked by the congestion controller.

Does PR# 2806 fix this by merging them?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2886#issuecomment-509800585

---

From: ianswett <[email-masked]>
Date: Mon, 15 Jul 2019 20:00:12 -0700

Closed #2886 via #2806.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2886#event-2484757640