Subject: [quicwg/base-drafts] Omission of DCIL change in draft-ietf-quic-transport-22? (#2932)

From: evagld <[email-masked]>
Date: Tue, 30 Jul 2019 02:36:07 -0700

I'm currently working on an implementation of the protocol and have juste realized the changes in the last draft of RFC about the DCIL and SCIL. 
Reading the changes, I noticed that the DCID Len didn't change in the draft, opposed to the SCID Len, which doesn't seem rigth :
 "_DCID Len: The byte following the version contains the lengths of the two connection ID fields that follow it. These lengths are encoded as two 4-bit unsigned integers. The Destination
 Connection ID Length (DCIL) field occupies the 4 high bits of the byte and the Source Connection ID Length (SCIL) field occupies the 4 low bits of the byte. An encoded length of 0 indicates that the connection ID is also 0 bytes in length. Non-zero encoded lengths
 are increased by 3 to get the full length of the connection ID, producing a length between 4 and 18 bytes inclusive. For example,  a byte with the value 0x50 describes an 8-byte Destination
 Connection ID and a zero-length Source Connection ID_."
Is it an omission of change or have I missed something?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2932

---

From: evagld <[email-masked]>
Date: Tue, 30 Jul 2019 02:42:37 -0700

Closed #2932.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2932#event-2519180835

---

From: evagld <[email-masked]>
Date: Tue, 30 Jul 2019 02:49:07 -0700

Reopened #2932.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2932#event-2519200170

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jul 2019 17:33:31 -0700

The [editor's drafts](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#long-header) contain the fix already.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2932#issuecomment-516646587

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jul 2019 17:33:32 -0700

Closed #2932.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2932#event-2521632773