Subject: Re: [quicwg/base-drafts] H3 GOAWAY should be symmetric and cover bidi and uni streams (#2632)

From: Lucas Pardue <[email-masked]>
Date: Wed, 24 Jul 2019 16:15:59 -0700

It was mentioned in Montreal that the HTTP WG was asked about this. Was the response reflected back in this ticket?

* apologies, this one completely popped off my stack

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2632#issuecomment-514833409

---

From: afrind <[email-masked]>
Date: Thu, 25 Jul 2019 06:33:51 -0700

To summarize the discussion on the HTTP list:

* H2 GOAWAY is symmetric
* A GOAWAY sent by the client will prevent any pushes higher than the last-stream-id in the GOAWAY
* Martin feels like this behavior is wrong, and it shouldn't be carried over into H3.

Do we need to build consensus from the HTTP working group that it is OK to deviate from H2 semantics in H3, like we are now planning to do for priorities? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2632#issuecomment-515045178

---

From: Martin Thomson <[email-masked]>
Date: Thu, 25 Jul 2019 10:47:19 -0700

> Martin feels like this behavior is wrong, and it shouldn't be carried over into H3.

While this is true, we have - as a working group - previously discussed the principles underlying this and agreed that the unit we should care about is the request.

However, I agree that this is something we should discuss at the HTTP working group.  Where we can each put on a different set of hats.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2632#issuecomment-515144737

---

From: afrind <[email-masked]>
Date: Fri, 26 Jul 2019 08:18:17 -0700

> While this is true, we have - as a working group - previously discussed the principles underlying this and agreed that the unit we should care about is the request.

What's ill defined is whether the pushes that come on a request are part of the request or not. I think a reasonable argument can be made for either interpretation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2632#issuecomment-515494152