Subject: [quicwg/base-drafts] QPACK [editorial] Update text on wire instructions. (#2938)

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 08:58:57 -0700

* Use more uniform language in description of instructions: "begin" instead of "start" everywhere (arbitrarily, but make it consistent); "follows" instead of "includes" or implicit mention of a field.
* Prefer internal references to external ones, also elsewhere.
* Prefer "instruction" to "representation" in low-level contexts focusing on wire format, but not in higher-level contexts.
* Avoid undefined term "header block representation" when it is used to mean "header block".
* Explicitly allow a header block to not have any instructions after the mandatory prefix.
* Refer to Literal Header Field With Name Reference section in Literal Header Field Without Name Reference instead of verbatim repeating text on 'N' bit.

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2938

-- Commit Summary --

  * instructions

-- File Changes --

    M draft-ietf-quic-qpack.md (175)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2938.patch
https://github.com/quicwg/base-drafts/pull/2938.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:01:01 -0700

bencebeky commented on this pull request.

>  The following bit, 'N', indicates whether an intermediary is permitted to add
 this header to the dynamic header table on subsequent hops. When the 'N' bit is
-set, the encoded header MUST always be encoded with a literal representation. In
-particular, when a peer sends a header field that it received represented as a
-literal header field with the 'N' bit set, it MUST use a literal representation
-to forward this header field.  This bit is intended for protecting header field

The sentence starting with "In particular" does not seem to add any value, therefore I propose removing it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#pullrequestreview-269117964

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:10:22 -0700

Sorry, let me reword this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#issuecomment-516916665

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:10:23 -0700

Closed #2938.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#event-2523772647

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 31 Jul 2019 09:20:15 -0700

LPardue commented on this pull request.

I think these changes are good. They address an editorial annoyance I had but never got around to suggesting a fix. 

Alan may have something to say about the change to Represetnation, because that was introduced fairly recently. 

> @@ -170,13 +170,13 @@ decoder and vice versa.
 
 An encoder converts a header list into a header block by emitting either an
 indexed or a literal representation for each header field in the list (see
-{{header-block-representations}}).  Indexed representations achieve high
-compression by replacing the literal name and possibly the value with an index
-to either the static or dynamic table.  References to the static table and
-literal representations do not require any dynamic state and never risk
-head-of-line blocking.  References to the dynamic table risk head-of-line
-blocking if the encoder has not received an acknowledgement indicating the entry
-is available at the decoder.
+{{header-blocks}}).  Indexed representations achieve high compression by

`header-blocks` is a dangling  reference , causing the build failure

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#pullrequestreview-269122918

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:33:14 -0700

> Alan may have something to say about the change to Represetnation, because that was introduced fairly recently.

Thanks.  I have totally misunderstood "representation", so now I'm working on a new PR that includes most changes except for that one.  I closed this PR in a haste to prevent people from wasting time proofreading it.

Also, thank you for pointing out the build failure to me, I did not know where to look for in the error log.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#issuecomment-516924742

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 31 Jul 2019 09:36:24 -0700

hehe, no probs. Thanks for making effort to do PRs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#issuecomment-516925837

---

From: Bence Béky <[email-masked]>
Date: Wed, 31 Jul 2019 09:49:16 -0700

Okay, my new proposal is at https://github.com/quicwg/base-drafts/pull/2941.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2938#issuecomment-516930282