Subject: [quicwg/base-drafts] MIn_RTT management (#2923)

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 22 Jul 2019 13:56:41 -0700

So, I understand that min_RTT is maintained per path as the minimum RTT. 
 
I foresee paths that persist for long periods and where the set of network devices forming the can path change, and hence the min_RTT can be "ridiculously" small concerned to the actual value had it been measured recently. I don't much like that min_RTT is never raised.

The solution could be simple. Re-initialise min_RTT from the RTT sample periodically. How often to reset is not critical, but needs to be reasonably often - I suggest every 600 secs.  (I'd be OK with other numbers, this is the default path state timeout in RFC1981).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 23 Jul 2019 07:25:08 -0700

Related to #2908, but this is more than editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-514233012