Subject: [quicwg/base-drafts] Tighten HEADERS and DATA frame order requirements. (#2867)

From: Bence Béky <[email-masked]>
Date: Tue, 02 Jul 2019 09:42:02 -0700

* Clarify HTTP message definition.
* Require the connection to be closed upon receipt of frames in
  incorrect order.
* Refer to HTTP messages in push stream section.

This addresses https://github.com/quicwg/base-drafts/issues/2858.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2867

-- Commit Summary --

  * Tighten HEADERS and DATA frame order requirements.

-- File Changes --

    M draft-ietf-quic-http.md (29)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2867.patch
https://github.com/quicwg/base-drafts/pull/2867.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867

---

From: ianswett <[email-masked]>
Date: Tue, 02 Jul 2019 10:42:40 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867#pullrequestreview-257048321

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Jul 2019 06:35:07 -0700

MikeBishop commented on this pull request.

This text was already somewhat lacking by not discussing the possibility of extension frames being interleaved; stating that the push stream consists of "responses" rather than "frames" extends this shortcoming to the push stream section.

I'm open to fixing this in a separate PR, if you prefer, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867#pullrequestreview-263029634

---

From: Bence Béky <[email-masked]>
Date: Wed, 17 Jul 2019 07:09:05 -0700

@bencebeky pushed 1 commit.

0bdc75a1790fb5e9cf76fd576ff3fb71397f944a  Explicitly allow unknown frames.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867/files/3b6df422a8b847a16981d26e0885a3437cf98409..0bdc75a1790fb5e9cf76fd576ff3fb71397f944a

---

From: Bence Béky <[email-masked]>
Date: Wed, 17 Jul 2019 07:14:07 -0700

07a0fbb47fb472591f67f0ff5b63a0a8dbd021ae  wordsmithing

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867/files/0bdc75a1790fb5e9cf76fd576ff3fb71397f944a..07a0fbb47fb472591f67f0ff5b63a0a8dbd021ae

---

From: Bence Béky <[email-masked]>
Date: Wed, 17 Jul 2019 07:14:41 -0700

> I'm open to fixing this in a separate PR, if you prefer, though.

Good catch.  I added a paragraph to explicitly allow unknown frames to the message exchange section.  I also modified the wording in the push section to be more permissive of interleaved frames ("by" instead of "consists of").

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867#issuecomment-512273416

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 21 Jul 2019 06:10:52 -0700

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2867#issuecomment-513553129