Subject: [quicwg/base-drafts] PTO should always send an ack-eliciting packet (#2912)

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 05:26:03 -0700

Fixed #2895 which discusses sending an ack-eliciting packet instead of a PADDING only packet to unblock the server.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2912

-- Commit Summary --

  * PTO should always send an ack-eliciting packet

-- File Changes --

    M draft-ietf-quic-recovery.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2912.patch
https://github.com/quicwg/base-drafts/pull/2912.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 21 Jul 2019 06:59:09 -0700

erickinnear approved this pull request.

Looks good to me, for what it's worth our implementation always bundles a PING in here if there is nothing else ack-eliciting to send.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912#pullrequestreview-264538547

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 21 Jul 2019 12:41:05 -0700

@janaiyengar pushed 1 commit.

114b20f4b2accf4f76a242a34d5f620cd48f4e3d  Add rationale for why ack-eliciting

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912/files/407928b26fd9e4fcb2efbef4f70a39eb8a466cd6..114b20f4b2accf4f76a242a34d5f620cd48f4e3d

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 21 Jul 2019 12:41:40 -0700

janaiyengar approved this pull request.

This looks good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912#pullrequestreview-264551544

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 12:52:52 -0700

ianswett commented on this pull request.

Thanks for your changes Jana, this LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912#pullrequestreview-264551943

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 21 Jul 2019 13:05:02 -0700

Merged #2912 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2912#event-2498220751