Subject: [quicwg/base-drafts] Should server TP encryption be a requirement for the cryptographic handshake? (#2920)

From: Christopher Wood <[email-masked]>
Date: Sun, 21 Jul 2019 13:47:47 -0700

The TPs might carry a stateless reset token, which must be encrypted in transit. Section 7 lists some requirements for the handshake, including authentication of the TPs, yet does not include any mention of encrypting them from server to client. Should it? 

cc @DavidSchinazi @martinthomson 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2920

---

From: David Schinazi <[email-masked]>
Date: Sun, 21 Jul 2019 15:16:13 -0700

This makes sense to me. The TLS document ensures that the server's transport parameters are encrypted so an editorial PR changing the transport doc to require that should be sufficient.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2920#issuecomment-513592099

---

From: Martin Thomson <[email-masked]>
Date: Mon, 22 Jul 2019 05:34:03 -0700

Good catch.  Marking as design so that we can consensus call this, but it's arguably editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2920#issuecomment-513772262