Subject: Re: [quicwg/base-drafts] Explicitly allow discard of packets <40 bytes (#2864)

From: David Schinazi <[email-masked]>
Date: Mon, 01 Jul 2019 13:00:56 -0700

This PR adds a recommendation involving the number 40 without explaining where that number comes from. It would be nice to include a reference to the section that explains the math.

That said, I don't think this number should depend on the maximum connection ID length, [as discussed here](https://github.com/quicwg/base-drafts/issues/2770#issuecomment-502763574). But feel free to tell me that this PR is not the place to discuss that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#issuecomment-507404132

---

From: Martin Thomson <[email-masked]>
Date: Mon, 01 Jul 2019 19:32:08 -0700

If you want to talk about the idea that the connection ID might change in length, that's a separate issue, which you should feel free to open.  I am fairly sure that I can show that this isn't a meaningful insight, but happy to discuss it there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#issuecomment-507493620

---

From: David Schinazi <[email-masked]>
Date: Tue, 02 Jul 2019 12:55:23 -0700

@martinthomson filed #2869.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#issuecomment-507821856

---

From: ianswett <[email-masked]>
Date: Tue, 02 Jul 2019 15:56:32 -0700

ianswett requested changes on this pull request.

> @@ -2510,7 +2510,8 @@ Reset in response, which could lead to an infinite exchange.
 An endpoint MUST ensure that every Stateless Reset that it sends is smaller than
 the packet which triggered it, unless it maintains state sufficient to prevent
 looping.  In the event of a loop, this results in packets eventually being too
-small to trigger a response.
+small to trigger a response.  An endpoint MAY choose not to send a Stateless
+Reset in response to a packet that is smaller than 40 bytes.

The existing text was confusing, but I don'd see how this text is relevant to looping?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#pullrequestreview-257188911

---

From: Mike Bishop <[email-masked]>
Date: Wed, 17 Jul 2019 06:39:19 -0700

MikeBishop approved this pull request.

This provides the end condition to the loop.

> @@ -2525,9 +2526,6 @@ a small packet might result in Stateless Reset not being useful in detecting
 cases of broken connections where only very small packets are sent; such
 failures might only be detected by other means, such as timers.
 
-An endpoint can increase the odds that a packet will trigger a Stateless Reset

It might be nice to explicitly mention the packet after quiescence as part of this advice, and/or advise sending at least one 40+ byte packet in each flight.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2864#pullrequestreview-263031214