Subject: [quicwg/base-drafts] Advise bundling a PING or other small ACK eliciting frame with Initials (#2895)

From: ianswett <[email-masked]>
Date: Sat, 13 Jul 2019 04:31:22 -0700

When there is nothing to send today, the text says you can send a PADDING only packet.

These packets will be removed from flight when Initial keys are dropped, but it may never be acknowledged, which loses some congestion control signal, including RTT measurements.

For PTO, we decided you always send a PING if PTO expires and there's nothing to send.  It seems like we should say the same for the handshake case now that it's part of PTO?

This came from Ryan's comment on #2806 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895

---

From: Martin Thomson <[email-masked]>
Date: Sun, 14 Jul 2019 17:15:48 -0700

Not sure that this helps all that much.  Even though you might be eliciting an acknowledgment, you will still lose the packet when you discard keys, which could still happen.  All you have done is increase the work that the recipient needs to perform.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-511247002

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 05:18:31 -0700

It doesn't help that much, but it's a lot more consistent with the rest of the PTO design, so I think it's preferable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-513548754

---

From: Martin Thomson <[email-masked]>
Date: Sun, 21 Jul 2019 05:22:32 -0700

In discussing our PTO strategy yesterday I realized that you only send a packet if you have something ack- eliciting outstanding. Would you not want to send that again?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-513549015

---

From: ianswett <[email-masked]>
Date: Sun, 21 Jul 2019 05:28:59 -0700

Sometimes you can't send that again once the handshake is confirmed(there's an example in the text, but the easiest is something unreliable like DATAGRAM).

Prior to handshake confirmation, the client needs to drive the handshake to confirmation so it may have to send something, as your PR #2881 discusses

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-513549825

---

From: Martin Thomson <[email-masked]>
Date: Sun, 21 Jul 2019 07:27:29 -0700

Makes sense to me.  I hadn't considered data that isn't retransmitted after loss, which is a little embarrassing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-513559138

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 21 Jul 2019 12:45:41 -0700

This seems reasonable. The RTT estimate could be quite wrong at this stage in the connection, so an ack-eliciting packet can be used to improve that as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#issuecomment-513582198

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 21 Jul 2019 13:05:01 -0700

Closed #2895 via #2912.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2895#event-2498220754