Subject: Re: [quicwg/base-drafts] QPACK [editorial] Update text to include both criteria of "blocking entry". (#2937)

From: afrind <[email-masked]>
Date: Tue, 13 Aug 2019 14:37:17 -0700

afrind commented on this pull request.

> @@ -229,8 +229,9 @@ table that it will emit a reference for.  As new entries are inserted, the
 encoder increases the draining index to maintain the section of the table that
 it will not reference.  If the encoder does not create new references to entries
 with an absolute index lower than the draining index, the number of
-unacknowledged references to those entries will eventually become zero, allowing
-them to be evicted.
+unacknowledged references to every such entry will eventually become zero,
+allowing it to be evicted provided that its insertion has been acknowledged by
+the decoder.

This is now a pretty long sentence.  Maybe end it after 'become zero', and start a new sentence talking about eviction?

> @@ -359,9 +360,9 @@ infer from this instruction that any updates to the dynamic table have been
 received.
 
 The Header Acknowledgement and Stream Cancellation instructions permit the
-encoder to remove references to entries in the dynamic table.  When entries
-have zero references they are no longer considered blocking (see
-{{blocked-insertion}}).
+encoder to remove references to entries in the dynamic table.  When an entry
+with absolute index lower than the Known Received Count has zero references,

Does this leave ambiguous what happens to entries with absolute indices higher than Known Received Count?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2937#pullrequestreview-274569683

---

From: Bence Béky <[email-masked]>
Date: Thu, 15 Aug 2019 09:32:47 -0700

@bencebeky pushed 1 commit.

44642c25477cd990e91e354ae0e069255e5031db  Revert changes to section 2.1.2.1. Avoiding Blocked Insertions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2937/files/da6200d82edf21c2faa34ab9512c557bf1d03f74..44642c25477cd990e91e354ae0e069255e5031db

---

From: Bence Béky <[email-masked]>
Date: Thu, 15 Aug 2019 09:32:50 -0700

bencebeky commented on this pull request.

Ah, let me just revert the change to this paragraph.  No matter how I try to reword it, mentioning acknowledgement of the insertion always leaves it more confusing that the original text.  After all, if the number of unacknowledged references _becomes_ zero, that means it was not zero beforehand, therefore the encoder knows for sure that the insertion has been processed by the decoder.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2937#discussion_r314393645

---

From: Bence Béky <[email-masked]>
Date: Thu, 15 Aug 2019 09:36:28 -0700

received.

I don't believe so.  It kind of implies that such an entry is considered blocking, which is true.  Note that if the entry is ever referenced in a header block and that reference is acknowledged, that guarantees that the Known Received Count is larger than the absolute index of the entry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2937#discussion_r314395065

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Aug 2019 07:23:06 -0700

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2937#pullrequestreview-276593740