Subject: Re: [quicwg/base-drafts] What if a client sends a NEW TOKEN frame? (#2382)

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Aug 2019 03:13:19 -0700

I'll bite.  Yes, a P2P app that used mutual authentication in a way that would allow a former server to associate a token with an attempt to connect to a peer that was previously a client, might be able to use NEW_TOKEN.

That's a little outside our remit.  I'm going to take this as an editorial change on the understanding that a design issue could be opened to allow the asymmetry.

Anyone who is serious about that should also consider the fact that NewSessionTicket in TLS is potentially symmetrical by the same logic.  Which suggests that 0-RTT isn't out of the question either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-524804749

---

From: MikkelFJ <[email-masked]>
Date: Tue, 27 Aug 2019 00:44:51 -0700

On p2p there is the potential problem of relating a token to previously stored settings and observables from a previous session. This isn't well defined if the client specifies a new token. So perhaps it is better for each peer to "waste" a single 1-RTT connection the first time in a given direction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#issuecomment-525182209

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Aug 2019 15:14:26 -0700

Closed #2382 via #2988.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2382#event-2588650836