Subject: [quicwg/base-drafts] Clarify out of order acking (#2954)

From: Jana Iyengar <[email-masked]>
Date: Mon, 05 Aug 2019 18:58:56 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2954

-- Commit Summary --

  * clarify out of order acking

-- File Changes --

    M draft-ietf-quic-recovery.md (13)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2954.patch
https://github.com/quicwg/base-drafts/pull/2954.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954

---

From: Nick Banks <[email-masked]>
Date: Mon, 05 Aug 2019 19:15:56 -0700

nibanks approved this pull request.

What about the case where you receive an in order ack eliciting packet and then an out of order ack only packet? Should you still rely on delayed ack timer or send an ack immediately?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#pullrequestreview-271085979

---

From: Marten Seemann <[email-masked]>
Date: Mon, 05 Aug 2019 19:17:42 -0700

marten-seemann commented on this pull request.

What does it mean for a subsequent packet to arrive out of order?
If I received packets 10, 11, 13, then clearly 13 is out of order. If I received 14 now, would that also be considered out of order? Would 15 be?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#pullrequestreview-271086284

---

From: Rui Paulo <[email-masked]>
Date: Mon, 05 Aug 2019 19:51:53 -0700

> What about the case where you receive an in order ack eliciting packet and then an out of order ack only packet? Should you still rely on delayed ack timer or send an ack immediately?

Yes, this was going to be my follow up question.

Also @janaiyengar what about the ECN paragraph just below it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#issuecomment-518476450

---

From: ianswett <[email-masked]>
Date: Tue, 06 Aug 2019 10:48:14 -0700

ianswett approved this pull request.

This text is moving drafts in #2916, so it might make sense to land that first?  Or I I can pull this change in after it lands.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#pullrequestreview-271510454

---

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Aug 2019 17:51:54 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#pullrequestreview-272296964

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 07 Aug 2019 18:04:31 -0700

@janaiyengar pushed 1 commit.

1a2c09dbf3e29c2780fce5065cab12b44b4b3749  comments and more

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954/files/783887941997b6a826fd6b4f102f740f64b546ca..1a2c09dbf3e29c2780fce5065cab12b44b4b3749

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 07 Aug 2019 18:08:10 -0700

@nibanks: The current spec would not cause an ack to be triggered if non-ack-eliciting packets are received out of order. I think that's important. If the packet that was lost was another ack-only packet, this would cause unnecessary acks, and doing this at both ends could cause a minor ack storm.

@marten-seemann: out-of-order is defined in the draft above. I think it's less than ideal, but it's not ambiguous.

@rpaulo: I've rephrased the ECN section just a bit to be clearer. Does that help?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#issuecomment-519323141

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 08 Aug 2019 13:36:45 -0700

I'll merge this. If folks have any pending questions, happy to take them on in a new PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#issuecomment-519678128

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 08 Aug 2019 13:36:54 -0700

Merged #2954 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2954#event-2544617053