Subject: Re: [quicwg/base-drafts] CANCEL_PUSH edge cases (#2819)

From: martinduke <[email-masked]>
Date: Thu, 15 Aug 2019 13:02:04 -0700

I'd also add a CANCEL_PUSH from the client for a PUSH_ID that has not been promised.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2819#issuecomment-521777107

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Aug 2019 07:43:03 -0700

CANCEL_PUSH with a reused ID is probably indistinguishable from receiving one for a stream that's already open; you SHOULD reset the stream (which is a no-op if the stream is already full transferred).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2819#issuecomment-522606576