Subject: [quicwg/base-drafts] ECN counts in the ACK frame should be in the same pn_space of the ACK frame (#2964)

From: Yuanshan <[email-masked]>
Date: Fri, 09 Aug 2019 13:39:34 -0700

Specify that ECN counts in the ACK frame to be in the same pn_space of the ACK frame. 
Change pseudocode in recovery-draft to reflect that.

Closes #2957 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2964

-- Commit Summary --

  * ECN counts in the ACK frame should be per packet number space

-- File Changes --

    M draft-ietf-quic-recovery.md (19)
    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2964.patch
https://github.com/quicwg/base-drafts/pull/2964.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 13 Aug 2019 15:55:24 -0700

janaiyengar commented on this pull request.

A few editorial suggestions, but looks good.

 ECT(1) Count:
 : A variable-length integer representing the total number of packets received
-  with the ECT(1) codepoint.
+  with the ECT(1) codepoint in in the same packet number space of the ACK.

```suggestion
  with the ECT(1) codepoint in the packet number space of the ACK frame.
```

> @@ -4586,15 +4586,15 @@ The three ECN Counts are:
 
 ECT(0) Count:
 : A variable-length integer representing the total number of packets received
-  with the ECT(0) codepoint.
+  with the ECT(0) codepoint in the same packet number space of the ACK.

```suggestion
  with the ECT(0) codepoint in the packet number space of the ACK frame.
```

 CE Count:
 : A variable-length integer representing the total number of packets received
-  with the CE codepoint.
+  with the CE codepoint in the same packet number space of the ACK.

```suggestion
  with the CE codepoint in the packet number space of the ACK frame.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#pullrequestreview-274596637

---

From: Yuanshan <[email-masked]>
Date: Wed, 14 Aug 2019 11:16:32 -0700

@YuanshanZ pushed 1 commit.

75f83f93eae54e40622e8c3867f46030d17ef0f2  Editorial Changes According to Review Comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964/files/91f40a669c4e5351beff982bd0cacde9efdff126..75f83f93eae54e40622e8c3867f46030d17ef0f2

---

From: Yuanshan <[email-masked]>
Date: Wed, 14 Aug 2019 11:18:33 -0700

YuanshanZ commented on this pull request.

 CE Count:

Thanks for the suggestion! I've fixed this one along with the other two in the latest commit. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#discussion_r314016026

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 14 Aug 2019 12:45:39 -0700

janaiyengar approved this pull request.

Thanks! @ianswett, want to take a look?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#pullrequestreview-275109853

---

From: ianswett <[email-masked]>
Date: Wed, 14 Aug 2019 13:07:20 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#pullrequestreview-275120785

---

From: ianswett <[email-masked]>
Date: Wed, 14 Aug 2019 13:08:53 -0700

This only changes pseudocode and no normative text, so I'm inclined to mark it editorial and merge it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#issuecomment-521399056

---

From: ianswett <[email-masked]>
Date: Wed, 14 Aug 2019 13:09:09 -0700

Merged #2964 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2964#event-2557770659