Subject: [quicwg/base-drafts] Byte order of IP addresses in PreferredAddress (#2951)

From: Masakazu Kitajo <[email-masked]>
Date: Fri, 02 Aug 2019 00:42:47 -0700

Byte order of IP addresses in PreferredAddress is not explicitly stated. In practice, most OSs keep them in network byte order, and the spec says integers are in network byte order, however the fields for ip addresses are defined as opaque data. The byte order should be stated on this spec.

```
    struct {
     opaque ipv4Address[4];
     uint16 ipv4Port;
     opaque ipv6Address[16];
     uint16 ipv6Port;
     opaque connectionId<0..20>;
     opaque statelessResetToken[16];
   } PreferredAddress;
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2951

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 16 Aug 2019 15:36:27 -0700

Closed #2951 via #2976.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2951#event-2563571158