Subject: [quicwg/base-drafts] Error codes can't cause errors (#2998)

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Aug 2019 12:59:47 -0700

Fixes #2816 by saying that, since error codes are extensible, you can&#39;t treat the receipt of an error code you don&#39;t understand or don&#39;t think you should have gotten as an error itself.  (Though it can still be an error that the stream closed, regardless of the error code.)

(Which leads to the question, should we be greasing the error code space?)
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2998

-- Commit Summary --

  * Error codes can&#39;t cause errors

-- File Changes --

    M draft-ietf-quic-http.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2998.patch
https://github.com/quicwg/base-drafts/pull/2998.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2998

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 28 Aug 2019 13:02:44 -0700

> Which leads to the question, should we be greasing the error code space?)

Yes! I would create a grease stream and it could be closed (stop sending and/or reset) by peers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2998#issuecomment-525900379

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Aug 2019 16:00:39 -0700

That seems to have very narrow applicability.  Would you only be permitted to send a greasing error code in that case?

Or to put the question differently, what would happen if you decided to randomly turn a subset of the semantic-ful error codes you generate into greasing codes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2998#issuecomment-525954577

---

From: Mike Bishop <[email-masked]>
Date: Thu, 29 Aug 2019 09:37:45 -0700

Per the language of this PR, I think that would be fine.  Possibly with the exception of the errors that are supposed to inform behavior, like _REJECTED and perhaps EARLY_RESPONSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2998#issuecomment-526265970