Subject: Re: [quicwg/base-drafts] ChaCha inputs (#2171)

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Aug 2019 03:30:27 -0700

I don't think that the reinterpretation of the little-endian thing is safe, as per @mikkelfj's comment.

The [PKCS#11 interface](https://docs.oasis-open.org/pkcs11/pkcs11-curr/v3.0/csprd01/pkcs11-curr-v3.0-csprd01.html#_Toc10561273) takes a byte buffer as input rather than a `uint32_t`.  That is to allow for different block counter sizes.  I'll make the editorial change, but leave the suggestion there alone.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2171#issuecomment-524809410

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Aug 2019 03:44:01 -0700

I have a question out to the editor of the PKCS#11 spec.  It appears like there are no solid rules in the spec to support any particular position here.  I'm going with my best guess at WWDJBD here, but I'm happy to make a change if there is a strong case made for something else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2171#issuecomment-524812777

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Aug 2019 03:49:59 -0700

@mnot, @larseggert, can we flip this to `design` please?   I don't think that we need to change the substance here, but I want to confirm the little-endian/big-endian choice here.

I hope to have more information to share on the question soon, but that might not be definitive.  We might just have to make a call ourselves.  

Absent better information, I'm going to suggest that we continue with little-endian, but I this is far from an obvious conclusion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2171#issuecomment-524814218