Subject: Re: [quicwg/base-drafts] Ian's suggestion (7119afb)

From: MikkelFJ <[email-masked]>
Date: Mon, 26 Aug 2019 23:58:11 -0700

What is ultimately the point (value) of specifying DCID of short headers in the invariants then? The length could be 0 and a pseudo DCID could be placed elsewhere in some arbitrary version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/7119afb175aecc071b73857f349d6c258e266795#commitcomment-34843993

---

From: Martin Thomson <[email-masked]>
Date: Tue, 27 Aug 2019 00:20:57 -0700

I'm sure that we could do that, but the intent is to signal that - should we provide a DCID - it is in that location that it will appear.  I don't think that's zero value, even if it doesn't amount to much in terms of a commitment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/7119afb175aecc071b73857f349d6c258e266795#commitcomment-34844277

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 27 Aug 2019 00:36:24 -0700

I like that the text we have now - a load balancer can limit it's supported length, assuming that it is not longer than the limit imposed by QUIC vN. Assuming that is the case, it would be possible for such a middlebox to forward the packet to the correct backend server regardless of the QUIC version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/7119afb175aecc071b73857f349d6c258e266795#commitcomment-34844449