Subject: [quicwg/base-drafts] Confused about Fixed Bit in Version Negotiation Packet (#2995)

From: Ainiroad <[email-masked]>
Date: Wed, 28 Aug 2019 01:02:28 -0700

Fixed Bit Must set to 1:
> Fixed Bit:
The next bit (0x40) of byte 0 is set to 1. Packets containing a zero value for this bit are not valid packets in this version and MUST be discarded.

the first byte in Version Negotiation Packet
```
+-+-+-+-+-+-+-+-+
|1|  Unused (7) |
```
there is 7 bits unused, including Fixed Bit.

> The value in the Unused field is selected randomly by the server. Clients MUST ignore the value of this field. Servers SHOULD set the most significant bit of this field (0x40) to 1 so that Version Negotiation packets appear to have the Fixed Bit field.

It's said that `Clients MUST ignore the value of this field.` and `Servers SHOULD set the most significant bit of this field (0x40) to 1`. 
If Client must ignore the value(including Fixed Bit), why server should set Fixed Bit?

I'm confused about the describe. I think maybe it want to express it like this:
> Clients MUST ignore the value of this field *except Fixed Bit(0x40)*. Servers SHOULD set the most significant bit of this field (0x40) to 1 .......

Do I have any misunderstanding? thanks a lot

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995

---

From: MikkelFJ <[email-masked]>
Date: Wed, 28 Aug 2019 01:06:58 -0700

A version negotiation packet is not version specific so the rule you refer to does not apply.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995#issuecomment-525632322

---

From: Ainiroad <[email-masked]>
Date: Wed, 28 Aug 2019 01:13:05 -0700

> A version negotiation packet is not version specific so the rule you refer to does not apply.

I'm confused about the describe.
If Client must ignore the value(including Fixed Bit), why server should set Fixed Bit?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2995#issuecomment-525634421