Subject: [quicwg/base-drafts] What if server does not send HTTP_EARLY_RESPONSE but starts sending response (#2963)

From: Dragana Damjanovic <[email-masked]>
Date: Fri, 09 Aug 2019 08:36:01 -0700

There is a text that say:

> A server can send a complete response prior to the client sending an
>    entire request if the response does not depend on any portion of the
>    request that has not been sent and received.  When this is true, a
>    server MAY request that the client abort transmission of a request
>    without error by triggering a QUIC STOP_SENDING frame with error code
>    HTTP_EARLY_RESPONSE, sending a complete response, and cleanly closing
>    its stream.  Clients MUST NOT discard complete responses as a result
>    of having their request terminated abruptly, though clients can
>    always discard responses at their discretion for other reasons.

A server MAY send STOP_SENDING. What should the client do if the server does not send it? Is the client allowed to close the send stream or should it continue until everything has been sent? In the second case the client may receive the complete response before the complete request has been sent. Is there a use case where a sever can send a response before receiving the complete request, but still cares about the request data?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2963

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Aug 2019 10:18:05 -0700

Good question.  From a purely transactional point of view, if no part of the response depends on the remainder of the request, the client might as well stop sending.  However, I can also imagine an API where the server wants to consume and store the remainder of what the client is sending even if the return value is determined already.

The most generic way to handle this is to say that the server can express that it doesn't need the remainder of the response, and if it doesn't do so, the client SHOULD finish sending it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2963#issuecomment-522085102