Subject: Re: [quicwg/base-drafts] QPACK [editorial] update RIC and Base on figures (#2935)

From: Mike Bishop <[email-masked]>
Date: Mon, 05 Aug 2019 13:24:41 -0700

[Indices point between elements](https://blog.nelhage.com/2015/08/indices-point-between-elements/)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-518385266

---

From: afrind <[email-masked]>
Date: Tue, 13 Aug 2019 14:29:41 -0700

Agree we should remove the arrow from count.  I guess there's two minds on where array indices point.  I think I inherited the current style.  HPACK only has the 'insertion point' and 'dropping point' arrows, so sidesteps the issue altogether. 

I'm inlined to say it's more clear as is, with Base pointing on the line between what was in the table when encoding started and the Post Base entries.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-521016601

---

From: Bence Béky <[email-masked]>
Date: Thu, 15 Aug 2019 08:34:00 -0700

While I understand the argument outlined in the blog post @MikeBishop linked above, and would not be unhappy if that was the widespread convention, I am worried that this is not the mental model that most engineers share.  I think the index--element bijection is the general convention, and deviating from that might cause confusion.

A particular source of confusion arising in this situation even for people used to the "indices point between elments" convention is that on the two figures in question, indices increase to the left. 
 Therefore the element with a given index is not the one on the right of the arrow, but the one on the left, breaking the rule of thumb mentioned in the blog post.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-521685479