Subject: Re: [quicwg/base-drafts] Layout of PreferredAddress (#2944)

From: David Schinazi <[email-masked]>
Date: Thu, 01 Aug 2019 10:27:49 -0700

Google's QUIC implementation uses a TLS encoding parser so changing the order of fields would not impact our implementation complexity. I'm inclined to push back against encoding changes at this point, but I don't feel incredibly strongly here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2944#issuecomment-517383296

---

From: Martin Thomson <[email-masked]>
Date: Thu, 01 Aug 2019 17:17:03 -0700

We're similarly equipped and disinclined toward change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2944#issuecomment-517501512

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Aug 2019 12:10:07 -0700

I agree that this would be an improvement, but I'm not sure the benefit is significant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2944#issuecomment-522119704

---

From: MikkelFJ <[email-masked]>
Date: Sat, 17 Aug 2019 04:57:48 -0700

Minor change but the annoyance will stay forever, so I think it is worth going for.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2944#issuecomment-522230805