Subject: [quicwg/base-drafts] Are ECN counts per pn_space or unified across pn_spaces? (#2957)

From: Yuanshan <[email-masked]>
Date: Wed, 07 Aug 2019 17:00:11 -0700

Are ECN counts in ACK frames per pn_space or unified across pn_spaces? I've observed different behaviors of public servers regarding that.

[13.3.1. ECN Counts] seems to suggest they are per pn_space:
```
Each packet number space maintains separate acknowledgement state and separate ECN counts. For example, if one each of an Initial, 0-RTT, Handshake, and 1-RTT QUIC packet are coalesced, the corresponding counts for the Initial and Handshake packet number space will be incremented by one and the counts for the 1-RTT packet number space will be increased by two.
```

However, [19.3.2. ECN Counts] says:
```
The three ECN Counts are:
ECT(0) Count:
A variable-length integer representing the total number of packets received with the ECT(0) codepoint.
ECT(1) Count:
A variable-length integer representing the total number of packets received with the ECT(1) codepoint.
CE Count:
A variable-length integer representing the total number of packets received with the CE codepoint. 
```

Pseudocode in the recovery draft (Appendix B.  Congestion Control Pseudocode) also has a global ecn_ce_counter. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2957

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 13 Aug 2019 15:52:09 -0700

Thanks for the issue, @YuanshanZ, PR looks good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2957#issuecomment-521038507

---

From: ianswett <[email-masked]>
Date: Wed, 14 Aug 2019 13:09:12 -0700

Closed #2957 via #2964.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2957#event-2557770664