Subject: Re: [quicwg/base-drafts] Can an H3 server send a response before receiving the SETTINGS frame? (#2726)

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Aug 2019 12:42:05 -0700

Closed #2726.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2726#event-2591717165

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Aug 2019 12:42:05 -0700

Fixed in #2972:
> Each endpoint SHOULD use these initial values to send messages before the peer's SETTINGS frame has arrived, as packets carrying the settings can be lost or delayed.  When the SETTINGS frame arrives, any settings are changed to their new values.
>
> This removes the need to wait for the SETTINGS frame before sending messages. Endpoints MUST NOT require any data to be received from the peer prior to sending the SETTINGS frame; settings MUST be sent as soon as the transport is ready to send data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2726#issuecomment-525893369