Subject: Re: [quicwg/base-drafts] Does a Retry really need to change the CID? (#2837)

From: Mike Bishop <[email-masked]>
Date: Wed, 07 Aug 2019 11:46:41 -0700

Another reason, I think:  By requiring it to change, the ODCID becomes something that the server can include in the TPs to ensure than an on-path attacker didn't inject a Retry before the Initial reached the server.  It proves that the sender of the Retry was, if not the server itself, affiliated with it.  Otherwise, the ODCID is potentially still in the client's Initial for the server to echo back without coordination.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-519222617

---

From: Martin Thomson <[email-masked]>
Date: Wed, 07 Aug 2019 16:22:24 -0700

By not allowing it to change you have a stronger assurance in that the server has to have a key.

Having just implemented Retry (yeah, it is like that...) I don't see any advantage either side of this from an implementation perspective. Either way, the server either holds state or puts the odcid in the token. The client implementation is very slightly easier and more efficient if the key doesn't change.  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-519303612

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Aug 2019 12:54:38 -0700

@martinthomson, does that mean you're advocating for this to be a design issue again?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-522131933

---

From: Martin Thomson <[email-masked]>
Date: Sun, 18 Aug 2019 18:22:41 -0700

I won't do that if others don't think that, but it seems that at least @nharper thinks it's worth doing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-522379029

---

From: Nick Harper <[email-masked]>
Date: Mon, 19 Aug 2019 17:54:13 -0700

In issue #2823 I was advocating for keeping the initial key the same (even across a Retry that changes the CID), but I don't have a preference for whether the CID MUST vs MAY vs MUST NOT change in a Retry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-522808650

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Aug 2019 19:26:00 -0700

OK, I think that I'm getting my wires crossed.  I think that changing CID is valuable because it then forces the server to demonstrate continuity.  It's keeping the keys constant (per #2823) that has the added value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2837#issuecomment-522826023