Subject: [quicwg/base-drafts] Can CRYPTO frames be sent in 0-RTT packets? (#2959)

From: tandf <[email-masked]>
Date: Wed, 07 Aug 2019 19:59:49 -0700

In quic-transport-22 section 19.6 it says CRYPTO frames can be sent in all packet types.
> The CRYPTO frame (type=0x06) is used to transmit cryptographic handshake messages.  It can be sent in all packet types.

However in quic-tls-22 section 4 it says the CRYPTO frames can't be sent in 0-RTT packets.
> CRYPTO and CONNECTION_CLOSE frames MAY appear in packets of any encryption level except 0-RTT.

Also in quic-tls-22 section 8.3, similar statement.
> A server MUST treat receipt of a CRYPTO frame in a 0-RTT packet as a connection error of type PROTOCOL_VIOLATION.

Maybe the statement in quic-transport-22 needs to be corrected?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2959

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Aug 2019 00:57:55 -0700

Closed #2959 via #2960.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2959#event-2542417202