Subject: Re: [quicwg/base-drafts] Simplify ChaCha20 interface (55ec704)

From: MikkelFJ <[email-masked]>
Date: Mon, 26 Aug 2019 03:51:58 -0700

So you say this is beyond what is specified here, with test vectors?

https://tools.ietf.org/id/draft-agl-tls-chacha20poly1305-03.html

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/55ec704a1ee1a730853ddd6e8192fb3737d88278#commitcomment-34831258

---

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Aug 2019 04:05:53 -0700

Yes.  That (now RFC 8439, as cited in this spec), specifies block counters as a number. It doesn't specify how that number might be derived from a sequence of bytes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/55ec704a1ee1a730853ddd6e8192fb3737d88278#commitcomment-34831398