Subject: [quicwg/base-drafts] QPACK decoder stream buffer grows without bounds (#2999)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Fri, 30 Aug 2019 08:55:23 -0700

If I understand correctly, the decoder stream buffer which endpoint has to keep grows indefinitely if encoder-side app does not return back flow control credit.
The number of Header Acknowledgement instruction is bounded by the number of max blocked streams which decoder can specify.
On the other hand, the number of Stream Cancellation is not bounded.  So if encoder-side app keeps resetting stream without sending MAX_STREAM_DATA, decoder-side has to keep all closed stream in decoder stream.  I'm not sure this has been discussed already.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2999

---

From: Mike Bishop <[email-masked]>
Date: Fri, 30 Aug 2019 09:33:09 -0700

The solution to this seems implementation-dependent, but implementations should place a bound on the amount of data waiting to be sent on the decoder stream.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2999#issuecomment-526666510