Subject: [quicwg/base-drafts] Collapse frame errors into HTTP_FRAME_ERROR (#2996)

From: Lucas Pardue <[email-masked]>
Date: Wed, 28 Aug 2019 03:57:24 -0700

This is the most extreme form of fixing #2809, which was about rationalizing HTTP_WRONG_STREAM and HTTP_UNEXPECTED_FRAME. 

In a nutshell, what it means is that the same code is used when an endpoint that detects an error in the frame itself, or if the frame is on the wrong stream type or sent in the wrong direction.

To paraphrase @MikeBishop slightly from the list discussion, this might be too much of a change for  a protocol on the edge of late-stage process. 

Is this a clear improvement over what we have today (even if today is a bit clunky and requires a little extra code? I&#39;m undecided but in the interest of resolving the conversation one way or the other I present this PR.

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2996

-- Commit Summary --

  * replace HTTP_WRONG_STREAM and HTTP_UNEXPECTED_FRAME for HTTP_FRAME_ERROR

-- File Changes --

    M draft-ietf-quic-http.md (87)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2996.patch
https://github.com/quicwg/base-drafts/pull/2996.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2996

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 30 Aug 2019 09:17:11 -0700

I like this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2996#issuecomment-526661473