Subject: [quicwg/base-drafts] forbid empty NEW_TOKEN frames (#2977)

From: Marten Seemann <[email-masked]>
Date: Fri, 16 Aug 2019 20:37:07 -0700

If we allow empty NEW_TOKEN frames, the receiver would have to check that the token is not empty before saving and reusing it, so it seems slightly easier to forbid this nonsensical edge case.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/2977

-- Commit Summary --

  * forbid empty NEW_TOKEN frames

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/2977.patch
https://github.com/quicwg/base-drafts/pull/2977.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2977

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 22 Aug 2019 23:02:23 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2977#pullrequestreview-278808649

---

From: ianswett <[email-masked]>
Date: Fri, 23 Aug 2019 08:15:30 -0700

ianswett approved this pull request.

> @@ -4843,7 +4843,8 @@ Token Length:
 
 Token:
 
-: An opaque blob that the client may use with a future Initial packet.
+: An opaque blob that the client may use with a future Initial packet. The token
+  MUST NOT be empty.

Did you want to specify the connection close error to use if it's empty?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2977#pullrequestreview-279063332

---

From: Marten Seemann <[email-masked]>
Date: Sat, 24 Aug 2019 02:03:02 -0700

marten-seemann commented on this pull request.

 Token:

I'd use a FRAME_ENCODING_ERROR error here. However, for other invalid frame errors we use PROTOCOL_VIOLATION. Not sure if that's something we want to address at some point.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2977#discussion_r317351101