Subject: Re: [quicwg/base-drafts] Define under-utilizing the congestion window (#2675)

From: Jana Iyengar <[email-masked]>
Date: Tue, 15 Oct 2019 11:05:46 -0700

janaiyengar approved this pull request.

This text looks good, let's get it in.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2675#pullrequestreview-302096785

---

From: ianswett <[email-masked]>
Date: Tue, 15 Oct 2019 11:26:06 -0700

Merged #2675 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2675#event-2714994612

---

From: Junho Choi <[email-masked]>
Date: Thu, 17 Oct 2019 09:54:46 -0700

junhochoi commented on this pull request.

> @@ -836,9 +836,11 @@ in Linux (3.11 onwards).
 
 ## Under-utilizing the Congestion Window
 
-A congestion window that is under-utilized SHOULD NOT be increased in either
-slow start or congestion avoidance. This can happen due to insufficient
-application data or flow control credit.
+When bytes in flight is smaller than the congestion window and sending is not
+pacing limited, the congestion window is under-utilized.  When this occurs,

I think BBR is considered here for pacing limited case? But there is no description what is pacing limited. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2675#discussion_r336117554

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 17 Oct 2019 14:23:00 -0700

janaiyengar commented on this pull request.

 

@junhochoi : The point here is that if you're unable to utilize the full cwnd because you are limited by a pacer, then it doesn't count as app limited.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2675#discussion_r336233331