Subject: [quicwg/base-drafts] Packets on one path must not adjust values for a different path (#3139)

From: Eric Kinnear <[email-masked]>
Date: Wed, 23 Oct 2019 15:07:39 -0700

The intent here was that either (a) you only ever have a singe CC context and you reset it for each path, or (b) you have a CC context for each path, in which case each context is strongly tied to a path and you don&#39;t need to reset anything (except when it&#39;s been a while and the previous values may no longer be valid, etc.). We require that everyone does at least (a), while not preventing folks who want to do extra work for a potential performance gain from doing (b).

Packets *can* contribute to the CC/RTT estimation for the old path if it&#39;s still around and you&#39;re willing to maintain that state, which is why this (mistakenly) was a SHOULD.

Closes #2909.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3139

-- Commit Summary --

  * Packets on one path must not adjust values for a different path

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3139.patch
https://github.com/quicwg/base-drafts/pull/3139.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139

---

From: Martin Thomson <[email-masked]>
Date: Wed, 23 Oct 2019 15:51:22 -0700

This looks good.  I'm calling it editorial.  However, it changes normative language, so I want an opinion on that from at least @ianswett or @janaiyengar before merging (other opinions are also highly valued).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#issuecomment-545668761

---

From: ianswett <[email-masked]>
Date: Wed, 23 Oct 2019 18:28:45 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#pullrequestreview-306275472

---

From: MikkelFJ <[email-masked]>
Date: Thu, 24 Oct 2019 05:48:42 -0700

mikkelfj commented on this pull request.

> @@ -2096,7 +2096,7 @@ more likely to indicate an intentional migration rather than an attack.
 ## Loss Detection and Congestion Control {#migration-cc}
 
 The capacity available on the new path might not be the same as the old path.
-Packets sent on the old path SHOULD NOT contribute to congestion control or RTT
+Packets sent on the old path MUST NOT contribute to congestion control or RTT
 estimation for the new path.

What about the initial RTT estimate on the new path?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#pullrequestreview-306545340

---

From: ianswett <[email-masked]>
Date: Thu, 24 Oct 2019 06:22:17 -0700

ianswett commented on this pull request.

That's a fair point.  In practice, it's more likely the new path is similar to the old path RTT than it is to a default like 1 second, given these are the same two endpoints.

But I'm not sure that optimization is worth considering.  If you're validating the new path before migrating, which is probably the typical case, you expect to get an RTT sample in 1 round trip anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#discussion_r338568687

---

From: mirjak <[email-masked]>
Date: Fri, 25 Oct 2019 01:43:19 -0700

mirjak commented on this pull request.

Yes, good question. So I think it is correct that it is important to make sure that when you migrate you need to use a new cc context and not just keep using the old one. But I guess this was a SHOULD because using the old estimate as the new initial could make sense e.g. if you have very small RTTs or only a few ms. On the other hand, as Ian said, you should get a new sample with the validation anyway and therefore it should not have an impact. Do we maybe need more text to actually explain that?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#discussion_r338945759