Subject: Re: [quicwg/base-drafts] QPACK [editorial] update RIC and Base on figures (#2935)

From: afrind <[email-masked]>
Date: Tue, 15 Oct 2019 16:59:47 -0700

This confusion comes from when we changed Absolute Index to start from 0, and Base *Index* became just "Base".  What is Base now anyways?   Base is now a *Count*, and perhaps we should rename it to Base Count everywhere.

Because Base is a Count and not an Index, it shouldn't really point anywhere in the diagram.  Maybe we should remove the arrow entirely, and just say, `Base = n - 2`

If we really have to have an arrow, then where should it point when Base = Required Insert Count?

Required Insert Count = 2
Base = 2

```
Base
  |
  v 
  | 1 | 0 |   # Absolute
  | 0 | 1 |   # Relative 
```

or

```
Base
  |
  v 
    | 1 | 0 |   # Absolute
    | 0 | 1 |   # Relative 
```

Or when Base is 0 ?

Required Insert Count = 2
Base = 0

```
      Base
        |
        v 
  | 1 | 0 |   # Absolute
  | 0 | 1 |   # Relative 
```

or

```
        Base
          |
          v 
  | 1 | 0 |   # Absolute
  | 0 | 1 |   # Relative 
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-542452651

---

From: Bence Béky <[email-masked]>
Date: Wed, 16 Oct 2019 06:17:17 -0700

@bencebeky pushed 2 commits.

05f2a6092aad438ecbea68440f85c44495e9fd30  Merge remote-tracking branch 'upstream/master' into bencebeky-qpack-base
bf92f065e4dc84fa59d72df66cbdd04042d42e22  Update figure captions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935/files/5a1303cd34ff5ab84aae7e7eab6a649cb1326da8..bf92f065e4dc84fa59d72df66cbdd04042d42e22

---

From: Bence Béky <[email-masked]>
Date: Wed, 16 Oct 2019 06:28:35 -0700

@bencebeky pushed 1 commit.

06607c16e38dce809672e43b990905dbd334619d  Revert "Update figure captions"

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935/files/bf92f065e4dc84fa59d72df66cbdd04042d42e22..06607c16e38dce809672e43b990905dbd334619d

---

From: Bence Béky <[email-masked]>
Date: Wed, 16 Oct 2019 06:33:17 -0700

Only the author of this PR and editors of the spec ever commented on this editorial issue.  This indicates to me that this issue is insignificant.  I encourage any of the editors to just make a decision on where Base should point or if it should appear on the drawing at all.  I'm happy to implement that so that we can cross this PR off the list.

If the decision is that Base should point between two elements, or that it should be removed from the drawing, then I suggest adding text specifying that Base = n-2.

By the way it just occurred to me that RIC does not belong to this diagram at all.  In fact it is possible that a header block does not reference the most recently inserted element, in which case RIC has a different value than currently indicated.

In my mental model Base is neither an index nor a count.  It is an integer that the encoder sends to the decoder, which is then used for arithmetics described in the spec to convert between absolute and relative indices.  I'm not convinced that renaming it to Base Count would increase clarity.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-542702765

---

From: afrind <[email-masked]>
Date: Wed, 16 Oct 2019 09:28:56 -0700

In a one-pass encoder, Base is the Insert Count when the encoder begins encoding the block.  In a two-pass encoder, I assume most folks set Base = RIC.  So I think it logically is a count, but lets put aside whether to rename it since that's not happening in this PR.

For now, I say remove RIC from the figure, but leave the arrow where it is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-542784731

---

From: Bence Béky <[email-masked]>
Date: Wed, 16 Oct 2019 10:59:38 -0700

9647009c5e7454d82f95264797681b5fda1922ef  Move arrows back to original position; add Base value to figure.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935/files/06607c16e38dce809672e43b990905dbd334619d..9647009c5e7454d82f95264797681b5fda1922ef

---

From: Bence Béky <[email-masked]>
Date: Wed, 16 Oct 2019 11:02:05 -0700

> For now, I say remove RIC from the figure, but leave the arrow where it is.

Sounds good to me.  Let me add text specifying the Base value because it is not clear for those not familiar with the "indices point between elements" mental model or would be confused by the element with a given index being the one not on the right of the arrow but on the left.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#issuecomment-542821859

---

From: afrind <[email-masked]>
Date: Tue, 22 Oct 2019 15:35:46 -0700

Merged #2935 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2935#event-2735052695