Subject: [quicwg/base-drafts] Server sends a PING-only packet if it's limited (#3162)

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:03:22 -0700

If a server is limited by the amplification factor when the PTO expires, send a PING-only packet instead of sending nothing.

This also removes the client complexity of continuing to arm the PTO and send even when there&#39;s nothing in flight and nothing to send.

Fixes #3161 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3162

-- Commit Summary --

  * Server sends a PING-only packet if it&#39;s limited

-- File Changes --

    M draft-ietf-quic-recovery.md (33)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3162.patch
https://github.com/quicwg/base-drafts/pull/3162.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:04:53 -0700

@ianswett pushed 1 commit.

efae6564080e5c07190b3a08c3132db68d727d1e  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162/files/f4ef38a26a8fc64277204ab4b066e38a82e5ea35..efae6564080e5c07190b3a08c3132db68d727d1e

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:05:45 -0700

1a6d987374ccccb29b6008da5fde6b250c8d1374  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162/files/efae6564080e5c07190b3a08c3132db68d727d1e..1a6d987374ccccb29b6008da5fde6b250c8d1374

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:06:11 -0700

077f77265c2e192dd641f3557779ac607e0426a1  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162/files/1a6d987374ccccb29b6008da5fde6b250c8d1374..077f77265c2e192dd641f3557779ac607e0426a1

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:07:40 -0700

325920a2ee43499dc400cb133b5cd5c13b455eb8  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162/files/077f77265c2e192dd641f3557779ac607e0426a1..325920a2ee43499dc400cb133b5cd5c13b455eb8

---

From: martinduke <[email-masked]>
Date: Mon, 28 Oct 2019 11:10:37 -0700

martinduke approved this pull request.

Should we also edit section 8.1 of quic-transport to specify that Ping-only PTO is an exception?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162#pullrequestreview-308049228

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 11:51:15 -0700

ec7cf1dce6824eed3d3d69da33034e62a44ba9c6  Update transport to allow a PING-only packet

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162/files/325920a2ee43499dc400cb133b5cd5c13b455eb8..ec7cf1dce6824eed3d3d69da33034e62a44ba9c6

---

From: Nick Banks <[email-masked]>
Date: Mon, 28 Oct 2019 11:59:59 -0700

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162#pullrequestreview-308078681

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 12:05:23 -0700

Transport section 8.1 updated to allow a PING-only packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3162#issuecomment-547099661