Subject: [quicwg/base-drafts] Is CONNECTION_CLOSE ACK-eliciting? (#3097)

From: Kazuho Oku <[email-masked]>
Date: Tue, 15 Oct 2019 21:36:34 -0700

At the moment, we state that _a QUIC packet that contains frames other than ACK and PADDING_ ([section 1.2](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.1.2)), but I wonder if that is true for CONNECTION_CLOSE frame.

A CONNECTION_CLOSE frame never elicits an acknowledgment. IIUC, it is not meant to be governed by the congestion controller.

Considering the aspects, I think we should add CONNECTION_CLOSE to the list of *non-*ACK-eliciting frames.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097

---

From: ianswett <[email-masked]>
Date: Tue, 15 Oct 2019 21:44:05 -0700

That also ensures the congestion controller never inadvertently blocks sending a CONNECTION_CLOSE, which is consistent with the intent.

If we make this change, I believe APPLICATION_CLOSE needs to be on the list as well.

Now that we discuss ack-eliciting in transport, I think we'd need to change both transport and recovery and mark this design.

So I think this would be a slight improvement, but I an also imagine people claiming that CONNECITON_CLOSE is already special, so there's no need for a change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097#issuecomment-542511267

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Oct 2019 08:30:47 -0700

APPLICATION_CLOSE is no more.  This seems like a fine change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097#issuecomment-542759028

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 16 Oct 2019 09:42:29 -0700

This seems sensible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097#issuecomment-542789988

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 15:33:00 -0700

Discussed in Cupertino. Obvious correction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097#issuecomment-542918511

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:29:17 -0700

Closed #3097 via #3098.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3097#event-2758500702