Subject: [quicwg/base-drafts] MUST limit bursts to the initial congestion window (#3160)

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 07:12:30 -0700

>From discussion on #3106 people prefer the normative text to apply to the initial congestion window, not the specific value recommended in the recovery document.
https://github.com/quicwg/base-drafts/pull/3106#discussion_r338921935
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3160

-- Commit Summary --

  * MUST limit bursts to the initial congestion window

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3160.patch
https://github.com/quicwg/base-drafts/pull/3160.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160

---

From: ianswett <[email-masked]>
Date: Mon, 28 Oct 2019 07:13:23 -0700

@ianswett pushed 1 commit.

bc27ab1719ed440795fcd086b93a7bb0373f0dd7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160/files/568febf40a21f538abe126d8598e5b45ce21ec31..bc27ab1719ed440795fcd086b93a7bb0373f0dd7

---

From: martinduke <[email-masked]>
Date: Mon, 28 Oct 2019 10:36:27 -0700

I approve of this editorial change

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160#issuecomment-547062148

---

From: martinduke <[email-masked]>
Date: Mon, 28 Oct 2019 10:36:36 -0700

martinduke approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160#pullrequestreview-308027284

---

From: Martin Thomson <[email-masked]>
Date: Mon, 28 Oct 2019 20:37:13 -0700

martinthomson approved this pull request.

> @@ -744,9 +744,9 @@ their delivery to the peer.
 
 Sending multiple packets into the network without any delay between them
 creates a packet burst that might cause short-term congestion and losses.
-Implementations MUST either use pacing or limit such bursts to the minimum
-of 10 * kMaxDatagramSize and max(2* kMaxDatagramSize, 14720)), the same
-as the recommended initial congestion window.
+Implementations MUST either use pacing or limit such bursts to the initial
+congestion window, which is recommended to be the min of

```suggestion
congestion window, which is recommended to be the minimum of
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160#pullrequestreview-308260438

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 04:08:57 -0700

7b268f0e6818ff0ceadeb6642ef461c0b8890a79  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160/files/bc27ab1719ed440795fcd086b93a7bb0373f0dd7..7b268f0e6818ff0ceadeb6642ef461c0b8890a79

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 04:11:07 -0700

Merged #3160 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3160#event-2751722413