Subject: [quicwg/base-drafts] NEW_TOKEN and Retry tokens must be distinguishable (#3127)

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Oct 2019 19:45:16 -0700

We currently say that these tokens SHOULD be distinguishable by a server on the basis that an error in a NEW_TOKEN token is recoverable, but an error in a Retry token is fatal.  I don't see why this can't be MUST.  If we make it "MUST", then we can rely on this property in the design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3127

---

From: ianswett <[email-masked]>
Date: Mon, 21 Oct 2019 19:49:16 -0700

Agreed, that'd be a useful property to rely on.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3127#issuecomment-544785697

---

From: Marten Seemann <[email-masked]>
Date: Mon, 21 Oct 2019 20:04:09 -0700

Does that property need to hold if there are bit flips in the token?
If you’re encrypting the token, this would be easy to ensure: put the distinguishing bit under crypto cover. If you’re using a map lookup, you’ll probably have to work a little bit harder.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3127#issuecomment-544787934

---

From: Marten Seemann <[email-masked]>
Date: Mon, 21 Oct 2019 20:12:15 -0700

Please ignore my last post, I mixed up Retry packets and Initials. Tokens in the client’s Initial are part of the AAD, so we don’t have to worry about bit flips.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3127#issuecomment-544789089