Subject: [quicwg/base-drafts] ACK+PADDING in response to ACK should be illegal (#3100)

From: martinduke <[email-masked]>
Date: Wed, 16 Oct 2019 14:10:20 -0700

quic-transport draft 13.2.1:

An endpoint MUST NOT send a packet containing
   only an ACK frame in response to a non-ACK-eliciting packet (one
   containing only ACK and/or PADDING frames),

@marten-seemann points out that this allows one to send an ACK+PADDING packet, which seems to violate the spirit of the rule. This loophole breaks #3093. I believe this may be Editorial if we all know what we meant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3100

---

From: ianswett <[email-masked]>
Date: Wed, 16 Oct 2019 14:50:15 -0700

Yes, it was intended that ACK should not elicit an ACK+PADDING packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3100#issuecomment-542906236

---

From: Marten Seemann <[email-masked]>
Date: Wed, 16 Oct 2019 14:53:32 -0700

I agree with this change, but I disagree that this is a satisfactory fix for #3093.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3100#issuecomment-542907308

---

From: Marten Seemann <[email-masked]>
Date: Tue, 22 Oct 2019 19:19:03 -0700

This issue should have been closed by #3104.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3100#issuecomment-545233603

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Oct 2019 19:19:54 -0700

Closed #3100.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3100#event-2735394914