Subject: Re: [quicwg/base-drafts] Handling of Retire Prior To field (#3046)

From: Kazuho Oku <[email-masked]>
Date: Tue, 01 Oct 2019 09:29:10 -0700

While I agree that we have tried to make MUST requirements testable, I am not certain if it is a goo idea to avoid use of MUST when a requirement cannot be tested (or if doing so is a good idea, per the definition of the keywords in RFC 2119).

At least for this particular case, isn't it a requirement for an endpoint to drop the old connection IDs?

Though I could well be wrong though in how the keywords are used in practice.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3046#issuecomment-537117388

---

From: Nick Banks <[email-masked]>
Date: Tue, 01 Oct 2019 09:32:50 -0700

I'm fine saying MUST drop in a timely manner, and being explicit about what we mean by timely manner (3 PTO from the peer's perspective). Obviously, from the peer's perspective, that is enforceable. Locally though, it's obviously not as clear cut.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3046#issuecomment-537118795

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Oct 2019 13:44:10 -0700

We need a PR.  @kazuho, do you think that you can do this?  As discussed, should be that the receiving side will retire within one PTO.  The sending side can enforce at 3PTO, by dropping the connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3046#issuecomment-542396357

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 15:14:24 -0700

Discussed in Cupertino. @kazuho to quickly rev the PR to incorporate @martinthomson's suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3046#issuecomment-542913602

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:31:07 -0700

Closed #3046 via #3096.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3046#event-2758503408