Subject: [quicwg/base-drafts] 0-RTT is still optional (#3136)

From: Mike Bishop <[email-masked]>
Date: Wed, 23 Oct 2019 11:12:43 -0700

In [Section 5.4](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#rfc.section.5.4), we say that one of the required operations on a connection is "enable 0-RTT".

@mikkelfj [asks](https://github.com/quicwg/base-drafts/pull/2857/files_):
> But why does an application need to be able to enable 0-RTT? Isn't 0-RTT optional at transport level, and more so at the app level?

The current text implies that implementations are required to support 0-RTT, which is not the case.  It would be more correct to say that applications must be able to prevent early data from being offered on a connection, even if the implementation supports it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3136

---

From: Mike Bishop <[email-masked]>
Date: Wed, 23 Oct 2019 11:15:10 -0700

Alternately, the server section prefaces certain bullets with "If Early Data is supported, ...."  That formulation might be used here as well.

Also, this section uses "0-RTT" in the client piece but "Early Data" in the server piece.  Should be consistent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3136#issuecomment-545570921

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Oct 2019 15:48:54 -0700

Closed #3136 via #3138.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3136#event-2754070248