Subject: [quicwg/base-drafts] token-based greasing / initial packet protection (downgradable variant) (#3178)

From: Kazuho Oku <[email-masked]>
Date: Thu, 31 Oct 2019 00:09:01 -0700

There seem to be split views on if the greasing should be downgradable.

This PR is a variant of #3166 that allows downgrade.

The design rationale is that a downgrade attack by a middlebox should be detectable, though it reveals the payload of the Initial packet.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3178

-- Commit Summary --

  * first cut
  * editorial
  * define downgrade prevention
  * clarify the requirement when building a token
  * editorial
  * protect token using checksum (reusing text from #3120 by @DavidSchinazi)
  * use list for implementation guidance, applying @DavidSchnazi&#39;s suggestions
  * clarify what can be associated with the token, adopting @MikeBishop&#39;s suggestion
  * s/comprises of/contains/ (@MikeBishop)
  * use &quot;Long Packet Type&quot; (@DavidSchinazi)
  * swap reserved bits and packet type modifier (suggested by @martinthomson)
  * long packet types when encoded in a long header packet is an XOR (@martinthomson)
  * clarify how a server can opt-out
  * Revert &quot;protect token using checksum (reusing text from #3120 by @DavidSchinazi)&quot;
  * no more downgrade
  * server always announce (though it can effectively opt-out)
  * delete VERSION_NEGOTIATION_ERROR (once again)
  * clarify how to handle Retry, as well as stating that a fixed mapping bet. versions and salts is better than nothing
  * add Lifetime field
  * Update draft-ietf-quic-transport.md
  * @MikeBishop&#39;s suggestions; https://github.com/quicwg/base-drafts/pull/3166#discussion_r340822271
  * oops, amend the previous commit
  * fix typo, emphasize that this is just an example
  * Rephrase as &quot;seeding&quot;; The default of &quot;alternative&quot; being the standard values has been confusing
  * define the downgrade process; that lets the server detect downgrade attack

-- File Changes --

    M draft-ietf-quic-transport.md (162)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3178.patch
https://github.com/quicwg/base-drafts/pull/3178.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3178

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 31 Oct 2019 00:10:38 -0700

@kazuho pushed 1 commit.

dbac83112b888845920ed30db91917f6bb32d8f3  wordwrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3178/files/08077028ffc5852e2375e328988c484f488f5734..dbac83112b888845920ed30db91917f6bb32d8f3

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 31 Oct 2019 04:51:12 -0700

@kazuho pushed 7 commits.

3caa73ef9279f8ff867c12943415f006a5fd41da  Update draft-ietf-quic-transport.md
ead19c004bd4ba063eeb9dcef0217f1322dff7d7  Update draft-ietf-quic-transport.md
bd45b3740c8323bdbe9a2a31fe600a8a23c122ee  Update draft-ietf-quic-transport.md
0a45df175f7a3cdb8a58bdbe2fceede5c3f11f05  Update draft-ietf-quic-transport.md
d683da83643b996412c7852beaf0e8da6427bfc9  wordwrap
febd89944d6481428987be6122b9299b8e686da0  s/PRF/CSPRNG/ for clarification
26d62d17b48f9275b3b3ef770d267021e413e624  Merge branch 'kazuho/new-token-with-alias' into kazuho/new-token-with-alias-downgradable

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3178/files/dbac83112b888845920ed30db91917f6bb32d8f3..26d62d17b48f9275b3b3ef770d267021e413e624