Subject: Re: [quicwg/base-drafts] ack-eliciting not ACK-eliciting (#3069)

From: Jana Iyengar <[email-masked]>
Date: Thu, 03 Oct 2019 16:57:02 -0700

janaiyengar approved this pull request.

One nit, but LGTM.

> @@ -190,6 +190,11 @@ QUIC packet:
 : A complete processable unit of QUIC that can be encapsulated in a UDP
   datagram.  Multiple QUIC packets can be encapsulated in a single UDP datagram.
 
+Ack-eliciting Packet:
+
+: A QUIC packet that contains frames other than ACK and PADDING. These cause a
+  recipient to send an acknowledgment within the maximum ack delay.

```suggestion
  recipient to send an acknowledgment within its maximum ACK delay ({{transport-parameter-definitions}}).
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#pullrequestreview-297209513

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 17:00:55 -0700

@ianswett pushed 1 commit.

a329e7cd3756fcdb345c79650142c0ac2a51b3cf  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/030e4b5584d2768c3dacc88bc286633437de1c46..a329e7cd3756fcdb345c79650142c0ac2a51b3cf

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 17:01:47 -0700

9e5a680f258260d3acdafa161232e70bc1340cb2  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/a329e7cd3756fcdb345c79650142c0ac2a51b3cf..9e5a680f258260d3acdafa161232e70bc1340cb2

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 03 Oct 2019 17:12:23 -0700

janaiyengar commented on this pull request.

Sorry, that sentence seems to suggest that ack-eliciting packets have something to do with max ack delay. I've rephrased again.

> @@ -190,6 +190,12 @@ QUIC packet:
 
+Ack-eliciting Packet:
+
+: A QUIC packet that contains frames other than ACK and PADDING. These cause a
+  recipient to send an acknowledgment within its maximum ACK delay

```suggestion
  recipient to send an acknowledgment (see {{sending-acknowledgements}}).
```

> @@ -190,6 +190,12 @@ QUIC packet:
 
+Ack-eliciting Packet:
+
+: A QUIC packet that contains frames other than ACK and PADDING. These cause a
+  recipient to send an acknowledgment within its maximum ACK delay
+  ({{transport-parameter-definitions}}).

```suggestion
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#pullrequestreview-297213345

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 17:18:48 -0700

95606b78e172ae3713e9ed8e4524a78a537f952b  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/9e5a680f258260d3acdafa161232e70bc1340cb2..95606b78e172ae3713e9ed8e4524a78a537f952b

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 17:18:56 -0700

690a9b954cc71b9835fa0fe889b429e025e8cc6d  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/95606b78e172ae3713e9ed8e4524a78a537f952b..690a9b954cc71b9835fa0fe889b429e025e8cc6d

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 17:25:08 -0700

c54b0dcd5a5b2a4441e30f989721f883ef7d1df6  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069/files/690a9b954cc71b9835fa0fe889b429e025e8cc6d..c54b0dcd5a5b2a4441e30f989721f883ef7d1df6

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 18:16:13 -0700

Merged #3069 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3069#event-2685907027