Subject: [quicwg/base-drafts] kMaxDatagramSize -> max_datagram_size (#3167)

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 15:00:33 -0700

Clarifies that this is the maximum datagram size currently in use on the connection.

Fixes #3041
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3167

-- Commit Summary --

  * kMaxDatagramSize -&gt; max_datagram_size

-- File Changes --

    M draft-ietf-quic-recovery.md (19)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3167.patch
https://github.com/quicwg/base-drafts/pull/3167.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Oct 2019 15:30:27 -0700

martinthomson approved this pull request.

> @@ -1258,6 +1254,11 @@ kPersistentCongestionThreshold:
 Variables required to implement the congestion control mechanisms
 are described in this section.
 
+max_datagram_size:
+: The sender's current maximum payload size. Does not include UDP or IP
+  overhead.  The max datagram size is used for calculating initial and
+  minimum congestion windows. The RECOMMENDED value is 1200 bytes.

This can't be less than 1200.  Worth adding?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167#pullrequestreview-308873549

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 15:36:29 -0700

@ianswett pushed 1 commit.

9309a0ac194307cf002b92d965403ee08d882500  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/f436b81a90eb36ddfa14eb7862cec142a128a5be..9309a0ac194307cf002b92d965403ee08d882500

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 15:40:23 -0700

19200d397bd9bef6a81151169111597b3edcbcc6  Cite 14.1 of Transport

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/9309a0ac194307cf002b92d965403ee08d882500..19200d397bd9bef6a81151169111597b3edcbcc6

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 15:45:34 -0700

ianswett commented on this pull request.

+max_datagram_size:

Done, PTAL.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167#discussion_r340361135

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 16:00:14 -0700

e8b1251eb9a99928db70c8cc44df5c3bccff5373  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/19200d397bd9bef6a81151169111597b3edcbcc6..e8b1251eb9a99928db70c8cc44df5c3bccff5373

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 29 Oct 2019 16:25:04 -0700

janaiyengar requested changes on this pull request.

> @@ -1258,6 +1255,12 @@ kPersistentCongestionThreshold:
 
+max_datagram_size:
+: The sender's current maximum payload size. Does not include UDP or IP
+  overhead.  The max datagram size is used for calculating initial and
+  minimum congestion windows. The RECOMMENDED value is 1200 bytes, may be

I think this is actually wrong. (i) It's used for computing cwnd increases as well, but I would drop that list, and (ii) we don't need to recommend 1200, we need to require at least 1200, in keeping with the transport draft.

```suggestion
The sender's current maximum payload size. Does not include UDP or IP overhead.  The max datagram size is used for calculating  minimum congestion windows. An endpoint sets the value of this variable based on its PMTU, with a minimum value of 1200 bytes (see Section 14 of {{QUIC-TRANSPORT}}).
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167#pullrequestreview-308887171

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 16:48:06 -0700

b1ff885bd354b9218e37b00de1366904335210e7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/e8b1251eb9a99928db70c8cc44df5c3bccff5373..b1ff885bd354b9218e37b00de1366904335210e7

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 16:50:34 -0700

d27a37d1d171440cde763c730e4dc4d7bd245180  Jana's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/b1ff885bd354b9218e37b00de1366904335210e7..d27a37d1d171440cde763c730e4dc4d7bd245180

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 16:51:13 -0700

48573bf0a5755e0f341aed6f6124cad13537bc1a  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/d27a37d1d171440cde763c730e4dc4d7bd245180..48573bf0a5755e0f341aed6f6124cad13537bc1a

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 16:58:06 -0700

ed3b3f93ef292a596e827e56aab78eca1e2b6688  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/48573bf0a5755e0f341aed6f6124cad13537bc1a..ed3b3f93ef292a596e827e56aab78eca1e2b6688

---

From: ianswett <[email-masked]>
Date: Tue, 29 Oct 2019 17:11:46 -0700

2d5f46faab5cf09442fff533c89d499e4f80fc6c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/ed3b3f93ef292a596e827e56aab78eca1e2b6688..2d5f46faab5cf09442fff533c89d499e4f80fc6c

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 29 Oct 2019 17:17:57 -0700

janaiyengar commented on this pull request.

another fix

> @@ -1258,6 +1254,13 @@ kPersistentCongestionThreshold:
 
+max_datagram_size:
+: The sender's current maximum payload size. Does not include UDP or IP
+  overhead.  The max datagram size is used for calculating the minimum

Used for min, init, and cwnd increases, not just for min.
```suggestion
  overhead.  The max datagram size is used for congestion window
```

> @@ -1258,6 +1254,13 @@ kPersistentCongestionThreshold:
 
+max_datagram_size:
+: The sender's current maximum payload size. Does not include UDP or IP
+  overhead.  The max datagram size is used for calculating the minimum
+  congestion window. An endpoint sets the value of this variable based on its

```suggestion
  computations. An endpoint sets the value of this variable based on its
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167#pullrequestreview-308906634

---

From: ianswett <[email-masked]>
Date: Wed, 30 Oct 2019 05:58:40 -0700

52b3c343033b749355dfa8d34421a651f69238e5  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/2d5f46faab5cf09442fff533c89d499e4f80fc6c..52b3c343033b749355dfa8d34421a651f69238e5

---

From: ianswett <[email-masked]>
Date: Wed, 30 Oct 2019 05:58:46 -0700

694975600a94a0244dce16e54559c60fde771c79  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/52b3c343033b749355dfa8d34421a651f69238e5..694975600a94a0244dce16e54559c60fde771c79

---

From: ianswett <[email-masked]>
Date: Wed, 30 Oct 2019 05:59:54 -0700

cf63bd95f00d0cf7b48253742237b69f218c24aa  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/694975600a94a0244dce16e54559c60fde771c79..cf63bd95f00d0cf7b48253742237b69f218c24aa

---

From: ianswett <[email-masked]>
Date: Thu, 31 Oct 2019 14:46:51 +0000 (UTC)

373b0abdb02c74076c6dcfa87552e3946bcf1eb2  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3167/files/cf63bd95f00d0cf7b48253742237b69f218c24aa..373b0abdb02c74076c6dcfa87552e3946bcf1eb2