Subject: [quicwg/base-drafts] Make language of representations consistent. (#3133)

From: Bence Béky <[email-masked]>
Date: Tue, 22 Oct 2019 16:37:30 -0700

This was inspired by the comment by afrind at
https://github.com/quicwg/base-drafts/pull/2942#discussion_r335222617.

For each representation, uniformly
* use the word &quot;representation&quot; in the first sentence;
* use the word &quot;identifies&quot; if it&#39;s a verbatim entry; &quot;encodes&quot; otherwise;
* identify relative versus post-base indexing in the first sentence;
* move drawing right after first sentence;
* use consistent language describing binary format.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3133

-- Commit Summary --

  * Make language of representations consistent.

-- File Changes --

    M draft-ietf-quic-qpack.md (95)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3133.patch
https://github.com/quicwg/base-drafts/pull/3133.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133

---

From: Mike Bishop <[email-masked]>
Date: Mon, 28 Oct 2019 08:42:06 -0700

MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133#pullrequestreview-307946859

---

From: afrind <[email-masked]>
Date: Tue, 29 Oct 2019 14:13:23 -0700

afrind commented on this pull request.

> @@ -965,9 +965,8 @@ entry.
 
 ### Indexed Header Field
 
-An indexed header field representation identifies an entry in either the static
-table or the dynamic table and causes that header field to be added to the
-decoded header list.
+An indexed header field representation identifies an entry in the static table,
+or an entry in the dynamic table with an absolute index less than the Base.

I now find the comparison of absolute index and "Base" (which I assert is a count) to be awkward.  Does it read better with 

> less than the *value of* the Base

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133#pullrequestreview-308837957

---

From: afrind <[email-masked]>
Date: Tue, 29 Oct 2019 14:17:31 -0700

### Indexed Header Field

We can tackle this in another PR.  This is all goodness so I'm merging now :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133#discussion_r340330192

---

From: afrind <[email-masked]>
Date: Tue, 29 Oct 2019 14:17:50 -0700

Merged #3133 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133#event-2753841792

---

From: Bence Béky <[email-masked]>
Date: Wed, 30 Oct 2019 17:07:35 +0000 (UTC)

bencebeky commented on this pull request.

 ### Indexed Header Field

I do not feel strongly, but I was happy to draft #3175 to address this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3133#discussion_r340746082