Subject: [quicwg/base-drafts] Explicit linkages for ODCID/OCID TP (#3149)

From: Mike Bishop <[email-masked]>
Date: Thu, 24 Oct 2019 12:52:21 -0700

Fixes #2926.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3149

-- Commit Summary --

  * Explicit linkages for ODCID/OCID TP

-- File Changes --

    M draft-ietf-quic-transport.md (14)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3149.patch
https://github.com/quicwg/base-drafts/pull/3149.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149

---

From: Mike Bishop <[email-masked]>
Date: Thu, 24 Oct 2019 12:53:30 -0700

Note that #3120 may want to change the phrasing of the ODCID field, depending on which PR lands first.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149#issuecomment-546076471

---

From: Martin Thomson <[email-masked]>
Date: Thu, 24 Oct 2019 14:30:29 -0700

martinthomson requested changes on this pull request.

There's a conflict imminent here.

> @@ -4412,9 +4412,10 @@ The following transport parameters are defined:
 original_connection_id (0x0000):
 
 : The value of the Destination Connection ID field from the first Initial packet
-  sent by the client.  This transport parameter is only sent by a server.  A
-  server MUST include the original_connection_id transport parameter if it sent
-  a Retry packet.
+  sent by the client.  This transport parameter is only sent by a server.  This
+  is the same value sent in the "Original Destination Connection ID" field of a
+  Retry packet (see {{packet-retry}}).  A server MUST include the

Note that David's proposal for integrity protection of the Retry packet changes this text to point to the original Initial sent by the client.  You should probably do the same.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149#pullrequestreview-306876405

---

From: Mike Bishop <[email-masked]>
Date: Tue, 29 Oct 2019 08:36:41 -0700

MikeBishop commented on this pull request.

Can you point to the specific text you're looking at?

David's text in #3120:
> value of the Destination Connection ID from the Initial packet that this Retry is in response to.

Text here:
> value of the Destination Connection ID field from the first Initial packet sent by the client

These seem to indicate the same Initial packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149#discussion_r340154472

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Oct 2019 16:16:52 -0700

martinthomson approved this pull request.

I might have misremembered, sorry.  In #3120, the text I was concerned about was

> If the server sends a Retry packet, it MUST include the Destination Connection ID field from the client's first Initial packet in the transport parameter.

But you didn't touch that. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149#pullrequestreview-308889421

---

From: Martin Thomson <[email-masked]>
Date: Tue, 29 Oct 2019 16:17:00 -0700

Merged #3149 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3149#event-2754127443