Subject: [quicwg/base-drafts] Recommend algorithm for packet scheduler, rather than implementation (#3122)

From: MikkelFJ <[email-masked]>
Date: Thu, 17 Oct 2019 22:09:26 -0700

The current text in recovery says:

> As an example of a well-known and publicly available implementation of a flow pacer, implementers are referred to the Fair Queue packet scheduler (fq qdisc) in Linux (3.11 onwards).

Could we change this recommendation to something like "a Fair Queue packet scheduler using an algorithm such as "Weighted Round Robin" or "Deficit Round Robin"? The specific Linux reference is not very helpful in online searches.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122

---

From: ianswett <[email-masked]>
Date: Fri, 18 Oct 2019 15:01:01 -0700

The interesting part about the the Linux qdisc is its support for rate-based packet pacing, not it's fair queueing algorithm.  Would it help to make that more clear or provide a reference such as: http://man7.org/linux/man-pages/man8/tc-fq.8.html

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122#issuecomment-543971554

---

From: MikkelFJ <[email-masked]>
Date: Fri, 18 Oct 2019 23:07:01 -0700

Not really, this is the first (and almost only) thing you find and it tells you very little about queueing algorithms.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122#issuecomment-544105952