Subject: [quicwg/base-drafts] Does a client need to remember SETTINGS it doesn't understand when doing 0-RTT resumption? (#3110)

From: Nick Harper <[email-masked]>
Date: Thu, 17 Oct 2019 16:49:12 +0000 (UTC)

The HTTP draft currently specifies

>  If a server accepts 0-RTT, but then sends a SETTINGS frame which reduces a setting the client understands or omits a value that was previously specified to have a non-default value, this MUST be treated as a connection error of type HTTP_SETTINGS_ERROR.

Is it intentional that a client MUST remember SETTINGS values that it doesn't support (to check that the server didn't omit a setting)?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 17 Oct 2019 09:54:12 -0700

The comment about checking for omitted settings says ... "omits a value that was previously specified to have a non-default value". In order for a client to know what the default value is for that setting, surely the client must support that setting, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110#issuecomment-543266193

---

From: Nick Harper <[email-masked]>
Date: Thu, 17 Oct 2019 10:02:37 -0700

You're right that for the client to know whether or not it's the default value it needs to support the setting (or at least know about it).

Suppose the server sends SETTING BLORP (which the client knows nothing about) with value X in the original SETTINGS, but omits it on the 0-RTT resumed connection. As currently specified, if value X is not the default value, the client MUST close the connection, but if it is the default value, then that's fine. (Meaning the client needs to know all possible default values for all possible settings.)

I think this needs an editorial fix to apply something like "a setting the client understands" to the bit about omitting a value as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110#issuecomment-543269545

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 17 Oct 2019 10:09:32 -0700

Oh, I see your reading now. Interesting! Good point about an editorial tweak.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110#issuecomment-543272250

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 17 Oct 2019 10:12:30 -0700

I think this could affect reserved settings (aka grease) too, just in a slightly different way. Some editorial tweak to address the problem would be good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110#issuecomment-543273349

---

From: Mike Bishop <[email-masked]>
Date: Thu, 24 Oct 2019 20:01:48 +0000 (UTC)

Closed #3110 via #3113.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3110#event-2742041933