Subject: Re: [quicwg/base-drafts] Allow PING in Initial/Handshake? (#3034)

From: martinduke <[email-masked]>
Date: Tue, 01 Oct 2019 13:14:22 -0700

The case that I found interop was that my client and one packet's worth of unacknowledged data. In the 1-RTT case, I'd just send the data in the first probe and then a PING in the second probe.

Since I can't do that for Handshake, I have two unattractive options:
- send only one probe, reducing the probability of success
- introduce special logic to spread out the data into two packets with a CRYPTO frame (gross)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3034#issuecomment-537209381

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Oct 2019 15:33:59 -0700

@martinduke : So, you are in favor of sending PINGs in the handshake, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3034#issuecomment-539731975

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 08 Oct 2019 16:22:54 -0700

@martinduke 
> * introduce special logic to spread out the data into two packets with a CRYPTO frame (gross)

IIUC, CRYPTO(off=0,len=0) can be used as a replacement for PING. There is no need to have special logic to spread out the data. So it's not as gross as it seems.

That said, considering the fact that we have PING in 1-RTT even though CRYPTO(off=0,len=0) can be used instead in 1-RTT also, I do not think there is a reason to argue *against* having PINGs for Initial and Handshake too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3034#issuecomment-539745308

---

From: martinduke <[email-masked]>
Date: Tue, 08 Oct 2019 16:46:32 -0700

@janaiyengar It is the most straightforward way to send PTO and I see no downside, so yes.

That said, I know that many of our mechanisms (e.g. discarding keys) bake in assumptions about the handshake and who sends what and when, so maybe we should examine the implications of, for example, a client sending a Handshake PING before it gets any Handshake packets from the server.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3034#issuecomment-539750595

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Oct 2019 09:57:34 -0700

Closed #3034 via #3035.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3034#event-2714744497