Subject: [quicwg/base-drafts] Stateless reset detection should be datagram-based (#3085)

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Oct 2019 16:48:57 -0700

This will make the process more robust, as the process of splitting a datagram into packets could cause the token to be split.  We recommend sending a packet (and one that can't be coalesced to boot).  This was always going to be a single packet datagram anyway, so this shouldn't affect implementations much.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3085

---

From: Martin Thomson <[email-masked]>
Date: Wed, 09 Oct 2019 16:50:29 -0700

Not sure if this is editorial or not. We already require *sending* to be a whole datagram: 

> A stateless reset uses an entire UDP datagram, [...]

So this could be seen to match things up.  But it could require code changes in implementations, so I'm leaning toward `design`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3085#issuecomment-540253307

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 14:15:47 -0700

Discussed in Cupertino. #2993 to be merged following consensus call.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3085#issuecomment-542894922

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:29:37 -0700

Closed #3085 via 03979a0235d6fd3ff79555911c79bc5c10e2b61a.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3085#event-2758501063