Subject: [quicwg/base-drafts] Be more specific when naming bits (#3089)

From: Robin Marx <[email-masked]>
Date: Sun, 13 Oct 2019 03:49:30 -0700

- Renamed S bit for static vs dynamic table to T bit (for Table)
- Replaced backticks with single quotes around individual bits (previously, about half used single, half used double)
- Added explicit references to bit letter indicators where they were missing (e.g., for &#39;H&#39;)
- Fixed broken reference to &quot;blocked-decoding&quot; section
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3089

-- Commit Summary --

  * Be more specific when naming bits

-- File Changes --

    M draft-ietf-quic-qpack.md (44)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3089.patch
https://github.com/quicwg/base-drafts/pull/3089.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 13 Oct 2019 03:57:21 -0700

LPardue commented on this pull request.

> @@ -311,7 +311,7 @@ instructions received on the encoder stream.
 The decoder MUST emit header fields in the order their representations appear in
 the input header block.
 
-### Blocked Decoding
+### Blocked Decoding  {#blocked-decoding}

I think auto anchoring should mean this is not required (I.e. only need to define explicit links that differ from the section title)

> @@ -682,10 +682,10 @@ acknowledged as this instruction does not insert an entry.
 An encoder adds an entry to the dynamic table where the header field name
 matches the header field name of an entry stored in the static or the dynamic
 table using an instruction that starts with the '1' one-bit pattern.  The second
-(`S`) bit indicates whether the reference is to the static or dynamic table. The
+('T') bit indicates whether the reference is to the static or dynamic table. The

T seems odd to me because they both use a table. And then we have T=1 meaning that it's the static table.

Are we really so constrained that we can't assign a noun to bits?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#pullrequestreview-301043507

---

From: Robin Marx <[email-masked]>
Date: Sun, 13 Oct 2019 12:18:44 -0700

rmarx commented on this pull request.

-### Blocked Decoding

A) did not know about auto-anchoring
B) seems like it didn't work for this specific one, since draft-10 of the qpack document has an unresolved reference to the section (see https://tools.ietf.org/html/draft-ietf-quic-qpack-10#section-2.1.3). Not sure why that's failing then...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334292071

---

From: Robin Marx <[email-masked]>
Date: Sun, 13 Oct 2019 12:20:57 -0700

My main gripe was that we were using S with two different meanings (Sign bit and "Static Table bit"). On slack, @afrind was ok with T, so I went with that. I see it as a table "index" personally, which makes sense to me. 

But really, I don't care which letter or noun is used, as long as the same letter/noun isn't used for different things. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334292158

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Oct 2019 12:02:05 -0700

MikeBishop commented on this pull request.

-### Blocked Decoding

The reference in 2.1.3 should have `{{` instead of `{`, looks like.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334621164

---

From: Robin Marx <[email-masked]>
Date: Mon, 14 Oct 2019 12:09:18 -0700

@rmarx pushed 1 commit.

479c7d0f6e65b2146ac2bfc19e22a5a51fc676fa  Hopefully auto-linking does work now

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089/files/225dc1a18ab070d590f1f728771dd4ab0dea3f4b..479c7d0f6e65b2146ac2bfc19e22a5a51fc676fa

---

From: Robin Marx <[email-masked]>
Date: Mon, 14 Oct 2019 12:09:55 -0700

-### Blocked Decoding

Aha, that might do the trick. Did that instead in 479c7d0

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334623701

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Oct 2019 12:57:10 -0700

-### Blocked Decoding

Just built it locally to confirm; it works now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334639010

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Oct 2019 12:58:30 -0700

I'm fine with it being an index of the tables.  In my mind (thanks in part to HPACK) the static table comes "first," so it feels a little weird that it's 1 vs. 0, but that's probably better than turning something purely editorial into a needless breaking change at this point.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r334639464

---

From: afrind <[email-masked]>
Date: Tue, 15 Oct 2019 17:03:32 -0700

afrind commented on this pull request.

I'm fine with T.  T=1 -> Static is a little weird I guess, but you can just think about it as the sTatic table bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#discussion_r335228599

---

From: afrind <[email-masked]>
Date: Tue, 15 Oct 2019 17:04:18 -0700

afrind approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#pullrequestreview-302261363

---

From: afrind <[email-masked]>
Date: Tue, 15 Oct 2019 17:06:29 -0700

As for 'B' vs `B`, transport doc just uses (B).  Maybe we should follow suit, bui I can do in a separate pass.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#issuecomment-542454200

---

From: afrind <[email-masked]>
Date: Tue, 15 Oct 2019 17:06:44 -0700

Merged #3089 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3089#event-2715814355