Subject: [quicwg/base-drafts] loss detection timer description could be simplified by definining a timer mode (#3151)

From: Marten Seemann <[email-masked]>
Date: Thu, 24 Oct 2019 18:14:04 -0700

In `SetLossDetectionTimer` we're setting the loss detection timer in order to:

- trigger an early retransmit (if we received gaps in the acknowledged packets) **or**
- trigger a PTO (if we only have a tail outstanding)

When the timer fires, in `OnLossDetectionTimeout`, we first need to figure out why we set the timer, and trigger an early retransmit or a PTO based on that.

I think the code would be easier if we save a "timer mode" `enum { EARLY_RETRANSMIT, PTO }` in `SetLossDetectionTimer`, and take action based on that mode in `OnLossDetectionTimeout`.

@ianswett, @janaiyengar What do you think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151

---

From: ianswett <[email-masked]>
Date: Thu, 24 Oct 2019 19:04:51 -0700

That could work, but I'd call it { LOSS_DETECTION, PTO }

Any interest in writing up a PR so we can see what the change you have in mind looks like?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151#issuecomment-546169453