Subject: [quicwg/base-drafts] Discussion in quic-recovery of delayed ack being 25ms does not seem to relate to anything (#3075)

From: Johannes Rudolph <[email-masked]>
Date: Thu, 03 Oct 2019 15:00:21 -0700

This paragraph didn't seem to relate to anything else in the document:

> A shorter delayed ack time of 25ms was chosen because longer delayed acks can delay loss recovery and for the small number of connections where less than packet per 25ms is delivered, acking every packet is beneficial to congestion control and loss recovery.

Is it left-over from a previous version?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3075

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 15:11:28 -0700

Thanks for pointing this out.

The intent was to explain why 25ms was chosen, given it's smaller than most TCP implementations default delayed ack time.  

There were more exceptions before, but now there's only the one, which makes the preceding paragraph awkward as well.
"The majority of constants were derived from best common practices among widely deployed TCP implementations on the internet. Exceptions follow."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3075#issuecomment-538148915

---

From: ianswett <[email-masked]>
Date: Thu, 03 Oct 2019 15:15:41 -0700

I realized that the 25ms recommendation is in transport, so this is just out of place now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3075#issuecomment-538150075

---

From: Johannes Rudolph <[email-masked]>
Date: Sat, 12 Oct 2019 05:33:03 -0700

> I realized that the 25ms recommendation is in transport, so this is just out of place now.

Ah, I see, I remember I went looking for it in transport, but I think I looked for "delayed ack" and didn't come up with anything fitting. I've got no concrete suggestion how to resolve it but moving the notice to transport in some form would probably make sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3075#issuecomment-541320810

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 24 Oct 2019 15:44:31 -0700

Closed #3075 via #3077.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3075#event-2742437789