Subject: [quicwg/base-drafts] Consider HTTP_ prefix on h3 error codes (#3116)

From: Martin Thomson <[email-masked]>
Date: Thu, 17 Oct 2019 14:46:54 -0700

Either s/HTTP_/H3_/g or s/HTTP_//g.  Because these aren't really HTTP errors, they are HTTP/3 errors.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3116

---

From: "Roy T. Fielding" <[email-masked]>
Date: Thu, 17 Oct 2019 14:48:55 -0700

Er, reconsider the existing HTTP_ prefix on h3 error code names so that they are not confused with HTTP status codes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3116#issuecomment-543375896

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 17 Oct 2019 15:08:55 -0700

`s/HTTP_//g` will cause a name clash between for the Transport error code `NO_ERROR (0x0)` and the HTTP/3 error code `HTTP_NO_ERROR (0x100)`. The name clash is not a massive problem but I think it using a `H3` prefix is more preferable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3116#issuecomment-543382233

---

From: Mike Bishop <[email-masked]>
Date: Tue, 22 Oct 2019 12:12:24 -0700

Closed #3116 via #3119.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3116#event-2734487554