Subject: Re: [quicwg/base-drafts] Idle Timer Can Fire Even with Outstanding Data to Send (#2744)

From: ianswett <[email-masked]>
Date: Tue, 22 Oct 2019 15:41:56 -0700

Sending a BLOCKED frame repeatedly, maybe on exponential backoff, makes sense to me.  @nibanks any interest in writing a PR for this one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2744#issuecomment-545186746

---

From: Nick Banks <[email-masked]>
Date: Tue, 22 Oct 2019 16:01:30 -0700

I could definitely write a PR. We implement exactly this. I would argue though that it's not exponential. It's immediate and will go forever. The app has data to send. The connection is not idle, and should never idle out in this scenario. It's the app's responsibility to time out, if their protocol dictates as such (which it might not, if they expect to be blocked while a long running operation is processed).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2744#issuecomment-545191545