Subject: [quicwg/base-drafts] CONNECTION_CLOSE is non-ack-eliciting (#3098)

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Oct 2019 08:37:28 -0700

fixes #3097
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3098

-- Commit Summary --

  * CONNECTION_CLOSE is non-ack-eliciting

-- File Changes --

    M draft-ietf-quic-recovery.md (7)
    M draft-ietf-quic-transport.md (20)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3098.patch
https://github.com/quicwg/base-drafts/pull/3098.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098

---

From: Marten Seemann <[email-masked]>
Date: Wed, 16 Oct 2019 09:41:58 -0700

marten-seemann commented on this pull request.

> @@ -167,8 +168,8 @@ of frames contained in a packet affect recovery and congestion control logic:
   performance of the QUIC handshake and use shorter timers for
   acknowledgement.
 
-* Packets that contain only ACK frames do not count toward congestion control
-  limits and are not considered in-flight.
+* Packets that contain only ACK or CONNECTION_CLOSE frames do not count toward

It's not clear if the "only" applies only to ACKs or to both.

> @@ -192,8 +192,9 @@ QUIC packet:
 
 Ack-eliciting Packet:
 
-: A QUIC packet that contains frames other than ACK and PADDING. These cause a
-  recipient to send an acknowledgment (see {{sending-acknowledgements}}).
+: A QUIC packet that contains frames other than ACK, PADDING, and
+  CONNECTION_CLOSE. These cause a recipient to send an acknowledgment (see

If you bundle a CONNECTION_CLOSE with other frames, it's still not ack ack-eliciting, is it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-302718749

---

From: ianswett <[email-masked]>
Date: Wed, 16 Oct 2019 17:02:24 +0000 (UTC)

ianswett approved this pull request.

We could reword this sentence to be parallel to the above definition and flip the sentence, ie: 
"Packets containing frames besides ACK or CONNECTION_CLOSE count toward congestion control limits and are considered in-flight."

 Ack-eliciting Packet:

It would be, but it wouldn't really matter because the connection will close.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-302730503

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 16 Oct 2019 10:04:33 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-302733384

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Oct 2019 16:27:39 -0700

@kazuho pushed 1 commit.

f7eed75fae81d12988dc0a121db1245307f8e53d  @ianswett's suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098/files/e9f4ada542c1bc1ab77cf2bd2009b50f94a379d5..f7eed75fae81d12988dc0a121db1245307f8e53d

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 16 Oct 2019 16:28:40 -0700

kazuho commented on this pull request.

@ianswett Thank you for the suggestion. Applied in f7eed75f.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#discussion_r335753253

---

From: ianswett <[email-masked]>
Date: Wed, 16 Oct 2019 20:22:49 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-302984547

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Oct 2019 17:28:25 -0700

martinthomson approved this pull request.

Seems right to me.  Editorial tweaks suggested.

> @@ -123,7 +123,8 @@ In-flight:
 
 Ack-eliciting Frames:
 
-: All frames besides ACK or PADDING are considered ack-eliciting.
+: All frames besides ACK, PADDING, or CONNECTION_CLOSE are considered

```suggestion
: All frames other than ACK, PADDING, and CONNECTION_CLOSE are considered
```

> @@ -2992,9 +2993,8 @@ valid frames? -->
 ## Generating Acknowledgements {#generating-acks}
 
 Endpoints acknowledge all packets they receive and process. However, only
-ack-eliciting packets (see {{QUIC-RECOVERY}}) trigger the sending of an ACK
-frame.  Packets that are not ack-eliciting are only acknowledged when an ACK
-frame is sent for other reasons.
+ack-eliciting packets trigger the sending of an ACK frame.  Packets that are not

Can we fix this here?  I know that this isn't this PR, but I would prefer to say:

```suggestion
ack-eliciting packets cause an ACK frame to be sent within the maximum ack delay.  Packets that are not
```

Or something like that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-304920319

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 21 Oct 2019 17:42:35 -0700

@kazuho pushed 1 commit.

ca86dd1a53df738dce6100c44adeb31c8f3c5a46  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098/files/f7eed75fae81d12988dc0a121db1245307f8e53d..ca86dd1a53df738dce6100c44adeb31c8f3c5a46

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 21 Oct 2019 17:43:31 -0700

@kazuho pushed 1 commit.

c1be5113976a998ad86795b54808587159591fbb  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098/files/ca86dd1a53df738dce6100c44adeb31c8f3c5a46..c1be5113976a998ad86795b54808587159591fbb

---

From: ianswett <[email-masked]>
Date: Tue, 22 Oct 2019 03:30:38 +0000 (UTC)

ianswett commented on this pull request.

+ack-eliciting packets cause an ACK frame to be sent within the maximum ack delay.  Packets that are not

Formatting nit: This needs to be a new line to make CircleCI happy

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#pullrequestreview-304950229

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 22 Oct 2019 03:33:37 +0000 (UTC)

@kazuho pushed 1 commit.

af7a8767450f28452a8f0cfc274950e30d801cce  wordwrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098/files/c1be5113976a998ad86795b54808587159591fbb..af7a8767450f28452a8f0cfc274950e30d801cce

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:29:17 -0700

Merged #3098 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3098#event-2758500693