Subject: Re: [quicwg/base-drafts] Transport parameter registry is too constraining for innovation (#3020)

From: ekr <[email-masked]>
Date: Tue, 01 Oct 2019 13:56:16 -0700

I agree with Kazuho here: splitting it in half would make plenty of room

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-537226777

---

From: Marten Seemann <[email-masked]>
Date: Sun, 13 Oct 2019 04:47:52 -0700

I'm in favor of the change that @DavidSchinazi is suggesting in #3087.
There's no reason for us to use TLS presentation language, if anything, it just makes the spec harder to read for people who are unfamiliar with the TLS presentation language (if I remember correctly, this came up multiple times on issues here and / or on Slack).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-541411627

---

From: Christian Huitema <[email-masked]>
Date: Wed, 16 Oct 2019 14:37:41 -0700

Remember the experience with the X-Options in SMTP or HTML? Do we really want to replicate that?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-542902327

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 14:53:32 -0700

Discussed in Cupertino. @DavidSchinazi to rework #3087 to only replace the TLS syntax with something easier to understand. This will be an Editorial change, reclassifying accordingly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-542907307

---

From: David Schinazi <[email-masked]>
Date: Thu, 17 Oct 2019 09:45:45 -0700

As discussed in Cupertino, I have closed #3087 and replaced it with:
- editorial-only PR #3108 
- IANA policy PR #3109

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-543262629

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Oct 2019 17:44:44 -0700

I think that the RFC 6648 lessons need to be considered carefully here.  I think that it would be better to use a combination of random selection and provisional registration as a means of handling experiments.  Random selection means that we end up colliding with very low probability; provisional registration ensures that registrations are protected.  Making the private use space larger does neither.  I would prefer to instead remove the private use space completely.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3020#issuecomment-544765479