Subject: Re: [quicwg/base-drafts] Lift single-packet ClientHello requirement? (#2928)

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Wed, 09 Oct 2019 19:29:08 -0700

I observed that the size of ticket OpenSSL issues if client certificate is used becomes quite large and it does not fit into a single QUIC packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-540303366

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Oct 2019 17:10:40 -0700

NSS does the same because it puts the entire certificate (if not the certification path) into the ticket.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-540847847

---

From: David Benjamin <[email-masked]>
Date: Thu, 10 Oct 2019 17:57:23 -0700

BoringSSL as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-540856162

---

From: Christian Huitema <[email-masked]>
Date: Wed, 16 Oct 2019 10:53:59 -0700

If we do a change like that, how do we test it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-542818373

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 11:05:00 -0700

Discussed in Cupertino. PR exists #3045. @DavidSchinazi assigned.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-542822951

---

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 11:06:19 -0700

@huitema to add a test to the interop matrix

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-542823464

---

From: Christian Huitema <[email-masked]>
Date: Wed, 16 Oct 2019 13:47:29 -0700

I just defined the test matrix option Q for Quantum Readiness.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#issuecomment-542884718

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:45:29 -0700

Closed #2928 via #3045.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2928#event-2758525174