Subject: Re: [quicwg/base-drafts] QUIC Version Ossification (#2496)

From: Lars Eggert <[email-masked]>
Date: Wed, 16 Oct 2019 14:00:09 -0700

Discussed in Cupertino. @ekr to take #2573 and review it based on the lunch discussion in Cupertino. @kazuho to open an issue to add additional suggestions. To be closed by Singapore.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-542889512

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 17 Oct 2019 09:54:14 -0700

In Cupertino, we agreed that we'd grease the version number field (while the alternative being eliminate) and also change the salt of the Initial encryption key.

That still leaves some of the non-invariant, cleartext fields that might ossify: the long header packet type bits, token length, and packet length.

Should we scramble them too? For example, the parameters used for ossification could include a XOR bitmask that would be applied to these fields.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-543266197

---

From: Ryan Hamilton <[email-masked]>
Date: Thu, 17 Oct 2019 09:56:47 -0700

By "Grease the version number field", I think we agreed that out-of-band, the server can communicate an alternative version number and alternative salt which can be used for future connections. Does that sound right to you?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-543267154

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 17 Oct 2019 10:47:52 -0700

@RyanAtGoogle I think that's correct, with the reservation that the medium for sending the information (e.g., alternative salt) being in debate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-543287118

---

From: David Schinazi <[email-masked]>
Date: Sat, 19 Oct 2019 13:54:34 -0700

I agree with @kazuho, I think the ossification parameters should include 2 bits used to XOR the long header type field.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-544196537

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Oct 2019 18:52:17 -0700

I think that I would prefer the NEW_TOKEN design suggested in #3111.  The additional bits seem like they might be worth adding as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2496#issuecomment-544776611