Subject: Re: [quicwg/base-drafts] Do Initial secrets change after Retry packet? (#2823)

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Oct 2019 13:20:25 -0700

@ianswett has a design-level change for this in #2878 that I think is a good idea to talk about.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2823#issuecomment-542387360

---

From: ianswett <[email-masked]>
Date: Wed, 16 Oct 2019 10:15:56 -0700

One new point that came up in the discussion of #3014 is that if every packet is self-contained(ie: option 2), it would be possible for the server to send a CONNECTION_CLOSE to terminate a handshake that is doomed to failure quickly, opposed to waiting for the handshake to timeout.

If my PR is accepted, the server would not be able to send a CONNECTION_CLOSE.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2823#issuecomment-542802852

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 16 Oct 2019 15:31:25 -0700

Discussed in Cupertino; we believe that we should clarify to option 3 (i.e., mt's #2870).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2823#issuecomment-542918115

---

From: Martin Thomson <[email-masked]>
Date: Mon, 21 Oct 2019 17:23:41 -0700

For the record, the two arguments that carried this were a) everyone has already implemented #2870, and b) you can't send CONNECTION_CLOSE if you keep the keys the same.  Mix to taste.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2823#issuecomment-544761573

---

From: Martin Thomson <[email-masked]>
Date: Wed, 30 Oct 2019 22:32:36 -0700

Closed #2823 via #2870.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2823#event-2758505787