Subject: [quicwg/base-drafts] Transport: Flow Control Tuning (#3216)

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 11 Nov 2019 09:53:36 -0800

/ A receiver can use an autotuning mechanism to tune the frequency and
   amount of advertised additional credit based on a round-trip time
   estimate and the rate at which the receiving application consumes
   data, similar to common TCP implementations. 
/ 
- I think this has potential for strange pathologies where flow control interacts with ACKs within the transport. I now have at least some data where we have seen problems, from one policy that updated flow control too infrequently. Achieving similar behaviour to TCP could require more than currently stated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3216

---

From: Martin Thomson <[email-masked]>
Date: Wed, 27 Nov 2019 18:45:55 -0800

After briefly discussing this with Gorry, I think that we concluded that advice about the frequency of flow control updates would help.

Where flow control limits broadly correspond to the congestion window size, those updates would need to be sent about as often as acknowledgments in order to ensure that flow control didn't stall unnecessarily.  That would be the upper limit; larger flow control limits need proportionally fewer updates.  If flow control limits are very large, updates could be far less frequent.

I don't think that we have an algorithm here, but it seems like this advice would go a long way to avoiding the worst problems.

There's a question then about where this advice goes.  I am inclined to keep this in the transport doc as long as our response only extends to advice in the abstract.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3216#issuecomment-559319078

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 29 Nov 2019 00:23:56 -0800

Thanks for starting this issue. I will speak to my team and see if we can come up with some more context and plots that show the key issues and send a link to what we have.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3216#issuecomment-559702821