Subject: [quicwg/base-drafts] Remove SHOULD for advice to pre-generate KeyUpdate (#3211)

From: ekr <[email-masked]>
Date: Sun, 10 Nov 2019 14:07:20 -0800

> The process of creating new packet protection keys for receiving packets could
> reveal that a key update has occurred.  An endpoint MAY perform this process as
> part of packet processing, but this creates a timing signal that can be used by
> an attacker to learn when key updates happen and thus the value of the Key Phase
> bit in certain packets.  Endpoints SHOULD instead defer the creation of the next
> set of receive packet protection keys until some time after a key update
> completes, up to three times the PTO; see {{old-keys-recv}}.

I don't believe we had consensus on this -- and there was considerable debate in YUL. It just got pulled in as part of a big PR. 

This is a significantly more complicated mechanism than just generating as needed, and I haven't yet seen any real security analysis.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3211

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Nov 2019 16:04:18 -0800

This text was specifically put in to address #2792.  That issue was extensively debated, but I agree that it was not concluded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3211#issuecomment-552673372

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 12 Nov 2019 14:56:28 -0800

Reopening #2792. We need to be more careful about PRs that close multiple issues...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3211#issuecomment-553155544

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 12 Nov 2019 14:56:28 -0800

Closed #3211.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3211#event-2793307694