Subject: [quicwg/base-drafts] Reduce HTTP/3 editorial dependence on HTTP/2 (#3264)

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 18 Nov 2019 18:29:26 -0800

The HTTP/3 draft relies on the reader's familiarity with the HTTP/2 spec, bouncing between normative references to HTTP/2 and specification as a delta to some prior decision for HTTP/2. While that's understandable for initial development and for a section on gatewaying to h2, I don't think it is appropriate for a standards track document that will eventually (or at least likely) obsolete HTTP/2.

I don't expect readers (outside of the WG members) to have implemented h2, even if the design is based on h2. I would like all of the necessary concepts, aside from what can be normatively referenced via http-core, to be fully defined within this spec, even if that means copy and paste from h2.

(I would label this as editorial and -http)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3264

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 18:47:44 -0800

I agree that readers should not be required to read the HTTP/2 spec.  We've taken the same approach with recovery where the intent is to be self-contained, but add informative references to TCP RFCs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3264#issuecomment-555307537

---

From: Mike Bishop <[email-masked]>
Date: Tue, 19 Nov 2019 18:50:10 -0800

I agree with that principle, but I've been working on that for a while, but I think we're already mostly there.  There are normative references to specific sections of HTTP/2 where relevant; I've attempted not to have anything that assumes you already know HTTP/2 in general.  The informative comparisons to HTTP/2 have largely (if not entirely) been moved to an appendix.

If you have specific places where you think I haven't achieved that, please point them out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3264#issuecomment-555811993