Subject: [quicwg/base-drafts] Ambiguous wording about error codes in HTTP/3 (#3276)

From: Lucas Pardue <[email-masked]>
Date: Wed, 27 Nov 2019 06:21:51 -0800

Creating an issue on behalf of @SamB that reflects #3239. On that PR they quote a section of the document and say:

> It's not very clear what it means to not treat an error code as an error.
Maybe [replacing "an error" with "a further error"] is what's meant? (If not, please explain it better.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 27 Nov 2019 06:27:09 -0800

I don't think the suggested change is aligned with the intent but there might be something we can do to improve the readability. 

"error codes" are used for normal operations when it comes to closing streams. So one interpretation of the current text is to say that if you get an unknown error code in a RESET_STREAM, don't treat it as any kind of error.  The suggested text "further error" confuses this interpretation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-559109365

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 27 Nov 2019 13:31:29 -0800

Maybe something like "MUST NOT be interpreted as an indication of a problem"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-559257691