Subject: Re: [quicwg/base-drafts] Packets on one path must not adjust values for a different path (#3139)

From: Eric Kinnear <[email-masked]>
Date: Sun, 03 Nov 2019 21:43:21 -0800

erickinnear commented on this pull request.

> @@ -2096,7 +2096,7 @@ more likely to indicate an intentional migration rather than an attack.
 ## Loss Detection and Congestion Control {#migration-cc}
 
 The capacity available on the new path might not be the same as the old path.
-Packets sent on the old path SHOULD NOT contribute to congestion control or RTT
+Packets sent on the old path MUST NOT contribute to congestion control or RTT
 estimation for the new path.

I'd tend to agree with Ian that it's probably not necessary to add text covering that -- you're doing the safest thing if you treat them as completely independent, and you're likely to have new data from the new path just from validation or within a few RTTs.

(That said, I'd be quite interested in the results of experiments in this area, and there's no enforcement here that prevents such experimentation.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#discussion_r341908356

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Nov 2019 17:39:42 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#pullrequestreview-311461546

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 04 Nov 2019 17:41:35 -0800

+1 that we should require this behavior. We know that implementers will try out tricks here if they want to, and there's no enforcement to stop that from happening.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#issuecomment-549625656

---

From: Eric Kinnear <[email-masked]>
Date: Thu, 07 Nov 2019 22:17:21 -0800

I agree that this seems generally editorial, but either way I think this is ready to go?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3139#issuecomment-551400451