Subject: [quicwg/base-drafts] Reference 3168 for ECN (#3241)

From: ianswett <[email-masked]>
Date: Sat, 16 Nov 2019 19:26:47 -0800

And note that 8311 is an update.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3241

-- Commit Summary --

  * Reference 3168 for ECN

-- File Changes --

    M draft-ietf-quic-recovery.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3241.patch
https://github.com/quicwg/base-drafts/pull/3241.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241

---

From: ianswett <[email-masked]>
Date: Sat, 16 Nov 2019 19:28:37 -0800

@ianswett pushed 1 commit.

3e0c5f00f5aa1e95d2cf8028da01534a642b9d06  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241/files/00e05fbb38c9079150e06806e97b5f4763c70ac2..3e0c5f00f5aa1e95d2cf8028da01534a642b9d06

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 16 Nov 2019 19:37:01 -0800

janaiyengar commented on this pull request.

> @@ -655,11 +655,11 @@ to support different algorithms.
 
 ## Explicit Congestion Notification {#congestion-ecn}
 
-If a path has been verified to support ECN, QUIC treats a Congestion Experienced
-codepoint in the IP header as a signal of congestion. This document specifies an
-endpoint's response when its peer receives packets with the Congestion
-Experienced codepoint.  As discussed in {{!RFC8311}}, endpoints are permitted to
-experiment with other response functions.
+If a path has been verified to support ECN as specified in {{?RFC3168}} and
+updated in {{?RFC8311}}, QUIC treats a Congestion Experienced(CE) codepoint in

Suggestion: "If a path has been verified to support ECN {{?RFC3168}} {{?RFC8311}}"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241#pullrequestreview-317999220

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 16 Nov 2019 19:54:41 -0800

janaiyengar approved this pull request.

one suggestion, but I'm approving

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241#pullrequestreview-317999534

---

From: ianswett <[email-masked]>
Date: Sat, 16 Nov 2019 23:04:13 -0800

e41a121b775409e5b7f6e276ede0e11eca7936d5  Jana's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241/files/3e0c5f00f5aa1e95d2cf8028da01534a642b9d06..e41a121b775409e5b7f6e276ede0e11eca7936d5

---

From: ianswett <[email-masked]>
Date: Sat, 16 Nov 2019 23:05:01 -0800

Merged #3241 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3241#event-2805236323