Subject: Re: [quicwg/base-drafts] Handling of corrupt Retry packets (#3014)

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 16:03:45 -0800

Moving discussion back here to address @ekr's [request](https://github.com/quicwg/base-drafts/pull/3120#issuecomment-554271932) to encrypt the token.

Discussion thus far identified a very minor performance/value trade-off. Running AES might cost some.  This is minor, as the key is fixed and so the AES key preparation costs are erased; you might even pregenerate the fixed key stream and just run XOR.  With that realization, we observed that the value provided by encryption was equivalent to the difficulty of applying that XOR.

There is a step higher, which is to use a key derived from the connection ID, but that depends on running a KDF and setting up AES, which I think we all agreed was prohibitive.

I think that the idea of moving from a 0 key to a fixed key is easy, so we should definitely do that even if we do nothing else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3014#issuecomment-554803356

---

From: David Schinazi <[email-masked]>
Date: Mon, 18 Nov 2019 03:17:49 -0800

I've incorporated @martinthomson 's suggestion and switched the key from all-zeroes to the `initial_salt`

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3014#issuecomment-554971668