Subject: [quicwg/base-drafts] Use host less, define address more (#3249)

From: Martin Thomson <[email-masked]>
Date: Sat, 16 Nov 2019 21:26:11 -0800

Some definitional work for terms that were poorly used.

Note that &quot;host&quot; in the remaining uses is strictly interpreted in the RFC 1122 sense, so I left those alone.

I considered sorting the terms section differently, and might still alphabetize that, but this isn&#39;t problematic just yet.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3249

-- Commit Summary --

  * Use host less as appropriate
  * Define &quot;address&quot;

-- File Changes --

    M draft-ietf-quic-transport.md (13)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3249.patch
https://github.com/quicwg/base-drafts/pull/3249.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249

---

From: ianswett <[email-masked]>
Date: Sun, 17 Nov 2019 22:25:19 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#pullrequestreview-318118103

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 18 Nov 2019 02:00:42 -0800

janaiyengar commented on this pull request.

> @@ -210,6 +210,11 @@ Server:
 
 : The endpoint accepting incoming QUIC connections.
 
+Address:
+
+: When used without qualification, the tuple of IP version, IP address, UDP
+  protocol, and UDP port number that represents one end of a network path.

What's "UDP protocol"? Did you mean "IP protocol"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#pullrequestreview-318212480

---

From: Martin Thomson <[email-masked]>
Date: Mon, 18 Nov 2019 19:26:27 -0800

martinthomson commented on this pull request.

 
+Address:
+

I was talking about the protocol field in the IP header.  How would you suggest we make that clear?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#discussion_r347716257

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 25 Nov 2019 04:35:05 -0800

+Address:
+

Yeah, that's what I meant, though clearly that's confusing as well. Thinking about it, what you have might be the best we can do. Let's leave it as it is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#discussion_r350157340

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 25 Nov 2019 04:35:15 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#pullrequestreview-322244712

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 25 Nov 2019 04:35:43 -0800

Merged #3249 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3249#event-2827917047