Subject: [quicwg/base-drafts] conflicting advice how to handle Retire Prior To (#3195)

From: Marten Seemann <[email-masked]>
Date: Wed, 06 Nov 2019 02:47:53 -0800

In the section talking about Connection IDs (section 5.1.2) it says:
> An endpoint can cause its peer to retire connection IDs by sending a NEW_CONNECTION_ID frame with an increased Retire Prior To field. Upon receipt, the peer MUST retire the corresponding connection IDs and send corresponding RETIRE_CONNECTION_ID frames.

In the description of the NEW_CONNECTION_ID frame (section 19.15) it says:
> The Retire Prior To field is a request for the peer to retire all connection IDs with a sequence number less than the specified value. [...] The peer SHOULD retire the corresponding connection IDs and send the corresponding RETIRE_CONNECTION_ID frames in a timely manner.

So it's not clear if you just SHOULD or if you MUST send the RETIRE_CONNECTION_ID frame.

As an editorial remark, I find the existing text a bit hard to understand, since it's spread over these two sections. Maybe it would be easier to keep the frame description relatively short, and move more of the logic into the section that describes how CIDs are used and retired. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3195

---

From: Mike Bishop <[email-masked]>
Date: Wed, 06 Nov 2019 11:20:29 -0800

I think what we concluded in previous discussion was that you MUST retire them, and SHOULD do so in a timely manner.  The suggested reorganization isn't a bad suggestion either.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3195#issuecomment-550460829

---

From: Martin Thomson <[email-masked]>
Date: Wed, 06 Nov 2019 16:57:47 -0800

Based on this feedback, this can probably be handled as an editorial matter.  I would be happy to receive a PR that reconciled this with [the agreed conclusion](https://github.com/quicwg/base-drafts/issues/3195#issuecomment-550460829).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3195#issuecomment-550570713

---

From: Eric Kinnear <[email-masked]>
Date: Thu, 07 Nov 2019 22:16:04 -0800

Definitely agree that this is editorial, we just missed this duplicate requirement in the original change. Removed that duplication and cleaned up the frame description a bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3195#issuecomment-551400183

---

From: Martin Thomson <[email-masked]>
Date: Mon, 11 Nov 2019 13:21:14 -0800

Closed #3195 via #3204.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3195#event-2789353811