Subject: [quicwg/base-drafts] [HTTP/3] [editorial] Remove mention of redefining setting format. (#3220)

From: Bence Béky <[email-masked]>
Date: Mon, 11 Nov 2019 12:32:26 -0800

Each SETTINGS parameter consists of an identifier and a value, each
encoded as QUIC variable-length integer.  The sentence being removed is
a remnant from the time when setting values were encoded as
length-prefixed binary blobs.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3220

-- Commit Summary --

  * [HTTP/3] [editorial] Remove mention of redefining setting format.

-- File Changes --

    M draft-ietf-quic-http.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3220.patch
https://github.com/quicwg/base-drafts/pull/3220.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220

---

From: Mike Bishop <[email-masked]>
Date: Mon, 11 Nov 2019 12:54:29 -0800

No, it's not.  It's a warning that, *due* to the varint encoding, if you use the full 32-bit value space from HTTP/2, you'll get encoded into 64 bits in HTTP/3.  For example, Secondary Certs sends a four-byte binary value in its setting; keeping the identical definition in HTTP/3 would waste space.

Such extensions should either restrict themselves to 30 bits (to fit in the same size) or make use of the 62-bit space since they'll be encoded into that size anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220#issuecomment-552611318

---

From: Bence Béky <[email-masked]>
Date: Tue, 12 Nov 2019 05:03:01 -0800

@bencebeky pushed 1 commit.

853d1b31b1c126a895f6115ce53e199dab94c5c4  Clarify how settings ported from HTTP/2 might redefine value.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220/files/32482433600e67e23dd3ce450ade7ba314782293..853d1b31b1c126a895f6115ce53e199dab94c5c4

---

From: Bence Béky <[email-masked]>
Date: Tue, 12 Nov 2019 05:03:32 -0800

3cdf7151d63862a0abe790667779418ebffaab90  Clarify how settings ported from HTTP/2 might redefine value.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220/files/853d1b31b1c126a895f6115ce53e199dab94c5c4..3cdf7151d63862a0abe790667779418ebffaab90

---

From: Bence Béky <[email-masked]>
Date: Tue, 12 Nov 2019 05:06:11 -0800

Thank you for the response.  I reworded the PR to capture your explanation.  PTAL.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220#issuecomment-552884985

---

From: Mike Bishop <[email-masked]>
Date: Tue, 12 Nov 2019 09:58:30 -0800

MikeBishop approved this pull request.

> @@ -1941,7 +1941,9 @@ In HTTP/3, setting values are variable-length integers (6, 14, 30, or 62 bits
 long) rather than fixed-length 32-bit fields as in HTTP/2.  This will often
 produce a shorter encoding, but can produce a longer encoding for settings which
 use the full 32-bit space.  Settings ported from HTTP/2 might choose to redefine
-the format of their settings to avoid using the 62-bit encoding.
+their value to limit it to 30 bits for more efficient encoding, or to make use
+of the 62-bit space (for example, if encoding the original value often requires
+eight bytes anyway).

This parenthetical feels kind of awkward; maybe just something like "or might choose to make use of the 62-bit space if more than 30 bits are required"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220#pullrequestreview-315729886

---

From: Bence Béky <[email-masked]>
Date: Tue, 12 Nov 2019 10:43:50 -0800

8ec3b0da82e510596487a2558908989711e2389b  reword parenthetical

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220/files/d40d76703b55b8bd58494ecbbe464a3971644e11..8ec3b0da82e510596487a2558908989711e2389b

---

From: Bence Béky <[email-masked]>
Date: Tue, 12 Nov 2019 10:44:21 -0800

bencebeky commented on this pull request.

Thanks for the suggestion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220#discussion_r345378768

---

From: Mike Bishop <[email-masked]>
Date: Wed, 13 Nov 2019 15:14:29 +0000 (UTC)

Merged #3220 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3220#event-2795664569