Subject: [quicwg/base-drafts] Can we make a normative ref to RFC8085? (#3244)

From: Gorry Fairhurst <[email-masked]>
Date: Sat, 16 Nov 2019 20:24:39 -0800

I would like to suggest that RFC8085 is normative. 

This RFC was written as BCP for UDP usage, and QUIC implementations need to comply with that or describe the difference and reach consensus about why it differs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 16:08:02 -0800

I see RFC 8085 in the list of normative references already.  Was there something in particular that you think we should be explicitly depending on?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554803826

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 16:09:20 -0800

...Or, I realize now, does this comment apply to the recovery document?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554803950

---

From: ianswett <[email-masked]>
Date: Sun, 17 Nov 2019 16:31:33 -0800

This was intended for the recovery doc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554806262

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 16:36:19 -0800

Ahh, the comment still applies then.  What specific items in RFC 8085 would this need to depend on?  We don't just add normative dependencies without that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554806795

---

From: Gorry Fairhurst <[email-masked]>
Date: Sun, 17 Nov 2019 18:15:01 -0800

Yes, this comment targets recovery. I think the editors can propose text referring to the draft - there is no intended change to the technical spec.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554821548

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 19:33:07 -0800

I'm sorry, I perhaps wasn't clear.  This is not stated as an issue.  "This document doesn't cite X" isn't an issue.  Is there something specific that is in RFC 8085 that is needed to address an issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554836389

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 17 Nov 2019 19:55:28 -0800

I suspect what I have in PR 3248 (
https://github.com/quicwg/base-drafts/pull/3248) ought to address this. I
think Gorry wanted to have normative reference for congestion control
conformance.

On Mon, Nov 18, 2019 at 11:33 AM Martin Thomson <[email-masked]>
wrote:

> I'm sorry, I perhaps wasn't clear. This is not stated as an issue. "This
> document doesn't cite X" isn't an issue. Is there something specific that
> is in RFC 8085 that is needed to address an issue?
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/3244?email_source=notifications&email_token=ACUOBVADNJN5BK3OKBWCPQLQUIEHFA5CNFSM4JOIEOC2YY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOEEJCDJI#issuecomment-554836389>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/ACUOBVBMGGR3BJENIZRX3PDQUIEHFANCNFSM4JOIEOCQ>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-554840758

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 18 Nov 2019 18:15:11 -0800

Yes, and WFM - see single comment on the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-555299946

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 25 Nov 2019 04:39:43 -0800

If this goes into late-stage, it should be design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3244#issuecomment-558137644