Subject: [quicwg/base-drafts] Recovery editorial update (#3234)

From: ianswett <[email-masked]>
Date: Fri, 15 Nov 2019 11:06:01 -0800

Update based on my review of the editor&#39;s copy.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3234

-- Commit Summary --

  * Recovery editorial update

-- File Changes --

    M draft-ietf-quic-recovery.md (49)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3234.patch
https://github.com/quicwg/base-drafts/pull/3234.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234

---

From: ianswett <[email-masked]>
Date: Fri, 15 Nov 2019 11:29:26 -0800

@ianswett pushed 1 commit.

9566264ca83828a0a33abe1587cefa9da2071ed1  whitespace

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/c8df2b0fc3d26156b956e622f3f73648e7df6005..9566264ca83828a0a33abe1587cefa9da2071ed1

---

From: ianswett <[email-masked]>
Date: Fri, 15 Nov 2019 11:37:15 -0800

0cf2aab793c7393a9edad7f5a3fc360b56d9646b  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/9566264ca83828a0a33abe1587cefa9da2071ed1..0cf2aab793c7393a9edad7f5a3fc360b56d9646b

---

From: martinduke <[email-masked]>
Date: Sat, 16 Nov 2019 16:56:20 -0800

martinduke approved this pull request.

> @@ -359,8 +354,9 @@ rttvar = 3/4 * rttvar + 1/4 * rttvar_sample
 
 # Loss Detection {#loss-detection}
 
-QUIC senders use both ack information and timeouts to detect lost packets, and
-this section provides a description of these algorithms.
+QUIC senders use acknowledgements to detect lost packets, and a probe
+time out {{pto}} to ensure acknowledgements are received. This section

...to ensure it receives acknowledgements.

> @@ -532,7 +527,7 @@ keys are available to the client, it MUST send a Handshake packet, and
 otherwise it MUST send an Initial packet in a UDP datagram of at least 1200
 bytes.
 
-Initial packets and Handshake packets may never be acknowledged, but they are
+Initial packets and Handshake packets may never be acknowledged, so they are

s/may/might

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#pullrequestreview-317995637

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 02:26:15 -0800

ianswett commented on this pull request.

 

Done

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#discussion_r347301062

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 02:26:41 -0800

Done

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#discussion_r347301264

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 02:27:16 -0800

afb284145fd83da4c72f37cd4a867f98946f4d39  Martin's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/0cf2aab793c7393a9edad7f5a3fc360b56d9646b..afb284145fd83da4c72f37cd4a867f98946f4d39

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 02:28:12 -0800

cae4f4f5ae14fd93a3797bbdc135facffc639453  Merge branch 'master' into ianswett-recovery-editorial

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/afb284145fd83da4c72f37cd4a867f98946f4d39..cae4f4f5ae14fd93a3797bbdc135facffc639453

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 Nov 2019 22:05:38 -0800

janaiyengar commented on this pull request.

 
-QUIC senders use both ack information and timeouts to detect lost packets, and
-this section provides a description of these algorithms.
+QUIC senders use acknowledgements to detect lost packets, and a probe
+time out {{pto}} to ensure it receives acknowledgements. This section

```suggestion
timeouts {{pto}} to ensure it receives acknowledgements. This section
```

 

```suggestion
A QUIC sender uses acknowledgements to detect lost packets, and probe
```

> @@ -549,9 +544,7 @@ expired, the sender SHOULD send ack-eliciting packets from other packet
 number spaces with in-flight data, coalescing packets if possible.
 
 When the PTO timer expires, and there is new or previously sent unacknowledged
-data, it MUST be sent.  Data that was previously sent with Initial encryption
-MUST be sent before Handshake data and data previously sent at Handshake
-encryption MUST be sent before any ApplicationData data.

Why are you removing this text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#pullrequestreview-319520311

---

From: ianswett <[email-masked]>
Date: Tue, 19 Nov 2019 22:21:32 -0800

5dcb4782f027a9d3577db6cfacbc68662520b48a  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/cae4f4f5ae14fd93a3797bbdc135facffc639453..5dcb4782f027a9d3577db6cfacbc68662520b48a

---

From: ianswett <[email-masked]>
Date: Tue, 19 Nov 2019 22:21:50 -0800

9725dba1ba63f222e5b087d9c13d8a5a82554770  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/5dcb4782f027a9d3577db6cfacbc68662520b48a..9725dba1ba63f222e5b087d9c13d8a5a82554770

---

From: ianswett <[email-masked]>
Date: Tue, 19 Nov 2019 22:22:35 -0800

This should have been removed in #3066, but was missed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#discussion_r348307953

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 Nov 2019 23:02:36 -0800

Ah, right, of course.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#discussion_r348317847

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 Nov 2019 23:02:40 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#pullrequestreview-319585558

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 Nov 2019 23:33:07 -0800

@janaiyengar pushed 3 commits.

b52d6e51eaa3d54a7c6501d85f1b4ada7d5b3707  Recovery editorial update
33a4a4804a4d4ba9e10d311560a873adef1d5c77  whitespace
258f2da1aaaaaef58d84ecc04556cbe932238b4a  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234/files/9725dba1ba63f222e5b087d9c13d8a5a82554770..258f2da1aaaaaef58d84ecc04556cbe932238b4a

---

From: ianswett <[email-masked]>
Date: Tue, 19 Nov 2019 23:36:13 -0800

Merged #3234 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3234#event-2814202005