Subject: [quicwg/base-drafts] I am concerned the congestion control text is too permissive. (#3247)

From: Gorry Fairhurst <[email-masked]>
Date: Sat, 16 Nov 2019 21:08:19 -0800

The docs call out that the design is based on (new)Reno. That is good and suitable for a PS. I have no problem here.

However, there are several places where the text is very permissive "MAY..." that suggests the PS can implement this or anything else. This combination seems awkward for a PS. I'd hoped that we could allow experimentation with new CC's but say SHOULD use an IETF-specified congestion control method, or something text close to that, and change the MAYs into something more helpful. I think this is an easy piece of text to get correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3247

---

From: Gorry Fairhurst <[email-masked]>
Date: Sat, 16 Nov 2019 21:14:47 -0800

Please check appendices, e.g.

" Constants used in loss recovery are based on a combination of RFCs,
   papers, and common practice.  Some may need to be changed or
   negotiated in order to better suit a variety of environments."
- that final sentence needs thought.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3247#issuecomment-554706175

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 25 Nov 2019 04:39:33 -0800

If this goes into late-stage, it should be design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3247#issuecomment-558137588