Subject: [quicwg/base-drafts] Add caution when using IW10 and fragmentation (#3243)

From: Jana Iyengar <[email-masked]>
Date: Sat, 16 Nov 2019 20:24:26 -0800

Gorry notes correctly that fragmentation can play poorly with using IW10. If a sender uses a large max_datagram_size, and if the network fragments, then IW10 can result in substantially larger amplification than 10x.

A simple fix here is to say that if the endpoint uses max_datagram_size larger than 1280 bytes (this is what the transport spec limits it to in the absence of DPLPMTUD), then the endpoint MUST set DF on outgoing packets.

This is a problem with RFC 6928 as well, but we should be clear about it for QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243

---

From: Praveen Balasubramanian <[email-masked]>
Date: Sun, 17 Nov 2019 05:42:30 -0800

Shouldn't endpoint always set DF for all QUIC packets? TCP does so. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-554746830

---

From: ianswett <[email-masked]>
Date: Sun, 17 Nov 2019 13:27:42 -0800

I tend to agree with Praveen here.  I think this is something that's under-specified in transport?

I believe it should be in section 14: https://tools.ietf.org/html/draft-ietf-quic-transport-24#section-14

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-554789171

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 Nov 2019 16:17:14 -0800

Yeah, this is probably an issue in transport.  DF seems like the obvious answer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-554804759

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 18 Nov 2019 02:05:10 -0800

That was my first answer, but I thought that might be too intrusive. If we all agree that is a fine response, I'm happy with that. I can write up a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-554945047