Subject: Re: [quicwg/base-drafts] loss detection timer description could be simplified by definining a timer mode (#3151)

From: ianswett <[email-masked]>
Date: Fri, 01 Nov 2019 10:48:02 -0700

I wrote up #3182, but I don't think it's an improvement.  Maybe it wasn't what you had in mind, @marten-seemann ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151#issuecomment-548885244

---

From: Marten Seemann <[email-masked]>
Date: Fri, 01 Nov 2019 18:50:43 -0700

@ianswett I have a half-baked PR on my disk, but I still need to figure out the details of how this interacts the amplification limit. It seems like on the client side, there's a third timer mode (send *anything* to unblock the server from the 3x limit).
I'll put some more work into my PR and post it by early next week.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151#issuecomment-548999205

---

From: ianswett <[email-masked]>
Date: Sat, 02 Nov 2019 12:11:24 -0700

One other idea would be to add a second timer, so you'd have a loss_timer and pto_timer.  I was strongly against this when we had handshake retransmissions and TLP retransmissions and RTO retransmissions, but now that we're down to PTO, I like the idea better.  I think that might be simpler to understand than an enum, and you could split the pseudocode into two methods.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151#issuecomment-549072303

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 02 Nov 2019 12:20:04 -0700

If we are going to make a change, I would very much argue for using a
single timer. There's never a time when we might want both timers, which is
signaled clearly to implementers by using a single timer. We can refactor
the handling of timeouts though.

On Sat, Nov 2, 2019, 12:11 PM ianswett <[email-masked]> wrote:

> One other idea would be to add a second timer, so you'd have a loss_timer
> and pto_timer. I was strongly against this when we had handshake
> retransmissions and TLP retransmissions and RTO retransmissions, but now
> that we're down to PTO, I like the idea better. I think that might be
> simpler to understand than an enum, and you could split the pseudocode into
> two methods.
>
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/3151?email_source=notifications&email_token=ACUOBVCZ4BN6YOF5ATH62PDQRXGFXA5CNFSM4JE5JFSKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOEC5C3LY#issuecomment-549072303>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/ACUOBVGBOLNG37GJS2A6WIDQRXGFXANCNFSM4JE5JFSA>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3151#issuecomment-549072942