Subject: Re: [quicwg/base-drafts] congestion window increase on every ACKed packet could result in bursty sends (#3094)

From: Vidhi Goel <[email-masked]>
Date: Mon, 04 Nov 2019 12:56:57 -0800

@ianswett: I am working on the PR for pseudocode changes. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-549543290

---

From: Praveen Balasubramanian <[email-masked]>
Date: Sun, 17 Nov 2019 05:50:01 -0800

I agree that when not pacing, using an ABC limit is appropriate. FWIW Windows TCP was using a limit of 4 and not 2 for a long time and now uses 8 which is pretty close to IW10 burst in slow start phase.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-554747535

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 18:27:35 -0800

For the WG:  The proposed PR attempts to include a mechanism to limit CWND increase during slow start when not pacing.  I'll note that by itself, it does not guarantee we follow the existing MUST: 
 "Implementations MUST either use pacing or limit such
   bursts to the initial congestion window, which is recommended to be
   the minimum of 10 * max_datagram_size and max(2* max_datagram_size,
   14720)), where max_datagram_size is the current maximum size of a
   datagram for the connection, not including UDP or IP overhead."

I don't think we should add this to the pseudocode, because we say SHOULD pace packets and the pseudocode currently only covers SHOULDs, not MAYs.  Adding all MAYs to the pseudocode is too complex.

I don't have a concern about adding a reference to the existing RFC as a mechanism that MAY help limit bursts during slow start.

I'd like a decision from the WG on whether to include this change and if so, some criteria on what should be included going forward.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-555302900

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 18 Nov 2019 20:00:28 -0800

I agree with the comment that burst from ACK compression or Stretch-ACKs result in bursts. I think the ways to change that is implement a maximum burst size or use pacing. The bursts do not appear a CC function to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-555322521