Subject: [quicwg/base-drafts] Disabling Spin bit for what percentage of connections? (#3257)

From: Igor Lubashev <[email-masked]>
Date: Sun, 17 Nov 2019 23:18:52 -0800

The draft says:
> The random selection process SHOULD be designed such that on average the spin bit is disabled for at least one eighth of network paths.

However, given that each endpoint needs to decide for itself whether it is enabling spin bit, it is not exactly clear whether each endpoint SHOULD disable spin bit on at least 1/8 (=12.5%) of connections, or it can assume that the other endpoint is also making a random decision to disable and disable only on 1-sqrt(7/8) (=6.5%) of connections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3257

---

From: Brian Trammell <[email-masked]>
Date: Mon, 18 Nov 2019 00:43:13 -0800

as the author of this passage, I intended the latter (assume the other side is disabling as well, so 1-sqrt(7/8)), but the "at least" is in there since just disabling 1/8 is probably what people will do, and the result (about 1/4) is "at least 1/8".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3257#issuecomment-554912431

---

From: Igor Lubashev <[email-masked]>
Date: Wed, 20 Nov 2019 01:15:06 -0800

@britram could you review #3270?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3257#issuecomment-555913033