Subject: [quicwg/base-drafts] Allow CRYPTO_BUFFER_EXCEEEDED error when CRYPTO frame goes beyond 2^62 bytes (#3258)

From: Kazuho Oku <[email-masked]>
Date: Sun, 17 Nov 2019 23:58:57 -0800

When discussing #3027 at Cupertino, we agreed that either of the following two errors can be sent when the payload of the STREAM frame exceeds 2^62 bytes:
* FRAME_ENCODING_ERROR
* FLOW_CONTROL_ERROR

And we've merged PR #3042 that made that change, along with other changes. However, in that PR, we failed to apply the rule that we agreed for SRTEAM frame to CRYPTO frame.

Editors' draft now allows use of FRAME_ENCODING_ERROR for CRYPTO frames, but not CRYPTO_BUFFER_EXCEEDED.

As CRYPTO_BUFFER_EXCEEDED *is* the flow control error for CRYPTO streams, that should be permitted too.

To be fixed by PR #3186.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3258

---

From: Martin Thomson <[email-masked]>
Date: Mon, 18 Nov 2019 08:23:03 -0800

Thanks for doing all of this Kazuho.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3258#issuecomment-555092168