Subject: [quicwg/base-drafts] reordered NEW_CONNECTION_ID frames with retired sequence numbers shouldn't be used (#3194)

From: Marten Seemann <[email-masked]>
Date: Wed, 06 Nov 2019 02:32:57 -0800

Let's say an endpoint receives a NEW_CONNECTION_ID frame with Sequence Number: X, Retire Prior To: M. At a later moment, it receives a (reordered) NEW_CONNECTION_ID frame with Sequence Number: N (where N < M).

As the spec is currently written, it would be perfectly legal to use CID N at this moment. Obviously, this doesn't make sense, since the receiving peer is about to or has already stopped accepting packets with using CIDs < M. When receiving such a reordered NEW_CONNECTION_ID frame, the reasonable thing to do is to immediately send the corresponding RETIRE_CONNECTION_ID frame for N.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3194

---

From: Eric Kinnear <[email-masked]>
Date: Thu, 07 Nov 2019 10:36:30 -0800

Agreed, I think that was the intent all along, we just missed the text. Thanks for the close read! 😄 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3194#issuecomment-551207838

---

From: Martin Thomson <[email-masked]>
Date: Thu, 07 Nov 2019 19:26:27 -0800

Technically design, so we'll need a consensus call, but the PR is probably the best way to address this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3194#issuecomment-551368653

---

From: Martin Thomson <[email-masked]>
Date: Thu, 28 Nov 2019 17:54:46 -0800

Closed #3194 via #3202.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3194#event-2840138161