Subject: [quicwg/base-drafts] max_datagram_size being a variable means other constants become variables (#3205)

From: Lars Eggert <[email-masked]>
Date: Fri, 08 Nov 2019 04:11:11 -0800

Now that `max_datagram_size` is a variable, other constants that are defined in terms of it need to become variables (or probably function), too. This includes at least `kInitialWindow` and `kMinimumWindow`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205

---

From: ianswett <[email-masked]>
Date: Fri, 08 Nov 2019 04:14:38 -0800

Good point, thanks for filing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205#issuecomment-551688621

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 18 Nov 2019 18:32:17 -0800

I have thoughts... I suggest the currently definition wrt max_datagram_size raises new safety issues. I am not sure a minimum of 10 * max_datagram_size, where max datagram, is say 9KB or 16KB, is actually something that is safe. From what I recall, the MSS term in IW for TCP related to sub 1500B MSS, and the need to constrain, not safe to expand. I suggest we define this in terms of the base size of 1280B. 

There is also an evil pathology in IPv4, where this can result in a router on path fragmenting larger packets to result in intense bursts of packets. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205#issuecomment-555304027

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 18 Nov 2019 18:36:57 -0800

#3243 - is related. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205#issuecomment-555305138

---

From: ianswett <[email-masked]>
Date: Mon, 18 Nov 2019 18:45:29 -0800

@gorryfair the current formula specifies a max of 14720 bytes, so increasing the MTU does not increase the IW beyond 14720.  This was based on the referenced RFC6928.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205#issuecomment-555307060

---

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 18 Nov 2019 18:57:51 -0800

Bah - the "and" in the ID text confused me, this actually is Min(10 * max_datagram_size, max(2 * max_datagram_size, 14720)). So - I was wrong on my comment, sorry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3205#issuecomment-555309794