Subject: [quicwg/base-drafts] Retry packet with zero-length token doesn't make sense (#3271)

From: Marten Seemann <[email-masked]>
Date: Fri, 22 Nov 2019 21:52:12 -0800

The Retry packet currently allows sending an empty token. The Retry token is defined as an opaque blob 
```
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
|                        Retry Token (*)                      ...
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
```
where `(*)` "indicates that x is variable-length", which also includes zero-length values.

On the wire, an Initial packet with a zero-length token is identical to an Initial without a token. However, there's a difference on the client side, since a client will perform at most a single Retry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3271

---

From: Martin Thomson <[email-masked]>
Date: Sun, 24 Nov 2019 22:22:09 -0800

Tagging this editorial.  This was clearly intended to be considered non-zero length.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3271#issuecomment-558009246