Subject: [quicwg/base-drafts] Limit CWND increase in slow start (#3183)

From: ianswett <[email-masked]>
Date: Fri, 01 Nov 2019 11:01:26 -0700

When not pacing packets, limit the CWND increase to 2 packets per ACK frame received and cite RFC3465.

Fixes #3094
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3183

-- Commit Summary --

  * Limit CWND increase in slow start

-- File Changes --

    M draft-ietf-quic-recovery.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3183.patch
https://github.com/quicwg/base-drafts/pull/3183.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3183

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 01 Nov 2019 14:47:36 -0700

janaiyengar commented on this pull request.

This is fine, but Vidhi is working on a PR for this that includes pseudo-code changes. I'd suggest that we wait for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3183#pullrequestreview-310711279

---

From: ianswett <[email-masked]>
Date: Fri, 01 Nov 2019 15:50:51 -0700

Given pacing is the recommended approach, what is the motivation to change the pseudocode?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3183#issuecomment-548976330

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 01 Nov 2019 16:19:17 -0700

The text is reflected in the psuedo-code, so changes to text should be reflected as well. I think it's useful to provide code for those not pacing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3183#issuecomment-548981463

---

From: Vidhi Goel <[email-masked]>
Date: Mon, 04 Nov 2019 12:58:44 -0800

goelvidhi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3183#pullrequestreview-311353844