Subject: [quicwg/base-drafts] Define AreAllPacketsLost() function (#3288)

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 06 Dec 2019 09:19:42 -0800

It's not very clear how the `AreAllPacketsLost()` function in the recovery draft should be implemnted, so having more guidance would be helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3288

---

From: ianswett <[email-masked]>
Date: Fri, 06 Dec 2019 09:23:45 -0800

Also, I believe the example is incorrect, and should be (7 - 0) = 7.  3 is correct for the packet number, not for the time.

`If an ack-eliciting packet is sent at time = 0, the following
   scenario would illustrate persistent congestion:

                     +-----+------------------------+
                     | t=0 | Send Pkt #1 (App Data) |
                     +-----+------------------------+
                     | t=1 | Send Pkt #2 (PTO 1)    |
                     |     |                        |
                     | t=3 | Send Pkt #3 (PTO 2)    |
                     |     |                        |
                     | t=7 | Send Pkt #4 (PTO 3)    |
                     |     |                        |
                     | t=8 | Recv ACK of Pkt #4     |
                     +-----+------------------------+

   The first three packets are determined to be lost when the ACK of
   packet 4 is received at t=8.  The congestion period is calculated as
   the time between the oldest and newest lost packets: (3 - 0) = 3.
   The duration for persistent congestion is equal to: (1 *
   kPersistentCongestionThreshold) = 3. `

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3288#issuecomment-562662906

---

From: ianswett <[email-masked]>
Date: Fri, 06 Dec 2019 09:27:00 -0800

Sorry, disregard my second comment, the example is correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3288#issuecomment-562664145

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 06 Dec 2019 09:30:35 -0800

Made https://github.com/quicwg/base-drafts/pull/3290 to update the pseudo-code.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3288#issuecomment-562665475