Subject: Re: [quicwg/base-drafts] Make transport parameters varint (#3169)

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Dec 2019 19:32:50 -0800

@DavidSchinazi, as we have decided not to do this, can we close this?  (It doesn't have an issue, so if we wanted to pursue it, we'd need one.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-560983044

---

From: David Schinazi <[email-masked]>
Date: Tue, 03 Dec 2019 10:16:52 -0800

@martinthomson I don't think we've quite decided not to do this yet. The sense I got in the room in Cupertino was that some folks were opposed to changing this, but the main opposition was the fact that I had conflated three issues into one (TLS presentation language, IANA registry, varint). The first one #3108 was merged, the second one #3170 is almost merged. I was thinking of filing a new issue and rebasing this PR when #3170 gets merged to have a conversation specific to this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561291569

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 03 Dec 2019 14:04:42 -0800

My recollection matches that of @martinthomson.  Unfortunately, I don't see it in the IETF 106 minutes and I don't have it in my own notes (I wasn't documenting every issue we covered...)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561377841

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 03 Dec 2019 14:37:02 -0800

FWIW my recollection also matches that of @martinthomson, and the relevant minutes are at https://github.com/quicwg/wg-materials/blob/master/interim-19-10/minutes.md#issue-3020-transport-parameter-registry-changes. It was discussed in Cupertino.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561388917

---

From: Marten Seemann <[email-masked]>
Date: Tue, 03 Dec 2019 17:36:16 -0800

I agree with @DavidSchinazi. Now that we're not using TLS presentation language any more, there's no need to continue using uint16s.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561435153

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 03 Dec 2019 17:52:11 -0800

> I agree with @DavidSchinazi. Now that we're not using TLS presentation language any more, there's no need to continue using uint16s.

I disagree with that way of thinking, as it is my understanding that we agreed on moving away from TLS presentation language _based on the premise_ that we would be using 16-bit lengths.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561438777

---

From: ianswett <[email-masked]>
Date: Wed, 04 Dec 2019 06:05:24 -0800

The notes are really sparse on the varint conversation, varint is mentioned 3 times.

Because this issue was conflated with other issues, it wasn't discussed much by itself.  I thought we decided to split it up, do the first two, and then discuss the third, which I remember some in the room commenting wasn't going to happen, but I didn't think that constituted consensus of any sort.

All that said, unless we have strong support for changing this, I think the status quo wins.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-561659746

---

From: David Schinazi <[email-masked]>
Date: Mon, 09 Dec 2019 19:56:56 -0800

@DavidSchinazi pushed 1 commit.

6bc3d4ad61c2c11baf7183488613e9fcc5dff1cb  Merge branch 'master' into varinttp

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169/files/e846500ce2ee4a6d78b2ab54c2dc9a2dc0d43c9b..6bc3d4ad61c2c11baf7183488613e9fcc5dff1cb

---

From: Marten Seemann <[email-masked]>
Date: Mon, 09 Dec 2019 20:03:23 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#pullrequestreview-329578401

---

From: David Schinazi <[email-masked]>
Date: Mon, 09 Dec 2019 20:09:44 -0800

I've now created issue #3294 so we can move the conversation there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#issuecomment-563741285