Subject: [quicwg/base-drafts] Issue: Incorrect offset in sample (#3279)

From: slightlyfloating <[email-masked]>
Date: Mon, 02 Dec 2019 11:12:19 -0800

I believe the sample given in https://tools.ietf.org/html/draft-ietf-quic-tls-24#appendix-A.2
contains an incorrect offset to the packet number field,

Considering the 22-byte long header given in the sample
c3 ff000017 08 8394c8f03e515708 00 00 449e 00000002
I think the following line
header[17..20] ^= mask[1..4]
is supposed to read:
header[18..21] ^= mask[1..4]
as the 4-byte packet number (0x00000002) actually start at offset 18 (0-based) of the header.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3279

---

From: Martin Thomson <[email-masked]>
Date: Mon, 02 Dec 2019 14:45:52 -0800

Closed #3279 via 9f09e6eee38f86f60336db70483c6b049dec90c9.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3279#event-2847548294