Subject: [quicwg/base-drafts] Unnecessary packet number expectations in ACK frame description (#3310)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 27 Dec 2019 07:44:29 -0800

The [Transport Draft](https://tools.ietf.org/html/draft-ietf-quic-transport-24#section-19.3) contains the following paragraph:

```
   It is expected that a sender will reuse the same packet number across
   different packet number spaces.  ACK frames only acknowledge the
   packet numbers that were transmitted by the sender in the same packet
   number space of the packet that the ACK was received in.
```

I see a few problems with the first sentence:
1. As written, it does not make sense.
1. There is no mention of packet number reuse expectations across packet number spaces in [Section 12.3](https://tools.ietf.org/html/draft-ietf-quic-transport-24#section-12.3).
1. The connection between it and the sentence that follows is not clear.

I propose that the first sentence simply be dropped.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3310

---

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 27 Dec 2019 07:58:23 -0800

The second sentence can stand some improvement as well:
1. There is no need for the word "only."
1. It is not necessary to say that the ACK frame was received.
1. Packets, not packet numbers, are acknowledged.

How about something like this:
> An ACK frame acknowledges packets in the same packet number space as the packet in which it is contained.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3310#issuecomment-569296381