Subject: Re: [quicwg/base-drafts] RTTVar is not really a variance (#3223)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 15:48:07 -0800

martinthomson commented on this pull request.

> @@ -251,8 +251,8 @@ RTT samples and peer-reported host delays (see Section 13.2 of
 {{QUIC-TRANSPORT}}) to generate a statistical description of the connection's
 RTT. An endpoint computes the following three values: the minimum value
 observed over the lifetime of the connection (min_rtt), an
-exponentially-weighted moving average (smoothed_rtt), and the variance in the
-observed RTT samples (rttvar).
+exponentially-weighted moving average (smoothed_rtt), and the mean deviation

I would say "variation (or mean deviation)"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223#discussion_r356339399

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 15:50:22 -0800

janaiyengar commented on this pull request.

```suggestion
exponentially-weighted moving average (smoothed_rtt), and the variation (or mean deviation)
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223#pullrequestreview-330222206

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 15:51:57 -0800

@ianswett pushed 1 commit.

77882faf2c30745a5444168dfeac8d708c9c8117  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223/files/7016f46e961bfc46a235379c274cdaf68fccd051..77882faf2c30745a5444168dfeac8d708c9c8117

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 15:52:03 -0800

d8ca865c63bf318b58938eb64adf064032f5971c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223/files/77882faf2c30745a5444168dfeac8d708c9c8117..d8ca865c63bf318b58938eb64adf064032f5971c

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 15:52:43 -0800

@janaiyengar pushed 1 commit.

60076da33e27d5f49d9cccfe7a8aee1c67171720  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223/files/d8ca865c63bf318b58938eb64adf064032f5971c..60076da33e27d5f49d9cccfe7a8aee1c67171720

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 15:53:32 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223#pullrequestreview-330223309

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 16:20:23 -0800

2625670ec2c3b179bcd81df66c6bf25946c38996  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223/files/60076da33e27d5f49d9cccfe7a8aee1c67171720..2625670ec2c3b179bcd81df66c6bf25946c38996

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 16:38:07 -0800

918a1c05d10f94cac30b4651aed997604673a360  Reduce repetition

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223/files/2625670ec2c3b179bcd81df66c6bf25946c38996..918a1c05d10f94cac30b4651aed997604673a360

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 18:15:26 -0800

Merged #3223 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3223#event-2872709761