Subject: [quicwg/base-drafts] Fix persistent congestion period calculation (#3289)

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 06 Dec 2019 09:19:49 -0800

Should use times instead of packet numbers (also fix formatting).
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3289

-- Commit Summary --

  * Fix persistent congestion period calculation

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3289.patch
https://github.com/quicwg/base-drafts/pull/3289.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289

---

From: Nick Banks <[email-masked]>
Date: Fri, 06 Dec 2019 09:23:24 -0800

nibanks commented on this pull request.

> @@ -735,7 +737,7 @@ illustrate persistent congestion:
 
 The first three packets are determined to be lost when the acknowlegement of
 packet 4 is received at t=8.  The congestion period is calculated as the time
-between the oldest and newest lost packets: (3 - 0) = 3.  The duration for
+between the oldest and newest lost packets: (7 - 0) = 7.  The duration for

I believe it was correct before. The time is the time between oldest and newest **lost** packets. The oldest **lost** packet was at t=3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#pullrequestreview-328346086

---

From: Nick Banks <[email-masked]>
Date: Fri, 06 Dec 2019 09:24:37 -0800

Sorry, ignore me. I misread the sample packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#discussion_r354944744

---

From: ianswett <[email-masked]>
Date: Fri, 06 Dec 2019 09:26:46 -0800

ianswett commented on this pull request.

Good point, my mistake on reading the example.  It's correct as is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#discussion_r354945872

---

From: Nick Banks <[email-masked]>
Date: Fri, 06 Dec 2019 09:26:57 -0800

Ok, the rich diff in the browser confused me once more. I go back to my original statement. I think the original text is correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#discussion_r354945957

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 06 Dec 2019 09:30:50 -0800

Closing, @nibanks is right.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#issuecomment-562665564

---

From: Alessandro Ghedini <[email-masked]>
Date: Fri, 06 Dec 2019 09:30:51 -0800

Closed #3289.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3289#event-2862192959