Subject: [quicwg/base-drafts] Contributors for -transport and -tls (#3283)

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Dec 2019 19:09:09 -0800

This is based on my scan of the git logs AND the working group mailing
list.  There were a few people who didn&#39;t make this first cut, but who
made what - in my judgment - were minor contributions only.  That&#39;s
obviously a little subjective and only based on the information I have,
so people who contributed text are more likely to appear here.

Let me know about obvious omissions.  Also, @janaiyengar might have a
few names to add.

This is currently failing to build properly due to some problems with
Unicode processing in xml2rfc.  There is apparently no path that will
preserve Unicode text, despite claims in RFC 7997 that what I&#39;m trying
to do here is entirely reasonable.

Stay tuned.  I hope to have some progress to report eventually.

For #3278.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3283

-- Commit Summary --

  * Contributors for -transport and -tls

-- File Changes --

    M draft-ietf-quic-tls.md (19)
    M draft-ietf-quic-transport.md (31)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3283.patch
https://github.com/quicwg/base-drafts/pull/3283.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283

---

From: ianswett <[email-masked]>
Date: Sun, 08 Dec 2019 07:03:54 -0800

ianswett approved this pull request.

These look reasonable to me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#pullrequestreview-328613954

---

From: ekr <[email-masked]>
Date: Sun, 08 Dec 2019 15:26:00 -0800

+1. You should also do a call for people who feel they were left out

On Sun, Dec 8, 2019 at 7:03 AM ianswett <[email-masked]> wrote:

> *@ianswett* approved this pull request.
>
> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/pull/3283?email_source=notifications&email_token=AAIPLIJQPFSKK24PQ7ITMMTQXUEFJA5CNFSM4JVCFH72YY3PNVWWK3TUL52HS4DFWFIHK3DMKJSXC5LFON2FEZLWNFSXPKTDN5WW2ZLOORPWSZGOCOLEAQQ#pullrequestreview-328613954>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/AAIPLIIHBKGQRTC66OSUWXTQXUEFJANCNFSM4JVCFH7Q>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#issuecomment-563008938

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 14:53:02 -0800

@martinthomson pushed 1 commit.

0260c0d214a62e4f9f23376e002391fb2031d43c  Add Subodh

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/60032ad476b19fa600eb93aec7edf6acc6bde034..0260c0d214a62e4f9f23376e002391fb2031d43c

---

From: Subodh Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 14:59:02 -0800

Thanks @martinthomson :), could you add me to quic-tls too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#issuecomment-564298249

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 16:21:30 -0800

0cc7ff777f4b5a9addcce3e233e75a79df3b718a  Add Adam

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/0260c0d214a62e4f9f23376e002391fb2031d43c..0cc7ff777f4b5a9addcce3e233e75a79df3b718a

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 16:22:25 -0800

5233ef1f9a80f5fd04e5d1ff46cbb36bfb2f0492  Move ACKs to contributors

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/0cc7ff777f4b5a9addcce3e233e75a79df3b718a..5233ef1f9a80f5fd04e5d1ff46cbb36bfb2f0492

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 16:23:48 -0800

88c283dbfe0e7e86260784fefca2ab1f8fca7a6d  Move ACKs to contributors, trim

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/5233ef1f9a80f5fd04e5d1ff46cbb36bfb2f0492..88c283dbfe0e7e86260784fefca2ab1f8fca7a6d

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 16:24:37 -0800

f02b9f7b45eb31a4fc71161fd0cac2b3ba968333  Remove extra sentence

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/88c283dbfe0e7e86260784fefca2ab1f8fca7a6d..f02b9f7b45eb31a4fc71161fd0cac2b3ba968333

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 16:27:49 -0800

1aa6c8fd5460949cd3278f378e2e1ea48c0810ac  Add Jana

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/f02b9f7b45eb31a4fc71161fd0cac2b3ba968333..1aa6c8fd5460949cd3278f378e2e1ea48c0810ac

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 10 Dec 2019 18:06:56 -0800

kazuho commented on this pull request.

>  # Contributors
 {:numbered="false"}
 
-Ryan Hamilton was originally an author of this specification.
+The IETF QUIC Working Group received an enormous amount of support from many
+people. The following people provided substantive contributions:
+Adam Langley,
+Alessandro Ghedini,
+Christian Huitema,
+Christopher Wood,
+David Schinazi,
+Dragana Damjanovic,
+Eric Rescorla,
+Ian Swett,
+Jana Iyengar,
+<u format="char-ascii" ascii="Kazuho Oku">?</u>,

@martinthomson Thank you for working on this.

Besides, I am really happy to see the possibility of using Kanjis to represent our names. Please let @tatsuhiro-t and me know if we are expected to file PRs that add / change the names to the characters we want.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#pullrequestreview-330261244

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 18:16:12 -0800

45f0b7f6aaf4778d65ae0df6a69a8ecca3b63321  Use contact element

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/1aa6c8fd5460949cd3278f378e2e1ea48c0810ac..45f0b7f6aaf4778d65ae0df6a69a8ecca3b63321

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Dec 2019 18:17:54 -0800

martinthomson commented on this pull request.

 {:numbered="false"}

Thanks.  Just give me the text in whatever way you like.  Paste it in a comment or send a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#discussion_r356374744

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Dec 2019 19:03:43 -0800

26fc408021b91bc2df26977694a6c7519a9e7d54  Rewrap to trick kramdown into using inline elements

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/45f0b7f6aaf4778d65ae0df6a69a8ecca3b63321..26fc408021b91bc2df26977694a6c7519a9e7d54

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Dec 2019 20:15:01 -0800

{:numbered="false"}

As my name in Japanese, please use "奥 一穂" (U+5965 U+0020  U+4e00  U+7a42). The space can be either U+0020 or U+3000 (Ideographic space).

Thank you in advance.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#discussion_r356951698

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Dec 2019 21:18:42 -0800

36267c2da84add8594e3d899d3b9ef333f4c616e  Kazuho's real name

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/26fc408021b91bc2df26977694a6c7519a9e7d54..36267c2da84add8594e3d899d3b9ef333f4c616e

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Dec 2019 00:44:08 -0800

{:numbered="false"}

Done.  I'm just waiting on a functional xml2rfc release now.

@tatsuhiro-t would you mind sharing your preferred name?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#discussion_r357017603

---

From: Tatsuhiro Tsujikawa <[email-masked]>
Date: Thu, 12 Dec 2019 04:14:20 -0800

tatsuhiro-t commented on this pull request.

 {:numbered="false"}

I'm just ok with "Tatsuhiro Tsujikawa" as is.  Thank you.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#discussion_r357112548

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Dec 2019 16:27:17 -0800

{:numbered="false"}

I'll do that.  Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283#discussion_r357436381

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Dec 2019 16:28:27 -0800

f5f3362f4b4ed3104bdc5e8dc4d77f7660ac8855  Tatsuhiro doesn't want Kanji

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/36267c2da84add8594e3d899d3b9ef333f4c616e..f5f3362f4b4ed3104bdc5e8dc4d77f7660ac8855

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Dec 2019 15:38:59 -0800

@janaiyengar pushed 1 commit.

4f906120e9b0d4b8fd890db98b1161cc2cac1179  Update draft-ietf-quic-tls.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/f5f3362f4b4ed3104bdc5e8dc4d77f7660ac8855..4f906120e9b0d4b8fd890db98b1161cc2cac1179

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Dec 2019 15:39:57 -0800

084d65369dadcc07fc4fe76ef2e87c3cd0f4d881  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3283/files/4f906120e9b0d4b8fd890db98b1161cc2cac1179..084d65369dadcc07fc4fe76ef2e87c3cd0f4d881