Subject: [quicwg/base-drafts] Guidance wrt ACK frames that don't fit in a packet (#3311)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 27 Dec 2019 08:05:43 -0800

The [ACK frame section](https://tools.ietf.org/html/draft-ietf-quic-transport-24#section-19.3) of the Transport Draft should explain what to do when generated ACK is too large to fit in a packet:
1. Generate a shorter ACK frame (instead of aborting connection or erroring out).
2. To generate the shorter frame, don't include older (smaller) packet numbers.  (As opposed to not including newer packet numbers.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3311

---

From: ianswett <[email-masked]>
Date: Sun, 29 Dec 2019 06:41:49 -0800

There is a good amount of existing text about what ranges to send, ie "ACK frames SHOULD always acknowledge the most recently received packets,"

I think this can be solved with some editorial additions to 13.2.2.
https://tools.ietf.org/html/draft-ietf-quic-transport-24#section-13.2.2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3311#issuecomment-569511666

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 31 Dec 2019 18:02:21 -0800

The text we already have in 13.2.4 has the right context:
```
  To limit receiver state or the size of ACK frames, a receiver MAY
   limit the number of ACK Ranges it sends.  A receiver can do this even
   without receiving acknowledgment of its ACK frames, with the
   knowledge this could cause the sender to unnecessarily retransmit
   some data.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3311#issuecomment-570014006

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 31 Dec 2019 20:10:04 -0800

Ok, this became a bigger fix. See #3316 and #3315.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3311#issuecomment-570019126