Subject: Re: [quicwg/base-drafts] Add Contributors (#3278)

From: Lars Eggert <[email-masked]>
Date: Tue, 03 Dec 2019 22:45:56 -0800

Do we need this? IMO it'll just open up a can of worms when someone later on feels like they should be on this list but aren't.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-561502391

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Dec 2019 02:22:14 -0800

Consider the can opened.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-561573846

---

From: ekr <[email-masked]>
Date: Wed, 04 Dec 2019 13:01:58 -0800

FWIW, we did this with TLS 1.3, and didn't have any serious problems. At
the end, I asked people who felt i had missed them to speak up and there
wasn't any controversy.

On Wed, Dec 4, 2019 at 2:22 AM Martin Thomson <[email-masked]>
wrote:

> —
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/3278?email_source=notifications&email_token=AAIPLIN4YIBYHM6W6UBVQS3QW6AE3A5CNFSM4JSOUQ6KYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOEF4O7VQ#issuecomment-561573846>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/AAIPLIKFAROSTUOHZ3SAIDDQW6AE3ANCNFSM4JSOUQ6A>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-561837111

---

From: David Schinazi <[email-masked]>
Date: Wed, 04 Dec 2019 17:53:11 -0800

I think this is a very good idea. Thanks for doing the work @martinthomson.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-561929979

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 04 Dec 2019 19:01:17 -0800

@larseggert : I think we can make this work.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-561945414

---

From: Mike Bishop <[email-masked]>
Date: Wed, 11 Dec 2019 08:52:54 -0800

FWIW, my plan was to use `git blame -w draft-ietf-quic-http.md | perl -n -e '/^.*?\((.*?)\s+[\d]{4}/; print $1,"\n"' | sort -f | uniq -c | sort -n` to generate an initial list and then use judgement where to draw the cut-off and/or add people who contributed on the mailing list but not on git.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-564634622

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Dec 2019 15:25:54 -0800

That's part of what I did.  `git shortlog -sne $file` might be better than blame, especially since that captures changes that were subsequently erased by other commits.  There are some duplicates as some people change names, and `root` appears to have contributed in at least one case, but it works well enough.

I also walked through the issues and mailing list to see if there were others who made contributions other than commits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3278#issuecomment-564778898