Subject: [quicwg/base-drafts] Keep RFC6928 non-normative (#3287)

From: ianswett <[email-masked]>
Date: Fri, 06 Dec 2019 07:48:57 -0800

Adds Gorry&#39;s suggestion for an editorial improvement.

Fixes #3245 with the suggested editorial change from @gorryfair 
An alternative to #3246 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3287

-- Commit Summary --

  * Keep RFC6928 non-normative

-- File Changes --

    M draft-ietf-quic-recovery.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3287.patch
https://github.com/quicwg/base-drafts/pull/3287.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287

---

From: ianswett <[email-masked]>
Date: Fri, 06 Dec 2019 10:43:36 -0800

@ianswett pushed 1 commit.

c8495ba33d09665dceb3b3a391f30f4654e4ed03  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287/files/802d40f7043ea1e3dd16a0f8fadb6c9d3162c9d8..c8495ba33d09665dceb3b3a391f30f4654e4ed03

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 06 Dec 2019 13:55:50 -0800

janaiyengar commented on this pull request.

> @@ -1253,10 +1253,11 @@ papers, and common practice.  Some may need to be changed or negotiated
 in order to better suit a variety of environments.
 
 kInitialWindow:
-: Default limit on the initial amount of data in flight, in bytes.  Taken from
-  {{?RFC6928}}, but increased slightly to account for the smaller 8 byte
-  overhead of UDP vs 20 bytes for TCP.  The RECOMMENDED value is the minimum
-  of 10 * max_datagram_size and max(2 * max_datagram_size, 14720)).
+: Default limit on the initial amount of data in flight, in bytes.
+  This follows the analysis and recommendations in {{?RFC6928}}, increasing the
+  byte limit to account for the smaller 8 byte overhead of UDP compared to the
+  20 byte overhead for TCP.  The RECOMMENDED value is the minimum of
+  10 * max_datagram_size and max(2 * max_datagram_size, 14720)).

Swap these two sentences -- recommendation first, rationale afterwards.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287#pullrequestreview-328479288

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 06:29:55 -0800

5ac62013d6dd9ee85e2061dc807caf192c22387e  Swap sentence order

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287/files/c8495ba33d09665dceb3b3a391f30f4654e4ed03..5ac62013d6dd9ee85e2061dc807caf192c22387e

---

From: ianswett <[email-masked]>
Date: Tue, 10 Dec 2019 06:30:04 -0800

ianswett commented on this pull request.

 kInitialWindow:

Done

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287#discussion_r356067946

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 15:09:14 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287#pullrequestreview-330207614

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Dec 2019 18:32:04 -0800

Let this run through the consensus process, since the issue is marked as design. I'm removing the editorial tag to avoid any confusion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3287#issuecomment-564349683