Subject: Re: [quicwg/base-drafts] What if an ACK frame doesn't fit in a packet (#3312)

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Jan 2020 19:03:50 -0800

martinthomson commented on this pull request.

Seems fine.

> @@ -3182,7 +3182,10 @@ caused by losing previously sent ACK frames, at the cost of larger ACK frames.
 ACK frames SHOULD always acknowledge the most recently received packets, and the
 more out-of-order the packets are, the more important it is to send an updated
 ACK frame quickly, to prevent the peer from declaring a packet as lost and
-spuriously retransmitting the frames it contains.
+spuriously retransmitting the frames it contains.  It's expected the ACK frame
+will be much smaller than a QUIC packet.  However, if the entire ACK frame
+does not fit into a single QUIC packet, older ranges with the smallest packet

The tautology here might be fixed with:

```suggestion
does not fit into a single QUIC packet, older ranges (that is, those with 
the smallest packet numbers) SHOULD be omitted.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312#pullrequestreview-337521707

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 12:59:48 -0800

@ianswett pushed 1 commit.

a69e561fa432d95adabf735e328a113edeba526f  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/364bbfb7073737bed108ad711828b3e747bde12c..a69e561fa432d95adabf735e328a113edeba526f

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 13:00:47 -0800

7d17c456141051542476f65052ae01aed94e4bbe  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/a69e561fa432d95adabf735e328a113edeba526f..7d17c456141051542476f65052ae01aed94e4bbe

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 13:08:12 -0800

@janaiyengar In terms of which is the right section, I'll explain my thinking.

In my mind, I think of the subsequent two sections as examples of how one could limit ACK frame size, but not really required reading, because I think that's how they were originally written?  However, there's quite a bit of normative text in there, so maybe I have an obsolete mental model.

An easy alternative to doing what's in those sections is to set a max number of ACK ranges(ie: 3), which I think should be considered acceptable, even if it might not be optimal.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312#issuecomment-570349751

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 12:26:55 -0800

Let's land this and handle any redundancies in an editorial pass along with #3316.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312#issuecomment-571756551

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 12:35:02 -0800

janaiyengar approved this pull request.

A few suggestions

```suggestion
spuriously retransmitting the frames it contains.  The ACK frame is expected
```

```suggestion
to fit within a single QUIC packet.  If it does not, then older ranges
```

+does not fit into a single QUIC packet, older ranges (that is, those with the

```suggestion
(those with the smallest packet numbers) are omitted.
```

 ACK frames SHOULD always acknowledge the most recently received packets, and the
 more out-of-order the packets are, the more important it is to send an updated
 ACK frame quickly, to prevent the peer from declaring a packet as lost and
-spuriously retransmitting the frames it contains.
+spuriously retransmitting the frames it contains.  It's expected the ACK frame
+will be much smaller than a QUIC packet.  However, if the entire ACK frame
+does not fit into a single QUIC packet, older ranges (that is, those with the
+smallest packet numbers) SHOULD be omitted.

```suggestion
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312#pullrequestreview-339487828

---

From: ianswett <[email-masked]>
Date: Tue, 07 Jan 2020 12:35:26 -0800

ef30511043224abd03c2ce809d86f92769302f75  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/7d17c456141051542476f65052ae01aed94e4bbe..ef30511043224abd03c2ce809d86f92769302f75

---

From: ianswett <[email-masked]>
Date: Tue, 07 Jan 2020 12:35:47 -0800

074d22ce06be9ffd0d9bba66b5425efc568c3670  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/ef30511043224abd03c2ce809d86f92769302f75..074d22ce06be9ffd0d9bba66b5425efc568c3670

---

From: ianswett <[email-masked]>
Date: Tue, 07 Jan 2020 12:35:53 -0800

a48e87201d2a1cd5ecf43e99dc6bbd078d0e9285  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/074d22ce06be9ffd0d9bba66b5425efc568c3670..a48e87201d2a1cd5ecf43e99dc6bbd078d0e9285

---

From: ianswett <[email-masked]>
Date: Tue, 07 Jan 2020 12:35:59 -0800

91ccecd035d0fa06084f9605e1735e495f48b2ac  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/a48e87201d2a1cd5ecf43e99dc6bbd078d0e9285..91ccecd035d0fa06084f9605e1735e495f48b2ac

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 14:47:11 -0800

@janaiyengar pushed 1 commit.

417e341285472b0986ee5024844d154314d59652  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312/files/91ccecd035d0fa06084f9605e1735e495f48b2ac..417e341285472b0986ee5024844d154314d59652

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 15:07:43 -0800

Merged #3312 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3312#event-2929351164