Subject: [quicwg/base-drafts] Remove hole left in error codes from early response removal. (#3367)

From: Cory Nelson <[email-masked]>
Date: Sat, 18 Jan 2020 21:34:30 -0800

Removes a hole in error codes introduced by removing H3_EARLY_RESPONSE in https://github.com/quicwg/base-drafts/pull/3208
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3367

-- Commit Summary --

  * Fix hole left in error codes from H3_EARLY_RESPONSE removal.

-- File Changes --

    M draft-ietf-quic-http.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3367.patch
https://github.com/quicwg/base-drafts/pull/3367.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3367

---

From: Martin Thomson <[email-masked]>
Date: Sun, 19 Jan 2020 22:34:05 -0800

martinthomson commented on this pull request.

Changes that have interoperability implications need to have design issues opened for them, otherwise we get interop problems.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3367#pullrequestreview-345100376

---

From: Mike Bishop <[email-masked]>
Date: Mon, 20 Jan 2020 10:38:42 -0800

We might take this close to the end, but my inclination would be to wait and see if we define any more error codes.  Just stick the new one in the hole.

I agree we ideally don't want to ship with a gap, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3367#issuecomment-576390315

---

From: Cory Nelson <[email-masked]>
Date: Mon, 20 Jan 2020 17:34:01 -0800

Closed #3367.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3367#event-2964580111

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 20 Jan 2020 17:37:26 -0800

If we are to renumber things, I'd appreciate it if that could be done before we start running the protocol in production.

The reason is that once we ship QUIC and H3, it is likely that we'd be required to run more than one draft version concurrently. Once that happens, change of codepoints becomes a headache.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3367#issuecomment-576482079