Subject: Re: [quicwg/base-drafts] Ambiguous wording about error codes in HTTP/3 (#3276)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jan 2020 16:01:59 -0800

@afrind points out that promotion from stream to connection error is something you shouldn't do absent an understanding of the error semantics.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-571829794

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Jan 2020 16:07:35 -0800

The only case where this matters is for stream errors (RESET_STREAM / STOP_SENDING).  The scenario we want to avoid is closing the connection in response to an unexpected error code in a stream closure.  So the right guidance here might be to say that you MUST NOT close the connection based on the unexpected error code.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-571831188

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Jan 2020 16:14:24 -0800

Correction:  We also care about closing one side of bidirectional streams.  You shouldn't close the other direction because the first direction closed.  One possibility is to treat unknown error codes as equivalent to NO_ERROR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-571832643

---

From: afrind <[email-masked]>
Date: Wed, 08 Jan 2020 16:15:13 -0800

> You shouldn't close the other direction because the first direction closed

If you receive a STOP_SENDING, aren't you supposed to RESET_STREAM if you haven't sent a FIN yet?  I guess the other direction is weirder (abrupt termination of response, should you terminate the request too. etc?) but probably tearing everything down is the right move most of the time?  At least it's not totally unexpected or catastrophic.  Preventing connection closure still seems like the main objective.

I think the general guidance of 'treat unknown error codes as you would treat NO_ERROR' is good, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-572320133

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jan 2020 10:57:04 -0800

> If you receive a STOP_SENDING, aren't you supposed to RESET_STREAM if you haven't sent a FIN yet?

Right, but if you receive a RESET_STREAM, that doesn't tell you anything about what to do with the other direction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-572703828

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 Jan 2020 12:32:01 -0800

@larseggert / @mnot, this is borderline, but the PR does touch the specifics of the "MUST."  Shall we run the process on this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-573856417

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 13 Jan 2020 16:04:52 -0800

I don't think it changes the intent; let's keep it editorial unless someone explicitly objects to that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-573933867

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Jan 2020 07:23:27 -0800

SOLD, as editorial, to the chairs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#issuecomment-574226495

---

From: Mike Bishop <[email-masked]>
Date: Tue, 14 Jan 2020 07:24:12 -0800

Closed #3276 via #3331.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3276#event-2947492998