Subject: [quicwg/base-drafts] Remove HTTP_ prefix (#3372)

From: Mike Bishop <[email-masked]>
Date: Tue, 21 Jan 2020 08:16:52 -0800

I noticed that the QPACK error codes still started with the HTTP_QPACK_ prefix, while the HTTP document has shifted to H3_ as the prefix.  I shortened the QPACK prefix to simply &quot;QPACK_&quot;, though &quot;H3_QPACK&quot; could work, too.

Along the way, I noticed that backticks were sometimes, but not always, used when referring to the error code names.  We haven&#39;t been in the HTTP document, so I reconciled them to not.  Again, this could go the opposite way.

I also noticed that the settings are &quot;SETTINGS_QPACK_&quot; except in the IANA registration where they&#39;re simply &quot;QPACK_&quot;.  I didn&#39;t touch those, but am open to feedback on whether that&#39;s worth trimming/reconciling.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3372

-- Commit Summary --

  * Remove HTTP_ prefix

-- File Changes --

    M draft-ietf-quic-qpack.md (56)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3372.patch
https://github.com/quicwg/base-drafts/pull/3372.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372

---

From: ianswett <[email-masked]>
Date: Tue, 21 Jan 2020 10:17:26 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372#pullrequestreview-346088689

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 21 Jan 2020 15:09:38 -0800

LPardue approved this pull request.

QPACK_ prefix WFM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372#pullrequestreview-346255024

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Jan 2020 17:37:05 -0800

martinthomson approved this pull request.

Do it.  You don't need my approval to do something that is so self-evidently a good idea.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372#pullrequestreview-346301530

---

From: Mike Bishop <[email-masked]>
Date: Wed, 22 Jan 2020 09:00:39 -0800

@martinthomson, I don't need your approval, but I kind of do need @afrind's.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372#issuecomment-577284286

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jan 2020 15:08:19 -0800

Well, you did ask :)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3372#issuecomment-577428986