Subject: [quicwg/base-drafts] Move out-of-order packets definition (#3369)

From: ianswett <[email-masked]>
Date: Mon, 20 Jan 2020 11:50:43 -0800

>From recovery to transport.

Fixes #3347 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3369

-- Commit Summary --

  * Update draft-ietf-quic-recovery.md

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3369.patch
https://github.com/quicwg/base-drafts/pull/3369.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jan 2020 11:51:33 -0800

@ianswett pushed 1 commit.

cfe4321590f623a3ba210a232cb31618e1781f9c  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369/files/a1b58beacd0efb45c1a13b7cd110208c105181ea..cfe4321590f623a3ba210a232cb31618e1781f9c

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 20 Jan 2020 15:28:56 -0800

kazuho commented on this pull request.

Thank you for working on this.

> @@ -196,6 +196,12 @@ Ack-eliciting Packet:
   CONNECTION_CLOSE. These cause a recipient to send an acknowledgment (see
   {{sending-acknowledgements}}).
 
+Out-of-order Packets:
+
+: Packets that do not increase the largest received packet number for its
+  packet number space by exactly one. Packets arrive out of order
+  when earlier packets are lost or delayed.

Do we need to point out that an endpoint also might skip a packet number intentionally, as suggested in [section 21.3](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-optimistic-ack-attack)?

Or maybe we should state in that section that skipping packet numbers too frequently would lead to an unnecessarily large number of ACK packets being sent in response.

Not that I have a strong opinion here, but I just wanted to make sure we'd be fine with what we'd have.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#pullrequestreview-345570841

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 20 Jan 2020 16:44:05 -0800

janaiyengar commented on this pull request.

+Out-of-order Packets:

```suggestion
Out-of-order packet:
```

+Out-of-order Packets:
+

```suggestion
: A packet that does not increase the largest received packet number for its
```

+Out-of-order Packets:
+

```suggestion
  packet number space by exactly one. A packet can arrive out of order
```

+Out-of-order Packets:
+

```suggestion
  if it is delayed or if earlier packets are lost or delayed.
```

+Out-of-order Packets:
+

I think it's worth mentioning something in 21.3, but I don't think it belongs in this definition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#pullrequestreview-345583943

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jan 2020 17:55:01 -0800

5fb51fc4b85d756b1cc605212a225666fca0e6e7  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369/files/cfe4321590f623a3ba210a232cb31618e1781f9c..5fb51fc4b85d756b1cc605212a225666fca0e6e7

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jan 2020 10:07:21 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#pullrequestreview-346082560

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jan 2020 10:07:51 -0800

Merged #3369 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#event-2967232883