Subject: [quicwg/base-drafts] editorial: Remove ACK-only (#3381)

From: mirjak <[email-masked]>
Date: Wed, 22 Jan 2020 07:50:26 -0800

ACK-only was only even used in the definition part and in-flight can also be defined using ack-eliciting.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3381

-- Commit Summary --

  * editorial: Remove ACK-only

-- File Changes --

    M draft-ietf-quic-recovery.md (16)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3381.patch
https://github.com/quicwg/base-drafts/pull/3381.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381

---

From: mirjak <[email-masked]>
Date: Wed, 22 Jan 2020 07:55:59 -0800

@mirjak pushed 1 commit.

ab2a97a4504b1dbee515210d364e17dfa1cc6d85  add padding

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381/files/2dfdd0fc05734aede0fff51a2c7f21704b3e3358..ab2a97a4504b1dbee515210d364e17dfa1cc6d85

---

From: mirjak <[email-masked]>
Date: Wed, 22 Jan 2020 07:57:40 -0800

I just realised that padding is the "complicating" thing here. I still don't think we need to define "act-only" just for that but can rather be explicit about padding frames because otherwise this is easy to miss (as I did initially).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381#issuecomment-577254465

---

From: mirjak <[email-masked]>
Date: Wed, 22 Jan 2020 08:06:50 -0800

@mirjak pushed 1 commit.

49ea0b98bf5657650fddb390b447362835561e6c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381/files/ab2a97a4504b1dbee515210d364e17dfa1cc6d85..49ea0b98bf5657650fddb390b447362835561e6c

---

From: Mike Bishop <[email-masked]>
Date: Wed, 22 Jan 2020 09:40:49 -0800

While the defined term is not used elsewhere, the terms "Packets containing only ACK frames" and "Packets only containing ACK frames" are used.  We should either eliminate the definition or explicitly use the defined term in those places.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381#issuecomment-577301764

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jan 2020 14:48:43 -0800

martinthomson approved this pull request.

Of Mike's options, I think that this makes sense.  Fewer defined terms means lower fixed cognitive load when reading this.  Less jargon = good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381#pullrequestreview-346958907

---

From: ianswett <[email-masked]>
Date: Wed, 22 Jan 2020 15:38:07 -0800

ianswett approved this pull request.

I re-read the other spots @MikeBishop mentioned and I believe the text is still correct, so I'm going to accept this.

Thanks for the simplification.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381#pullrequestreview-346979053

---

From: ianswett <[email-masked]>
Date: Wed, 22 Jan 2020 15:38:14 -0800

Merged #3381 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3381#event-2971989998