Subject: Re: [quicwg/base-drafts] Server cannot proceed after invalid Retry token (#3396)

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Jan 2020 10:43:09 +0000 (UTC)

The problem here is that something that is identifiable as a Retry token as distinct from a NEW_TOKEN token will ultimately not be usable.  There's a bit of hedging necessary though as junk that appears to be a Retry token is still ultimately just junk.

To be concrete, let's say that you generate Retry tokens that start with "RETRY!!!" and NEW_TOKEN tokens start with "~~~NEW_TOKEN" The difference between those two is such that it would be unlikely for corruption to cause one to be mistaken for the other, and you have a way to distinguish the two even when all the subsequent bits can't be interpreted after you lose keys or something like that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3396#issuecomment-579185046

---

From: Mike Bishop <[email-masked]>
Date: Tue, 28 Jan 2020 10:51:49 -0800

The only case in which the server can proceed is when the server sees a junk token, but knows that the client does not consider it a Retry token.  There's no mechanism for the client to tell the server what it thinks the token it has presented is, so the server doesn't know when it's in this state.  I agree -- axe it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3396#issuecomment-579398817

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 28 Jan 2020 17:20:14 -0800

As pointed out by @marten-seemann and @dtikhonov, the client would reject the handshake even if the server ignores the token and proceeds with the handshake. This is because TP.original_connection_id would not contain the expected value.

I now agree that this MAY is awkward and that we can strike the sentence.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3396#issuecomment-579549670