Subject: [quicwg/base-drafts] Retry integrity protection should not add new requirements to TLS API (#3366)

From: Kazuho Oku <[email-masked]>
Date: Sat, 18 Jan 2020 18:57:29 -0800

Retry integrity protection (#3120) specifies the AES-GCM key and IV directly. While that works fine for people using TLS stacks that provide direct access to AES-GCM, it does not for people using TLS stacks that only provides access to TLS AEAD API.

I think we can resolve the concern by simply changing the hard-coded AES-GCM key and IV we specify in the TLS draft to a set of values that can be derived by using the TLS AEAD API.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3366

---

From: Martin Thomson <[email-masked]>
Date: Sun, 19 Jan 2020 22:31:15 -0800

It would be easier for me to do as @kazuho suggested, but the overall effort is small.  I can live with either answer.  Note that the additional indirection can be hard-coded out if people find they want to prime their AES directly.  Of course, you don't need to run AES at all if you want to go that far.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3366#issuecomment-576126951

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 21 Jan 2020 13:53:10 -0800

I agree that this is not a must, even though it's about helping some of the implementations.

I would highly appreciate it if you could merge the PR before -25 ships, as I think changing the default key before shipping the first draft that adopts the GCM-based Retry protection would have the least friction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3366#issuecomment-576900098

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jan 2020 14:39:48 -0800

This is useful, and we should merge this. I don't think this needs to be design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3366#issuecomment-576919630

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Jan 2020 15:12:16 -0800

Closed #3366 via #3365.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3366#event-2968128518