Subject: Re: [quicwg/base-drafts] ACK frames PN space editorial (#3313)

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Jan 2020 19:02:44 -0800

martinthomson commented on this pull request.

This is better than #3314, I think, though I have a suggestion here.

> @@ -4747,10 +4747,9 @@ QUIC acknowledgements are irrevocable.  Once acknowledged, a packet remains
 acknowledged, even if it does not appear in a future ACK frame.  This is unlike
 TCP SACKs ({{?RFC2018}}).
 
-It is expected that a sender will reuse the same packet number across different
-packet number spaces.  ACK frames only acknowledge the packet numbers that were
-transmitted by the sender in the same packet number space of the packet that the
-ACK was received in.
+An ACK frame acknowledges packets in the same packet number space as the packet
+in which it is contained.  As such, the same packet number can be acknowledged

```suggestion
in which it is contained.  Packets from different packet number spaces can be identified using the same numeric value.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#pullrequestreview-337521597

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 12:53:39 -0800

@ianswett pushed 1 commit.

a925d9c08639e82bd28e933212018f263a83ae92  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313/files/8cc78262e5363e7d36e30e00b0f88dfb9056001e..a925d9c08639e82bd28e933212018f263a83ae92

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 12:54:27 -0800

73b9b04d52a67774551265c2f4509478b5ce9ff1  Martin's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313/files/a925d9c08639e82bd28e933212018f263a83ae92..73b9b04d52a67774551265c2f4509478b5ce9ff1

---

From: ianswett <[email-masked]>
Date: Thu, 02 Jan 2020 12:54:57 -0800

Thanks for the suggestion @martinthomson , accepted.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#issuecomment-570344538

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 04 Jan 2020 18:14:32 -0800

I have an editorial disagreement here, but as with all such disagreements, I'm happy to go with whatever more people think reads better.

I find this use of "numeric value" to be unnecessary. Making it implicit (which is what this sentence is doing) doesn't really change the way a reader consumes this sentence. As a reader, I will replace "numeric value" with "packet number"; there isn't a different definition for packet number that is anything more than the numeric value.

At a minimum, I would swap the order of the two sentences.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#issuecomment-570837550

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 15:45:19 -0800

@janaiyengar pushed 1 commit.

6be25520cc09cb7eed433cb03998a9a137504fef  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313/files/73b9b04d52a67774551265c2f4509478b5ce9ff1..6be25520cc09cb7eed433cb03998a9a137504fef

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 15:50:50 -0800

a570bfb9ca01f49ff9d40f44e22596709b9b80ee  ekr's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313/files/6be25520cc09cb7eed433cb03998a9a137504fef..a570bfb9ca01f49ff9d40f44e22596709b9b80ee

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 15:53:46 -0800

5fe4a8f21e570441b9e12dfeb583c53101b12b1c  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313/files/a570bfb9ca01f49ff9d40f44e22596709b9b80ee..5fe4a8f21e570441b9e12dfeb583c53101b12b1c

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jan 2020 15:54:20 -0800

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#pullrequestreview-339579686

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jan 2020 16:13:16 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#pullrequestreview-339585169

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Jan 2020 16:22:26 -0800

Merged #3313 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3313#event-2929488304