Subject: [quicwg/base-drafts] Small clarification and one nit (recovery) (#3392)

From: mirjak <[email-masked]>
Date: Thu, 23 Jan 2020 03:45:30 -0800

Btw. is it &quot;a 1-RTT packet&quot; or &quot;an 1-RTT packet&quot;? I found one occasion of &quot;an 1-RTT packet&quot; in the transport draft but otherwise there is always &quot;a 1-RTT packet&quot;... so I assume the one in the transport draft should be fixed...?
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3392

-- Commit Summary --

  * Small clarification and one nit (recovery)

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3392.patch
https://github.com/quicwg/base-drafts/pull/3392.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3392

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 23 Jan 2020 03:58:53 -0800

FWIW: "a 1-RTT packet" is the correct construct

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3392#issuecomment-577650903

---

From: ianswett <[email-masked]>
Date: Thu, 23 Jan 2020 05:25:30 -0800

ianswett commented on this pull request.

> @@ -467,14 +467,14 @@ Handshake packet number spaces, the max_ack_delay is 0, as specified in
 The PTO value MUST be set to at least kGranularity, to avoid the timer expiring
 immediately.
 
-A sender computes its PTO timer every time an ack-eliciting packet is sent.
+A sender resets its PTO timer every time an ack-eliciting packet is sent.

I think computes is more accurate in this case, because the timer may not change if another packet number space will fire earlier.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3392#pullrequestreview-347291445

---

From: mirjak <[email-masked]>
Date: Thu, 23 Jan 2020 05:52:21 -0800

mirjak commented on this pull request.

On a quick read it's actually not clear from the beginning that there is only one timer and not a separate timer for each packet. So maybe "recomputes" catches that? Or we could add a separate (half-)sentence.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3392#discussion_r370128036