Subject: [quicwg/base-drafts] Add sample Retry packet (#3394)

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Jan 2020 18:36:17 -0800

Can someone please verify my work?  I&#39;ve written two implementations
here and the values match, but I value independent validation.

Closes #3374.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3394

-- Commit Summary --

  * Add sample Retry packet

-- File Changes --

    M draft-ietf-quic-tls.md (31)
    R protection-samples.js (34)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3394.patch
https://github.com/quicwg/base-drafts/pull/3394.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394

---

From: Marten Seemann <[email-masked]>
Date: Thu, 23 Jan 2020 19:00:29 -0800

@martinthomson The value matches what quic-go is calculating. Will add this test vector as a unit test to my implementation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#issuecomment-577971855

---

From: Martin Thomson <[email-masked]>
Date: Thu, 23 Jan 2020 19:01:31 -0800

Woo!  I'm not as bad at this as I thought.  Thanks @marten-seemann.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#issuecomment-577972069

---

From: Marten Seemann <[email-masked]>
Date: Thu, 23 Jan 2020 20:50:06 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#pullrequestreview-347749895

---

From: Mike Bishop <[email-masked]>
Date: Fri, 24 Jan 2020 09:55:22 -0800

MikeBishop commented on this pull request.

> @@ -1973,6 +1973,19 @@ cd32f0b5004d9f5754c4f7f2d1f35cf3 f7116351c92b99c8ae5833225cb51855
 ~~~

+## Retry
+
+This shows a Retry packet that might be sent in response to the Initial packet
+in {{sample-client-initial}}. The integrity check includes the client-chosen
+connection ID value of 0x8394c8f03e515708, but that value is not transmitted

```suggestion
connection ID value of 0x8394c8f03e515708, but that value is not
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#pullrequestreview-348123178

---

From: Rui Paulo <[email-masked]>
Date: Fri, 24 Jan 2020 16:02:27 -0800

rpaulo approved this pull request.

I also tested these vectors and it works fine.  Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#pullrequestreview-348286539

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Jan 2020 07:14:16 -0800

@martinthomson pushed 1 commit.

ba45c0b4487ac98597cc86a91f554a7a22bb6cb9  double double

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394/files/eae51430d786e69574ec885281b9c828e4785884..ba45c0b4487ac98597cc86a91f554a7a22bb6cb9

---

From: Martin Thomson <[email-masked]>
Date: Sun, 26 Jan 2020 07:18:10 -0800

Merged #3394 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3394#event-2979971132