Subject: Re: [quicwg/base-drafts] Editorial-only NITS on QUIC-Transport-24 (#3214)

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 29 Jan 2020 07:07:04 -0800

Each of these two dozen or so nits requires its own GitHub issue.  It will become unwieldy quickly were we to start discussing all of them in one place.  This is likely there have been no comments since this issue was opened.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3214#issuecomment-579797942

---

From: Gorry Fairhurst <[email-masked]>
Date: Wed, 29 Jan 2020 08:12:17 -0800

I'll let the editors propose how to handle these. If you want to make each of these an issue we can do that... or I can submit them as WGLC comments or we can just discuss using the list.- I still expect few (if any) of these are likely to result in important technical changes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3214#issuecomment-579832829

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 29 Jan 2020 08:24:01 -0800

I, too, think that editors should edit.  I take back my "requires its own issue" remark -- I did not mean to demand that it be done.  On the other hand, since the issue has not been commented upon, I presume that the editors' expectation is that PRs be opened.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3214#issuecomment-579838822

---

From: ianswett <[email-masked]>
Date: Wed, 29 Jan 2020 11:11:31 -0800

I expect once most of the design issues have been closed, the editors will focus more on closing out remaining editorial issues.  In the meantime, if there are small editorial issues I know how to fix, I try to fix them, but it's best effort at the moment.

As always, PRs to fix editorial issues are appreciated.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3214#issuecomment-579912494

---

From: Mike Bishop <[email-masked]>
Date: Thu, 30 Jan 2020 09:08:49 -0800

PRs are a great way to fix *simple* editorial issues -- spelling, broken references, etc.  Things get dicey when an "editorial" PR changes the meaning or flow of the text and we don't want to take the whole of a given PR.  Then an editor needs to either accept the PR and partially revert it, or they need to duplicate the work for the things they want to keep.

Without looking super closely at the list of changes here, I probably wouldn't want to get a single PR that made all of these changes at once.  (Noting, of course, that this isn't my document.)

So my personal recommendation:
- Combination PRs for totally obvious editorial fixes
- Separate PRs for more invasive or controversial editorial fixes
- Issues for design changes and/or editorial issues where the solution isn't obvious (or you don't want to write it yourself)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3214#issuecomment-580356028