Subject: [quicwg/base-drafts] Grease HTTP/3 error codes (#3325)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jan 2020 16:17:22 -0800

The discussion on #3276 made us conclude that the reason for doing this is that we want to safeguard our ability to define new error codes.  Greasing might help with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3325

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 07 Jan 2020 16:25:08 -0800

Since you'd probably want want the grease to not sacrifice connections it might make sense to couple grease error codes to H3 grease streams.

Also, what about greasing of transport-level error codes? Can't play the stream tricks there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3325#issuecomment-571835305

---

From: Mike Bishop <[email-masked]>
Date: Fri, 17 Jan 2020 12:40:51 -0800

Unknown error codes are supposed to be equivalent to H3_NO_ERROR.  Perhaps a recommendation (SHOULD) to substitute a grease code with non-zero probability when you would have sent NO_ERROR?  And MAY use them when terminating grease streams, sure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3325#issuecomment-575787099

---

From: Mike Bishop <[email-masked]>
Date: Tue, 21 Jan 2020 15:43:18 -0800

Closed #3325 via #3360.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3325#event-2968192424