Subject: [quicwg/base-drafts] Clarify CANCEL_PUSH server send conditions (#3387)

From: BrianGithubber <[email-masked]>
Date: Wed, 22 Jan 2020 14:25:27 -0800

The current draft (7.2.3) says:
A server SHOULD NOT send a CANCEL_PUSH when it has already created a corresponding push stream.

However, this is ambiguous.   In our implementation, at least, it is possible to create a push stream, but not have sent anything on that push stream yet.
If a failure happens while in this state, and we don’t send a CANCEL_PUSH per current draft, then the peer will never know that that push stream has failed.

A possible suggested edit could be:
A server SHOULD NOT send a CANCEL_PUSH after it has completed a send on the corresponding push stream of the pushId.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3387

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 22 Jan 2020 14:31:55 -0800

In this state, the server could abruptly terminate the stream (I.E RESET_STREAM) with the error code H3_REQUEST_CANCELLED or H3_NO_ERROR

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3387#issuecomment-577417080

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jan 2020 14:35:13 -0800

In some cases, creating a stream can result in a STREAM frame being sent.  It depends on the shape of the contract between the different components.  And it also might be difficult to determine whether anything has been sent.

I believe that the existing language is fine.

If you have created a stream object locally, and can be sure that the other side is unaware of this, and you have some means of taking it back or repurposing it, then it's fine to do that.  Note that this is only a "SHOULD" anyway.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3387#issuecomment-577418196

---

From: BrianGithubber <[email-masked]>
Date: Thu, 23 Jan 2020 08:53:27 -0800

Closed #3387.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3387#event-2974492336