Subject: [quicwg/base-drafts] Revert "Remove "Ignoring Loss of Undecryptable Packets"" (#3449)

From: ianswett <[email-masked]>
Date: Tue, 11 Feb 2020 07:29:47 -0800

Reverts quicwg/base-drafts#3442

I think this text needs clarification, but the reason I removed it was incorrect, because the reason these packets end up being declared lost is due to the timing of key availability and a peer dropping any packets it cannot decrypt immediately.  So the packets were in fact &#39;lost&#39;, but by the peer, not the network.

Sorry for the churn.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3449

-- Commit Summary --

  * Revert &quot;Remove &quot;Ignoring Loss of Undecryptable Packets&quot;&quot;

-- File Changes --

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3449.patch
https://github.com/quicwg/base-drafts/pull/3449.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3449

---

From: Marten Seemann <[email-masked]>
Date: Tue, 11 Feb 2020 08:11:29 -0800

marten-seemann approved this pull request.

The commit seems to change no files (?).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3449#pullrequestreview-356788987

---

From: ianswett <[email-masked]>
Date: Tue, 11 Feb 2020 08:27:47 -0800

Interesting, that's my first time using revert.  I'll manually revert it I guess.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3449#issuecomment-584721608

---

From: ianswett <[email-masked]>
Date: Tue, 11 Feb 2020 08:28:14 -0800

Closed #3449.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3449#event-3027268373