Subject: Re: [quicwg/base-drafts] MIN_RTT management (#2923)

From: ianswett <[email-masked]>
Date: Tue, 04 Feb 2020 06:37:33 -0800

After more discussion, I think Jana's right and we should close this with no action.  The min_rtt in QUIC recovery is used for a very specific purpose(preventing 'silly' SRTTs due to ack_delay) and not meant for other purposes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-581939361

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 04 Feb 2020 07:08:08 -0800

I don't agree that the method is robust to path changes that result in a larger RTT. I can read the latest draft and see if the comment still applies.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-581953891

---

From: Christian Huitema <[email-masked]>
Date: Wed, 05 Feb 2020 03:55:00 -0800

The corresponding mechanism in BBR uses a 10 seconds interval. Quite different from the 600 seconds mentioned above.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-582373505

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 03:57:24 -0800

Discussed in ZRH. Proposed resolution is to close with no action. Possible new Editorial PR to explain that `min_rtt` is only used to provide a safety feature and having a potentially stale value is therefore not terrible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-582374281

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 06 Feb 2020 05:25:19 -0800

OK - I missed the part of the meeting discussing that: I concur that  if QUIC never uses this variable for other things, then the current specific use of min_rtt in the latest rev does note the problem above.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-582904192

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 06 Feb 2020 05:25:22 -0800

Closed #2923.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#event-3013858152

---

From: Martin Thomson <[email-masked]>
Date: Thu, 06 Feb 2020 05:34:01 -0800

I'm going to re-open this so that we can let the process run, but thanks for acknowledging this Gorry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#issuecomment-582907619

---

From: Martin Thomson <[email-masked]>
Date: Thu, 06 Feb 2020 05:34:03 -0800

Reopened #2923.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/2923#event-3013888400