Subject: Re: [quicwg/base-drafts] HTTP/QUIC without Alt-Svc? (#253)

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 06:10:18 -0800

Discussed in ZRH. Waiting for HTTP changes to materialize.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/253#issuecomment-582425051

---

From: Evgeny Vrublevsky <[email-masked]>
Date: Sat, 08 Feb 2020 01:59:09 -0800

Could you please describe in a couple of sentences what you decided in ZRH? Just for people who are curious what is happening with these new promising web standards.

IMHO, the best possible solution is to introduce HTTP-specific DNS record which will describe available HTTP versions as well as the preferred one. It even could be used to make an actual HTTP/3 connection when a user opens an `http://` URL. So, even old HTTP links to website which moved to HTTPS recently will be opened through HTTPS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/253#issuecomment-583721878

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Feb 2020 08:44:06 -0800

Short version:  The http-core draft is [contemplating changes](https://github.com/httpwg/http-core/pull/266) that describe the authoritative endpoint as being any endpoint that has the right certificate.  Alt-Svc and other mechanisms can give you additional ways to discover an authoritative endpoint to send requests to.

As to a DNS record, please see the [SVCB and HTTPS](https://github.com/MikeBishop/dns-alt-svc/) records (naming still TBD) which have been adopted by DNSop, which support exposing whether an endpoint supports TLS/TCP or QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/253#issuecomment-584729790

---

From: Mike Bishop <[email-masked]>
Date: Mon, 24 Feb 2020 07:45:31 -0800

http-core PR is merged; unparking.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/253#issuecomment-590393320