Subject: Re: [quicwg/base-drafts] Only send one immediate ACK after reordering (#3357)

From: Gorry Fairhurst <[email-masked]>
Date: Mon, 03 Feb 2020 07:26:18 -0800

My point is I think this is the wrong direction. I think n=2 is unnecessarily restrictive as a default, and does have unwanted performance impacts in some places. 

I think the case of loss for a burst of one packet that you mention is handed by the timer. The congestion impact is minor.

While I agree for n=2 the method doesn't make much difference, for n=10, it would make a difference - because I'd expect it to be Important to be able to robustly detect and respond after congestion, I'm not sure it matters if the intention is to send DupACK+k immediate ACks or to send ACKs more frequently for some proportion of a RTT. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3357#issuecomment-581467628

---

From: ianswett <[email-masked]>
Date: Sun, 09 Feb 2020 06:36:23 -0800

@gorryfair You appear to be saying that if we substantially changed the current ACK guidance, this might be suboptimal.  Is that correct?

I don't believe the current guidance is optimal in almost any circumstance, so I would really like to change it.  Also, I don't believe we'll end up changing the ACK behavior substantially in the core drafts at this point, so I believe we should proceed with guidance we think works well with the existing draft without being substantially sub-optimal if a receiver does unilaterally decide to ACK less frequently.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3357#issuecomment-583852240