Subject: Re: [quicwg/base-drafts] use a HANDSHAKE_DONE frame to drive the handshake to confirmation (#3145)

From: MikkelFJ <[email-masked]>
Date: Sat, 22 Feb 2020 07:53:37 -0800

Catching up on old PR's: The text says that the client can consider the handshake done when receiving a handshake done frame. Such a frame can only be sent in 1-RTT and the server can only send it when it completes the handshake. However, a MITM could inject a handshake done packet earlier in the flow.

Even if the client is required to reject early handshake done frames, it might be a good idea to make it explicit that a handshake done packet MUST NOT be trusted before 1-RTT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3145#issuecomment-589968912

---

From: Christian Huitema <[email-masked]>
Date: Sat, 22 Feb 2020 16:43:22 +0000 (UTC)

MITM or not, the client will terminate the connection with a Protocol Violation error if it receives a Handshake Done frame before sending the last handshake frame. 
We spent time debugging that during the Zurich interop.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3145#issuecomment-589974017