Subject: Re: [quicwg/base-drafts] Improve language on evictable entries. (#3131)

From: afrind <[email-masked]>
Date: Tue, 11 Feb 2020 15:14:06 -0800

afrind commented on this pull request.

Sorry this got ignored for so long.  Can you rebase it and I can merge it?  There's one minor comment inline

>  ### Limits on Dynamic Table Insertions {#blocked-insertion}
 
 Inserting entries into the dynamic table might not be possible if the table
 contains entries which cannot be evicted.
 
 A dynamic table entry cannot be evicted immediately after insertion, even if it
 has never been referenced. Once the insertion of a dynamic table entry has been
-acknowledged and there are no outstanding unacknowledged references to the
-entry, the entry becomes evictable.
+acknowledged and there are no outstanding references to the entry in
+unacknowledged header blocks, the entry becomes evictable.  Note that
+unacknowledged references on the encoder stream do not preclude the eviction of

I don't know that we need to say this, since the previous sentence explicitly says 'references to the entry in unacknowledged header blocks' and header blocks do not appear on the encoder stream.

Or maybe the sentence should just indicate that headers on the encoder stream that reference other headers do not count as a reference.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#pullrequestreview-357065437

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 12 Feb 2020 05:58:00 -0800

dtikhonov requested changes on this pull request.

 

I don't agree with introducing the concept of "an unacknowledged reference on the encoder stream."  In the current version of the draft (12), the term "unacknowledged reference" always implies a reference from the header block.  In addition, only insertions and header blocks can be acknowledged.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#pullrequestreview-357470249

---

From: Bence Béky <[email-masked]>
Date: Thu, 20 Feb 2020 10:22:13 -0800

bencebeky commented on this pull request.

 

I have a slight preference of adding an explicit note that encoder stream references do not count, to make sure no one unnecessarily implements tracking for them (like I foolishly did).  But I'm flexible as far as wording is concerned, and do not insist on adding this note if you don't believe it adds any value.  Let me know what you think.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#discussion_r382175737

---

From: Bence Béky <[email-masked]>
Date: Thu, 20 Feb 2020 10:22:16 -0800

I agree with your observation, thank you.  I removed "unacknowledged" from this sentence.  Does it read better?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#discussion_r382175763

---

From: Bence Béky <[email-masked]>
Date: Thu, 20 Feb 2020 10:22:18 -0800

@bencebeky pushed 2 commits.

6ba50d14c4b3e879518a33716c17da4d0de0e031  Merge remote-tracking branch 'upstream/master' into bencebeky-qpack-blocking
ff3e3ddcbbfdc0c180b7d0df6428095edc36f8dd  Minor rewording

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131/files/e2fd8e382e6af00897c65b54fe8623090174d842..ff3e3ddcbbfdc0c180b7d0df6428095edc36f8dd

---

From: Mike Bishop <[email-masked]>
Date: Tue, 25 Feb 2020 08:06:53 -0800

MikeBishop commented on this pull request.

 

This might be a (very old!) holdover from when inserts weren't always on a single stream.  In that case, you might have an unacknowledged insert that depended on another entry for the field name.  But as they *are* on a single stream, the insert that causes an eviction can only arrive after the insert that has the dependency has already been processed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#discussion_r383977630

---

From: afrind <[email-masked]>
Date: Tue, 25 Feb 2020 14:31:06 -0800

Merged #3131 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3131#event-3071273921