Subject: [quicwg/base-drafts] Remove "Ignoring Loss of Undecryptable Packets" (#3442)

From: ianswett <[email-masked]>
Date: Sun, 09 Feb 2020 04:53:55 -0800

Now that QUIC has separate packet number spaces, it&#39;s impossible to declare a packet lost without the relevant keys being present at both peers, because an ACK needs to be sent by one and processed by the other.

So this text is OBE and potentially confusing.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3442

-- Commit Summary --

  * Remove &quot;Ignoring Loss of Undecryptable Packets&quot;

-- File Changes --

    M draft-ietf-quic-recovery.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3442.patch
https://github.com/quicwg/base-drafts/pull/3442.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442

---

From: Martin Thomson <[email-masked]>
Date: Sun, 09 Feb 2020 14:39:12 -0800

martinthomson approved this pull request.

Finding this sort of skew is hard without regular, thorough reviewing.  Good that we caught it now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#pullrequestreview-355639573

---

From: ianswett <[email-masked]>
Date: Sun, 09 Feb 2020 16:54:43 -0800

Merged #3442 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#event-3021033471

---

From: David Schinazi <[email-masked]>
Date: Sun, 09 Feb 2020 10:29:57 -0800

DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#pullrequestreview-355624431

---

From: Marten Seemann <[email-masked]>
Date: Mon, 10 Feb 2020 23:03:42 -0800

I don't think this is entirely correct. 0-RTT packets can still arrive before the ClientHello, and a server might have dropped those packets.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#issuecomment-584501647

---

From: ianswett <[email-masked]>
Date: Tue, 11 Feb 2020 07:30:48 -0800

Good point, I'll revert it for now and then create a PR to improve the text some and clarify exactly what case is being accomadated.
See #3449

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#issuecomment-584692526

---

From: ianswett <[email-masked]>
Date: Thu, 13 Feb 2020 14:40:45 -0800

Ok, manually reverted and I created an issue for what is now possibly a design change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3442#issuecomment-586007419