Subject: Re: [quicwg/base-drafts] Make transport parameters varint (#3169)

From: Mike Bishop <[email-masked]>
Date: Wed, 05 Feb 2020 01:09:05 -0800

MikeBishop commented on this pull request.

> @@ -4634,10 +4628,14 @@ preferred_address (0x000d):
 +                                                               +
 |                                                               |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+| CID Length (8)|
++-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
+|                      Connection ID (*)                      ...
++-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

What's the rationale for reordering the contents of this TP payload in this PR?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#pullrequestreview-353557897

---

From: Rui Paulo <[email-masked]>
Date: Wed, 05 Feb 2020 01:24:32 -0800

rpaulo commented on this pull request.

 +                                                               +
 |                                                               |

This came from https://github.com/quicwg/base-drafts/issues/2944 since they were both cosmetic.   

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#discussion_r375140804

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 01:29:06 -0800

@DavidSchinazi pushed 2 commits.

9876208d33d68d923d31699b7a5e54e32bf321f1  Merge branch 'master' into varinttp
6ab9bab55bb3247e5f8938fd908578f9ef13187e  revert preferred_address change

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169/files/6bc3d4ad61c2c11baf7183488613e9fcc5dff1cb..6ab9bab55bb3247e5f8938fd908578f9ef13187e

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 01:29:45 -0800

DavidSchinazi commented on this pull request.

 +                                                               +
 |                                                               |

Based on feedback from the room, I've reverted that change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#discussion_r375143495

---

From: Martin Thomson <[email-masked]>
Date: Wed, 05 Feb 2020 03:53:37 -0800

martinthomson approved this pull request.

Thanks for doing this David.  I can't see any problem with this, but we have to wait the full consensus call cycle before it lands.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#pullrequestreview-353658820

---

From: ianswett <[email-masked]>
Date: Thu, 06 Feb 2020 09:16:51 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#pullrequestreview-354628136

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 10 Feb 2020 02:45:22 -0800

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#pullrequestreview-355839289

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Feb 2020 13:06:55 -0800

Merged #3169 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3169#event-3061921179