Subject: [quicwg/base-drafts] 0-RTT status of new transport parameters (#3433)

From: Mike Bishop <[email-masked]>
Date: Thu, 06 Feb 2020 01:32:51 -0800

We've added new transport parameters since we wrote section 7.3.1.  The following TPs are neither MUST NOT remember nor MUST remember:
- max_idle_timeout
- max_packet_size
- max_ack_delay
- disable_active_migration

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433

---

From: Marten Seemann <[email-masked]>
Date: Thu, 06 Feb 2020 01:50:06 -0800

In my opinion, the only one that the client SHOULD remember is max_packet_size. This is an interesting special case since the server doesn’t need to remember this one (nor store it in the session ticket).
I don’t see any motivation for remembering the other three TPs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-582821690

---

From: ianswett <[email-masked]>
Date: Thu, 06 Feb 2020 03:28:58 -0800

Remember ing max_ack_delay is useless I believe, because Initial and Handshake packets use an max_ack_delay of kAlarmGranularity.

I would not want to remember disable_active_migration or max_idle_timeout if at all possible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-582861797

---

From: Martin Thomson <[email-masked]>
Date: Thu, 06 Feb 2020 04:07:51 -0800

As max_idle_timeout and disable_active_migration can only ever apply after the handshake is complete, remembrance is unnecessary.

max_ack_delay is annoying because it implies a particular acknowledgment schedule for 0-RTT that might not be compatible with the path, but setting it to the absolute minimum is problematic also.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-582875592

---

From: Martin Thomson <[email-masked]>
Date: Thu, 06 Feb 2020 04:08:12 -0800

See also #3434.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-582875723

---

From: martinduke <[email-masked]>
Date: Mon, 10 Feb 2020 10:53:19 -0800

I don't read the text this way. In the fourth paragraph it says that "A client that attempts to send 0-RTT data MUST remember all other transport parameters used by the server." [i.e. all but a short list of obviously insane TPs listed in the previous paragraph.

I suggest we close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-584292650

---

From: Mike Bishop <[email-masked]>
Date: Tue, 25 Feb 2020 07:44:23 -0800

@martinduke, that's a good point that the list doesn't have to be exhaustive.  The text says clients MUST NOT remember certain parameters and MUST remember all others.  So perhaps the more apt question is whether any of these unmentioned TPs belong in the MUST-NOT list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-590932371

---

From: Mike Bishop <[email-masked]>
Date: Tue, 25 Feb 2020 07:44:31 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3433#issuecomment-590932467