Subject: [quicwg/base-drafts] Here be dragons (#3421)

From: Mike Bishop <[email-masked]>
Date: Wed, 05 Feb 2020 11:50:55 +0000 (UTC)

Fixes #3419.

The SHOULD is guidance for future extensions; if we&#39;d like to downgrade that to non-normative, that&#39;s also fine.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3421

-- Commit Summary --

  * Extension dragons

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3421.patch
https://github.com/quicwg/base-drafts/pull/3421.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 03:52:59 -0800

DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#pullrequestreview-353658488

---

From: Marten Seemann <[email-masked]>
Date: Wed, 05 Feb 2020 03:53:08 -0800

marten-seemann commented on this pull request.

This is a good start, but the problem is broader than this. If you two extensions modify the same mechanism (even if they don’t change any of the wire encoding), you’ll have the same problem.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#pullrequestreview-353658575

---

From: Mike Bishop <[email-masked]>
Date: Wed, 05 Feb 2020 03:56:04 -0800

@MikeBishop pushed 1 commit.

2af27a157234152c1b19d68ea827b5cfd31901bc  Not just frames

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421/files/ce9a03f47093c1196d24e53f5d3eb62645f1e435..2af27a157234152c1b19d68ea827b5cfd31901bc

---

From: Marten Seemann <[email-masked]>
Date: Wed, 05 Feb 2020 03:56:39 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#pullrequestreview-353660459

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 05 Feb 2020 04:58:28 -0800

LPardue commented on this pull request.

> @@ -5710,6 +5710,12 @@ that a peer is able to understand the frame.  An endpoint can use a transport
 parameter to signal its willingness to receive one or more extension frame types
 with the one transport parameter.
 
+Extensions that modify or replace core protocol functionality (including frame

do we want to be specific about **this** version?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#pullrequestreview-353694453

---

From: Martin Thomson <[email-masked]>
Date: Wed, 05 Feb 2020 05:18:12 -0800

I'm going to merge this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#issuecomment-582402884

---

From: ianswett <[email-masked]>
Date: Wed, 05 Feb 2020 07:15:05 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#pullrequestreview-353795355

---

From: Mike Bishop <[email-masked]>
Date: Wed, 05 Feb 2020 13:10:13 -0800

MikeBishop commented on this pull request.

We don't yet know about the portability of extensions across versions.  I'm kind of inclined to just leave that topic for future-us.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#discussion_r375509181

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 13:12:43 -0800

DavidSchinazi commented on this pull request.

+1, this document only discusses this version. Any other version is future work

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#discussion_r375510330

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 05 Feb 2020 14:12:27 -0800

Makes sense, I agree.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#discussion_r375537429

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Feb 2020 15:40:03 -0800

Merged #3421 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3421#event-3028686729