Subject: [quicwg/base-drafts] Scope connection IDs to the current connection (#3485)

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Feb 2020 15:26:20 -0800

This isn&#39;t strictly necessary, as it might be implied by the definition
of a connection ID.

I tried tweaking the connection ID definition, but it is hard to say anything concrete because of the way that addressing can also be used in combination with connection IDs to identify a connection at an endpoint.  So I left that alone.

Closes #3484.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3485

-- Commit Summary --

  * Scope connection IDs to the current connection

-- File Changes --

    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3485.patch
https://github.com/quicwg/base-drafts/pull/3485.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485

---

From: ianswett <[email-masked]>
Date: Mon, 24 Feb 2020 15:55:25 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485#pullrequestreview-363784599

---

From: Eric Kinnear <[email-masked]>
Date: Mon, 24 Feb 2020 16:38:30 -0800

erickinnear approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485#pullrequestreview-363799902

---

From: Marten Seemann <[email-masked]>
Date: Mon, 24 Feb 2020 19:06:29 -0800

marten-seemann approved this pull request.

Not really sure if this is necessary. The text around this sentence implies that connection IDs identify one connection (which shouldn't be too surprising in the first place). It's only when you take this one sentence out of context, that the "problem" of #3484 occurs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485#pullrequestreview-363843928

---

From: MikkelFJ <[email-masked]>
Date: Tue, 25 Feb 2020 02:10:34 -0800

I agree that a connection ID identifies one session, and due to forbidden correlation, it is clear that a connection ID in use cannot proliferate. However, this is not implied for newly issued connection IDs. There is precedence for new tokens which do apply to new connections, so I think it is worth being precise here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485#issuecomment-590788107

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Feb 2020 15:40:44 -0800

Merged #3485 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3485#event-3071484518