Subject: Re: [quicwg/base-drafts] More strongly recommend ECN marking (#3373)

From: ekr <[email-masked]>
Date: Tue, 04 Feb 2020 04:49:15 -0800

I would not be in favor of reopening this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-581894880

---

From: mirjak <[email-masked]>
Date: Tue, 04 Feb 2020 05:03:42 -0800

Just to clarify the proposal was that if you decide to enable ECN, you should just do it and only disable if you notice a failure, instead of having the more complicated probing logic that we have right now (in the appendix I think)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-581899883

---

From: Martin Thomson <[email-masked]>
Date: Wed, 05 Feb 2020 02:51:08 -0800

This is just about this one paragraph:

> To reduce the chances of misinterpreting congestive loss as packets dropped by a faulty network element, an endpoint could set the ECT(0) codepoint in the first ten outgoing packets on a path, or for a period of three RTTs, whichever occurs first.

The concrete proposal would be to remove this paragraph.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-582350400

---

From: Christian Huitema <[email-masked]>
Date: Wed, 05 Feb 2020 02:51:05 -0800

The [Interop Matrix](https://docs.google.com/spreadsheets/d/1D0tW89vOoaScs3IY9RGC0UesWGAwE6xyLk0l4JtvTVg/edit#gid=1303503263) shows that out of 14 implementations doing active tests, only 3 demonstrate ECN support. No ill will, but major places like AWS or the Windows OS do not support ECN, so it is not clear what more text in the spec would change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-582350377

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 03:03:42 -0800

Discussed in ZRH. Proposed resolution is to close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-582355371

---

From: mirjak <[email-masked]>
Date: Wed, 05 Feb 2020 03:08:50 -0800

I will make a proposal for an editorial PR for the paragraph mention above to make it sounds less scary that this risk exists.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3373#issuecomment-582357598