Subject: Re: [quicwg/base-drafts] Recommend algorithm for packet scheduler, rather than implementation (#3122)

From: ianswett <[email-masked]>
Date: Sat, 15 Feb 2020 11:50:18 -0800

I think @martinthomson was going to write a more crisp definition of a pacer and remove this reference?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122#issuecomment-586635220

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Feb 2020 15:51:13 -0800

I was [advocating for a crisper definition](https://github.com/quicwg/base-drafts/issues/3094#issuecomment-574962313).

If the formula I described is acceptable, then I'm happy to contribute text, but I hadn't planned to.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122#issuecomment-586770080

---

From: MikkelFJ <[email-masked]>
Date: Sat, 22 Feb 2020 03:38:44 -0800

@martinthomson I think it is good to have a clear definition of what pacing means when QUIC has that as a requirement for one operational mode. I'm not sure it is really helpful by itself in guiding the user towards queueing disciplines such as deficit round robin. I'd prefer at least a mention of such an algorithm as one way to achieve the desired behaviour rather then referring to qdisc. Such a name can searched and Wikipedia will answer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3122#issuecomment-589947874