Subject: Re: [quicwg/base-drafts] congestion window increase on every ACKed packet could result in bursty sends (#3094)

From: Vidhi Goel <[email-masked]>
Date: Tue, 04 Feb 2020 17:40:15 -0800

There are two routes that we can take:
1. Specify clearly what 'delay` refers to in the below statement, which is done in #3351
```
Sending multiple packets into the network without any delay between them
creates a packet burst that might cause short-term congestion and losses. 
```
OR
2. Change MUST pace to SHOULD and remove the 10 MSS burst size limit and provide general recommendation if an implementation doesn't pace. Something like:
```
Implementations SHOULD either use pacing or use another mechanism 
(for example, limit congestion window increase as specified by RFC 3465)
to introduce delay between successive transmissions. Implementations
that don't pace are at risk of underutilizing the network.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-582201025

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 05 Feb 2020 01:00:17 -0800

I'm sympathetic to saying MUST pace, and I like the formatlization that @martinthomson suggests. I've heard some pushback on saying MUST pace in the past, but it might be worth giving it a shot again. @erickinnear @tfpauly : What do you think?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-582306647

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 05 Feb 2020 01:54:50 -0800

That said... I will note that @martinthomson 's formalization allows for a burst at the _end_ of an RTT. Consider for example when a single ACK is received that acknowledges an entire window. That would be legal by this definition. I think that's ok.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-582327938

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 06:01:02 -0800

Discussed in ZRH. Proposed resolution is to define and REQUIRE pacing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-582421008

---

From: Tommy Pauly <[email-masked]>
Date: Wed, 05 Feb 2020 09:10:42 -0800

@janaiyengar I think requiring pacing makes good sense, with some formalization of what that means.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3094#issuecomment-582512112