Subject: [quicwg/base-drafts] Sending probe packet has duplicated text (#3468)

From: mirjak <[email-masked]>
Date: Mon, 17 Feb 2020 09:48:10 -0800

I removed this text because it was duplicated with text further below in the same section (but different normative requirements). I assume this was an oversight and the text further down is the more current one (at least it makes for sense to me). 

However, I&#39;m not sure if this sentence is still needed, and if so why:
&quot;In addition to sending data in the packet number space for which the timer
expired, the sender SHOULD send ack-eliciting packets from other packet
number spaces with in-flight data, coalescing packets if possible.&quot;
????
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3468

-- Commit Summary --

  * Sending probe packet has duplicated text

-- File Changes --

    M draft-ietf-quic-recovery.md (18)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3468.patch
https://github.com/quicwg/base-drafts/pull/3468.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3468

---

From: mirjak <[email-masked]>
Date: Mon, 17 Feb 2020 09:53:36 -0800

I also just noticed that there is this sentence in the "sending probe packets" section:
" Alternatively, instead of sending an ack-eliciting packet, the sender
MAY mark any packets still in flight as lost."

and this sentence in the next "detection loss" section:
" A PTO timer expiration event does not indicate packet loss and MUST
NOT cause prior unacknowledged packets to be marked as lost."

So maybe that first sentence should have be removed as well? Not sure what is intended here...?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3468#issuecomment-587102790

---

From: ianswett <[email-masked]>
Date: Mon, 17 Feb 2020 15:10:27 -0800

I'm happy to change it to a MAY.

FWIW, "TCP Control Block Interdependence" is not a good name for that draft in my opinion.  And it seems like almost none of the potential considerations are TCP-specific, so is the reason this is in tcpm a historical quirk?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3468#issuecomment-587186228

---

From: mirjak <[email-masked]>
Date: Wed, 19 Feb 2020 02:00:08 -0800

@ianswett I assume you actually meant to put this comment on issue #3464 ?

However, let me answer anyway: draft-ietf-tcpm-2140bis as the name says is a bis document, so it does have the title and scope from rfc2140. I agree that this is not TCP specific, however, then it would not be a bis doc anymore but a new document. That is probably something that could be discussed in tcpm. Feel free to raise that point there!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3468#issuecomment-588134710