Subject: Re: [quicwg/base-drafts] Mysterious 1 vs 2 packet distinction in recovery pseudocode (#3070)

From: ianswett <[email-masked]>
Date: Sat, 15 Feb 2020 11:30:03 -0800

I updated the pseudocode in #3461 to always prefer the standard PTO response unless it's the client anti-deadlock case.  I believe this matches the text much better now.  It keeps the two cases when 1 packet is sent for anti-deadlock, but that matches the normative text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3070#issuecomment-586633556

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Feb 2020 15:47:23 -0800

That is a different solution to the one I imagined, but a better one.  You forgot some conditions in the pseudocode though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3070#issuecomment-586769740