Subject: [quicwg/base-drafts] Recovery period definition is odd (#3409)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Feb 2020 06:21:50 -0800

This is weird in that it assumes some context that isn't provided:

> Recovery is a period of time beginning with detection of a lost packet or an increase in the ECN-CE counter. Because QUIC does not retransmit packets, it defines the end of recovery as a packet sent after the start of recovery being acknowledged.

Perhaps instead:

> A recovery period is entered when loss or ECN-CE marking of a packet is detected.  The recovery period ends when a packet sent during the recovery period is acknowledged.

This "Because QUIC does not retransmit packets" thing is unnecessary.  I'll open a PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3409

---

From: ianswett <[email-masked]>
Date: Tue, 11 Feb 2020 15:43:33 -0800

Closed #3409 via #3410.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3409#event-3028695472