Subject: [quicwg/base-drafts] Unilateral Transport Parameters (#3478)

From: Martin Thomson <[email-masked]>
Date: Sat, 22 Feb 2020 15:34:22 -0800

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3478

-- Commit Summary --

  * Remove tabs from recovery draft
  * Transport parameters can be declared unilaterally

-- File Changes --

    M draft-ietf-quic-recovery.md (16)
    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3478.patch
https://github.com/quicwg/base-drafts/pull/3478.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478

---

From: David Schinazi <[email-masked]>
Date: Sat, 22 Feb 2020 16:34:31 -0800

DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#pullrequestreview-363058472

---

From: Marten Seemann <[email-masked]>
Date: Sat, 22 Feb 2020 17:44:19 -0800

marten-seemann approved this pull request.

> -## Ignoring Loss of Undecryptable Packets	
-
-During the handshake, some packet protection keys might not be	
-available when a packet arrives. In particular, Handshake and 0-RTT packets	
-cannot be processed until the Initial packets arrive, and 1-RTT packets	
-cannot be processed until the handshake completes.  Endpoints MAY	
-ignore the loss of Handshake, 0-RTT, and 1-RTT packets that might arrive before	
-the peer has packet protection keys to process those packets.	
+## Ignoring Loss of Undecryptable Packets
+
+During the handshake, some packet protection keys might not be
+available when a packet arrives. In particular, Handshake and 0-RTT packets
+cannot be processed until the Initial packets arrive, and 1-RTT packets
+cannot be processed until the handshake completes.  Endpoints MAY
+ignore the loss of Handshake, 0-RTT, and 1-RTT packets that might arrive before
+the peer has packet protection keys to process those packets.

Why?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#pullrequestreview-363060354

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Feb 2020 08:04:43 -0800

martinthomson commented on this pull request.

-

This is unrelated content. I will trim this commit from the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#discussion_r383016766

---

From: ianswett <[email-masked]>
Date: Mon, 24 Feb 2020 06:59:17 -0800

ianswett commented on this pull request.

> @@ -1486,6 +1485,10 @@ QUIC includes the encoded transport parameters in the cryptographic handshake.
 Once the handshake completes, the transport parameters declared by the peer are
 available.  Each endpoint validates the value provided by its peer.
 
+Transport parameters are declarations that are made unilaterally by each

I'd prefer this two paragraphs up closer to where it was.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#pullrequestreview-363451275

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Feb 2020 13:22:10 -0800

@martinthomson pushed 1 commit.

69c2d95035420cc9bc596ed1d6a3373dfbe85548  Transport parameters can be declared unilaterally

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478/files/c9857e27969d59f80bc1e07bdac29ef7f437eb72..69c2d95035420cc9bc596ed1d6a3373dfbe85548

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Feb 2020 13:22:53 -0800

e28286096182fa8b57a8607da90ce73144b3f105  ^^

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478/files/69c2d95035420cc9bc596ed1d6a3373dfbe85548..e28286096182fa8b57a8607da90ce73144b3f105

---

From: ianswett <[email-masked]>
Date: Mon, 24 Feb 2020 13:37:41 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#pullrequestreview-363719077

---

From: David Schinazi <[email-masked]>
Date: Mon, 24 Feb 2020 14:13:36 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#pullrequestreview-363739436

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Feb 2020 15:13:29 -0800

Merged #3478 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3478#event-3071404590