Subject: Re: [quicwg/base-drafts] Make transport parameter ID and length varint (#3294)

From: Brian Trammell <[email-masked]>
Date: Wed, 05 Feb 2020 01:10:29 -0800

I wouldn't characterize changes to make the design of the protocol self-consistent as gratuitous; this seems like it'll reduce implementation confusion. And changing this encoding in future versions seems like a good place for parser vulnerabilities to hide, so I'm in favor of making this change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-582310424

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 01:21:29 -0800

Discussed in ZRH. Proposed resolution is to make this change and apply #3169.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-582314766

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 01:31:26 -0800

Following feedback from the room, I've reverted the preferred_address part of this change, and as far as I know this is ready to merge once we confirm consensus on the list.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-582318573

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 05 Feb 2020 01:34:22 -0800

Discussion of the preferred_address requires an issue, so whomever is a proponent for that please create one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-582319737

---

From: David Schinazi <[email-masked]>
Date: Wed, 05 Feb 2020 01:36:07 -0800

@LPardue the preferred_address change is discussed in issue #2944.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-582320458

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Feb 2020 10:43:05 -0800

In fairness, the outcome documented on that issue and the minutes from Cupertino was that, if we decide to make *this* change, the modified layout would be considered as part of it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-585356918

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Feb 2020 12:51:50 -0800

I believe that consideration was given.  Maybe if you were advocating for the change, the cursory manner of its dismissal might be unsatisfactory, but ample opportunity was given to argue for including the change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#issuecomment-585411665

---

From: Martin Thomson <[email-masked]>
Date: Fri, 21 Feb 2020 13:06:56 -0800

Closed #3294 via #3169.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3294#event-3061921187