Subject: [quicwg/base-drafts] Does the amplification limit apply to PTO packets? (#3413)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Feb 2020 07:41:49 -0800

>From @gorryfair in #3214, this is not a nit:

>> Prior to validating the client address, servers MUST NOT send more
than three times as many bytes as the number of bytes they have
received.

> So, let me understand - does that include retransmissions? or is this constrain within the PTO or something?

I think that the intent was that the server limit its sending, including PTO.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3413

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 06:53:01 -0800

Discussed in ZRH. Proposed resolution is "yes".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3413#issuecomment-582444715

---

From: ekr <[email-masked]>
Date: Wed, 05 Feb 2020 06:58:23 -0800

Repeating what I said earlier: it's not clear to me that not being able to arm the PTO timer when at the limit implies that PTO packets count against the amplification limit. The reason is that you could have *already* armed the PTO timer at the time you hit the limit. E.g., you might be streaming 0.5RTT and so send Initial, Handshake, arm timer, <wait> 0.5RTT.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3413#issuecomment-582447283