Subject: [quicwg/base-drafts] Authenticating connection IDs (#3439)

From: Martin Thomson <[email-masked]>
Date: Thu, 06 Feb 2020 07:18:23 -0800

@ad-l has noted in the past that we don't authenticate the connection IDs that are exchanging during the handshake.  This complicates analysis of header protection (for details, see the upcoming paper).  We already authenticate the connection ID that the client first uses if there is a Retry packet sent, but we don't otherwise authenticate the connection IDs that are signaled in the Source Connection ID field.

The question here is whether we should be more careful about authenticating these.  

@nharper also points out in #3429 that the ODCID transport parameter is an odd duck.  If we use transport parameters to authenticate connection IDs, we might be better served by restoring a fixed header to the transport parameters so that we can more cleanly address that issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3439

---

From: Antoine Delignat-Lavaud <[email-masked]>
Date: Thu, 06 Feb 2020 08:05:35 -0800

There is also something interesting about the ODCID transport parameter. If no retry happens, then the DCID gets authenticated, however if a retry does happen then an attacker can tamper with the new SCID in the RETRY packet. 

Also our QUIPS paper is on ePrint https://eprint.iacr.org/2020/114 and section 3.4 has some relevant details

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3439#issuecomment-582976998

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Feb 2020 01:48:25 -0800

I think we need to see more (supportive) discussion in order to justify taking this on.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3439#issuecomment-588129595