Subject: [quicwg/base-drafts] #3348 Clarify that you can use any issued CID at any time, even during the handshake (#3438)

From: Eric Kinnear <[email-masked]>
Date: Thu, 06 Feb 2020 03:41:43 -0800

Note also the editorial changes in #3354, which are great and still needed: this adds a little bit more to the reference from those changes to do the key clarifying for #3348.

The remaining clarification about `preferred_address` is coming in the SPA PRs, but I wanted to look at this paragraph in one place.

Closes #3348.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3438

-- Commit Summary --

  * 

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3438.patch
https://github.com/quicwg/base-drafts/pull/3438.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438

---

From: ianswett <[email-masked]>
Date: Thu, 06 Feb 2020 04:02:19 -0800

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-354398135

---

From: Marten Seemann <[email-masked]>
Date: Fri, 07 Feb 2020 00:16:42 -0800

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-354988754

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 07 Feb 2020 00:55:23 -0800

kazuho commented on this pull request.

> @@ -1002,7 +1002,9 @@ When an endpoint issues a connection ID, it MUST accept packets that carry this
 connection ID for the duration of the connection or until its peer invalidates
 the connection ID via a RETIRE_CONNECTION_ID frame
 ({{frame-retire-connection-id}}).  Connection IDs that are issued and not
-retired are considered active; any active connection ID can be used.
+retired are considered active; any active connection ID is valid for use at any
+time, including during the handshake.  This includes the connection ID issued by

Maybe add "in any packet type", considering that the original issue was if the CID of a Handshake packet can change?

Note: CID of a server-sent Initial packet might also use a CID delivered by a NCID frame, when 0-RTT is being used.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-355007966

---

From: ianswett <[email-masked]>
Date: Fri, 07 Feb 2020 02:50:38 -0800

ianswett commented on this pull request.

Discard-Initial currently says:
"A client stops both sending and processing Initial packets when it sends its first Handshake packet."

If a client processed an Initial, Handshake and 0.5RTT from the server, then it could start using the CID in NEW_CONNECTION_ID in Initial packet if it sent the Initial packet right before the Handshake packet.

Of course, if the Initial was dropped it wouldn't matter, so this is a bit irrelevant, but I wanted to make sure others realized it was not just Handshake, because I missed that previously.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#discussion_r376329586

---

From: Martin Thomson <[email-masked]>
Date: Sun, 09 Feb 2020 13:56:44 -0800

martinthomson commented on this pull request.

Both those Initial cases are interesting, but probably not worth extra text :)

The "any packet type" comment is worth the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#discussion_r376819248

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 09 Feb 2020 23:21:48 -0800

erickinnear commented on this pull request.

Good call, "during the handshake" is unclear in referring to a time or a packet type. Updated!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#discussion_r376897984

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 09 Feb 2020 23:24:28 -0800

@erickinnear pushed 1 commit.

8e532b07e8f56cc31ca53a84325ba5539d5a603c  Note that CIDs are valid in any packet type

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438/files/059773ce1e6cb04fe9f5b2a97ff3eb292e7df1fd..8e532b07e8f56cc31ca53a84325ba5539d5a603c

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 09 Feb 2020 23:24:54 -0800

Settled on just noting "any packet type" since the presence of Initial and Handshake packets implies that you're using these during the handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#discussion_r376898730

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 10 Feb 2020 01:24:41 -0800

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-355785696

---

From: Nick Banks <[email-masked]>
Date: Mon, 10 Feb 2020 07:02:29 -0800

nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-356006003

---

From: ianswett <[email-masked]>
Date: Mon, 10 Feb 2020 06:25:21 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-355975469

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Feb 2020 15:46:43 -0800

Merged #3438 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#event-3028703496

---

From: Christian Huitema <[email-masked]>
Date: Tue, 11 Feb 2020 16:43:34 -0800

huitema commented on this pull request.

Looks good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3438#pullrequestreview-357121237