Subject: [quicwg/base-drafts] CONNECTION_CLOSE should be allowed in 0-RTT (#3436)

From: Marten Seemann <[email-masked]>
Date: Thu, 06 Feb 2020 02:23:54 -0800

CONNECTION_CLOSE is the only exception to our principle that any frame that is allowed in 1-RTT is also allowed in 0-RTT (where some frames just don’t make sense in 0-RTT).

An application that doesn’t care about the server’s response (and reliability) might use this to send a short message and then immediately close the connection. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3436

---

From: Marten Seemann <[email-masked]>
Date: Thu, 06 Feb 2020 02:24:35 -0800

I see @martinthomson was faster than me in #3435. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3436#issuecomment-582835404

---

From: Marten Seemann <[email-masked]>
Date: Thu, 06 Feb 2020 02:24:37 -0800

Closed #3436.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3436#event-3013304274