Subject: Re: [quicwg/base-drafts] Backoff on CONNECTION_CLOSE (#3157)

From: MikkelFJ <[email-masked]>
Date: Sat, 22 Feb 2020 17:22:16 +0000 (UTC)

Is there a risk of amplification attacks if an attacker sends bad packets during handshake that triggers a connection close, possible to a spoofed address. Sorry, not really up to speed on handshake details, just want to make sure this isn't overlooked. I think it should be OK, since it would be below a factor 3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3157#issuecomment-589978273

---

From: Martin Thomson <[email-masked]>
Date: Sat, 22 Feb 2020 15:44:24 -0800

Yes, amplification using CONNECTION_CLOSE is impossible because we require that - if you don't apply other rate limiting methods - the closing packet you send is smaller than the packet you receive.  That is, the factor is <1 in that case.  If you apply other rate limiting methods, then the 3x limit would apply, though it would be unlikely that you would ever have cause to hit that limit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3157#issuecomment-590009498