Subject: Re: [quicwg/base-drafts] Which DCID do Handshake retransmissions use? (#3348)

From: Igor Lubashev <[email-masked]>
Date: Sun, 02 Feb 2020 11:53:07 -0800

I agree with @DavidSchinazi here. Any alternative is ok, but the draft should say whether servers can expect that the client might switch DCID and whether the clients can expect the server to send NCID w/ RPT>0 before the handshake is complete.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-581170454

---

From: Christian Huitema <[email-masked]>
Date: Wed, 05 Feb 2020 03:19:51 -0800

Let's keep it simple: no migration before Handshake Done, period.
That would include prohibit NCID in 0-RTT

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-582361725

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 05 Feb 2020 03:49:10 -0800

@huitema The problem is not that simple.

Consider the case where the server receives ClientFinished and sends two 1-RTT packets, the first packet containing HANDSHAKE_DONE, and the second packet containing an NCID with RPT set to 1.

If the first 1-RTT packet gets lost, the client receives a request to retire the connection ID before *it* confirms the handshake.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-582371612

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 05 Feb 2020 03:57:01 -0800

I think I'd prefer a design that meets the two requirements stated below:
* A server should not be required to withhold NCID frames until it receives an ACK for HANDSHAKE_DONE.
* A client should be allowed to use the original CID until the handshake is confirmed.

The intention is to minimize additional complexity to existing (and future) QUIC stacks.

One solution that meets these requirements is to state that a NCID frame confirms the handshake, exactly the same way as HANDSHAKE_DONE frame does. That would be a trivial change to any of the QUIC stacks, and there would be no ambiguity regarding the state changes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-582374168

---

From: Lars Eggert <[email-masked]>
Date: Wed, 05 Feb 2020 05:18:29 -0800

Discussed in ZRH. Proposed resolution is to clarify that issuing a CID means being prepared to seeing it used at any time. Additional Editorial issue on packetization issues.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-582403010

---

From: ianswett <[email-masked]>
Date: Wed, 05 Feb 2020 07:14:00 -0800

Editorial PR on packetization challenges with retransmitted frames is #3424.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-582454866

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Feb 2020 15:46:43 -0800

Closed #3348 via #3438.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#event-3028703508

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Feb 2020 23:47:03 +0000 (UTC)

Reopened #3348.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#event-3028704289

---

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Feb 2020 15:47:31 -0800

Ugh, editorial changes for a design issue.  Reopened for consensus calling.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3348#issuecomment-584921628