Subject: [quicwg/base-drafts] Clarify PTO packets count towards amplification limit (#3539)

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:28:35 -0700

Fixes #3413
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3539

-- Commit Summary --

  * Clarify PTO packets count towards amplification limit

-- File Changes --

    M draft-ietf-quic-recovery.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3539.patch
https://github.com/quicwg/base-drafts/pull/3539.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:49:48 -0700

@ianswett pushed 1 commit.

eb47fe039e4eb2a94d91e2db11784e3c52d6b0e4  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539/files/7f3cda841c01bcb677892e61e03341be06bef5a7..eb47fe039e4eb2a94d91e2db11784e3c52d6b0e4

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:50:32 -0700

99796822b309ecd39bee7d648d4916c4edcdfc99  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539/files/eb47fe039e4eb2a94d91e2db11784e3c52d6b0e4..99796822b309ecd39bee7d648d4916c4edcdfc99

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Mar 2020 21:42:54 -0700

martinthomson approved this pull request.

Not sure how to split the difference between the limit applying to the packet that was just sent (causing PTO to be armed) or the packet that arming the PTO timer implies.

Personally, I would have put the test at the point that you send a packet, but that's not how this is structured, and you do have "because packets sent on PTO count against the anti-amplification limit", which captures the important concept neatly.

> @@ -558,6 +545,23 @@ keys are discarded, the PTO and loss detection timers MUST be reset, because
 discarding keys indicates forward progress and the loss detection timer might
 have been set for a now discarded packet number space.
 
+#### Before Address Validation
+
+Until the server has validated the client's address on the path, the amount of
+data it can send is limited to three times the amount of data received,
+as specified in Section 8.1 of {{QUIC-TRANSPORT}}. If no data can be sent,

```suggestion
as specified in Section 8.1 of {{QUIC-TRANSPORT}}. If no additional data can be sent,
```

When you arm the timer, you might be sending a packet that is within the limit, but the next packet might exceed the limit.

I don't know if this should be adjusted somehow, but this might help.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539#pullrequestreview-379129293

---

From: ianswett <[email-masked]>
Date: Mon, 23 Mar 2020 07:26:37 -0700

90ffa0a9f47780511e6ae18456669cb36696c9fe  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539/files/99796822b309ecd39bee7d648d4916c4edcdfc99..90ffa0a9f47780511e6ae18456669cb36696c9fe

---

From: ianswett <[email-masked]>
Date: Mon, 23 Mar 2020 07:29:16 -0700

By not arming the alarm, we avoid the possibility of having the alarm expire, send nothing, and then be immediately re-armed over and over again.  We've hit bugs like that a few times in our implementation, which is why I prefer this structure of not setting the alarm if you can't send anything.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539#issuecomment-602630522

---

From: ianswett <[email-masked]>
Date: Mon, 23 Mar 2020 07:30:17 -0700

1320c22506454ff42bc867250fa55eaaa1accdd7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539/files/90ffa0a9f47780511e6ae18456669cb36696c9fe..1320c22506454ff42bc867250fa55eaaa1accdd7

---

From: ianswett <[email-masked]>
Date: Sun, 29 Mar 2020 16:20:39 -0700

95e46952fcec6da8297f40eaef105ce0538563c1  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539/files/1320c22506454ff42bc867250fa55eaaa1accdd7..95e46952fcec6da8297f40eaef105ce0538563c1

---

From: ianswett <[email-masked]>
Date: Sun, 29 Mar 2020 16:22:07 -0700

Merged #3539 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3539#event-3176436641