Subject: Re: [quicwg/base-drafts] Clarify ACK sending text in transport (#3480)

From: Igor Lubashev <[email-masked]>
Date: Sun, 01 Mar 2020 08:44:55 -0800

> a sender cannot rely on receiving an acknowledgement of every packet, whether it's ack-eliciting or not, because ACKs get lost.

I do not understand this statement. Yes, packets with ACKs can get lost. But the mechanics of QUIC is that until an ACK-of-the-ACK is received, the sender will continue to acknowledge all packet ranges from the original ACK in every subsequent ACK. So if at least some ACK gets through, everything will get ACKed, despite of some losses of ACKs.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3480#issuecomment-593117576

---

From: ianswett <[email-masked]>
Date: Sun, 01 Mar 2020 10:47:56 -0800

The ACK-of-the-ACK algorithm is a recommendation, not a requirement.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3480#issuecomment-593130640