Subject: Re: [quicwg/base-drafts] Remembering transport parameters (#3434)

From: ianswett <[email-masked]>
Date: Tue, 10 Mar 2020 11:28:11 -0700

@martinduke If the client's Initial is too large, it'll be dropped by the server and the handshake will fail.  That seems a bit concerning.

That being said, this seems like a case of "Either remember it or only use the default/min prior to handshake completion"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3434#issuecomment-597242668

---

From: martinduke <[email-masked]>
Date: Tue, 10 Mar 2020 11:35:51 -0700

This is specifically about remembering for 0RTT. It is probably unwise to
ever assume that an Initial over 1200 will get through, unless you are
taking the trouble to store a higher value.

On Tue, Mar 10, 2020 at 11:28 AM ianswett <[email-masked]> wrote:

> @martinduke <https://github.com/martinduke> If the client's Initial is
> too large, it'll be dropped by the server and the handshake will fail. That
> seems a bit concerning.
>
> That being said, this seems like a case of "Either remember it or only use
> the default/min prior to handshake completion"?
>
> —
> You are receiving this because you were mentioned.
> Reply to this email directly, view it on GitHub
> <https://github.com/quicwg/base-drafts/issues/3434?email_source=notifications&email_token=AF2EYEO3XQN7HTND3WKW5TTRG2BDBA5CNFSM4KQZSVGKYY3PNVWWK3TUL52HS4DFVREXG43VMVBW63LNMVXHJKTDN5WW2ZLOORPWSZGOEOMTGLA#issuecomment-597242668>,
> or unsubscribe
> <https://github.com/notifications/unsubscribe-auth/AF2EYEOCICPN737NZ23DGMLRG2BDBANCNFSM4KQZSVGA>
> .
>

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3434#issuecomment-597246223

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Mar 2020 21:05:17 -0700

Closed #3434.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3434#event-3153542282

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Mar 2020 21:05:18 -0700

Closing this on the basis of having this text:

> If 0-RTT data is accepted by the server, the server MUST NOT reduce any limits or alter any values that might be violated by the client with its 0-RTT data.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3434#issuecomment-602373572