Subject: Re: [quicwg/base-drafts] Add caution when using IW10 and fragmentation (#3243)

From: MikkelFJ <[email-masked]>
Date: Thu, 12 Mar 2020 05:10:07 -0700

>From memory, I think there was once a discussion on DF bit not being accessible in some language interfaces. As such, the formulation should perhaps be that the DF bit SHOULD be set whenever possible. Having a MUST whenever possible could be problematic because possible could involve a lot of complexity.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-598151900

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Mar 2020 14:39:50 -0700

> UDP datagrams MUST NOT be fragmented at the IP layer. In IPv4 [IPv4], the DF bit MUST be set to prevent fragmentation on the path.

-- https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-14-4

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-598429956

---

From: MikkelFJ <[email-masked]>
Date: Thu, 12 Mar 2020 14:45:44 -0700

@martinthomson yes, that is exactly the text I am referring to. I'm questioning if that requirement is practically enforceable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3243#issuecomment-598431795