Subject: Re: [quicwg/base-drafts] Padding outside QUIC packet (#3333)

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Mar 2020 16:15:30 -0700

I don't like the idea of allowing any kind of data in the datagram outside of the QUIC framework. Even for coalesced packets, they are required to belong to the same connection, possibly even the same packet number space.

Additional information in the datagram can be removed or fingerprinted, as already mentioned, but worse, information can be added. This could be used to leak cooperate data, tracking etc. - preventing this requires dropping all datagrams that cannot be fully decrypted, but I think there is consensus for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3333#issuecomment-597925997

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Mar 2020 16:30:03 -0700

Closed #3333 via #3470.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3333#event-3153193964