Subject: [quicwg/base-drafts] Inconsistency between early timeout calculations (#3524)

From: Kazuho Oku <[email-masked]>
Date: Sat, 14 Mar 2020 22:19:14 -0700

For each connection, the loss detection timeout is defined as 2 * InitialRTT.

I wonder if this should be 3 * InitialRTT instead, because, once you have one RTT sample, PTO is calculated as 3 * InitialRTT.

I do not think we have a reason to believe that the variance of RTT (which applies as a multiplier here) increases when we obtain the first sample?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3524

---

From: ianswett <[email-masked]>
Date: Mon, 16 Mar 2020 06:13:24 -0700

I wasn't sure if this would be design or not, but now that the PR is complete, I believe it's editorial, as @kazuho PR changes the pseudocode, but proscribes exactly the same behavior as the existing text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3524#issuecomment-599528442

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 16 Mar 2020 12:20:56 -0700

To be precise, there is one thing that does change, and that is the initial timeout when a connection is resumed on the same path.

At the moment, the only variable we recommend to remember is SRTT, and when resuming a connection on the same path, use 2 * SRTT as the initial timeout.

The proposed change increases that to 3 * SRTT. I think this is better than status-quo, assuming that we agree that RTTVAR should be 2 * sample when there is only one known sample.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3524#issuecomment-599716802

---

From: ianswett <[email-masked]>
Date: Mon, 16 Mar 2020 13:11:18 -0700

Thanks for pointing that out, I noticed that the first time around and then forgot.  I'll let @larseggert make the call about whether he thinks this is design then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3524#issuecomment-599737075