Subject: Re: [quicwg/base-drafts] MAY send 1 packet entering recovery (#3443)

From: ianswett <[email-masked]>
Date: Wed, 04 Mar 2020 16:44:36 -0800

Merged #3443 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3443#event-3099233171

---

From: MikkelFJ <[email-masked]>
Date: Thu, 12 Mar 2020 05:36:29 -0700

mikkelfj commented on this pull request.

> @@ -706,6 +706,13 @@ The recovery period limits congestion window reduction to once per round trip.
 During recovery, the congestion window remains unchanged irrespective of new
 losses or increases in the ECN-CE counter.
 
+When entering recovery, a single packet MAY be sent even if bytes in flight

If it is possible to enter recovery before amplification mitigation is no longer needed, sending a packet upon entering recovery might contradict amp. rules.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3443#pullrequestreview-373516127

---

From: ianswett <[email-masked]>
Date: Thu, 12 Mar 2020 05:42:00 -0700

ianswett commented on this pull request.

Agreed, but the amplification factor is a MUST and this is a MAY, so I think the MUST wins here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3443#discussion_r391593572

---

From: MikkelFJ <[email-masked]>
Date: Thu, 12 Mar 2020 05:51:10 -0700

I'm not sure. It depends on what you read first. It's like that NATO test with two pages of questions and instructions, the first stating to read everything first, the last stating the all other questions need not be answered. Why gives those entries priority over other entries?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3443#discussion_r391598372