Subject: Re: [quicwg/base-drafts] Update PTO pseudocode to better match text (#3461)

From: ianswett <[email-masked]>
Date: Sat, 14 Mar 2020 16:55:36 -0700

@ianswett pushed 1 commit.

85554f934d7357584d728b521594bdd4eef09d30  MT's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/4de119f1d207ada8de6689112f876d9d2fc29527..85554f934d7357584d728b521594bdd4eef09d30

---

From: ianswett <[email-masked]>
Date: Sat, 14 Mar 2020 17:03:19 -0700

ad3b1d8ea1e77a6828548ea2147b87665350f744  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/85554f934d7357584d728b521594bdd4eef09d30..ad3b1d8ea1e77a6828548ea2147b87665350f744

---

From: ianswett <[email-masked]>
Date: Sat, 14 Mar 2020 17:08:17 -0700

e9bde2162d5ec1adb25a1779ab1c9cff3b95f397  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/ad3b1d8ea1e77a6828548ea2147b87665350f744..e9bde2162d5ec1adb25a1779ab1c9cff3b95f397

---

From: ianswett <[email-masked]>
Date: Sun, 15 Mar 2020 13:59:59 -0700

d38a58221838edbc6f82d97f5a204345a5baf50a  Two comments based on MT's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/e9bde2162d5ec1adb25a1779ab1c9cff3b95f397..d38a58221838edbc6f82d97f5a204345a5baf50a

---

From: ianswett <[email-masked]>
Date: Sun, 15 Mar 2020 14:00:38 -0700

@martinthomson I added two comments to address the two points of potential confusion you raised in your last comment, PTAL.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461#issuecomment-599263954

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Mar 2020 14:34:56 -0700

martinthomson approved this pull request.

> +    // There is nothing to detect lost and the server
+    // is not blocked by the anti-amplification limit.

This comment is a little strange.

The point here is to catch the case where there is nothing to send, with the exception that the client might need to keep the server primed in case it is blocked on its anti-amplification limit.

As we've already dispensed with the anti-amplification limit at the server, I think that this needs to concentrate on the client instead.

```suggestion
    // There is nothing to detect lost, so set no timer.
    // However, the client still sets the timer if the server
    // might be blocked by the anti-amplification limit.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461#pullrequestreview-374835865

---

From: ianswett <[email-masked]>
Date: Sun, 15 Mar 2020 16:37:59 -0700

2c07fed9f4e21f95002dcb25dc1fac69aa009a8d  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/d38a58221838edbc6f82d97f5a204345a5baf50a..2c07fed9f4e21f95002dcb25dc1fac69aa009a8d

---

From: ianswett <[email-masked]>
Date: Sun, 15 Mar 2020 16:40:11 -0700

aacd0773af40e062ce90b788d331719061ee23ba  tweak mt's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461/files/2c07fed9f4e21f95002dcb25dc1fac69aa009a8d..aacd0773af40e062ce90b788d331719061ee23ba

---

From: Martin Thomson <[email-masked]>
Date: Sun, 15 Mar 2020 17:24:26 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461#pullrequestreview-374851726

---

From: ianswett <[email-masked]>
Date: Sun, 15 Mar 2020 17:26:43 -0700

Merged #3461 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3461#event-3131154897