Subject: Re: [quicwg/base-drafts] Move out-of-order packets definition (#3369)

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Mar 2020 03:16:00 -0700

mikkelfj commented on this pull request.

> @@ -196,6 +196,12 @@ Ack-eliciting Packet:
   CONNECTION_CLOSE. These cause a recipient to send an acknowledgment (see
   {{sending-acknowledgements}}).
 
+Out-of-order packet:
+
+: A packet that does not increase the largest received packet number for its
+  packet number space by exactly one. A packet can arrive out of order
+  if it is delayed or if earlier packets are lost or delayed.
+

Technically, a packet can also arrive out of order if a packet number is intentionally skipped, typically for optimistic ACK attack protection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#pullrequestreview-372626035

---

From: ianswett <[email-masked]>
Date: Wed, 11 Mar 2020 06:05:28 -0700

ianswett commented on this pull request.

+Out-of-order packet:
+

We're using it to elicit an ACK more quickly in the case of a single PTO packet, see #2952 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3369#discussion_r390954637