Subject: Re: [quicwg/base-drafts] Authenticate connection IDs (2fc5157)

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Mar 2020 00:48:58 -0700

nitpick but it would be more precise to say that it must not associate any packets with the same connection since other SCIDs could refer to other connections. Further, connection IDs can later change, so for that reason the statement is also not precise. Whether it is possible to formulate this concisely I'm not so sure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/2fc5157ed013ae8f84f17e44409c42be87660feb#commitcomment-37761891

---

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Mar 2020 00:53:58 -0700

I may be dropping the ball on this, but how does the server know what it send in a Retry if the retry is stateless?  This can only be derived from information encoded in a token sent in the retry package unless servers coordinate effectively, which they in general do not.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/2fc5157ed013ae8f84f17e44409c42be87660feb#commitcomment-37761947

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Mar 2020 16:09:59 -0700

The server can copy this from the DCID in the client's Initial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/2fc5157ed013ae8f84f17e44409c42be87660feb#commitcomment-37884186

---

From: MikkelFJ <[email-masked]>
Date: Wed, 18 Mar 2020 01:45:45 -0700

Yes, that is is correct, I forgot. But the reason I was wondering is that setting the TP appears to be informative to the client, so why would you set a TP the client already knows? I was thinking of this in terms of the server ensuring some sort of guarantee towards the client.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/2fc5157ed013ae8f84f17e44409c42be87660feb#commitcomment-37890646

---

From: MikkelFJ <[email-masked]>
Date: Wed, 18 Mar 2020 01:48:32 -0700

Ah, it such that the client can see that the server got the right one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/commit/2fc5157ed013ae8f84f17e44409c42be87660feb#commitcomment-37890690