Subject: [quicwg/base-drafts] Out-of-order may be intentional (#3511)

From: ianswett <[email-masked]>
Date: Wed, 11 Mar 2020 06:07:49 -0700

A sender can intentionally skip a packet number, causing the receiver to treat a packet as &quot;Out-of-order&quot;.

>From @mikkelfj comment on #3369
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3511

-- Commit Summary --

  * Out-of-order may be intentional

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3511.patch
https://github.com/quicwg/base-drafts/pull/3511.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Mar 2020 07:19:08 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#pullrequestreview-372800206

---

From: Marten Seemann <[email-masked]>
Date: Wed, 11 Mar 2020 07:25:00 -0700

marten-seemann commented on this pull request.

> @@ -200,7 +200,8 @@ Out-of-order packet:
 
 : A packet that does not increase the largest received packet number for its
   packet number space ({{packet-numbers}}) by exactly one. A packet can arrive
-  out of order if it is delayed or if earlier packets are lost or delayed.
+  out of order if it is delayed, if earlier packets are lost or delayed, or if
+  the sender intentionally skips a packet number.

Reading through the whole definition now, I'm wondering why an out-of-order packet is one that doesn't increase the largest received packet number. If a packet jumps ahead of the queue, I would have considered it out-of-order, but it's not according to this definition.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#pullrequestreview-372805724

---

From: MikkelFJ <[email-masked]>
Date: Wed, 11 Mar 2020 08:13:15 -0700

mikkelfj commented on this pull request.

@marten-seemann If the received packet number is not an increment by one over the largest received, it is considered out-of-order. This also applies to packets that jumps ahead of the queue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#discussion_r391044102

---

From: Marten Seemann <[email-masked]>
Date: Wed, 11 Mar 2020 08:15:52 -0700

Sorry, missed the "by exactly one".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#discussion_r391046013

---

From: Marten Seemann <[email-masked]>
Date: Wed, 11 Mar 2020 08:16:06 -0700

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#pullrequestreview-372855832

---

From: ianswett <[email-masked]>
Date: Wed, 11 Mar 2020 11:21:22 -0700

Merged #3511 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3511#event-3120000421