Subject: [quicwg/base-drafts] Clarify handshake anti-deadlock wrt. handshake confirmation (#3503)

From: Benjamin Saunders <[email-masked]>
Date: Fri, 06 Mar 2020 20:24:13 -0800

Fixes #3502.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3503

-- Commit Summary --

  * Clarify handshake anti-deadlock wrt. handshake confirmation

-- File Changes --

    M draft-ietf-quic-recovery.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3503.patch
https://github.com/quicwg/base-drafts/pull/3503.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503

---

From: ianswett <[email-masked]>
Date: Sat, 07 Mar 2020 01:41:39 -0800

ianswett commented on this pull request.

Thanks for writing this!

I think I'd prefer mentioning HANDSHAKE_DONE explicitly since receiving a 1-RTT ACK also confirms the handshake and I think in this case, it's probably easier to not rely on handshake confirmed?

Also be aware of #3461 to update the PTO pseudocode.

> @@ -517,7 +517,7 @@ client, it is the client's responsibility to send packets to unblock the server
 until it is certain that the server has finished its address validation
 (see Section 8 of {{QUIC-TRANSPORT}}).  That is, the client MUST set the
 probe timer if the client has not received an acknowledgement for one of its
-Handshake or 1-RTT packets.
+Handshake or 1-RTT packets and the handshake has not been confirmed.

As history, this text was written without HANDSHAKE_DONE in mind(because it hadn't been added) and I thought receiving a 1-RTT ACK was going to be how the handshake was confirmed.

Technically, receiving an ACK of 1-RTT confirms the handshake, so I prefer "or a HANDSHAKE_DONE frame." instead of "and the handshake has not been confirmed."  It's a bit more explicit, now that our mechanisms have stabilized.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#pullrequestreview-370734411

---

From: Benjamin Saunders <[email-masked]>
Date: Sat, 07 Mar 2020 20:25:31 -0800

@Ralith pushed 1 commit.

91b3d1b28346ad5e9b2a4aca41b6a397c33f9b0f  Clarify handshake anti-deadlock wrt. handshake confirmation

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503/files/2de61fdc0b8a1336286b52cc9cad3943b483debc..91b3d1b28346ad5e9b2a4aca41b6a397c33f9b0f

---

From: Benjamin Saunders <[email-masked]>
Date: Sat, 07 Mar 2020 20:26:28 -0800

Having non-overlapping conditions makes sense; adjusted wording.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#issuecomment-596165338

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Mar 2020 14:40:54 -0700

martinthomson commented on this pull request.

> @@ -1162,7 +1162,7 @@ PeerNotAwaitingAddressValidation():
   # Servers complete address validation when a
   # protected packet is received.
   return has received Handshake ACK ||
-         has received 1-RTT ACK
+         has received 1-RTT ACK or a HANDSHAKE_DONE frame

```suggestion
       has received 1-RTT ACK ||
       has received HANDSHAKE_DONE
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#pullrequestreview-370859969

---

From: Benjamin Saunders <[email-masked]>
Date: Sun, 08 Mar 2020 14:42:38 -0700

@Ralith pushed 1 commit.

a8e454f2019b63856fad3693475499648e777e04  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503/files/91b3d1b28346ad5e9b2a4aca41b6a397c33f9b0f..a8e454f2019b63856fad3693475499648e777e04

---

From: ianswett <[email-masked]>
Date: Tue, 10 Mar 2020 11:26:20 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#pullrequestreview-372213883

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Mar 2020 15:27:38 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#pullrequestreview-372364362

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Mar 2020 15:28:04 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#pullrequestreview-372364635

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 10 Mar 2020 15:28:27 -0700

Merged #3503 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3503#event-3116683497