Subject: [quicwg/base-drafts] Clarify cases ACKing every could not happen (#3518)

From: ianswett <[email-masked]>
Date: Thu, 12 Mar 2020 05:53:53 -0700

Adds editorial text about why a receiver could decide to send ACKs less frequently than every two packets.

This keeps coming up(ie: #3501), so I thought text was necessary.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3518

-- Commit Summary --

  * Clarify cases ACKing every could not happen

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3518.patch
https://github.com/quicwg/base-drafts/pull/3518.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518

---

From: Marten Seemann <[email-masked]>
Date: Thu, 12 Mar 2020 05:55:27 -0700

marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518#pullrequestreview-373528535

---

From: Martin Thomson <[email-masked]>
Date: Thu, 12 Mar 2020 16:31:45 -0700

martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518#pullrequestreview-373964279

---

From: martinduke <[email-masked]>
Date: Thu, 12 Mar 2020 21:08:52 -0700

martinduke approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518#pullrequestreview-374039773

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Mar 2020 15:22:08 -0700

janaiyengar commented on this pull request.

> +A receiver could decide to send an ACK frame less frequently than every other
+ack-eliciting packet if it has information about how frequently the sender's
+congestion controller needs feedback for optimal performance, or if the
+receiver is CPU or bandwidth constrained.

```suggestion
A receiver could decide to send an ACK frame less frequently if it has
information about how frequently the sender's congestion controller
needs feedback for optimal performance, or if the receiver is CPU or
bandwidth constrained.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518#pullrequestreview-376445685

---

From: ianswett <[email-masked]>
Date: Tue, 17 Mar 2020 15:23:19 -0700

@ianswett pushed 1 commit.

ece73d0732087247a9d792e2b1f01d822dd91423  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518/files/5c144a08e829b1a3ff8d279d65eca2b4c2a0f799..ece73d0732087247a9d792e2b1f01d822dd91423

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Mar 2020 15:27:34 -0700

Merged #3518 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3518#event-3139282874