Subject: Re: [quicwg/base-drafts] Import most H2 references (#3407)

From: Lucas Pardue <[email-masked]>
Date: Tue, 10 Mar 2020 15:31:24 -0700

LPardue approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#pullrequestreview-372366127

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Mar 2020 15:33:10 -0700

MikeBishop commented on this pull request.

>  those listed here.
 
+TODO:  This is going to be a big import, probably worthy of its own PR.

@martinthomson notes that many of the Security Considerations of 7540 are from transporty stuff, and we might have less to import here than it seems.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#discussion_r390649733

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Mar 2020 17:01:44 -0700

mnot commented on this pull request.

> @@ -659,6 +704,15 @@ CANCEL_PUSH frame, the client can abort reading the stream with an error code of
 H3_REQUEST_CANCELLED. This asks the server not to transfer additional data and
 indicates that it will be discarded upon receipt.
 
+Pushed responses that are cacheable (see Section 3 of {{!RFC7234}}) can be

This is a _very_ murky area, still.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#discussion_r391965781

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 12 Mar 2020 17:02:14 -0700

mnot approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#pullrequestreview-373973310

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Mar 2020 09:12:37 -0700

Separating to #3530 so I can merge this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#discussion_r394468210

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Mar 2020 09:13:25 -0700

This wound up being pretty big.  It will follow as a separate PR to encourage appropriate review.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#discussion_r394468864

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Mar 2020 09:13:54 -0700

Merged #3407 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3407#event-3142168969