Subject: [quicwg/base-drafts] Push and Cache Interaction (#3530)

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Mar 2020 16:12:14 +0000 (UTC)

> This is okay for now, but it should be improved eventually to talk about browser state separately from the cache. IOW, define push as part of the browser history (prehistory) because this is entirely separate from a cache (even if they use the same storage handles).

_Originally posted by @royfielding in https://github.com/quicwg/base-drafts/pull/3407_

@MikeBishop:

> Push isn't part of the cache, but it does use the definition of "cacheable" -- do you think it should be pointing elsewhere?

@mnot:
> This is a very murky area, still.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 18 Mar 2020 17:29:20 -0700

I would be very concerned if H3 started defining push in a way that's more specific / different to H2. If we're going to "clean up" push, it should be done across the board, and by the HTTP wg.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-600924373

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 18 Mar 2020 17:32:31 -0700

See also https://github.com/whatwg/fetch/issues/354

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-600925128

---

From: Lars Eggert <[email-masked]>
Date: Thu, 19 Mar 2020 03:57:39 -0700

This sounds like a design issue, but I defer to the HTTP folks to categorize it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-601116050

---

From: Mike Bishop <[email-masked]>
Date: Thu, 19 Mar 2020 06:02:23 -0700

I agree; I think my ideal outcome here would be to leave it as-is, or failing that, for another document to have appropriate text I can point to.  The issue exists mostly to ensure we didn't lose Roy's unaddressed comment when I merged the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-601164799

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 19 Mar 2020 07:17:59 -0700

I think this is out of scope for the work in QUIC WG.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-601204165

---

From: "Roy T. Fielding" <[email-masked]>
Date: Thu, 19 Mar 2020 10:15:28 -0700

My comment was intended to be editorial for QUIC, but it is also critical to understand from an implementation perspective (regardless of protocol).

When a browser makes a request and receives a 2xx response, that response is not "part of the cache". It is part of the working state (hypertext workspace) for the user agent (windows/tabs/history). The response may also be cached, but the working state is not subject to cache controls or freshness. The same should be true for push or it won't be usable for non-cached session-specific content.

I don't need QUIC to redefine that. It's actually something that should be defined by user agents (Fetch). What I need is for the HTTP/3 text to be consistent with the existing distinction between the working state of a user agent and the terminology for a cache. They are distinct on purpose. We should probably reinforce that in http-core as well, beyond the brief section in Caching.

I'd prefer that we keep this open (editorial) until I get a chance to review the next draft version.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3530#issuecomment-601306624