Subject: [quicwg/base-drafts] Appendix B: nameIndex (#3544)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 24 Mar 2020 01:38:23 -0700

It seems to me that `nameIndex` appears suddenly in Appendix B. What's that? Is it the same as `nameIdx`?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544

---

From: Martin Thomson <[email-masked]>
Date: Tue, 24 Mar 2020 03:36:20 -0700

Yikes, that original name was a little hard to follow.

It strikes me that this code could be improved by consistently choosing either Idx or Index throughout.  Though that might require some additional attention to line length if the longer (and better) option is chosen.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#issuecomment-603160588

---

From: afrind <[email-masked]>
Date: Tue, 24 Mar 2020 11:27:23 -0700

Broader question: do we still feel like the pseudocode is useful in general?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#issuecomment-603429953

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 24 Mar 2020 18:23:05 -0700

Let's suppose that `nameIdx` and `nameIndex` are the same.

The next question is how `getNameIndex` should behave?

The return value (`nameIdx`) is compared with `staticTable.size`. But it is also used for dynamic table. If my understanding is correct, the index spaces of the two table are independent. I cannot understand what is returned from `getNameIndex`.

Can `getNameIndex` return `nil`? If `nameIdx` can be `nil`, `nameIdx <= staticTable.size` causes an error. If it cannot be `nil`, it means that an index for the name cab be always found, which, I think, is not realistic.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#issuecomment-603588324