Subject: [quicwg/base-drafts] Remove normative text from the Recovery Appendix (#3538)

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 06:53:23 -0700

Moves some RECOMMENDEDs up and removes others which are already elsewhere in the draft and reference those sections.

This was intended to fix #3205, which I can still do in this PR if @larseggert would like, but I still think of Min CWND and Initial CWND as constants per-connection, even if they&#39;re not truly constants.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3538

-- Commit Summary --

  * Remove normative text from the Recovery Appendix

-- File Changes --

    M draft-ietf-quic-recovery.md (21)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3538.patch
https://github.com/quicwg/base-drafts/pull/3538.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:05:46 -0700

@ianswett pushed 1 commit.

642ce7caca446e4b44bd395ac082e49c3b9b50f2  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/05f5956b827e93aa895cf4d3d6a30b81db29e13a..642ce7caca446e4b44bd395ac082e49c3b9b50f2

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:09:25 -0700

1c593340d789d6125321e5472f64683dd5394000  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/642ce7caca446e4b44bd395ac082e49c3b9b50f2..1c593340d789d6125321e5472f64683dd5394000

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:16:15 -0700

b9329499d67dfcd20cceec5f248408c2e2bbbed6  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/1c593340d789d6125321e5472f64683dd5394000..b9329499d67dfcd20cceec5f248408c2e2bbbed6

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:19:00 -0700

9377e7102c4004ebfedb9bb22ad5c0db9b2cc19b  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/b9329499d67dfcd20cceec5f248408c2e2bbbed6..9377e7102c4004ebfedb9bb22ad5c0db9b2cc19b

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:19:38 -0700

cf83390780ab5d7fb6de9bc433509d9fff6a1f3f  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/9377e7102c4004ebfedb9bb22ad5c0db9b2cc19b..cf83390780ab5d7fb6de9bc433509d9fff6a1f3f

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 07:21:01 -0700

3fc39f20336830e011ec04c1ef28b22214430664  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/cf83390780ab5d7fb6de9bc433509d9fff6a1f3f..3fc39f20336830e011ec04c1ef28b22214430664

---

From: Martin Thomson <[email-masked]>
Date: Sun, 22 Mar 2020 17:52:26 -0700

martinthomson approved this pull request.

> @@ -448,7 +448,8 @@ Using max(smoothed_rtt, latest_rtt) protects from the two following cases:
   up.
 
 The RECOMMENDED time threshold (kTimeThreshold), expressed as a round-trip time
-multiplier, is 9/8.
+multiplier, is 9/8. The RECOMMENDED value of the timer granularity(kGranularity)

```suggestion
multiplier, is 9/8. The RECOMMENDED value of the timer granularity (kGranularity)
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538#pullrequestreview-379081250

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 17:55:01 -0700

ffd25220f508a8d4e9448c45768a52636bfb9a4e  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/3fc39f20336830e011ec04c1ef28b22214430664..ffd25220f508a8d4e9448c45768a52636bfb9a4e

---

From: ianswett <[email-masked]>
Date: Sun, 22 Mar 2020 17:58:55 -0700

a594e565afab913579509b9a67497ef148b96671  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538/files/ffd25220f508a8d4e9448c45768a52636bfb9a4e..a594e565afab913579509b9a67497ef148b96671

---

From: ianswett <[email-masked]>
Date: Fri, 27 Mar 2020 09:02:23 -0700

Merged #3538 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3538#event-3173033146