Subject: Re: [quicwg/base-drafts] Should we allow ACK-only packets to be declared lost? (#3451)

From: Igor Lubashev <[email-masked]>
Date: Sun, 01 Mar 2020 08:39:33 -0800

Happy to discuss acknowledgement reliability, though I want to point out that the two issues are related.  If it is decided that non-ACK-eliciting packets will be acknowledged eventually (except for special circumstances, such as connection termination or packet number space issues), then it informs the "considered lost" discussion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3451#issuecomment-593117062

---

From: ianswett <[email-masked]>
Date: Sun, 01 Mar 2020 10:46:26 -0800

The difference between MUST with caveats(ie: connection-close/etc) and SHOULD is small to zero in practice I believe, since in both cases you may never receive an acknowledgement for the packet.

It's also an unenforceable MUST, which I hate adding unless it's critical to protocol correctness.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3451#issuecomment-593130487

---

From: ianswett <[email-masked]>
Date: Wed, 04 Mar 2020 16:43:28 -0800

Closed #3451 via #3453.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3451#event-3099231212