Subject: Re: [quicwg/base-drafts] Skip a packet number when sending one PTO packet (#2952)

From: ianswett <[email-masked]>
Date: Mon, 16 Mar 2020 18:26:24 -0700

Reopened #2952.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#event-3135484053

---

From: ianswett <[email-masked]>
Date: Mon, 16 Mar 2020 18:30:36 -0700

@ianswett pushed 1 commit.

91474d493c4ef2951476fb8b20746ab1e30f21ce  Merge branch 'master' into ianswett-skip-packet-number

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952/files/b66c69c8d05ee5d3f8cdb312020ec642b6e45ead..91474d493c4ef2951476fb8b20746ab1e30f21ce

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Mar 2020 15:44:01 -0700

@martinthomson pushed 1 commit.

87dcdbb8d14c8ffdbb3279c1a787d7b4d6fc8b88  Skip a packet number when sending one PTO packet

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952/files/91474d493c4ef2951476fb8b20746ab1e30f21ce..87dcdbb8d14c8ffdbb3279c1a787d7b4d6fc8b88

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Mar 2020 15:46:46 -0700

janaiyengar commented on this pull request.

> @@ -587,6 +587,9 @@ In addition to sending data in the packet number space for which the timer
 expired, the sender SHOULD send ack-eliciting packets from other packet
 number spaces with in-flight data, coalescing packets if possible.
 
+When only sending a single packet on PTO, senders can skip a packet number to

```suggestion
If the sender sends a single packet on PTO, it can skip a packet number to
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#pullrequestreview-376456604

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Mar 2020 15:47:08 -0700

a33165b1e8daf7161fa38a429856e5c6dd932a34  Fix line length

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952/files/87dcdbb8d14c8ffdbb3279c1a787d7b4d6fc8b88..a33165b1e8daf7161fa38a429856e5c6dd932a34

---

From: ianswett <[email-masked]>
Date: Tue, 17 Mar 2020 15:48:46 -0700

5bed48fa00e604d3231bcde6afa4b920d546747d  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952/files/a33165b1e8daf7161fa38a429856e5c6dd932a34..5bed48fa00e604d3231bcde6afa4b920d546747d

---

From: ianswett <[email-masked]>
Date: Tue, 17 Mar 2020 15:51:02 -0700

4795016ab6ce9ce1c6a1e9f64d3e4fcc5cffcda3  Remove one packet

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952/files/5bed48fa00e604d3231bcde6afa4b920d546747d..4795016ab6ce9ce1c6a1e9f64d3e4fcc5cffcda3

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Mar 2020 15:54:04 -0700

janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#pullrequestreview-376459485

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Mar 2020 15:55:35 -0700

Merged #2952 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/2952#event-3139347945