Subject: [quicwg/base-drafts] protection-samples.js: add option to output ChaCha20-Poly1305 trace (#3506)

From: Daiki Ueno <[email-masked]>
Date: Tue, 10 Mar 2020 05:06:10 -0700

This adds `-c` option to `protection-samples.js` to control which AEAD algorithm will be used for the trace.

Related to #3488 

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3506

-- Commit Summary --

  * protection-samples.js: use const as possible
  * protection-samples.js: add option to output ChaCha20-Poly1305 trace

-- File Changes --

    M protection-samples.js (142)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3506.patch
https://github.com/quicwg/base-drafts/pull/3506.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3506

---

From: Daiki Ueno <[email-masked]>
Date: Tue, 10 Mar 2020 21:55:36 -0700

@ueno pushed 1 commit.

2f1edda743fd22068b687edf1b5b928ff368a528  protection-samples.js: add option to output ChaCha20-Poly1305 trace

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3506/files/f295be40d1a1d42a91b254c56f8ffc088285848a..2f1edda743fd22068b687edf1b5b928ff368a528

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Mar 2020 22:33:32 -0700

Hey Daiki,

Thanks for spending the time on this.  You've improved my terrible code a fair bit in the process.  Most of the refactoring is flat good and I want to take that.

However, I don't think that this is the right approach.  All the examples here are Initial or Retry packets, for which there is only one AEAD we use: AES-GCM.  What we really need is an example of another type of packet (maybe a 1-RTT packet with a short header) for a ChaCha example.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3506#issuecomment-597451992