Subject: Re: [quicwg/base-drafts] max_packet_size in 0-RTT (#3447)

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Mar 2020 16:33:15 -0700

Chairs, I believe that this should be design.  Kazuho and I might disagree about the relative value of requiring this change, but it is design even if we do nothing.  It's minor: we already strongly recommend remembering the parameter, we just don't mandate rejection of 0-RTT if the value is reduced.  That is what the PR does.

Jana has promised to talk to Kazuho and determine what to do next.  I will defer to Jana's judgment here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3447#issuecomment-597370580

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 11 Mar 2020 00:35:55 -0700

After chatting with @martinthomson and kazuho, I recommend that we _not_ make this change.

With the current spec, where a server is not required to reject 0RTT, it means that the server might reduce this value and a client might have to cope with the network (or server) dropping larger 0RTT packets, which it would misconstrue as congestion. OTOH, if the server receives these larger packets despite it having reduced its max_udp_payload_size, it seems a waste to drop packets that have reached and can be processed by the server. Subsequent client connections should use the revised value anyway since the server will communicate a new value in the ServerHello.

(FWIW, a client _could_ use a new reduced transport parameter from the server as an indication that any 0RTT losses were probably not due to congestion. Granted this is a bit of gymnastics, but if a client were to care about the performance of this rare case, it is possible for it to reasonably revert any congestion control action.)

My opinion isn't super strong, but this issue is minor enough. Let's move along to more important things.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3447#issuecomment-597485779

---

From: ianswett <[email-masked]>
Date: Mon, 30 Mar 2020 09:06:21 -0700

It looks like consensus is to close this with no action.  If so, I believe this can be marked has-proposal?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3447#issuecomment-606091312