Subject: [quicwg/base-drafts] Note that state probably needs to be maintained for each issued CID if the peer chooses to use it (#3557)

From: Eric Kinnear <[email-masked]>
Date: Mon, 30 Mar 2020 10:46:07 -0700

Add another note when cautioning endpoints about how many CIDs to issue: in this case to note that if you issue a CID you need to be willing for the other endpoint to use 100% of the issued CIDs, which comes with an implicit willingness to maintain state for each path on which that CID could be used. (That&#39;s one per path, but # paths == # CIDs in the worst case.)

Fixes #3489.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3557

-- Commit Summary --

  * #3489: Note that state probably needs to be maintained for each issued CID if the peer chooses to use it

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3557.patch
https://github.com/quicwg/base-drafts/pull/3557.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557

---

From: ianswett <[email-masked]>
Date: Mon, 30 Mar 2020 10:59:33 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#pullrequestreview-384099015

---

From: ianswett <[email-masked]>
Date: Mon, 30 Mar 2020 11:00:33 -0700

This adds a MAY and the issue is already marked design, so I'm inclined to mark this design and do a consensus call on the issue with the next batch.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#issuecomment-606151523

---

From: Eric Kinnear <[email-masked]>
Date: Mon, 30 Mar 2020 11:01:58 -0700

We could also leave this as `might` choose, which seems completely reasonable as well. The only reason I went for `MAY` was because the previous sentence is the same level of advisory and we also used `MAY` there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#issuecomment-606152258

---

From: ianswett <[email-masked]>
Date: Mon, 30 Mar 2020 11:12:21 -0700

@erickinnear I'd prefer you keep it as is.  The process isn't going to cause an appreciable delay in this case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#issuecomment-606157309

---

From: Martin Thomson <[email-masked]>
Date: Mon, 30 Mar 2020 15:36:24 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#pullrequestreview-384281101

---

From: Marten Seemann <[email-masked]>
Date: Mon, 30 Mar 2020 19:02:07 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#pullrequestreview-384353474

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 30 Mar 2020 19:10:42 -0700

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#pullrequestreview-384355851

---

From: Mike Bishop <[email-masked]>
Date: Tue, 31 Mar 2020 12:11:13 -0700

@MikeBishop commented on this pull request.

> +per-path state it maintains, such as path validation status, as its peer can
+interact with as many paths as there are issued connection IDs.

```suggestion
per-path state it maintains, such as path validation status, as its peer
might interact with it over as many paths as there are issued
connection IDs.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3557#pullrequestreview-385026850