Subject: [quicwg/base-drafts] Inconsistency of QPACK static table (#3562)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 31 Mar 2020 01:43:42 -0700

Entry 52 has a space after `;`, ie `text/html; charset=utf-8`.
But entry 54 does not, ie `ext/plain;charset=utf-8`.
This is intentional? The other entries always have a space after `;`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562

---

From: Mike Bishop <[email-masked]>
Date: Tue, 31 Mar 2020 06:27:26 -0700

IIRC, it's deliberate, albeit regrettable.

The values were compiled from real-world header use, and while the space is not semantically meaningful, we opted to go with the most common variant of each to get the most benefit on encoders which would do a strict string comparison to the value in the table instead of checking for equivalent values.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562#issuecomment-606626397

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 31 Mar 2020 13:20:54 -0700

Since the text is as intended, I believe we can close with no action.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562#issuecomment-606852976

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 31 Mar 2020 13:44:21 -0700

It would be helpful if a comment of "no space is intentional" was added.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562#issuecomment-606864593

---

From: afrind <[email-masked]>
Date: Tue, 31 Mar 2020 15:06:07 -0700

I'll add a comment to prevent this issue from coming up again

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562#issuecomment-606901985

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 31 Mar 2020 17:10:01 -0700

@afrind Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3562#issuecomment-606952517