Subject: Re: [quicwg/base-drafts] One of 'host' or ':authority' is required (#3475)

From: "Roy T. Fielding" <[email-masked]>
Date: Fri, 06 Mar 2020 18:19:40 -0800

royfielding requested changes on this pull request.

Doesn't this beg the question "what if the request is for a URI that does not have a mandatory authority component?" All of the other cases are described.  I would add something like:

```
  If the scheme does not have a mandatory authority component and
  none is provided in the request target, the request MUST NOT contain
  the ":authority" pseudo-header and "Host" header fields.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3475#pullrequestreview-370714740

---

From: Mike Bishop <[email-masked]>
Date: Tue, 10 Mar 2020 15:16:59 -0700

@MikeBishop pushed 1 commit.

29f7d0d3f8c3b6bb18051dfd55715b46986ced78  Roy's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3475/files/2de14d7cb9ea83c85f134eae9348c51dc7601a50..29f7d0d3f8c3b6bb18051dfd55715b46986ced78

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Mar 2020 01:38:57 -0700

kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3475#pullrequestreview-372558400

---

From: Mike Bishop <[email-masked]>
Date: Mon, 23 Mar 2020 08:15:03 -0700

Merged #3475 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3475#event-3155690928