Subject: [quicwg/base-drafts] The packet header changed since this was written (#3514)

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Mar 2020 17:24:06 -0700

Now the version comes before the connection ID fields.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3514

-- Commit Summary --

  * The packet header changed since this was written

-- File Changes --

    M draft-ietf-quic-invariants.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3514.patch
https://github.com/quicwg/base-drafts/pull/3514.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Mar 2020 17:36:37 -0700

kazuho commented on this pull request.

> @@ -352,7 +352,7 @@ The following statements are NOT guaranteed to be true for every QUIC version:
 * QUIC uses an AEAD (AEAD_AES_128_GCM {{?RFC5116}}) to protect the packets it
   exchanges during connection establishment
 
-* QUIC packet numbers appear after the Version field
+* QUIC packet numbers appear after the connection ID fields

This statement is bit weird, as the packet number field of an Initial packet does not immediately follow the connection ID fields. The field appears after the token field. And I point this out in relation to Initial packets, because IIUC the primary intended reader here are the middlebox developers, who would have the possibility of analyzing Initial packets, but no other packet types with a packet number field.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514#pullrequestreview-373212890

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Mar 2020 17:47:01 -0700

@martinthomson pushed 1 commit.

813992d32661388da7e1a790c3e3054f5a6d06de  Try again with an allowance for Initial

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514/files/e394a7ab9701f9edf0a50be30da23bb2a9cd669e..813992d32661388da7e1a790c3e3054f5a6d06de

---

From: Martin Thomson <[email-masked]>
Date: Wed, 11 Mar 2020 17:47:22 -0700

martinthomson commented on this pull request.

Of course.  I was trying to be economical with language, but clearly that needs to be better.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514#discussion_r391347735

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 11 Mar 2020 17:49:56 -0700

kazuho approved this pull request.

Thank you for the changes LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514#pullrequestreview-373216567

---

From: ianswett <[email-masked]>
Date: Wed, 11 Mar 2020 19:01:36 -0700

ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514#pullrequestreview-373234733

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Mar 2020 15:18:00 -0700

Merged #3514 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3514#event-3139260959