Subject: Re: [quicwg/base-drafts] Clarify zero-length CIDs and active_connection_id_limit TP (#3426)

From: Jana Iyengar <[email-masked]>
Date: Tue, 07 Apr 2020 15:26:05 -0700

@janaiyengar approved this pull request.

LGTM, modulo one suggestion.

> @@ -4697,11 +4697,12 @@ active_connection_id_limit (0x000e):
   to store. This value includes the connection ID received during the handshake,
   that received in the preferred_address transport parameter, and those received
   in NEW_CONNECTION_ID frames.
-  Unless a zero-length connection ID is being used, the value of the
-  active_connection_id_limit parameter MUST be no less than 2. If this
-  transport parameter is absent, a default of 2 is assumed.
-  When a zero-length connection ID is being used, the active_connection_id_limit
-  parameter MUST NOT be sent.
+  The value of the active_connection_id_limit parameter MUST be at least 2.

```suggestion
  The value of the active_connection_id_limit parameter MUST be at least 2.
  An endpoint that receives a value less than 2 MUST close the connection
  with an error of type TRANSPORT_PARAMETER_ERROR.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#pullrequestreview-389532948

---

From: Nick Harper <[email-masked]>
Date: Tue, 07 Apr 2020 19:00:42 -0700

@nharper pushed 1 commit.

0b3ff6b60864e9b29657e784c4a85bec36a05694  Clarify what to do if an invalid value is received

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426/files/7eabbf9eb01302c45b75f3beb5fd9ced655112d6..0b3ff6b60864e9b29657e784c4a85bec36a05694

---

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Apr 2020 09:10:08 -0700

Purely editorial nit:  This text has a lot of line breaks that won't render as such in the output.  If you want to have separate paragraphs in the definition, you need a new `: ` for each new paragraph.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#issuecomment-621310908