Subject: [quicwg/base-drafts] Backticks around parameter names (#3609)

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Apr 2020 08:55:09 -0700

We're somewhat inconsistent about whether transport parameters et al. get backticks or not across the documents.  For example,

>   the ACK Delay field is scaled by multiplying the encoded value by 2 to the
>  power of the value of the `ack_delay_exponent` transport parameter set by the
>  sender of the ACK frame; see {{transport-parameter-definitions}}.  Scaling in

> The Retire Prior To field counts connection IDs established during connection
> setup and the preferred_address transport parameter; see {{retiring-cids}}. The
> Retire Prior To field MUST be less than or equal to the Sequence Number field.

Same goes for error code names, frame types, etc.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3609

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Apr 2020 22:27:29 -0700

I think that - at this point - the overwhelming majority of parameter names are not quoted in any way and do go in and fix all of them would be tiresome.  However, most are in snake_case, CamelCase, Title Case, or SHOUTING_CASE so they are almost always distinguishable.

I grepped through and we have 38 instances of backticks.  Most of these are in -http and -qpack.  Most of them are in the description of reserved codepoints.  I'm going to suggest we scrub the others out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3609#issuecomment-621620429