Subject: Re: [quicwg/base-drafts] Linkability with preferred_address usage (#3559)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Apr 2020 00:09:36 -0700

This is a maybe-design issue with an editorial-shaped proposed resolution.  I think we'll start to see a lot more of these.  I think we should run the design issue process still, but I leave that to chair discretion.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-610216040

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Apr 2020 17:27:38 +0000 (UTC)

@quicwg/chairs, ^

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-610514901

---

From: MikkelFJ <[email-masked]>
Date: Tue, 07 Apr 2020 11:01:25 -0700

> We already decided not to prohibit active migration in the presence of zero-length CIDs, IIRC.

As I recall and unless something changed recently, active migration is not permitted for 0 length CID, but it is accepted that a NAT migrates outside the peers control.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-610535837

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 07 Apr 2020 15:58:58 -0700

I read this as a clarification of existing protocol design. I'd like to get eyes on it to make sure there is sufficient opportunity for discussion. Marking as design.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-610660506

---

From: MikkelFJ <[email-masked]>
Date: Wed, 08 Apr 2020 08:12:37 -0700

Transport section 9.5 says "An endpoint MUST use a new connection ID if it initiates connection migration as described in Section 9.2 or probes a new network path as described in Section 9.1. ". 

Section 19.15 (NEW_CONNECTION_ID) says: "An endpoint MUST NOT send this frame if it currently requires that its peer send packets with a zero-length Destination Connection ID. "

I take this means active migration cannot happen with 0-length ID.

BTW: in a few places "zero length" used over the more common "zero-length".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-611016419

---

From: David Schinazi <[email-masked]>
Date: Wed, 08 Apr 2020 17:31:12 -0700

I really think we shouldn't disallow connection migration when the server uses zero-length CIDs. As stated above, linkability can happen for a variety a reasons, and we should leave it up to the client to decide whether it wants its bytes to go through or not. Perhaps an editorial paragraph stating this in the migration section or security considerations would do the job.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3559#issuecomment-611262513