Subject: [quicwg/base-drafts] DPLPMTUD fixes (#3606)

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Apr 2020 23:52:05 -0700

A few minor tweaks based on review of the latest DPLPMTUD draft.

If I never have to type DPLPMTUD ever again, I&#39;ll be happy.

Closes #3217.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3606

-- Commit Summary --

  * DPLPMTUD fixes

-- File Changes --

    M draft-ietf-quic-transport.md (42)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3606.patch
https://github.com/quicwg/base-drafts/pull/3606.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Apr 2020 16:54:23 -0700

@martinthomson pushed 1 commit.

2c874dc1c477a7d8f07d5ad232251c73069f0a97  More explicit 'probe for the MTU'

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606/files/8e68ce6266e405fd56b90753737d641be8e7ba50..2c874dc1c477a7d8f07d5ad232251c73069f0a97

---

From: martinduke <[email-masked]>
Date: Thu, 30 Apr 2020 08:43:29 -0700

@martinduke approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606#pullrequestreview-403645616

---

From: ianswett <[email-masked]>
Date: Thu, 30 Apr 2020 08:44:18 -0700

@ianswett approved this pull request.

Thanks, LG

>  The endpoint SHOULD ignore all ICMP messages that fail validation.
 
-An endpoint MUST NOT increase PMTU based on ICMP messages.  Any reduction in the
-QUIC maximum packet size MAY be provisional until QUIC's loss detection
-algorithm determines that the quoted packet has actually been lost.
+An endpoint MUST NOT increase PMTU based on ICMP messages; see Section 3, clause
+6 of {{!DPLPMTUD}}.  Any reduction in the QUIC maximum packet size MAY be

```suggestion
6 of {{!DPLPMTUD}}.  Any reduction in the QUIC maximum packet size in response to ICMP messages MAY be
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606#pullrequestreview-403645283

---

From: Martin Thomson <[email-masked]>
Date: Thu, 30 Apr 2020 23:18:48 -0700

cb6d26caf615a6fd3e036cc54ac1b881fc6504fd  Helpful tweak to existing text

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606/files/2c874dc1c477a7d8f07d5ad232251c73069f0a97..cb6d26caf615a6fd3e036cc54ac1b881fc6504fd

---

From: Martin Thomson <[email-masked]>
Date: Thu, 30 Apr 2020 23:19:01 -0700

Merged #3606 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3606#event-3292354384