Subject: [quicwg/base-drafts] avoid setting the loss timer when amplification limited (#3596)

From: Marten Seemann <[email-masked]>
Date: Wed, 22 Apr 2020 23:40:14 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3596

-- Commit Summary --

  * avoid setting the loss timer when amplification limited

-- File Changes --

    M draft-ietf-quic-recovery.md (10)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3596.patch
https://github.com/quicwg/base-drafts/pull/3596.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3596

---

From: Marten Seemann <[email-masked]>
Date: Wed, 22 Apr 2020 23:58:02 -0700

@marten-seemann pushed 1 commit.

c248ff2a917b46cfdd011442d7dd68c60dea86ae  avoid setting the loss timer when amplification limited

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3596/files/c9ddc51bcf3616abfb94eb66578f08682c47306b..c248ff2a917b46cfdd011442d7dd68c60dea86ae

---

From: ianswett <[email-masked]>
Date: Thu, 23 Apr 2020 07:51:52 -0700

@ianswett approved this pull request.

I think this is slightly better, but I also don't think it matters that much?  If the packets were declared lost, they wouldn't be sent immediately due to the amplification limit, so I think either way works.

I'll let @janaiyengar make the call on whether to merge this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3596#pullrequestreview-399178722

---

From: Marten Seemann <[email-masked]>
Date: Thu, 23 Apr 2020 19:45:49 -0700

This change only makes a difference if the server sent multiple Initial packets, and only some of them were acknowledged. In that case, you'd usually set an early retransmit timer. Of course, if you're amplification limited, you wouldn't be able to send out anything on timer expiration.

I don't think this makes a big difference in practice. I just found it easier to reason about the amplification limit this way: "If amplication limited, never set a timer."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3596#issuecomment-618771240

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 28 Apr 2020 15:37:46 -0700

Let's not do this. There's a potential deadlock here: if the server does not mark the packet as lost, it will not retransmit later when a data packet is received from the client that opens up the server to send. Basically, the server only marks packets as lost on receiving an ACK, and if you make this change, the server could end up never marking a handshake packet as lost.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3596#issuecomment-620891691