Subject: [quicwg/base-drafts] Error code for increasing stream_id in GOAWAY frames (#3616)

From: Dragana Damjanovic <[email-masked]>
Date: Wed, 29 Apr 2020 22:38:02 -0700

The spec defines this as MUST NOT:

> An endpoint MAY send multiple GOAWAY frames indicating different identifiers, but MUST NOT increase the identifier value they send, since clients might already have retried unprocessed requests on another connection.

we should define an error code for this?
I do not see that it is define, maybe I missed it somewhere.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3616

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Apr 2020 23:05:59 -0700

We can define our own internal error code for this and report that as a generic error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3616#issuecomment-621631983

---

From: Dragana Damjanovic <[email-masked]>
Date: Thu, 30 Apr 2020 04:25:24 -0700

> We can define our own internal error code for this and report that as a generic error.

I am fine with that. Adding a description to the "Reason Phrase" in CONNECTION_CLOSE frame is enough.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3616#issuecomment-621773652