Subject: [quicwg/base-drafts] Forbid zero-length connection ID with preferred addresses (#3565)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Apr 2020 00:07:42 -0700

This is option 4 from the discussion in #3560.  That is, making
preferred_address equivalent to NEW_CONNECTION_ID with a sequence number
of 1 in every way that matters.

Closes #3560.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3565

-- Commit Summary --

  * Forbid zero-length connection ID with preferred addresses

-- File Changes --

    M draft-ietf-quic-transport.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3565.patch
https://github.com/quicwg/base-drafts/pull/3565.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565

---

From: Mike Bishop <[email-masked]>
Date: Tue, 07 Apr 2020 10:25:37 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#pullrequestreview-389328446

---

From: ianswett <[email-masked]>
Date: Tue, 07 Apr 2020 11:27:37 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#pullrequestreview-389380810

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 07 Apr 2020 12:07:10 -0700

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#pullrequestreview-389409810

---

From: Marten Seemann <[email-masked]>
Date: Wed, 08 Apr 2020 00:18:07 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#pullrequestreview-389709686

---

From: David Schinazi <[email-masked]>
Date: Wed, 08 Apr 2020 17:16:22 -0700

@DavidSchinazi commented on this pull request.

> @@ -4740,6 +4740,14 @@ preferred_address (0x0d):
   be at least one unused active connection ID when the client initiates
   migration to the preferred address.
 
+: The Connection ID and Stateless Reset Token fields of a preferred address are
+  identical in syntax and semantics to the corresponding fields of a
+  NEW_CONNECTION_ID frame ({{frame-new-connection-id}}).  A server that chooses
+  a zero-length connection ID MUST NOT provide a preferred address.  Similarly,

I don't think this is right. NEW_CONNECTION_ID frames don't ban zero-length CIDs. What NEW_CONNECTION_ID bans is switching between zero-length CIDs and non-zero-length CIDs. If the server is using a zero-length CID, it should be allowed to switch to a preferred address, and also use zero-length CIDs there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#pullrequestreview-390414323

---

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Apr 2020 17:44:25 -0700

@martinthomson commented on this pull request.

Thanks for taking this to the issue.

NEW_CONNECTION_ID can't [change to or from zero-length](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-19.15-6), so this is making this feature consistent with that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3565#discussion_r405894081