Subject: [quicwg/base-drafts] editorial advice for h2<->h3 error propagation (#3602)

From: Lucas Pardue <[email-masked]>
Date: Tue, 28 Apr 2020 06:49:37 -0700

Fixes #2817 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3602

-- Commit Summary --

  * editorial advice for h2&lt;-&gt;h3 error propagation

-- File Changes --

    M draft-ietf-quic-http.md (35)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3602.patch
https://github.com/quicwg/base-drafts/pull/3602.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3602

---

From: ianswett <[email-masked]>
Date: Tue, 28 Apr 2020 08:45:55 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3602#pullrequestreview-401970976

---

From: Mike Bishop <[email-masked]>
Date: Thu, 30 Apr 2020 08:41:32 -0700

@MikeBishop requested changes on this pull request.

I think I'd invert the polarity of this, based on what I recall of the list discussion.  Error codes largely reflect connection-local issues and mostly shouldn't be propagated.  I'm inclined to lead with indicating an upstream  failure via the HTTP status codes, then note that there are times it might be useful to proxy a specific stream error, such as REFUSED_STREAM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3602#pullrequestreview-403643922