Subject: Re: [quicwg/base-drafts] QPACK Appendix B: nameIndex (#3544)

From: afrind <[email-masked]>
Date: Mon, 13 Apr 2020 15:21:36 -0700

The code comes from a time when the index space was unified, and the first staticTable.size indexes were static and the rest were dynamic.  And yes, getNameIndex can return "not found".  I'll add some comments explaining this case and sanitize the pseudocode.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#issuecomment-613125869

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 14 Apr 2020 17:30:16 -0700

Closed #3544.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#event-3233381953

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 14 Apr 2020 17:30:16 -0700

@afrind Thank you for your answer. Let's close this in favor of #3577.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3544#issuecomment-613748026