Subject: Re: [quicwg/base-drafts] Retaining the largest received packet number (#3541)

From: Mike Bishop <[email-masked]>
Date: Wed, 01 Apr 2020 07:47:43 -0700

> Given you need to track largest acknowledged locally(ie: not only in the in-flight ACK frame), I don't think there are any problems there.
> 
> I have two cases in mind where the largest acked could validly decrease:

Perhaps it's a naive model, but I had envisioned an implementation remembering a chain of ranges of packet numbers it had received or not.  The implementation would save space by forgetting the earliest packet numbers when the chain got too long, and would construct an ACK frame out of the latest set of these ranges it had room for.

In that mental model, at least, there's not really room for the idea that you might drop the largest-acked frame number from your memory because it's too old -- it's always at the most-recent end of your chain, even if you currently happen to be receiving packets that fill in the middle for some implementation-specific reason.  (Implementation-specific *to the peer*, which you obviously can't know about or code for!)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3541#issuecomment-607293498

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Apr 2020 16:26:37 -0700

That matches my model for this.  It is also likely the case that the next packet you receive is largest+1, so there is no real advantage to forgetting the largest acknowledged.  Not sending it is slightly different though.  I can understand how an implementation might choose to send only ranges that have recently changed.  My contention is that this is not a good choice and we should recommend against that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3541#issuecomment-607538378

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 14 Apr 2020 16:08:26 -0700

@martinthomson to produce some text here that separates retention policy (MUST) from signaling policy (SHOULD).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3541#issuecomment-613724477

---

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Apr 2020 18:44:55 -0700

Closed #3541 via #3581.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3541#event-3282725513