Subject: [quicwg/base-drafts] Describe what happens if TLS breaks (#3587)

From: Martin Thomson <[email-masked]>
Date: Sun, 19 Apr 2020 23:20:01 -0700

We don&#39;t ever really say that QUIC depends on TLS providing the
properties that we claim TLS provides.  So it&#39;s worth pointing that
exposure.  This is more so because some of the properties we claim are
dependent on these properties.

Closes #3512.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3587

-- Commit Summary --

  * Describe what happens if TLS breaks

-- File Changes --

    M draft-ietf-quic-transport.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3587.patch
https://github.com/quicwg/base-drafts/pull/3587.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 19 Apr 2020 23:24:02 -0700

@erickinnear approved this pull request.

Looking good, thanks for writing this!

> +of confidentiality protections, both from the negotiation of keys using the TLS
+handshake and from QUIC packet protection, to avoid linkability across network

Minor word nit:
```suggestion
of confidentiality protections, both for the negotiation of keys using the TLS
handshake and for QUIC packet protection, to avoid linkability across network
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#pullrequestreview-396167797

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Apr 2020 00:04:56 -0700

@martinthomson pushed 1 commit.

9c911c716fddb325c0bdd91039f0e6095442cc74  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587/files/5e5a61d904bc870925af97a27d11d18b8a5c2520..9c911c716fddb325c0bdd91039f0e6095442cc74

---

From: Mike Bishop <[email-masked]>
Date: Mon, 20 Apr 2020 08:28:25 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#pullrequestreview-396563142

---

From: ianswett <[email-masked]>
Date: Mon, 20 Apr 2020 19:21:24 -0700

@ianswett approved this pull request.

> @@ -6170,10 +6170,22 @@ considered separately.
 ### Handshake {#handshake-properties}
 
 The QUIC handshake incorporates the TLS 1.3 handshake and enjoys the

enjoys is an odd word to me, but I'm struggling to find a better one.

-In addition to those properties, the handshake is intended to provide some
-defense against DoS attacks on the handshake, as described below.
+Any attack on the TLS handshake that might compromise the secrecy or uniqueness

```suggestion
Any attack on the TLS handshake that compromises the secrecy or uniqueness
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#pullrequestreview-396941715

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Apr 2020 00:17:21 -0700

4df3184f1d5f1fca44b368bc1b1e542a0546f76e  maybe or not

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587/files/9c911c716fddb325c0bdd91039f0e6095442cc74..4df3184f1d5f1fca44b368bc1b1e542a0546f76e

---

From: Marten Seemann <[email-masked]>
Date: Tue, 21 Apr 2020 00:58:07 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#pullrequestreview-397079359

---

From: David Schinazi <[email-masked]>
Date: Tue, 21 Apr 2020 09:23:47 -0700

@DavidSchinazi commented on this pull request.

"benefits from" ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#discussion_r412299722

---

From: David Schinazi <[email-masked]>
Date: Tue, 21 Apr 2020 09:26:12 -0700

"benefits from" ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#discussion_r412299662

---

From: Mike Bishop <[email-masked]>
Date: Tue, 21 Apr 2020 10:38:05 -0700

(Cleaned up duplicate instances of the same comment.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#issuecomment-617309149

---

From: Eric Kinnear <[email-masked]>
Date: Tue, 21 Apr 2020 11:10:51 -0700

@erickinnear commented on this pull request.

Ahh @ekr will be sad
But yeah “benefits from” or “inherits” are all less tongue-in-cheek

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#discussion_r412380530

---

From: ekr <[email-masked]>
Date: Tue, 21 Apr 2020 13:44:35 -0700

@ekr commented on this pull request.

I don't really feel strongly about it. This is the text that 8446 uses (See S 8.1), so it's not tongue in cheek. I prefer "inherits" if that's accurate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#discussion_r412478425

---

From: ianswett <[email-masked]>
Date: Tue, 21 Apr 2020 14:12:25 -0700

@ianswett commented on this pull request.

I also don't really care, we can keep it as is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#discussion_r412494830

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Apr 2020 15:20:40 -0700

Merged #3587 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3587#event-3258115520