Subject: [quicwg/base-drafts] MUST verify => MUST NOT accept on fail (#3590)

From: Mike Bishop <[email-masked]>
Date: Mon, 20 Apr 2020 08:15:14 -0700

Addresses @ekr&#39;s comments on #3558.  While this adds a new MUST NOT, I believe it&#39;s editorial because it&#39;s simply stating the implicit result of the &quot;MUST verify&quot; in that PR.  If anyone disagrees, speak up and I&#39;ll change it.

Separately, I think there&#39;s a case for this &quot;MUST NOT&quot; to be a &quot;SHOULD NOT,&quot; as we all know there are situations in which clients proceed through a certificate warning.  It&#39;s a reasonable semantic distinction whether the client does not consider the server authoritative but processes the result anyway (MUST NOT), or considers the server authoritative because the user told it to (SHOULD NOT).  Opinions on the bikeshed welcome.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3590

-- Commit Summary --

  * MUST verify =&gt; MUST NOT accept on fail

-- File Changes --

    M draft-ietf-quic-http.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3590.patch
https://github.com/quicwg/base-drafts/pull/3590.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3590

---

From: ianswett <[email-masked]>
Date: Mon, 20 Apr 2020 14:42:01 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3590#pullrequestreview-396833799

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Apr 2020 15:20:06 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3590#pullrequestreview-397716600

---

From: Mike Bishop <[email-masked]>
Date: Tue, 28 Apr 2020 15:40:27 -0700

Merged #3590 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3590#event-3282389826