Subject: Re: [quicwg/base-drafts] Add capability for sending HTTP metadata (trailer fields) in mid-stream (#3265)

From: Lars Eggert <[email-masked]>
Date: Wed, 22 Apr 2020 05:06:10 -0700

I'd like to see if we can "unpark" this issue and move it forward in some way. Any suggestions?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-617737626

---

From: Mike Bishop <[email-masked]>
Date: Wed, 22 Apr 2020 08:09:14 -0700

I'm of the opinion that this doesn't belong in HTTP/3 if it hasn't been defined by the HTTP WG before we ship (and it won't be).  If/when this takes shape, it will probably be as an extension to HTTP/2 and HTTP/3, and that's okay.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-617837856

---

From: ianswett <[email-masked]>
Date: Wed, 22 Apr 2020 08:51:14 -0700

+1 that this should become an extension and doesn't belong in HTTP/3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-617863808

---

From: Lars Eggert <[email-masked]>
Date: Wed, 22 Apr 2020 09:15:46 -0700

So "close with no action"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-617878933

---

From: "Roy T. Fielding" <[email-masked]>
Date: Wed, 22 Apr 2020 10:45:59 -0700

Just leave it parked for now. It is still an issue for QUIC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-617929884

---

From: Lars Eggert <[email-masked]>
Date: Thu, 23 Apr 2020 03:48:31 -0700

We're trying to clear out the "parked" queue, because folks seem to think "parked" means "needs to be resolved for v1."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-618330315

---

From: "Roy T. Fielding" <[email-masked]>
Date: Thu, 23 Apr 2020 08:40:03 -0700

The discussion in HTTP was entirely positive and there is already a non-IETF spec for it as an extension to h2, but that was in Singapore and nobody has had time to work on it since. The http-core specs already allow for it. h2 is not under revision. The only bits it requires in HTTP/3 is a frame type and some expectation of what to do with it (i.e., it contains fields, treat them as optional trailers, done).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-618471820

---

From: ianswett <[email-masked]>
Date: Thu, 23 Apr 2020 08:52:25 -0700

I don't expect most people to use this, and those that do(yes, that includes us) would likely want support in H2 and H3, so I'd prefer an extension for both H2 and H3.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-618479450

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Apr 2020 09:13:04 -0700

I'm going to mark this as v2 for now. We can unmark it if there is HTTP progress that would allow us to target QUICv1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-620084577

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 27 Apr 2020 11:14:52 -0700

That's fine with me. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-620148347

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 28 Apr 2020 05:20:15 -0700

Since this is a design issue, we'll run this through the Late-stage process and include it in the next consensus call. 

The proposal is to:

> mark this as v2 for now. We can unmark it if the HTTP work progresses faster than we do, and we decide to incorporate it in some way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3265#issuecomment-620570088