Subject: Re: [quicwg/base-drafts] (PL)PMTU text (#3217)

From: Martin Thomson <[email-masked]>
Date: Tue, 28 Apr 2020 23:44:53 -0700

Let me see if I can break this down a little.  cc @martinduke for his opinion of these.

14.3.1: The first and last comment relates to the section on using coalescing to help the routing of ICMP messages.  I had no difficulty reading this section, though I might suggest one tweak:

> Endpoints that rely on the destination connection ID for routing *incoming* QUIC packets are likely to require that the connection ID be included in PMTU probe packets to route any resulting ICMP messages (Section 14.2) back to the correct endpoint.

The "further validation" text: DF is currently mandated, but this text pre-dates that requirement.  We should drop that clause.  And the other clause is a little lame.  I'd be happy dropping all of the quoted text.

Citing DPLPMTUDTD is sensible and we should do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3217#issuecomment-621019631

---

From: Martin Thomson <[email-masked]>
Date: Thu, 30 Apr 2020 23:19:01 -0700

Closed #3217 via #3606.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3217#event-3292354391