Subject: [quicwg/base-drafts] [qpack] Add comment explaining static table (#3576)

From: afrind <[email-masked]>
Date: Mon, 13 Apr 2020 15:10:52 -0700

Fixes #3562
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3576

-- Commit Summary --

  * [qpack] Add comment explaining static table

-- File Changes --

    M draft-ietf-quic-qpack.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3576.patch
https://github.com/quicwg/base-drafts/pull/3576.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Apr 2020 18:18:10 -0700

@martinthomson commented on this pull request.

> +this methodology, some of the entries may be inconsistent.  Notably,
+"content-type: text/plain; charset=utf-8" appears twice with two different
+whitespace encodings (entries 52 and 54).

```suggestion
this methodology, some of the entries may be inconsistent.
```

It's probably enough to observe that there are inconsistencies that derive from the source data.

> @@ -1199,6 +1199,12 @@ are registered in the "HTTP/3 Error Code" registry established in {{HTTP3}}.
 
 # Static Table
 
+This table was generated by analyzing actual internet traffic in 2018 and
+manually crafting the table for optimal compression of common headers.  Due to

What does "manually crafting" mean?  I think that you mean manually removing obvious redundancies and (other stuff we/Mike did).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#pullrequestreview-392540302

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 14 Apr 2020 15:37:55 -0700

@LPardue commented on this pull request.

 # Static Table

maybe you want to include some info from https://github.com/quicwg/base-drafts/issues/904#issuecomment-414471170

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#discussion_r408476458

---

From: afrind <[email-masked]>
Date: Tue, 14 Apr 2020 15:50:09 -0700

@afrind commented on this pull request.

I feel like we've gotten a couple questions about this one in particular, but I can remove it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#discussion_r408480919

---

From: afrind <[email-masked]>
Date: Tue, 14 Apr 2020 16:00:19 -0700

@afrind pushed 1 commit.

9ae56f45f7ad4ff677465f7d22537994089f2187  Feedback from Martin and Lucas

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576/files/cb2841badefe470760d1b3d52263a56ab9734f7b..9ae56f45f7ad4ff677465f7d22537994089f2187

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 14 Apr 2020 17:37:35 -0700

@kazu-yamamoto commented on this pull request.

I would like to support @martinthomson because `text/plain; charsert=utf-8-` does not appear *twice*. The other is `text/html`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#discussion_r408514594

---

From: Mike Bishop <[email-masked]>
Date: Wed, 15 Apr 2020 11:32:46 -0700

@MikeBishop commented on this pull request.

 # Static Table

We started from an automated query for data, then:

- Removed vendor-specific artifacts and anti-patterns as best we could
- Sorted the entries into the three tranches described in the comment; the sizes are dictated by the QPACK instruction space, but the selection of which things go in each tranche is a mix of data and judgement.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#discussion_r409049584

---

From: Bence Béky <[email-masked]>
Date: Wed, 22 Apr 2020 13:29:51 +0000 (UTC)

@bencebeky approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#pullrequestreview-398187879

---

From: afrind <[email-masked]>
Date: Tue, 28 Apr 2020 15:05:30 -0700

Merged #3576 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3576#event-3282305072