Subject: [quicwg/base-drafts] Text on ECN probing (#3585)

From: mirjak <[email-masked]>
Date: Thu, 16 Apr 2020 10:10:24 -0700

Currently there is text saying:
"To reduce the chances of misinterpreting congestive loss as packets dropped by a
 faulty network element, an endpoint could set the ECT(0) codepoint in the first
 ten outgoing packets on a path, or for a period of three RTTs, whichever occurs
 first."
At the interim there was a discussion that today it is likely save to just make all packets with ECT as the risk of black-holing is not measurable anymore. PR #3454 proposes a text change to provide more background. In the comments there is also a link to a measurement which could be added if desired.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3585

---

From: Martin Thomson <[email-masked]>
Date: Sun, 19 Apr 2020 22:19:30 -0700

This issue has been extensively litigated and I don't think that there is new information that would suggest a change here.  Implementations are free to assume that ECN works, but we did previously have consensus to recommend a more conservative approach.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3585#issuecomment-616316008

---

From: mirjak <[email-masked]>
Date: Mon, 20 Apr 2020 04:32:59 -0700

I don't think we had consensus to recommend this and the proposed text makes clear that this is not a recommendation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3585#issuecomment-616493019

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Apr 2020 09:19:26 -0700

Folks who care about a change here need to prioritize progressing this issue. We're close to being able to last-call the specs, and would like this resolved in time.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3585#issuecomment-620088160