Subject: [quicwg/base-drafts] use TRANSPORT_PARAMETER_ERROR when authenticating connection IDs (#3703)

From: Marten Seemann <[email-masked]>
Date: Tue, 26 May 2020 20:22:45 -0700

The guiding principle here (as we apply it for FRAME_ENCODING_ERRORs) is that if an error is detectable without accessing connection state, we use the more specific error. So for example, since `initial_source_connection_id` and `original_destination_connection_id` are required transport parameters, their absence should be responded to with a TRANSPORT_PARAMETER_ERROR. A similar argument applies to the absence of the `retry_source_connection_id` TP, although I can see how one might use PROTOCOL_VIOLATION here (note that this is still valid behavior with this PR, as every more specific error can be replaced with a PROTOCOL_VIOLATION, if an implementation wishes to do so).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3703

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 May 2020 20:40:08 -0700

Thanks.  I think that this is fine.  I will make a few editorial comments on the PR, but I think that the application of the agreed principles is correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3703#issuecomment-634409106