Subject: [quicwg/base-drafts] Add CID authentication to draft-28 changelog (#3682)

From: David Schinazi <[email-masked]>
Date: Wed, 20 May 2020 21:04:01 -0700

I suspect this was an editorial oversight?
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3682

-- Commit Summary --

  * Add CID authentication to draft-28 changelog

-- File Changes --

    M draft-ietf-quic-transport.md (1)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3682.patch
https://github.com/quicwg/base-drafts/pull/3682.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3682

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 May 2020 21:21:52 -0700

@martinthomson commented on this pull request.

Oops.  Yes.  Given the importance of this change, it's a bit of a problem that I missed it.

> @@ -6902,6 +6902,7 @@ Issue and pull request numbers are listed with a leading octothorp.
 - Clarified that largest acknowledged needs to be saved, but not necessarily
   signaled in all cases (#3541, #3581)
 - Addressed linkability risk with the use of preferred_address (#3559, #3563)
+- Added authentication of handshake connection IDs (#3429, #3499)

```suggestion
- Added authentication of handshake connection IDs (#3439, #3499)
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3682#pullrequestreview-415868769

---

From: David Schinazi <[email-masked]>
Date: Wed, 20 May 2020 21:37:20 -0700

@DavidSchinazi pushed 1 commit.

44bef0c230a2723a3aa21976aa283d7a75325d0a  Numbers all look the same :(

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3682/files/e934d003976041b7325c0b5750cf4697a3593d89..44bef0c230a2723a3aa21976aa283d7a75325d0a

---

From: David Schinazi <[email-masked]>
Date: Wed, 20 May 2020 21:38:27 -0700

Yeah I went through the changelog looking for compatibility-breaking changes and this was the main one I was expecting to see there...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3682#issuecomment-631874635

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 May 2020 23:11:37 -0700

Merged #3682 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3682#event-3359387736