Subject: [quicwg/base-drafts] A suggested text about a push stream after a CANCEL_PUSH (#3699)

From: Dragana Damjanovic <[email-masked]>
Date: Tue, 26 May 2020 07:24:10 -0700

I found this while reading the draft. I think the text is a bit misleading. The current test suggests that this is a server error, but it may not be a server error:

&gt; If a push stream arrives after a client has sent CANCEL_PUSH, this MAY be treated as a stream error of type H3_STREAM_CREATION_ERROR.

This PR is just a propose text that make this more clear and changes the error code.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3699

-- Commit Summary --

  * A suggested text about a push stream after a CANCEL_PUSH

-- File Changes --

    M draft-ietf-quic-http.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3699.patch
https://github.com/quicwg/base-drafts/pull/3699.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3699

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 May 2020 16:45:32 -0700

@martinthomson commented on this pull request.

So the problem here is that this is one-sided.  A server has a similar issue.  If it decides to cancel, then it might have created the stream, so it needs to reset the stream too.

> @@ -1292,9 +1292,10 @@ corresponding promise to be fulfilled.
 Sending CANCEL_PUSH has no direct effect on the state of existing push streams.
 A server SHOULD NOT send a CANCEL_PUSH when it has already created a
 corresponding push stream, and a client SHOULD NOT send a CANCEL_PUSH when it
-has already received a corresponding push stream.  If a push stream arrives
-after a client has sent CANCEL_PUSH, this MAY be treated as a stream error of
-type H3_STREAM_CREATION_ERROR.
+has already received a corresponding push stream. A push stream may arrive

```suggestion
has already received a corresponding push stream. A push stream could arrive
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3699#pullrequestreview-418751214

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 08:28:00 -0700

This overlaps the change in #3700.  I've cherry-picked it into that branch and we'll address them together.  I believe that will also address @martinthomson's comment, since #3700 already discusses the server side.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3699#issuecomment-634740104

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 08:28:03 -0700

Closed #3699.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3699#event-3378728294