Subject: Re: [quicwg/base-drafts] Migration with zero-length CID is inadvisable (#3563)

From: ekr <[email-masked]>
Date: Fri, 08 May 2020 13:22:19 -0700

@ekr approved this pull request.

> @@ -2246,6 +2246,16 @@ that packet numbers cannot be used to correlate activity.  This does not prevent
 other properties of packets, such as timing and size, from being used to
 correlate activity.
 
+An endpoint SHOULD NOT initiate migration with a peer that uses a zero-length

```suggestion
An endpoint SHOULD NOT initiate migration with a peer that has requested a zero-length
```

> @@ -2246,6 +2246,16 @@ that packet numbers cannot be used to correlate activity.  This does not prevent
 other properties of packets, such as timing and size, from being used to
 correlate activity.
 
+An endpoint SHOULD NOT initiate migration with a peer that uses a zero-length

"uses" is confusing here. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3563#pullrequestreview-408501768

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 May 2020 16:27:51 -0700

@martinthomson pushed 1 commit.

d29840a2953c9f87abbe8c4838b58934ee46de9a  CIDs are requested in this context

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3563/files/7d5089a754a6cecce519d6c20325ec0adaf65f2e..d29840a2953c9f87abbe8c4838b58934ee46de9a

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 May 2020 16:28:57 -0700

b400f0946ee8770b9432ae6f38ca80b479bd17a7  reflow

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3563/files/d29840a2953c9f87abbe8c4838b58934ee46de9a..b400f0946ee8770b9432ae6f38ca80b479bd17a7

---

From: Martin Thomson <[email-masked]>
Date: Thu, 14 May 2020 00:34:46 -0700

Merged #3563 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3563#event-3335241840