Subject: [quicwg/base-drafts] Move MUST not send bursts up in the pacing section (#3664)

From: ianswett <[email-masked]>
Date: Mon, 18 May 2020 03:02:45 -0700

I prefer to have MUSTs towards the top of sections when possible so they&#39;re not missed.

This is a follow-on from #3630
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3664

-- Commit Summary --

  * Move MUST not send bursts up in the pacing section

-- File Changes --

    M draft-ietf-quic-recovery.md (13)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3664.patch
https://github.com/quicwg/base-drafts/pull/3664.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664

---

From: ianswett <[email-masked]>
Date: Mon, 18 May 2020 03:11:17 -0700

@ianswett pushed 1 commit.

23e3109e596baa220b83923443df4ea60f71dde7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664/files/de2b8544cc2449c97fc76d00efe0da83c2044e39..23e3109e596baa220b83923443df4ea60f71dde7

---

From: Martin Thomson <[email-masked]>
Date: Mon, 18 May 2020 16:43:21 -0700

@martinthomson approved this pull request.

> -controller. For example, a pacer might distribute the congestion window over
-the smoothed RTT when used with a window-based controller, or a pacer might use
-the rate estimate of a rate-based controller.

I'm OK with leaving this out, but I'm interested in why you did.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664#pullrequestreview-414008130

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 18 May 2020 17:30:02 -0700

I'm not a fan of this change -- I think there's value in having that text below where we talk about how bursts can occur. That said, I don't feel strongly about it, so I'm not going to fight for it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664#issuecomment-630504890

---

From: ianswett <[email-masked]>
Date: Tue, 19 May 2020 07:08:15 -0700

@ianswett commented on this pull request.

I thought it was redundant to the text you added below.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664#discussion_r427329968

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 29 May 2020 19:36:04 -0700

Merged #3664 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3664#event-3389333813