Subject: Re: [quicwg/base-drafts] Review conditions for PTO arming around end of handshake (#3613)

From: Martin Thomson <[email-masked]>
Date: Sun, 17 May 2020 19:47:33 -0700

@ianswett can we get a status update?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3613#issuecomment-629916342

---

From: ianswett <[email-masked]>
Date: Mon, 18 May 2020 03:41:20 -0700

The PTO is always armed when there are bytes in flight(except when the loss timer is armed), it's just a matter of what PN spaces it can be armed for at a given point in time.  Once the connection is handshake complete, it's immediately allowed to arm it for inflight 1-RTT ack-eliciting packets.

Re-reading the text, I couldn't find anything explicitly calling out that the alarm may need to be recomputed and reset in the handshake confirmed case, though it is stated for discarding keys.

As clarified in #3597 when the client is handshake complete but not confirmed, it is unsure whether the server has Handshake keys or ApplicationData keys, but it's very unlikely to have both.  As such, sending something ack-eliciting from both PN spaces is safest.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3613#issuecomment-630099015

---

From: Martin Thomson <[email-masked]>
Date: Tue, 19 May 2020 16:22:19 -0700

Closed #3613 via #3665.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3613#event-3354072268