Subject: Re: [quicwg/base-drafts] Clarify zero-length CIDs and active_connection_id_limit TP (#3426)

From: ekr <[email-masked]>
Date: Fri, 08 May 2020 13:42:56 -0700

@ekr requested changes on this pull request.

> @@ -4697,11 +4697,14 @@ active_connection_id_limit (0x000e):
   to store. This value includes the connection ID received during the handshake,
   that received in the preferred_address transport parameter, and those received
   in NEW_CONNECTION_ID frames.
-  Unless a zero-length connection ID is being used, the value of the
-  active_connection_id_limit parameter MUST be no less than 2. If this
-  transport parameter is absent, a default of 2 is assumed.
-  When a zero-length connection ID is being used, the active_connection_id_limit
-  parameter MUST NOT be sent.
+  The value of the active_connection_id_limit parameter MUST be at least 2.
+  An endpoint that receives a value less than 2 MUST close the connection
+  with an error of type TRANSPORT_PARAMETER_ERROR.
+  If this transport parameter is absent, a default of 2 is assumed.  If an
+  endpoint uses a zero-length connection ID, the active_connection_id_limit

"uses" here seems confusing

If an endpoint issues a zero-length connection-id, the active_connection_id_limit value it says is ignored, as...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#pullrequestreview-408513951

---

From: Nick Harper <[email-masked]>
Date: Fri, 08 May 2020 13:53:51 -0700

@nharper commented on this pull request.

Here's the situation I'm trying to explain:

Suppose the client (C) uses 0-length CIDs. Since C uses 0-length CIDs, it will never send a NEW_CONNECTION_ID frame. The server (S) can still send an active_connection_id_limit transport param, but C will ignore it because it is irrelevant.

> If an endpoint issues a zero-length connection-id, the active_connection_id_limit value it says is ignored, as...

My interpretation of this is that it says if a client (for example) C uses the 0-length CID, the active_connection_id_limit sent by C should be ignored. I believe this is incorrect, as C's active_connection_id_limit is regarding how many NEW_CONNECTION_IDs S can send to C.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#discussion_r422368749

---

From: ekr <[email-masked]>
Date: Fri, 08 May 2020 14:21:52 -0700

@ekr commented on this pull request.

My problem here is the text "uses", which is non-specific. A issues a CID and B sends packets with it. So they both use it.

You're right that my text above is backwards, which seems like an argument in favor of "this is confusing text".  How about:

"If an endpoint issues a zero-length connection ID, it will never send NEW_CONNECTION_ID and therefore ignores any active_connection_id limits values it receives"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#discussion_r422381485

---

From: Nick Harper <[email-masked]>
Date: Fri, 08 May 2020 14:30:23 -0700

@nharper pushed 1 commit.

149475babfed6f9f739460dee7ff953bd43c0ad9  Clarify issues instead of uses 0-length CID

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426/files/0b3ff6b60864e9b29657e784c4a85bec36a05694..149475babfed6f9f739460dee7ff953bd43c0ad9

---

From: Nick Harper <[email-masked]>
Date: Fri, 08 May 2020 14:30:33 -0700

I've changed "uses" to "issues" and tightened up the language.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#discussion_r422384928

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 May 2020 17:53:14 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#pullrequestreview-408802105

---

From: ekr <[email-masked]>
Date: Fri, 15 May 2020 13:26:31 -0700

@ekr approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#pullrequestreview-412945357

---

From: Martin Thomson <[email-masked]>
Date: Sun, 17 May 2020 16:56:38 -0700

Merged #3426 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3426#event-3345068266