Subject: [quicwg/base-drafts] Improve HTTP draft wording: frames carry identifier values (#3689)

From: Dmitri Tikhonov <[email-masked]>
Date: Fri, 22 May 2020 13:31:58 -0700

The endpoint sends frames, which *carry* -- not send -- identifier values.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3689

-- Commit Summary --

  * Improve HTTP draft wording: frames carry identifier values

-- File Changes --

    M draft-ietf-quic-http.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3689.patch
https://github.com/quicwg/base-drafts/pull/3689.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689

---

From: Mike Bishop <[email-masked]>
Date: Fri, 22 May 2020 13:48:15 -0700

The way it's intended to parse, "An endpoint ... MUST NOT increase the value they send," is probably incorrect in number or gender.  But yes, changing the verb to reflect that the subject is the frames instead of the endpoint is also an option.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-632903288

---

From: Dmitri Tikhonov <[email-masked]>
Date: Tue, 26 May 2020 07:42:45 -0700

OK.  I have no preference how this sentence is fixed -- as long as it's fixed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-634069186

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 08:19:06 -0700

@MikeBishop commented on this pull request.

Maybe, given the ambiguity, the right answer is to get rid of "they" in the first place?

> @@ -954,7 +954,7 @@ might have acted on.
 A client that is unable to retry requests loses all requests that are in flight
 when the server closes the connection.  An endpoint MAY send multiple GOAWAY
 frames indicating different identifiers, but MUST NOT increase the identifier

```suggestion
frames indicating different identifiers, but the identifier in each frame
```

> +value they carry, since clients might already have retried unprocessed requests
 on another connection.

```suggestion
MUST NOT be greater than the identifier in any previous frame, since clients
might already have retried unprocessed requests on another connection.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#pullrequestreview-419325576

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 May 2020 08:23:00 -0700

@dtikhonov pushed 1 commit.

ec59b1d50b6b947667aaedf4709269216496ace3  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689/files/c559ffd9bf727ae5a8c37cae44f0831086417f36..ec59b1d50b6b947667aaedf4709269216496ace3

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 May 2020 08:23:06 -0700

3541315cebf536990718f017beb83b4bd292587f  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689/files/ec59b1d50b6b947667aaedf4709269216496ace3..3541315cebf536990718f017beb83b4bd292587f

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 May 2020 08:25:46 -0700

This looks good.

While we are at this paragraph, why say "client?"  GOAWAY can be sent by either side now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-634738435

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 08:31:35 -0700

It can, but a server isn't going to retry push streams on a new connection; it's going to decide *de novo* whether to push there.  Arguably, nothing breaks if the client increases the Push ID on the server after the fact.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-634742791

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 08:32:52 -0700

BTW, thanks for catching this.  I appreciate how many of these ambiguities you're winkling out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-634743717

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 27 May 2020 08:45:31 -0700

@LPardue commented on this pull request.

> +frames indicating different identifiers, but the identifier in each frame
+MUST NOT be greater than the identifier in any previous frame, since clients
+might already have retried unprocessed requests on another connection.

I like the improvement but will highlight that this is an alternative way to present the described behaviour later on 

```
Like the server, the client MAY send subsequent GOAWAY
frames so long as the specified Push ID is strictly smaller than all previously
sent values.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#pullrequestreview-419358131

---

From: Dmitri Tikhonov <[email-masked]>
Date: Wed, 27 May 2020 09:34:06 -0700

@MikeBishop, @LPardue, OK, lgtm, then.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3689#issuecomment-634785711