Subject: [quicwg/base-drafts] Does a dynamic table entry insertion needs to be acknowledged for the enttry to become evictable? (#3624)

From: Dragana Damjanovic <[email-masked]>
Date: Mon, 04 May 2020 10:59:02 -0700

> Once the insertion of a
   dynamic table entry has been acknowledged and there are no
   outstanding unacknowledged references to the entry, the entry becomes
   evictable.

Does a entry really needs to acknowledged to become evictable? Inserts are happening on the same stream so it is not possible a entry is reference after being evicted. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3624

---

From: Dmitri Tikhonov <[email-masked]>
Date: Mon, 04 May 2020 13:00:19 -0700

Yes, this is necessary.  This is done to prevent unlimited speculative insertions, otherwise wrapped [Required Insert Count](https://tools.ietf.org/html/draft-ietf-quic-qpack-14#section-4.5.1.1) does not work.  See proposal in issue #1644.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3624#issuecomment-623674688

---

From: Dragana Damjanovic <[email-masked]>
Date: Mon, 04 May 2020 15:28:09 -0700

Closed #3624.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3624#event-3301962122

---

From: Dragana Damjanovic <[email-masked]>
Date: Mon, 04 May 2020 15:28:14 -0700

thanks

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3624#issuecomment-623741076