Subject: [quicwg/base-drafts] ECN probing needs to imply that you stop (#3669)

From: Martin Thomson <[email-masked]>
Date: Tue, 19 May 2020 15:41:30 -0700

The current text doesn&#39;t really suggest that the probes stop.

Closes #3585.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3669

-- Commit Summary --

  * ECN probing needs to imply that you stop

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3669.patch
https://github.com/quicwg/base-drafts/pull/3669.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 19 May 2020 16:24:52 -0700

@janaiyengar commented on this pull request.

> @@ -3733,9 +3733,9 @@ packets on a new path to a peer:
   lost {{QUIC-RECOVERY}}, validation is deemed to have failed.
 
 To reduce the chances of misinterpreting congestive loss as packets dropped by a
-faulty network element, an endpoint could set the ECT(0) codepoint in the first
-ten outgoing packets on a path, or for a period of three RTTs, whichever occurs
-first.
+faulty network element, an endpoint could set the ECT(0) codepoint only for the

```suggestion
faulty network element, an endpoint could set the ECT(0) codepoint for only the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669#pullrequestreview-414890437

---

From: Martin Thomson <[email-masked]>
Date: Tue, 19 May 2020 16:35:16 -0700

@martinthomson pushed 1 commit.

c93cddb90d413bdaddb6ea72f910bef3e3959223  >>

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669/files/d95b49f433108dd49e7f8ad492c6d3d8a4a3d744..c93cddb90d413bdaddb6ea72f910bef3e3959223

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 26 May 2020 05:03:10 -0700

@gloinul commented on this pull request.

Looks good to me. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669#pullrequestreview-418228913

---

From: ianswett <[email-masked]>
Date: Tue, 26 May 2020 05:08:52 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669#pullrequestreview-418232735

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 28 May 2020 22:59:48 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3669#pullrequestreview-420671626