Subject: [quicwg/base-drafts] New packet format used before it is defined (#3673)

From: David Schinazi <[email-masked]>
Date: Tue, 19 May 2020 19:00:05 -0700

#3573 introduced a new bespoke packet format. I don't have issues with the format itself, but as I reviewed [draft-ietf-quic-invariants-08](https://tools.ietf.org/html/draft-ietf-quic-invariants-08) I was surprised to see it used there without any explanation as to how to decipher it. I think it would be nicer if each document that uses this format either:
- References the "Notational Conventions" section from draft-ietf-quic-transport
- Has a "Notational Conventions" section of its own explaining this format

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3673

---

From: Martin Thomson <[email-masked]>
Date: Wed, 20 May 2020 17:32:15 -0700

> This document uses terms and notational conventions from [QUIC-TRANSPORT].
-- https://quicwg.org/base-drafts/draft-ietf-quic-invariants.html#section-2-2

There is a lot more that the document leans on than the packet format grammar, so any expansion of this might explode.  I tend to think that this is adequate.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3673#issuecomment-631808747

---

From: Mike Bishop <[email-masked]>
Date: Thu, 21 May 2020 11:38:11 -0700

I agree that the reference is sufficient, except for one aspect:  We do want the invariants drafts to be readable without needing to get into the v1 spec, because the target audience is people who need to handle QUIC without regard to versions.

I think it's wrong that the reference to QUIC-TRANSPORT is normative instead of informative, and this reference for conventions and definitions is the only reference in the doc that actually needs to be normative.  I'm almost be more inclined to move the notation definition across, just as we ultimately did for the definition of VN, and let -transport refer to -invariants for it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3673#issuecomment-632273639

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 May 2020 16:15:29 -0700

Closed #3673 via #3684.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3673#event-3375754072