Subject: Re: [quicwg/base-drafts] Core terminology in QPACK (#3520)

From: afrind <[email-masked]>
Date: Tue, 19 May 2020 16:22:06 -0700

@afrind pushed 1 commit.

ec2cf11792bdfa19d6b85d09f5e4cccd0c69924c  Merge branch 'master' into qpack/core_terminology

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3520/files/ef94156b855018d1e085832602872c0cb4445aee..ec2cf11792bdfa19d6b85d09f5e4cccd0c69924c

---

From: afrind <[email-masked]>
Date: Tue, 19 May 2020 16:55:52 -0700

@afrind commented on this pull request.

I think there are few places where we should be using 'encoded field section' rather than just field section.  I made a pass and will update shortly.  It's not perfect, since there are places where it just felt too redundant and field section alone was unambiguous.  I'm open to feedback though.

Also, I changed "Entry Acknowledgement" to "Section Acknowledgement", since that instruction acknowledges processing of an encoded field section, not an individual entry or representation.

> @@ -217,7 +235,7 @@ contains entries which cannot be evicted.
 A dynamic table entry cannot be evicted immediately after insertion, even if it
 has never been referenced. Once the insertion of a dynamic table entry has been
 acknowledged and there are no outstanding references to the entry in
-unacknowledged header blocks, the entry becomes evictable.  Note that
+unacknowledged representations, the entry becomes evictable.  Note that

representations are not acknowledged.   We lost the definition of "header block", and now use 'encoded field section' ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3520#pullrequestreview-414891747

---

From: afrind <[email-masked]>
Date: Tue, 19 May 2020 17:13:29 -0700

@afrind pushed 2 commits.

4dfe27c1c5fa99b25ab99a2b9b8ae0f6c38518b1  Rename Entry Acknowledgement to Section Acknowledgement
340df2025a5a3a9f768bbeeff283e95b352aa2af  Merge branch 'qpack/core_terminology' of https://github.com/quicwg/base-drafts into qpack/core_terminology

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3520/files/ec2cf11792bdfa19d6b85d09f5e4cccd0c69924c..340df2025a5a3a9f768bbeeff283e95b352aa2af

---

From: afrind <[email-masked]>
Date: Tue, 19 May 2020 17:16:05 -0700

Merged #3520 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3520#event-3354184634