Subject: [quicwg/base-drafts] rename SERVER_BUSY to CONNECTION_REFUSED (#3694)

From: Kazuho Oku <[email-masked]>
Date: Mon, 25 May 2020 11:35:00 -0700

Please see the discussion on #3690 for the rationale, but in short, SERVER_BUSY is renamed as CONNECTION_REFUSED. A server might refuse a connection for various reasons. SERVER_BUSY is one specific reason. Having an error code for that specific case while not having an error code for generic case is awkward. Hence the rename.

Closes #3690.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3694

-- Commit Summary --

  * rename SERVER_BUSY to CONNECTION_REFUSED

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3694.patch
https://github.com/quicwg/base-drafts/pull/3694.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 May 2020 15:44:12 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#pullrequestreview-418728590

---

From: ianswett <[email-masked]>
Date: Tue, 26 May 2020 15:45:32 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#pullrequestreview-418729114

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 26 May 2020 16:51:36 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#pullrequestreview-418753608

---

From: Martin Thomson <[email-masked]>
Date: Tue, 26 May 2020 18:28:12 -0700

Merged #3694 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#event-3376004655

---

From: Marten Seemann <[email-masked]>
Date: Tue, 26 May 2020 18:50:25 -0700

I'm not if this was an editorial PR. The previous text talked about a situation where a server was too busy to accept a new connection. The new text generalizes this to a connection refusal for any reason. That's a design change.

I also strongly disagree that this issue should close #3690. There's still on ongoing discussion if an additional error code should be introduced. I can't see how this is not a design issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#issuecomment-634377518

---

From: Mike Bishop <[email-masked]>
Date: Wed, 27 May 2020 13:11:21 -0700

There was previously no requirement to send this error code under any particular circumstances nor any requirement to take action upon receipt of this error code, and therefore those requirements cannot have been changed.  This modifies the prose around an error code the server could use to reject a connection attempt to make the recommendation more narrow.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3694#issuecomment-634913499