Subject: [quicwg/base-drafts] Limit sending by the anti-amplification factor (#3640)

From: ianswett <[email-masked]>
Date: Sun, 10 May 2020 13:07:33 -0700

Clarifies the impact of the anti-amplification factor on congestion control.

Fixes #3639
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3640

-- Commit Summary --

  * Limit sending by the anti-amplification factor

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3640.patch
https://github.com/quicwg/base-drafts/pull/3640.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 10 May 2020 13:33:22 -0700

@kazuho approved this pull request.

Thank you for the quick PR.

I've stated my slight preference, but the text looks already :+1: to me.

> @@ -752,6 +752,12 @@ twice the maximum datagram size. This follows the analysis and recommendations
 in {{?RFC6928}}, increasing the byte limit to account for the smaller 8 byte
 overhead of UDP compared to the 20 byte overhead for TCP.
 
+Prior to validating the client's address, the server can also be limited by

How about saying "can be limited further"? I think that might better clarify that it is a `min` of the two.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640#pullrequestreview-408779129

---

From: ianswett <[email-masked]>
Date: Sun, 10 May 2020 14:26:08 -0700

@ianswett commented on this pull request.

SGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640#discussion_r422702596

---

From: ianswett <[email-masked]>
Date: Sun, 10 May 2020 14:26:37 -0700

@ianswett pushed 1 commit.

c8fa3f8b1a97d520b177470fe2f57451c875c91c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640/files/010574ee63c0cc9af3ed84758e91e13beffe55bf..c8fa3f8b1a97d520b177470fe2f57451c875c91c

---

From: Martin Thomson <[email-masked]>
Date: Sun, 10 May 2020 16:18:33 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640#pullrequestreview-408791630

---

From: Marten Seemann <[email-masked]>
Date: Sun, 10 May 2020 23:08:43 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640#pullrequestreview-408882136

---

From: ianswett <[email-masked]>
Date: Wed, 13 May 2020 06:08:59 -0700

Merged #3640 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3640#event-3331984328