Subject: [quicwg/base-drafts] Clarify RESET_STREAM interaction with flow-control limits (#3782)

From: Jeremy Lainé <[email-masked]>
Date: Tue, 23 Jun 2020 00:37:47 -0700

When a `RESET_STREAM` is received, it carries a `final size` field. The specs do not describe the behaviour if the final size exceeds per-stream or connection-wide flow-control limits: should a `FLOW_CONTROL_ERROR` be triggered or a `FINAL_SIZE_ERROR`?

My preference would be `FLOW_CONTROL_ERROR` as this means the peer has transmitted too much data (presumably lost in flight prior to the reset).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3782

---

From: Martin Thomson <[email-masked]>
Date: Fri, 26 Jun 2020 00:08:14 -0700

I think that the [current text](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-4.1-7) is clear enough:

> A receiver MUST close the connection with a FLOW_CONTROL_ERROR error (Section 11) if the sender violates the advertised connection or stream data limits.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3782#issuecomment-650015973