Subject: [quicwg/base-drafts] QUIC Transport - sending after final size? (#3721)

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 04 Jun 2020 04:17:32 -0700

Section: Stream Final Size 
/An endpoint MUST NOT send data on a stream at or beyond the final size./
- It seems reasonable not to send after the Final Size , but why is this a “MUST NOT”?
The need to require this is not stated, and the reaction of the receiver appears to be ignore. Is this requirement justified?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3721

---

From: Mike Bishop <[email-masked]>
Date: Fri, 05 Jun 2020 08:07:33 -0700

Because the Final Size is used to synchronize flow control consumption.  If the Final Size is not, in fact, the last data ever sent on a stream, the two sides will disagree about how much flow control credit has been consumed.

The reaction of the receiver isn't to ignore; in the very next paragraph:

> A receiver SHOULD treat receipt of data at or beyond the final size as a FINAL_SIZE_ERROR error, even after a stream is closed. Generating these errors is not mandatory, but only because requiring that an endpoint generate these errors also means that the endpoint needs to maintain the final size state for closed streams, which could mean a significant state commitment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3721#issuecomment-639553291

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 08:27:19 -0700

Aha, I knew there must be a reason - could we add something like this sentence? "This is used to synchronize flow control consumption between the endpoints."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3721#issuecomment-639564348

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jun 2020 15:23:30 -0700

Closed #3721 via #3739.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3721#event-3427062678