Subject: [quicwg/base-drafts] Some more explanation on ECN validation to address issue #3733 (#3767)

From: mirjak <[email-masked]>
Date: Tue, 16 Jun 2020 06:08:07 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3767

-- Commit Summary --

  * Some more explanation on ECN validation to address issue #3733

-- File Changes --

    M draft-ietf-quic-transport.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3767.patch
https://github.com/quicwg/base-drafts/pull/3767.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3767

---

From: Martin Thomson <[email-masked]>
Date: Tue, 16 Jun 2020 16:07:45 -0700

@martinthomson commented on this pull request.

I don't think that this addresses the concerns in #3733.  It's not wrong, but I believe that the need to remember the marking on sent packets is already strongly implied.

> +use the following steps on receiving an ACK frame to validate ECN. In order to
+perform these checks, the endpoint has to remember the values of each ECN Count
+from the last ACK frame to calucate the increase since the last ACK.

This seems to repeat the above.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3767#pullrequestreview-431951387

---

From: mirjak <[email-masked]>
Date: Wed, 17 Jun 2020 01:42:05 -0700

@mirjak commented on this pull request.

No, this sentence is about remembering the ECN counts in the last ACK frame. The previous sentence was about remembering with marking a packet had when it was sent out.

I agree that all this was already implied and clear to me before but given #3733 I tried to make it explicit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3767#discussion_r441381144

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Jun 2020 15:48:36 -0700

Obviated by #3777.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3767#issuecomment-648467497

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Jun 2020 15:48:37 -0700

Closed #3767.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3767#event-3475092899