Subject: [quicwg/base-drafts] List all transport parameters in "Values of Transport Parameters for 0-RTT" section (#3755)

From: Nick Harper <[email-masked]>
Date: Wed, 10 Jun 2020 14:01:37 -0700

The "Values of Transport Parameters for 0-RTT" section lists some, but not all, of the transport parameters defined in the spec. As currently written, it is ambiguous whether a server needs to remember the parameters not listed. (A list of parameters that the client MUST NOT remember, and therefore the server need not remember, is provided, as well as a list that the server MUST remember so it doesn't lower limits.)

As far as I understand the definitions of the remaining parameters, there isn't any need for a server to remember them. However, instead of requiring implementors to read through all of the transport parameter definitions and infer this on their own, it would be easier on implementors to spell this out in this section. (This is required for definitions of new parameters.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3755

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 23 Jun 2020 16:08:48 -0700

Closed #3755 via #3756.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3755#event-3475134550