Subject: [quicwg/base-drafts] QUIC Transport: Reading NiTs - set 1 (#3720)

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 04 Jun 2020 04:15:54 -0700

The following NiTs are from a careful read of QUIC transport. I expect all are editorial and that the editors may be able to perform suitable changes to improve reading.

- to which
/deciding which streams to dedicate resources to/deciding the stream to which resources should be dedicated/

- that
/operations which an application MUST/operations that an application MUST/

- avoid sides … causes.. 
/because the opening of either send or receive sides causes the stream to open in both directions./because the opening of either the send or receive side causes the stream to be open in both directions./

- add /a/
/The sending part of stream/The sending part of a stream/

- Other sentences include /frame/
/is created when the first STREAM, STREAM_DATA_BLOCKED, or RESET_STREAM is received for that stream./is created when the first STREAM, STREAM_DATA_BLOCKED, or RESET_STREAM frame is received for that stream./

- This did not parse for me, is this better?
- /A sender MUST NOT send STREAM or STREAM_DATA_BLOCKED after sending a RESET_STREAM; that is, in the terminal states and in the "Reset Sent" state. /A sender MUST NOT send a STREAM or STREAM_DATA_BLOCKED frame that is in the terminal states and in the "Reset Sent" state (after sending a RESET_STREAM frame)./

- is this /can/MAY/  - because MUST is used for illegal frames?
/A receiver can send STOP_SENDING in any state /

- include word frame to be consistent with other text?
/STREAM frames received after sending STOP_SENDING are/STREAM frames received after sending a STOP_SENDING frame are/

- include word frame to be consistent with other text?
/can terminate one direction by sending a RESET_STREAM/can terminate one direction by sending a RESET_STREAM frame/

- /which/that/,  add /to be/
/method which will allow packets with that connection ID to be routed back to the endpoint and identified by the endpoint upon receipt/method that allows packets with that connection ID to be routed back to the endpoint and to be identified by the endpoint upon receipt/

- rate control?
/Servers MAY rate control these packets to avoid storms of Version Negotiation packets./
- perhaps /rate limit/ or /control the rate of/

The words appear to depend on the wrong previous sentence:
/Servers MAY rate control these packets to avoid storms of Version Negotiation packets. Otherwise, servers MUST drop packets that specify unsupported versions./
- appear to be an “otherwise” to rate control, but is this actually intended as an “otherwise” to “SHOULD send a Version Negotiation packet”?

-/which/that/, 
/There are certain operations which an application MUST/There are certain operations that an application MUST/

- or any number more permitted by initial cwnd and initial_max_stream_data_uni, the current text needs to not suggest this is unlimited!
/As a result, this handshake may consist of as few as 4 UDP datagrams, or any number more./

- are required to comply with implied …
/Endpoints are required to comply with the restrictions implied by these parameters;/
- change /implied/ to /defined/ or perhaps remove the word?

- is this the same, I wasn’t sure what the original ordering was?
/Implementations MUST support buffering at least 4096 bytes of data received in CRYPTO frames out of order. /Implementations MUST support buffering at least 4096 bytes of data received in out of order CRYPTO frames./ 

- awkward multiple use of /used/? perhaps:
/Address validation is used by QUIC to avoid being used for a traffic amplification attack./Address validation in QUIC avoids QUIC being used for a traffic amplification attack./

- I did not understand this, please add something to explain:
- /Sending padded datagrams ensures that the server is not overly constrained by the amplification restriction./

- please be careful about the layer at which s size is expressed.
/in a UDP datagram of at least 1200 bytes/
- Is this actually a UDP datagram or size 1200 or a payload of 1200B (as previously stated in the section) or something different?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3720

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jun 2020 15:14:39 -0700

Closed #3720 via #3742.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3720#event-3427040963