Subject: [quicwg/base-drafts] Gorrys invariant nits (#3730)

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 00:06:09 -0700

Editorial NiTs when reviewing the invariant text. These NiTs address readability issues, and do not intend to change the meaning of the text.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3730

-- Commit Summary --

  * Expand SCID/DCID
  * Add big endian to notation section
  * not specified -&gt; not encoded for DCID length
  * Make references to concepts clearer
  * Use transport endpoint
  * Remove the bit about rules and just list the assumption

-- File Changes --

    M draft-ietf-quic-invariants.md (44)
    M draft-ietf-quic-transport.md (56)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3730.patch
https://github.com/quicwg/base-drafts/pull/3730.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730

---

From: Lars Eggert <[email-masked]>
Date: Fri, 05 Jun 2020 00:08:05 -0700

Is there an associated issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730#issuecomment-639300144

---

From: ianswett <[email-masked]>
Date: Mon, 08 Jun 2020 17:43:20 -0700

@ianswett commented on this pull request.

Thanks for changing SCID/DCID to "Source Connection ID" and "Destination Connection ID", that seems like a good change.

> @@ -235,11 +240,11 @@ A connection ID is an opaque field of arbitrary length.
 
 The primary function of a connection ID is to ensure that changes in addressing
 at lower protocol layers (UDP, IP, and below) don't cause packets for a QUIC
-connection to be delivered to the wrong endpoint.  The connection ID is used by
-endpoints and the intermediaries that support them to ensure that each QUIC
-packet can be delivered to the correct instance of an endpoint.  At the
-endpoint, the connection ID is used to identify which QUIC connection the packet
-is intended for.
+connection to be delivered to the wrong transport endpoint.  The connection ID

What's a transport endpoint?  I don't recall us using that term elsewhere, so endpoint seems sufficient to me.  Or maybe we need another term for this case?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730#pullrequestreview-426713541

---

From: Martin Thomson <[email-masked]>
Date: Mon, 08 Jun 2020 18:46:49 -0700

@martinthomson commented on this pull request.

This was really trying to avoid having to pull in the definition of "endpoint" from the transport doc.  I see that I failed there.  Happy to take suggestions, like:

```suggestion
connection to be delivered to the wrong destination.  The connection ID
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730#discussion_r437091718

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 09 Jun 2020 01:06:19 -0700

@gorryfair commented on this pull request.

"destination" sounds like it could be network-layer?

The document uses "QUIC endpoint" elsewhere to refer to an endpoint at the transport layer, so that may perhaps be the term we are looking for?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730#discussion_r437214624

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jun 2020 02:19:43 -0700

@martinthomson pushed 1 commit.

8726e7094a9e2b70b77a5f33787c8260ce8ee5bf  Going with QUIC endpoint

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730/files/caaf168a6b18a4541c4d50c7a675054c0e1809e1..8726e7094a9e2b70b77a5f33787c8260ce8ee5bf

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 09 Jun 2020 15:28:34 -0700

Merged #3730 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3730#event-3427074952