Subject: [quicwg/base-drafts] Three ECN NiTS (#3734)

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 05:47:25 -0700

(1) NiT:
/The ECN counter for the ECN codepoint received in the associated IP header are incremented once for each QUIC packet, not per enclosing IP packet or UDP datagram./
- mixed singular and plural - is this /counters/?

(2) I like this phrase in the security considerations also from the point of view of how to generate transport feedback for ECT(?). Can we call this out here:
/QUIC endpoints ignore the ECN codepoint field on an IP packet unless at least one QUIC packet in that IP packet is successfully processed/

(3) General experiments are not permitted in RFC8311, only using experimental RFCs. I think therefore, we should be clear in the detail here:
/Implementations MAY experiment with and use other strategies for use of ECN. Other methods of probing paths for ECN support are possible, as are different marking strategies. Implementations can also use the ECT(1) codepoint, as specified in {{?RFC8311}}./
I’d propose something more like this:
/Other methods of probing paths for ECN support are possible, as are different marking strategies. Implementations MAY use other methods defined in RFCs, as specified in {{?RFC8311}}.  Implementations that use the ECT(1) codepoint, need to perform ECN validation using this code point./

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3734

---

From: Martin Thomson <[email-masked]>
Date: Tue, 09 Jun 2020 15:20:43 -0700

Closed #3734 via #3747.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3734#event-3427056164