Subject: [quicwg/base-drafts] Coalescing different CIDs for same connection (#3800)

From: Mike Bishop <[email-masked]>
Date: Tue, 30 Jun 2020 15:27:20 -0700

Section 12.2 makes two quasi-conflicting statements about coalesced packets.

> Senders MUST NOT coalesce QUIC packets for different connections into a single UDP datagram.

> Receivers SHOULD ignore any subsequent packets with a different Destination Connection ID than the first packet in the datagram.

In a connection where the sender has multiple CIDs in hand, using two different CIDs in the two coalesced packets is entirely consistent with the guidance to the sender, but would be dropped based on the guidance to the receiver.  We should align these two statements.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3800

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 17:00:37 -0700

Fixing this would require a change to normative language.

I'm of the opinion that the first should change to different connection IDs rather than connections; the second might change to a MUST NOT, but it could remain a SHOULD and achieve the same end.

The main reason for this is that routing will be based on the first packet.  But there is also a secondary benefit in not creating a strong correlation between different connection IDs for the same connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3800#issuecomment-652108798