Subject: [quicwg/base-drafts] Gorrys invariant nits (#3731)

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 00:15:19 -0700

Thanks Gorry, these are all quite helpful.

1) I understand the acronyms DCID and SCID, but these aren't really 
expanded on first use in sect 5.1. 

2) There's mention of "the high bit", but there doesn't seem to be any 
statement of bit order saying. Is it worth declaring network byte/bit 
order earlier in section 4? This also clarifies the placement of fields within a byte, which was basically assumed knowledge otherwise.

3) Personally, I don't think: "The length of the Destination Connection 
 ID is not specified" is a great choice of words. Surely, this needs to 
be specified somewhere for a protocol instance to use it?
This reads better as something like: The length of the Destination Connection ID is not encoded in packets with a short header and is not constrained by this specification.
 
4) The brackets here seem to point to connection IDs in general, not the  DCID "(see Section 5.3)". Is it worth writing that as "Connection IDs   are described in Section 5", rather than use brackets? The same is true for versions.

5) In section 5.3: "the wrong endpoint" is taken as the wrong transport 
endpoint, but some of our IP and subIP colleagues would use the term 
endpoint for other uses, so one insertion of "transport" would perhaps help?

6) In the appendix A, this: "QUIC forbids acknowledgments of packets" - 
still has me wondering what is actually intended to be understood, 
because the list of bullets is not guarenteed ... :

/The last packet before a long period of quiescence might be assumed 
to contain an acknowledgment (it should be assumed that QUIC could allow acknowledgments of packets that only contain ACK frames)/

I'm not sure what to say here I think the combination of not... forbids threw me off the meaning.

Changes proposed in  #3730

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3731

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 09 Jun 2020 15:28:34 -0700

Closed #3731 via #3730.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3731#event-3427074961