Subject: [quicwg/base-drafts] HTTP: provide guidance on PING usage (#3723)

From: Dmitri Tikhonov <[email-masked]>
Date: Thu, 04 Jun 2020 08:01:16 -0700

The transport Draft states:

> An application protocol SHOULD provide guidance about the conditions under which generating a PING is recommended.

This guidance was added to the HTTP Draft in #744, but was subsequently removed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3723

---

From: mirjak <[email-masked]>
Date: Fri, 05 Jun 2020 08:01:14 -0700

I guess that something to discuss in the applicability draft as well

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3723#issuecomment-639549679

---

From: Mike Bishop <[email-masked]>
Date: Fri, 05 Jun 2020 12:35:17 -0700

Looks like #2324 made this text more generic, leaving the specifics of how to keep a connection alive (e.g. with PING frames) to the transport implementation.  The text in question is now in Section 5.1:

> HTTP clients are expected to request that the transport keep connections open while there are responses outstanding for requests or server pushes, as described in Section 19.2 of [QUIC-TRANSPORT]. If the client is not expecting a response from the server, allowing an idle connection to time out is preferred over expending effort maintaining a connection that might not be needed. A gateway MAY maintain connections in anticipation of need rather than incur the latency cost of connection establishment to servers. Servers SHOULD NOT actively keep connections open.

It's possible the transport draft needs a similar generalization, to recommend implementations expose a way for the application layer to control whether an connection is idle.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3723#issuecomment-639747613

---

From: mirjak <[email-masked]>
Date: Mon, 08 Jun 2020 01:09:43 -0700

Actually there is a section on "Session resumption versus Keep-alive" in the applicability draft already. Do we need to say more? Is that needed in the transport draft as well?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3723#issuecomment-640441353

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 09 Jun 2020 15:44:45 -0700

Closed #3723 via #3745.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3723#event-3427110692