Subject: [quicwg/base-drafts] Version field <-> Version is not invariant (#3785)

From: Martin Thomson <[email-masked]>
Date: Tue, 23 Jun 2020 21:42:09 -0700

...it&#39;s just a Version field.

This is a subtle one, but it follows from the work that others have been
doing on greasing versions or providing additions to echconfig for QUIC
connection establishment.  It basically says that Version is for
endpoints, not middleboxes.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3785

-- Commit Summary --

  * Version field &lt;-&gt; Version is not invariant

-- File Changes --

    M draft-ietf-quic-invariants.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3785.patch
https://github.com/quicwg/base-drafts/pull/3785.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 25 Jun 2020 18:36:14 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785#pullrequestreview-437961990

---

From: David Schinazi <[email-masked]>
Date: Fri, 26 Jun 2020 14:19:37 -0700

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785#pullrequestreview-438601312

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 15:42:49 -0700

@martinthomson pushed 1 commit.

6b19c710bd1ea0df6553a314a2fc473f776b55f0  Version is for endpoints

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785/files/065a6bd49dc0ddc7a1fb6b7b8a2142834b0158af..6b19c710bd1ea0df6553a314a2fc473f776b55f0

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 30 Jun 2020 15:48:10 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785#pullrequestreview-440437186

---

From: ekr <[email-masked]>
Date: Tue, 30 Jun 2020 19:54:31 -0700

I like the idea here, but it seems like the distinction in the text is too subtle. Why not remove this entirely?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785#issuecomment-652156946

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 21:12:25 -0700

By "this", do you mean striking ~~This value can be used by endpoints to identify a QUIC Version.~~?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3785#issuecomment-652178137