Subject: [quicwg/base-drafts] Frame Types and Formats by transport requirements (#3737)

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 05:55:41 -0700

In Section Frame Types and Formats, there is a very useful summary of frame types by packet type. As a person with a CC and transport protocol interest, it would be really nice to have had a summary table of key properties that included whether each frame type is ack-eliciting;  whether transmission is controlled by flow-control; and whether transmission is controlled by congestion-control. Is there any chance we can add an extra column say to this table?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3737

---

From: Martin Thomson <[email-masked]>
Date: Mon, 08 Jun 2020 23:19:17 -0700

The problem with the table is that it is already essentially the full width available to us.  That makes the addition of more information quite difficult.

The rules for most of these are simple enough that I'm not sure that the table is the best way to present it.  That is:

ack-eliciting: all except ACK, PADDING
congestion-controlled: all except ACK
flow controlled: only STREAM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3737#issuecomment-641056863

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 09 Jun 2020 04:24:54 -0700

I wouldn't want to mess-up the table format to include the info. However, it would be really nice to have the info in a compact way close to the table somehow so that readers quickly confirm this. Would a note below the table possibly work, saying just this?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3737#issuecomment-641227192

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Jun 2020 21:22:37 -0700

Closed #3737 via #3776.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3737#event-3460891182