Subject: [quicwg/base-drafts] Draining after Idle Timeout? (#3798)

From: Mike Bishop <[email-masked]>
Date: Tue, 30 Jun 2020 15:10:37 -0700

10.2 says that after the idle timeout expires, "the connection is silently closed and its state is discarded."  However, 10.2.1 says that the peer "might enter its draining state."  Based on 10.2, I would not expect there to be a draining state; the connection is simply gone, and you would get a stateless reset.

Is the draining state used after the endpoints time out, or not?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3798

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 22:17:11 +0000 (UTC)

I need to find the issue, but we explicitly decided to not drain after idle timeout.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3798#issuecomment-652075379

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 15:18:50 -0700

#2347 resolved this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3798#issuecomment-652075958