Subject: [quicwg/base-drafts] Frames vs. Frame (#3804)

From: Mike Bishop <[email-masked]>
Date: Tue, 30 Jun 2020 16:28:16 -0700

In the Frame Types section (19.x), the types which span multiple IDs are identified as "STREAM Frames", "ACK Frames", and "CONNECTION_CLOSE Frames" while all other frame types are singular ("NEW_TOKEN Frame").  I initially thought it was just a typo, but it's consistently done for everything that has embedded flags.

Raising an editorial issue to double-check if we want to retain a convention that looks like an error on first glance.  If the editors say yes, feel free to close with no objection from me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804

---

From: Martin Thomson <[email-masked]>
Date: Tue, 30 Jun 2020 18:49:23 -0700

I made this change quite deliberately, but I'm happy to take input on why "Frame" is clearer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804#issuecomment-652138885