Subject: [quicwg/base-drafts] bundling and coalescing? (#3736)

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 05 Jun 2020 05:50:43 -0700

What does “bundling” refer to? I think I might now understand coalescing, but I don’t understand if bundling is subtly different?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3736

---

From: Mike Bishop <[email-masked]>
Date: Fri, 05 Jun 2020 09:14:58 -0700

Several instances I see in the draft refer to the situation where an endpoint is required to send a packet containing certain frames.  The endpoint might opportunistically add other frames, not mandated to be sent, as long as it's doing the work of generating and sending a packet anyway.  These opportunistically added frames are "bundled" with the mandatory frames.

More generally, the term refers to selecting a collection of frames waiting to be sent when generating an outgoing packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3736#issuecomment-639603621

---

From: Mike Bishop <[email-masked]>
Date: Fri, 05 Jun 2020 09:15:23 -0700

(Versus coalescing, which is putting more than one packet in a single UDP datagram.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3736#issuecomment-639603857

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 09 Jun 2020 08:01:15 +0000 (UTC)

Closed #3736 via #3740.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3736#event-3423561757