Subject: [quicwg/base-drafts] Frame special rules (#3776)

From: Martin Thomson <[email-masked]>
Date: Wed, 17 Jun 2020 18:53:19 -0700

After considering this a little more it seems helpful to bring some of the special handling rules up into the summary.  We don&#39;t really give up-front treatment of ack-eliciting, probing, and other important distinctions, so an extra column seemed useful.

A table of this size *just* fits in the text format.

Closes #3737.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3776

-- Commit Summary --

  * Add special handling column to frame summary
  * Condense the table to fit

-- File Changes --

    M draft-ietf-quic-transport.md (72)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3776.patch
https://github.com/quicwg/base-drafts/pull/3776.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776

---

From: Martin Thomson <[email-masked]>
Date: Wed, 17 Jun 2020 18:54:45 -0700

@martinthomson pushed 1 commit.

d0a2a233d076564eb1d82a6ae5a42c8499640587  More truncation of column names

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776/files/41b6fa24742f170be7cbd4d6d259a21fe1f371c9..d0a2a233d076564eb1d82a6ae5a42c8499640587

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Jun 2020 14:57:55 -0700

@janaiyengar commented on this pull request.

I like this a lot! I know there are just one frame type for C and F, but I have an editorial suggestion that just makes it more uniform and easier to read IMO.

> +: Packets containing only ACK frames do not count toward bytes in flight for
+  congestion control purposes; see {{QUIC-RECOVERY}}.

```suggestion
: Packets containing only frames with this marking do not count toward bytes
  in flight for congestion control purposes; see {{QUIC-RECOVERY}}.
```

> +characters:
+
+N:
+: Packets containing only frames with this marking are not ack-eliciting; see
+  {{generating-acks}}.
+
+C:
+: Packets containing only ACK frames do not count toward bytes in flight for
+  congestion control purposes; see {{QUIC-RECOVERY}}.
+
+P:
+: Packets containing only frames with this marking can be used to probe new
+  network paths during connection migration; see {{probing}}.
+
+F:
+: The content of the STREAM frame are flow controlled; see {{flow-control}}.

```suggestion
: The content of frames with this marking are flow controlled; see {{flow-control}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776#pullrequestreview-433672736

---

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Jun 2020 21:01:28 -0700

I had almost exactly those changes in a previous version.  It was a near thing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776#issuecomment-646422308

---

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Jun 2020 21:01:59 -0700

b418befdd1865d74e97de2ddb09a8f949f5dc71e  Keep definitions generic

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776/files/d0a2a233d076564eb1d82a6ae5a42c8499640587..b418befdd1865d74e97de2ddb09a8f949f5dc71e

---

From: Martin Thomson <[email-masked]>
Date: Thu, 18 Jun 2020 21:02:40 -0700

a79de3490b2971600abb96a20e68d664e58e0341  wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776/files/b418befdd1865d74e97de2ddb09a8f949f5dc71e..a79de3490b2971600abb96a20e68d664e58e0341

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Jun 2020 21:05:57 -0700

> +: Packets containing only frames with this marking are not ack-eliciting; see
+  {{generating-acks}}.
+
+C:
+: Packets containing only frames with this marking do not count toward bytes
+  in flight for congestion control purposes; see {{QUIC-RECOVERY}}.
+
+P:
+: Packets containing only frames with this marking can be used to probe new
+  network paths during connection migration; see {{probing}}.
+
+F:
+: The content of frames with this marking are flow controlled; see
+  {{flow-control}}.
+
+The "Pkts" and "Spec" columns in  {{frame-types}} does not form part of the IANA

```suggestion
The "Pkts" and "Spec" columns in  {{frame-types}} do not form part of the IANA
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776#pullrequestreview-433788782

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Jun 2020 21:06:07 -0700

@janaiyengar pushed 1 commit.

8bf7b6caca3b9819a5ddb8f6e9cca9b2e20ee675  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776/files/a79de3490b2971600abb96a20e68d664e58e0341..8bf7b6caca3b9819a5ddb8f6e9cca9b2e20ee675

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 18 Jun 2020 21:22:36 -0700

Merged #3776 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776#event-3460891180

---

From: Gorry Fairhurst <[email-masked]>
Date: Fri, 19 Jun 2020 03:35:06 -0700

That is super helpful, and is the direction I was hoping for!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3776#issuecomment-646564563