Subject: [quicwg/base-drafts] Frames of impermissible type (#3851)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 19:07:12 -0700

> An endpoint MUST treat the receipt of a frame of unknown type as a connection
error of type FRAME_ENCODING_ERROR.

What about a frame of an impermissible type for this key space?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3851

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 19:11:07 -0700

https://quicwg.org/base-drafts/draft-ietf-quic-tls.html#section-4-5

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3851#issuecomment-655237984

---

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 19:17:04 -0700

This seems to only apply to 0-RTT, but there are lots of frames which may not appear in Initial

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3851#issuecomment-655239722