Subject: [quicwg/base-drafts] Which DCID used to determine packet protection keys (#3840)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:27:14 -0700

When an Initial packet is sent by a client that has not previously received an
  Initial or Retry packet from the server, the client populates the Destination
  Connection ID field with an unpredictable value.  This Destination Connection ID
  MUST be at least 8 bytes in length.  Until a packet is received from the server,
  the client MUST use the same Destination Connection ID value on all packets in
  this connection. This Destination Connection ID is used to determine packet
  protection keys for Initial packets.

I had understood that you changed keys for the later initial packets when DCID changed. No?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3840

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 18:29:45 -0700

> I had understood that you changed keys for the later initial packets when DCID changed. No?

That is correct. I guess the confusion comes from the "This" in the last sentence. We should make clear which CID it is referring to.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3840#issuecomment-655226131

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 09:55:32 -0700

Depends why it changed.  Retry starts a new connection attempt, with a new DCID, and new Initial keys.  But the Initial keys don't change when the server's Initial provides a new SCID.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3840#issuecomment-656239399

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 15:06:31 -0700

Closed #3840 via #3862.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3840#event-3546106005