Subject: [quicwg/base-drafts] infinite loop of OnLossDetectionTimeout (#3967)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 18:40:14 -0700

`OnLossDetectionTimeout` in the recovery draft always calls `SetLossDetectionTimer`, resulting in an infinite loop which continues even after the connection is closed. It would be nice if conditions such as `if (connection is open):` are added or comments are added.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3967

---

From: Marten Seemann <[email-masked]>
Date: Tue, 28 Jul 2020 19:00:53 -0700

`SetLossDetectionTimer` cancels the timer when there are no ack-eliciting packets in flight, so I can't see how this would create an infinite loop. I'd prefer to not further complicate the pseudo-code here for this corner case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3967#issuecomment-665386314

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 19:29:53 -0700

@marten-seemann You are right. My interpretation and implementation was wrong. Thank you for pointing out.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3967#issuecomment-665394134

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 19:30:07 -0700

Closed #3967.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3967#event-3596990854