Subject: [quicwg/base-drafts] Packet protection or not? (#3887)

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 14:38:58 +0000 (UTC)

In Transport, we say:

> Invalid packets without packet protection, such as Initial, Retry, or Version Negotiation, MAY be discarded.

However, in TLS we have a section named "Packet Protection" (Section 5) with subsections describing how to protect Initial (5.2) and Retry (5.8) packets which talk about Initial, at least, as using packet protection.  I think it would be clearer to describe the lack of security properties that this limited form of protection provides, rather than say they're not protected at all.

Alternatively, we could rework the language in TLS, but that feels like a bigger terminology change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3887

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Jul 2020 17:23:54 -0700

ekr suggested that we limit the use of "integrity protection" (and I presume "confidentiality protection") to those cases where the protection is real, and not based on fixed keys or trivially-acquired keys.  I think that might be the best answer here, even if that takes more effort to get right.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3887#issuecomment-656414667

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 13 Jul 2020 22:20:21 -0700

@martinthomson : That sounds good like a good way forward.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3887#issuecomment-657972835