Subject: [quicwg/base-drafts] Acks for 0rtt only after Handshake Complete as in Quic-TLS 4.1.1 (#3914)

From: Christian Huitema <[email-masked]>
Date: Wed, 15 Jul 2020 20:55:02 -0700

Specify that when the spec says that a &quot;client only receives acknowledgments for its 0-RTT packets once the handshake
is complete&quot;, it means &quot;as defined in the Handshake Complete section of {{QUIC-TLS}}.&quot;.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3914

-- Commit Summary --

  * Merge pull request #14 from quicwg/master
  * Merge pull request #15 from quicwg/master
  * Merge pull request #16 from quicwg/master
  * Crossing the Ts for 0-RTT ACKs after Handshake Complete.

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3914.patch
https://github.com/quicwg/base-drafts/pull/3914.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914

---

From: Christian Huitema <[email-masked]>
Date: Wed, 15 Jul 2020 20:55:59 -0700

Close #3842 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914#issuecomment-659142683

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Jul 2020 21:00:19 -0700

@martinthomson approved this pull request.

We've generally used section numbers for this.

> @@ -4578,7 +4578,8 @@ likely to compromise the packet protection for all 0-RTT packets because the
 same key and nonce could be used to protect different content.
 
 A client only receives acknowledgments for its 0-RTT packets once the handshake
-is complete.  Consequently, a server might expect 0-RTT packets to start with a
+is complete, as defined in the Handshake Complete section of {{QUIC-TLS}}.

```suggestion
is complete, as defined Section 4.1.1 of {{QUIC-TLS}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914#pullrequestreview-449490711

---

From: Christian Huitema <[email-masked]>
Date: Wed, 15 Jul 2020 21:05:51 -0700

@huitema commented on this pull request.

That's what I first wrote, but I was worried about section renumbering if TLS draft is edited. Fine with me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914#discussion_r455497305

---

From: Christian Huitema <[email-masked]>
Date: Wed, 15 Jul 2020 21:06:01 -0700

@huitema pushed 1 commit.

15b725eb3c634b493203da526d188060b06f14d1  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914/files/300a588c46db1758d9dcd210f47e956f23f51fdb..15b725eb3c634b493203da526d188060b06f14d1

---

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 08:13:37 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3914#pullrequestreview-449948255