Subject: [quicwg/base-drafts] Starting persistent congestion on a ack-eliciting packet (#3941)

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jul 2020 05:13:38 -0700

Persistent congestion has to start with an ack-eliciting packet.  The section on persistent congestion isn't very clear about this point.

This is because a non-ack-eliciting packet won't be followed up with any probes.  It is therefore possible to send one packet and then not send anything else for an extended period.  After this, the loss of just the next packet will cause persistent congestion.

Note that persistent congestion can be caused by the loss of just two packets after multiple PTOs have occurred, but the common case is that you have at least three packet, or four if you send two packets on PTO.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3941

---

From: Marten Seemann <[email-masked]>
Date: Wed, 22 Jul 2020 05:30:37 -0700

> Note that persistent congestion can be caused by the loss of just two packets after multiple PTOs have occurred, but the common case is that you have at least three packet, or four if you send two…

Would it make sense to change the persistent congestion condition to require at least 3 packets to be lost, in addition to the time threshold that we already have?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3941#issuecomment-662425149

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 22 Jul 2020 06:36:46 -0700

> Would it make sense to change the persistent congestion condition to require at least 3 packets to be lost, in addition to the time threshold that we already have?

FWIW we have had some discussion around this in #3875, and it seemed to me that there were preference to *not* do that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3941#issuecomment-662457425

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jul 2020 17:46:45 -0700

I implemented this as requiring ack-eliciting on the basis that once you are two PTOs out, it's not that bad that you hit persistent congestion, but I wouldn't object to that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3941#issuecomment-662767605

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 23 Jul 2020 13:33:30 -0700

I can at least change this to ack-eliciting -- that's a simple editorial change. That was the intent anyway. If we want to change the way persistent congestion is established, that's a bigger issue, so let's separate that issue from this one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3941#issuecomment-663218223