Subject: Re: [quicwg/base-drafts] Versions are for endpoints (#3808)

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 05:53:11 -0700

There seems to be support for this issue and #3785, and the change is editorial.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-653534055

---

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 05:55:09 -0700

As an individual, I wonder if it would be worthwhile to add text to the draft that explicitly calls out that it is not safe for anybody other than the endpoints to assume knowledge about what protocol version an observed version number refers to. I think this it the implicit goal, making it explicit is IMO more direct.

(This could also be something for the ops-drafts to talk about though.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-653534851

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 03 Jul 2020 06:00:56 -0700

> There seems to be support for this issue and #3785, and the change is editorial.

@martinthomson relabelled the PR as design a few days ago, so it this potentially a design issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-653537111

---

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 06:08:34 -0700

Looking at the diff, I don't really see a need for labelling it design. @martinthomson, why the design label?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-653540392

---

From: Mike Bishop <[email-masked]>
Date: Fri, 03 Jul 2020 12:41:14 -0700

It's a subtle change, but it is a change in the design of the invariants.  It's saying that a packet marked version 0x13 isn't necessarily carrying a packet encoded in version 0x13, even if an observer speaks that version.  Previously, we made the assertion that the version field indicated what version was used in the packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-653661438

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 09 Jul 2020 07:53:53 -0700

Let's run this through the design issue process to be sure.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-656175866

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 23:55:03 -0700

So it seems we have a resolution in #3785. Labelling as such.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#issuecomment-661671977

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Jul 2020 06:15:06 -0700

Closed #3808 via #3785.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3808#event-3598989051