Subject: [quicwg/base-drafts] Editorial Fiexes for HTTP-QUIC (#3815)

From: Jxck <[email-masked]>
Date: Thu, 02 Jul 2020 05:39:19 -0700

> If a client stream terminates without enough of the HTTP message to provide a complete response, the server SHOULD abort its response with the error code H3_REQUEST_INCOMPLETE.

**client stream** should be clearly written as **client initiated stream**

> If the server sends a partial or complete response but does not **abort reading**, clients SHOULD continue sending the body of the request and close the stream normally.

the word which pair of **send response** is **receive request**, so its better to be **does not abort recieving request** here for clearify.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3815

---

From: Mike Bishop <[email-masked]>
Date: Thu, 02 Jul 2020 06:48:35 -0700

First one is good. The second one is intended to align with Section 2.4 of the transport draft, where "abort reading" is a defined operation on a stream; maybe "does not abort reading the request"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3815#issuecomment-653016442

---

From: Jxck <[email-masked]>
Date: Thu, 02 Jul 2020 13:58:07 +0000 (UTC)

@MikeBishop > "does not abort reading the request"
SGTM too

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3815#issuecomment-653021726

---

From: Mike Bishop <[email-masked]>
Date: Fri, 10 Jul 2020 13:11:30 -0700

Closed #3815 via e8eed6e6ab2de5c07c9bbb094478c71a525b162c.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3815#event-3535308127