Subject: [quicwg/base-drafts] Error for frames in the wrong packet (#3859)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 21:59:39 -0700

Closes #3851.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3859

-- Commit Summary --

  * Error for frames in the wrong packet

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3859.patch
https://github.com/quicwg/base-drafts/pull/3859.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3859

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 22:09:41 -0700

@marten-seemann commented on this pull request.

> @@ -3354,7 +3354,9 @@ ih:
   packets.
 
 Section 4 of {{QUIC-TLS}} provides more detail about these restrictions.  Note
-that all frames can appear in 1-RTT packets.
+that all frames can appear in 1-RTT packets.  An endpoint MUST treat receipt of
+a frame in a packet type that is not permitted as a connection error of type
+PROTOCOL_VIOLATION.

Would FRAME_ENCODING_ERROR be ok too?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3859#pullrequestreview-444416643

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 22:10:45 -0700

@martinthomson commented on this pull request.

   packets.

Interesting question.  It's not something that can be determined without context, so I would lean toward "no".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3859#discussion_r451286326

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 22:13:20 -0700

packets.

Depends on what your definition of "context" is. If it is "the bytes that this frame is composed of", then no. If you include the encryption level you received those bytes with, then "yes". You might want to do that, because the encryption level is not connection-level state.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3859#discussion_r451287053