Subject: [quicwg/base-drafts] Are 13.2.3 and 13.2.4 normative or not? (#3852)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 19:10:46 -0700

13.2.2. calls them "exemplary" but 13.2.4 has MUST in it. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 22:09:03 -0700

For reference, this refers to [Section 13.2.3](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-managing-ack-ranges) and [Section 13.2.5](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-limiting-ack-ranges) in the editor's copy.

I'm in favour of striking the exemplary note and saying that while the recovery draft is advisory, this document depends on implementations following something like what is recommended.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852#issuecomment-655288106

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 11:25:28 -0700

The specific MUSTs aren't really about the ACK algorithm per se, but about state endpoints will have to maintain for other reasons that are typically folded into your loss recovery code.

- If an implementation is unable to do duplicate detection for a packet number range, it MUST fail toward rejecting all packets, not toward accepting potential duplicates.
- An implementation must track the greatest packet number ever received, for use in recovering future packet numbers.

In fact, the first requirement is discussed in 12.3 and could probably be dropped here.  The second isn't actually called out (MUST) in 17.1, but could easily be moved there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852#issuecomment-656281329

---

From: ianswett <[email-masked]>
Date: Fri, 10 Jul 2020 11:40:44 -0700

I think I'm inclined towards reorganizing the text and putting all the 'exemplary' parts into one section(ie: "Limiting ACK Ranges") and moving the normative text either into "Managing ACK Ranges" or elsewhere in the draft.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852#issuecomment-656825261

---

From: ianswett <[email-masked]>
Date: Fri, 10 Jul 2020 11:50:31 -0700

I thought I could clean this up fairly quickly, but I think a fair number of paragraphs need to move, including some of @MikeBishop suggestions.  I'm happy to try to improve this in a few days if no one else has beaten me to it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852#issuecomment-656829601

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 05:32:28 -0700

Anyone want to help @ianswett out and take this on?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3852#issuecomment-660999793