Subject: [quicwg/base-drafts] pseudo code doesn't reflect the change introduced in #3911 (#3962)

From: Marten Seemann <[email-masked]>
Date: Mon, 27 Jul 2020 21:16:28 -0700

The pseudo code says the following:
```
if (no in-flight packets):
    assert(!PeerCompletedAddressValidation())
    if (has handshake keys):
      return (now() + duration), Handshake
    else:
      return (now() + duration), Initial
```

The spec says the following for the time from which the timer should be armed if there are no outstanding packets in the Handshake packet number space:
> the PTO timer is armed from the time that the Initial packet number space is discarded.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3962

---

From: ianswett <[email-masked]>
Date: Tue, 28 Jul 2020 06:08:56 -0700

This code is called from where Initial keys are discarded, so I believe it still matches the text, which only discusses the "(has handshake keys)" case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3962#issuecomment-665029205

---

From: ianswett <[email-masked]>
Date: Tue, 28 Jul 2020 06:23:19 -0700

That being said, it feels odd we mention one case of using now() and not the other, so I updated PR #3959

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3962#issuecomment-665037123

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 30 Jul 2020 13:41:31 -0700

Closed #3962 via #3959.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3962#event-3605713509