Subject: Re: [quicwg/base-drafts] New confidentiality and integrity limits (#3788)

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 05:50:15 -0700

There has been some discussion [on the list](https://mailarchive.ietf.org/arch/msg/quic/6ABngnMhcwvIQQQ-zYC_Ok-0NaM) and #3789 indicates that this would be a design change. Is there support for this issue and #3789?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3788#issuecomment-653532919

---

From: Christopher Wood <[email-masked]>
Date: Tue, 14 Jul 2020 06:05:53 -0700

For clarity, yes, this would be a design change. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3788#issuecomment-658167479

---

From: David Schinazi <[email-masked]>
Date: Wed, 15 Jul 2020 13:10:43 -0700

IANAC (disclaimer: I Am Not A Cryptographer)

>From my understanding of the issue, it seems that draft-29 does not provide the security guarantees it claims, when in the presence of a high number of received forged packets. In that instance, QUIC provides less security than TLS 1.3. I think that we should fix this issue in QUICv1, since we are chartered to produce a protocol that is at least as safe as TLS1.3.

PR #3789 seems like the right direction to me, especially if folks more knowledgeable in cryptography think it's correct.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3788#issuecomment-658983102

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 28 Jul 2020 11:42:15 -0700

There seems to be emerging consensus for the associated PR, so this has been marked as proposal-ready

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3788#issuecomment-665210628