Subject: [quicwg/base-drafts] Initial window bursts are too small (#3918)

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 12:19:20 -0700

@pravb argues that limiting bursts to IW is too small a limit in his WGLC comments here: https://mailarchive.ietf.org/arch/msg/quic/_KeDg0RMQqP5epdYQdFb0M7MJ5s/

Section 7.9

"Implementations MUST either use pacing or another method to limit such bursts to the initial congestion window; see Section 7.2."

This seems to preclude use of segmentation offload of sizes greater than IW. In datacenters we routinely send bursts that are higher without causing loss. The MUST here seems unnecessary. It also conflicts with the RECOMMENDED in an earlier sentence.

Neal Cardwell's suggestion:
"Implementations MUST either use pacing or another method to limit such bursts.
  It is RECOMMENDED that traffic over the public Internet limit bursts to the initial
  congestion window; see Section 7.2."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918

---

From: ianswett <[email-masked]>
Date: Fri, 17 Jul 2020 12:55:20 -0700

@pravb suggestion on the thread is to change the MUST to a SHOULD.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-660309336

---

From: ianswett <[email-masked]>
Date: Fri, 17 Jul 2020 12:59:09 -0700

There's also the classic "MUST unless" option.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-660310923

---

From: ianswett <[email-masked]>
Date: Fri, 17 Jul 2020 13:26:02 -0700

@LPardue I think this comment came in prior to WGLC ending, it just didn't get an issue because I'm so behind on email.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-660321967

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 17 Jul 2020 19:19:11 -0700

Yeah, this was filed in WGLC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-660408791

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 05:34:04 -0700

Is this not a duplicate of #3982?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-661001098

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 14:22:16 +0000 (UTC)

Yup, it's a duplicate of #3892 I missed that when filing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#issuecomment-661070809

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 07:22:16 -0700

Closed #3918.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3918#event-3566099038