Subject: [quicwg/base-drafts] incorrect error code used for invalid RETIRE_CONNECTION_ID frames (#3860)

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 22:01:24 -0700

> The sequence number specified in a RETIRE_CONNECTION_ID frame MUST NOT refer to the Destination Connection ID field of the packet in which the frame is contained. The peer MAY treat this as a connection error of type FRAME_ENCODING_ERROR.

Our principle regarding error codes states that only those errors that are detectable without accessing connection state should result in a FRAME_ENCODING_ERROR. Since the RETIRE_CONNECTION_ID frame contains only the sequence number of the connection ID, but not the actual connection ID itself, this should be a different error.
Looking through the list of error codes, it seems like we don't have any more specific error code here, so this would be a PROTOCOL_VIOLATION.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 22:09:49 -0700

Seems OK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#issuecomment-655288441

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 09 Jul 2020 08:05:51 -0700

As the proposed PR indicates, this would be a design change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#issuecomment-656182792

---

From: ianswett <[email-masked]>
Date: Fri, 10 Jul 2020 12:20:55 -0700

Agreed, this seems OK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#issuecomment-656849022

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 12 Jul 2020 18:56:20 -0700

As I noted in the PR, I agree that PROTOCOL_VIOLATION seems like a more appropriate error. In addition to @marten-seemann's point, this is a semantic error, not one of encoding (which suggests syntactic).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#issuecomment-657318469

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 23:52:35 -0700

It seems we have a proposed resolution, marking as such.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#issuecomment-661671035

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Jul 2020 06:14:08 -0700

Closed #3860 via #3861.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3860#event-3598984722