Subject: [quicwg/base-drafts] loss_detection_timer.update in recovery (#3969)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 18:59:38 -0700

When a client is downloading a large contents from a server, the server sends `STREAM` repeatedly and the client sends `ACK` repeatedly. In this situation, `time_of_last_ack_eliciting_packet` is not updated in the client side. So, `timeout - now()`in `loss_detection_timer.update` can be a non-positive timeout value.

It seems to me that it is unclear how `loss_detection_timer.update` should behave when timeout value is non-positive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969

---

From: Marten Seemann <[email-masked]>
Date: Tue, 28 Jul 2020 19:02:36 -0700

`SetLossDetectionTimer` only sets a timer when there are ack-eliciting packets in flight. This is not the case on the client side in the scenario you describe, so you wouldn't set a timer in the first place.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#issuecomment-665386785

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 19:30:52 -0700

The same as #3967. Let's close. Thanks.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#issuecomment-665394394

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 28 Jul 2020 19:30:52 -0700

Closed #3969.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#event-3596992809