Subject: [quicwg/base-drafts] How long is a validated address good for? (#3880)

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Jul 2020 22:55:22 -0700

There are a few cases where we don't have continuous validation of a peer address.  A long idle timeout might still be short enough that this isn't a concern.

1. A path migration that returns to a previously-used path might happen over a relatively long period of time.

2. NEW_TOKEN can be good for a considerable time.

Right now, the time limit is entirely undefined.  That might be the right answer, but maybe we should say that we don't know.

If we do think that a time limit makes sense, then we need to pick a value.  I wouldn't even dare to suggest a number right now.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 08 Jul 2020 23:20:50 -0700

I do not think that we need to recommend a particular value. I might even ask if there is a need to have a time-bound.

The reason we have the 3x limit prior to address validation is because it is an DDoS attack vector. Compared to that, it is much harder to use old validated paths as an attack vector. Compared to the difficulty, the benefit that the attacker gains is rather small.

For the NEW_TOKEN case, the amplifier is 10x + alpha (assuming that IW is 10 packets), less than a magnitude different from the 3x limit.

For the path migration case, the amplifier becomes maybe two magnitudes greater, but the effectiveness of the attack is limited by the idle timeout, as path migration works only when the connection is kept alive.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-655926117

---

From: ianswett <[email-masked]>
Date: Fri, 10 Jul 2020 14:24:17 -0700

I'd suggest we do nothing about this, since I don't have a good answer.

To quote Roberto: "A server's gonna do what a server's gonna do."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-656897690

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 14 Jul 2020 15:44:43 -0700

I'm not seeing support for this idea...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-658449337

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 14 Jul 2020 16:17:56 -0700

I think this nicely fits in the bucket of "Future Work" :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-658458761

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Jul 2020 23:59:32 -0700

This is a design issue, but only if we decide to do something.  Personally, I'm happy to defer this.  But this is not my issue; this was raised in a WGLC email from @gloinul.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-659200217

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 05:26:30 -0700

Proposed resolution is to close with no action, consensus to be confirmed

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-660995104

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 23:48:44 -0700

Labelling as such.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-661669439

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 27 Jul 2020 04:53:59 -0700

I am fine with for future consideration and that the WG has an understanding of the boundaries of potential impact. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#issuecomment-664351241

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Jul 2020 06:13:36 -0700

Closed #3880.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3880#event-3598982343