Subject: [quicwg/base-drafts] Clarify what should be sent on PTO (#3897)

From: ianswett <[email-masked]>
Date: Mon, 13 Jul 2020 09:07:49 -0700

I think this is clearer, but maybe there&#39;s a larger change people would like.

Fixes #3780
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3897

-- Commit Summary --

  * Clarify what should be sent on PTO

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3897.patch
https://github.com/quicwg/base-drafts/pull/3897.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 00:09:34 -0700

@martinthomson commented on this pull request.

> +When the PTO timer expires, new or previously sent unacknowledged data MUST
+be sent if available. A probe packet SHOULD carry new data when possible.
 A probe packet MAY carry retransmitted unacknowledged data when new data is
 unavailable, when flow control does not permit new data to be sent, or to
 opportunistically reduce loss recovery delay.  Implementations MAY use

```suggestion
When the PTO timer expires, an ack-eliciting packet MUST be sent.  An endpoint
SHOULD include new data in this packet.  Previously sent data MAY be sent if
no new data can be sent.  Implementations MAY use
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#pullrequestreview-447843391

---

From: Junho Choi <[email-masked]>
Date: Tue, 14 Jul 2020 00:24:56 -0700

@junhochoi commented on this pull request.

Thanks. I think this is more concise. Additionally,

"When the PTO timer ..." -> L625 says "When a PTO timer ..."
"an ack-eliciting packet MUST be sent" -> is it a duplicate of L625?
"An endpoint SHOULD include new data in this packet" -> "An endpoint SHOULD include new data in this packet if available"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#discussion_r454156309

---

From: Junho Choi <[email-masked]>
Date: Tue, 14 Jul 2020 00:28:53 -0700

Also, L649 (below this line, I can't comment on the line) says "sending new or retransmitted" -> "sending new or previously-sent"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#discussion_r454158399

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 00:39:55 -0700

Yeah the duplication with earlier is bad.

```suggestion
An endpoint SHOULD include new data in probe packets.  Data that was sent
previously MAY be sent again no new data can be sent.  Implementations MAY use
```

I think that using previously-sent and retransmitted is OK.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#discussion_r454164130

---

From: ianswett <[email-masked]>
Date: Tue, 14 Jul 2020 15:14:38 -0700

@ianswett pushed 1 commit.

741d1de572804a1f22cd706b173c4243f3420d05  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897/files/4eee107e5aa45810be4fdf7923c0256069cfd4f3..741d1de572804a1f22cd706b173c4243f3420d05

---

From: Junho Choi <[email-masked]>
Date: Tue, 14 Jul 2020 15:44:29 -0700

@junhochoi approved this pull request.

LGTM. Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#pullrequestreview-448515839

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 14 Jul 2020 16:04:23 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#pullrequestreview-448523677

---

From: ianswett <[email-masked]>
Date: Tue, 14 Jul 2020 16:05:15 -0700

2d9fc395c63de43565fe58ec5d6b991923c3b436  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897/files/741d1de572804a1f22cd706b173c4243f3420d05..2d9fc395c63de43565fe58ec5d6b991923c3b436

---

From: ianswett <[email-masked]>
Date: Tue, 14 Jul 2020 16:07:06 -0700

Merged #3897 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3897#event-3546239912