Subject: [quicwg/base-drafts] Simplify and use better example for persistent congestion (#3929)

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 14:12:43 -0700

Makes the period computation a bit clearer.

Closes #3923. 
Also addresses @pravb&#39;s comment in #3919.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3929

-- Commit Summary --

  * Better example of persistent congestion
  * use PTO

-- File Changes --

    M draft-ietf-quic-recovery.md (54)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3929.patch
https://github.com/quicwg/base-drafts/pull/3929.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 14:17:11 -0700

@janaiyengar pushed 1 commit.

6d16cc98ecc8caaa02896d5eca57b2552c9af33b  write out

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929/files/2780f26cc63a9d5143abc08731cadcabadf37e27..6d16cc98ecc8caaa02896d5eca57b2552c9af33b

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 14:18:04 -0700

cb5635178e68203d1ce58044a77db2a1805a8a7a  capitalize

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929/files/6d16cc98ecc8caaa02896d5eca57b2552c9af33b..cb5635178e68203d1ce58044a77db2a1805a8a7a

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Jul 2020 15:06:02 -0700

@martinthomson approved this pull request.

PTO = 1.5 is odd, and this is hardly simpler, but it is good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#pullrequestreview-452862915

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 21 Jul 2020 17:50:27 -0700

@pravb commented on this pull request.

> +| t=3   | Send packet #4 (app data)  |
+| t=4   | Send packet #5 (app data)  |
+| t=5   | Send packet #6 (app data)  |
+| t=6.5 | Send packet #7 (PTO 1)     |
+| t=9.5 | Send packet #8 (PTO 2)     |
+| t=9.7 | Recv acknowledgement of #8 |
+
+Packets 2 through 7 are declared lost when the acknowledgement for packet 8 is
+received at t = 9.7.
+
+The congestion period is calculated as the time between the oldest and newest
+lost packets: 6.5 - 1 = 5.5.  The duration for establishing persistent
+congestion is: 1.5 * 3 = 4.5.  Because the threshold was reached and because
+none of the packets between the oldest and the newest lost packets were
+acknowledged, the network is considered to have experienced persistent
+congestion.

I think we should still add a line here about PTO not being necessary for establishing persistent congestion since the example still uses PTO.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#pullrequestreview-452923097

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Jul 2020 17:51:14 -0700

@martinthomson commented on this pull request.

There is a change in Jana's other PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#discussion_r458470500

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 21 Jul 2020 17:51:26 -0700

@pravb approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#pullrequestreview-452923389

---

From: Praveen Balasubramanian <[email-masked]>
Date: Tue, 21 Jul 2020 19:00:01 -0700

Looks like there is some confusion on Slack about the case where disjoint sets of packets are lost. Do we need two examples rather than one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#issuecomment-662197474

---

From: Marten Seemann <[email-masked]>
Date: Tue, 21 Jul 2020 20:11:28 -0700

@pravb This confusion now has its own issue: #3937.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#issuecomment-662216308

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 22 Jul 2020 00:58:59 -0700

@kazuho commented on this pull request.

>  ~~~
 
-For example, assume:
+where PTO is computed as described in {{computing-pto}}.

If we are to (re)use PTO in the equation, I think it would be better to clarify that max_ack_delay should be used regardless of the packet number space for which a loss is newly observed.

That's what we do in the existing text, and IMO that aligns with the fact that persistent congestion is a connection-wide event that happens across all the packet number spaces.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#pullrequestreview-453081351

---

From: Martin Thomson <[email-masked]>
Date: Wed, 22 Jul 2020 19:11:10 -0700

-For example, assume:

That's a good point, and not an obvious one.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#discussion_r459180362

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Jul 2020 19:26:38 -0700

bae4459886c4cfb0cb58af9268f78a64b4a38bdc  kazuho's and martin's comments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929/files/cb5635178e68203d1ce58044a77db2a1805a8a7a..bae4459886c4cfb0cb58af9268f78a64b4a38bdc

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Jul 2020 19:27:57 -0700

@janaiyengar commented on this pull request.

-For example, assume:

That's a really good point. I've brought back the expanded expression, since it is perhaps less confusing, and I've added a sentence to point out this difference as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#discussion_r461279565

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Jul 2020 19:31:58 -0700

f5b7fc54911f5708f30df45f1a25a641a73fee0e  lint

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929/files/bae4459886c4cfb0cb58af9268f78a64b4a38bdc..f5b7fc54911f5708f30df45f1a25a641a73fee0e

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Jul 2020 19:43:50 -0700

Merged #3929 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#event-3592367398

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 27 Jul 2020 19:43:53 -0700

I'm going to merge this. Happy to fix any more editorial issues separately.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#issuecomment-664742970

---

From: ianswett <[email-masked]>
Date: Tue, 28 Jul 2020 07:37:04 -0700

@ianswett commented on this pull request.

Thanks Jana, this is a nice improvement.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3929#pullrequestreview-456700142