Subject: Re: [quicwg/base-drafts] Source for 15-30 second timeout on middleboxes? (#3799)

From: Lars Eggert <[email-masked]>
Date: Wed, 01 Jul 2020 06:05:39 -0700

Maybe see https://tools.ietf.org/html/bcp145#section-3.5

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3799#issuecomment-652406150

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 01 Jul 2020 11:04:26 -0700

Closed #3799 via #3806.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3799#event-3503615077

---

From: Martin Thomson <[email-masked]>
Date: Wed, 01 Jul 2020 18:12:07 -0700

I'm going to say that while the 15s floor is a good requirement, I don't want to cite RFC 8085 for this gem, which I think is straight-up misinformation: "NATs require a state timeout of 2 minutes or longer [RFC4787]."  We do cite RFC 8085 elsewhere and that's fine, but the fact here is that the IETF has requested that NATs provide a state timeout of 2 minutes.  That does not mean that they do.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3799#issuecomment-652721960

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 01 Jul 2020 19:24:31 -0700

I have seen anecdata as well that showing 30 seconds is an important threshold. I think the ref we now have is good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3799#issuecomment-652741460