Subject: [quicwg/base-drafts] Invariants definition of Unused in Version Negotiation packet (#3827)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 06 Jul 2020 01:33:15 -0700

For -09 in WG LC.

Section 6 has a packet header structure with the field:

Unused (7)

All the other fields are either fixed value or kind of defined earlier. In fact I would argue they represent concepts that are defined in -transport. Thus a second part of this is if -transport needs to be normative reference for the concepts used in this document. 

But back to Unused: I think this field can take any value on transmission, and should be ignored on reception. Maybe this needs to be noted explicitly in Section 6. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3827

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 07:15:29 -0700

It's very deliberate that Invariants does not normatively depend on Transport.  Invariants needs to stand alone, as a description of what versionless QUIC means.  Arguably, Transport could normatively depend on Invariants, but it chooses instead to restate the things it depends on and make the reference informative.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3827#issuecomment-656153539

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Jul 2020 23:42:34 -0700

Closed #3827 via #3829.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3827#event-3542703894