Subject: [quicwg/base-drafts] Magnus wglc (#3881)

From: Martin Thomson <[email-masked]>
Date: Wed, 08 Jul 2020 23:27:40 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3881

-- Commit Summary --

  * Multiple transitions happen
  * The receiver might close the connection
  * Contextualize remembering of transport parameters
  * Acknowledgments aren&#39;t path validation
  * Frames are at least 8 bits long
  * Cite common field definitions
  * Unused is set arbitrarily, and ignored on receipt
  * Contact: the IETF
  * EOFU: PMTU
  * Reword requirements about path validation

-- File Changes --

    M draft-ietf-quic-transport.md (100)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3881.patch
https://github.com/quicwg/base-drafts/pull/3881.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 09 Jul 2020 01:31:04 -0700

@gloinul commented on this pull request.

> @@ -4446,9 +4460,10 @@ Initial Packet {
 {: #initial-format title="Initial Packet"}
 
 The Initial packet contains a long header as well as the Length and Packet
-Number fields.  The first byte contains the Reserved and Packet Number Length
-bits.  Between the Source Connection ID and Length fields, there are two
-additional fields specific to the Initial packet.
+Number fields; see {{long-header}}.  The first byte contains the Reserved and

This text needs to be replicated to the 0-RTT and Handshake packet also. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881#pullrequestreview-445399959

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Jul 2020 02:13:39 -0700

@martinthomson pushed 1 commit.

879c1c027f4556795abc2ce7cc288db9ea0e40e4  Cite long-header in other sections too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881/files/dd62291b41acc47aeb4ec8fbdc592ed2736cfe09..879c1c027f4556795abc2ce7cc288db9ea0e40e4

---

From: ianswett <[email-masked]>
Date: Mon, 13 Jul 2020 12:02:56 -0700

@ianswett approved this pull request.

> @@ -2084,10 +2095,11 @@ receive packets without first having sent a packet on that path. Effective NAT
 traversal needs additional synchronization mechanisms that are not provided
 here.
 
-An endpoint MAY bundle PATH_CHALLENGE and PATH_RESPONSE frames that are used for
-path validation with other frames.  In particular, an endpoint may pad a packet
-carrying a PATH_CHALLENGE for PMTU discovery, or an endpoint may bundle a
-PATH_RESPONSE with its own PATH_CHALLENGE.
+An endpoint MAY bundle PATH_CHALLENGE and PATH_RESPONSE frames that are used
+for path validation with other frames.  In particular, an endpoint may pad a
+packet carrying a PATH_CHALLENGE for Path Maximum Transfer Unit (PMTU)

Is it worth adding a reference to the PMTU section here?

>  validation until after a peer sends the next non-probing frame to its new
 address.
 
+Path validation is necessary verify reachability of a peer on a new network

```suggestion
Path validation is necessary to verify reachability of a peer on a new network
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881#pullrequestreview-447498825

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Jul 2020 18:39:19 -0700

17fd3911ab80a7fc914dd1e1831c01c377bc9bb6  Ian's review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881/files/879c1c027f4556795abc2ce7cc288db9ea0e40e4..17fd3911ab80a7fc914dd1e1831c01c377bc9bb6

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 15:57:01 -0700

285d80f54b5221efcfd937d7b47364cf5f7bbeb5  Merge branch 'master' into magnus-wglc

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881/files/17fd3911ab80a7fc914dd1e1831c01c377bc9bb6..285d80f54b5221efcfd937d7b47364cf5f7bbeb5

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 15:58:33 -0700

Merged #3881 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3881#event-3546222823