Subject: [quicwg/base-drafts] Require only support for PSK-(EC)DHE (#3839)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:24:33 -0700

S 7. Claims

      * 1-RTT keys have forward secrecy

This is only true if you only resume with PSK-(EC)DHE, but I don't see a requirement for this. So we need to either require this or change the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3839

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 23:07:31 -0700

This obsession with forward secrecy is a hang-up from Google QUIC.  I think that we should instead say that 1-RTT keys are derived from the completed cryptographic handshake instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3839#issuecomment-655307665

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Jul 2020 16:58:47 -0700

Closed #3839 via #3866.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3839#event-3537549070