Subject: [quicwg/base-drafts] Unifying words in recovery draft (#3893)

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 20:02:51 -0700

This should resolve some parts of #3813.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3893

-- Commit Summary --

  * using max_ack_delay instead of MaxAckDelay.
  * using in-flight.
  * using towards instead of toward.
  * using &quot;a client&quot; because of &quot;a server&quot;
  * using DetectAndRemoveAckedPackets instead of undefined DetectNewlyAckedPackets
  * fixing strange &quot;for&quot;.

-- File Changes --

    M draft-ietf-quic-recovery.md (46)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3893.patch
https://github.com/quicwg/base-drafts/pull/3893.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893

---

From: Marten Seemann <[email-masked]>
Date: Sun, 12 Jul 2020 20:22:27 -0700

@marten-seemann requested changes on this pull request.

Unfortunately, this PR bundles a bunch of unrelated changes. Some of them I like, some of them I don't.

> @@ -518,7 +518,7 @@ or when Initial or Handshake keys are discarded. This ensures the PTO is always
 set based on the latest RTT information and for the last sent packet in the
 correct packet number space.
 
-When ack-eliciting packets in multiple packet number spaces are in flight,
+When ack-eliciting packets in multiple packet number spaces are in-flight,

I think "in flight" is more correct here.

> @@ -615,7 +615,7 @@ a packet containing unacknowledged CRYPTO data earlier than the PTO expiry,
 subject to address validation limits; see Section 8.1 of {{QUIC-TRANSPORT}}.
 
 Peers can also use coalesced packets to ensure that each datagram elicits at
-least one acknowledgement.  For example, clients can coalesce an Initial packet
+least one acknowledgement.  For example, a client can coalesce an Initial packet

The previous sentence uses a plural. Why change one but not the other?

> @@ -657,7 +657,7 @@ send, the sender SHOULD send a PING or other ack-eliciting frame in a single
 packet, re-arming the PTO timer.
 
 Alternatively, instead of sending an ack-eliciting packet, the sender MAY mark
-any packets still in flight as lost.  Doing so avoids sending an additional
+any packets still in-flight as lost.  Doing so avoids sending an additional

Again here, I think "in flight" reads better.

> @@ -697,7 +697,7 @@ When packet protection keys are discarded (see Section 4.10 of {{QUIC-TLS}}),
 all packets that were sent with those keys can no longer be acknowledged because
 their acknowledgements cannot be processed anymore. The sender MUST discard
 all recovery state associated with those packets and MUST remove them from
-the count of bytes in flight.
+the count of bytes in-flight.

Same here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#pullrequestreview-446958217

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 20:25:42 -0700

@marten-seemann If you wish, I will split this PR into small ones.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#issuecomment-657338359

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 20:28:18 -0700

@kazu-yamamoto commented on this pull request.

I might be too strict but "in flight" is not defined anywhere. When I looked into stuff relating to "in-flight", I actually had to search both "in-flight" and "in flight". It was inconvenience.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#discussion_r453415854

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 20:30:23 -0700

This is followed by "a server". Why are both singular and plural used in the same sentence?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#discussion_r453416287

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Jul 2020 20:35:04 -0700

@martinthomson commented on this pull request.

This is a quirk in English.  The hyphen is only used when "in-flight" is a modifier for some other term, like "in-flight packets".  https://en.wikipedia.org/wiki/English_compound#Hyphenated_compound_modifiers

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#discussion_r453417239

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 21:49:43 -0700

I have dropped the commit of "in flight".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#issuecomment-657356123

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 22:04:53 -0700

@kazu-yamamoto pushed 1 commit.

61b41c13d251c12d85629668c58bfedb2ebe8330  using // instead of #.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893/files/c52266184642a4271f3db0b3a30cc8e3471447e9..61b41c13d251c12d85629668c58bfedb2ebe8330

---

From: Kazu Yamamoto <[email-masked]>
Date: Sun, 12 Jul 2020 22:05:42 -0700

I also changed `#` into `//`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#issuecomment-657360386

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Jul 2020 23:34:00 -0700

@martinthomson approved this pull request.

I think that "toward" is acceptable usage, otherwise, this is good.

```suggestion
Endpoints can also use coalesced packets to ensure that each datagram elicits at
```

>    congestion control limits and are considered in-flight.
 
-* PADDING frames cause packets to contribute toward bytes in flight without
+* PADDING frames cause packets to contribute towards bytes in flight without

```suggestion
* PADDING frames cause packets to contribute toward bytes in flight without
```

> @@ -145,10 +145,10 @@ of frames contained in a packet affect recovery and congestion control logic:
   performance of the QUIC handshake and use shorter timers for
   acknowledgement.
 
-* Packets containing frames besides ACK or CONNECTION_CLOSE frames count toward
+* Packets containing frames besides ACK or CONNECTION_CLOSE frames count towards

I think that the original is correct.

```suggestion
* Packets containing frames besides ACK or CONNECTION_CLOSE frames count toward
```

I think that "a client" and "a server" are best here.  The previous sentence is general, this is an example and therefore specific.

That said, we are almost certainly hugely inconsistent about addressing requirements to "endpoints" (plural) or "an endpoint" (singular).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#pullrequestreview-447822856

---

From: Kazu Yamamoto <[email-masked]>
Date: Mon, 13 Jul 2020 23:58:41 -0700

803780504baae3d301e07ebd0027b0528f56cdd4  Peers -> Endopoints

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893/files/61b41c13d251c12d85629668c58bfedb2ebe8330..803780504baae3d301e07ebd0027b0528f56cdd4

---

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 14 Jul 2020 00:02:14 -0700

@martinthomson The commit for "towards" has been dropped.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#issuecomment-658007989

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 00:04:09 -0700

Thanks.  BTW, that [toward/towards](https://www.grammarly.com/blog/toward-towards/) thing is an another odd English quirk.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#issuecomment-658008805

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 16:00:17 -0700

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#pullrequestreview-448522114

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 14 Jul 2020 16:13:17 -0700

@janaiyengar approved this pull request.

Thanks for the PR, @kazu-yamamoto !

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#pullrequestreview-448527004

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 14 Jul 2020 16:13:33 -0700

Merged #3893 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3893#event-3546252475