Subject: [quicwg/base-drafts] MUST requirement on bursts smaller than IW is too restrictive (#3892)

From: Praveen Balasubramanian <[email-masked]>
Date: Sun, 12 Jul 2020 09:56:14 -0700

"Implementations MUST either use pacing or another method to limit such bursts to the initial congestion window; see Section 7.2."  

This precludes use of segmentation offload of sizes greater than IW. Hardware does not pace TSO for TCP or USO for UDP. In datacenters we routinely send bursts that are higher without causing loss. Both Linux and Windows TCP send bursts larger than IW (up to 64k) at higher bandwidths. Higher bursts are required for achieving high data rates. 

This text should be changed to a SHOULD. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 12 Jul 2020 17:25:20 -0700

@pravb: DC requirements are likely to run into more than just this problem -- for instance, the initial window itself might be too small. Since the recovery document was really meant for Internet use, not for DC, I would suggest leaving out DC requirements. Perhaps there's a separate document in order for how to tune QUIC for DC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-657299611

---

From: Lucas Pardue <[email-masked]>
Date: Sun, 12 Jul 2020 17:42:39 -0700

As an individual, I agree with Jana. We're not going to be able to ship a specification that is able to accommodate all of the spectrum of network characteristics. The documents should allow implementers to build a QUIC implementation that is safe to deploy on the Internet.

As someone less familiar with DCTCP and more general DC considerations, the nuance of making a MUST a SHOULD is likely to be lost on me. A document that takes a more broad look as QUIC in the DC would be super helpful.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-657302677

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 05:24:43 -0700

Also being discussed [on the mailing list](https://mailarchive.ietf.org/arch/msg/quic/DYjeywiWYuWPF3iTX9_T3R3sI-s)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-660994254

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 16:40:30 -0700

Based on the discussion on the mailing list, I'm proposing that we change the MUST to a SHOULD. See #3936.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-662160702

---

From: Lars Eggert <[email-masked]>
Date: Tue, 21 Jul 2020 22:30:34 -0700

Do folks agree with this proposed resolution?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-662249995

---

From: ianswett <[email-masked]>
Date: Sat, 25 Jul 2020 12:52:58 -0700

@larseggert I think it's the right direction, but I'd like to do some more work on the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3892#issuecomment-663894436