Subject: Re: [quicwg/base-drafts] Improve Large Server Certificate Scenario (#3784)

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 05:46:53 -0700

Is the resolution here what @janaiyengar suggests above, i.e., an editorial addition to -tls
> that to realize QUIC's promise, cert compression is necessary. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3784#issuecomment-653531571

---

From: Lucas Pardue <[email-masked]>
Date: Fri, 03 Jul 2020 05:58:49 -0700

That seems overspecific based on one datapoint and one resolution. A different take on this is to make the observation that within the mechanisms described for QUIC, increasing certificate size can reduce the chances of achieving minimal-possible round-trips. Implementations can use methods to minimize the size of certificates such as ECDSA or compression.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3784#issuecomment-653536276

---

From: Lars Eggert <[email-masked]>
Date: Fri, 03 Jul 2020 06:01:02 -0700

Fair point. But it looks like an editorial change saying "moar handshake data = bad" is what would address the issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3784#issuecomment-653537170

---

From: Martin Thomson <[email-masked]>
Date: Sun, 05 Jul 2020 18:25:45 -0700

That seems like a good summary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3784#issuecomment-653970397

---

From: Martin Thomson <[email-masked]>
Date: Sun, 12 Jul 2020 16:58:32 -0700

Closed #3784 via #3825.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3784#event-3537548869