Subject: Re: [quicwg/base-drafts] Frames vs. Frame (#3804)

From: Jana Iyengar <[email-masked]>
Date: Wed, 01 Jul 2020 22:27:57 -0700

I suggest that we use the singular, since these sections are definitions of these frame types.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804#issuecomment-652790896

---

From: Mike Bishop <[email-masked]>
Date: Thu, 02 Jul 2020 07:07:31 -0700

Two reasons.  The first is simply consistency -- something technically correct that still looks like an error might not be worth defending.  The second is the question of whether there are in fact multiple types versus a single type with flags.

I can see the alternate view, that there are two different ACK frames and the section describes those two frame types.  The same is true for CONNECTION_CLOSE, where there are two types with different implications. Both of these *were* two distinct frame types in previous drafts.

For me, that view breaks down with STREAM, unless you want to say there are eight types of STREAM frame and the section describes all eight.  The section describes a single STREAM frame with flags embedded in the type byte.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804#issuecomment-653026999

---

From: Lucas Pardue <[email-masked]>
Date: Thu, 02 Jul 2020 07:21:44 -0700

I've seen implementations handle it both ways: one struct with a type, and many structs.

My suggestion would be to define a `Frameset` term, then it is editorially pleasant to say something like 

``` 
   The MAX_STREAMS frameset (type=0x12 and 0x13) informs the peer of the
   cumulative number of streams of a given type it is permitted to open.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804#issuecomment-653034972

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Jul 2020 22:00:08 -0700

I'm ambivalent on "frame" vs. "frames" here, but I will oppose any attempt to add to the cognitive load on readers.  New terms are out for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3804#issuecomment-653348062