Subject: [quicwg/base-drafts] Reorder 10.1 and 10.X (#3843)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:36:26 -0700

I understand why you might want to cover closing and draining states before covering the types of close, but I think it would actually be clearer pedagogically to cover the types of close and point to closing and draining states, putting that later.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3843

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 22:56:57 -0700

I agree with this, but it will require some updates to other drafts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3843#issuecomment-655303896

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 11:36:40 -0700

Given that closing/draining states *only* occur after immediate close, it might make more sense to move 10.1 to be 10.[3->2].2

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3843#issuecomment-656286418

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 11:45:41 -0700

Actually, poking at it a bit, that works -- but a lot of the content in current-10.1 duplicates content in current-10.3.  Rather than merely moving the text to be a sub-section, we should probably try to condense it a bit; either move all the close/drain requirements into the new subsection, or fold the two sections together.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3843#issuecomment-656290476

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Jul 2020 21:15:44 -0700

Closed #3843 via #3865.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3843#event-3551278040