Subject: [quicwg/base-drafts] change error to PROTOCOL_VIOLATION when receiving an invalid RCID frame (#3861)

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 22:04:26 -0700

Fixes #3860.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3861

-- Commit Summary --

  * change error to PROTOCOL_VIOLATION when receiving an invalid RCID frame

-- File Changes --

    M draft-ietf-quic-transport.md (2)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3861.patch
https://github.com/quicwg/base-drafts/pull/3861.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 11:14:33 -0700

This seems like another instance of deciding the scope of "context."  Is the packet that the frame arrived in part of the connection context, or is it part of looking at the bytes?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#issuecomment-656276323

---

From: Marten Seemann <[email-masked]>
Date: Thu, 09 Jul 2020 18:33:48 -0700

@MikeBishop Even if the packet header is part of the context, that still doesn't help. The RETIRE_CONNECTION_ID frame only carries the sequence number, not the actual connection ID. You have to access connection-level information to detect this error, which makes the FRAME_ENCODING_ERROR a poor choice here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#issuecomment-656431951

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 09 Jul 2020 18:38:26 -0700

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#pullrequestreview-446070005

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 09 Jul 2020 18:40:05 -0700

+1 to what @marten-seemann says. In addition this is a "MAY send" error, therefore I do not think we need to be cautious in trying to list all the possible error codes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#issuecomment-656433572

---

From: ianswett <[email-masked]>
Date: Fri, 10 Jul 2020 08:25:10 -0700

@ianswett approved this pull request.

This seems like a more correct error, but I also don't have strong opinions about it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#pullrequestreview-446492246

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 12 Jul 2020 18:55:36 -0700

@janaiyengar approved this pull request.

I agree that this seems like a more appropriate error. In addition to @marten-seemann 's point, I will not that this is a semantic error, not one of encoding (which suggests syntactic).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#pullrequestreview-446939158

---

From: Eric Kinnear <[email-masked]>
Date: Sun, 12 Jul 2020 19:55:36 -0700

@ekinnear approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#pullrequestreview-446952476

---

From: Mike Bishop <[email-masked]>
Date: Mon, 13 Jul 2020 11:47:54 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#pullrequestreview-447510508

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Jul 2020 06:14:08 -0700

Merged #3861 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3861#event-3598984717