Subject: [quicwg/base-drafts] Clarify how to represent the packet number if no ACKs have been received (#3915)

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 08:13:05 -0700

I noticed the 0-RTT specific text in #3914 and thought a general clarification would be better.

Conveniently, I don&#39;t think anyone has gotten this wrong in their implementation.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3915

-- Commit Summary --

  * Clarify how to represent the packet number if no ACKs have been received

-- File Changes --

    M draft-ietf-quic-transport.md (9)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3915.patch
https://github.com/quicwg/base-drafts/pull/3915.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915

---

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 08:28:34 -0700

@ianswett pushed 1 commit.

b029ae61e52c7d7beb1bc751ed0843d5095d4490  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915/files/35b28e13aa41ebc53b3e053a8b52868bfb81a8e8..b029ae61e52c7d7beb1bc751ed0843d5095d4490

---

From: Martin Thomson <[email-masked]>
Date: Sun, 19 Jul 2020 16:28:10 -0700

@martinthomson approved this pull request.

> +Prior to any acknowledgements being received for a packet number space, there is
+no largest acknowledge packet, so the full packet number is encoded in the
+header.
+

I think that we need to move this paragraph up one.  And it might instead say:

> Prior to receiving an acknowledgement for a packet number space, the full packet number MUST be included.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915#pullrequestreview-451172713

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 09:39:29 -0700

f009224fcd784f2e5ea88bdb11dcdb4adfb0badd  Martin's suggestion

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915/files/b029ae61e52c7d7beb1bc751ed0843d5095d4490..f009224fcd784f2e5ea88bdb11dcdb4adfb0badd

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 20 Jul 2020 20:06:59 -0700

@janaiyengar pushed 1 commit.

e25d48bd6227bf2f0616da85f317c341441977ad  fix lint

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915/files/f009224fcd784f2e5ea88bdb11dcdb4adfb0badd..e25d48bd6227bf2f0616da85f317c341441977ad

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 20 Jul 2020 20:07:04 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915#pullrequestreview-452094330

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Jul 2020 23:53:31 -0700

Merged #3915 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915#event-3569514801

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Jul 2020 23:53:41 -0700

Thanks Ian, this is much clearer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3915#issuecomment-661671468