Subject: [quicwg/base-drafts] Tickets/tokens MUST NOT carry application semantics, but carry settings (#3817)

From: Mike Bishop <[email-masked]>
Date: Thu, 02 Jul 2020 12:24:45 -0700

There seems to be a conflict between this assertion in Section 9.2:

> TLS session tickets and address validation tokens are used to carry QUIC configuration information between connections.  These MUST NOT be used to carry application semantics.

...and the fact that 4.8 explicitly discusses how application protocols might need to have data embedded in the session ticket.  (Also, QUIC doesn't use TLS address validation tokens.)  I think this is actually trying to say that receipt of the session ticket MUST NOT cause side-effect beyond setting up the connection, but it's a broader prohibition than that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3817

---

From: Martin Thomson <[email-masked]>
Date: Thu, 02 Jul 2020 22:09:18 -0700

I think that it says something else, namely that these are not intended to convey semantic information from client to server (or vice versa).  PR inbound.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3817#issuecomment-653351374

---

From: Martin Thomson <[email-masked]>
Date: Mon, 13 Jul 2020 18:54:53 -0700

Closed #3817 via #3820.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3817#event-3542091120