Subject: [quicwg/base-drafts] Integrity protection (#3849)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:59:50 -0700

Should we perhaps not use integrity in S 12.1 when we are talking about null keys?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3849

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 21:56:01 -0700

I don't follow.  Assuming that you are talking about [the same Section 12.1](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-protected-packets) then I don't see any reference to null keys.  Are you suggesting that we say something like:

>  Initial protection only exists to ensure that the sender of the packet is on the network path.  The integrity protection provided for Initial and Retry packets guards against accidental modification of packets that might not be caught by the UDP checksum.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3849#issuecomment-655283500

---

From: ekr <[email-masked]>
Date: Wed, 08 Jul 2020 12:29:39 +0000 (UTC)

What I'm saying is that we should probably reserve the word "integrity" for when there are strong keys.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3849#issuecomment-655488802