Subject: [quicwg/base-drafts] May use 64+bit CIDs as address validation (#3924)

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 07:38:19 -0700

I&#39;m not sure this changes anything in practice, since the client can&#39;t rely on it and the server could already do this, but explicitly saying it seems preferable.

Fixes #3834
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3924

-- Commit Summary --

  * May use 64+bit CIDs as address validation

-- File Changes --

    M draft-ietf-quic-transport.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3924.patch
https://github.com/quicwg/base-drafts/pull/3924.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924

---

From: Marten Seemann <[email-masked]>
Date: Mon, 20 Jul 2020 16:37:53 +0000 (UTC)

@marten-seemann commented on this pull request.

> @@ -1876,7 +1876,9 @@ Connection establishment implicitly provides address validation for both
 endpoints.  In particular, receipt of a packet protected with Handshake keys
 confirms that the client received the Initial packet from the server.  Once the
 server has successfully processed a Handshake packet from the client, it can
-consider the client address to have been validated.
+consider the client address to have been validated.  Servers MAY treat the
+receipt of a server generated destination connection ID with at least 64 bits

```suggestion
receipt of a packet using a server generated destination connection ID with at least 64 bits
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#pullrequestreview-451775742

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 09:50:41 -0700

@ianswett pushed 1 commit.

918e823125d0111b7ab1c62268d2a8df880f1178  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924/files/13cfae81cd06270203423bbf93d6ce294dbc676e..918e823125d0111b7ab1c62268d2a8df880f1178

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 10:33:56 -0700

c2d50c6f103af8f66f2985f4d82861772b37fc99  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924/files/918e823125d0111b7ab1c62268d2a8df880f1178..c2d50c6f103af8f66f2985f4d82861772b37fc99

---

From: David Schinazi <[email-masked]>
Date: Mon, 20 Jul 2020 12:37:04 -0700

@DavidSchinazi approved this pull request.

I think this is a useful improvement.

+receipt of a packet using a server generated destination connection ID with

nit: s/server generated/server-generated/

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#pullrequestreview-451901278

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 14:03:10 -0700

@ianswett commented on this pull request.

SGTM, for the future, suggestions are faster for me to commit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#discussion_r457690058

---

From: ianswett <[email-masked]>
Date: Mon, 20 Jul 2020 14:27:50 -0700

7590ad3639cfb3cabd918498cad2ee93d90d25fa  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924/files/c2d50c6f103af8f66f2985f4d82861772b37fc99..7590ad3639cfb3cabd918498cad2ee93d90d25fa

---

From: ekr <[email-masked]>
Date: Mon, 20 Jul 2020 17:21:40 -0700

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#issuecomment-661480704

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 20 Jul 2020 17:57:09 -0700

@kazuho approved this pull request.

LGTM. My weak preference goes to adding a word or a phrase that indicates that this is an alternative to the strategy being described in the previous sentence (like below).

```suggestion
consider the client address to have been validated.  Servers MAY also treat the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#pullrequestreview-452054181

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 20 Jul 2020 19:39:26 -0700

@janaiyengar commented on this pull request.

> +consider the client address to have been validated.  Servers MAY treat the
+receipt of a packet using a server-generated destination connection ID with
+at least 64 bits of entropy as address validation.

```suggestion
consider the client address to have been validated.

Additionally, if a server sends a packet carrying a Source Connection
ID field that has at least 64 bits of entropy to a client address,
and if the server subsequently receives a packet from the client
carrying this server-generated connection ID in its Destination
Connection ID field, the server MAY consider the address to be
validated.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#pullrequestreview-452086280

---

From: Martin Thomson <[email-masked]>
Date: Mon, 20 Jul 2020 23:50:25 -0700

@martinthomson commented on this pull request.

Longest sentence ever.  Though I agree with having a new paragraph for this separate concept.

> A server MAY consider the client address to be valid if the client uses a connection ID chosen by the server and the connection ID contains at least 64 bits of entropy.

BTW, it is not necessary that the connection ID be provided by the server in Source Connection ID, it's just overwhelmingly likely.  (In an extreme case, involving very specific sorts of loss, this could use a connection ID provided in NEW_CONNECTION_ID; preferred_address is also unlikely but marginally more likely.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#discussion_r457874256

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 11:58:27 -0700

Good points, both. I like your sentence better, but I'd propose "Additionally" or "also", as Kazuho proposes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#discussion_r458320276

---

From: ianswett <[email-masked]>
Date: Tue, 21 Jul 2020 12:06:16 -0700

6874d0047957ab40acba32937cc915fb2fb47a8a  Updates from MT, Jana and Kazuho's suggestions

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924/files/7590ad3639cfb3cabd918498cad2ee93d90d25fa..6874d0047957ab40acba32937cc915fb2fb47a8a

---

From: ianswett <[email-masked]>
Date: Tue, 21 Jul 2020 12:06:51 -0700

SG, I tried to update taking into account all your comments/suggestions

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#discussion_r458324957

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 21 Jul 2020 12:21:55 -0700

@janaiyengar approved this pull request.

Thanks, @ianswett !

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#pullrequestreview-452759852

---

From: Martin Thomson <[email-masked]>
Date: Wed, 29 Jul 2020 06:17:11 -0700

Merged #3924 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3924#event-3598998302