Subject: [quicwg/base-drafts] Split minimum idle timeout period (#3847)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 18:51:34 -0700

The text as written implied that the actual timeout period was
calculated using:

```
min(max_idle_timeout[client],
    max_idle_timeout[server],
    3 * PTO)
```
This is silly, as 3PTO is usually smaller than the other two values, and
connections would time out too fast.

Splitting the text regarding the 3PTO backstop makes this clearer.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3847

-- Commit Summary --

  * Split minimum idle timeout period

-- File Changes --

    M draft-ietf-quic-transport.md (7)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3847.patch
https://github.com/quicwg/base-drafts/pull/3847.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847

---

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:52:54 -0700

@ekr commented on this pull request.

> @@ -2682,6 +2681,10 @@ ack-eliciting packet if no other ack-eliciting packets have been sent since last
 receiving and processing a packet. Restarting this timer when sending a packet
 ensures that connections are not closed after new activity is initiated.
 
+There is no minimum value for max_idle_timeout.  To avoid excessively small idle

This is like a major nitpick, but isn't the minimum value actually 1ms, because 0 means no timeout?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#pullrequestreview-444359904

---

From: Marten Seemann <[email-masked]>
Date: Tue, 07 Jul 2020 18:53:48 -0700

Wasn't the intended meaning
```
min(max_idle_timeout[client] + 3*PTO,
    max_idle_timeout[server] + 3*PTO)
 ```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#issuecomment-655232961

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 19:01:20 -0700

I can only speak about my intent, but I did not intend to always add 3PTO to the timeout.  The text was clearly more confused than I thought.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#issuecomment-655235122

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 19:19:59 -0700

@martinthomson pushed 1 commit.

d44f3c87218775820808aa5c6357298d7b0753ed  Remove the justification (too hard)

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847/files/9d55480335f0988bc4ca0ba4a793e50cb4011b19..d44f3c87218775820808aa5c6357298d7b0753ed

---

From: ianswett <[email-masked]>
Date: Mon, 13 Jul 2020 13:00:33 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#pullrequestreview-447558518

---

From: ianswett <[email-masked]>
Date: Mon, 13 Jul 2020 13:01:02 -0700

I actually wasn't sure what you meant before, but this is what I assumed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#issuecomment-657761777

---

From: Martin Thomson <[email-masked]>
Date: Tue, 14 Jul 2020 00:18:26 -0700

Merged #3847 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3847#event-3542812797