Subject: [quicwg/base-drafts] which -> that where appropriate & related nit fixes (#3964)

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Jul 2020 23:25:41 -0700

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3964

-- Commit Summary --

  * which -&gt; that where appropriate &amp; related nit fixes

-- File Changes --

    M draft-ietf-quic-http.md (79)
    M draft-ietf-quic-invariants.md (2)
    M draft-ietf-quic-qpack.md (44)
    M draft-ietf-quic-tls.md (20)
    M draft-ietf-quic-transport.md (46)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3964.patch
https://github.com/quicwg/base-drafts/pull/3964.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Jul 2020 23:32:57 -0700

@martinthomson approved this pull request.

Lars will include this PR as part of his job application for the RPC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-456337816

---

From: Martin Thomson <[email-masked]>
Date: Mon, 27 Jul 2020 23:34:03 -0700

@martinthomson commented on this pull request.

> @@ -1175,8 +1175,7 @@ H3_NO_ERROR or a reserved error code ({{http-error-codes}}) SHOULD be used.
 
 HTTP frames are carried on QUIC streams, as described in {{stream-mapping}}.
 HTTP/3 defines three stream types: control stream, request stream, and push
-stream. This section describes HTTP/3 frame formats and the streams types on
-which they are permitted; see {{stream-frame-mapping}} for an overview.  A
+stream. This section describes HTTP/3 frame formats and their permitted stream types; see {{stream-frame-mapping}} for an overview.  A

```suggestion
stream. This section describes HTTP/3 frame formats and their permitted stream
types; see {{stream-frame-mapping}} for an overview.  A
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-456338276

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Jul 2020 23:40:05 -0700

@larseggert pushed 1 commit.

3ae2a88ef7627d48ed7dae68a96489632b0f6301  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964/files/ae6715ab12a27087bc27976f1416c5d03e928228..3ae2a88ef7627d48ed7dae68a96489632b0f6301

---

From: Lars Eggert <[email-masked]>
Date: Mon, 27 Jul 2020 23:41:06 -0700

> Lars will include this PR as part of his job application for the RPC.

They would need to let me add several zeroes to Heather's salary...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#issuecomment-664809398

---

From: afrind <[email-masked]>
Date: Tue, 28 Jul 2020 11:22:39 -0700

@afrind approved this pull request.

QPACK changes look ok, with a minor comment

> @@ -1153,7 +1153,7 @@ represented as a 4-bit prefix string literal, then the value, represented as an
 
 #  Configuration
 
-QPACK defines two settings which are included in the HTTP/3 SETTINGS frame.
+QPACK defines two settings that are included in the HTTP/3 SETTINGS frame:

Seems a bit strange, since it seems to imply that these SETTINGS are always present.

Would this be better:

"QPACK defines two settings for the HTTP/3 SETTINGS frame" ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-456894120

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 28 Jul 2020 13:05:37 -0700

@janaiyengar approved this pull request.

Thanks, @larseggert!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-456969167

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 28 Jul 2020 13:06:16 -0700

>Lars will include this PR as part of his job application for the RPC.

This PR can be his entire application.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#issuecomment-665252018

---

From: Lars Eggert <[email-masked]>
Date: Tue, 28 Jul 2020 22:49:26 -0700

@larseggert pushed 5 commits.

92b25a11d37ad2b86082763b5e07a08ec2af6c93  Fix spelling and style consistency nits
203377ea35d22d5fdc226ce424fabe019e8ba1e9  Emphasize still talking about sending (#3934)
d9368bd94f4e7c638617239793ff2b7db05849c6  which -> that where appropriate & related nit fixes
7c4acb7c19474b355b170c9dc70512938f81065d  Incorporate @afrind's suggestion
4113a20edc3c8b549cd124477e75a49c6603245f  Merge branch 'which-that' of github.com:larseggert/base-drafts into which-that

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964/files/3ae2a88ef7627d48ed7dae68a96489632b0f6301..4113a20edc3c8b549cd124477e75a49c6603245f

---

From: Lars Eggert <[email-masked]>
Date: Tue, 28 Jul 2020 22:57:02 -0700

@larseggert pushed 0 commits.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964/files/4113a20edc3c8b549cd124477e75a49c6603245f..7c4acb7c19474b355b170c9dc70512938f81065d

---

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Jul 2020 14:02:20 -0700

@MikeBishop commented on this pull request.

> @@ -1176,8 +1176,7 @@ either the H3_NO_ERROR error code or a reserved error code

Can you rewrap this?  The build will break if I merge it with this long line.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-457894708

---

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Jul 2020 14:08:24 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#pullrequestreview-457898698

---

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Jul 2020 14:11:06 -0700

@MikeBishop pushed 1 commit.

e907711312e7c36c85346910d0dbec4f6ee8d211  Wrap

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964/files/7c4acb7c19474b355b170c9dc70512938f81065d..e907711312e7c36c85346910d0dbec4f6ee8d211

---

From: Mike Bishop <[email-masked]>
Date: Wed, 29 Jul 2020 14:11:16 -0700

N/m, I did it directly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#discussion_r462591394

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 29 Jul 2020 16:01:59 -0700

Merged #3964 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3964#event-3601260550