Subject: [quicwg/base-drafts] Clearer explanation of caveat on discarding packets (#3869)

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 23:19:52 -0700

Those packets that are not authenticated can be discarded, but only if
processing them has no permanent effect on existing state.  This
attempts to explain that.

Closes #3836.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3869

-- Commit Summary --

  * Clearer explanation of caveat on discarding packets

-- File Changes --

    M draft-ietf-quic-transport.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3869.patch
https://github.com/quicwg/base-drafts/pull/3869.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869

---

From: ekr <[email-masked]>
Date: Wed, 08 Jul 2020 05:36:31 -0700

@ekr approved this pull request.

LGTM

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869#pullrequestreview-444719685

---

From: Marten Seemann <[email-masked]>
Date: Wed, 08 Jul 2020 05:52:07 -0700

@marten-seemann approved this pull request.

> @@ -1167,7 +1167,8 @@ expected keys are available.
 
 Invalid packets without packet protection, such as Initial, Retry, or Version
 Negotiation, MAY be discarded.  An endpoint MUST generate a connection error if
-it commits changes to state before discovering an error.
+processing of the contents of these packets prior to discovering an error
+results in changes to the state of a connection that cannot be reverted.

s/results/resulted?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869#pullrequestreview-444731758

---

From: Mike Bishop <[email-masked]>
Date: Thu, 09 Jul 2020 09:41:48 -0700

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869#pullrequestreview-445789990

---

From: ianswett <[email-masked]>
Date: Thu, 09 Jul 2020 15:46:23 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869#pullrequestreview-446017650

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Jul 2020 18:00:54 -0700

@martinthomson pushed 1 commit.

88e5ca8f65e61cae07c4bc029854190fe9124e9c  resulted, I guess

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869/files/73c4da7ff17069db4374888aafab5c239d250634..88e5ca8f65e61cae07c4bc029854190fe9124e9c

---

From: Martin Thomson <[email-masked]>
Date: Thu, 09 Jul 2020 18:01:02 -0700

Merged #3869 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3869#event-3531963810