Subject: [quicwg/base-drafts] Current time PTO clarification (#3911)

From: ianswett <[email-masked]>
Date: Wed, 15 Jul 2020 14:13:18 -0700

This is a rephrase of @martinthomson  suggestion.

Fixes #3908
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3911

-- Commit Summary --

  * Current time PTO clarification

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3911.patch
https://github.com/quicwg/base-drafts/pull/3911.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3911

---

From: Martin Thomson <[email-masked]>
Date: Wed, 15 Jul 2020 20:58:28 -0700

@martinthomson approved this pull request.

This is good, but I wouldn't talk about "current time" at all.

> +ack-eliciting Handshake packets.  In this case, when the Initial packet number
+space is discarded, the PTO is set from the current time.

I would have said instead that:

```suggestion
ack-eliciting Handshake packets.  In this case, the PTO timer starts at the
time that the Initial packet number space is discarded.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3911#pullrequestreview-449490149

---

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 13:50:08 +0000 (UTC)

@ianswett pushed 1 commit.

a5cc128e346c5d5ac0111a8a192fdc682ba4a3dd  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3911/files/6bfa25a4eda6b4efe52fb802940b0efb04d15f99..a5cc128e346c5d5ac0111a8a192fdc682ba4a3dd

---

From: ianswett <[email-masked]>
Date: Thu, 16 Jul 2020 06:51:20 -0700

58f73149cd0bc83afa499877ac092635a541a44c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3911/files/a5cc128e346c5d5ac0111a8a192fdc682ba4a3dd..58f73149cd0bc83afa499877ac092635a541a44c

---

From: ianswett <[email-masked]>
Date: Mon, 27 Jul 2020 09:13:45 -0700

Merged #3911 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3911#event-3590604694