Subject: [quicwg/base-drafts] Remove API requirement for resource allocation (#3838)

From: ekr <[email-masked]>
Date: Tue, 07 Jul 2020 18:20:37 -0700

S 5.4 requires that the application be able to

  - control resource allocation of various types, including flow control and the
  number of permitted streams of each type;

This seems like a good idea, but it seems like one could have a reasonable QUIC stack that did not do this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3838

---

From: Martin Thomson <[email-masked]>
Date: Tue, 07 Jul 2020 23:06:23 -0700

I would prefer to leave this.  Noting that the level of control is not specified.

This also suggests that the stack provide a keep-alive control, but there are likely cases (I'm thinking here of DNS over QUIC) where that is unlikely to be a useful feature.

The goal is to list things that the specification believes a generic stack will provide.  Maybe we could avoid the implication that such an implementation is incomplete by saying that specialized implementations might provide less than a complete API.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3838#issuecomment-655307229

---

From: Lars Eggert <[email-masked]>
Date: Mon, 20 Jul 2020 05:30:27 -0700

@ekr willing to fight for this one?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3838#issuecomment-660997926

---

From: Martin Thomson <[email-masked]>
Date: Tue, 21 Jul 2020 15:43:00 -0700

After discussing with editors, we think that it would be better to remove the MUST in this section and say something like: "A general purpose QUIC implementation provides the following functions:" and add "A specialized implementation might provide a subset of these."

The same applies to the stream operations.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3838#issuecomment-662143911

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 21 Jul 2020 16:27:45 -0700

I think that is a positive change. Borderline design by the sound of it. It would be good to see the PR once its available.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3838#issuecomment-662157199