Subject: [quicwg/base-drafts] Use of "in order" might be misunderstood as an ordering requirement (2) (#4039)

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:45:24 -0700

There are other uses of "in order" that the editors may like to address to avoid potential misunderstanding:

/Servers SHOULD be able to read longer connection IDs from other QUIC versions in order to properly form a version negotiation packet./ ... seem like /Servers SHOULD be able to read longer connection IDs from other QUIC versions to properly form a version negotiation packet./

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039

---

From: Mike Bishop <[email-masked]>
Date: Thu, 20 Aug 2020 11:11:07 -0700

"in order to" seems like a well-known construction, so I'm not concerned about its existence.  Your rewording loses the implication of "SHOULD... because you'll need to...."

Though I see your point that this sentence could be parsed as "reading in order" being the thing servers SHOULD be able to do.  Perhaps "In order to properly form X, servers SHOULD Y"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039#issuecomment-677818693

---

From: Mike Bishop <[email-masked]>
Date: Thu, 20 Aug 2020 11:22:32 -0700

Also, this seems to be the same sentence as #4038?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039#issuecomment-677823775

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 11:53:53 -0700

That works for me - starting with the construction seems clear.

Gorry 

> On 20 Aug 2020, at 19:11, Mike Bishop <[email-masked]> wrote:
> 
> 
> —
> You are receiving this because you authored the thread.
> Reply to this email directly, view it on GitHub, or unsubscribe.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039#issuecomment-677838558

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 12:26:11 -0700

The new PR appears to have all the in orders in good order then!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039#issuecomment-677855165

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 12:26:12 -0700

Closed #4039.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4039#event-3676778757