Subject: [quicwg/base-drafts] Make the ack-tracking examplary (#3979)

From: ianswett <[email-masked]>
Date: Mon, 03 Aug 2020 07:05:43 -0700

It&#39;s no longer normative and it&#39;s in a single section.

I only moved text so far, and not as far as @MikeBishop  suggested.  I can go farther here or in a follow-up PR.

Fixes #3852
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3979

-- Commit Summary --

  * Make the ack-tracking examplary

-- File Changes --

    M draft-ietf-quic-transport.md (50)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3979.patch
https://github.com/quicwg/base-drafts/pull/3979.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979

---

From: ianswett <[email-masked]>
Date: Mon, 03 Aug 2020 07:15:03 -0700

@ianswett commented on this pull request.

>  ack-eliciting packet has been received to include an ACK frame with outgoing
 frames.

This is pre-existing, but this sentence is weird, particularly in the context of the "An endpoint MUST NOT send a non-ack-eliciting packet in response to a non-ack-eliciting packet..." above.

Is this supposed to be ", and endpoint waits until..." without the MAY?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#pullrequestreview-460062191

---

From: ianswett <[email-masked]>
Date: Mon, 03 Aug 2020 07:20:14 -0700

@ianswett pushed 1 commit.

9663dc9ab37d0ec82b45d542e461573ff06f0cbe  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979/files/9cf53b9ced77e3434f8ff5d47a0ff4795c148ca2..9663dc9ab37d0ec82b45d542e461573ff06f0cbe

---

From: Martin Thomson <[email-masked]>
Date: Mon, 03 Aug 2020 18:05:10 -0700

@martinthomson approved this pull request.

Thanks Ian.  When you lay it out like this, it seems so obvious.  I checked that we don't have citations for {{ack-tracking}}, so this works nicely.  If you care about the "MAY", then we can fix that in another PR.

 frames.

or "can".  I don't think that there is any use for the MAY, but I don't think that the sentence is inherently *bad*.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#pullrequestreview-460429587

---

From: ianswett <[email-masked]>
Date: Tue, 04 Aug 2020 19:37:36 -0700

frames.

Thanks, I think I'd rather not change it in this PR, but wanted to point out the awkwardness to reviewers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#discussion_r465437358

---

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Aug 2020 20:37:39 -0700

@janaiyengar I would like to merge this.  WDYT?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#issuecomment-668960896

---

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Aug 2020 08:10:50 -0700

@MikeBishop approved this pull request.

> @@ -3666,17 +3644,33 @@ validation at a sender and including a lower value than what was included in a
 previous ACK frame could cause ECN to be unnecessarily disabled; see
 {{ecn-validation}}.
 
+{{ack-tracking}} describes an exemplary approach for determining what packets
+to acknowledge in each ACK frame.  Though the goal of this algorithm is to
+generate an acknowledgment for every packet that is processed, it is still
+possible for acknowledgments to be lost.  A sender cannot expect to receive

Minor nit; I think the sender is right to expect this in the normal case, but it's not guaranteed and can't be relied upon.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#pullrequestreview-464318361

---

From: ianswett <[email-masked]>
Date: Mon, 10 Aug 2020 14:49:12 -0700

f6ffebe16738c836b4bcaf174e2ca6776ab37072  Move a sentence up and tweak

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979/files/9663dc9ab37d0ec82b45d542e461573ff06f0cbe..f6ffebe16738c836b4bcaf174e2ca6776ab37072

---

From: ianswett <[email-masked]>
Date: Mon, 10 Aug 2020 14:49:49 -0700

Thanks, I moved this up and tweaked the wording, since it's a general statement and not specific to ack-tracking.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#discussion_r468205396

---

From: ianswett <[email-masked]>
Date: Fri, 14 Aug 2020 13:02:06 -0700

Can we merge this soon.  I'm worried about it developing conflicts.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#issuecomment-674249538

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Aug 2020 18:44:24 -0700

Merged #3979 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#event-3659862201

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Aug 2020 18:45:01 -0700

Yep, @janaiyengar lost the chance to fix the PR.  We are - of course - still open for editorial improvements in the form of new pull requests though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#issuecomment-674614387

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 18 Aug 2020 14:09:32 -0700

@janaiyengar commented on this pull request.

Sorry about dropping this one. I'm fine with it, and happy to make editorials one later.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3979#pullrequestreview-469832586