Subject: [quicwg/base-drafts] New path may not have the same RTT (#4026)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:38:39 -0700

(Broken out of #3214.)

> 9.2.  Initiating Connection Migration/
- I assert the new path may not have the same RTT, because the path could traverse a different set of network devices or be subject to different policies that influence forwarding behaviour. These are not currently listed here, but are the basis for some later text in 9.3.1. Can we mention here?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4026

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Aug 2020 14:00:21 -0700

Is the RTT not included in the reset of the congestion controller?

> When migrating, the new path might not support the endpoint's current sending rate. Therefore, the endpoint resets its congestion controller, as described in Section 9.4.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4026#issuecomment-676697856

---

From: ianswett <[email-masked]>
Date: Wed, 19 Aug 2020 14:46:54 -0700

Section 9.4 reads:

"The capacity available on the new path might not be the same as the
   old path.  Packets sent on the old path MUST NOT contribute to
   congestion control or RTT estimation for the new path."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4026#issuecomment-676731692

---

From: ianswett <[email-masked]>
Date: Wed, 19 Aug 2020 14:50:15 -0700

I sent a PR to add "and RTT estimate" to that sentence to make this completely clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4026#issuecomment-676733666

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 16:31:01 -0700

Closed #4026 via #4034.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4026#event-3672950956