Subject: Re: [quicwg/base-drafts] Clarify simultaneous path validation (#3932)

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Aug 2020 11:59:11 -0700

Note that while the server needs to respond to the probes (so the client can validate the paths), I don't think there's any requirement that the server continue to regard all those paths as validated.  When the client actually migrates, if the server wants to treat the migration as an unvalidated path and initiate validation again, that seems fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3932#issuecomment-671530292

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Aug 2020 17:49:58 -0700

Well, the paths aren't validated until the server explicitly validates them, so it seems like the cost is pretty minimal until the server decides to engage resources for that path.  The server can also respond on the old path if the client is just probing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3932#issuecomment-671661091

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Aug 2020 21:09:16 -0700

@ianswett, do you want to think about how you reached your conclusion here and see if there is something we can do to avoid that?  It seems to me that the cost to a server is limited by how many paths it wants to probe, not how many the client probes, so the state is well managed.

It's a little less neat if the client actively migrates multiple times.  But I would say that the server can abandon probes to keep the number of active probes down to at most 2 (one for the most recent *validated* path, one for the most recent *active* path).  Is that something we need to explain more thoroughly?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3932#issuecomment-674644455

---

From: ianswett <[email-masked]>
Date: Mon, 17 Aug 2020 07:03:21 -0700

I have read this text quite a bit, but not end-to-end in quite a long time, so I believe that's the cause of my confusion.

I'm planning to re-read all the path validation and connection migration text and I'll send out a PR if there are points that I think I are unclear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3932#issuecomment-674900819