Subject: [quicwg/base-drafts] Tokens are repeated in Initial packets (#4047)

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Aug 2020 23:39:55 -0700

This issue has a long and storied history.  We were originally of the view that only one packet needed to include a token (which you can see in the discussion of #1649).  However, the resolution of that issue in #1794 was very clear: every Initial packet needs to include a token.

That introduced a regression as it grouped the token with the connection ID, and we caught that in #1830.  However, the fix to that in #1929 reverted the token changes along with the connection ID changes.  Since then, this error has gone unnoticed.

Most people will have seen the stronger normative requirement [here](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-8.1.2-1):

> This token MUST be repeated by the client in all Initial packets it sends for that connection after it receives the Retry packet. 

To my knowledge, every implementation includes the token in every Initial packet, changing only when a Retry is received.  We should reconcile the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4047

---

From: Marten Seemann <[email-masked]>
Date: Mon, 24 Aug 2020 23:51:02 -0700

> To my knowledge, every implementation includes the token in every Initial packet, changing only when a Retry is received. We should reconcile the text.

FWIW, that's what the interop runner tests for in the Retry test case.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4047#issuecomment-679838950

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:26:53 -0700

@marten-seemann : Yes, that's what sent us off on this chase :-)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4047#issuecomment-680300177

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:28:55 -0700

Closed #4047 via #4049.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4047#event-3692159041