Subject: [quicwg/base-drafts] Define slow start and congestion avoidance (#3982)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Aug 2020 15:44:56 -0700

These are not very crisply defined currently.

The congestion controller starts in slow start.  Slow start is where the congestion window is less than the slow start threshold.  Congestion avoidance is where the congestion window is at least the slow start threshold.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3982

---

From: Martin Thomson <[email-masked]>
Date: Sun, 16 Aug 2020 22:01:49 -0700

BTW, do people prefer to think of this as a two-state system, or three states:
![image](https://user-images.githubusercontent.com/67641/90358813-71612a00-e09a-11ea-8a05-63dc5672170e.png)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3982#issuecomment-674656304

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:45:32 -0700

This would be excellent to add after we've merged the normatives in #3978.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3982#issuecomment-680305796

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:46:05 -0700

FWIW, I think now that this really is 3 states. Your FSM works for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3982#issuecomment-680305951