Subject: [quicwg/base-drafts] Move/duplicate no server migration text (#4063)

From: ekr <[email-masked]>
Date: Mon, 31 Aug 2020 09:27:01 -0700

9.6 says:

   Migrating a connection to a new server address mid-connection is left
   for future work.  If a client receives packets from a new server
   address not indicated by the preferred_address transport parameter,
   the client SHOULD discard these packets.

However, this is after several sections which describe how connection migration works generically from either side, including this text in 9.3.

  Receiving a packet from a new peer address containing a non-probing
   frame indicates that the peer has migrated to that address.
   In response to such a packet, an endpoint MUST start sending
   subsequent packets to the new peer address and MUST initiate path
   validation (Section 8.2) to verify the peer's ownership of the
   unvalidated address.

Which is confusing and in fact arguably contradictory. I would propose that we add a sentence to the top of 9.3 that explains that while the text is generic, it actually only applies to servers.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063

---

From: Martin Thomson <[email-masked]>
Date: Mon, 31 Aug 2020 22:45:22 -0700

Is this enough?

> This document limits migration of connections to new client addresses, except as described in Section 9.6. 

This appears in [the top of Section 9](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#section-9-6) (that's paragraph 6, not sub-section 6 in case you look at the URL).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4063#issuecomment-684361776