Subject: [quicwg/base-drafts] ECN "not quite enough" (#4022)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:34:06 -0700

(Broken out of #3214.)

>An endpoint can verify support for Explicit Congestion Notification
>   (ECN) in the first packets it sends, /
- Nearly - It can verify the endpoints support ECN and the current path could be used to transfer ECN-marked packets. That’s not quite enough to complete verification that the path and endpoints have full ECN support.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 15:51:08 -0700

This is the level of support that we rely upon.  If the path does not provide ECN-CE marking, that's OK, because the congestion controller responds to loss just as well as marking.  If it doesn't have L4S support, that's not something we care about.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-676789101

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:29:46 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677286897

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 00:59:18 -0700

No. I think this is not the same understanding of what it means to say "verify support for ECN". What I see as validation, is the act of setting a CE code point and seeing this echoed by the remote endpoint. To me this can be done at the sending endpoint and the resulting ECN feedback can safely ignored from a CC perspective when it refers to the packet was intentionally CE-marked.

(This does not confirm the devices on path observe or remark, simply that if a known CE-mark is inserted by the sender, this is in fact observed by the receiver and generates a response to the sender. I agree that knowledge whether the path updates ECT-marks is not a part of the spec.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677440399

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 01:29:49 -0700

So would a resolution be "An end point can verify support for ECN by observing whether the ACK frames acknowledging the first packets it sends carry ECN counters"?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677457383

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 02:08:59 -0700

Hmmmm, I recall that proposal .... That's a different approach to what I said, and doesn't check that CE is correctly interpreted, but I think there is only a slim chance that CE-only is not correctly reported (I guess a server could in principle cheat and refuse to report CE-marks - but I have no evidence to suggest we currently need this).

So ... I think my answer is "YES"! Can we explain this out a little, and state that QUIC does this. I'm assuming that this refers independently for each direction of transmission.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677476746

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 02:44:42 -0700

If you'd like more text than what I proposed above, could you craft that text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677495001

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 06:08:52 -0700

Bashed and I believe I'm fine with the current rev.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677654101

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 06:51:28 -0700

I added the text above to #4016.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#issuecomment-677676692

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 06:51:29 -0700

Closed #4022.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4022#event-3675363356