Subject: Re: [quicwg/base-drafts] loss_detection_timer.update in recovery (#3969)

From: Kazu Yamamoto <[email-masked]>
Date: Mon, 03 Aug 2020 21:29:10 -0700

Reopened #3969.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#event-3618473247

---

From: Kazu Yamamoto <[email-masked]>
Date: Mon, 03 Aug 2020 21:29:11 -0700

I understand why `timeout - now()` can be negative. Suppose PTO for Initial is set. `SetLossDetectionTimer` is called even in Handshake but `GetPtoTimeAndSpace` returns Initial in this case. So, `loss_detection_timer.update` called in `SetLossDetectionTimer` *adjusts* the previous timer. It depends on timing (probably in thread programming), the value can be negative.

When I modify my code so that `SetLossDetectionTimer` takes packet space and add some logic, I don't see warning for minus anymore. I don't have a strong opinion to modify the current pseudocode but I'm pointing out this for record.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#issuecomment-668372594

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 06:23:16 -0700

Does anyone have a proposal for a change here, or is this a close-with-no-action?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#issuecomment-676349667

---

From: Kazu Yamamoto <[email-masked]>
Date: Wed, 19 Aug 2020 18:26:02 -0700

It seems to me that people want the current simple pseudocode rather than complex code with corner cases removed. So, let's close this hoping that new programmers would refer to this issue when necessary.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#issuecomment-676842400

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 19:30:19 -0700

Closed #3969.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3969#event-3673258792