Subject: Re: [quicwg/base-drafts] Clarify HTTP/2 setting parameter reservation (#3955)

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Aug 2020 11:15:25 -0700

@martinthomson, that goes back to the discussion we had around stream vs. connection errors.  @kazuho's point, if I can summarize briefly, is that an intermediary might directly copy some things from its connection to the client onto its connection to the server, or vice versa.  That led to the logic of using connection errors for things _definitely_ generated by your peer; settings are definitely generated by the peer, which argues for "MUST error," while frames might have come from upstream.

However, I note that we currently don't specify whether receiving a reserved frame type is a stream or a connection error, so I've opened #3991 for that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#issuecomment-671509132

---

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Aug 2020 11:17:19 -0700

@MikeBishop pushed 2 commits.

18c9108b1e127bb3b59c26798a9b63f3f97b154a  MUST error, error reference
f75b0c8b20757f89a86ca6fe77ad6700f811be9c  Merge remote-tracking branch 'origin/master' into http/h2_settings_reserved

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955/files/8c8c36327a096f13cfa4241420554b827cec24f6..f75b0c8b20757f89a86ca6fe77ad6700f811be9c

---

From: David Schinazi <[email-masked]>
Date: Mon, 10 Aug 2020 13:29:56 -0700

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#pullrequestreview-464564916

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 10 Aug 2020 17:20:28 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#pullrequestreview-464669705

---

From: Martin Thomson <[email-masked]>
Date: Mon, 10 Aug 2020 17:44:26 -0700

I'm going to argue that frames also need to definitely come from a peer.  If SETTINGS definitely comes from an immediate peer, then transport-level intermediation is not valid.  That is, you forward (HTTP) frames blindly at your own risk.

That is, if you indicate in SETTINGS that you understand an extension and then blindly forward frames related to that extension, you are responsible for the effects.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#issuecomment-671659801

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Aug 2020 13:11:36 -0700

When you argue that, do so on #3991 and we'll invite @kazuho for the cage match.  For this issue/PR, it sounds like we have violent agreement that SETTINGS are a MUST-connection-error.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#issuecomment-672254454

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Aug 2020 16:07:08 -0700

@MikeBishop pushed 1 commit.

d18fcbcede4eb53201047160b1991ea72df95f8d  Connection error

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955/files/f75b0c8b20757f89a86ca6fe77ad6700f811be9c..d18fcbcede4eb53201047160b1991ea72df95f8d

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Aug 2020 16:10:22 -0700

a3e82f272c2eb28b04d08b9106a138d5ae02d0fc  Merge remote-tracking branch 'origin/master' into http/h2_settings_reserved

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955/files/d18fcbcede4eb53201047160b1991ea72df95f8d..a3e82f272c2eb28b04d08b9106a138d5ae02d0fc

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 20 Aug 2020 20:48:50 -0700

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3955#pullrequestreview-472126965