Subject: [quicwg/base-drafts] Allowing QUIC to suspend ECN usage (#4028)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:42:13 -0700

(Broken out of #3214.)

In Section 13.4 
>An endpoint
>   validates the use of ECN on the path, both during connection
>   establishment and when migrating to a new path (Section 9)./
- I think the QUIC endpoint MAY also validate ECN is still support by the path during communication. This may be necessary when ECN is enabled, but a path change results in there no longer being support.
- I think this needs to also be permitted in Section  13.4.2, allowing QUIC to suspend ECN usage for a path or to an endpoint for which it currently has a connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 17:02:39 -0700

I apologize, but I don't understand the "suspend" comment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-676820622

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:28:55 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677284597

---

From: mirjak <[email-masked]>
Date: Thu, 20 Aug 2020 04:11:43 -0700

I think the point is if a path changes happens without the sender noticing and suddenly because of misconfiguration alll packets get CE marked you want to detect that and disable ECN. However, if that is something we want to recommend I think we further need to specify this. Another case that is easier to detect would be you only set ECT(0) packets but suddenly get feedback for ECT(1) marks. For that case to detect you basically would need to "run" the validation continuously.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677536353

---

From: mirjak <[email-masked]>
Date: Thu, 20 Aug 2020 04:13:33 -0700

Having that said I'm not sure how likely this case is. I guess we could recommend to re-start validation if e.g. the RTT jumps suddenly as this might be an indication of path change. Again, not sure how likely this case is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677538870

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 04:14:52 -0700

Since we don't know how likely these ECN misconfigs are and what to do about them, maybe we remain silent on the issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677540640

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 04:15:50 -0700

(I have yet to receive a single CE mark on *any* packet reaching my public server. I set it up so I get an email when that happens.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677541926

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 04:52:07 -0700

My original point was not calling for a new "test" (I'm also unsure about adding extra tests for pathologies before we know they are needed), but simply a request that a "QUIC endpoint MAY/SHOULD validate ECN is still support by the path during communication"... and as mentioned, this can be simply realised by checking the ECN counters continue to reflect packets that are being sent. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677590385

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 05:02:00 -0700

But that ongoing validation is already in the spec in https://tools.ietf.org/html/draft-ietf-quic-transport-29#section-13.4.2.2, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677603676

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 06:05:30 -0700

Yes. I've reread that text and the current text is fine with me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#issuecomment-677652356

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 06:07:29 -0700

Closed #4028.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4028#event-3675157115