Subject: [quicwg/base-drafts] What if parameter definition requires that it is stored? (#4024)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:36:18 -0700

(Broken out of #3214.)

> An endpoint MUST ignore transport parameters that it does
>   not support./
- What happens if the parameter definition requires that it is stored? How would it know?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Aug 2020 13:55:21 -0700

>From 7.4.1:
> A client need not store a transport parameter it cannot process.

If the client doesn't understand a TP, it doesn't store it and ignores it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024#issuecomment-676694700

---

From: ianswett <[email-masked]>
Date: Wed, 19 Aug 2020 15:12:14 -0700

I think this is close with no action, personally.

If it's ignored, then it cannot be stored.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024#issuecomment-676753181

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:30:58 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024#issuecomment-677288786

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:26:41 -0700

This was a question, close with no action is fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024#issuecomment-677455914

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 01:27:08 -0700

Closed #4024.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4024#event-3674165026