Subject: [quicwg/base-drafts] Reserved frame types error (#3991)

From: Mike Bishop <[email-masked]>
Date: Mon, 10 Aug 2020 11:14:35 -0700

We currently say:
> Frame types that were used in HTTP/2 where there is no corresponding HTTP/3 frame have also been reserved (Section 11.2.1). These frame types MUST NOT be sent, and receipt MAY be treated as an error of type H3_FRAME_UNEXPECTED.

This text has two failings:

- It doesn't specify whether the error is a stream error or a connection error
- In #3955, it was argued that this violation is easily detected, and perhaps warrants a "MUST error" instead of a "MAY error"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991

---

From: ianswett <[email-masked]>
Date: Mon, 10 Aug 2020 14:55:22 -0700

+1 to both changes from my perspective.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991#issuecomment-671609284

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 11 Aug 2020 15:32:43 -0700

This sounds like a design issue. Since this spins off from https://github.com/quicwg/base-drafts/issues/3954 and https://github.com/quicwg/base-drafts/issues/3955 I'm going to assume from past discussion that there is sufficient interest in discussing this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991#issuecomment-672327342

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Aug 2020 16:10:00 -0700

MUST respond with a connection error SGTM. Frames are hop-by-hop (compared to HTTP messages being end-to-end), therefore we can enforce this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991#issuecomment-672345023

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Aug 2020 16:11:04 -0700

Thanks, @kazuho.  This had shades of the tunneling discussion before, and I wasn't sure on which side of that fence you'd land.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991#issuecomment-672345381

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 11 Aug 2020 16:26:14 -0700

@MikeBishop Thank you for checking. As stated above, I think we can be strict regarding HTTP frames (especially the types), even though I tend to think that we need to be lax about HTTP messages (and how they are terminated).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3991#issuecomment-672353340