Subject: [quicwg/base-drafts] Explain why we include max_ack_delay in some timers (#3987)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Aug 2020 22:16:43 -0700

@Ralith says in #3951:

> Some clarifying language expressing that the ack delay is included in path validation/closing/draining timers/etc only for simplicity would be nice. Given the large potential impact, the reader is otherwise left trying to guess why that's appropriate.

This is reasonable.  I don't know which document needs the text though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3987

---

From: Lars Eggert <[email-masked]>
Date: Wed, 26 Aug 2020 03:45:09 -0700

This looks like it should go into -recovery, since -transport mostly only refers to `max_ack_delay` as a TP, except in Section 13.2.1 ("sending-acknowledgements"), but that text is very general.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3987#issuecomment-680803835

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 26 Aug 2020 14:34:51 -0700

I would suggest that this should go where a value of X PTOs is suggested for each specific timer.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/3987#issuecomment-681136036