Subject: [quicwg/base-drafts] This statement is dangerous (#4027)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:40:13 -0700

(Broken out of #3214.)

This statement is dangerous:
>However, an implementor should
>   only deviate from these requirements after careful consideration of
>   the performance implications of doing so./
- Let me argue this statement needs to be replaced by:
- “The requirements described are baed on consideration of
   the performance implications and the on other flows that could share network capacity”.
- I strongly argue that implementors how do not implement a PS do not conform to that PS. That happens, but I don’t see the point in a spec saying if you don’t comply you’re still compliant.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 16:32:46 -0700

Current text is:

> However, an implementation should only deviate from these requirements after careful consideration of the performance implications of a change, for connections made by the endpoint and for other users of the network.

Which was the result of this feedback.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027#issuecomment-676810513

---

From: ianswett <[email-masked]>
Date: Wed, 19 Aug 2020 16:37:37 -0700

I'd suggest this is already fixed per @martinthomson comment

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027#issuecomment-676811888

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:29:19 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027#issuecomment-677285740

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 00:51:55 -0700

Yes - this includes other uses of the network.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027#issuecomment-677436341

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 01:30:59 -0700

Closed #4027.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4027#event-3674178843