Subject: [quicwg/base-drafts] Spin bit is path-bound (#3984)

From: Martin Thomson <[email-masked]>
Date: Tue, 04 Aug 2020 17:02:48 -0700

This binds the spin-bit state to a network path, which aligns with
intent better than the existing language.  It&#39;s more words, but it is
far less ambiguous.

Closes #3802.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3984

-- Commit Summary --

  * Spin bit is path-bound

-- File Changes --

    M draft-ietf-quic-transport.md (29)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3984.patch
https://github.com/quicwg/base-drafts/pull/3984.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984

---

From: ianswett <[email-masked]>
Date: Tue, 04 Aug 2020 19:25:44 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#pullrequestreview-461296440

---

From: Mike Bishop <[email-masked]>
Date: Tue, 11 Aug 2020 16:22:08 -0700

@MikeBishop approved this pull request.

-An endpoint resets its spin value to zero when sending the first packet of a
-given connection with a new connection ID. This reduces the risk that transient
-spin bit state can be used to link flows across connection migration or ID
-change.
+An endpoint resets the spin value for a network path to zero when sending the
+first packet of a given connection with a new connection ID.

This is fine for clients that use one CID for a period of time, then retires it and switches to another, then retires that and switches to another.  For a client that uses one CID for a while, switches, switches back, etc. this will tend to correlate those CIDs.

I think the wording we want here is "when changing the connection ID being used on that network path."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#pullrequestreview-465492118

---

From: mirjak <[email-masked]>
Date: Wed, 12 Aug 2020 05:30:38 -0700

@mirjak commented on this pull request.

+1 to Mike

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#discussion_r469222916

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Aug 2020 17:10:28 -0700

@martinthomson pushed 1 commit.

0f5dfe5233f25c139741c60783da398a7ad5261f  First packet with a given connection ID

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984/files/a3f8e95d65042f286024e09c8999eca2aa2e3952..0f5dfe5233f25c139741c60783da398a7ad5261f

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Aug 2020 17:10:42 -0700

@janaiyengar, sanity check please?  I'll merge this soon either way.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#issuecomment-673170069

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 18 Aug 2020 12:42:36 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#pullrequestreview-469767716

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 18 Aug 2020 12:43:03 -0700

Merged #3984 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3984#event-3667850993