Subject: [quicwg/base-drafts] Implying sequencing (#4018)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:28:46 -0700

(Broken out of #3214.)

> frames in multiple packets in order to make
- Could be read as implying sequencing, I suggest removing /in order/ or saying /to ensure that

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Aug 2020 12:38:23 -0700

Context:  Where is the text in question?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-676621253

---

From: Martin Thomson <[email-masked]>
Date: Wed, 19 Aug 2020 15:46:32 -0700

I can't find this text at all.  Even by searching for a substring "frames in mu" or "order to make".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-676787312

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:30:36 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-677288235

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:23:02 -0700

This particular text appears to have been edited, thanks.

There's still other uses of "in order" that the editors may like to address to avoid potential misunderstanding:

/Servers SHOULD be able to read longer connection IDs from other QUIC versions in order to properly form a version negotiation packet./ ... this might be misread as an ordering requirement, but I think is intend to be: /Servers SHOULD be able to read longer connection IDs from other QUIC versions to properly form a version negotiation packet./

and
/Servers SHOULD be able to read longer connection IDs from other QUIC versions in order to properly form a version negotiation packet./ ... seem like /Servers SHOULD be able to read longer connection IDs from other QUIC versions to properly form a version negotiation packet./ 

This also is potentially misread: /An adversarial sender might intentionally send fragments of stream data in order to cause disproportionate receive buffer memory commitment and/or creation of a large and inefficient data structure./ and could be /An adversarial sender might intentionally send fragments of stream data that cause disproportionate receive buffer memory commitment and/or creation of a large and inefficient data structure./

and perhaps this also: 
/An adversarial receiver might intentionally not acknowledge packets containing stream data in order to force the sender to store the unacknowledged stream data for retransmission./ would be clearer as /An adversarial receiver might intentionally not acknowledge packets containing stream data so that it forces the sender to store the unacknowledged stream data for retransmission./

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-677454242

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 01:26:38 -0700

@gorryfair, you *please* need to open new issues for these things, one for each.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-677455889

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:49:02 -0700

The current text no longer exists, so this issue can be closed.

However, this was a generic editorial comment to the editors ... and several instances still exist. I'll follow the recommendation to raise 4 issues to address the 4 cases I currently see.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#issuecomment-677466652

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 01:58:42 -0700

Closed #4018.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4018#event-3674283616