Subject: [quicwg/base-drafts] Doesn’t say the default is in-order delivery (#4017)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:27:00 -0700

(Broken out of #3214.)

> However, implementations MAY choose to offer the ability to
> deliver data out of order to a receiving application.

This doesn’t say the default is in-order delivery, which I would have thought was the case. It also doesn’t say whether this is per-connection, or per-stream (I imagined the latter).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4017

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Aug 2020 12:36:28 -0700

The previous paragraph seems pretty clear about exactly those points.

> Endpoints MUST be able to deliver stream data to an application as an ordered byte-stream. Delivering an ordered byte-stream requires that an endpoint buffer any data that is received out of order, up to the advertised flow control limit.

I'm not seeing the issue here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4017#issuecomment-676620336

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 19 Aug 2020 20:47:52 -0700

There isn't a "default". The sentence up there was in fact added later to allow endpoints to deliver out of order. As @MikeBishop notes, the para before it says that in-order is necessary. We aren't requiring anything of the API, so a default delivery mode does not make sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4017#issuecomment-676968534

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:19:46 -0700

@gorryfair OK to close with no action?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4017#issuecomment-677263208

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 06:04:12 -0700

Closed #4017.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4017#event-3675143087