Subject: [quicwg/base-drafts] Suspect this needs to not delay? (#4025)

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 07:37:26 -0700

(Broken out of #3214.)

> MUST respond
>   immediately by echoing the data/
- Of course it may not be able to immediately send anything:-) , but I suspect this needs to not delay?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025

---

From: Mike Bishop <[email-masked]>
Date: Wed, 19 Aug 2020 13:57:26 -0700

These frames aren't subject to flow control, so the only reason it would be unable to send something is congestion control.  The frame that it echos back needs to be enqueued for sending; if it takes some time to actually hit the network, that's fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025#issuecomment-676696278

---

From: Lars Eggert <[email-masked]>
Date: Wed, 19 Aug 2020 23:31:20 -0700

@gorryfair?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025#issuecomment-677289346

---

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:29:23 -0700

Seems resolved by the PR

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025#issuecomment-677457192

---

From: Marten Seemann <[email-masked]>
Date: Thu, 20 Aug 2020 01:31:22 -0700

For the benefit of others reviewing this: This seems to refer to [8.4 Path Validation Responses](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-path-validation-responses).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025#issuecomment-677458080

---

From: Martin Thomson <[email-masked]>
Date: Mon, 24 Aug 2020 17:53:25 -0700

Closed #4025 via #4036.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4025#event-3687741439