Subject: [quicwg/base-drafts] When to reduce cwnd in recovery (#4050)

From: mirjak <[email-masked]>
Date: Tue, 25 Aug 2020 02:34:16 -0700

The recovery draft currently has the following text:

```
When slow start is exited, the congestion
window halves and the slow start threshold is set to the new congestion
window.
```

However, in https://tools.ietf.org/html/rfc5681#section-4.3 ssthresh is reduced upon entering recovery but cwnd is set to ssthresh when leaving recovery.

There is more discussion on this already in PR #3978 and PR #4005.

@ianswett proposed by email the following alternative wording:

```
MUST reduce the CWND to the ssthresh by the time recovery is exited and implementations MAY use a variety of mechanisms to reduce bytes in flight, including reducing it immediately, packet conservation, PRR(RFC6937) or decreasing the pacing rate.
```

@janaiyengar noted this text from RFC5861 which works as well:

```
   Second, until all lost segments in the window of data in question are
   repaired, the number of segments transmitted in each RTT MUST be no
   more than half the number of outstanding segments when the loss was
   detected.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4050

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:39:24 -0700

This discussion belongs in #3944, since #3978 hasn't been merged yet. Let's move this there.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4050#issuecomment-680303976

---

From: Lars Eggert <[email-masked]>
Date: Wed, 26 Aug 2020 03:30:45 -0700

Closed #4050.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4050#event-3694138851

---

From: Lars Eggert <[email-masked]>
Date: Wed, 26 Aug 2020 03:30:45 -0700

I'll close this one, since we have #3944 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4050#issuecomment-680797723