Subject: [quicwg/base-drafts] Make frame format introductions consistent (#3994)

From: Martin Thomson <[email-masked]>
Date: Tue, 11 Aug 2020 17:27:10 -0700

All references to figures that describe frame formats are changed to use
the form: &quot;X frames are formatted as shown in {{x}}.&quot;

This retains some of the extra details so that the change is limited to
this change, but I made the empty frame description consistent
throughout (with a little extra explanation for PADDING, which is
first).

Closes #3804.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/3994

-- Commit Summary --

  * Make frame format introductions consistent

-- File Changes --

    M draft-ietf-quic-transport.md (58)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/3994.patch
https://github.com/quicwg/base-drafts/pull/3994.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994

---

From: Mike Bishop <[email-masked]>
Date: Wed, 12 Aug 2020 08:51:05 -0700

This is a good improvement, but I disagree that it addresses #3804.  That is specifically about the section headings, in which some are "X Frame" and others are "X Frames":

> 19. Frame Types and Formats
> 19.1.  PADDING Frame
> 19.2.  PING Frame
> **19.3.  ACK Frames**
> 19.4.  RESET_STREAM Frame
> 19.5.  STOP_SENDING Frame
> 19.6.  CRYPTO Frame
> 19.7.  NEW_TOKEN Frame
> **19.8.  STREAM Frames**
> 19.9.  MAX_DATA Frame
> 19.10. MAX_STREAM_DATA Frame
> **19.11. MAX_STREAMS Frames**
> 19.12. DATA_BLOCKED Frame
> 19.13. STREAM_DATA_BLOCKED Frame
> **19.14. STREAMS_BLOCKED Frames**
> 19.15. NEW_CONNECTION_ID Frame
> 19.16. RETIRE_CONNECTION_ID Frame
> 19.17. PATH_CHALLENGE Frame
> 19.18. PATH_RESPONSE Frame
> **19.19. CONNECTION_CLOSE Frames**
> 19.20. HANDSHAKE_DONE Frame
> 19.21. Extension Frames

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994#issuecomment-672957033

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Aug 2020 17:15:06 -0700

@martinthomson pushed 1 commit.

f5b4676f5b3b2fa10bbb80b4f6f52aa7fba1a286  Change the titles too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994/files/1c99f22ef79aff6dcd32d24d5e94710fbed12917..f5b4676f5b3b2fa10bbb80b4f6f52aa7fba1a286

---

From: Martin Thomson <[email-masked]>
Date: Wed, 12 Aug 2020 17:16:18 -0700

My bad.  I had forgotten that bit.  I made these plural and changed definitions from "the X frame" to "a[n] X frame".  For the multi-valued types, we were also inconsistent with use of "or" vs. "and", so I changed that to match.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994#issuecomment-673171607

---

From: Mike Bishop <[email-masked]>
Date: Thu, 13 Aug 2020 09:01:20 -0700

@MikeBishop approved this pull request.

Thanks!

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994#pullrequestreview-466902391

---

From: Martin Thomson <[email-masked]>
Date: Thu, 13 Aug 2020 18:25:59 -0700

Merged #3994 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/3994#event-3654396011