Subject: [quicwg/base-drafts] SHOULD NOT attempt to parse -> unlikely to be able (#4053)

From: Mike Bishop <[email-masked]>
Date: Tue, 25 Aug 2020 13:13:01 -0700

Fixes #4020; instead of saying servers SHOULD NOT attempt to parse unknown versions, stick with the factual statement that they will likely be unable to do so.  Flips the SHOULD to the second half of the sentence, the expected response.

I believe this is editorial, since we&#39;re not modifying expected behavior, but it&#39;s touching normative language, so please speak up if you&#39;re not convinced.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4053

-- Commit Summary --

  * Convert a SHOULD NOT to a SHOULD

-- File Changes --

    M draft-ietf-quic-transport.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4053.patch
https://github.com/quicwg/base-drafts/pull/4053.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053

---

From: Martin Thomson <[email-masked]>
Date: Tue, 25 Aug 2020 15:11:10 -0700

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#pullrequestreview-474950437

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:18:50 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#pullrequestreview-474966036

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 25 Aug 2020 15:19:19 -0700

Merged #4053 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#event-3692134887

---

From: ekr <[email-masked]>
Date: Wed, 26 Aug 2020 17:33:51 -0700

Actually, it seems like there should be a normative MUST NOT attempt.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#issuecomment-681193417

---

From: Martin Thomson <[email-masked]>
Date: Wed, 26 Aug 2020 17:35:57 -0700

I would have said "cannot".  The contents are unknown, after all.  Attempting to prohibit someone from doing something impossible seems like it might be unnecessary (or at least futile).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#issuecomment-681194139

---

From: ekr <[email-masked]>
Date: Wed, 26 Aug 2020 19:15:23 -0700

Why do you say it's impossible? You could simply hope that version n+1 was the same as version n in terms of structure and try to parse it as that, ignoring the version number.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#issuecomment-681301377

---

From: Mike Bishop <[email-masked]>
Date: Thu, 27 Aug 2020 07:33:14 -0700

Which is why the PR says "unlikely," not "impossible."  But the impossible thing is for the server to know whether it's doing things correctly.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#issuecomment-681987340

---

From: ekr <[email-masked]>
Date: Thu, 27 Aug 2020 14:38:14 -0700

Right, but my point is that we should prohibit trying, not just give people advice that it's dumb.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4053#issuecomment-682204068