Subject: [quicwg/base-drafts] Use of "in order" might be misunderstood as an ordering requirement (1) (#4038)

From: Gorry Fairhurst <[email-masked]>
Date: Thu, 20 Aug 2020 01:44:25 -0700

There are other uses of "in order" that the editors may like to address to avoid potential misunderstanding:

/Servers SHOULD be able to read longer connection IDs from other QUIC versions in order to properly form a version negotiation packet./ ... this might be misread as an ordering requirement, but I think is intend to be: /Servers SHOULD be able to read longer connection IDs from other QUIC versions to properly form a version negotiation packet./

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4038

---

From: Lars Eggert <[email-masked]>
Date: Thu, 20 Aug 2020 02:03:14 -0700

FYI, it's more readable to quote with `>`, e.g., 

> Servers SHOULD be able to read longer connection IDs from other QUIC versions in order to properly form a version negotiation packet.

this might be misread as an ordering requirement, but I think is intend to be:

> Servers SHOULD be able to read longer connection IDs from other QUIC versions to properly form a version negotiation packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4038#issuecomment-677473766

---

From: Martin Thomson <[email-masked]>
Date: Sun, 23 Aug 2020 19:07:01 -0700

Closed #4038 via #4042.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4038#event-3683409312