Subject: [quicwg/base-drafts] TLS-31: Figure 6 - header_protection function (#4198)

From: Magnus Westerlund <[email-masked]>
Date: Tue, 13 Oct 2020 06:35:16 -0700

Section 5.4.1, Figure 6:

mask = header_protection(hp_key, sample)

I think it is a bit unclear that the header_protection function is what is producing the stream cipher cipher text that will be masked and xored with the header bits. Especially as the instantiations of these functions for AES_GCM (Section 5.4.3) and ChaCha20 (Section 5.4.4) is not defined as instantiation of that function, only as providing the same variable output. 

I think this could be clarified in both places so that the linkage between the general application and the stream cipher producing function is clear.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4198

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:10:57 -0700

Looks good and resolve my issue. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4198#issuecomment-709258115

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Oct 2020 16:37:37 -0700

Closed #4198 via #4202.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4198#event-3883971902