Subject: [quicwg/base-drafts] Initial timeout in path validation failure (#4261)

From: Martin Thomson <[email-masked]>
Date: Mon, 26 Oct 2020 23:05:48 -0700

[Section 8.2.4](https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-failed-path-validation) says "initial timeout (that is, `2*kInitialRtt`)".  But I don't think that we have this initial timeout concept in recovery any more; we [just use the PTO](https://quicwg.org/base-drafts/draft-ietf-quic-recovery.html#section-6.2.2-1).  Should this just be `3*PTO` now?  The result is that the `6*kInitialRtt` is meaningless as the PTO is `3*kInitialRtt + max_ack_delay` when initialized.

Or is this the PTO on the pre-existing path?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4261

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 27 Oct 2020 00:12:37 -0700

> Or is this the PTO on the pre-existing path?

I think this is the case. Notice "current."

Therefore I belive that the formula should be `max(3*current_PTO, 3*initial_PTO)`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4261#issuecomment-717038408

---

From: ianswett <[email-masked]>
Date: Tue, 27 Oct 2020 06:22:22 -0700

Changing 2*kInitialRtt to 3*kInitialRtt and 6*kInitialRtt to 9*kInitialRtt seems like the simplest fix since we don't define an initial_PTO variable anywhere in the documents.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4261#issuecomment-717239068

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 27 Oct 2020 17:10:50 -0700

I assume that the choice between #4262 and #4263 is purely editorial. Either works for me.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4261#issuecomment-717614807

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 29 Oct 2020 15:59:47 -0700

I prefer #4263 with some changes that I've noted on the PR.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4261#issuecomment-719070989