Subject: [quicwg/base-drafts] Connection ID length requirements for Version Negotiation packets need clarification (#4186)

From: Marten Seemann <[email-masked]>
Date: Wed, 07 Oct 2020 18:47:16 -0700

Since future QUIC versions might have different CID length requirements for Initial packets (or however that packet type will be called in that version), we already require servers to be able to send Version Negotiation packets with CIDs longer than 20 bytes (which is the maximum length that v1 allows).

We need to clarify that this also applies to the minimum CID length, which is 8 byte for the DCID in v1. A future version of QUIC might relax this limit, so a server also needs to generate a VN packet if it receives a packet with an unknown version and a shorter DCID, otherwise it won't be possible to roll out such a QUIC version.

This is coming out of a Slack discussion with @DavidSchinazi and @nibanks, as well as recent tests on the interop runner. It turns out that 2 server implementations on the interop runner didn't get this right, and at least one server implementation that's not on the interop runner, but is running QUIC in production.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4186

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Oct 2020 16:28:11 -0700

Closed #4186 via #4187.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4186#event-3883953379