Subject: [quicwg/base-drafts] 0x?a?a?a?a is somewhat pulled out of a hat (#4281)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:02:27 -0700

> For a server to use a new version in the future, clients need to
  correctly handle unsupported versions.  Some version numbers
  (0x?a?a?a?a as defined in Section 15) are reserved for inclusion in
  fields that contain version numbers.

The value 0x?a?a?a?a is somewhat pulled out of a hat, it would be useful to
explain the rational. SB> and then in Section 15 I wondered why this pattern
which leaves all sorts of holes in the version space?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4281

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 08:17:09 -0700

The point of GREASE is that the values be easy to generate, but not clustered in the space (and thus more easily coded for).  We used this pattern because it had already been successfully used in TLS for four-byte spaces.  See RFC 8701.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4281#issuecomment-718003423

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:13:07 -0700

I don't plan to do anything with this feedback.  Like other questions we've received, this doesn't really warrant an explanation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4281#issuecomment-718384247