Subject: [quicwg/base-drafts] Looking for a protocol definition (#4267)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 06:49:38 -0700

>  Packet and frame diagrams in this document use a custom format.  The
  purpose of this format is to summarize, not define, protocol
  elements.

I found this confusing, because in a ST protocol specification I was
looking for a protocol definition

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4267

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 07:56:23 -0700

The protocol definition is the text; the diagrams are helpful summaries of the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4267#issuecomment-717989200

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:05:27 -0700

For the benefit of others, who might struggle with "ST", like I did.  "ST" == standards-track.

I don't know what sort of protocol definition is contemplated here.  There is RFC 4101, I guess.

If you look at that, the information RFC 4101 suggests be included is there already.  The introduction lays out the actors involved and what they hope to do and how they do it in general terms.  And the handshake section (7) shows some example handshake exchanges.

As for the use of diagrams, what Mike said applies.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4267#issuecomment-718381403