Subject: [quicwg/base-drafts] Recovery-31: Congestion control based on ACKs only to speed up? (#4194)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 09:24:32 -0700

Section 7. 
 
 "Unlike TCP, QUIC can detect the loss of these packets and MAY use that information to adjust the congestion controller or the rate of ACK-only packets being sent, but this document does not describe a mechanism for doing so." 
 
So is there need to say anything that if one does this it needs to be adjusted in both directions, i.e. it is not okay to only use it to speed up, and not slow down. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194

---

From: ianswett <[email-masked]>
Date: Mon, 12 Oct 2020 16:03:00 -0700

As it stands, the statement uses the neutral word 'adjust' which does not imply up or down.  I think this is appropriate and given this is more of a research project, I'd prefer to keep the text approximately as is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194#issuecomment-707387424

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 13 Oct 2020 15:39:07 -0700

I agree with @ianswett. The sentence actually says what you want it to say, in that it doesn't specify a direction of adjustment.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194#issuecomment-708047367

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Oct 2020 04:23:55 -0700

@gloinul do these explanations address your issue? Or are text changes required?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194#issuecomment-709216293

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:34:28 -0700

Yes, lets close this issue. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194#issuecomment-709286857

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Oct 2020 05:36:14 -0700

Closed #4194.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4194#event-3881309439