Subject: [quicwg/base-drafts] Document why one might want to pad ACKS (#4252)

From: ianswett <[email-masked]>
Date: Mon, 19 Oct 2020 15:10:22 -0700

...or alter the idle timeout behavior when unpadded ACK-only packets are received.

Fixes #4183 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4252

-- Commit Summary --

  * Document why one might want to pad ACKS

-- File Changes --

    M draft-ietf-quic-transport.md (19)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4252.patch
https://github.com/quicwg/base-drafts/pull/4252.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Oct 2020 15:23:45 -0700

As I said privately, I don't think that we need to say anything more on this point.  The case we are interested in is Initial packets from a server that contain only ACK.  If those are getting through, then they will be in response to Initial packets from the client.  Given that the client has received an acknowledgement, it will only be sending Initial packets on PTO.  As the PTO count doesn't reset at this stage, the PTO timeout increases exponentially.  Eventually the PTO will be larger than the idle timeout.  So - worst case - the idle timeout is doubled.  If you are relying on idle timeout to abandon the connection attempt, then this isn't great, but you can still rely on that being hit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#issuecomment-712475046

---

From: ianswett <[email-masked]>
Date: Mon, 19 Oct 2020 16:34:09 -0700

@ianswett pushed 1 commit.

2cc7fd7a99e9da301557a0902ea04336b2eec1de  Changed to a Note

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252/files/e0864a5a5ea82cfd3f29215b570851a7a438b5ce..2cc7fd7a99e9da301557a0902ea04336b2eec1de

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 19 Oct 2020 16:40:40 -0700

I agree with @martinthomson here. If we are going to add a note, I'd rather add one about the fact that smaller-than-1200-byte non-ack-eliciting packets can cause unpredicted side-effects. Given that we don't have anything actionable here for an implementer however, I don't see the value in this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#issuecomment-712499955

---

From: ianswett <[email-masked]>
Date: Mon, 19 Oct 2020 17:51:23 -0700

Possibly this is not the right text, but @marten-seemann wanted to pad ACKs and I think there are valid reasons, so I'm attempting to describe the one possible issue with not doing so.

I'm happy to close this and accept someone else's PR instead.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#issuecomment-712520945

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 19 Oct 2020 21:02:09 -0700

@kazuho commented on this pull request.

I am concerned that the note is a bit too specific regarding behaviors around timeout. We do assume endpoints to have timeouts other than idle timeouts.

@janaiyengar 
> I'd rather add one about the fact that smaller-than-1200-byte non-ack-eliciting packets can cause unpredicted side-effects.

I'm not sure if giving such advice makes sense. As pointed out in #4253, size of datagram is not authenticated, and therefore endpoints should be prepared against MOTS attackers injecting spoofed datagrams that do not meet the padding requirement.

It might be true that we can have exceptions for Initial packets, but I do not think having such exception is worthwhile when we cannot have such an exception for connection migration.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#pullrequestreview-512314787

---

From: ianswett <[email-masked]>
Date: Tue, 20 Oct 2020 14:40:05 -0700

Not a lot of interest in this, so closing.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#issuecomment-713155509

---

From: ianswett <[email-masked]>
Date: Tue, 20 Oct 2020 14:40:05 -0700

Closed #4252.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4252#event-3900911113