Subject: [quicwg/base-drafts] Pseudo code is code component (#4189)

From: Jana Iyengar <[email-masked]>
Date: Thu, 08 Oct 2020 17:00:47 -0700

Closes #4177.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4189

-- Commit Summary --

  * Pseudo code is code component

-- File Changes --

    M draft-ietf-quic-recovery.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4189.patch
https://github.com/quicwg/base-drafts/pull/4189.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 08 Oct 2020 17:01:56 -0700

@janaiyengar pushed 1 commit.

e77e6ee4037a16f3871d73d115dcd4d9da7ffc22  better?

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189/files/cf53d55541b4ed7ea3230ac116ac9a9489daf75f..e77e6ee4037a16f3871d73d115dcd4d9da7ffc22

---

From: Martin Thomson <[email-masked]>
Date: Thu, 08 Oct 2020 17:26:49 -0700

@martinthomson approved this pull request.

This works for me.  Thanks for writing it up.

Some word deletion suggestions only.

> @@ -1150,6 +1150,9 @@ This document has no IANA actions.
 We now describe an example implementation of the loss detection mechanisms
 described in {{loss-detection}}.
 
+The pseudocode snippets in this section are licensed as Code Components; see the
+copyright notice above.

```suggestion
copyright notice.
```

I get that we can't cite this directly, but I think we're OK not saying "above".

> @@ -1605,6 +1608,9 @@ OnPacketNumberSpaceDiscarded(pn_space):
 We now describe an example implementation of the congestion controller described
 in {{congestion-control}}.
 
+The pseudocode snippets in this section are licensed as Code Components; see the
+copyright notice above.

```suggestion
copyright notice.
```

> @@ -1150,6 +1150,9 @@ This document has no IANA actions.
 We now describe an example implementation of the loss detection mechanisms
 described in {{loss-detection}}.
 
+The pseudocode snippets in this section are licensed as Code Components; see the

```suggestion
The pseudocode in this section is licensed as Code Components; see the
```

> @@ -1605,6 +1608,9 @@ OnPacketNumberSpaceDiscarded(pn_space):
 We now describe an example implementation of the congestion controller described
 in {{congestion-control}}.
 
+The pseudocode snippets in this section are licensed as Code Components; see the

```suggestion
The pseudocode in this section is licensed as Code Components; see the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#pullrequestreview-505261629

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 08 Oct 2020 18:12:23 -0700

8ac0c4276325c37afbfa57cfbb0d3e39abe40f71  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189/files/e77e6ee4037a16f3871d73d115dcd4d9da7ffc22..8ac0c4276325c37afbfa57cfbb0d3e39abe40f71

---

From: Mike Bishop <[email-masked]>
Date: Fri, 09 Oct 2020 07:53:00 -0700

@MikeBishop approved this pull request.

+The pseudocode in this section is licensed as Code Components; see the

The agreement in number between "The pseudocode" and "Components" is jarring.  I'd go either....
```suggestion
The pseudocode in this section is licensed as a Code Component; see the
```
or
```suggestion
The sections which follow contain pseudocode.  The contents of these sections are
licensed as Code Components; see the
```
Given that it's multiple blocks, I think keeping it plural (as it originally was) might be better, but I agree on finding a word besides "snippets."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#pullrequestreview-505748254

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 09 Oct 2020 16:37:23 -0700

c24e60714a4fb8170284be9f33c94971e6b7fb85  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189/files/8ac0c4276325c37afbfa57cfbb0d3e39abe40f71..c24e60714a4fb8170284be9f33c94971e6b7fb85

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 09 Oct 2020 16:40:49 -0700

@janaiyengar commented on this pull request.

I'm using "segments", see if that works.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#discussion_r502713627

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 09 Oct 2020 16:41:21 -0700

51ebab59453aae1bd8fd45a3e160abe6859ff7a3  pseudocode segments

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189/files/c24e60714a4fb8170284be9f33c94971e6b7fb85..51ebab59453aae1bd8fd45a3e160abe6859ff7a3

---

From: Martin Thomson <[email-masked]>
Date: Sun, 11 Oct 2020 22:39:37 -0700

I think that this is OK, but I want to point out that the pseudocode is pretty useless without the bits around it that explain when it is used and how.  Why not just label the entire section as a code component?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#issuecomment-706876482

---

From: ianswett <[email-masked]>
Date: Mon, 12 Oct 2020 09:43:02 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#pullrequestreview-506771962

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 12 Oct 2020 12:54:32 -0700

Merged #4189 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#event-3868083368

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 12 Oct 2020 12:56:51 -0700

@martinthomson : The point of the issue was to protect the pseudo code under the license. The explanatory text doesn't need to be licensed any differently than the text in the rest of the document, IMO. I'm happy to take an editorial PR to change this as you would like though, if you think it's useful enough.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4189#issuecomment-707316368