Subject: [quicwg/base-drafts] Explain format more (#4292)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:14:22 -0700

>  The layout of a Version Negotiation packet is:
>
>  Version Negotiation Packet {
    Header Form (1) = 1,
    Unused (7),
    Version (32) = 0,
    Destination Connection ID Length (8),
    Destination Connection ID (0..2040),
    Source Connection ID Length (8),
    Source Connection ID (0..2040),
    Supported Version (32) ...,
  }
>
>                  Figure 14: Version Negotiation Packet
>
>  The value in the Unused field is selected randomly by the server.

When I first met this text the following questions arose.
What does the (7) in unused mean?
What length is Destination/Source Connection ID/What does (0..2040) mean?
Now I have figured this out, but I really worry about how difficult this is
for the new/casual reader of the text.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4292

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 12:48:25 -0700

The notation is described in Section 1.3, before it is ever used in the document.  It seems excessive to refer back to the diagram conventions from every diagram.  I'm not sure what would make this clearer for a reader who doesn't read the introduction.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4292#issuecomment-718169138

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 29 Oct 2020 09:19:45 -0700

This might be difficult for a casual reader of the text, but I would argue that we shouldn't optimize for them. As Mike notes, there are a large number of diagrams, and the notations section exists precisely to capture common notation that is used throughout the document.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4292#issuecomment-718863960