Subject: [quicwg/base-drafts] Error states missing (#4277)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 06:59:19 -0700

In looking at  "Figure 2: States for Sending Parts of Streams" it occurred
to me that this was the major states but there were possibly a number of error
states missing. It would be useful to clarify.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4277

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 08:10:57 -0700

Errors result in closing the connection, at which point the streams no longer have a state.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4277#issuecomment-717999120

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:12:17 -0700

I think we'd need something more concrete for this to be actionable.  As this state machine has been implemented a number of times now, I don't believe that we've missed any states.

And, as Mike says, many error states are not relevant as genuine errors result in the connection closing.  Of course, there are far fewer concrete errors than you might first think.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4277#issuecomment-718383911