Subject: [quicwg/base-drafts] HTTP-31: HTTP/3 Connection definition? (#4206)

From: Magnus Westerlund <[email-masked]>
Date: Wed, 14 Oct 2020 05:19:30 -0700

Section 2.2.:

"connection:
    A transport-layer connection between two endpoints, using QUIC as the transport protocol.
connection error:
    An error that affects the entire HTTP/3 connection."

In a total of 11 places this document uses "HTTP/3 connection". The word connection exists 213 times in this document (HTML version). So are there a difference between connection and HTTP/3 Connection, and if it is can that be clearly expressed. Else maybe alignment would be better.

Secondly, I think the above "connection" definition is likely missing one important aspect isn't it? I have the impression that an "HTTP/3" connection is a QUIC connection established with the purpose of communicating HTTP/3 over it. That intention is likely explicitly expressed at QUIC connection establishment using ALPN?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 03:18:13 -0700

So that pull request resolves the definition of the HTTP connection. Does the usage of HTTP/3 connection vs Connection in the document need adjustment? In other words, can you please check all the usage of connection if there is difference and if anywhere it needs to be clarified that it is not an HTTP/3 connection? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#issuecomment-709090342

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Oct 2020 04:19:44 -0700

Based on #4212, labeling this as "editorial"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#issuecomment-709212471

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:37:59 -0700

Having looked through the occurrences of "connection" in the document, I mostly think it's clear from context which type of connection we're talking about.  (It also helps that an HTTP/3 connection *is* a QUIC connection, and so it's rarely necessary to distinguish the two.)  I did a slightly aggressive pass in 2530b98, but I think I'm going to pare that down a bit.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#issuecomment-709577023

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:48:19 -0700

Okay, I've pushed a less-aggressive change as dae7b75e.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#issuecomment-709581848

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 16 Oct 2020 01:06:59 -0700

Thanks @MikeBishop that commit appear good to me. I think with these changes this issue is resolved.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#issuecomment-709894658

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Oct 2020 08:35:27 -0700

Closed #4206 via #4212.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4206#event-3886998460