Subject: [quicwg/base-drafts] Recovery-31: Limits on kPersistentCongestionThreshold values? (#4195)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 09:30:47 -0700

Section 7.6.1: 

	The RECOMMENDED value for kPersistentCongestionThreshold is 3, which is approximately equivalent to two TLPs before an RTO in TCP.

Any values that needs to be explicitly forbidden? For example does it need a sentence saying that it MUST be larger than X? I would think that 1 would be to low and allow slow start after just one RTT+variations? I understand that likely would give the application bad behavior but likely also have negative impact on other applications if the QUIC stack ends up doing slow start crashing into the wall and then slow starting again?  

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4195

---

From: ianswett <[email-masked]>
Date: Mon, 12 Oct 2020 16:00:02 -0700

I lean towards not being overly proscriptive here.  We could elaborate on the pros and cons of smaller and larger values if you think that is necessary?  Exponential backoff is clearly critical, but it's less clear to me that the CWND really needs to be collapsed in these situations.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4195#issuecomment-707386582

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 13 Oct 2020 00:34:16 -0700

I am really just trying to asses if there are significant risks with any specific ranges of values. For example causing very bursty behavior that could be considered harmful or becoming extremely aggressive after a persistent congestion event, in those cases some text may be necessary. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4195#issuecomment-707551883

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Oct 2020 04:15:45 -0700

Based on #4215, labeling this as "editorial"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4195#issuecomment-709209018

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 15 Oct 2020 13:04:49 -0700

Closed #4195 via #4215.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4195#event-3883360827