Subject: [quicwg/base-drafts] Hard to parse (#4301)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:22:28 -0700

>  As a result, the size of the packet number encoding is at least one
  bit more than the base-2 logarithm of the number of contiguous
  unacknowledged packet numbers, including the new packet.

That is really hard to parse.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4301

---

From: ianswett <[email-masked]>
Date: Wed, 28 Oct 2020 11:59:42 -0700

I agree that first sentence is hard to parse.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4301#issuecomment-718143014

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:25:22 -0700

I also agree regarding the first.  As this is an alternative description, and I don't have anything better to offer, I plan not to change anything unless someone offers something good.

The second seems fine.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4301#issuecomment-718389067

---

From: Mike Bishop <[email-masked]>
Date: Thu, 29 Oct 2020 07:07:11 -0700

I wonder if the real takeaway here is that these "examples in passing" assume the reader is deeply following along with the algorithm in their head; I know I don't, but I'm also not implementing packetization.  We already have an appendix that illustrates packet number decoding; perhaps we should move one or both paragraphs to an appendix that illustrates selecting an encoding, with these as the examples.

Reading the rest of the section, is "protection of the packet number" the term we've used elsewhere?  Shouldn't that be "header protection," perhaps with a cross-ref to -tls?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4301#issuecomment-718776200