Subject: [quicwg/base-drafts] Recovery-31: PTO time MUST NOT be set and interaction with time threshold (#4193)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 08:27:57 -0700

Section 6.2.1:

"The probe timer MUST NOT be set if the time threshold (Section 6.1.2) loss detection timer is set. The time threshold loss detection timer is expected to both expire earlier than the PTO and be less likely to spuriously retransmit data."

What does "MUST NOT be set" means. The time threshold loss detection 6.1.2 only occurs if there is acknowledgement received by the sender sufficient late after the transmission. Thus, PTO timer needs to always be set. because even if Time Threshold timer fires it might not declare a loss.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193

---

From: ianswett <[email-masked]>
Date: Mon, 12 Oct 2020 08:41:48 -0700

It means if the time threshold timer is armed, you are not supposed to arm the PTO timer.

If the Time Threshold timer fires and doesn't declare a loss, then I would consider that a bug.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-707196385

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 09:52:32 -0700

So the above text about loss timer is only when one are under the condition created by this Section 6.1.2 sentence? 

"If packets sent prior to the largest acknowledged packet cannot yet be declared lost, then a timer SHOULD be set for the remaining time."

Does the formulation in 6.1.2 need to be improved, possibly naming the timer? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-707233351

---

From: ianswett <[email-masked]>
Date: Mon, 12 Oct 2020 12:30:49 -0700

I can see the confusion.  This can either be a single timer or multiple, and sometimes we refer to it one way and sometimes as separately named timers, ie "The time threshold loss detection timer"

We can either be more consistent about naming the timers or stop naming the timers entirely.  Would you prefer the former?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-707305473

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:36:57 -0700

Frankly I don't know which direction that is best. Could I ask you to take an editorial stab on your most preferred. I would guess when you sit down to do either you realize if it will work or not when you harmonize it. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-709289168

---

From: ianswett <[email-masked]>
Date: Fri, 16 Oct 2020 11:28:29 -0700

@gloinul Does PR #4222 resolve this for you?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-710380729

---

From: Lars Eggert <[email-masked]>
Date: Mon, 19 Oct 2020 10:56:10 -0700

@gloinul we'd need a response, please

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-712338824

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 19 Oct 2020 23:33:52 -0700

Yes, that simple tweak do make it clearer. So resolved. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#issuecomment-712627076

---

From: ianswett <[email-masked]>
Date: Tue, 20 Oct 2020 05:48:13 -0700

Closed #4193 via #4222.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4193#event-3898505724