Subject: [quicwg/base-drafts] Only packet you can trust to explore the path is a QUIC packet (#4274)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 06:56:48 -0700

>14.2.1.  Handling of ICMP Messages by PMTUD

I am worried about the text in this section. ICMP and UDP paths may not be
congruent as a result of different RTG ECMP treatment. The only packet you can
trust to explore the path is a QUIC packet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4274

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 08:08:07 -0700

Can you expand on the worry?  The section doesn't use ICMP to explore path sizes, only defines reactions to ICMP notifications of dropped packets.  Further, "don't trust ICMP" seems to be exactly what it says:

> An endpoint MUST NOT increase PMTU based on ICMP messages; see Section 3, clause 6 of [DPLPMTUD]. Any reduction in QUIC's maximum datagram size in response to ICMP messages MAY be provisional until QUIC's loss detection algorithm determines that the quoted packet has actually been lost.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4274#issuecomment-717997229