Subject: [quicwg/base-drafts] Magnus' TLS nits (#4205)

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Oct 2020 02:07:44 -0700

These are all small, but neat improvements inspired by the feedback in #4204.

Closes #4204.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4205

-- Commit Summary --

  * Describe TLS properties more precisely
  * Just describe 0-RTT (and its limitations)
  * DCID is 0..20 and clarify...

-- File Changes --

    M draft-ietf-quic-tls.md (22)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4205.patch
https://github.com/quicwg/base-drafts/pull/4205.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205

---

From: Sean Turner <[email-masked]>
Date: Wed, 14 Oct 2020 06:53:19 -0700

@seanturner approved this pull request.

I liked that we dropped the MUST NOT, it's already somewhere else. I also like that we point back to quic-trans for the dcid info.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205#pullrequestreview-508370939

---

From: ianswett <[email-masked]>
Date: Wed, 14 Oct 2020 16:41:09 -0700

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205#pullrequestreview-508843465

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:01:22 -0700

@gloinul approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205#pullrequestreview-509301148

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 15 Oct 2020 13:46:56 -0700

@janaiyengar approved this pull request.

nit

> @@ -990,11 +991,12 @@ response to an Initial packet from the server.
 
 Note:
 
-: The Destination Connection ID is of arbitrary length, and it could be zero
-  length if the server sends a Retry packet with a zero-length Source Connection
-  ID field.  In this case, the Initial keys provide no assurance to the client
-  that the server received its packet; the client has to rely on the exchange
-  that included the Retry packet for that property.
+: The Destination Connection ID field could be any length up to 20 bytes,
+  including zero length if the server sends a Retry packet with a zero-length
+  Source Connection ID field. After a Retry, the Initial keys provide the client
+  no assurance that the server received its packet; the client has to rely on

```suggestion
  no assurance that the server received its packet, so the client has to rely on
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205#pullrequestreview-509795573

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Oct 2020 16:37:56 -0700

@martinthomson pushed 1 commit.

9811e96cf6e4604bd5ae583824c4ccbacfbe4b84  so...

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205/files/baeefed4af92420b4d088ccb9f75b9e9348d91c4..9811e96cf6e4604bd5ae583824c4ccbacfbe4b84

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Oct 2020 16:38:05 -0700

Merged #4205 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4205#event-3883972732