Subject: [quicwg/base-drafts] What units of time you are using (#4283)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:05:22 -0700

>     validation_timeout = max(3*PTO, 6*kInitialRtt)

A quick look in the reference did not show what units of time you are using
in the protocol - maybe I missed it?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283

---

From: Marten Seemann <[email-masked]>
Date: Wed, 28 Oct 2020 07:47:49 -0700

`kInitialRtt` is set to 333ms. Not sure why a max between two values needs to define the unit in the first place though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283#issuecomment-717983239

---

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:49:25 -0700

`kInitialRtt` is not defined in -transport, and Stewart was (probably) only reviewing the document in isolation.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283#issuecomment-717984329

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 08:20:12 -0700

@marten-seemann, a max needs to ensure both values use the same units.  But provided that they do, I agree.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283#issuecomment-718005605

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 28 Oct 2020 08:44:13 -0700

Maybe it's easier to say that these are all physical quantities, or numbers with units. In the specification, we use seconds, milliseconds, microseconds. That's fine, because we know how to align the units when we make calculations (e.g., max).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283#issuecomment-718021966

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:15:35 -0700

PR #4263 proposes removing the text in question.  Of course, it doesn't matter what time units are in use in this case.  I'm fairly confident that where units matter (i.e., we base the value on a constant), the units are explicit.  Here, the units are part of the definition of the variables.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4283#issuecomment-718385227