Subject: [quicwg/base-drafts] Choice of padding values (#4295)

From: Lars Eggert <[email-masked]>
Date: Wed, 28 Oct 2020 07:16:21 -0700

> 19.1.  PADDING Frames

The choice of padding values is itself an interesting problem, but as far
as I can see the text is silent on the subject.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4295

---

From: Mike Bishop <[email-masked]>
Date: Wed, 28 Oct 2020 12:41:39 -0700

I don't understand this comment.  The text is silent because there is no choice of padding values -- PADDING frames have a defined frame type and no content.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4295#issuecomment-718165853

---

From: Martin Thomson <[email-masked]>
Date: Wed, 28 Oct 2020 23:30:23 -0700

I believe that this is raising the known-difficult problem of knowing when and how much to pad.  That is something that other documents have addressed by saying "we provide the tools, but don't show you how to use them".  That is absent here, so this is a fair criticism.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4295#issuecomment-718391026

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 29 Oct 2020 16:50:55 -0700

I don't read the comment as being about the amount of padding, and so I have the same question as @MikeBishop, but the clarification in #4312 is a welcome addition. I think the PR addresses the addressable part of this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4295#issuecomment-719087765

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 29 Oct 2020 16:51:03 -0700

Closed #4295 via #4312.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4295#event-3938896578