Subject: [quicwg/base-drafts] receivers cannot enforce datagram padding (though they may drop) (#4254)

From: Kazuho Oku <[email-masked]>
Date: Mon, 19 Oct 2020 18:55:10 -0700

Closes #4523, by adding generic &quot;MUST NOT close, MAY discard packets&quot; rule.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4254

-- Commit Summary --

  * endpoint MAY discard, MUST NOT close when receiving a datagram that does not meet the padding requirements
  * add ref

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4254.patch
https://github.com/quicwg/base-drafts/pull/4254.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254

---

From: Marten Seemann <[email-masked]>
Date: Mon, 19 Oct 2020 19:00:19 -0700

#4253?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#issuecomment-712539807

---

From: Marten Seemann <[email-masked]>
Date: Mon, 19 Oct 2020 21:11:49 -0700

@marten-seemann requested changes on this pull request.

> @@ -4085,6 +4085,13 @@ UDP datagrams MUST NOT be fragmented at the IP layer.  In IPv4
 ({{!IPv4=RFC0791}}), the DF bit MUST be set if possible, to prevent
 fragmentation on the path.
 
+Even though datagrams with certain properties are required to be padded, the
+size of the datagram is not authenticated, and endpoints might send coalesced
+packets after the handshake is confirmed (see {{packet-coalesce}}).  Therefore,

Once the handshake is confirmed, Handshake keys are dropped. From that point on, it's not possible to send coalesced packets any more.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#pullrequestreview-512317468

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 19 Oct 2020 21:39:11 -0700

@kazuho commented on this pull request.

> Once the handshake is confirmed, Handshake keys are dropped. From that point on, it's not possible to send coalesced packets any more.

That's not true. Use of handshake packets is explicitly allowed post-handshake; see
https://quicwg.org/base-drafts/draft-ietf-quic-transport.html#name-pmtu-probes-containing-sour.

The reason the reference currently points to packet-coalesce is because it's more generic (and also contains reference to post-handshake PMTUD), but the reference can be specific if that's others' preference.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#discussion_r508204455

---

From: Martin Thomson <[email-masked]>
Date: Mon, 19 Oct 2020 23:18:07 -0700

@martinthomson commented on this pull request.

This seems sensible.

```suggestion
packets after the handshake is confirmed; see {{packet-coalesce}}.  Therefore,
```

```suggestion
Datagrams are required to be padded under some conditions.  However, the
```

```suggestion
size of the datagram is not authenticated.  Therefore,
```
I don't think that we need to call this out, but you can use the other suggestion if you prefer.

+Even though datagrams with certain properties are required to be padded, the
+size of the datagram is not authenticated, and endpoints might send coalesced
+packets after the handshake is confirmed (see {{packet-coalesce}}).  Therefore,
+an endpoint MUST NOT close a connection when it receives a datagram that does
+not meet the padding requirements, though the endpoint MAY discard such

```suggestion
not meet size constraints, though the endpoint MAY discard such
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#pullrequestreview-512359586

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 20 Oct 2020 01:10:03 -0700

@kazuho pushed 1 commit.

3fce52c3e6633f9b231c76bc8b88fecaf6842461  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/a364f7d638459ca0c3b0b35fb6a57aecfc4f733d..3fce52c3e6633f9b231c76bc8b88fecaf6842461

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 20 Oct 2020 01:10:34 -0700

@kazuho pushed 1 commit.

49585a13f953f35d08b53e46d2f272b34e5efb18  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/3fce52c3e6633f9b231c76bc8b88fecaf6842461..49585a13f953f35d08b53e46d2f272b34e5efb18

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 20 Oct 2020 01:10:49 -0700

@kazuho pushed 1 commit.

db0065748b54228ac2ca98401331f936c1e90919  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/49585a13f953f35d08b53e46d2f272b34e5efb18..db0065748b54228ac2ca98401331f936c1e90919

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 20 Oct 2020 01:13:57 -0700

@kazuho pushed 1 commit.

353747da54f98792413e2b913f2859251ab13122  drop reference to packet coalescing, as suggested by @martinthomson

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/db0065748b54228ac2ca98401331f936c1e90919..353747da54f98792413e2b913f2859251ab13122

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 20 Oct 2020 01:15:25 -0700

Thank you for the review. I removed the callout in 353747d.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#discussion_r508298771

---

From: ianswett <[email-masked]>
Date: Tue, 20 Oct 2020 05:04:33 -0700

@ianswett approved this pull request.

> @@ -4085,6 +4085,11 @@ UDP datagrams MUST NOT be fragmented at the IP layer.  In IPv4
 
+Datagrams are required to be padded under some conditions.  However, the

One small suggestion.

```suggestion
Datagrams are required to be a minimum size under some conditions.  However, the
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#pullrequestreview-512630912

---

From: Martin Thomson <[email-masked]>
Date: Tue, 20 Oct 2020 07:32:13 -0700

@martinthomson pushed 1 commit.

f4e391a879586cb26d6f571558efa6d3a9fdade2  minimumumum

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/353747da54f98792413e2b913f2859251ab13122..f4e391a879586cb26d6f571558efa6d3a9fdade2

---

From: Marten Seemann <[email-masked]>
Date: Tue, 20 Oct 2020 09:55:18 -0700

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#pullrequestreview-512943485

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 20 Oct 2020 12:37:57 -0700

@janaiyengar pushed 1 commit.

bbb245b5a3ed4567f052caa413e7c4cfc296d91a  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254/files/f4e391a879586cb26d6f571558efa6d3a9fdade2..bbb245b5a3ed4567f052caa413e7c4cfc296d91a

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 20 Oct 2020 12:38:10 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#pullrequestreview-513070259

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 20 Oct 2020 13:11:11 -0700

Merged #4254 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#event-3900589736

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 20 Oct 2020 13:12:58 -0700

@larseggert @LPardue: Merging this, since the plan is to do consensus as part of LC.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4254#issuecomment-713111533