Subject: [quicwg/base-drafts] QPACK-18: Appendix B and Decoder confirming inserts (#4245)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 19 Oct 2020 06:57:59 -0700

Looking at Appendix B I wonder why isn't the decoder sending "Insert Count Increment" in B.4. Even if Stream 8 is cancelled, shouldn't the decoder actually acknowledge the received Encoder Stream message to do an duplicate by sending a "Insert Count Increment". I think the lack of such a message must at least be commented on? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245

---

From: afrind <[email-masked]>
Date: Mon, 19 Oct 2020 14:10:42 -0700

The example as written is not *incorrect*, since the decoder has the option to batch Insert Count Increments.  And further, there's no indication in the example that the Duplicate arrived at the decoder either.  But I agree that if that's the intent of the example, then there should be a comment to that effect...does anyone feel like one or the other is more illustrative? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712444117

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 19 Oct 2020 14:14:59 -0700

I think, in the interest if simplicity, don't overload example if you can avoid it. Batching seems like overloading to me.

If you're saying "the client cancelled before receiving the instruction" that seems clear to me and text to make that explicit could help

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712446113

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 19 Oct 2020 15:11:49 -0700

@gloinul does the PR address this issue?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712470519

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 20 Oct 2020 00:19:33 -0700

The PR provides the context for the cancellation. However, if I understand the spec correctly, you can't reneg on the encoder stream duplicate command. That is going to happen. And even if the count increase doesn't happen in B.4, why haven't it happen in B.5? I think the connection to B.5 state here is of relevance. As the examples are a seuqence, I would expect that the B.4 ends with a Insert Increment Count to acknowledge the duplication when that arrives. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712648481

---

From: Lars Eggert <[email-masked]>
Date: Tue, 20 Oct 2020 05:21:58 -0700

@afrind and @MikeBishop need to weigh in on this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712810157

---

From: Mike Bishop <[email-masked]>
Date: Tue, 20 Oct 2020 07:30:58 -0700

It's not reneged, just not yet acknowledged.  B.5 doesn't send any encoded field sections, so there's not a requirement to acknowledge.  However, it's probably a good idea to mention in B.5 that the delayed instruction has arrived, since otherwise the decoder won't have seen the newly-added field yet.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712896015

---

From: afrind <[email-masked]>
Date: Tue, 20 Oct 2020 08:53:55 -0700

Example B.5 doesn't make any assertions about what the decoder has seen or not seen -- all examples show the encoder's table only.  But I can update the PR to include that note.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712952715

---

From: Lars Eggert <[email-masked]>
Date: Tue, 20 Oct 2020 09:33:54 -0700

@gloinul are we ok on this one now? We'd like to merge the PR and close this.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712989067

---

From: Lars Eggert <[email-masked]>
Date: Tue, 20 Oct 2020 09:47:24 -0700

@afrind & @MikeBishop: if there is no reply from @gloinul in the next hour or so (it's evening in Europe) let's please merge the PR and assume the issue is resolved. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-712996913

---

From: afrind <[email-masked]>
Date: Tue, 20 Oct 2020 11:06:21 -0700

I'll merge as is without any changes to B5.  The text doesn't mention the decoder at all so I think it's clear enough as is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#issuecomment-713041155

---

From: afrind <[email-masked]>
Date: Tue, 20 Oct 2020 11:06:33 -0700

Closed #4245 via #4250.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4245#event-3900105765