Subject: [quicwg/base-drafts] Pseudo-headers can be negotiated (#4248)

From: Lucas Pardue <[email-masked]>
Date: Mon, 19 Oct 2020 11:41:56 -0700

Taken from @MikeBishop&#39;s suggestion on the list.

Fixes #4240 
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4248

-- Commit Summary --

  * Pseudo-headers can be negotiated

-- File Changes --

    M draft-ietf-quic-http.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4248.patch
https://github.com/quicwg/base-drafts/pull/4248.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4248

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 19 Oct 2020 12:37:20 -0700

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4248#pullrequestreview-512097469

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Oct 2020 13:45:01 -0700

@MikeBishop commented on this pull request.

> @@ -565,8 +565,8 @@ convey the target URI, the method of the request, and the status code for the
 response.
 
 Pseudo-header fields are not HTTP fields.  Endpoints MUST NOT generate
-pseudo-header fields other than those defined in this document, except as
-negotiated via an extension; see {{extensions}}.
+pseudo-header fields other than those defined in this document; however, an
+extension could negotiate a modification of this restriction; see {{extensions}}.

```suggestion
extension could negotiate a modification of this restriction; see
{{extensions}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4248#pullrequestreview-512144740

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Oct 2020 13:45:15 -0700

@MikeBishop pushed 1 commit.

f7b4476ee0792f73c44052e69640267ff5e4c4d0  Wrapping

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4248/files/5a9f2a29855c6929f5b5355581ac86fa9cb80496..f7b4476ee0792f73c44052e69640267ff5e4c4d0

---

From: Mike Bishop <[email-masked]>
Date: Mon, 19 Oct 2020 13:46:35 -0700

Merged #4248 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4248#event-3895451510