Subject: [quicwg/base-drafts] Initial Smoothed_RTT values (#4192)

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 07:43:36 -0700

In Section 5.3:

"When there are no samples for a network path, and on the first RTT sample for the network path:

smoothed_rtt = rtt_sample
rttvar = rtt_sample / 2

Before any RTT samples are available, the initial RTT is used as rtt_sample. On the first RTT sample for the network path, that sample is used as rtt_sample. This ensures that the first measurement erases the history of any persisted or default values."

First of all this text uses "rtt_sample" while other places with the exception of the pseudo code uses latest_rtt variable. There are two issues with that. First that the value of rtt_sample is state dependent. If there exist an latest_rtt then that is used, if not the initial rtt. As the initial RTT is defined in Section 6.2.2 I think a forward reference is in place. 

Finally, should this calculation in cases where latest_rtt exists be using min_ack_delay? 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4192

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 12 Oct 2020 08:41:32 -0700

I like to add that there are some structural issues in Section 6.2.1 and 6.2.2 where the initial value depends on both section. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4192#issuecomment-707196237

---

From: Lars Eggert <[email-masked]>
Date: Thu, 15 Oct 2020 04:16:55 -0700

Based on #4213, labeling this as "editorial"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4192#issuecomment-709209935

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:38:36 -0700

The PR resolves this issue. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4192#issuecomment-709290401

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 15 Oct 2020 19:56:53 +0000 (UTC)

Closed #4192 via #4213.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4192#event-3883332130