Subject: [quicwg/base-drafts] Don't refer to the Time Threshold Loss Detection Timer (#4222)

From: ianswett <[email-masked]>
Date: Thu, 15 Oct 2020 09:53:52 -0700

That term doesn&#39;t appear above, so don&#39;t use it in the PTO section.

Fixes #4193
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4222

-- Commit Summary --

  * Don&#39;t refer to the Time Threshold Loss Detection Timer

-- File Changes --

    M draft-ietf-quic-recovery.md (8)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4222.patch
https://github.com/quicwg/base-drafts/pull/4222.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 15 Oct 2020 13:36:05 -0700

@janaiyengar approved this pull request.

Editorial suggestion. I'm fine with merging this, but @gloinul should probably see if it addresses his issue.

> +({{time-threshold}}) loss detection.  Time threshold loss detection
+is expected to both expire earlier than the PTO and be less likely to
+spuriously retransmit data.

```suggestion
loss detection ({{time-threshold}}).  A timer that is set for time
threshold loss detection is expected to both expire earlier than
the PTO timer and be less likely to spuriously retransmit data.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222#pullrequestreview-509787864

---

From: ianswett <[email-masked]>
Date: Thu, 15 Oct 2020 15:18:23 -0700

@ianswett pushed 1 commit.

cb51821d0db98da09838879f586aa29e80b0b172  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222/files/ce7b16180676a31d72ea3da124adca730e3aeba4..cb51821d0db98da09838879f586aa29e80b0b172

---

From: Martin Thomson <[email-masked]>
Date: Thu, 15 Oct 2020 23:51:41 -0700

@martinthomson approved this pull request.

The second suggestion is a little risky, but avoids a slightly awkward construction.

> @@ -610,10 +610,10 @@ in the Handshake packet number space.
 The total length of time over which consecutive PTOs expire is limited by the
 idle timeout.
 
-The probe timer MUST NOT be set if the time threshold ({{time-threshold}}) loss
-detection timer is set.  The time threshold loss detection timer is expected
-to both expire earlier than the PTO and be less likely to spuriously retransmit
-data.
+The PTO timer MUST NOT be set if a timer is set for time threshold
+loss detection ({{time-threshold}}).  A timer that is set for time

```suggestion
loss detection; see {{time-threshold}}.  A timer that is set for time
```

> +threshold loss detection is expected to both expire earlier than
+the PTO timer and be less likely to spuriously retransmit data.

```suggestion
threshold loss detection will expire earlier than the PTO timer
in many cases and is less likely to spuriously retransmit data.
```

I think that this is accurate: the time threshold mostly fires earlier, but if it does fire, then it will select the data that is most likely to be lost for retransmission.  PTO logic for selecting what to send is far less precise.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222#pullrequestreview-510195415

---

From: ianswett <[email-masked]>
Date: Fri, 16 Oct 2020 11:26:09 -0700

a5d1222f710b2cf0b1cd0a4b07585f1d1efe37b7  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222/files/cb51821d0db98da09838879f586aa29e80b0b172..a5d1222f710b2cf0b1cd0a4b07585f1d1efe37b7

---

From: ianswett <[email-masked]>
Date: Fri, 16 Oct 2020 11:26:50 -0700

37e5917ffe14ded49cf806f84a4e90e0f2b0339c  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222/files/a5d1222f710b2cf0b1cd0a4b07585f1d1efe37b7..37e5917ffe14ded49cf806f84a4e90e0f2b0339c

---

From: ianswett <[email-masked]>
Date: Fri, 16 Oct 2020 11:27:12 -0700

6d453f70fce302e3dceb6ed19995dd9f687bcb8f  Update draft-ietf-quic-recovery.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222/files/37e5917ffe14ded49cf806f84a4e90e0f2b0339c..6d453f70fce302e3dceb6ed19995dd9f687bcb8f

---

From: ianswett <[email-masked]>
Date: Fri, 16 Oct 2020 11:27:50 -0700

Thanks @martinthomson I took your suggestions with one tweak.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222#issuecomment-710379638

---

From: Magnus Westerlund <[email-masked]>
Date: Mon, 19 Oct 2020 23:33:28 -0700

@gloinul approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222#pullrequestreview-512369608

---

From: ianswett <[email-masked]>
Date: Tue, 20 Oct 2020 05:48:13 -0700

Merged #4222 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4222#event-3898505709