Subject: [quicwg/base-drafts] What's an HTTP/3 connection? (#4212)

From: Mike Bishop <[email-masked]>
Date: Wed, 14 Oct 2020 07:30:40 -0700

Fixes #4206.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4212

-- Commit Summary --

  * What&#39;s an HTTP/3 connection?

-- File Changes --

    M draft-ietf-quic-http.md (3)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4212.patch
https://github.com/quicwg/base-drafts/pull/4212.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 14 Oct 2020 07:46:50 -0700

@LPardue commented on this pull request.

> @@ -241,6 +241,9 @@ frame:
   frames."  References without this preface refer to frames defined in
   {{frames}}.
 
+HTTP/3 connection:
+: A QUIC connection where the negotiated application protocol is HTTP/3.

```suggestion
: A QUIC connection where the selected application protocol is HTTP/3.
```

make it more consistent with the notion of H3 selection in #4211

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#pullrequestreview-508427311

---

From: ianswett <[email-masked]>
Date: Wed, 14 Oct 2020 09:53:26 -0700

@ianswett approved this pull request.

+HTTP/3 connection:

Huh, I always thought negotiated was preferred since we're using ALPN?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#pullrequestreview-508545252

---

From: Lucas Pardue <[email-masked]>
Date: Wed, 14 Oct 2020 10:01:13 -0700

+HTTP/3 connection:

The spec also says that other methods of selecting H3 are possible. And if we're speaking generically, then that might not be a negotiation. But I'll let Mike make the editorial decision here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#discussion_r504833986

---

From: Martin Thomson <[email-masked]>
Date: Wed, 14 Oct 2020 14:40:25 -0700

@martinthomson approved this pull request.

+HTTP/3 connection:

Either works; but as ALPN involves a server selection and the N stands for negotiation, I don't think it matters.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#pullrequestreview-508782879

---

From: Magnus Westerlund <[email-masked]>
Date: Thu, 15 Oct 2020 05:21:19 -0700

@gloinul commented on this pull request.

As I said in the Issue there likely need to be a review of the 200+ times the word "connection" is used in the document to determine if one need to stress that it is the HTTP/3 connection or some other connection. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#pullrequestreview-509317341

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:26:44 -0700

@MikeBishop pushed 1 commit.

2530b985bfd8921e000eeba128be23e0c4fbcae4  Say 'HTTP/3' a whole lot more

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212/files/38c00cfb4e2b2ca1b91a53f79add830437aa2fdd..2530b985bfd8921e000eeba128be23e0c4fbcae4

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:31:01 -0700

@MikeBishop pushed 0 commits.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212/files/2530b985bfd8921e000eeba128be23e0c4fbcae4..38c00cfb4e2b2ca1b91a53f79add830437aa2fdd

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:47:47 -0700

dae7b75efb64a59d827fdea22286f730073aa788  Say 'HTTP/3' a whole lot more

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212/files/38c00cfb4e2b2ca1b91a53f79add830437aa2fdd..dae7b75efb64a59d827fdea22286f730073aa788

---

From: Mike Bishop <[email-masked]>
Date: Thu, 15 Oct 2020 13:48:58 -0700

@MikeBishop commented on this pull request.

+HTTP/3 connection:

I'm inclined toward keeping negotiation here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#discussion_r505836087

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 15 Oct 2020 14:00:34 -0700

@janaiyengar approved this pull request.

a couple of suggestions

> @@ -1052,7 +1057,7 @@ the server.  For more detail on QUIC streams, see Section 2 of
 When HTTP fields and data are sent over QUIC, the QUIC layer handles most of
 the stream management.  HTTP does not need to do any separate multiplexing when
 using QUIC - data sent over a QUIC stream always maps to a particular HTTP
-transaction or connection context.
+transaction or to the HTTP/3 connection context as a whole.

suggestion:
```suggestion
transaction or to the entire HTTP/3 connection context.
```

> @@ -1561,8 +1567,8 @@ type H3_ID_ERROR.
 In the client to server direction, the GOAWAY frame carries a Push ID encoded as
 a variable-length integer.
 
-The GOAWAY frame applies to the connection, not a specific stream.  A client
-MUST treat a GOAWAY frame on a stream other than the control stream as a
+The GOAWAY frame applies to the connection as a whole, not a specific stream.  A

```suggestion
The GOAWAY frame applies to the entire connection, not a specific stream.  A
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#pullrequestreview-509800359

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Oct 2020 06:58:37 -0700

043e1b80d78e4809ba78a848cfded694c1784b95  Apply suggestions from code review

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212/files/dae7b75efb64a59d827fdea22286f730073aa788..043e1b80d78e4809ba78a848cfded694c1784b95

---

From: Mike Bishop <[email-masked]>
Date: Fri, 16 Oct 2020 08:35:27 -0700

Merged #4212 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4212#event-3886998449