Subject: [quicwg/base-drafts] Privacy wrt reused connections (#4363)

From: Lars Eggert <[email-masked]>
Date: Mon, 16 Nov 2020 21:26:55 -0800

Hilarie Orman wrote:
> Similarly, there is brief
mention of privacy wrt reused connections in 10.11, but that is
weak beer, simply saying that HTTP 3 prefers not to reuse connections.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4363

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Nov 2020 15:40:53 -0800

It doesn't even say that it prefers not to reuse.  It notes an explicit preference *to* reuse connections, but that's a privacy choice that clients will need to manage the trade-off for.  Individual implementations can be as aggressive about reuse or as aggressive about privacy as they want.  All this section is attempting to do is point out the trade-off.

I'm inclined to do nothing, but would welcome text suggestions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4363#issuecomment-733296032

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 15:41:00 -0800

Given this is not any different in terms of privacy considerations as compared to h2, and unless someone can propose text that is stronger, I'm inclined to say that we leave it as is. There's not much more we can _do_ about the privacy issue here besides noting it.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4363#issuecomment-733296062

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 24 Nov 2020 15:42:17 -0800

The text is almost word-for-wrod what is present in HTTP/2 https://tools.ietf.org/html/rfc7540#section-10.8. I'm happyto leave this as is.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4363#issuecomment-733296852