Subject: Re: [quicwg/base-drafts] Add a definition for "frame" (#4313)

From: Mike Bishop <[email-masked]>
Date: Mon, 02 Nov 2020 06:33:56 -0800

@MikeBishop commented on this pull request.

> +: A unit of structured protocol information.  There are multiple frame types,
+  each of which carries different information.  Frames are conveyed in QUIC

I agree; that's too detailed for the definitions list.  I think the furthest I'd go is to say there are multiple types of frames, but I'm not sure we need even that.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4313#discussion_r516011947

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 03 Nov 2020 15:13:34 -0800

@janaiyengar commented on this pull request.

> +QUIC packet:
+
+: A complete processable unit of QUIC that can be encapsulated in a UDP
+  datagram.  One or more QUIC packets can be encapsulated in a single UDP
+  datagram.
+
+Ack-eliciting Packet:
+
+: A QUIC packet that contains frames other than ACK, PADDING, and
+  CONNECTION_CLOSE. These cause a recipient to send an acknowledgment; see
+  {{sending-acknowledgements}}.
+
+Frame:
+
+: A unit of structured protocol information.  There are multiple frame types,
+  each of which carries different information.  Frames are conveyed in QUIC

```suggestion
  each of which carries different information.  Frames are contained in QUIC
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4313#pullrequestreview-522941393

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Nov 2020 15:13:47 -0800

@martinthomson commented on this pull request.

+

```suggestion

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4313#pullrequestreview-522941469

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Nov 2020 15:14:03 -0800

@martinthomson pushed 1 commit.

b26c0a20718b6550eee21dfd5104726c21f5e5a7  s/veyed/tained/

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4313/files/7b7523e05c9f9ddd71e23465d260b78b112973f5..b26c0a20718b6550eee21dfd5104726c21f5e5a7

---

From: Martin Thomson <[email-masked]>
Date: Tue, 03 Nov 2020 15:14:26 -0800

Merged #4313 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4313#event-3955160799