Subject: [quicwg/base-drafts] transport: error connection of what (#4347)

From: Kazu Yamamoto <[email-masked]>
Date: Tue, 10 Nov 2020 17:07:30 -0800

I'm checking "MUST treat" in the transport draft. Sec 17.2.4 says:

> Handshake packets MAY contain CONNECTION_CLOSE frames of type 0x1c. Endpoints MUST treat receipt of Handshake packets with other frames as a connection error.

This is only the place where the type of a connection error is NOT specified. This part should be modified as "a connection error of XXX".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4347

---

From: Martin Thomson <[email-masked]>
Date: Tue, 10 Nov 2020 18:04:35 -0800

This was deliberate, but you can now send CONNECTION_CLOSE in this case, so it makes sense to use a code here. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4347#issuecomment-725080444

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 17 Nov 2020 21:01:42 -0800

Closed #4347 via #4390.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4347#event-4008744309