Subject: [quicwg/base-drafts] Add an error code for when the path fails (#4331)

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Nov 2020 18:56:59 -0800

This is a bit of a niche code, as it is only narrowly useful for
signaling loss of paths.  But people wanted it and it doesn&#39;t code that
much.

Note the target of this pull request.

For #4257.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4331

-- Commit Summary --

  * Add an error code for when the path fails

-- File Changes --

    M draft-ietf-quic-transport.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4331.patch
https://github.com/quicwg/base-drafts/pull/4331.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 04 Nov 2020 19:15:33 -0800

@janaiyengar approved this pull request.

one suggestion, but lgtm

> @@ -2311,7 +2311,9 @@ When an endpoint abandons path validation, it determines that the path is
 unusable.  This does not necessarily imply a failure of the connection -
 endpoints can continue sending packets over other paths as appropriate.  If no
 paths are available, an endpoint can wait for a new path to become available or
-close the connection.
+close the connection.  An endpoint that has no valid network path to its peer
+MAY signal this using the NO_VIABLE_PATH connection error, noting that this is
+only possible if the network has a limited MTU.

```suggestion
only possible if the network path exists but does not support the required
MTU {{datagram-size}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331#pullrequestreview-523896853

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Nov 2020 19:18:43 -0800

@martinthomson pushed 1 commit.

352797227bdd9e6228c296707c97aeff4abc8e00  moar

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331/files/4769dbea68fe7bfdc70a70d64f141f58f0a4c7f3..352797227bdd9e6228c296707c97aeff4abc8e00

---

From: Martin Thomson <[email-masked]>
Date: Wed, 04 Nov 2020 19:19:15 -0800

I'm going to leave this for a bit, but if people like the idea, I plan to merge it into #4264.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331#issuecomment-722115608

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 05 Nov 2020 00:37:35 -0800

@kazuho approved this pull request.

Thank you for the PR.

This error code will be useful, as the only other way of closing the connection would be to use NO_ERROR. Then, it would be impossible to know why the connection was abruptly closed.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331#pullrequestreview-524027475

---

From: Mike Bishop <[email-masked]>
Date: Thu, 05 Nov 2020 07:34:35 -0800

@MikeBishop approved this pull request.

Yes, there's value in having a way to fail fast.

> @@ -6411,6 +6414,12 @@ AEAD_LIMIT_REACHED (0xf):
 : An endpoint has reached the confidentiality or integrity limit for the AEAD
   algorithm used by the given connection.
 
+NO_VIABLE_PATH (0x10):
+
+: An endpoint has determined that the network path is incapable of supporting
+  QUIC.  An endpoint is unlikely to receive CONNECTION_CLOSE carrying this code
+  unless the reason is to do the path not supporting a large enough MTU.

```suggestion
  except when the path does not support a large enough MTU.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331#pullrequestreview-524384698

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Nov 2020 14:37:59 -0800

2ffb2abe1ad95f333f7d1b52d125644760fc06c0  Fewer words = good

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331/files/352797227bdd9e6228c296707c97aeff4abc8e00..2ffb2abe1ad95f333f7d1b52d125644760fc06c0

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Nov 2020 14:38:09 -0800

Merged #4331 into migration-amplification.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4331#event-3964692196