Subject: [quicwg/base-drafts] Not all registries have stricter rules (#4388)

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 15:58:55 -0800

Closes #4385.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4388

-- Commit Summary --

  * Not all registries have stricter rules

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4388.patch
https://github.com/quicwg/base-drafts/pull/4388.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4388

---

From: Magnus Westerlund <[email-masked]>
Date: Tue, 17 Nov 2020 21:08:42 -0800

@gloinul commented on this pull request.

> @@ -7328,12 +7328,12 @@ permanent registrations.
 
 The creation of a registry MAY identify a range of codepoints where
 registrations are governed by a different registration policy.  For instance,
-the registries for 62-bit codepoints in this document have stricter policies for
-codepoints in the range from 0 to 63.
+the frame type registry in {{iana-frames}} has a stricter policy for codepoints

The transport error also have this range, but then have an additional range so I think this text need tweaking. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4388#pullrequestreview-533107718

---

From: Martin Thomson <[email-masked]>
Date: Wed, 18 Nov 2020 02:58:37 -0800

@martinthomson commented on this pull request.

Not sure that I follow.  Frame types have a stricter policy for 0..=63.  I don't see why would need to talk about the other ~2^62 values.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4388#discussion_r525995683

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 20 Nov 2020 17:22:47 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4388#pullrequestreview-535866587

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 15:02:45 -0800

@janaiyengar commented on this pull request.

I agree. @gloinul ?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4388#discussion_r529977657