Subject: [quicwg/base-drafts] IANA review of -http; question 2 (#4372)

From: Lars Eggert <[email-masked]>
Date: Mon, 16 Nov 2020 21:56:40 -0800

Please see the [review email](https://mailarchive.ietf.org/arch/msg/quic/2A76lPm7A86Aeu-6Y2mZyxB0Qtw) for full context. This issue is tracking the following IANA question:
> Second, a new registry is to be created called the HTTP/3 Frame Type registry. The registry will be created on a registry page to be decided as a result of the answer to the question from IANA above.
>
>IANA will add a note to the registry indicating that: " each code of the format "0x1f * N + 0x21" for non-negative integer values of N (that is, 0x21, 0x40, ..., through 0x3FFFFFFFFFFFFFFE) are reserved."
>
>IANA Question --> are those values to be marked as reserved in the new registry?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4372

---

From: Mike Bishop <[email-masked]>
Date: Tue, 17 Nov 2020 01:44:46 -0800

Copying my e-mail reply here:

> With regard to the GREASE values (the questions below), we specifically did not want the values shown as Reserved for two different reasons.  First, as a practical matter, 148 quadrillion reserved entries would be difficult to list on the page and will drown any actual reservations.  Second, the point of these values is that an implementer should be following the guidance to ignore 
unknown values; having an explicit list encourages an explicitly defined reaction.
>
> The intent, which we wanted to confirm was possible, was simply to say that IANA should not accept registrations for these values.  That feels functionally equivalent to Reserved; if it's possible to be "reserved but not listed," that's a reasonable implementation.  If it's necessary to have the note present, I prefer the "will not be assigned by IANA" language you've used for the Error Code registry over noting them as Reserved.

This also applies to #4373 and #4374, where the latter has better wording.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4372#issuecomment-728812435