Subject: Re: [quicwg/base-drafts] Say we have a maximum data size (#4288)

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Nov 2020 15:02:46 -0800

Proposing no action here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4288#issuecomment-722694957

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 06 Nov 2020 17:51:42 -0800

I don't think we can come up with a maximum data limit, since:
- packet numbers apply to packets, not to bytes (unlike in TCP)
- each packet is sized based on MTU,
- even theoretically, there are various control frames that need to be sent for protocol operation, which take away from any byte limit that we come up with.

I expect that we can do an approximate maximum (2^62 * MTU = 4.6 * 10^18 * MTU), which will have no practical value to an application.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4288#issuecomment-723372159