Subject: [quicwg/base-drafts] HTTP/3 stream types and extensibility (#4358)

From: Lucas Pardue <[email-masked]>
Date: Sun, 15 Nov 2020 10:54:59 -0800

In the HTTP genart review, @theri writes:

> Section 6.2
> 
> "However, stream types that could modify the state or
>    semantics of existing protocol components, including QPACK or other
>    extensions, MUST NOT be sent until the peer is known to support them."
> Is there a defined list of stream types that are not allowed to be used? If so,
> please provide a reference.
> 
> Is section 6 missing the request stream? It has subsections for Control Streams
> and Push Streams, but then Section 7 says that Request Stream is also a stream
> type.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4358

---

From: Mike Bishop <[email-masked]>
Date: Sun, 15 Nov 2020 11:55:37 -0800

Request streams are all client-initiated bidirectional streams, so they're not defined as a unidirectional stream type.  It's probably worth defining the term somewhere, though.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4358#issuecomment-727626718

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 17 Nov 2020 05:13:17 -0800

I agree with this review, "stream type" is used unqualified across section 6.2 and 7

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4358#issuecomment-728918070