Subject: [quicwg/base-drafts] Is HTTP CONNECT always TCP? (#4356)

From: Lucas Pardue <[email-masked]>
Date: Sun, 15 Nov 2020 10:53:47 -0800

In the HTTP genart review, @theri writes:

> Section 4.2
> 
> "A proxy that supports CONNECT establishes a TCP connection […]"
> Is this necessarily always TCP, not QUIC? Can this change in the future?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4356

---

From: David Schinazi <[email-masked]>
Date: Sun, 15 Nov 2020 11:47:28 -0800

Yes, CONNECT only supports TCP, and there's no short-term plan to change that. There is separate relevant work such as [CONNECT-UDP](https://tools.ietf.org/html/draft-ietf-masque-connect-udp) but I don't think we need to change anything in the draft here - it pretty clearly mentions TCP so I don't see any ambiguity.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4356#issuecomment-727625744

---

From: Mike Bishop <[email-masked]>
Date: Sun, 15 Nov 2020 11:53:57 -0800

This question should be addressed by the definition of CONNECT the spec is referring to.  It's worth double-checking the references in that section, though; it points to HTTP11, when I think there should be a definition in SEMANTICS.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4356#issuecomment-727626496

---

From: Mike Bishop <[email-masked]>
Date: Wed, 18 Nov 2020 01:05:42 -0800

Closed #4356 via #4383.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4356#event-4009548626