Subject: [quicwg/base-drafts] Clarify datagram size authentication a bit (#4342)

From: Jana Iyengar <[email-masked]>
Date: Fri, 06 Nov 2020 19:00:32 -0800

Fixes #4273.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4342

-- Commit Summary --

  * attempt to clarify

-- File Changes --

    M draft-ietf-quic-transport.md (10)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4342.patch
https://github.com/quicwg/base-drafts/pull/4342.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342

---

From: Kazuho Oku <[email-masked]>
Date: Fri, 06 Nov 2020 23:54:38 -0800

@kazuho commented on this pull request.

> @@ -4127,10 +4127,12 @@ UDP datagrams MUST NOT be fragmented at the IP layer.  In IPv4
 ({{!IPv4=RFC0791}}), the DF bit MUST be set if possible, to prevent
 fragmentation on the path.
 
-Datagrams are required to be of a minimum size under some conditions.  However,
-the size of the datagram is not authenticated.  Therefore, an endpoint MUST NOT
-close a connection when it receives a datagram that does not meet size
-constraints, though the endpoint MAY discard such datagrams.
+QUIC sometimes requires datagrams to be larger than a minimum size; see
+{{version-negotiation}} as an example. However, the size of a datagram is not

I think this sentence is incorrect. The intent of the paragraph is to state that receivers MUST NOT close a connection when it receives a datagram of X bytes carrying a QUIC packet, and if that QUIC packet being carried is required to be sent in a datagram of more htan X bytes.

So maybe something like: _QUIC sometimes requires datagrams to be no smaller than certain size; see {{validate-handshake}} as an example._

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#pullrequestreview-525635969

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Nov 2020 01:16:31 -0800

@martinthomson commented on this pull request.

Or "at least"

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#discussion_r519311047

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Nov 2020 01:17:25 -0800

@martinthomson approved this pull request.

Other than kazuho's nit  which I regard as minor, this is good. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#pullrequestreview-525789108

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 08 Nov 2020 16:14:42 -0800

@janaiyengar pushed 1 commit.

ade0b033ad81cbd832185871a5bb56dbc844dc34  no smaller than

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342/files/177fe0d7087e1d78fafcab4c9236c6c933822797..ade0b033ad81cbd832185871a5bb56dbc844dc34

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 08 Nov 2020 16:26:01 -0800

Merged #4342 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#event-3971344440

---

From: Kazuho Oku <[email-masked]>
Date: Sun, 08 Nov 2020 16:27:47 -0800

@janaiyengar I think you missed the change proposed to the reference. It should point to somewhere that imposes minimum datagram size (e.g., {{validate-handshake}}, not {{version-negotiation}}).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#issuecomment-723690847

---

From: Jana Iyengar <[email-masked]>
Date: Sun, 08 Nov 2020 16:35:24 -0800

Urgh. Thanks for catching that, @kazuho. #4343 sent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4342#issuecomment-723692739