Subject: [quicwg/base-drafts] Reserve fewer codepoints for greasing (#4387)

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 15:50:41 -0800

I just sent [an email](https://mailarchive.ietf.org/arch/msg/quic/0wt2N8v7GHX_6vRRRH2uSy4T4LE/) suggesting that we adopt a different formula to the one we currently use for identifying grease codepoints.

The current formula, `27+31N` takes a lot of codepoints.  This means that if someone deploys real code that depends on this value, the odds of a collision between that usage and real grease might be too low.  A different scheme with a higher risk of collision might avoid accidents that might ultimately render greasing ineffective.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4387

---

From: Lucas Pardue <[email-masked]>
Date: Tue, 24 Nov 2020 15:56:46 -0800

I believe this would require a design change. I've not seen enough support yet to take it on board as a design issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4387#issuecomment-733316582

---

From: Christian Huitema <[email-masked]>
Date: Tue, 24 Nov 2020 16:23:33 -0800

I wonder whether changing the formula would make any practical difference. One of the motivations for Martin's message is pushback from IANA, who apparently are not too happy about having to check a formula during the registration process. But replacing the formula by a different one would not be a big relief for IANA. We also don't want to just declare ranges of code point used only for greasing, because that would defeat the idea of greasing.

I think the simplest solution is to not change the formula, but place the onus of checking it to the registrant instead of IANA. For example, if a registrant is foolish enough to ask for codepoint number 3127, IANA will just assign it, but the registration will not have much value.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4387#issuecomment-733353157

---

From: ianswett <[email-masked]>
Date: Tue, 24 Nov 2020 17:43:15 -0800

Lower odds of collision are a mixed blessing.

One modification to consider is making N >= 2, since that leaves all the 1 byte codepoints unused, and those are particularly valuable.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4387#issuecomment-733408588