Subject: Re: [quicwg/base-drafts] Reclaiming is very hard (#4275)

From: StewartBryant <[email-masked]>
Date: Mon, 02 Nov 2020 03:46:51 -0800

Given that you do not think it is likely to be used, and given that in MPLS we tried this and found it to be very hard, why not remove the text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4275#issuecomment-720422838

---

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Nov 2020 15:04:38 -0800

We have been successful in recovering the port number that this protocol uses.  So we have a clear example of where reclamation was successful and useful.

That was made much harder due to a lack of an understanding about reclamation.  Being clear up front should help avoid problems.

Proposing no action here.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4275#issuecomment-722695651

---

From: StewartBryant <[email-masked]>
Date: Fri, 06 Nov 2020 01:22:44 -0800

On 5 Nov 2020, at 23:04, Martin Thomson <[email-masked]<mailto:[email-masked]>> wrote:

The degree of difficulty depends on the scale of heterogeneous implementations and the scale of deployment.

Leave the text in if you wish, we will see what happens.

In MPLS we wanted to reclaim a reserved label. There are only 16 of them and so they are valuable. We had one that was barely deployed and was in disuse that we wanted to repurpose., Although we tried hard we were unable to reclaim it.

Stewart

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4275#issuecomment-722973019

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 06 Nov 2020 18:31:48 -0800

We have far more values, so in practice this should not be an issue. I agree that we don't want to close out the possibility of reclaiming.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4275#issuecomment-723377203