Subject: [quicwg/base-drafts] A zero-length connection ID is always good (#4335)

From: Martin Thomson <[email-masked]>
Date: Thu, 05 Nov 2020 01:23:17 -0800

For all packets.  For all network paths.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4335

-- Commit Summary --

  * A zero-length connection ID is always good

-- File Changes --

    M draft-ietf-quic-transport.md (5)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4335.patch
https://github.com/quicwg/base-drafts/pull/4335.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335

---

From: Marten Seemann <[email-masked]>
Date: Thu, 05 Nov 2020 03:37:04 -0800

@marten-seemann approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-524174153

---

From: Mike Bishop <[email-masked]>
Date: Thu, 05 Nov 2020 07:36:10 -0800

@MikeBishop approved this pull request.

Yes, good to call out this implicit exception.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-524387423

---

From: Nick Banks <[email-masked]>
Date: Thu, 05 Nov 2020 08:02:23 -0800

@nibanks approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-524414393

---

From: David Schinazi <[email-masked]>
Date: Thu, 05 Nov 2020 09:30:49 -0800

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-524498672

---

From: ianswett <[email-masked]>
Date: Fri, 06 Nov 2020 03:56:51 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-525087819

---

From: ianswett <[email-masked]>
Date: Fri, 06 Nov 2020 03:57:52 -0800

@ianswett commented on this pull request.

> @@ -1163,6 +1163,11 @@ SHOULD ensure that the pool of connection IDs available to its peer allows the
 peer to use a new connection ID on migration, as the peer will be unable to
 respond if the pool is exhausted.
 
+An endpoint that selects a zero-length connection ID during the handshake
+cannot send a NEW_CONNECTION_ID frame.  A zero-length Destination Connection ID
+field is used for all packets sent toward such an endpoint and for all network
+paths.

I think it makes sense to clarify that the scope is for that connection in the second sentence.

```suggestion
paths for the remainder of the connection.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-525088499

---

From: Jana Iyengar <[email-masked]>
Date: Fri, 06 Nov 2020 16:38:51 -0800

@janaiyengar commented on this pull request.

couple of minor comments

```suggestion
cannot issue a new connection ID.  A zero-length Destination Connection ID
```

```suggestion
field is used in all packets sent toward such an endpoint over any network
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-525570116

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Nov 2020 22:10:58 -0800

@martinthomson commented on this pull request.

```suggestion
path.
```
For Jana's suggestions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-525946046

---

From: Martin Thomson <[email-masked]>
Date: Sun, 08 Nov 2020 22:11:30 -0800

@martinthomson pushed 1 commit.

4b93601fe20281bcd25d078ed5b197aa45657006  issuance, for all paths or any path

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335/files/bce5cb24c97df4f4c311e9a75fe5513bdb4368a7..4b93601fe20281bcd25d078ed5b197aa45657006

---

From: ianswett <[email-masked]>
Date: Sun, 08 Nov 2020 23:11:09 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-525970425

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 09 Nov 2020 00:09:37 -0800

@kazuho approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-526006549

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 09 Nov 2020 20:45:49 -0800

Merged #4335 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#event-3976948101