Subject: [quicwg/base-drafts] Clarify that short headers and 1-RTT are 1:1 (#4407)

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 16:21:19 -0800

Fixes #4397.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4407

-- Commit Summary --

  * Clarify that short headers and 1-RTT are 1:1
  * move text

-- File Changes --

    M draft-ietf-quic-transport.md (12)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4407.patch
https://github.com/quicwg/base-drafts/pull/4407.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 16:25:25 -0800

@janaiyengar pushed 1 commit.

5ea7d5de2448d0b5461e29fc3738a3b898ebc12e  s/are/can be

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407/files/c4f0f102dc53fb27c24f55297920af06c7f97f6c..5ea7d5de2448d0b5461e29fc3738a3b898ebc12e

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Nov 2020 16:25:30 -0800

@MikeBishop commented on this pull request.

> +This version of QUIC uses a short packet header for only 1-RTT
+packets. Additionally, 1-RTT packets in this version of QUIC can only use a
+short packet header

```suggestion
This version of QUIC only uses short packet headers for 1-RTT
packets. 1-RTT keys in this version of QUIC are only used with
short packet headers.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#pullrequestreview-538069281

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 16:56:12 -0800

fc3a207c066b0073a7cee721c38d75808839c90d  structural changes to short-header packet format section

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407/files/5ea7d5de2448d0b5461e29fc3738a3b898ebc12e..fc3a207c066b0073a7cee721c38d75808839c90d

---

From: Mike Bishop <[email-masked]>
Date: Tue, 24 Nov 2020 17:00:52 -0800

@MikeBishop approved this pull request.

This looks good.  The actual changes are much smaller than the diff appears, and I think the symmetry with 17.2 helps readability despite the extra layer.

> @@ -4974,11 +4973,15 @@ in {{cid-auth}}.
 
 ## Short Header Packets {#short-header}
 
-This version of QUIC defines a single packet type that uses the
-short packet header.
+This version of QUIC defines a single packet type that uses the short packet
+header.
+
+### 1-RTT Packet {#packet-1-rtt}
+
+1-RTT packets in this version of QUIC use a short packet header.

```suggestion
1-RTT packets use a short packet header.  They are used after the version
and 1-RTT keys are negotiated.
```

For parallelism with how 17.2.x phrases these.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#pullrequestreview-538080237

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 17:03:16 -0800

0debdfe3d77923c75b7fec5418cd8de07c7e1375  Update draft-ietf-quic-transport.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407/files/fc3a207c066b0073a7cee721c38d75808839c90d..0debdfe3d77923c75b7fec5418cd8de07c7e1375

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 24 Nov 2020 17:11:11 -0800

3bbe314b8396e8d9039d32e428265d00c2e00ee9  more formatting

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407/files/0debdfe3d77923c75b7fec5418cd8de07c7e1375..3bbe314b8396e8d9039d32e428265d00c2e00ee9

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 25 Nov 2020 01:08:32 -0800

@kazuho approved this pull request.

Thank you @janaiyengar. This LGTM.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#pullrequestreview-538285269

---

From: Kazuho Oku <[email-masked]>
Date: Wed, 25 Nov 2020 03:06:20 -0800

@kazuho commented on this pull request.

Update: I think we might want to make corresponding changes to the TLS draft.

Re TLS draft, I think we can replace all the occurrences of "short header packet(s)", "packet(s) with (a) short header" in the TLS draft with "1-RTT", as well as table 1.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#pullrequestreview-538385437

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 25 Nov 2020 16:49:33 -0800

fd902e545a29a768e1794d00c42619a7f196fc04  fix in tls

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407/files/3bbe314b8396e8d9039d32e428265d00c2e00ee9..fd902e545a29a768e1794d00c42619a7f196fc04

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 25 Nov 2020 16:52:02 -0800

@kazuho: Thanks for the note. I've updated the tls doc, but I've not replaced all uses of `short header`. I've retained it where it is used alongside `long header`, for symmetry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#issuecomment-734012143

---

From: ianswett <[email-masked]>
Date: Sun, 29 Nov 2020 12:23:14 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4407#pullrequestreview-540513285