Subject: [quicwg/base-drafts] Removing bytes from flight is a bit confusing (#4408)

From: ianswett <[email-masked]>
Date: Tue, 24 Nov 2020 18:09:03 -0800

Timo Völker thought the psuedocode was incorrect, because it always subtracted sent_bytes from bytes_in_flight when the packet was in acked_packets.  However, this works because bytes_sent is only set to a non-zero value if the packet is in_flight.

This is likely overly subtle, and there are a few possible changes to clarify the existing pseudocode.  Given in_flight is already a field being set, I think using it makes the most sense.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4408

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 25 Nov 2020 16:09:12 -0800

Closed #4408 via #4409.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4408#event-4040244190