Subject: [quicwg/base-drafts] Discarding an invalid Initial is allowed (#4359)

From: Martin Thomson <[email-masked]>
Date: Mon, 16 Nov 2020 14:45:05 -0800

But we managed to hide that in the security considerations.

Closes #4350.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4359

-- Commit Summary --

  * Discarding an invalid Initial is allowed

-- File Changes --

    M draft-ietf-quic-transport.md (6)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4359.patch
https://github.com/quicwg/base-drafts/pull/4359.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359

---

From: ianswett <[email-masked]>
Date: Mon, 16 Nov 2020 15:11:37 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#pullrequestreview-531893909

---

From: Kazuho Oku <[email-masked]>
Date: Mon, 16 Nov 2020 17:28:15 -0800

@kazuho approved this pull request.

LGTM. Regarding the MUST clause for the two bits, adding "unless stated otherwise" works for me too.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#pullrequestreview-531954482

---

From: David Schinazi <[email-masked]>
Date: Mon, 16 Nov 2020 17:29:13 -0800

@DavidSchinazi approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#pullrequestreview-531954835

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 16 Nov 2020 22:37:22 -0800

This PR is fine, but I agree with @huitema above. I think we should add the exception and a reference to this text in 17.2.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#issuecomment-728720281

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 13:26:43 -0800

How many other rules do we need to create exemptions for?  What if the Initial contains a bad frame?  What if the CRYPTO frame is too long?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#issuecomment-729223862

---

From: Christian Huitema <[email-masked]>
Date: Tue, 17 Nov 2020 13:48:04 -0800

If you don't want to have the discussion about exceptions, then write SHOULD instead of MUST.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#issuecomment-729233902

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 16:12:14 -0800

@martinthomson pushed 1 commit.

570ab07f134812e70b56a9c5900a1db98ba867ab  This overrides other requirements

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359/files/63f88b2b6e50acb3dd083d1ca55baec88021895e..570ab07f134812e70b56a9c5900a1db98ba867ab

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 16:13:05 -0800

I don't want to go to SHOULD.  Because for other packet types, MUST is what we want.  And finding and creating exceptions is impossible.  So I have added a "this permission overrides rules that mandate a connection error".

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#issuecomment-729291220

---

From: Kazuho Oku <[email-masked]>
Date: Tue, 17 Nov 2020 16:21:41 -0800

I think what @martinthomson says makes sense. This is a "MUST unless" however we cannot have that stated at every point. Having a catch-all statement makes sense.

I tend to wonder if the catch-all statement should be in the Protected Packets section or in the Error Handling section, but the PR looks good regardless.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#pullrequestreview-532919551

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 16:28:13 -0800

79e0514de77260009c7d25c945a4ec56266b259c  Move to Connection Error section

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359/files/570ab07f134812e70b56a9c5900a1db98ba867ab..79e0514de77260009c7d25c945a4ec56266b259c

---

From: Martin Thomson <[email-masked]>
Date: Tue, 17 Nov 2020 16:28:25 -0800

That's a good suggestion.  I moved it.  Then it is more likely to be seen.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#issuecomment-729297044

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 18 Nov 2020 18:04:30 -0800

@janaiyengar approved this pull request.

Thanks for the new text, @martinthomson -- this is good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#pullrequestreview-534024889

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 18 Nov 2020 18:04:52 -0800

Merged #4359 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4359#event-4013612071