Subject: [quicwg/base-drafts] Cross-protocol attacks are maybe possible (#4427)

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 00:35:54 -0800

Mostly because QUIC doesn&#39;t prevent all forms of request forgery.
Thankfully, this is dealt with in detail in the transport draft.

Closes #4364.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4427

-- Commit Summary --

  * Cross-protocol attacks are maybe possible

-- File Changes --

    M draft-ietf-quic-http.md (11)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4427.patch
https://github.com/quicwg/base-drafts/pull/4427.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 07:34:19 -0800

@MikeBishop approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#pullrequestreview-547350877

---

From: ianswett <[email-masked]>
Date: Tue, 08 Dec 2020 10:16:45 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#pullrequestreview-547502173

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 13:39:33 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#pullrequestreview-547654350

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 13:43:59 -0800

@martinthomson: this looks good. Can you also change one sentence in Sec 1.2, from:
`offering comparable security to running TLS over TCP`
to
`offering comparable confidentiality and integrity to running TLS over TCP`.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#issuecomment-741081010

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 14:45:23 -0800

@martinthomson pushed 1 commit.

7d260ad9edefd4d0b84f5d162511f0ef4cd04e18  Update intro bits for confidentiality/integrity

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427/files/406b63609d3bf7cc032002a94ec4cb8e4453af60..7d260ad9edefd4d0b84f5d162511f0ef4cd04e18

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 15:05:57 -0800

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#pullrequestreview-547707229

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 15:31:48 -0800

Merged #4427 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4427#event-4087229334