Subject: [quicwg/base-drafts] Consistency tweak to persistent congestion definition (#4437)

From: Jana Iyengar <[email-masked]>
Date: Sun, 13 Dec 2020 00:19:15 -0800

Persistent congestion means that no packets between two ack-eliciting packets was received by the peer. This was codified as all packets between those boundary packets being lost.

However, non-ack-eliciting packets are not marked as lost. What we really want to say is that none of the packets between these boundary packets were acknowledged. This PR makes this change.

Note that the example below the definition already follows this; packets in between the boundary packets are noted as &quot;not acknowledged&quot; rather than marked as lost.

(First noted in this comment on #4434: https://github.com/quicwg/base-drafts/pull/4434#issuecomment-742966423)

You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4437

-- Commit Summary --

  * not acked

-- File Changes --

    M draft-ietf-quic-recovery.md (4)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4437.patch
https://github.com/quicwg/base-drafts/pull/4437.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4437

---

From: ianswett <[email-masked]>
Date: Sun, 13 Dec 2020 07:01:01 -0800

@ianswett approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4437#pullrequestreview-550928829

---

From: ianswett <[email-masked]>
Date: Sun, 13 Dec 2020 07:01:33 -0800

Merged #4437 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4437#event-4106102854