Subject: Re: [quicwg/base-drafts] handling of KeyUpdate in other epochs are specified in RFC 8446, do not override (#4412)

From: Jana Iyengar <[email-masked]>
Date: Tue, 01 Dec 2020 15:45:54 -0800

@janaiyengar approved this pull request.

This LGTM. I would consider this an editorial change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4412#pullrequestreview-542389705

---

From: Martin Thomson <[email-masked]>
Date: Mon, 07 Dec 2020 01:59:31 -0800

@martinthomson approved this pull request.

>  TLS KeyUpdate message.  Endpoints MUST treat the receipt of a TLS KeyUpdate
-message as a connection error of type 0x10a, equivalent to a fatal TLS alert of
-unexpected_message (see {{tls-errors}}).
+message in a 1-RTT packet as a connection error of type 0x10a, equivalent to a
+fatal TLS alert of unexpected_message (see {{tls-errors}}).

```suggestion
fatal TLS alert of unexpected_message; see {{tls-errors}}.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4412#pullrequestreview-545990760

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 15:26:10 -0800

@martinthomson pushed 1 commit.

ad95f6930b9431d309d25d4f36aad5e580a929d5  semi

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4412/files/b33c48762efdd88170eebed13272bc14278495a1..ad95f6930b9431d309d25d4f36aad5e580a929d5

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 15:26:18 -0800

Merged #4412 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4412#event-4087215953