Subject: [quicwg/base-drafts] Don't DoS the IANA registry server (#4428)

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 08:19:11 -0800

IANA&#39;s review wanted to know whether the 148 quadrillion GREASE values should be listed on the registry page as Reserved, and what note should be present if not.

They should not, lest it be challenging to actually download the registry page within the lifetime of the human race.  This rewords the restriction and clarifies that the restriction should be the note.

Fixes #4372.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4428

-- Commit Summary --

  * Don&#39;t DoS the IANA registry page

-- File Changes --

    M draft-ietf-quic-http.md (33)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4428.patch
https://github.com/quicwg/base-drafts/pull/4428.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 13:49:07 -0800

@MikeBishop: Can you add the same text to 22.2 (Transport parameter registry) in the transport doc as well?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428#issuecomment-741087353

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 14:48:20 -0800

@martinthomson requested changes on this pull request.

Please don't add notes to the registries.  There are lots of things to note about the registration rules; calling this specific rule out implies that understanding this is sufficient.  It also puts information about greased codepoints in a very easily accessible place, which runs counter to our goals.

> +
+The previous paragraph will be included as a note on the IANA registry page.

```suggestion
```

> +
+The previous paragraph will be included as a note on the IANA registry page.

```suggestion
```

> +
+The previous paragraph will be included as a note on the IANA registry page.

```suggestion
```

> +
+The previous paragraph will be included as a note on the IANA registry page.

```suggestion
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428#pullrequestreview-547696811

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 15:03:06 -0800

@MikeBishop pushed 1 commit.

ecc97ab525507dce039ba5c41555c791dd16673b  No notes.

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428/files/f6dc7c1c98be8ae78bbb48fe140d92c58066dff0..ecc97ab525507dce039ba5c41555c791dd16673b

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 15:23:07 -0800

6ca971a4abe7b7399c69dcb2f446d4a3a932195a  Transport, too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428/files/ecc97ab525507dce039ba5c41555c791dd16673b..6ca971a4abe7b7399c69dcb2f446d4a3a932195a

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 15:24:11 -0800

c296888f356d62aba2f97256e2098d2b62ad10d2  Transport, too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428/files/6ca971a4abe7b7399c69dcb2f446d4a3a932195a..c296888f356d62aba2f97256e2098d2b62ad10d2

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 15:37:04 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428#pullrequestreview-547723733

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 15:38:22 -0800

@martinthomson approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428#pullrequestreview-547724326

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 15:38:29 -0800

Merged #4428 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4428#event-4087246009