Subject: [quicwg/base-drafts] http: update terminology and ref for new http core drafts (#4442)

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2020 04:34:58 -0800

note: &quot;payload body&quot; -&gt; &quot;payload data&quot;
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4442

-- Commit Summary --

  * http: update terminology and ref for new http core drafts

-- File Changes --

    M draft-ietf-quic-http.md (54)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4442.patch
https://github.com/quicwg/base-drafts/pull/4442.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Dec 2020 07:33:28 -0800

@MikeBishop approved this pull request.

This looks fine.  Basically all the suggested changes revolve around the fact that "a payload body" works but "a payload data" doesn't.

> @@ -497,8 +497,8 @@ The "chunked" transfer encoding defined in Section 7.1 of {{?HTTP11}} MUST NOT
 be used.
 
 A response MAY consist of multiple messages when and only when one or more
-interim responses (1xx; see Section 14.2 of {{!SEMANTICS}}) precede a final
-response to the same request.  Interim responses do not contain a payload body
+interim responses (1xx; see Section 15.2 of {{!SEMANTICS}}) precede a final
+response to the same request.  Interim responses do not contain a payload data

```suggestion
response to the same request.  Interim responses do not contain payload data
```

> @@ -744,11 +744,11 @@ frames but is invalid due to:
 - the inclusion of uppercase field names, or
 - the inclusion of invalid characters in field names or values
 
-A request or response that includes a payload body can include a
+A request or response that includes a payload data can include a

```suggestion
A request or response that includes payload data can include a
```

> @@ -744,11 +744,11 @@ frames but is invalid due to:
 - the inclusion of uppercase field names, or
 - the inclusion of invalid characters in field names or values
 
-A request or response that includes a payload body can include a
+A request or response that includes a payload data can include a
 Content-Length header field.  A request or response is also malformed if the
 value of a content-length header field does not equal the sum of the DATA frame
 payload lengths that form the body.  A response that is defined to have no

```suggestion
lengths that form the payload data.  A response that is defined to have no
```

> @@ -1289,7 +1289,7 @@ frame.
 ### DATA {#frame-data}
 
 DATA frames (type=0x0) convey arbitrary, variable-length sequences of bytes
-associated with an HTTP request or response payload body.
+associated with an HTTP request or response payload data.

```suggestion
associated with HTTP request or response payload data.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442#pullrequestreview-551476321

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Dec 2020 07:35:10 -0800

@MikeBishop pushed 1 commit.

aa253e43c441a22cc57e239b0b6d4a8da890b86e  Merge branch 'master' into patch-2

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/bc410979a7ec6c4bf8f639d4d4891c88c3a30f88..aa253e43c441a22cc57e239b0b6d4a8da890b86e

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2020 12:13:46 -0800

@reschke pushed 1 commit.

b03506eaf17752040307b1a9bc88b7625dbfbf07  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/aa253e43c441a22cc57e239b0b6d4a8da890b86e..b03506eaf17752040307b1a9bc88b7625dbfbf07

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2020 12:13:52 -0800

4c0e04f3401b72bf6b0e998cb6d5a6335c8c6385  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/b03506eaf17752040307b1a9bc88b7625dbfbf07..4c0e04f3401b72bf6b0e998cb6d5a6335c8c6385

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2020 12:14:02 -0800

5d0fceaf845ba6c6ae8b9eb02270735b8e4a0f6f  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/4c0e04f3401b72bf6b0e998cb6d5a6335c8c6385..5d0fceaf845ba6c6ae8b9eb02270735b8e4a0f6f

---

From: Julian Reschke <[email-masked]>
Date: Mon, 14 Dec 2020 12:14:13 -0800

623daabead44f48319be9894542d1ed0effc5eb3  Update draft-ietf-quic-http.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/5d0fceaf845ba6c6ae8b9eb02270735b8e4a0f6f..623daabead44f48319be9894542d1ed0effc5eb3

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Dec 2020 13:10:32 -0800

969a061d0ce1dd68e80040bdd410ac64992a0cef  Merge branch 'master' into patch-2

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442/files/623daabead44f48319be9894542d1ed0effc5eb3..969a061d0ce1dd68e80040bdd410ac64992a0cef

---

From: Mike Bishop <[email-masked]>
Date: Mon, 14 Dec 2020 13:11:38 -0800

Merged #4442 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4442#event-4111355594