Subject: Re: [quicwg/base-drafts] A zero-length connection ID is always good (#4335)

From: mirjak <[email-masked]>
Date: Tue, 01 Dec 2020 08:33:33 -0800

@mirjak commented on this pull request.

> @@ -1163,6 +1163,11 @@ SHOULD ensure that the pool of connection IDs available to its peer allows the
 peer to use a new connection ID on migration, as the peer will be unable to
 respond if the pool is exhausted.
 
+An endpoint that selects a zero-length connection ID during the handshake
+cannot issue a new connection ID.  A zero-length Destination Connection ID
+field is used in all packets sent toward such an endpoint over any network
+path.

Sorry I know this has been merged already but I thought this is easier than open a new issue. 

How can you use a connection with zero-length Conn ID over different paths? Does an address change without Conn ID mean that the connections breaks?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#pullrequestreview-542082479

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 01 Dec 2020 16:31:39 -0800

@janaiyengar commented on this pull request.

The peer could still change its address, right?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#discussion_r533814181

---

From: mirjak <[email-masked]>
Date: Wed, 02 Dec 2020 02:16:13 -0800

If you have changed the address and don't have a conn ID, you cannot associate the packet to an existing connection anymore, no?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#discussion_r534049934

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 02 Dec 2020 20:16:29 -0800

I see your point. You can still associate it in theory, though it might be fragile - this is left to the implementation ultimately. I agree with you that the "over any network path" is mostly redundant, but I am not sure that it hurts because I don't think it suggests something that is impossible.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#discussion_r534655634

---

From: mirjak <[email-masked]>
Date: Fri, 04 Dec 2020 02:45:20 -0800

You are right it's not really incorrect , I just found it confusing giving potentially the impression that using multiple paths without CID is "easily" possible. How about this phrasing to be even more clear:

"A zero-length Destination Connection ID
field is used in all packets sent toward such an endpoint and this cannot be changed even if the network
path changes."

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4335#issuecomment-738712417