Subject: Re: [quicwg/base-drafts] Minor update to Persistent Congestion (#4414)

From: mirjak <[email-masked]>
Date: Tue, 01 Dec 2020 07:48:51 -0800

I understood the text as saying that you can probably assume that all packets (including non-ack-eliciting ones) got lost when you don't hear anything back for a while... Also if you receive a packet that only ACKs non-ack-eliciting packets this would be weird but it probably means there is not persistent congestion because you know something went though. 

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-736638733

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 01 Dec 2020 16:27:54 -0800

This is good. The problem with non-ack-eliciting packets is that a sender cannot infer anything about network conditions when it isn't expecting an ack. Meaning that the receiver could have received everything and simply not responded if none of those packets are ack-eliciting.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-736907140

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 01 Dec 2020 16:28:03 -0800

@janaiyengar approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#pullrequestreview-542406837

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 01 Dec 2020 16:28:09 -0800

Merged #4414 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#event-4059834493

---

From: mirjak <[email-masked]>
Date: Wed, 02 Dec 2020 02:14:20 -0800

@Jana, yes, you don't know anything when you don't received an ACK. However, you may still received an ACK for non-ACK-eliciting packet (as that is not forbidden) and then you do know something that you should not ignore. The text is unclear about that. Maybe adding another sentence is the right thing to do.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-737131932

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 02 Dec 2020 20:39:32 -0800

@mirjak: I'm not sure I follow. If a sender receives an ack for a non-ack-eliciting packet, that only establishes its receipt. I don't understand how what you are saying is a problem with this text.

That said, I do think this text incorrectly depicts the actual mechanism below, so I've written #4420.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-737660833

---

From: Mike Bishop <[email-masked]>
Date: Tue, 08 Dec 2020 13:48:22 -0800

@janaiyengar, I think you're saying the same thing.  The text as currently written suggests that:

- Send an ack-eliciting packet
- Send 100 non-ack-eliciting packets
- Send another ack-eliciting packet
- Receive an ack for the 100 non-ack-eliciting packets

If persistent congestion is the loss of all packets in that time frame, this isn't persistent congestion.  If persistent congestion is the loss of all *ack-eliciting* packets in that time frame, this is.  The change in the follow-up PRs brings it back to what I think was originally intended.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-741086325

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 08 Dec 2020 15:11:12 -0800

@MikeBishop : But we do want loss of non-ack-eliciting packets to count towards persistent congestion; they aren't special in terms of loss, they're just special in terms of eliciting an ack. Which is why we only care about the "edge packets" being ack-eliciting.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4414#issuecomment-741197789