Subject: [quicwg/base-drafts] ShortHeaderPacket does not indicate the ConnectionId length (#4422)

From: Chris Dimitrov <[email-masked]>
Date: Thu, 03 Dec 2020 04:35:04 -0800

Hello,

reading draft-32 we can notice the structure of the ShortHeaderPacket

```
Short Header Packet {
     Header Form (1) = 0,
     Fixed Bit (1) = 1,
     Spin Bit (1),
     Reserved Bits (2),
     Key Phase (1),
     Packet Number Length (2),
     Destination Connection ID (0..160),
     Packet Number (8..32),
     Packet Payload (..),
}
```

The `Destination Connection ID (0..160)` does not have a preceding `Destination Connection ID Length (8)`. In this case, we wouldn't know how many bytes does the connection ID occupies.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4422

---

From: Lars Eggert <[email-masked]>
Date: Thu, 03 Dec 2020 04:38:58 -0800

This is discussed in [Section 5.1](https://tools.ietf.org/html/draft-ietf-quic-transport-32#section-5.1):
> Packets with short headers (Section 17.3) only include the
   Destination Connection ID and omit the explicit length.  The length
   of the Destination Connection ID field is expected to be known to
   endpoints. 

Your endpoint will need to remember the length chosen for a connection.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4422#issuecomment-737929695

---

From: Chris Dimitrov <[email-masked]>
Date: Thu, 03 Dec 2020 23:08:12 -0800

Thank you @larseggert !

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4422#issuecomment-738609916

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 Dec 2020 00:28:19 -0800

Closed #4422.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4422#event-4071559386