Subject: [quicwg/base-drafts] Martin Duke Transport Comment 8 (#4457)

From: Lucas Pardue <[email-masked]>
Date: Tue, 22 Dec 2020 10:05:55 -0800

@martinduke said:

>14 "Thus, modern IPv4 and all IPv6 network paths will be able to support QUIC."
Generally true, but should be qualified for the presence of arbitrary numbers
of tunnels.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4457

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Dec 2020 13:26:14 -0800

This is not one that I have an answer to currently.  We could just wave this away as Martin suggests, but I'm not sure that is best.  What do tunneling protocols say about ensuring the IPv6 minimum MTU?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4457#issuecomment-749783341

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 22 Dec 2020 14:29:23 -0800

I don't know what the IETF tunneling protocols say about MTU, but I don't expect them to violate IPv6 minimum MTU (someone should correct me if I'm wrong). The problem here might not be about what allowances we make for tunneling -- I don't want to create a list of exceptions in this document -- but about wording.

I propose changing "will be able to support" to "are expected to support".

As long as we are not making assumptions that violate permissions afforded by spec or practice, I think we're good.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4457#issuecomment-749809251

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Dec 2020 14:47:38 -0800

Closed #4457 via #4461.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4457#event-4142020588