Subject: [quicwg/base-drafts] Define pseudo-code of header protection using packet number offset (#4436)

From: Kazuho Oku <[email-masked]>
Date: Thu, 10 Dec 2020 19:13:20 -0800

Changes the pseudo-code of header protection to use `packet_number_offset`, because that value would be known to the QUIC stack by the time it tries to obtain the header protection sample.

Existing pseudo code includes the logic necessary for skipping entire packet header, which is a distraction to the readers.

Closes #4435.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4436

-- Commit Summary --

  * header protection is relative to packet number offset; rest of header parsing logic is purely informative

-- File Changes --

    M draft-ietf-quic-tls.md (36)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4436.patch
https://github.com/quicwg/base-drafts/pull/4436.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436

---

From: Jana Iyengar <[email-masked]>
Date: Thu, 10 Dec 2020 20:19:40 -0800

@janaiyengar approved this pull request.

I like this clarification -- it's much easier to follow.

 ~~~
-sample_offset = 1 + len(connection_id) + 4
+sample_offset = packet_number_offset + 4

```suggestion
# pn_offset is the start of the Packet Number field.
sample_offset = pn_offset + 4
```

We already use `pn_offset` in the header protection section above.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436#pullrequestreview-549791118

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 10 Dec 2020 20:29:29 -0800

@kazuho pushed 1 commit.

fd01f88ffa0475cea327fe0d3579b719937f5403  s/packet_number_offset/pn_offset/g, with clarification

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436/files/69387b3995bc5b28b030d176c3402500b428dfb9..fd01f88ffa0475cea327fe0d3579b719937f5403

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 10 Dec 2020 20:30:18 -0800

@kazuho commented on this pull request.

 ~~~

Thank you for the suggestion. Applied as part of fd01f88.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436#discussion_r540682739

---

From: Martin Thomson <[email-masked]>
Date: Thu, 10 Dec 2020 22:06:49 -0800

@martinthomson approved this pull request.

I like this.  Thanks @kazuho.

> +Note that multiple QUIC packets might be included in the same UDP datagram and
+that each one is handled separately.

```suggestion
Multiple QUIC packets might be included in the same UDP datagram. Each packet
is handled separately.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436#pullrequestreview-549823076

---

From: Kazuho Oku <[email-masked]>
Date: Thu, 10 Dec 2020 22:29:39 -0800

@kazuho pushed 1 commit.

7048d50e6b866a4feeed6b6b2fe029377d86e88a  Update draft-ietf-quic-tls.md

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436/files/fd01f88ffa0475cea327fe0d3579b719937f5403..7048d50e6b866a4feeed6b6b2fe029377d86e88a

---

From: Martin Thomson <[email-masked]>
Date: Fri, 11 Dec 2020 00:54:52 -0800

Merged #4436 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4436#event-4099241992