Subject: [quicwg/base-drafts] Martin Duke Transport Comment 3 (#4451)

From: Lucas Pardue <[email-masked]>
Date: Tue, 22 Dec 2020 10:00:55 -0800

@martinduke said:

> 22 I am unclear about the status of these registries (except the version
> registry) for new versions. QUICv2 might have entirely new frame, TP, and error
> registries, right? Is it worthwhile to point that out? Or that it's heavily
> discouraged, or forbidden?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4451

---

From: Martin Thomson <[email-masked]>
Date: Tue, 22 Dec 2020 13:28:58 -0800

I suggest we do nothing here.  Yes, we could preempt a version 2 and that these registries are for any QUIC version that signs on, but that is already true without saying anything at all.  And I would oppose saying that these are exclusively QUIC version 1, because that might not be true.

Let future versions of us deal with this issue without encumbering them with preconceptions.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4451#issuecomment-749784268

---

From: martinduke <[email-masked]>
Date: Tue, 22 Dec 2020 13:34:38 -0800

I am comfortable with @martinthomson 's suggestion if that is the consensus and there is no intention from the authors of what future versions should do. (I definitely agree that we should not put a MUST here).

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4451#issuecomment-749786169

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 22 Dec 2020 14:21:04 -0800

I agree with @martinthomson -- nothing in there prohibits future versions from either using the same or defining a new registry.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4451#issuecomment-749805736

---

From: martinduke <[email-masked]>
Date: Tue, 22 Dec 2020 14:24:03 -0800

good enough to close this, unless the editors want to hear from anyone else.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4451#issuecomment-749806961