Subject: Re: [quicwg/base-drafts] IANA review of -transport; question 2 (#4377)

From: Lars Eggert <[email-masked]>
Date: Fri, 04 Dec 2020 06:13:17 -0800

Closed #4377.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#event-4072872077

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 Dec 2020 06:13:17 -0800

@MikeBishop replied to IANA [by email](https://mailarchive.ietf.org/arch/msg/quic/ZXhbtZ-0BBjPKkGMQwUcIAS8gpE). Closing this issue.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#issuecomment-738805651

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 Dec 2020 06:13:45 -0800

Or wait, @MikeBishop replied for -tls. Did anyone reply yet for -transport. (Reopening.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#issuecomment-738805900

---

From: Lars Eggert <[email-masked]>
Date: Fri, 04 Dec 2020 06:13:45 -0800

Reopened #4377.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#event-4072874120

---

From: Jana Iyengar <[email-masked]>
Date: Mon, 07 Dec 2020 22:24:53 -0800

Response here should be the same as #4372. I'll write out the response here, so we can agree on the responses to all their questions; one of us can then collate them and send them to IANA in a single email. Response as follows:

```
With regard to the GREASE values (the questions below), we specifically did not want the values shown as Reserved for two
different reasons. First, as a practical matter, 148 quadrillion reserved entries would be difficult to list on the page and will
drown any actual reservations. Second, the point of these values is that an implementer should be following the guidance to
ignore unknown values; having an explicit list encourages an explicitly defined reaction.

The intent, which we wanted to confirm was possible, was simply to say that IANA should not accept registrations for these
values. That feels functionally equivalent to Reserved; if it's possible to be "reserved but not listed," that's a reasonable
implementation. If it's necessary to have the note present, we prefer the "will not be assigned by IANA" language you've used
for the Error Code registry over noting them as Reserved.
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#issuecomment-740408086

---

From: Martin Thomson <[email-masked]>
Date: Tue, 08 Dec 2020 23:39:04 +0000 (UTC)

Closed #4377.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/issues/4377#event-4087247445