Subject: [quicwg/base-drafts] It is spelled 'acknowledgement' (#4445)

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Dec 2020 16:15:21 -0800

Closes #4440.
You can view, comment on, or merge this pull request online at:

  https://github.com/quicwg/base-drafts/pull/4445

-- Commit Summary --

  * It is spelled &#39;acknowledgement&#39;

-- File Changes --

    M draft-ietf-quic-http.md (2)
    M draft-ietf-quic-qpack.md (12)
    M draft-ietf-quic-recovery.md (94)
    M draft-ietf-quic-tls.md (24)
    M draft-ietf-quic-transport.md (54)

-- Patch Links --

https://github.com/quicwg/base-drafts/pull/4445.patch
https://github.com/quicwg/base-drafts/pull/4445.diff

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445

---

From: MikkelFJ <[email-masked]>
Date: Tue, 15 Dec 2020 16:19:50 -0800

Do I read this wrong, or did you go for acknowledgment contrary to the topic header?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-745668185

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Dec 2020 16:28:58 -0800

I was trained on something approximating British English, which generally uses the longer form.  The title is a statement of (subjective) truth with no actual bearing on the changes.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-745681499

---

From: MikkelFJ <[email-masked]>
Date: Tue, 15 Dec 2020 16:38:26 -0800

In that case the capitalised (capitalized) version might also want to disagree with the topic header: "Acknowledgement", assuming that US spelling is somewhat consistent.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-745687172

---

From: ianswett <[email-masked]>
Date: Tue, 15 Dec 2020 16:58:24 -0800

@ianswett approved this pull request.

So it is

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553213717

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 15 Dec 2020 17:20:03 -0800

@janaiyengar approved this pull request.

Is it though? :-)

I'm fine with either, and I actually prefer the shorter one, but your issue title suggests the opposite change.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553242957

---

From: MikkelFJ <[email-masked]>
Date: Tue, 15 Dec 2020 17:20:25 -0800

@mikkelfj commented on this pull request.

> @@ -343,7 +343,7 @@ Count in order to identify which dynamic table entries can be referenced without
 potentially blocking a stream.  The decoder tracks the Known Received Count in
 order to be able to send Insert Count Increment instructions.
 
-A Section Acknowledgement instruction ({{header-acknowledgement}}) implies that
+A Section Acknowledgement instruction ({{header-acknowledgment}}) implies that

```suggestion
A Section Acknowledgment instruction ({{header-acknowledgment}}) implies that
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553243567

---

From: MikkelFJ <[email-masked]>
Date: Tue, 15 Dec 2020 17:24:51 -0800

There are other places with uppercase, but that needs a search, e.g. https://github.com/quicwg/base-drafts/blob/1fa5d4958609a9c1eb6ed2d94d16415476428b6e/draft-ietf-quic-http.md#acknowledgements

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-745702571

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Dec 2020 17:36:53 -0800

@martinthomson pushed 1 commit.

1cb4b0dd0b1e6d2b6b1142c7d17dd97ea91b13f3  Catch the capitalized ones too

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445/files/1fa5d4958609a9c1eb6ed2d94d16415476428b6e..1cb4b0dd0b1e6d2b6b1142c7d17dd97ea91b13f3

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Dec 2020 17:37:13 -0800

Someone should learn to drive sed better.  I've fixed the uppercase variants as well.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-745706697

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 15 Dec 2020 20:22:12 -0800

@janaiyengar commented on this pull request.

> @@ -1041,17 +1041,17 @@ Consider the following sequence of events:
 |:-------|:---------------------------|
 | t=0    | Send packet #1 (app data)  |
 | t=1    | Send packet #2 (app data)  |
-| t=1.2  | Recv acknowledgement of #1 |
+| t=1.2  | Recv acknowledgment of #1 |

```suggestion
| t=1.2  | Recv acknowledgment of #1  |
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553346505

---

From: Jana Iyengar <[email-masked]>
Date: Tue, 15 Dec 2020 20:23:23 -0800

couple of formatting ones, but otherwise lgtm.

>  | t=2    | Send packet #3 (app data)  |
 | t=3    | Send packet #4 (app data)  |
 | t=4    | Send packet #5 (app data)  |
 | t=5    | Send packet #6 (app data)  |
 | t=6    | Send packet #7 (app data)  |
 | t=8    | Send packet #8 (PTO 1)     |
 | t=12   | Send packet #9 (PTO 2)     |
-| t=12.2 | Recv acknowledgement of #9 |
+| t=12.2 | Recv acknowledgment of #9 |

```suggestion
| t=12.2 | Recv acknowledgment of #9  |
```

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553346557

---

From: Martin Thomson <[email-masked]>
Date: Tue, 15 Dec 2020 23:04:41 -0800

1e983d4c3efd2346f5e6cae9a5f4ab2dbf16f142  Bah, tables

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445/files/1cb4b0dd0b1e6d2b6b1142c7d17dd97ea91b13f3..1e983d4c3efd2346f5e6cae9a5f4ab2dbf16f142

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Dec 2020 03:08:57 -0800

@MikeBishop approved this pull request.

Now I know why we used "ack" so much -- to avoid deciding which way to spell this.

> @@ -64,7 +64,7 @@ normative:
 informative:
 
   FACK:
-    title: "Forward Acknowledgement: Refining TCP Congestion Control"
+    title: "Forward Acknowledgment: Refining TCP Congestion Control"

Is the title of this paper in fact different from what we had in the text?

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-553579515

---

From: ianswett <[email-masked]>
Date: Wed, 16 Dec 2020 04:17:55 -0800

> Now I know why we used "ack" so much -- to avoid deciding which way to spell this.

No kidding, and acknowledgement is pretty long.  I wonder if we should just define 'ack' as acknowledgement at the beginning.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-746202981

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Dec 2020 07:10:16 -0800

As "acknowledgment," you mean.  😉  I prefer it with the 'e', but without is technically the American spelling.  (Although what I found said both occur everywhere; the only difference is which is more prevalent.)

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-746444725

---

From: Mike Bishop <[email-masked]>
Date: Wed, 16 Dec 2020 07:11:29 -0800

@MikeBishop commented on this pull request.

 informative:
 
   FACK:

However, they use "Acknowledgment" without the 'e' in the abstract.  Yeesh.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#discussion_r544376771

---

From: Jana Iyengar <[email-masked]>
Date: Wed, 16 Dec 2020 14:13:39 -0800

@janaiyengar pushed 1 commit.

99ceeba68f11e3ab625a5cccbb9f307285e626e0  one more table

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445/files/1e983d4c3efd2346f5e6cae9a5f4ab2dbf16f142..99ceeba68f11e3ab625a5cccbb9f307285e626e0

---

From: MikkelFJ <[email-masked]>
Date: Wed, 16 Dec 2020 14:19:46 -0800

> one more table

The gift that keeps on giving ...

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#issuecomment-747074867

---

From: Martin Thomson <[email-masked]>
Date: Wed, 16 Dec 2020 17:13:07 -0800

9624201c65e6b47aee4bfd121b3af1facf9a8fa8  Don't change paper names

-- 
You are receiving this because you are subscribed to this thread.
View it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445/files/99ceeba68f11e3ab625a5cccbb9f307285e626e0..9624201c65e6b47aee4bfd121b3af1facf9a8fa8

---

From: afrind <[email-masked]>
Date: Fri, 18 Dec 2020 09:04:32 -0800

@afrind approved this pull request.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#pullrequestreview-555661154

---

From: Jana Iyengar <[email-masked]>
Date: Sat, 19 Dec 2020 02:16:35 +0000 (UTC)

Merged #4445 into master.

-- 
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/quicwg/base-drafts/pull/4445#event-4132040829